ArtOfTest.WebAii.BrowserSpecialized.AspNetHost Namespace

ArtOfTest, Inc. - WebAii 1.1 Automation Infrastructure reference library
ArtOfTest.WebAii.BrowserSpecialized.AspNetHost Namespace
Namespaces > ArtOfTest.WebAii.BrowserSpecialized.AspNetHost
Syntax
C#
namespace ArtOfTest.WebAii.BrowserSpecialized.AspNetHost
Types
All Types Classes Structures Interfaces Enumerations Delegates
Icon | Type | Description
public class | AspNetHostActions | Implements automation actions for the AspNetHost browser.
public class | AspNetHostBrowser | A proxy that represents a browser object for the AspNetHost inproc web server.
Copyright (c) 2008 - ArtOfTest, Inc.


AspNetHostActions class

AspNetHostActions class
Namespaces > ArtOfTest.WebAii.BrowserSpecialized.AspNetHost > AspNetHostActions
Implements automation actions for the AspNetHost browser.
Syntax
C#
public class AspNetHostActions : Actions
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AnnotateElement(Element, String) | Visually annotates an element on the browser surface. (Inherited from Actions.)
 | AnnotateMessage(String) | Visually annotate a message on the browser surface. (Inherited from Actions.)
 | Browser | Gets the Browser object associated with this instance of the actions object. (Inherited from Actions.)
 | Check(Element, Boolean) | Check an element or a radio button. (Overrides Actions.Check(Element, Boolean).)
 | Click(Element) | Click an element. (Overrides Actions.Click(Element).)
 | DoAction(AspNetForm) | Perform the form postback.
 | DoSelectDropDown(Element, String) | Select an item in a drop down. (Overrides Actions.DoSelectDropDown(Element, String).)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetComputedStyle(Element, String) | Unsupported - There is no concept of current styles for AspNetHost (Overrides Actions.GetComputedStyle(Element, String).)
 | GetHashCode() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType() | Gets the Type of the current instance. (Inherited from Object.)
 | InvokeEvent(Element, ScriptEventType) | Unsupported - There is no javascript engine running for this browser. (Overrides Actions.InvokeEvent(Element, ScriptEventType).)
 | InvokeScript(String) | Unsupported - There is no javascript engine running for this browser. (Overrides Actions.InvokeScript(String).)
 | MemberwiseClone() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ScrollToVisible(Element) | Unsupported - Does not apply for this browser. (Overrides Actions.ScrollToVisible(Element).)
 | ScrollToVisible(Element, ScrollToVisibleType) | Ensures that an item is visible in the browser. Scrolls it into view. (Inherited from Actions.)
 | SelectDropDown(Element, Int32) | Selects a drop down item from the drop down list using its index. (Inherited from Actions.)
 | SelectDropDown(Element, String) | Selects a drop down item from the drop down list using the item's text. (Inherited from Actions.)
 | SelectDropDown(Element, String, Boolean) | Selects a drop down item from the drop down list using the item's text or the items option value (if useItemValue = true). (Inherited from Actions.)
 | SetText(Element, String) | Set the text for a target element. (Overrides Actions.SetText(Element, String).)
 | ToString() | Returns a String that represents the current Object. (Inherited from Object.)
 | ValidateTargetElement(Element) | Validates the target element. (Inherited from Actions.)
 | WaitCheckInterval | The Settings.WaitCheckInterval value. You can get/set it here too. (Inherited from Actions.)
 | WaitForElement(FindParam, Int32) | Wait until an element is present in the DOM (Inherited from Actions.)
 | WaitForElement(FindParam, Int32, Boolean) | Wait until an element is present in the DOM (Inherited from Actions.)
 | WaitForElement(FindParam, TestRegion, Int32, Boolean) | Wait until an element within a region is present in the DOM. (Inherited from Actions.)
 | WaitForElement(FindParam[](), Int32) | Wait until an element is present in the DOM (Inherited from Actions.)
 | WaitForElement(FindParam[](), Int32, Boolean) | Wait until an element is present in the DOM (Inherited from Actions.)
 | WaitForElement(FindParam[](), TestRegion, Int32, Boolean) | Wait until an element within a region is present in the DOM. (Inherited from Actions.)
 | WaitForElements(Int32, Boolean, FindParam[]()) | Wait until all elements have been found. No chaining is used. (Inherited from Actions.)
 | WaitForElements(Int32, FindParam[]()) | Wait until all elements have been found. No chaining is used. (Inherited from Actions.)
 | WaitForElements(Int32, TestRegion, Boolean, FindParam[]()) | Wait until all elements have been found. No chaining is used. (Inherited from Actions.)
Inheritance Hierarchy
Object
 | Actions
 |  | AspNetHostActions

Assembly: ArtOfTest.WebAii (Module: ArtOfTest.WebAii)


Check(targetElement, checkedState) method

AspNetHostActions.Check(targetElement, checkedState) method
Namespaces > ArtOfTest.WebAii.BrowserSpecialized.AspNetHost > AspNetHostActions > Check(Element, Boolean)
Check an element or a radio button.
Syntax
C#
public override void Check (
    Element targetElement,
    bool checkedState
)
Parameters
targetElement (Element)
The target to check.
checkedState (Boolean)
The check state to set it to.


Click(targetElement) method

AspNetHostActions.Click(targetElement) method
Namespaces > ArtOfTest.WebAii.BrowserSpecialized.AspNetHost > AspNetHostActions > Click(Element)
Click an element.
Syntax
C#
public override void Click (
    Element targetElement
)
Parameters
targetElement (Element)
The target element.


DoAction(form) method

AspNetHostActions.DoAction(form) method
Namespaces > ArtOfTest.WebAii.BrowserSpecialized.AspNetHost > AspNetHostActions > DoAction(AspNetForm)
Perform the form postback.
Syntax
C#
public void DoAction (
    AspNetForm form
)
Parameters
form (AspNetForm)
The form to post.


DoSelectDropDown(targetElement, data) method

AspNetHostActions.DoSelectDropDown(targetElement, data) method
Namespaces > ArtOfTest.WebAii.BrowserSpecialized.AspNetHost > AspNetHostActions > DoSelectDropDown(Element, String)
Select an item in a drop down.
Syntax
C#
protected override void DoSelectDropDown (
    Element targetElement,
    string data
)
Parameters
targetElement (Element)
The target element.
data (String)
The item to select and how to select it.


GetComputedStyle(targetElement, style) method

AspNetHostActions.GetComputedStyle(targetElement, style) method
Namespaces > ArtOfTest.WebAii.BrowserSpecialized.AspNetHost > AspNetHostActions > GetComputedStyle(Element, String)
Unsupported - There is no concept of current styles for AspNetHost
Syntax
C#
public override string GetComputedStyle (
    Element targetElement,
    string style
)
Parameters
targetElement (Element)
The target element.
style (String)
The style.
Return Value
N/A - UnsupportedBrowserOperationException.


InvokeEvent(targetElement, eventType) method

AspNetHostActions.InvokeEvent(targetElement, eventType) method
Namespaces > ArtOfTest.WebAii.BrowserSpecialized.AspNetHost > AspNetHostActions > InvokeEvent(Element, ScriptEventType)
Unsupported - There is no javascript engine running for this browser.
Syntax
C#
public override void InvokeEvent (
    Element targetElement,
    ScriptEventType eventType
)
Parameters
targetElement (Element)
The target element.
eventType (ScriptEventType)
The event type.


InvokeScript(script) method

AspNetHostActions.InvokeScript(script) method
Namespaces > ArtOfTest.WebAii.BrowserSpecialized.AspNetHost > AspNetHostActions > InvokeScript(String)
Unsupported - There is no javascript engine running for this browser.
Syntax
C#
public override string InvokeScript (
    string script
)
Parameters
script (String)
The script to call.
Return Value
N/A - UnsupportedBrowserOperationException.


ScrollToVisible(targetElement) method

AspNetHostActions.ScrollToVisible(targetElement) method
Namespaces > ArtOfTest.WebAii.BrowserSpecialized.AspNetHost > AspNetHostActions > ScrollToVisible(Element)
Unsupported - Does not apply for this browser.
Syntax
C#
public override void ScrollToVisible (
    Element targetElement
)
Parameters
targetElement (Element)
Target element.


SetText(targetElement, text) method

AspNetHostActions.SetText(targetElement, text) method
Namespaces > ArtOfTest.WebAii.BrowserSpecialized.AspNetHost > AspNetHostActions > SetText(Element, String)
Set the text for a target element.
Syntax
C#
public override void SetText (
    Element targetElement,
    string text
)
Parameters
targetElement (Element)
The target element to set the text for.
text (String)
The text to set.


AspNetHostBrowser class

AspNetHostBrowser class
Namespaces > ArtOfTest.WebAii.BrowserSpecialized.AspNetHost > AspNetHostBrowser
A proxy that represents a browser object for the AspNetHost inproc web server.
Syntax
C#
public class AspNetHostBrowser : Browser
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Actions | Gets the Actions object that can be used to perform different actions against the loaded document in the browser. (Inherited from Browser.)
 | AfterCommandExecuted | Event occurs after the command is executed and the response is available. (Inherited from Browser.)
 | Annotator | Gets the Annotator object associated with this browser. (Inherited from Browser.)
 | AspNetAppInstance | The AspNetApplication instance that all requests are running against.
 | AutoDomRefresh | Gets/Sets whether to automatically refresh the DOM tree after each browser command. (Inherited from Browser.)
 | AutoWaitUntilReady | Gets/Sets whether to automatically wait until browser is ready after each browser command. (Inherited from Browser.)
 | BeforeCommandExecuted | Event occurs before a command is pushed to the browser. (Inherited from Browser.)
 | BrowserType | Gets the browser type (i.e. IE/FireFox ...etc) (Inherited from Browser.)
 | ClientId | The unique ID for this browser that the manager identifies it with. (Inherited from Browser.)
 | Close(Int32) | Close this browser. (Overrides Browser.Close(Int32).)
 | CommandTimeOut | Gets/Sets the max wait time in milliseconds that the browser will wait for a command to process before it times out. (Inherited from Browser.)
 | ContainsPoint(Point) | True/False whether a specific point falls within this browser/frame rendering region (Inherited from Browser.)
 | ContainsRectangle(Rectangle) | Unsupported - Browser is window-less. (Overrides Browser.ContainsRectangle(Rectangle).)
 | ContainsText(String) | True/False whether the 'text' is contained within the page currently loaded. Not case sensitive. (Inherited from Browser.)
 | ContentWindow | Unsupported - Browser is window-less. This will throw an UnsupportedBrowserOperation exception. (Overrides Browser.ContentWindow.)
 | Cookies | Gets the cookies manager associated with this browser that allows you to retrieve, delete and add cookies. (Inherited from Browser.)
 | DomHashCode | Gets the current DOM hash code (Inherited from Browser.)
 | DomRefreshed | Event occurs after the DomTree is rebuilt (either after a command is executed or when RefreshDom is called) (Inherited from Browser.)
 | DomTree | Gets the DOM Tree representation of the currently loaded document. (Inherited from Browser.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | ExecuteCommand(BrowserCommand) | Executes a command against this browser instance. (Inherited from Browser.)
 | ExecuteCommand(BrowserCommand, Boolean, Boolean) | Unsupported - All commands are executed in-proc. (Overrides Browser.ExecuteCommand(BrowserCommand, Boolean, Boolean).)
 | Finalize() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Find | Gets the Find objects used to provide a rich set of methods to help identify elements in the Dom tree associated with this browser object. (Inherited from Browser.)
 | FrameInfo | Gets the frame information if IsFrame = true else will return null. FrameInfo contains frame index and frame name. (Inherited from Browser.)
 | Frames | List of child frames contained in this instance (Inherited from Browser.)
 | GetForm() | Get the AspNetForm object.
 | GetHashCode() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetSelectedText() | Gets the text currently selected by the user in the browser window (Inherited from Browser.)
 | GetType() | Gets the Type of the current instance. (Inherited from Object.)
 | GoBack() | N/A - Call returns immediately. (Overrides Browser.GoBack().)
 | GoForward() | N/A - Call returns immediately. (Overrides Browser.GoForward().)
 | IsConnected | Whether the AspNetApplication is running and the host is registered. (Overrides Browser.IsConnected.)
 | IsFrame | Gets whether this instance represents a frame or not. (Inherited from Browser.)
 | IsIEDialog | Gets whether this instance is an IE dialog (Modal/Modeless) (Inherited from Browser.)
 | IsReady() | Always returns true for this browser. (Overrides Browser.IsReady().)
 | IsUILess | Whether this browser is UI less browser. (i.e. a raw http request/response browser) (Inherited from Browser.)
 | Manager | The manager of this browser object. (Inherited from Browser.)
 | MemberwiseClone() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NativeInstance | The native instance of this browser object (if available), otherwise null (Inherited from Browser.)
 | NavigateTo(String) | Navigate the browser to a specific url and then enable the script logging. (Inherited from Browser.)
 | NavigateTo(Uri) | Navigate to a certain relative Url. (Overrides Browser.NavigateTo(Uri).)
 | PageTitle | Gets the page title if one exists. (text content of the 'title' tags) (Inherited from Browser.)
 | PerformCustomPostAction(AspNetForm) | Performs a post action to the server as defined by the form passed in.
 | PrepareFrameForClosing() | Used to disable the AutoRefreshDom and WaitUntilReady of a frame preparing it to be closed on next action and no longer polled by the framework. (Inherited from Browser.)
 | QueryString | Gets a parsed name/value collection of the query string. (Inherited from Browser.)
 | Refresh() | N/A - Call returns immediately. (Overrides Browser.Refresh().)
 | RefreshDomTree() | Refresh the DomTree. (Overrides Browser.RefreshDomTree().)
 | Regions | Gets a dictionary of all identified test regions in the currently loaded document. (Inherited from Browser.)
 | ScrollBy(Int32, Int32) | Unsupported - Browser is window-less. (Overrides Browser.ScrollBy(Int32, Int32).)
 | Status | The response status code as of last response.
 | Stop() | N/A - Call returns immediately. (Overrides Browser.Stop().)
 | ToString() | Returns a String that represents the current Object. (Inherited from Object.)
 | UpdateDomTree(String) | Parse and update the DomTree (Inherited from Browser.)
 | Url | Gets the current page URL. This property is refreshed when calling RefreshDOMTree(). (Inherited from Browser.)
 | Version | The browser version for this browser type. (Inherited from Browser.)
 | ViewSourceString | Gets the source of the page currently loaded in the browser. This is the string that the framework used to build the DOM. (Inherited from Browser.)
 | WaitForUrl(String, Boolean, Int32) | Wait for a specific url to be set. This can be used to wait for browser redirects on certain sites. (Inherited from Browser.)
 | WaitUntilReady() | N/A - Call returns immediately. (Overrides Browser.WaitUntilReady().)
 | Window | Unsupported - Browser is window-less. (Overrides Browser.Window.)
Inheritance Hierarchy
Object
 | Browser
 |  | AspNetHostBrowser


AspNetAppInstance property

AspNetHostBrowser.AspNetAppInstance property
Namespaces > ArtOfTest.WebAii.BrowserSpecialized.AspNetHost > AspNetHostBrowser > AspNetAppInstance
The AspNetApplication instance that all requests are running against.
Syntax
C#
public AspNetApplication AspNetAppInstance { get; }


Close(waitToCloseTimeout) method

AspNetHostBrowser.Close(waitToCloseTimeout) method
Namespaces > ArtOfTest.WebAii.BrowserSpecialized.AspNetHost > AspNetHostBrowser > Close(Int32)
Close this browser.
Syntax
C#
public override void Close (
    int waitToCloseTimeout
)
Parameters
waitToCloseTimeout (Int32)
No Used.


ContainsRectangle(rectangle) method

AspNetHostBrowser.ContainsRectangle(rectangle) method
Namespaces > ArtOfTest.WebAii.BrowserSpecialized.AspNetHost > AspNetHostBrowser > ContainsRectangle(Rectangle)
Unsupported - Browser is window-less.
Syntax
C#
public override bool ContainsRectangle (
    Rectangle rectangle
)
Parameters
rectangle (Rectangle)
Return Value


ContentWindow property

AspNetHostBrowser.ContentWindow property
Namespaces > ArtOfTest.WebAii.BrowserSpecialized.AspNetHost > AspNetHostBrowser > ContentWindow
Unsupported - Browser is window-less. This will throw an UnsupportedBrowserOperation exception.
Syntax
C#
public override Window ContentWindow { get; }


ExecuteCommand(request, performDomRefresh, waitUntilReady) method

AspNetHostBrowser.ExecuteCommand(request, performDomRefresh, waitUntilReady) method
Namespaces > ArtOfTest.WebAii.BrowserSpecialized.AspNetHost > AspNetHostBrowser > ExecuteCommand(BrowserCommand, Boolean, Boolean)
Unsupported - All commands are executed in-proc.
Syntax
C#
public override BrowserCommand ExecuteCommand (
    BrowserCommand request,
    bool performDomRefresh,
    bool waitUntilReady
)
Parameters
request (BrowserCommand)
The request to execute.
performDomRefresh (Boolean)
Whether to perform a Dom refresh.
waitUntilReady (Boolean)
Whether to wait until the browser is ready.
Return Value
N/A - UnsupportedBrowserOperationException


GetForm() method

AspNetHostBrowser.GetForm() method
Namespaces > ArtOfTest.WebAii.BrowserSpecialized.AspNetHost > AspNetHostBrowser > GetForm()
Get the AspNetForm object.
Syntax
C#
public AspNetForm GetForm ()
Return Value
The AspNet Form of this browser as of last request.


GoBack() method

AspNetHostBrowser.GoBack() method
Namespaces > ArtOfTest.WebAii.BrowserSpecialized.AspNetHost > AspNetHostBrowser > GoBack()
N/A - Call returns immediately.
Syntax
C#
public override void GoBack ()


GoForward() method

AspNetHostBrowser.GoForward() method
Namespaces > ArtOfTest.WebAii.BrowserSpecialized.AspNetHost > AspNetHostBrowser > GoForward()
N/A - Call returns immediately.
Syntax
C#
public override void GoForward ()


IsConnected property

AspNetHostBrowser.IsConnected property
Namespaces > ArtOfTest.WebAii.BrowserSpecialized.AspNetHost > AspNetHostBrowser > IsConnected
Whether the AspNetApplication is running and the host is registered.
Syntax
C#
public override bool IsConnected { get; }


IsReady() method

AspNetHostBrowser.IsReady() method
Namespaces > ArtOfTest.WebAii.BrowserSpecialized.AspNetHost > AspNetHostBrowser > IsReady()
Always returns true for this browser.
Syntax
C#
public override bool IsReady ()
Return Value
True.


NavigateTo(uri) method

AspNetHostBrowser.NavigateTo(uri) method
Namespaces > ArtOfTest.WebAii.BrowserSpecialized.AspNetHost > AspNetHostBrowser > NavigateTo(Uri)
Navigate to a certain relative Url.
Syntax
C#
public override void NavigateTo (
    Uri uri
)
Parameters
uri (Uri)
The relative Url to navigate to (i.e. ~/default.aspx).


PerformCustomPostAction(form) method

AspNetHostBrowser.PerformCustomPostAction(form) method
Namespaces > ArtOfTest.WebAii.BrowserSpecialized.AspNetHost > AspNetHostBrowser > PerformCustomPostAction(AspNetForm)
Performs a post action to the server as defined by the form passed in.
Syntax
C#
public void PerformCustomPostAction (
    AspNetForm form
)
Parameters
form (AspNetForm)
The form object to use to make a postback.


Refresh() method

AspNetHostBrowser.Refresh() method
Namespaces > ArtOfTest.WebAii.BrowserSpecialized.AspNetHost > AspNetHostBrowser > Refresh()
N/A - Call returns immediately.
Syntax
C#
public override void Refresh ()


RefreshDomTree() method

AspNetHostBrowser.RefreshDomTree() method
Namespaces > ArtOfTest.WebAii.BrowserSpecialized.AspNetHost > AspNetHostBrowser > RefreshDomTree()
Refresh the DomTree.
Syntax
C#
public override bool RefreshDomTree ()


ScrollBy(x, y) method

AspNetHostBrowser.ScrollBy(x, y) method
Namespaces > ArtOfTest.WebAii.BrowserSpecialized.AspNetHost > AspNetHostBrowser > ScrollBy(Int32, Int32)
Unsupported - Browser is window-less.
Syntax
C#
public override void ScrollBy (
    int x,
    int y
)
Parameters
x (Int32)
y (Int32)


Status property

AspNetHostBrowser.Status property
Namespaces > ArtOfTest.WebAii.BrowserSpecialized.AspNetHost > AspNetHostBrowser > Status
The response status code as of last response.
Syntax
C#
public int Status { get; }


Stop() method

AspNetHostBrowser.Stop() method
Namespaces > ArtOfTest.WebAii.BrowserSpecialized.AspNetHost > AspNetHostBrowser > Stop()
N/A - Call returns immediately.
Syntax
C#
public override void Stop ()


WaitUntilReady() method

AspNetHostBrowser.WaitUntilReady() method
Namespaces > ArtOfTest.WebAii.BrowserSpecialized.AspNetHost > AspNetHostBrowser > WaitUntilReady()
N/A - Call returns immediately.
Syntax
C#
public override void WaitUntilReady ()


Window property

AspNetHostBrowser.Window property
Namespaces > ArtOfTest.WebAii.BrowserSpecialized.AspNetHost > AspNetHostBrowser > Window
Unsupported - Browser is window-less.
Syntax
C#
public override Window Window { get; }


ArtOfTest.WebAii.BrowserSpecialized.Firefox Namespace

ArtOfTest.WebAii.BrowserSpecialized.Firefox Namespace
Namespaces > ArtOfTest.WebAii.BrowserSpecialized.Firefox
Syntax
C#
namespace ArtOfTest.WebAii.BrowserSpecialized.Firefox
Types
All Types Classes Structures Interfaces Enumerations Delegates
Icon | Type | Description
public class | FireFoxActions | FireFox action support class.
public class | FireFoxClientProxy | Proxy used for firefox XPCOM extension to communicate with the .Net objects.


FireFoxActions class

FireFoxActions class
Namespaces > ArtOfTest.WebAii.BrowserSpecialized.Firefox > FireFoxActions
FireFox action support class.
Syntax
C#
public class FireFoxActions : Actions
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AnnotateElement(Element, String) | Visually annotates an element on the browser surface. (Inherited from Actions.)
 | AnnotateMessage(String) | Visually annotate a message on the browser surface. (Inherited from Actions.)
 | Browser | Gets the Browser object associated with this instance of the actions object. (Inherited from Actions.)
 | Check(Element, Boolean) | Sets the a checkbox or a radio button to a specific checked state. (Inherited from Actions.)
 | Click(Element) | Perform a click on the target element. (Inherited from Actions.)
 | DoSelectDropDown(Element, String) | Performs the select drop down action. (Inherited from Actions.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetComputedStyle(Element, String) | Get computed style for an element. (Overrides Actions.GetComputedStyle(Element, String).)
 | GetHashCode() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType() | Gets the Type of the current instance. (Inherited from Object.)
 | InvokeEvent(Element, ScriptEventType) | Invoke an event on the target element. (Inherited from Actions.)
 | InvokeScript(String) | Invokes a javascript function. This function performs a javascript eval() on the callString and returns and values from that call (if any). (Inherited from Actions.)
 | MemberwiseClone() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ScrollToVisible(Element) | Ensures that an item is visible in the browser. Scrolls it into view. Uses the ElementTopAtWindowTop. (Inherited from Actions.)
 | ScrollToVisible(Element, ScrollToVisibleType) | Ensures that an item is visible in the browser. Scrolls it into view. (Inherited from Actions.)
 | SelectDropDown(Element, Int32) | Selects a drop down item from the drop down list using its index. (Inherited from Actions.)
 | SelectDropDown(Element, String) | Selects a drop down item from the drop down list using the item's text. (Inherited from Actions.)
 | SelectDropDown(Element, String, Boolean) | Selects a drop down item from the drop down list using the item's text or the items option value (if useItemValue = true). (Inherited from Actions.)
 | SetText(Element, String) | Set the text of a textbox or textarea. (Inherited from Actions.)
 | ToString() | Returns a String that represents the current Object. (Inherited from Object.)
 | ValidateTargetElement(Element) | Validates the target element. (Inherited from Actions.)
 | WaitCheckInterval | The Settings.WaitCheckInterval value. You can get/set it here too. (Inherited from Actions.)
 | WaitForElement(FindParam, Int32) | Wait until an element is present in the DOM (Inherited from Actions.)
 | WaitForElement(FindParam, Int32, Boolean) | Wait until an element is present in the DOM (Inherited from Actions.)
 | WaitForElement(FindParam, TestRegion, Int32, Boolean) | Wait until an element within a region is present in the DOM. (Inherited from Actions.)
 | WaitForElement(FindParam[](), Int32) | Wait until an element is present in the DOM (Inherited from Actions.)
 | WaitForElement(FindParam[](), Int32, Boolean) | Wait until an element is present in the DOM (Inherited from Actions.)
 | WaitForElement(FindParam[](), TestRegion, Int32, Boolean) | Wait until an element within a region is present in the DOM. (Inherited from Actions.)
 | WaitForElements(Int32, Boolean, FindParam[]()) | Wait until all elements have been found. No chaining is used. (Inherited from Actions.)
 | WaitForElements(Int32, FindParam[]()) | Wait until all elements have been found. No chaining is used. (Inherited from Actions.)
 | WaitForElements(Int32, TestRegion, Boolean, FindParam[]()) | Wait until all elements have been found. No chaining is used. (Inherited from Actions.)
Inheritance Hierarchy
Object
 | Actions
 |  | FireFoxActions


GetComputedStyle(targetElement, style) method

FireFoxActions.GetComputedStyle(targetElement, style) method
Namespaces > ArtOfTest.WebAii.BrowserSpecialized.Firefox > FireFoxActions > GetComputedStyle(Element, String)
Get computed style for an element.
Syntax
C#
public override string GetComputedStyle (
    Element targetElement,
    string style
)
Parameters
targetElement (Element)
The target element.
style (String)
The style to get.
Return Value
The style value.


FireFoxClientProxy class

FireFoxClientProxy class
Namespaces > ArtOfTest.WebAii.BrowserSpecialized.Firefox > FireFoxClientProxy
Proxy used for firefox XPCOM extension to communicate with the .Net objects.
Syntax
C#
public class FireFoxClientProxy
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | FireFoxClientProxyNew(String) | Create a new proxy object.
 | ClientId | This client's unique id.
 | Connect(String, IntPtr) | Connect this proxy to the current active Manager object.
 | Disconnect() | Disconnect and clean up the proxy object and resources.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetRequest | Gets the current command request if any are available.
 | GetRequestId | Gets the current command request id if any are available.
 | GetType() | Gets the Type of the current instance. (Inherited from Object.)
 | LogMesssage(Int32, String) | Log a message to the log object controlled by the Manager.
 | MemberwiseClone() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | SetResponse(BrowserCommand, String) | Set the response of for a command to be processed.
 | SupportsJsLogging() | Returns whether the automation should support client script logging or not.
 | ToString() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
FireFoxClientProxy


ClientId property

FireFoxClientProxy.ClientId property
Namespaces > ArtOfTest.WebAii.BrowserSpecialized.Firefox > FireFoxClientProxy > ClientId
This client's unique id.
Syntax
C#
public string ClientId { get; }


Connect(version, hwnd) method

FireFoxClientProxy.Connect(version, hwnd) method
Namespaces > ArtOfTest.WebAii.BrowserSpecialized.Firefox > FireFoxClientProxy > Connect(String, IntPtr)
Connect this proxy to the current active Manager object.
Syntax
C#
public void Connect (
    string version,
    IntPtr hwnd
)
Parameters
version (String)
The version of the client that is being connected. (FireFox 2.0, IE 6.0 ..etc)
hwnd (IntPtr)
The Hwnd of the client being connected.
Remarks
For FireFox clients, the Hwnd is current not used.


Disconnect() method

FireFoxClientProxy.Disconnect() method
Namespaces > ArtOfTest.WebAii.BrowserSpecialized.Firefox > FireFoxClientProxy > Disconnect()
Disconnect and clean up the proxy object and resources.
Syntax
C#
public void Disconnect ()


FireFoxClientProxy(remoteUrl) constructor

FireFoxClientProxy(remoteUrl) constructor
Namespaces > ArtOfTest.WebAii.BrowserSpecialized.Firefox > FireFoxClientProxy > FireFoxClientProxyNew(String)
Create a new proxy object.
Syntax
C#
public FireFoxClientProxy (
    string remoteUrl
)
Parameters
remoteUrl (String)


GetRequest property

FireFoxClientProxy.GetRequest property
Namespaces > ArtOfTest.WebAii.BrowserSpecialized.Firefox > FireFoxClientProxy > GetRequest
Gets the current command request if any are available.
Syntax
C#
public BrowserCommand GetRequest { get; }
Return Value
The current command being requested for execution. If no requests are present, will return null.


GetRequestId property

FireFoxClientProxy.GetRequestId property
Namespaces > ArtOfTest.WebAii.BrowserSpecialized.Firefox > FireFoxClientProxy > GetRequestId
Gets the current command request id if any are available.
Syntax
C#
public string GetRequestId { get; }
Return Value
The current command id being request for execution. If no requests are present, will return a 'string.empty'.


LogMesssage(type, message) method

FireFoxClientProxy.LogMesssage(type, message) method
Namespaces > ArtOfTest.WebAii.BrowserSpecialized.Firefox > FireFoxClientProxy > LogMesssage(Int32, String)
Log a message to the log object controlled by the Manager.
Syntax
C#
public void LogMesssage (
    int type,
    string message
)
Parameters
type (Int32)
The log type to invoke.
message (String)
The message to log


SetResponse(command, id) method

FireFoxClientProxy.SetResponse(command, id) method
Namespaces > ArtOfTest.WebAii.BrowserSpecialized.Firefox > FireFoxClientProxy > SetResponse(BrowserCommand, String)
Set the response of for a command to be processed.
Syntax
C#
public void SetResponse (
    BrowserCommand command,
    string id
)
Parameters
command (BrowserCommand)
The response.
id (String)
The id of the command.


SupportsJsLogging() method

FireFoxClientProxy.SupportsJsLogging() method
Namespaces > ArtOfTest.WebAii.BrowserSpecialized.Firefox > FireFoxClientProxy > SupportsJsLogging()
Returns whether the automation should support client script logging or not.
Syntax
C#
public bool SupportsJsLogging ()
Return Value
True to support js script logging else false.


ArtOfTest.WebAii.BrowserSpecialized.InternetExplorer Namespace

ArtOfTest.WebAii.BrowserSpecialized.InternetExplorer Namespace
Namespaces > ArtOfTest.WebAii.BrowserSpecialized.InternetExplorer
Syntax
C#
namespace ArtOfTest.WebAii.BrowserSpecialized.InternetExplorer
Types
All Types Classes Structures Interfaces Enumerations Delegates
Icon | Type | Description
public class | InternetExplorerActions | Internet Explorer action support class.


InternetExplorerActions class

InternetExplorerActions class
Namespaces > ArtOfTest.WebAii.BrowserSpecialized.InternetExplorer > InternetExplorerActions
Internet Explorer action support class.
Syntax
C#
public class InternetExplorerActions : Actions
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AnnotateElement(Element, String) | Visually annotates an element on the browser surface. (Inherited from Actions.)
 | AnnotateMessage(String) | Visually annotate a message on the browser surface. (Inherited from Actions.)
 | Browser | Gets the Browser object associated with this instance of the actions object. (Inherited from Actions.)
 | Check(Element, Boolean) | Sets the a checkbox or a radio button to a specific checked state. (Inherited from Actions.)
 | Click(Element) | Perform a click on the target element. (Inherited from Actions.)
 | ConnectIEDialog(String, Int32) | Connect an IE modal or modeless dialog to the Manager.
 | DoSelectDropDown(Element, String) | Performs the select drop down action. (Inherited from Actions.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetComputedStyle(Element, String) | Get computed style for an element. (Overrides Actions.GetComputedStyle(Element, String).)
 | GetHashCode() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetNativeInstance(IntPtr) | Get a reference to the IE IWebBrowser2 object.
 | GetType() | Gets the Type of the current instance. (Inherited from Object.)
 | InvokeEvent(Element, ScriptEventType) | Invoke an event on the target element. (Inherited from Actions.)
 | InvokeScript(String) | Invokes a javascript function. This function performs a javascript eval() on the callString and returns and values from that call (if any). (Inherited from Actions.)
 | MemberwiseClone() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ScrollToVisible(Element) | Ensures that an item is visible in the browser. Scrolls it into view. Uses the ElementTopAtWindowTop. (Inherited from Actions.)
 | ScrollToVisible(Element, ScrollToVisibleType) | Ensures that an item is visible in the browser. Scrolls it into view. (Inherited from Actions.)
 | SelectDropDown(Element, Int32) | Selects a drop down item from the drop down list using its index. (Inherited from Actions.)
 | SelectDropDown(Element, String) | Selects a drop down item from the drop down list using the item's text. (Inherited from Actions.)
 | SelectDropDown(Element, String, Boolean) | Selects a drop down item from the drop down list using the item's text or the items option value (if useItemValue = true). (Inherited from Actions.)
 | SetText(Element, String) | Set the text of a textbox or textarea. (Inherited from Actions.)
 | ToString() | Returns a String that represents the current Object. (Inherited from Object.)
 | ValidateTargetElement(Element) | Validates the target element. (Inherited from Actions.)
 | WaitCheckInterval | The Settings.WaitCheckInterval value. You can get/set it here too. (Inherited from Actions.)
 | WaitForElement(FindParam, Int32) | Wait until an element is present in the DOM (Inherited from Actions.)
 | WaitForElement(FindParam, Int32, Boolean) | Wait until an element is present in the DOM (Inherited from Actions.)
 | WaitForElement(FindParam, TestRegion, Int32, Boolean) | Wait until an element within a region is present in the DOM. (Inherited from Actions.)
 | WaitForElement(FindParam[](), Int32) | Wait until an element is present in the DOM (Inherited from Actions.)
 | WaitForElement(FindParam[](), Int32, Boolean) | Wait until an element is present in the DOM (Inherited from Actions.)
 | WaitForElement(FindParam[](), TestRegion, Int32, Boolean) | Wait until an element within a region is present in the DOM. (Inherited from Actions.)
 | WaitForElements(Int32, Boolean, FindParam[]()) | Wait until all elements have been found. No chaining is used. (Inherited from Actions.)
 | WaitForElements(Int32, FindParam[]()) | Wait until all elements have been found. No chaining is used. (Inherited from Actions.)
 | WaitForElements(Int32, TestRegion, Boolean, FindParam[]()) | Wait until all elements have been found. No chaining is used. (Inherited from Actions.)
Inheritance Hierarchy
Object
 | Actions
 |  | InternetExplorerActions


ConnectIEDialog(caption, delaySearchPeriod) method

InternetExplorerActions.ConnectIEDialog(caption, delaySearchPeriod) method
Namespaces > ArtOfTest.WebAii.BrowserSpecialized.InternetExplorer > InternetExplorerActions > ConnectIEDialog(String, Int32)
Connect an IE modal or modeless dialog to the Manager.
Syntax
C#
public void ConnectIEDialog (
    string caption,
    int delaySearchPeriod
)
Parameters
caption (String)
The full or partial caption of the dialog to connect.
delaySearchPeriod (Int32)
Optionally, you can delay the search (in milli-seconds) for the dialog to make sure windows has actually created the window before looking for it. Else 0.


GetComputedStyle(targetElement, style) method

InternetExplorerActions.GetComputedStyle(targetElement, style) method
Namespaces > ArtOfTest.WebAii.BrowserSpecialized.InternetExplorer > InternetExplorerActions > GetComputedStyle(Element, String)
Get computed style for an element.
Syntax
C#
public override string GetComputedStyle (
    Element targetElement,
    string style
)
Parameters
targetElement (Element)
The target element.
style (String)
The style to get.
Return Value
The style value.


GetNativeInstance(hwnd) method

InternetExplorerActions.GetNativeInstance(hwnd) method
Namespaces > ArtOfTest.WebAii.BrowserSpecialized.InternetExplorer > InternetExplorerActions > GetNativeInstance(IntPtr)
Get a reference to the IE IWebBrowser2 object.
Syntax
C#
public static Object GetNativeInstance (
    IntPtr hwnd
)
Parameters
hwnd (IntPtr)
Return Value
The hwnd handle of the browser to find.


ArtOfTest.WebAii.Controls Namespace

ArtOfTest.WebAii.Controls Namespace
Namespaces > ArtOfTest.WebAii.Controls
Syntax
C#
namespace ArtOfTest.WebAii.Controls
Types
All Types Classes Structures Interfaces Enumerations Delegates
Icon | Type | Description
public class | BaseControlAssert<(Of T>) | Represents the base of all control assert objects.
public class | Control | The base object for all controls.


BaseControlAssert<T> class

BaseControlAssert<T> class
Namespaces > ArtOfTest.WebAii.Controls > BaseControlAssert<(Of T>)
Represents the base of all control assert objects.
Syntax
C#
public abstract class BaseControlAssert<T> where T : Control
Generic Template Parameters
T
The type of the base control.
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BaseControlAssert<(Of T>)New() | Create a new base assert.
 | BaseControlAssert<(Of T>)New(T) | Create a new base assert and pass it the target control
 | Assert(Boolean, String, String, String) | Perform an assert.
 | Assert(Boolean, String, String, String, Boolean) | Perform an assert.
 | AssertNumber(Int32, Int32, NumberCompareType) | Common assert for a number
 | AssertString(String, String, StringCompareType) | Commnon assert for strings.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NotFound | Not found constant string.
 | NumberCompare(Int32, Int32, NumberCompareType) | Do numerical comparison
 | NumberCompareRange(Int32, Int32, Int32, NumberRangeCompareType) | Do numberical range comparison.
 | StringCompare(String, String, StringCompareType) | Perform a string comparison
 | Target | Gets or sets the assert target
 | ToString() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | BaseControlAssert<(Of T>)
 |  | AssertTable
 |  | AssertStyle
 |  | AssertCheck
 |  | AssertSelect
 |  | AssertContent
 |  | AssertAttribute


Assert methods

BaseControlAssert<T>.Assert methods
Namespaces > ArtOfTest.WebAii.Controls > BaseControlAssert<(Of T>) > Assert
Members
Icon | Member | Description
 | Assert(Boolean, String, String, String) | Perform an assert.
 | Assert(Boolean, String, String, String, Boolean) | Perform an assert.


Assert(condition, message, expected, actual) method

BaseControlAssert<T>.Assert(condition, message, expected, actual) method
Namespaces > ArtOfTest.WebAii.Controls > BaseControlAssert<(Of T>) > Assert(Boolean, String, String, String)
Perform an assert.
Syntax
C#
protected bool Assert (
    bool condition,
    string message,
    string expected,
    string actual
)
Parameters
condition (Boolean)
The condition result.
message (String)
The message.
expected (String)
Expected value.
actual (String)
Actual value.
Return Value
The return value


Assert(condition, message, expected, actual, throwAssert) method

BaseControlAssert<T>.Assert(condition, message, expected, actual, throwAssert) method
Namespaces > ArtOfTest.WebAii.Controls > BaseControlAssert<(Of T>) > Assert(Boolean, String, String, String, Boolean)
Perform an assert.
Syntax
C#
protected bool Assert (
    bool condition,
    string message,
    string expected,
    string actual,
    bool throwAssert
)
Parameters
condition (Boolean)
The condition result.
message (String)
The message.
expected (String)
Expected value.
actual (String)
Actual value.
throwAssert (Boolean)
Return Value
The return value.


AssertNumber(leftPortion, rightPortion, compareType) method

BaseControlAssert<T>.AssertNumber(leftPortion, rightPortion, compareType) method
Namespaces > ArtOfTest.WebAii.Controls > BaseControlAssert<(Of T>) > AssertNumber(Int32, Int32, NumberCompareType)
Common assert for a number
Syntax
C#
protected bool AssertNumber (
    int leftPortion,
    int rightPortion,
    NumberCompareType compareType
)
Parameters
leftPortion (Int32)
rightPortion (Int32)
compareType (NumberCompareType)
Return Value


AssertString(expected, actual, compareType) method

BaseControlAssert<T>.AssertString(expected, actual, compareType) method
Namespaces > ArtOfTest.WebAii.Controls > BaseControlAssert<(Of T>) > AssertString(String, String, StringCompareType)
Commnon assert for strings.
Syntax
C#
protected bool AssertString (
    string expected,
    string actual,
    StringCompareType compareType
)
Parameters
expected (String)
The expected value.
actual (String)
The actual value.
compareType (StringCompareType)
The compare type
Return Value


Constructors

BaseControlAssert<T> constructors
Namespaces > ArtOfTest.WebAii.Controls > BaseControlAssert<(Of T>) > BaseControlAssert<(Of T>)New
Members
Icon | Member | Description
 | BaseControlAssert<(Of T>)New() | Create a new base assert.
 | BaseControlAssert<(Of T>)New(T) | Create a new base assert and pass it the target control


BaseControlAssert<T>() constructor

BaseControlAssert<T>() constructor
Namespaces > ArtOfTest.WebAii.Controls > BaseControlAssert<(Of T>) > BaseControlAssert<(Of T>)New()
Create a new base assert.
Syntax
C#
public BaseControlAssert ()


BaseControlAssert<T>(control) constructor

BaseControlAssert<T>(control) constructor
Namespaces > ArtOfTest.WebAii.Controls > BaseControlAssert<(Of T>) > BaseControlAssert<(Of T>)New(T)
Create a new base assert and pass it the target control
Syntax
C#
public BaseControlAssert (
    T control
)
Parameters
control (T)
The target control


NotFound field

BaseControlAssert<T>.NotFound field
Namespaces > ArtOfTest.WebAii.Controls > BaseControlAssert<(Of T>) > NotFound
Not found constant string.
Syntax
C#
protected static readonly string NotFound


NumberCompare(leftPortion, rightPortion, compareType) method

BaseControlAssert<T>.NumberCompare(leftPortion, rightPortion, compareType) method
Namespaces > ArtOfTest.WebAii.Controls > BaseControlAssert<(Of T>) > NumberCompare(Int32, Int32, NumberCompareType)
Do numerical comparison
Syntax
C#
public static bool NumberCompare (
    int leftPortion,
    int rightPortion,
    NumberCompareType compareType
)
Parameters
leftPortion (Int32)
Left side
rightPortion (Int32)
Right side
compareType (NumberCompareType)
The compare type.
Return Value
True/False whether the compare passed


NumberCompareRange(number, lowerEnd, upperEnd, compareType) method

BaseControlAssert<T>.NumberCompareRange(number, lowerEnd, upperEnd, compareType) method
Namespaces > ArtOfTest.WebAii.Controls > BaseControlAssert<(Of T>) > NumberCompareRange(Int32, Int32, Int32, NumberRangeCompareType)
Do numberical range comparison.
Syntax
C#
public static bool NumberCompareRange (
    int number,
    int lowerEnd,
    int upperEnd,
    NumberRangeCompareType compareType
)
Parameters
number (Int32)
The number to compare.
lowerEnd (Int32)
The lower end of the range.
upperEnd (Int32)
The upper end of the range.
compareType (NumberRangeCompareType)
The compare type.
Return Value
True/False whether the comparison passed.


StringCompare(a, b, compareType) method

BaseControlAssert<T>.StringCompare(a, b, compareType) method
Namespaces > ArtOfTest.WebAii.Controls > BaseControlAssert<(Of T>) > StringCompare(String, String, StringCompareType)
Perform a string comparison
Syntax
C#
public static bool StringCompare (
    string a,
    string b,
    StringCompareType compareType
)
Parameters
a (String)
The first string.
b (String)
The string to compare to.
compareType (StringCompareType)
The comparison type.
Return Value
True/False whether the comparison passed


Target property

BaseControlAssert<T>.Target property
Namespaces > ArtOfTest.WebAii.Controls > BaseControlAssert<(Of T>) > Target
Gets or sets the assert target
Syntax
C#
public T Target { get; set; }


Control class

Control class
Namespaces > ArtOfTest.WebAii.Controls > Control
The base object for all controls.
Syntax
C#
public abstract class Control
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ControlNew() | Create new control.
 | ControlNew(Element) | Create new control and assigns it a base element.
 | AssignElement(Element) | Assign this control a base element. Performs any initialization for this control.
 | AssignFailed(Exception) | Mark the assignment to failed. Throw if the framework is set for throwing.
 | BaseElement | Gets the DOM element representing this test control
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType() | Gets the Type of the current instance. (Inherited from Object.)
 | IsRefresh | Gets whether the control is executing a Refresh call.
 | Locator | Gets the FindParam that describes this control. The base Control returns null.
 | MatchControl(Element, FindParam) | Given a FindParam this method returns true/false whether this FindParam matches the passed in element.
 | MemberwiseClone() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OwnerBrowser | Gets the owner browser that owns this control.
 | Refresh() | Refresh this control within the current DOM and update this control property values.
 | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments
 | ToString() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Control
 |  | HtmlControl


AssignElement(e) method

Control.AssignElement(e) method
Namespaces > ArtOfTest.WebAii.Controls > Control > AssignElement(Element)
Assign this control a base element. Performs any initialization for this control.
Syntax
C#
public virtual void AssignElement (
    Element e
)
Parameters
e (Element)
The element to assign.


AssignFailed(exceptionToThrow) method

Control.AssignFailed(exceptionToThrow) method
Namespaces > ArtOfTest.WebAii.Controls > Control > AssignFailed(Exception)
Mark the assignment to failed. Throw if the framework is set for throwing.
Syntax
C#
protected void AssignFailed (
    Exception exceptionToThrow
)
Parameters
exceptionToThrow (Exception)
The exception to throw.


BaseElement property

Control.BaseElement property
Namespaces > ArtOfTest.WebAii.Controls > Control > BaseElement
Gets the DOM element representing this test control
Syntax
C#
public Element BaseElement { get; }


Constructors

Control constructors
Namespaces > ArtOfTest.WebAii.Controls > Control > ControlNew
Members
Icon | Member | Description
 | ControlNew() | Create new control.
 | ControlNew(Element) | Create new control and assigns it a base element.


Control() constructor

Control() constructor
Namespaces > ArtOfTest.WebAii.Controls > Control > ControlNew()
Create new control.
Syntax
C#
public Control ()


Control(element) constructor

Control(element) constructor
Namespaces > ArtOfTest.WebAii.Controls > Control > ControlNew(Element)
Create new control and assigns it a base element.
Syntax
C#
public Control (
    Element element
)
Parameters
element (Element)
The DOM element representing this control.


IsRefresh property

Control.IsRefresh property
Namespaces > ArtOfTest.WebAii.Controls > Control > IsRefresh
Gets whether the control is executing a Refresh call.
Syntax
C#
public bool IsRefresh { get; }


Locator property

Control.Locator property
Namespaces > ArtOfTest.WebAii.Controls > Control > Locator
Gets the FindParam that describes this control. The base Control returns null.
Syntax
C#
public virtual FindParam Locator { get; }
Remarks
This property is provided for convenience and can be overriden by custom controls as a place to put and store the FindParam that describes them.


MatchControl(element, paramToMatch) method

Control.MatchControl(element, paramToMatch) method
Namespaces > ArtOfTest.WebAii.Controls > Control > MatchControl(Element, FindParam)
Given a FindParam this method returns true/false whether this FindParam matches the passed in element.
Syntax
C#
public static bool MatchControl (
    Element element,
    FindParam paramToMatch
)
Parameters
element (Element)
The element to match.
paramToMatch (FindParam)
The FindParam.
Return Value
True/False whether the FindParam matches.
Remarks
For a FindParam to match an element, the following condition must be met: 1. The FindParam.TagName is set, needs to match the element's tagName. 2. If FindParam.Type=Content, then the content as described by FindParam need to match. 3. The FindParam.Attributes and FindParam.PartialAttributes need to match if any are set. 4. If FindParam.Type=TagIndex/XPath or NodeIndexPath will throw an exception since they do not apply in this scenario since they apply only when matching an element within a full DOM hierarchy not an atomic element matching.


OwnerBrowser property

Control.OwnerBrowser property
Namespaces > ArtOfTest.WebAii.Controls > Control > OwnerBrowser
Gets the owner browser that owns this control.
Syntax
C#
public Browser OwnerBrowser { get; }


Refresh() method

Control.Refresh() method
Namespaces > ArtOfTest.WebAii.Controls > Control > Refresh()
Refresh this control within the current DOM and update this control property values.
Syntax
C#
public virtual void Refresh ()


ThrowOnInvalidAssignment property

Control.ThrowOnInvalidAssignment property
Namespaces > ArtOfTest.WebAii.Controls > Control > ThrowOnInvalidAssignment
Gets whether the control should throw on invalid assignments
Syntax
C#
protected bool ThrowOnInvalidAssignment { get; }


ArtOfTest.WebAii.Controls.HtmlControls Namespace

ArtOfTest.WebAii.Controls.HtmlControls Namespace
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls
Syntax
C#
namespace ArtOfTest.WebAii.Controls.HtmlControls
Types
All Types Classes Structures Interfaces Enumerations Delegates
Icon | Type | Description
public enumeration | DownloadOption | Download options for a download from an html page.
public class | HtmlAnchor | Test class for an HtmlAnchor element <a href="...">...</a>
public class | HtmlButton | Test class for an HtmlButton element <button >...</button>
public class | HtmlContainerControl | Base class for all container controls. Controls that are allowed to contain other Html elements.
public class | HtmlControl | Base test control for all Html controls.
public class | HtmlControlsAssertExtensions | Assert extensions for the HtmlControl class.
public class | HtmlDiv | Test class for an HtmlDiv element <div>...</div>
public class | HtmlFind | Extends the generic Find methods to include HTML specific find objects.
public class | HtmlForm | Test class for an HtmlForm element <form >...</form>
public class | HtmlImage | Test class for an HtmlImage element <img src="..." />
public class | HtmlInputButton | Test class for an HtmlInputButton element <input type="button" />
public class | HtmlInputCheckBox | Test class for an HtmlInputCheckBox element <input type="checkbox" />
public class | HtmlInputCheckBoxExtensions | Assert extensions for the HtmlControl class.
public class | HtmlInputControl | Base class for all input controls
public class | HtmlInputFile | Test class for an HtmlInputFile element <input type="file" />
public class | HtmlInputHidden | Test class for an HtmlInputHidden element <input type="hidden" />
public class | HtmlInputImage | Test class for an HtmlInputImage element <input type="image" />
public class | HtmlInputPassword | Test class for an HtmlInputPassword element <input type="password" />
public class | HtmlInputRadioButton | Test class for an HtmlInputImage element <input type="radio" />
public class | HtmlInputRadioButtonExtensions | Assert extensions for the HtmlControl class.
public class | HtmlInputReset | Test class for an HtmlInputImage element <input type="reset" />
public class | HtmlInputSubmit | Test class for an HtmlInputImage element <input type="reset" />
public class | HtmlInputText | Test class for an HtmlInputImage element <input type="text" />
public class | HtmlOption | Test class for an HtmlOption element <option ... />
public class | HtmlSelect | Test class for an HtmlSelect element <select>...</select>
public class | HtmlSelectAssertExtensions | Assert extensions for the HtmlControl class.
public class | HtmlSpan | Test class for an HtmlSpan element <span>...</span>
public class | HtmlStyle | Represents a single HtmlStyle. This object can be used to help probe and do validation against Html styles. Has functionality to convert unit styles to int values and color styles to System.Drawing.Color.
public class | HtmlTable | Test class for an HtmlTable element <table>...</table>
public class | HtmlTableAssertExtensions | Assert extensions for the HtmlControl class.
public class | HtmlTableCell | Test class for an HtmlTableCell element <td>...</td>
public class | HtmlTableRow | Test class for an HtmlTableRow element <tr>...</tr>
public class | HtmlTextArea | Test class for an HtmlAnchor element <textarea>...</textarea>
public class | HtmlWait | Extends the Wait object for specific HtmlWait scenarios.


DownloadOption enumeration

DownloadOption enumeration
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > DownloadOption
Download options for a download from an html page.
Syntax
C#
public enum DownloadOption
Members
Member | Description
Save | Save the downloaded file to a specific location on disk.
Cancel | Cancel the download dialog.


HtmlAnchor class

HtmlAnchor class
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlAnchor
Test class for an HtmlAnchor element <a href="...">...</a>
Syntax
C#
public class HtmlAnchor : HtmlContainerControl
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | HtmlAnchorNew() | Create a new control.
 | HtmlAnchorNew(Element) | Create a new control.
 | AssignElement(Element) | Assign this control a base element. Performs any initialization for this control. (Overrides HtmlContainerControl.AssignElement(Element).)
 | AssignFailed(Exception) | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
 | Attributes | All attributes set on this control (Inherited from HtmlControl.)
 | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
 | Capture() | Captures and returns the image of the current Html Control. (Inherited from HtmlControl.)
 | Capture(String) | Captures and saves Html Control Image to the WebAii log location as a bmp file. (Inherited from HtmlControl.)
 | Capture(String, String) | Captures and saves Html Control Image to the specified save path as the specified image name in bmp format. (Inherited from HtmlControl.)
 | Click() | Invoke a click within the loaded page. (Inherited from HtmlControl.)
 | Click(Boolean) | Invoke a click that causes that browser window to close (i.e. this is common for html pop-ups) (Inherited from HtmlControl.)
 | CssClass | Control's CSS class if set. (Inherited from HtmlControl.)
 | Download(Boolean, DownloadOption, String, Int32) | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
 | DragTo(HtmlControl) | Drag this control to the center on the destination control. (Inherited from HtmlControl.)
 | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination control with an offset of where within the destination control to drag to. (Inherited from HtmlControl.)
 | DragTo(Int32, Int32) | Drag this control to a relative X/Y offset. (Inherited from HtmlControl.)
 | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this control by specifying a reference point on the control rectangle to start the drag from and a reference point on the destination control to specify the drop location. (Inherited from HtmlControl.)
 | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this control from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
 | DragTo(OffsetReference, Point, HtmlControl) | Drag this control by specifying a reference point on the control rectangle to start the drag from with an offset and drop on the destination control center. (Inherited from HtmlControl.)
 | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this control by specifying a reference point on the control rectangle to start the drag from and a reference point on the destination control to specify the drop location. (Inherited from HtmlControl.)
 | DragTo(OffsetReference, Point, Int32, Int32) | Drag this control from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
 | DragTo(Point) | Drag this control to an absolute point. (Inherited from HtmlControl.)
 | DragToWindowLocation(OffsetReference, Int32, Int32, Boolean, OffsetReference, Int32, Int32, Boolean) | Drag this control, using the browser window as the drop target (Inherited from HtmlControl.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Events collection set on this control (Inherited from HtmlControl.)
 | Finalize() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Find | Find property (Inherited from HtmlContainerControl.)
 | FindParentContainer<(Of TContainerControl>)() | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
 | GetAttributeAsString(String) | Get an attribute of this element as a string (Inherited from HtmlControl.)
 | GetComputedStyle(String) | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
 | GetComputedStyleValue(String) | Returns computed style value. Computed style represents the final computed value of all CSS properties for the element. (Inherited from HtmlControl.)
 | GetHashCode() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetRectangle() | The absolute screen position of the control. (Inherited from HtmlControl.)
 | GetStyle(String) | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
 | GetStyleValue(String) | Returns any style as if you are accessing the element.style object from javascript. (Inherited from HtmlControl.)
 | GetType() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue<(Of T>)(String) | Get a property value (i.e. control.border or control.style.backgroundColor). string s = myControl.GetValue<string>("style.backgroundColor") (Inherited from HtmlControl.)
 | HRef | Gets the URL of the linked resource.
 | ID | Control's ID if set. (Inherited from HtmlControl.)
 | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
 | InvokeEvent(ScriptEventType) | Invokes an event on this control (Inherited from HtmlControl.)
 | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
 | IsVisible() | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
 | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
 | MemberwiseClone() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MouseClick() | Uses the Desktop.Mouse object to move the mouse to this control and click it. (Inherited from HtmlControl.)
 | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to this control and click it. (Inherited from HtmlControl.)
 | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to this control and click it. (Inherited from HtmlControl.)
 | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to this control and click it. (Inherited from HtmlControl.)
 | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to this control and click it. (Inherited from HtmlControl.)
 | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over the control (Inherited from HtmlControl.)
 | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over the control (Inherited from HtmlControl.)
 | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over the control (Inherited from HtmlControl.)
 | Name | Gets the name of a link.
 | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
 | Parent<(Of TContainerControl>)() | Return the parent HtmlContainerControl of desired type that this control is contained in. If control is not found, will return null. (Inherited from HtmlControl.)
 | Refresh() | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
 | ScrollLeft | Gets/Sets the scrollLeft value of the html control. (Inherited from HtmlControl.)
 | ScrollTop | Gets/Sets the scrollTop value of the html control (Inherited from HtmlControl.)
 | ScrollToVisible(ScrollToVisibleType) | Scroll control to Visible Position on the page (Inherited from HtmlControl.)
 | SetValue<(Of T>)(String, T) | Set a property value. (i.e. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
 | Styles | Styles collection set on this control and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
 | TagName | The tag name of this element (Inherited from HtmlControl.)
 | Target | Gets where to open a link.
 | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
 | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
 | Title | The text displayed when the mouse pointer is placed over the System.Web.UI.HtmlControls.HtmlAnchor.
 | ToString() | Returns a String that represents the current Object. (Inherited from Object.)
 | ValidateControl() | Validate a control using a its Locator. (Inherited from HtmlControl.)
 | ValidateTag(String) | Validate a tag name (Inherited from HtmlControl.)
 | Wait | Gets the HTML Wait object. (Inherited from HtmlControl.)
Inheritance Hierarchy
Object
 | Control
 |  | HtmlControl
 |  |  | HtmlContainerControl
 |  |  |  | HtmlAnchor


AssignElement(e) method

HtmlAnchor.AssignElement(e) method
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlAnchor > AssignElement(Element)
Assign this control a base element. Performs any initialization for this control.
Syntax
C#
public override void AssignElement (
    Element e
)
Parameters
e (Element)
The element to assign.


Constructors

HtmlAnchor constructors
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlAnchor > HtmlAnchorNew
Members
Icon | Member | Description
 | HtmlAnchorNew() | Create a new control.
 | HtmlAnchorNew(Element) | Create a new control.


HtmlAnchor() constructor

HtmlAnchor() constructor
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlAnchor > HtmlAnchorNew()
Create a new control.
Syntax
C#
public HtmlAnchor ()


HtmlAnchor(element) constructor

HtmlAnchor(element) constructor
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlAnchor > HtmlAnchorNew(Element)
Create a new control.
Syntax
C#
public HtmlAnchor (
    Element element
)
Parameters
element (Element)
The base element.


HRef property

HtmlAnchor.HRef property
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlAnchor > HRef
Gets the URL of the linked resource.
Syntax
C#
public string HRef { get; }


Name property

HtmlAnchor.Name property
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlAnchor > Name
Gets the name of a link.
Syntax
C#
public string Name { get; }


Target property

HtmlAnchor.Target property
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlAnchor > Target
Gets where to open a link.
Syntax
C#
public string Target { get; }


Title property

HtmlAnchor.Title property
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlAnchor > Title
The text displayed when the mouse pointer is placed over the System.Web.UI.HtmlControls.HtmlAnchor.
Syntax
C#
public string Title { get; }


HtmlButton class

HtmlButton class
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlButton
Test class for an HtmlButton element <button >...</button>
Syntax
C#
public class HtmlButton : HtmlContainerControl
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | HtmlButtonNew() | Create a new control.
 | HtmlButtonNew(Element) | Create a new control.
 | AssignElement(Element) | Assign element and initialize this control. (Overrides HtmlContainerControl.AssignElement(Element).)
 | AssignFailed(Exception) | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
 | Attributes | All attributes set on this control (Inherited from HtmlControl.)
 | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
 | Capture() | Captures and returns the image of the current Html Control. (Inherited from HtmlControl.)
 | Capture(String) | Captures and saves Html Control Image to the WebAii log location as a bmp file. (Inherited from HtmlControl.)
 | Capture(String, String) | Captures and saves Html Control Image to the specified save path as the specified image name in bmp format. (Inherited from HtmlControl.)
 | Click() | Invoke a click within the loaded page. (Inherited from HtmlControl.)
 | Click(Boolean) | Invoke a click that causes that browser window to close (i.e. this is common for html pop-ups) (Inherited from HtmlControl.)
 | CssClass | Control's CSS class if set. (Inherited from HtmlControl.)
 | Disabled | Gets whether a button is disabled.
 | Download(Boolean, DownloadOption, String, Int32) | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
 | DragTo(HtmlControl) | Drag this control to the center on the destination control. (Inherited from HtmlControl.)
 | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination control with an offset of where within the destination control to drag to. (Inherited from HtmlControl.)
 | DragTo(Int32, Int32) | Drag this control to a relative X/Y offset. (Inherited from HtmlControl.)
 | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this control by specifying a reference point on the control rectangle to start the drag from and a reference point on the destination control to specify the drop location. (Inherited from HtmlControl.)
 | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this control from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
 | DragTo(OffsetReference, Point, HtmlControl) | Drag this control by specifying a reference point on the control rectangle to start the drag from with an offset and drop on the destination control center. (Inherited from HtmlControl.)
 | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this control by specifying a reference point on the control rectangle to start the drag from and a reference point on the destination control to specify the drop location. (Inherited from HtmlControl.)
 | DragTo(OffsetReference, Point, Int32, Int32) | Drag this control from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
 | DragTo(Point) | Drag this control to an absolute point. (Inherited from HtmlControl.)
 | DragToWindowLocation(OffsetReference, Int32, Int32, Boolean, OffsetReference, Int32, Int32, Boolean) | Drag this control, using the browser window as the drop target (Inherited from HtmlControl.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Events collection set on this control (Inherited from HtmlControl.)
 | Finalize() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Find | Find property (Inherited from HtmlContainerControl.)
 | FindParentContainer<(Of TContainerControl>)() | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
 | GetAttributeAsString(String) | Get an attribute of this element as a string (Inherited from HtmlControl.)
 | GetComputedStyle(String) | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
 | GetComputedStyleValue(String) | Returns computed style value. Computed style represents the final computed value of all CSS properties for the element. (Inherited from HtmlControl.)
 | GetHashCode() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetRectangle() | The absolute screen position of the control. (Inherited from HtmlControl.)
 | GetStyle(String) | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
 | GetStyleValue(String) | Returns any style as if you are accessing the element.style object from javascript. (Inherited from HtmlControl.)
 | GetType() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue<(Of T>)(String) | Get a property value (i.e. control.border or control.style.backgroundColor). string s = myControl.GetValue<string>("style.backgroundColor") (Inherited from HtmlControl.)
 | ID | Control's ID if set. (Inherited from HtmlControl.)
 | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
 | InvokeEvent(ScriptEventType) | Invokes an event on this control (Inherited from HtmlControl.)
 | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
 | IsVisible() | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
 | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
 | MemberwiseClone() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MouseClick() | Uses the Desktop.Mouse object to move the mouse to this control and click it. (Inherited from HtmlControl.)
 | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to this control and click it. (Inherited from HtmlControl.)
 | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to this control and click it. (Inherited from HtmlControl.)
 | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to this control and click it. (Inherited from HtmlControl.)
 | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to this control and click it. (Inherited from HtmlControl.)
 | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over the control (Inherited from HtmlControl.)
 | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over the control (Inherited from HtmlControl.)
 | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over the control (Inherited from HtmlControl.)
 | Name | Gets the name of a button.
 | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
 | Parent<(Of TContainerControl>)() | Return the parent HtmlContainerControl of desired type that this control is contained in. If control is not found, will return null. (Inherited from HtmlControl.)
 | Refresh() | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
 | ScrollLeft | Gets/Sets the scrollLeft value of the html control. (Inherited from HtmlControl.)
 | ScrollTop | Gets/Sets the scrollTop value of the html control (Inherited from HtmlControl.)
 | ScrollToVisible(ScrollToVisibleType) | Scroll control to Visible Position on the page (Inherited from HtmlControl.)
 | SetValue<(Of T>)(String, T) | Set a property value. (i.e. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
 | Styles | Styles collection set on this control and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
 | TabIndex | Gets the tab order for a button.
 | TagName | The tag name of this element (Inherited from HtmlControl.)
 | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
 | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
 | ToString() | Returns a String that represents the current Object. (Inherited from Object.)
 | ValidateControl() | Validate a control using a its Locator. (Inherited from HtmlControl.)
 | ValidateTag(String) | Validate a tag name (Inherited from HtmlControl.)
 | Value | Gets the text that is displayed on a button.
 | Wait | Gets the HTML Wait object. (Inherited from HtmlControl.)
Inheritance Hierarchy
Object
 | Control
 |  | HtmlControl
 |  |  | HtmlContainerControl
 |  |  |  | HtmlButton


AssignElement(e) method

HtmlButton.AssignElement(e) method
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlButton > AssignElement(Element)
Assign element and initialize this control.
Syntax
C#
public override void AssignElement (
    Element e
)
Parameters
e (Element)
The base element.


Constructors

HtmlButton constructors
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlButton > HtmlButtonNew
Members
Icon | Member | Description
 | HtmlButtonNew() | Create a new control.
 | HtmlButtonNew(Element) | Create a new control.


HtmlButton() constructor

HtmlButton() constructor
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlButton > HtmlButtonNew()
Create a new control.
Syntax
C#
public HtmlButton ()


HtmlButton(element) constructor

HtmlButton(element) constructor
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlButton > HtmlButtonNew(Element)
Create a new control.
Syntax
C#
public HtmlButton (
    Element element
)
Parameters
element (Element)
The base element.


Disabled property

HtmlButton.Disabled property
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlButton > Disabled
Gets whether a button is disabled.
Syntax
C#
public bool Disabled { get; }


Name property

HtmlButton.Name property
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlButton > Name
Gets the name of a button.
Syntax
C#
public string Name { get; }


TabIndex property

HtmlButton.TabIndex property
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlButton > TabIndex
Gets the tab order for a button.
Syntax
C#
public int TabIndex { get; }


Value property

HtmlButton.Value property
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlButton > Value
Gets the text that is displayed on a button.
Syntax
C#
[DebuggerBrowsableAttribute(DebuggerBrowsableState.Never)]
public string Value { get; set; }


HtmlContainerControl class

HtmlContainerControl class
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlContainerControl
Base class for all container controls. Controls that are allowed to contain other Html elements.
Syntax
C#
public class HtmlContainerControl : HtmlControl
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | HtmlContainerControlNew() | Create a new HtmlContainerControl
 | HtmlContainerControlNew(Element) | Create a new control.
 | AssignElement(Element) | Assign element and initialize this control. (Overrides HtmlControl.AssignElement(Element).)
 | AssignFailed(Exception) | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
 | Attributes | All attributes set on this control (Inherited from HtmlControl.)
 | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
 | Capture() | Captures and returns the image of the current Html Control. (Inherited from HtmlControl.)
 | Capture(String) | Captures and saves Html Control Image to the WebAii log location as a bmp file. (Inherited from HtmlControl.)
 | Capture(String, String) | Captures and saves Html Control Image to the specified save path as the specified image name in bmp format. (Inherited from HtmlControl.)
 | Click() | Invoke a click within the loaded page. (Inherited from HtmlControl.)
 | Click(Boolean) | Invoke a click that causes that browser window to close (i.e. this is common for html pop-ups) (Inherited from HtmlControl.)
 | CssClass | Control's CSS class if set. (Inherited from HtmlControl.)
 | Download(Boolean, DownloadOption, String, Int32) | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
 | DragTo(HtmlControl) | Drag this control to the center on the destination control. (Inherited from HtmlControl.)
 | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination control with an offset of where within the destination control to drag to. (Inherited from HtmlControl.)
 | DragTo(Int32, Int32) | Drag this control to a relative X/Y offset. (Inherited from HtmlControl.)
 | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this control by specifying a reference point on the control rectangle to start the drag from and a reference point on the destination control to specify the drop location. (Inherited from HtmlControl.)
 | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this control from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
 | DragTo(OffsetReference, Point, HtmlControl) | Drag this control by specifying a reference point on the control rectangle to start the drag from with an offset and drop on the destination control center. (Inherited from HtmlControl.)
 | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this control by specifying a reference point on the control rectangle to start the drag from and a reference point on the destination control to specify the drop location. (Inherited from HtmlControl.)
 | DragTo(OffsetReference, Point, Int32, Int32) | Drag this control from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
 | DragTo(Point) | Drag this control to an absolute point. (Inherited from HtmlControl.)
 | DragToWindowLocation(OffsetReference, Int32, Int32, Boolean, OffsetReference, Int32, Int32, Boolean) | Drag this control, using the browser window as the drop target (Inherited from HtmlControl.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Events collection set on this control (Inherited from HtmlControl.)
 | Finalize() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Find | Find property
 | FindParentContainer<(Of TContainerControl>)() | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
 | GetAttributeAsString(String) | Get an attribute of this element as a string (Inherited from HtmlControl.)
 | GetComputedStyle(String) | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
 | GetComputedStyleValue(String) | Returns computed style value. Computed style represents the final computed value of all CSS properties for the element. (Inherited from HtmlControl.)
 | GetHashCode() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetRectangle() | The absolute screen position of the control. (Inherited from HtmlControl.)
 | GetStyle(String) | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
 | GetStyleValue(String) | Returns any style as if you are accessing the element.style object from javascript. (Inherited from HtmlControl.)
 | GetType() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue<(Of T>)(String) | Get a property value (i.e. control.border or control.style.backgroundColor). string s = myControl.GetValue<string>("style.backgroundColor") (Inherited from HtmlControl.)
 | ID | Control's ID if set. (Inherited from HtmlControl.)
 | InnerText | Gets the innerText of this container control.
 | InvokeEvent(ScriptEventType) | Invokes an event on this control (Inherited from HtmlControl.)
 | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
 | IsVisible() | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
 | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
 | MemberwiseClone() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MouseClick() | Uses the Desktop.Mouse object to move the mouse to this control and click it. (Inherited from HtmlControl.)
 | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to this control and click it. (Inherited from HtmlControl.)
 | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to this control and click it. (Inherited from HtmlControl.)
 | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to this control and click it. (Inherited from HtmlControl.)
 | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to this control and click it. (Inherited from HtmlControl.)
 | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over the control (Inherited from HtmlControl.)
 | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over the control (Inherited from HtmlControl.)
 | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over the control (Inherited from HtmlControl.)
 | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
 | Parent<(Of TContainerControl>)() | Return the parent HtmlContainerControl of desired type that this control is contained in. If control is not found, will return null. (Inherited from HtmlControl.)
 | Refresh() | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
 | ScrollLeft | Gets/Sets the scrollLeft value of the html control. (Inherited from HtmlControl.)
 | ScrollTop | Gets/Sets the scrollTop value of the html control (Inherited from HtmlControl.)
 | ScrollToVisible(ScrollToVisibleType) | Scroll control to Visible Position on the page (Inherited from HtmlControl.)
 | SetValue<(Of T>)(String, T) | Set a property value. (i.e. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
 | Styles | Styles collection set on this control and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
 | TagName | The tag name of this element (Inherited from HtmlControl.)
 | TextContent | Gets the TextContent of this container control.
 | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
 | ToString() | Returns a String that represents the current Object. (Inherited from Object.)
 | ValidateControl() | Validate a control using a its Locator. (Inherited from HtmlControl.)
 | ValidateTag(String) | Validate a tag name (Inherited from HtmlControl.)
 | Wait | Gets the HTML Wait object. (Inherited from HtmlControl.)
Inheritance Hierarchy
Object
 | Control
 |  | HtmlControl
 |  |  | HtmlContainerControl
 |  |  |  | HtmlAnchor
 |  |  |  | HtmlTable
 |  |  |  | HtmlSpan
 |  |  |  | HtmlTableRow
 |  |  |  | HtmlTextArea
 |  |  |  | HtmlDiv
 |  |  |  | HtmlTableCell
 |  |  |  | HtmlButton
 |  |  |  | HtmlForm
 |  |  |  | HtmlSelect


AssignElement(e) method

HtmlContainerControl.AssignElement(e) method
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlContainerControl > AssignElement(Element)
Assign element and initialize this control.
Syntax
C#
public override void AssignElement (
    Element e
)
Parameters
e (Element)
The base element.


Constructors

HtmlContainerControl constructors
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlContainerControl > HtmlContainerControlNew
Members
Icon | Member | Description
 | HtmlContainerControlNew() | Create a new HtmlContainerControl
 | HtmlContainerControlNew(Element) | Create a new control.


HtmlContainerControl() constructor

HtmlContainerControl() constructor
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlContainerControl > HtmlContainerControlNew()
Create a new HtmlContainerControl
Syntax
C#
public HtmlContainerControl ()


HtmlContainerControl(element) constructor

HtmlContainerControl(element) constructor
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlContainerControl > HtmlContainerControlNew(Element)
Create a new control.
Syntax
C#
public HtmlContainerControl (
    Element element
)
Parameters
element (Element)
The base element.


Find property

HtmlContainerControl.Find property
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlContainerControl > Find
Find property
Syntax
C#
public virtual HtmlFind Find { get; }


InnerText property

HtmlContainerControl.InnerText property
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlContainerControl > InnerText
Gets the innerText of this container control.
Syntax
C#
public string InnerText { get; }


TextContent property

HtmlContainerControl.TextContent property
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlContainerControl > TextContent
Gets the TextContent of this container control.
Syntax
C#
public string TextContent { get; }


HtmlControl class

HtmlControl class
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlControl
Base test control for all Html controls.
Syntax
C#
public class HtmlControl : Control
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | HtmlControlNew() | Create a new HtmlControl
 | HtmlControlNew(Element) | Create a new HtmlControl
 | AssignElement(Element) | Assign the control and initialize its internal properties. (Overrides Control.AssignElement(Element).)
 | AssignFailed(Exception) | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
 | Attributes | All attributes set on this control
 | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
 | Capture() | Captures and returns the image of the current Html Control.
 | Capture(String) | Captures and saves Html Control Image to the WebAii log location as a bmp file.
 | Capture(String, String) | Captures and saves Html Control Image to the specified save path as the specified image name in bmp format.
 | Click() | Invoke a click within the loaded page.
 | Click(Boolean) | Invoke a click that causes that browser window to close (i.e. this is common for html pop-ups)
 | CssClass | Control's CSS class if set.
 | Download(Boolean, DownloadOption, String, Int32) | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced.
 | DragTo(HtmlControl) | Drag this control to the center on the destination control.
 | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination control with an offset of where within the destination control to drag to.
 | DragTo(Int32, Int32) | Drag this control to a relative X/Y offset.
 | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this control by specifying a reference point on the control rectangle to start the drag from and a reference point on the destination control to specify the drop location.
 | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this control from a source offset to an X/Y offset from the source.
 | DragTo(OffsetReference, Point, HtmlControl) | Drag this control by specifying a reference point on the control rectangle to start the drag from with an offset and drop on the destination control center.
 | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this control by specifying a reference point on the control rectangle to start the drag from and a reference point on the destination control to specify the drop location.
 | DragTo(OffsetReference, Point, Int32, Int32) | Drag this control from a source offset to an X/Y offset from the source.
 | DragTo(Point) | Drag this control to an absolute point.
 | DragToWindowLocation(OffsetReference, Int32, Int32, Boolean, OffsetReference, Int32, Int32, Boolean) | Drag this control, using the browser window as the drop target
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Events collection set on this control
 | Finalize() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindParentContainer<(Of TContainerControl>)() | Traverses the DOM tree upwards until it finds the container element desired.
 | GetAttributeAsString(String) | Get an attribute of this element as a string
 | GetComputedStyle(String) | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color)
 | GetComputedStyleValue(String) | Returns computed style value. Computed style represents the final computed value of all CSS properties for the element.
 | GetHashCode() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetRectangle() | The absolute screen position of the control.
 | GetStyle(String) | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color)
 | GetStyleValue(String) | Returns any style as if you are accessing the element.style object from javascript.
 | GetType() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue<(Of T>)(String) | Get a property value (i.e. control.border or control.style.backgroundColor). string s = myControl.GetValue<string>("style.backgroundColor")
 | ID | Control's ID if set.
 | InvokeEvent(ScriptEventType) | Invokes an event on this control
 | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
 | IsVisible() | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden'
 | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
 | MemberwiseClone() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MouseClick() | Uses the Desktop.Mouse object to move the mouse to this control and click it.
 | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to this control and click it.
 | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to this control and click it.
 | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to this control and click it.
 | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to this control and click it.
 | MouseHover() | Uses the Desktop.Mouse object to Hover over the control
 | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over the control
 | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over the control
 | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over the control
 | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
 | Parent<(Of TContainerControl>)() | Return the parent HtmlContainerControl of desired type that this control is contained in. If control is not found, will return null.
 | Refresh() | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
 | ScrollLeft | Gets/Sets the scrollLeft value of the html control.
 | ScrollTop | Gets/Sets the scrollTop value of the html control
 | ScrollToVisible(ScrollToVisibleType) | Scroll control to Visible Position on the page
 | SetValue<(Of T>)(String, T) | Set a property value. (i.e. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red")
 | Styles | Styles collection set on this control and persisted in the Html stream. This collection does not contain computed styles.
 | TagName | The tag name of this element
 | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
 | ToString() | Returns a String that represents the current Object. (Inherited from Object.)
 | ValidateControl() | Validate a control using a its Locator.
 | ValidateTag(String) | Validate a tag name
 | Wait | Gets the HTML Wait object.
Inheritance Hierarchy
Object
 | Control
 |  | HtmlControl
 |  |  | HtmlInputControl
 |  |  | HtmlContainerControl
 |  |  | HtmlImage
 |  |  | HtmlOption


AssignElement(e) method

HtmlControl.AssignElement(e) method
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlControl > AssignElement(Element)
Assign the control and initialize its internal properties.
Syntax
C#
public override void AssignElement (
    Element e
)
Parameters
e (Element)
The base element.


Attributes property

HtmlControl.Attributes property
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlControl > Attributes
All attributes set on this control
Syntax
C#
public virtual ReadOnlyCollection<iAttribute> Attributes { get; }


Capture methods

HtmlControl.Capture methods
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlControl > Capture
Members
Icon | Member | Description
 | Capture() | Captures and returns the image of the current Html Control.
 | Capture(String) | Captures and saves Html Control Image to the WebAii log location as a bmp file.
 | Capture(String, String) | Captures and saves Html Control Image to the specified save path as the specified image name in bmp format.


Capture() method

HtmlControl.Capture() method
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlControl > Capture()
Captures and returns the image of the current Html Control.
Syntax
C#
public virtual Bitmap Capture ()
Return Value
Bitmap of HtmlControl


Capture(imageName) method

HtmlControl.Capture(imageName) method
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlControl > Capture(String)
Captures and saves Html Control Image to the WebAii log location as a bmp file.
Syntax
C#
public virtual void Capture (
    string imageName
)
Parameters
imageName (String)
Image save name (without extension).


Capture(savePath, imageName) method

HtmlControl.Capture(savePath, imageName) method
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlControl > Capture(String, String)
Captures and saves Html Control Image to the specified save path as the specified image name in bmp format.
Syntax
C#
public virtual void Capture (
    string savePath,
    string imageName
)
Parameters
savePath (String)
Path to save file to.
imageName (String)
Image save name (without extension).


Click methods

HtmlControl.Click methods
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlControl > Click
Members
Icon | Member | Description
 | Click() | Invoke a click within the loaded page.
 | Click(Boolean) | Invoke a click that causes that browser window to close (i.e. this is common for html pop-ups)


Click() method

HtmlControl.Click() method
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlControl > Click()
Invoke a click within the loaded page.
Syntax
C#
public virtual void Click ()


Click(isClosing) method

HtmlControl.Click(isClosing) method
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlControl > Click(Boolean)
Invoke a click that causes that browser window to close (i.e. this is common for html pop-ups)
Syntax
C#
public virtual void Click (
    bool isClosing
)
Parameters
isClosing (Boolean)
If set, we won't wait for the browser to be ready.


Constructors

HtmlControl constructors
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlControl > HtmlControlNew
Members
Icon | Member | Description
 | HtmlControlNew() | Create a new HtmlControl
 | HtmlControlNew(Element) | Create a new HtmlControl


HtmlControl() constructor

HtmlControl() constructor
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlControl > HtmlControlNew()
Create a new HtmlControl
Syntax
C#
public HtmlControl ()


HtmlControl(e) constructor

HtmlControl(e) constructor
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlControl > HtmlControlNew(Element)
Create a new HtmlControl
Syntax
C#
public HtmlControl (
    Element e
)
Parameters
e (Element)
The base element.


CssClass property

HtmlControl.CssClass property
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlControl > CssClass
Control's CSS class if set.
Syntax
C#
public virtual string CssClass { get; }


Download(clickUsingDesktopMouse, downloadOption, saveLocation, downloadTimeout) method

HtmlControl.Download(clickUsingDesktopMouse, downloadOption, saveLocation, downloadTimeout) method
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlControl > Download(Boolean, DownloadOption, String, Int32)
Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced.
Syntax
C#
public virtual void Download (
    bool clickUsingDesktopMouse,
    DownloadOption downloadOption,
    string saveLocation,
    int downloadTimeout
)
Parameters
clickUsingDesktopMouse (Boolean)
True/False whether to use the DOM Click or the Desktop Mouse.Click
downloadOption (DownloadOption)
The download option to use. Save or Cancel.
saveLocation (String)
If save, the save location on disk.
downloadTimeout (Int32)
The wait timeout to wait until all dialogs are handled.


DragTo methods

HtmlControl.DragTo methods
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlControl > DragTo
Members
Icon | Member | Description
 | DragTo(HtmlControl) | Drag this control to the center on the destination control.
 | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination control with an offset of where within the destination control to drag to.
 | DragTo(OffsetReference, Point, HtmlControl) | Drag this control by specifying a reference point on the control rectangle to start the drag from with an offset and drop on the destination control center.
 | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this control by specifying a reference point on the control rectangle to start the drag from and a reference point on the destination control to specify the drop location.
 | DragTo(OffsetReference, Point, Int32, Int32) | Drag this control from a source offset to an X/Y offset from the source.
 | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this control by specifying a reference point on the control rectangle to start the drag from and a reference point on the destination control to specify the drop location.
 | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this control from a source offset to an X/Y offset from the source.
 | DragTo(Point) | Drag this control to an absolute point.
 | DragTo(Int32, Int32) | Drag this control to a relative X/Y offset.


DragTo(absolutePoint) method

HtmlControl.DragTo(absolutePoint) method
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlControl > DragTo(Point)
Drag this control to an absolute point.
Syntax
C#
public virtual void DragTo (
    Point absolutePoint
)
Parameters
absolutePoint (Point)
The absolut point.


DragTo(control) method

HtmlControl.DragTo(control) method
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlControl > DragTo(HtmlControl)
Drag this control to the center on the destination control.
Syntax
C#
public virtual void DragTo (
    HtmlControl control
)
Parameters
control (HtmlControl)
The destination control


DragTo(control, destinationOffsetReference, destinationOffset) method

HtmlControl.DragTo(control, destinationOffsetReference, destinationOffset) method
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlControl > DragTo(HtmlControl, OffsetReference, Point)
Drag to a destination control with an offset of where within the destination control to drag to.
Syntax
C#
public virtual void DragTo (
    HtmlControl control,
    OffsetReference destinationOffsetReference,
    Point destinationOffset
)
Parameters
control (HtmlControl)
The destination control.
destinationOffsetReference (OffsetReference)
The destination offset reference.
destinationOffset (Point)
The offset amount from reference.


DragTo(offsetX, offsetY) method

HtmlControl.DragTo(offsetX, offsetY) method
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlControl > DragTo(Int32, Int32)
Drag this control to a relative X/Y offset.
Syntax
C#
public virtual void DragTo (
    int offsetX,
    int offsetY
)
Parameters
offsetX (Int32)
The X offset. (negative to move left).
offsetY (Int32)
The Y offset. (negative to move up).


DragTo(sourceOffsetReference, sourceOffsetX, sourceOffsetY, destinationRectangle, destinationOffsetReference, destinationOffsetX, destinationOffsetY) method

HtmlControl.DragTo(sourceOffsetReference, sourceOffsetX, sourceOffsetY, destinationRectangle, destinationOffsetReference, destinationOffsetX, destinationOffsetY) method
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlControl > DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32)
Drag this control from a source offset to an X/Y offset from the source.
Syntax
C#
public virtual void DragTo (
    OffsetReference sourceOffsetReference,
    int sourceOffsetX,
    int sourceOffsetY,
    Rectangle destinationRectangle,
    OffsetReference destinationOffsetReference,
    int destinationOffsetX,
    int destinationOffsetY
)
Parameters
sourceOffsetReference (OffsetReference)
The source offset reference.
sourceOffsetX (Int32)
sourceOffsetY (Int32)
destinationRectangle (Rectangle)
destinationOffsetReference (OffsetReference)
destinationOffsetX (Int32)
The X offset from source.
destinationOffsetY (Int32)
The Y offset from source.


DragTo(sourceOffsetReference, sourceOffsetX, sourceOffsetY, sourcePixelDrag, destination, destinationOffsetReference, destinationOffsetX, destinationOffsetY, pixelDrop) method

HtmlControl.DragTo(sourceOffsetReference, sourceOffsetX, sourceOffsetY, sourcePixelDrag, destination, destinationOffsetReference, destinationOffsetX, destinationOffsetY, pixelDrop) method
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlControl > DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean)
Drag this control by specifying a reference point on the control rectangle to start the drag from and a reference point on the destination control to specify the drop location.
Syntax
C#
public virtual void DragTo (
    OffsetReference sourceOffsetReference,
    int sourceOffsetX,
    int sourceOffsetY,
    bool sourcePixelDrag,
    HtmlControl destination,
    OffsetReference destinationOffsetReference,
    int destinationOffsetX,
    int destinationOffsetY,
    bool pixelDrop
)
Parameters
sourceOffsetReference (OffsetReference)
The source offset reference of the drag start.
sourceOffsetX (Int32)
The offset X from the specified reference.
sourceOffsetY (Int32)
The offset Y from the specified reference.
sourcePixelDrag (Boolean)
destination (HtmlControl)
The destination control.
destinationOffsetReference (OffsetReference)
The destination offset reference of the drop.
destinationOffsetX (Int32)
The offset X from the specified destination reference
destinationOffsetY (Int32)
The offset Y from the specified destination reference
pixelDrop (Boolean)


DragTo(sourceOffsetReference, sourceOffset, destination) method

HtmlControl.DragTo(sourceOffsetReference, sourceOffset, destination) method
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlControl > DragTo(OffsetReference, Point, HtmlControl)
Drag this control by specifying a reference point on the control rectangle to start the drag from with an offset and drop on the destination control center.
Syntax
C#
public virtual void DragTo (
    OffsetReference sourceOffsetReference,
    Point sourceOffset,
    HtmlControl destination
)
Parameters
sourceOffsetReference (OffsetReference)
The source offset reference of the drag start.
sourceOffset (Point)
The offset from the specified reference.
destination (HtmlControl)
The destination control.


DragTo(sourceOffsetReference, sourceOffset, destinationOffsetX, destinationOffsetY) method

HtmlControl.DragTo(sourceOffsetReference, sourceOffset, destinationOffsetX, destinationOffsetY) method
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlControl > DragTo(OffsetReference, Point, Int32, Int32)
Drag this control from a source offset to an X/Y offset from the source.
Syntax
C#
public virtual void DragTo (
    OffsetReference sourceOffsetReference,
    Point sourceOffset,
    int destinationOffsetX,
    int destinationOffsetY
)
Parameters
sourceOffsetReference (OffsetReference)
The source offset reference.
sourceOffset (Point)
The source offset.
destinationOffsetX (Int32)
The X offset from source.
destinationOffsetY (Int32)
The Y offset from source.


DragTo(sourceOffsetReference, sourceOffset, destination, destinationOffsetReference, destinationOffset) method

HtmlControl.DragTo(sourceOffsetReference, sourceOffset, destination, destinationOffsetReference, destinationOffset) method
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlControl > DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point)
Drag this control by specifying a reference point on the control rectangle to start the drag from and a reference point on the destination control to specify the drop location.
Syntax
C#
public virtual void DragTo (
    OffsetReference sourceOffsetReference,
    Point sourceOffset,
    HtmlControl destination,
    OffsetReference destinationOffsetReference,
    Point destinationOffset
)
Parameters
sourceOffsetReference (OffsetReference)
The source offset reference of the drag start.
sourceOffset (Point)
The offset from the specified reference.
destination (HtmlControl)
The destination control.
destinationOffsetReference (OffsetReference)
The destination offset reference of the drop.
destinationOffset (Point)
The offset from the specified destination reference


DragToWindowLocation(sourceOffsetReference, sourceOffsetX, sourceOffsetY, sourcePixelDrag, windowOffset, windowOffsetX, windowOffsetY, pixelDrop) method

HtmlControl.DragToWindowLocation(sourceOffsetReference, sourceOffsetX, sourceOffsetY, sourcePixelDrag, windowOffset, windowOffsetX, windowOffsetY, pixelDrop) method
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlControl > DragToWindowLocation(OffsetReference, Int32, Int32, Boolean, OffsetReference, Int32, Int32, Boolean)
Drag this control, using the browser window as the drop target
Syntax
C#
public virtual void DragToWindowLocation (
    OffsetReference sourceOffsetReference,
    int sourceOffsetX,
    int sourceOffsetY,
    bool sourcePixelDrag,
    OffsetReference windowOffset,
    int windowOffsetX,
    int windowOffsetY,
    bool pixelDrop
)
Parameters
sourceOffsetReference (OffsetReference)
The source offset reference of the drag start.
sourceOffsetX (Int32)
The offset X from the specified reference.
sourceOffsetY (Int32)
The offset Y from the specified reference.
sourcePixelDrag (Boolean)
windowOffset (OffsetReference)
windowOffsetX (Int32)
windowOffsetY (Int32)
pixelDrop (Boolean)
If True, will use the windowOffsetX and windowOffsetY as the pixel drop point, if false will use windowOffsetX and windowOffsetY as a percentage for calculating the drop point.


Events property

HtmlControl.Events property
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlControl > Events
Events collection set on this control
Syntax
C#
public virtual NameValueCollection Events { get; }


FindParentContainer<TContainerControl>() method

HtmlControl.FindParentContainer<TContainerControl>() method
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlControl > FindParentContainer<(Of TContainerControl>)()
Traverses the DOM tree upwards until it finds the container element desired.
Syntax
C#
protected Element FindParentContainer<TContainerControl> () where TContainerControl : new(), HtmlContainerControl
Generic Template Parameters
TContainerControl
Return Value
The container element or element null.


GetAttributeAsString(attributeName) method

HtmlControl.GetAttributeAsString(attributeName) method
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlControl > GetAttributeAsString(String)
Get an attribute of this element as a string
Syntax
C#
protected string GetAttributeAsString (
    string attributeName
)
Parameters
attributeName (String)
The attribute name to get.
Return Value
The value of the attribute or a string.empty if the attribute is not available.


GetComputedStyle(style) method

HtmlControl.GetComputedStyle(style) method
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlControl > GetComputedStyle(String)
Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color)
Syntax
C#
public virtual HtmlStyle GetComputedStyle (
    string style
)
Parameters
style (String)
The style value.
Return Value
The HtmlStyle object that represents this style.


GetComputedStyleValue(style) method

HtmlControl.GetComputedStyleValue(style) method
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlControl > GetComputedStyleValue(String)
Returns computed style value. Computed style represents the final computed value of all CSS properties for the element.
Syntax
C#
public virtual string GetComputedStyleValue (
    string style
)
Parameters
style (String)
The style to access. i.e. backgroundColor, left, border
Return Value
The computed style.


GetRectangle() method

HtmlControl.GetRectangle() method
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlControl > GetRectangle()
The absolute screen position of the control.
Syntax
C#
public virtual Rectangle GetRectangle ()


GetStyle(style) method

HtmlControl.GetStyle(style) method
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlControl > GetStyle(String)
Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color)
Syntax
C#
public virtual HtmlStyle GetStyle (
    string style
)
Parameters
style (String)
The style value.
Return Value
The HtmlStyle object that represents this style.


GetStyleValue(style) method

HtmlControl.GetStyleValue(style) method
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlControl > GetStyleValue(String)
Returns any style as if you are accessing the element.style object from javascript.
Syntax
C#
public virtual string GetStyleValue (
    string style
)
Parameters
style (String)
The style to access. i.e. backgroundColor, border
Return Value
The style requested.


GetValue<T>(propertyName) method

HtmlControl.GetValue<T>(propertyName) method
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlControl > GetValue<(Of T>)(String)
Get a property value (i.e. control.border or control.style.backgroundColor). string s = myControl.GetValue<string>("style.backgroundColor")
Syntax
C#
public virtual T GetValue<T> (
    string propertyName
)
Generic Template Parameters
T
The type of the property.
Parameters
propertyName (String)
The property name.
Return Value
The value of the property.
Examples
myControl.GetValue<string>("style.backgroundColor")


ID property

HtmlControl.ID property
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlControl > ID
Control's ID if set.
Syntax
C#
public virtual string ID { get; }


InvokeEvent(eventType) method

HtmlControl.InvokeEvent(eventType) method
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlControl > InvokeEvent(ScriptEventType)
Invokes an event on this control
Syntax
C#
public virtual void InvokeEvent (
    ScriptEventType eventType
)
Parameters
eventType (ScriptEventType)
The event type to invoke.


IsVisible() method

HtmlControl.IsVisible() method
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlControl > IsVisible()
Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden'
Syntax
C#
public virtual bool IsVisible ()
Return Value
true/false whether this html control is visible on the page.


MouseClick methods

HtmlControl.MouseClick methods
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlControl > MouseClick
Members
Icon | Member | Description
 | MouseClick() | Uses the Desktop.Mouse object to move the mouse to this control and click it.
 | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to this control and click it.
 | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to this control and click it.
 | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to this control and click it.
 | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to this control and click it.


MouseClick() method

HtmlControl.MouseClick() method
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlControl > MouseClick()
Uses the Desktop.Mouse object to move the mouse to this control and click it.
Syntax
C#
public virtual void MouseClick ()


MouseClick(clicktType) method

HtmlControl.MouseClick(clicktType) method
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlControl > MouseClick(MouseClickType)
Uses the Desktop.Mouse object to move the mouse to this control and click it.
Syntax
C#
public virtual void MouseClick (
    MouseClickType clicktType
)
Parameters
clicktType (MouseClickType)
Mouse Click Type


MouseClick(clickType, offset, reference) method

HtmlControl.MouseClick(clickType, offset, reference) method
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlControl > MouseClick(MouseClickType, Point, OffsetReference)
Uses the Desktop.Mouse object to move the mouse to this control and click it.
Syntax
C#
public virtual void MouseClick (
    MouseClickType clickType,
    Point offset,
    OffsetReference reference
)
Parameters
clickType (MouseClickType)
Mouse Click Type
offset (Point)
Offset Point
reference (OffsetReference)
OffsetReference Enum


MouseClick(clickType, Xoffset, Yoffset, reference) method

HtmlControl.MouseClick(clickType, Xoffset, Yoffset, reference) method
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlControl > MouseClick(MouseClickType, Int32, Int32, OffsetReference)
Uses the Desktop.Mouse object to move the mouse to this control and click it.
Syntax
C#
public virtual void MouseClick (
    MouseClickType clickType,
    int Xoffset,
    int Yoffset,
    OffsetReference reference
)
Parameters
clickType (MouseClickType)
Mouse Click Type
Xoffset (Int32)
X
Yoffset (Int32)
Y
reference (OffsetReference)
OffsetReference Enum


MouseClick(clickType, x, y) method

HtmlControl.MouseClick(clickType, x, y) method
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlControl > MouseClick(MouseClickType, Int32, Int32)
Uses the Desktop.Mouse object to move the mouse to this control and click it.
Syntax
C#
public virtual void MouseClick (
    MouseClickType clickType,
    int x,
    int y
)
Parameters
clickType (MouseClickType)
Mouse Click Type
x (Int32)
X
y (Int32)
Y


MouseHover methods

HtmlControl.MouseHover methods
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlControl > MouseHover
Members
Icon | Member | Description
 | MouseHover() | Uses the Desktop.Mouse object to Hover over the control
 | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over the control
 | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over the control
 | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over the control


MouseHover() method

HtmlControl.MouseHover() method
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlControl > MouseHover()
Uses the Desktop.Mouse object to Hover over the control
Syntax
C#
public virtual void MouseHover ()


MouseHover(pointToHoverOver) method

HtmlControl.MouseHover(pointToHoverOver) method
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlControl > MouseHover(Point)
Uses the Desktop.Mouse object to Hover over the control
Syntax
C#
public virtual void MouseHover (
    Point pointToHoverOver
)
Parameters
pointToHoverOver (Point)
Hover Point


MouseHover(x, y) method

HtmlControl.MouseHover(x, y) method
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlControl > MouseHover(Int32, Int32)
Uses the Desktop.Mouse object to Hover over the control
Syntax
C#
public virtual void MouseHover (
    int x,
    int y
)
Parameters
x (Int32)
X
y (Int32)
Y


MouseHover(x, y, reference) method

HtmlControl.MouseHover(x, y, reference) method
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlControl > MouseHover(Int32, Int32, OffsetReference)
Uses the Desktop.Mouse object to Hover over the control
Syntax
C#
public virtual void MouseHover (
    int x,
    int y,
    OffsetReference reference
)
Parameters
x (Int32)
X
y (Int32)
Y
reference (OffsetReference)
OffsetReference Enum


Parent<TContainerControl>() method

HtmlControl.Parent<TContainerControl>() method
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlControl > Parent<(Of TContainerControl>)()
Return the parent HtmlContainerControl of desired type that this control is contained in. If control is not found, will return null.
Syntax
C#
public virtual TContainerControl Parent<TContainerControl> () where TContainerControl : new(), HtmlContainerControl
Generic Template Parameters
TContainerControl
The desired container control to return.
Return Value
The container control or null.


ScrollLeft property

HtmlControl.ScrollLeft property
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlControl > ScrollLeft
Gets/Sets the scrollLeft value of the html control.
Syntax
C#
[DebuggerBrowsableAttribute(DebuggerBrowsableState.Never)]
public virtual int ScrollLeft { get; set; }


ScrollTop property

HtmlControl.ScrollTop property
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlControl > ScrollTop
Gets/Sets the scrollTop value of the html control
Syntax
C#
[DebuggerBrowsableAttribute(DebuggerBrowsableState.Never)]
public virtual int ScrollTop { get; set; }


ScrollToVisible(scrollToVisibleType) method

HtmlControl.ScrollToVisible(scrollToVisibleType) method
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlControl > ScrollToVisible(ScrollToVisibleType)
Scroll control to Visible Position on the page
Syntax
C#
public virtual void ScrollToVisible (
    ScrollToVisibleType scrollToVisibleType
)
Parameters
scrollToVisibleType (ScrollToVisibleType)
ScrollToVisibleType Enum


SetValue<T>(propertyName, value) method

HtmlControl.SetValue<T>(propertyName, value) method
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlControl > SetValue<(Of T>)(String, T)
Set a property value. (i.e. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red")
Syntax
C#
public virtual void SetValue<T> (
    string propertyName,
    T value
)
Generic Template Parameters
T
The type of the property.
Parameters
propertyName (String)
The property name.
value (T)
The value to set.
Examples
myControl.SetValue<string>("style.backgroundColor","red")


Styles property

HtmlControl.Styles property
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlControl > Styles
Styles collection set on this control and persisted in the Html stream. This collection does not contain computed styles.
Syntax
C#
public virtual NameValueCollection Styles { get; }


TagName property

HtmlControl.TagName property
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlControl > TagName
The tag name of this element
Syntax
C#
public virtual string TagName { get; }


ValidateControl() method

HtmlControl.ValidateControl() method
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlControl > ValidateControl()
Validate a control using a its Locator.
Syntax
C#
protected void ValidateControl ()


ValidateTag(tagName) method

HtmlControl.ValidateTag(tagName) method
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlControl > ValidateTag(String)
Validate a tag name
Syntax
C#
protected void ValidateTag (
    string tagName
)
Parameters
tagName (String)
The tagName to verify.


Wait property

HtmlControl.Wait property
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlControl > Wait
Gets the HTML Wait object.
Syntax
C#
public virtual HtmlWait Wait { get; }


HtmlControlsAssertExtensions class

HtmlControlsAssertExtensions class
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlControlsAssertExtensions
Assert extensions for the HtmlControl class.
Syntax
C#
[ExtensionAttribute]
public static class HtmlControlsAssertExtensions
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AssertAttribute(HtmlControl) | Assert methods for the control attributes.
 | AssertContent(HtmlControl) | Assert methods for the control content.
 | AssertStyle(HtmlControl) | Assert methods for the control style.
Inheritance Hierarchy
Object
HtmlControlsAssertExtensions


AssertAttribute(control) method

HtmlControlsAssertExtensions.AssertAttribute(control) method
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlControlsAssertExtensions > AssertAttribute(HtmlControl)
Assert methods for the control attributes.
Syntax
C#
[ExtensionAttribute]
public static AssertAttribute AssertAttribute (
    HtmlControl control
)
Parameters
control (HtmlControl)
Return Value


AssertContent(control) method

HtmlControlsAssertExtensions.AssertContent(control) method
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlControlsAssertExtensions > AssertContent(HtmlControl)
Assert methods for the control content.
Syntax
C#
[ExtensionAttribute]
public static AssertContent AssertContent (
    HtmlControl control
)
Parameters
control (HtmlControl)
Return Value


AssertStyle(control) method

HtmlControlsAssertExtensions.AssertStyle(control) method
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlControlsAssertExtensions > AssertStyle(HtmlControl)
Assert methods for the control style.
Syntax
C#
[ExtensionAttribute]
public static AssertStyle AssertStyle (
    HtmlControl control
)
Parameters
control (HtmlControl)
Return Value


HtmlDiv class

HtmlDiv class
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlDiv
Test class for an HtmlDiv element <div>...</div>
Syntax
C#
public class HtmlDiv : HtmlContainerControl
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | HtmlDivNew() | Create a new control.
 | HtmlDivNew(Element) | Create a new test control
 | AssignElement(Element) | Assign element and initialize this control. (Overrides HtmlContainerControl.AssignElement(Element).)
 | AssignFailed(Exception) | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
 | Attributes | All attributes set on this control (Inherited from HtmlControl.)
 | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
 | Capture() | Captures and returns the image of the current Html Control. (Inherited from HtmlControl.)
 | Capture(String) | Captures and saves Html Control Image to the WebAii log location as a bmp file. (Inherited from HtmlControl.)
 | Capture(String, String) | Captures and saves Html Control Image to the specified save path as the specified image name in bmp format. (Inherited from HtmlControl.)
 | Click() | Invoke a click within the loaded page. (Inherited from HtmlControl.)
 | Click(Boolean) | Invoke a click that causes that browser window to close (i.e. this is common for html pop-ups) (Inherited from HtmlControl.)
 | CssClass | Control's CSS class if set. (Inherited from HtmlControl.)
 | Download(Boolean, DownloadOption, String, Int32) | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
 | DragTo(HtmlControl) | Drag this control to the center on the destination control. (Inherited from HtmlControl.)
 | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination control with an offset of where within the destination control to drag to. (Inherited from HtmlControl.)
 | DragTo(Int32, Int32) | Drag this control to a relative X/Y offset. (Inherited from HtmlControl.)
 | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this control by specifying a reference point on the control rectangle to start the drag from and a reference point on the destination control to specify the drop location. (Inherited from HtmlControl.)
 | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this control from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
 | DragTo(OffsetReference, Point, HtmlControl) | Drag this control by specifying a reference point on the control rectangle to start the drag from with an offset and drop on the destination control center. (Inherited from HtmlControl.)
 | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this control by specifying a reference point on the control rectangle to start the drag from and a reference point on the destination control to specify the drop location. (Inherited from HtmlControl.)
 | DragTo(OffsetReference, Point, Int32, Int32) | Drag this control from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
 | DragTo(Point) | Drag this control to an absolute point. (Inherited from HtmlControl.)
 | DragToWindowLocation(OffsetReference, Int32, Int32, Boolean, OffsetReference, Int32, Int32, Boolean) | Drag this control, using the browser window as the drop target (Inherited from HtmlControl.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Events collection set on this control (Inherited from HtmlControl.)
 | Finalize() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Find | Find property (Inherited from HtmlContainerControl.)
 | FindParentContainer<(Of TContainerControl>)() | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
 | GetAttributeAsString(String) | Get an attribute of this element as a string (Inherited from HtmlControl.)
 | GetComputedStyle(String) | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
 | GetComputedStyleValue(String) | Returns computed style value. Computed style represents the final computed value of all CSS properties for the element. (Inherited from HtmlControl.)
 | GetHashCode() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetRectangle() | The absolute screen position of the control. (Inherited from HtmlControl.)
 | GetStyle(String) | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
 | GetStyleValue(String) | Returns any style as if you are accessing the element.style object from javascript. (Inherited from HtmlControl.)
 | GetType() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue<(Of T>)(String) | Get a property value (i.e. control.border or control.style.backgroundColor). string s = myControl.GetValue<string>("style.backgroundColor") (Inherited from HtmlControl.)
 | ID | Control's ID if set. (Inherited from HtmlControl.)
 | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
 | InvokeEvent(ScriptEventType) | Invokes an event on this control (Inherited from HtmlControl.)
 | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
 | IsVisible() | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
 | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
 | MemberwiseClone() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MouseClick() | Uses the Desktop.Mouse object to move the mouse to this control and click it. (Inherited from HtmlControl.)
 | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to this control and click it. (Inherited from HtmlControl.)
 | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to this control and click it. (Inherited from HtmlControl.)
 | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to this control and click it. (Inherited from HtmlControl.)
 | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to this control and click it. (Inherited from HtmlControl.)
 | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over the control (Inherited from HtmlControl.)
 | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over the control (Inherited from HtmlControl.)
 | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over the control (Inherited from HtmlControl.)
 | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
 | Parent<(Of TContainerControl>)() | Return the parent HtmlContainerControl of desired type that this control is contained in. If control is not found, will return null. (Inherited from HtmlControl.)
 | Refresh() | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
 | ScrollLeft | Gets/Sets the scrollLeft value of the html control. (Inherited from HtmlControl.)
 | ScrollTop | Gets/Sets the scrollTop value of the html control (Inherited from HtmlControl.)
 | ScrollToVisible(ScrollToVisibleType) | Scroll control to Visible Position on the page (Inherited from HtmlControl.)
 | SetValue<(Of T>)(String, T) | Set a property value. (i.e. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
 | Styles | Styles collection set on this control and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
 | TagName | The tag name of this element (Inherited from HtmlControl.)
 | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
 | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
 | ToString() | Returns a String that represents the current Object. (Inherited from Object.)
 | ValidateControl() | Validate a control using a its Locator. (Inherited from HtmlControl.)
 | ValidateTag(String) | Validate a tag name (Inherited from HtmlControl.)
 | Wait | Gets the HTML Wait object. (Inherited from HtmlControl.)
Inheritance Hierarchy
Object
 | Control
 |  | HtmlControl
 |  |  | HtmlContainerControl
 |  |  |  | HtmlDiv


AssignElement(e) method

HtmlDiv.AssignElement(e) method
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlDiv > AssignElement(Element)
Assign element and initialize this control.
Syntax
C#
public override void AssignElement (
    Element e
)
Parameters
e (Element)
The base element.


Constructors

HtmlDiv constructors
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlDiv > HtmlDivNew
Members
Icon | Member | Description
 | HtmlDivNew() | Create a new control.
 | HtmlDivNew(Element) | Create a new test control


HtmlDiv() constructor

HtmlDiv() constructor
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlDiv > HtmlDivNew()
Create a new control.
Syntax
C#
public HtmlDiv ()


HtmlDiv(e) constructor

HtmlDiv(e) constructor
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlDiv > HtmlDivNew(Element)
Create a new test control
Syntax
C#
public HtmlDiv (
    Element e
)
Parameters
e (Element)
The base element.


HtmlFind class

HtmlFind class
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlFind
Extends the generic Find methods to include HTML specific find objects.
Syntax
C#
public class HtmlFind : Find
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon Member Description
HtmlFindNew(Element)
Create a new Find object.
All() Obsolete.
Find all elements set using FindParamAttributes on method/class.
(Inherited from Find.)
All(Boolean) Obsolete.
Find all elements set using FindParamAttributes.
(Inherited from Find.)
AllByAttributes(String[]())
Returns a list of elements that have attributes that match the NameValuePairs passed it fully or partially.
(Inherited from Find.)
AllByContent(String)
Returns a list of elements that have TextContent that match the specified content The content must start with: 'l:' for exact match strings, 'p:' for partial strings or 'x:' for regular expression matches. If none are provided, the string will be matched using an exact match 'l:'. All searches are case-insensitive.
Examples
To find tags with TextContent of: 'foo bar' Example 1: ByContent("l:foo bar"); Example 2: ByContent("p:foo"); Example 3: ByContent("x:[*foo*]");
The TextContent to match
Remarks
There is a difference between FindContentType.InnerText and FindContentType.TextContent that is worth noting: Example:
Text1
Text2
InnerText for div1 : Text1Text2 {recursive} TextContent of div1 : Text1 {non-recursive} Default for ByContent is TextContent which is the most common usage.
(Inherited from Find.)
AllByContent(String, FindContentType)
Returns a list of elements that match the specified content. The content must start with: 'l:' for exact match strings, 'p:' for partial strings or 'x:' for regular expression matches. If none are provided, the string will be matched using an exact match 'l:'. All searches are case-insensitive.
Examples
To find tags with TextContent of: 'foo bar' Example 1: ByContent("l:foo bar"); Example 2: ByContent("p:foo"); Example 3: ByContent("x:[*foo*]");
Remarks
There is a difference between FindContentType.InnerText and FindContentType.TextContent that is worth noting: Example:
Text1
Text2
InnerText for div1 : Text1Text2 {recursive} TextContent of div1 : Text1 {non-recursive} Default for ByContent is TextContent which is the most common usage.
(Inherited from Find.)
AllByCustom<(Of TControl>)(Predicate<(Of TControl>))
Returns all controls that match the predicate and are convertable to TControl.
(Inherited from Find.)
AllByCustom(Predicate<(Of Element>))
Return all elements that match the predicate
(Inherited from Find.)
AllByParam(FindParam)
Returns a list of elements that match the specified FindParam. Note that this method does not support FindParam.Type=NodePathIndex.
(Inherited from Find.)
AllByTagName(String)
Returns a list of elements with a specific tag name.
(Inherited from Find.)
AllByXPath(String)
Returns a list of elements that match the specified XPath. This function supports the System.Xml XPath syntax.
(Inherited from Find.)
AllControls<(Of TControl>)()
Gets an IEnmerable for TControl to be used for LINQ queries. This will return only elements that are convertable to TControl
(Inherited from Find.)
AllElements()
Gets a IEnumerable for all elements to be used for LINQ queries
(Inherited from Find.)
AssociatedBrowser
Gets the browser object that is associated with this find object. If this property is null, then the Find object is associated with a search region.
(Inherited from Find.)
ByAttributes(String[]())
Returns a an element that has attributes that match the NameValuePairs passed it. All matching is case-insensitive.
(Inherited from Find.)
ByContent(String)
Returns an element by searching its TextContent. The content must start with: 'l:' for exact match strings, 'p:' for partial strings or 'x:' for regular expression matches. If none are provided, the string will be matched using an exact match 'l:'. All searches are case-insensitive.
Examples
To find tags with innerText content is: 'foo bar' Example 1: ByContent("l:foo bar"); Example 2: ByContent("p:foo"); Example 3: ByContent("x:[*foo*]");
(Inherited from Find.)
ByContent(String, FindContentType)
Returns an element by searching its content with the options to pick the content type. (InnerText, InnerMarkup or OuterMarkup) The content must start with: 'l:' for exact match strings, 'p:' for partial strings or 'x:' for regular expression matches. If none are provided, the string will be matched using an exact match 'l:'. All searches are case-insensitive.
Examples
Similar to Find.ByContent(string) with the option to specify the content type: Example 1: ByContent("l:foo bar",FindContentType.InnerText); Example 2: ByContent("p:<foo id="f" />",FindContent.OuterMarkup);
Remarks
There is a difference between FindContentType.InnerText and FindContentType.TextContent that is worth noting: Example:
Text1
Text2
InnerText for div1 : Text1Text2 {recursive} TextContent of div1 : Text1 {non-recursive} Default for ByContent is TextContent which is the most common usage.
(Inherited from Find.)
ByContent(String, FindContentType, String[]())
Returns an element by searching its content with the options to pick the content type. (InnerText, InnerMarkup or OuterMarkup) in addition to a list of attributes. The content must start with: 'l:' for exact match strings, 'p:' for partial strings or 'x:' for regular expression matches. If none are provided, the string will be matched using an exact match 'l:'. All searches are case-insensitive.
Examples
Similar to Find.ByContent(string) with the option to specify the content type: Example 1: ByContent("l:foo bar",FindContentType.InnerText); Example 2: ByContent("p:<foo id="f" />",FindContent.OuterMarkup);
Remarks
There is a difference between FindContentType.InnerText and FindContentType.TextContent that is worth noting: Example:
Text1
Text2
InnerText for div1 : Text1Text2 {recursive} TextContent of div1 : Text1 {non-recursive} Default for ByContent is TextContent which is the most common usage.
(Inherited from Find.)
ByCustom<(Of TControl>)(Predicate<(Of TControl>))
Get a control by using custom predicate. This function will try to eliminate any elements that are not convertable to TControl type.
(Inherited from Find.)
ByCustom(Predicate<(Of Element>))
Return the element that matches the defined predicate
(Inherited from Find.)
ById(String)
Returns an element by looking for its 'id' attribute value.
(Inherited from Find.)
ByName(String)
Returns an element by searching for its 'name' attribute value
(Inherited from Find.)
ByNodeIndexPath(String)
Returns an element by searching for it using a node index path.
Examples
  For example:

  This call: ByNodeIndexPath("0/2/0/1") describes the <target></target> element in the below hierarchy:

  <referenceElement>
   (0)<foo>
          <bar>
          </bar>
          <car>
          </car>
       (2)<bus>
           (0)<driver>
                  <cap>
                  </cap>
               (1)<target>
                  </target>
              </driver>
          </bus>
      </foo>
  </referenceElement>

(Inherited from Find.)
ByParam(FindParam)
Return an element using a FindParam
(Inherited from Find.)
ByParam(FindParam[]())
Returns an element using a chained identification.
(Inherited from Find.)
ByTagIndex(String, Int32)
Returns an element by its tag name occrrence.
(Inherited from Find.)
ByXPath(String)
Returns an element using an XPath. This function supports the System.Xml XPath syntax.
(Inherited from Find.)
Elements Obsolete.
Found elements from FindParam attributes set on the class or method. If the Find.All() method has not been called, then accessing this dictionary will call Find.All() before returning the dictionary items.
(Inherited from Find.)
Equals(Object)
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Finalize()
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
FindReferenceType
Gets the reference type that this Find object is using. (i.e. browser root, testregion ... etc)
(Inherited from Find.)
FromCollection(FindParamCollection)
Finds all elements with the FindParams in the passed in collection.
(Inherited from Find.)
FromFile(String)
Finds all elements with FindParams defined in a file. Found elements can be accessed from Find.Elements
(Inherited from Find.)
FromXml(String)
Finds all elements with FindParams defined in the serialized xml string. Found elements can be accessed from Find.Elements
(Inherited from Find.)
GetHashCode()
Serves as a hash function for a particular type.
(Inherited from Object.)
GetType()
Gets the Type of the current instance.
(Inherited from Object.)
IgnoreFindAllControlMismatch
Gets/Sets whether to ignore Find.Allxx<TControl>(...) elements that don't match the TControl specified. (i.e. the TControl type validation fails for that element). If false, the Find.Allxx method will throw an exception.
(Inherited from Find.)
LastSearchLog
Gets the search log for the last find attempt. This log can help diagnose when find fails to locate an element.
(Inherited from Find.)
MemberwiseClone()
Creates a shallow copy of the current Object.
(Inherited from Object.)
ReturnedNullOrEmpty
Invoked when one of the find methods returns null or an empty list of elements.
(Inherited from Find.)
SearchRegion
Gets the search region for this Find object. When this is set to a specific region, all search is done locale to that region. All indexes are calculated starting at zero from this region's element. If this property is null, then the Find object will perform all searches from the document root element.
(Inherited from Find.)
SearchRootElement
Gets/Sets the root element that all searches will be performed under. This element depended on the reference type. [Browser/TestRegion/Element].
(Inherited from Find.)
Table(String)
Finds the first table that contains the cell text content specified.
TableCell(String)
Finds the first table cell that contains the text content specified. If the text is contained by a control inside that table cell, this method will not find that cell.
TableRow(String)
Finds the first table row that contains the cell text content specified.
ThrowIfNullOrEmpty
Gets/Sets whether to throw an exception if any of the find methods returns a null element or any of the find all methods return empty list of elements.
(Inherited from Find.)
ToString()
Returns a String that represents the current Object.
(Inherited from Object.)
Inheritance Hierarchy
Object
 | Find
 |  | HtmlFind


HtmlFind(rootElement) constructor

HtmlFind(rootElement) constructor
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlFind > HtmlFindNew(Element)
Create a new Find object.
Syntax
C#
public HtmlFind (
    Element rootElement
)
Parameters
rootElement (Element)


Table(textContent) method

HtmlFind.Table(textContent) method
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlFind > Table(String)
Finds the first table that contains the cell text content specified.
Syntax
C#
public HtmlTable Table (
    string textContent
)
Parameters
textContent (String)
The cell text content to find..
Return Value
The HtmlTable that contains that text, else null


TableCell(textContent) method

HtmlFind.TableCell(textContent) method
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlFind > TableCell(String)
Finds the first table cell that contains the text content specified. If the text is contained by a control inside that table cell, this method will not find that cell.
Syntax
C#
public HtmlTableCell TableCell (
    string textContent
)
Parameters
textContent (String)
The text content.
Return Value
The HtmlTableCell that contains that text, else null.


TableRow(textContent) method

HtmlFind.TableRow(textContent) method
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlFind > TableRow(String)
Finds the first table row that contains the cell text content specified.
Syntax
C#
public HtmlTableRow TableRow (
    string textContent
)
Parameters
textContent (String)
The text content.
Return Value
The HtmlTableRow that contains that text, else null


HtmlForm class

HtmlForm class
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlForm
Test class for an HtmlForm element <form >...</form>
Syntax
C#
public class HtmlForm : HtmlContainerControl
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | HtmlFormNew() | Create a new control.
 | HtmlFormNew(Element) | Create a new control.
 | AssignElement(Element) | Assign element and initialize this control. (Overrides HtmlContainerControl.AssignElement(Element).)
 | AssignFailed(Exception) | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
 | Attributes | All attributes set on this control (Inherited from HtmlControl.)
 | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
 | Capture() | Captures and returns the image of the current Html Control. (Inherited from HtmlControl.)
 | Capture(String) | Captures and saves Html Control Image to the WebAii log location as a bmp file. (Inherited from HtmlControl.)
 | Capture(String, String) | Captures and saves Html Control Image to the specified save path as the specified image name in bmp format. (Inherited from HtmlControl.)
 | Click() | Invoke a click within the loaded page. (Inherited from HtmlControl.)
 | Click(Boolean) | Invoke a click that causes that browser window to close (i.e. this is common for html pop-ups) (Inherited from HtmlControl.)
 | CssClass | Control's CSS class if set. (Inherited from HtmlControl.)
 | Download(Boolean, DownloadOption, String, Int32) | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
 | DragTo(HtmlControl) | Drag this control to the center on the destination control. (Inherited from HtmlControl.)
 | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination control with an offset of where within the destination control to drag to. (Inherited from HtmlControl.)
 | DragTo(Int32, Int32) | Drag this control to a relative X/Y offset. (Inherited from HtmlControl.)
 | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this control by specifying a reference point on the control rectangle to start the drag from and a reference point on the destination control to specify the drop location. (Inherited from HtmlControl.)
 | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this control from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
 | DragTo(OffsetReference, Point, HtmlControl) | Drag this control by specifying a reference point on the control rectangle to start the drag from with an offset and drop on the destination control center. (Inherited from HtmlControl.)
 | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this control by specifying a reference point on the control rectangle to start the drag from and a reference point on the destination control to specify the drop location. (Inherited from HtmlControl.)
 | DragTo(OffsetReference, Point, Int32, Int32) | Drag this control from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
 | DragTo(Point) | Drag this control to an absolute point. (Inherited from HtmlControl.)
 | DragToWindowLocation(OffsetReference, Int32, Int32, Boolean, OffsetReference, Int32, Int32, Boolean) | Drag this control, using the browser window as the drop target (Inherited from HtmlControl.)
 | EncType | Gets the MIME type used to encode the content of a form.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Events collection set on this control (Inherited from HtmlControl.)
 | Finalize() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Find | Find property (Inherited from HtmlContainerControl.)
 | FindParentContainer<(Of TContainerControl>)() | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
 | GetAttributeAsString(String) | Get an attribute of this element as a string (Inherited from HtmlControl.)
 | GetComputedStyle(String) | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
 | GetComputedStyleValue(String) | Returns computed style value. Computed style represents the final computed value of all CSS properties for the element. (Inherited from HtmlControl.)
 | GetHashCode() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetRectangle() | The absolute screen position of the control. (Inherited from HtmlControl.)
 | GetStyle(String) | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
 | GetStyleValue(String) | Returns any style as if you are accessing the element.style object from javascript. (Inherited from HtmlControl.)
 | GetType() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue<(Of T>)(String) | Get a property value (i.e. control.border or control.style.backgroundColor). string s = myControl.GetValue<string>("style.backgroundColor") (Inherited from HtmlControl.)
 | ID | Control's ID if set. (Inherited from HtmlControl.)
 | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
 | InvokeEvent(ScriptEventType) | Invokes an event on this control (Inherited from HtmlControl.)
 | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
 | IsVisible() | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
 | Length | Gets the number of elements in a form.
 | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
 | MemberwiseClone() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MouseClick() | Uses the Desktop.Mouse object to move the mouse to this control and click it. (Inherited from HtmlControl.)
 | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to this control and click it. (Inherited from HtmlControl.)
 | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to this control and click it. (Inherited from HtmlControl.)
 | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to this control and click it. (Inherited from HtmlControl.)
 | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to this control and click it. (Inherited from HtmlControl.)
 | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over the control (Inherited from HtmlControl.)
 | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over the control (Inherited from HtmlControl.)
 | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over the control (Inherited from HtmlControl.)
 | Name | Gets the name of a form.
 | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
 | Parent<(Of TContainerControl>)() | Return the parent HtmlContainerControl of desired type that this control is contained in. If control is not found, will return null. (Inherited from HtmlControl.)
 | Refresh() | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
 | ScrollLeft | Gets/Sets the scrollLeft value of the html control. (Inherited from HtmlControl.)
 | ScrollTop | Gets/Sets the scrollTop value of the html control (Inherited from HtmlControl.)
 | ScrollToVisible(ScrollToVisibleType) | Scroll control to Visible Position on the page (Inherited from HtmlControl.)
 | SetValue<(Of T>)(String, T) | Set a property value. (i.e. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
 | Styles | Styles collection set on this control and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
 | TagName | The tag name of this element (Inherited from HtmlControl.)
 | Target | Gets where to open the action-URL in a form.
 | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
 | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
 | ToString() | Returns a String that represents the current Object. (Inherited from Object.)
 | ValidateControl() | Validate a control using a its Locator. (Inherited from HtmlControl.)
 | ValidateTag(String) | Validate a tag name (Inherited from HtmlControl.)
 | Wait | Gets the HTML Wait object. (Inherited from HtmlControl.)
Inheritance Hierarchy
Object
 | Control
 |  | HtmlControl
 |  |  | HtmlContainerControl
 |  |  |  | HtmlForm


AssignElement(e) method

HtmlForm.AssignElement(e) method
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlForm > AssignElement(Element)
Assign element and initialize this control.
Syntax
C#
public override void AssignElement (
    Element e
)
Parameters
e (Element)
The base element.


Constructors

HtmlForm constructors
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlForm > HtmlFormNew
Members
Icon | Member | Description
 | HtmlFormNew() | Create a new control.
 | HtmlFormNew(Element) | Create a new control.


HtmlForm() constructor

HtmlForm() constructor
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlForm > HtmlFormNew()
Create a new control.
Syntax
C#
public HtmlForm ()


HtmlForm(element) constructor

HtmlForm(element) constructor
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlForm > HtmlFormNew(Element)
Create a new control.
Syntax
C#
public HtmlForm (
    Element element
)
Parameters
element (Element)
The base element.


EncType property

HtmlForm.EncType property
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlForm > EncType
Gets the MIME type used to encode the content of a form.
Syntax
C#
public string EncType { get; }


Length property

HtmlForm.Length property
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlForm > Length
Gets the number of elements in a form.
Syntax
C#
public int Length { get; }


Name property

HtmlForm.Name property
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlForm > Name
Gets the name of a form.
Syntax
C#
public string Name { get; }


Target property

HtmlForm.Target property
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlForm > Target
Gets where to open the action-URL in a form.
Syntax
C#
public string Target { get; }


HtmlImage class

HtmlImage class
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlImage
Test class for an HtmlImage element <img src="..." />
Syntax
C#
public class HtmlImage : HtmlControl
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | HtmlImageNew() | Create a new control.
 | HtmlImageNew(Element) | Create a new control.
 | Align | A string that specifies the alignment of the image relative to other Web page elements.
 | Alt | A string that contains the alternative caption for the browser to use when the image is unavailable.
 | AssignElement(Element) | Assign element and initialize this control. (Overrides HtmlControl.AssignElement(Element).)
 | AssignFailed(Exception) | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
 | Attributes | All attributes set on this control (Inherited from HtmlControl.)
 | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
 | Border | The width (in pixels) of a frame for an image.
 | Capture() | Captures and returns the image of the current Html Control. (Inherited from HtmlControl.)
 | Capture(String) | Captures and saves Html Control Image to the WebAii log location as a bmp file. (Inherited from HtmlControl.)
 | Capture(String, String) | Captures and saves Html Control Image to the specified save path as the specified image name in bmp format. (Inherited from HtmlControl.)
 | Click() | Invoke a click within the loaded page. (Inherited from HtmlControl.)
 | Click(Boolean) | Invoke a click that causes that browser window to close (i.e. this is common for html pop-ups) (Inherited from HtmlControl.)
 | CssClass | Control's CSS class if set. (Inherited from HtmlControl.)
 | Download(Boolean, DownloadOption, String, Int32) | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
 | DragTo(HtmlControl) | Drag this control to the center on the destination control. (Inherited from HtmlControl.)
 | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination control with an offset of where within the destination control to drag to. (Inherited from HtmlControl.)
 | DragTo(Int32, Int32) | Drag this control to a relative X/Y offset. (Inherited from HtmlControl.)
 | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this control by specifying a reference point on the control rectangle to start the drag from and a reference point on the destination control to specify the drop location. (Inherited from HtmlControl.)
 | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this control from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
 | DragTo(OffsetReference, Point, HtmlControl) | Drag this control by specifying a reference point on the control rectangle to start the drag from with an offset and drop on the destination control center. (Inherited from HtmlControl.)
 | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this control by specifying a reference point on the control rectangle to start the drag from and a reference point on the destination control to specify the drop location. (Inherited from HtmlControl.)
 | DragTo(OffsetReference, Point, Int32, Int32) | Drag this control from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
 | DragTo(Point) | Drag this control to an absolute point. (Inherited from HtmlControl.)
 | DragToWindowLocation(OffsetReference, Int32, Int32, Boolean, OffsetReference, Int32, Int32, Boolean) | Drag this control, using the browser window as the drop target (Inherited from HtmlControl.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Events collection set on this control (Inherited from HtmlControl.)
 | Finalize() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindParentContainer<(Of TContainerControl>)() | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
 | GetAttributeAsString(String) | Get an attribute of this element as a string (Inherited from HtmlControl.)
 | GetComputedStyle(String) | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
 | GetComputedStyleValue(String) | Returns computed style value. Computed style represents the final computed value of all CSS properties for the element. (Inherited from HtmlControl.)
 | GetHashCode() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetRectangle() | The absolute screen position of the control. (Inherited from HtmlControl.)
 | GetStyle(String) | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
 | GetStyleValue(String) | Returns any style as if you are accessing the element.style object from javascript. (Inherited from HtmlControl.)
 | GetType() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue<(Of T>)(String) | Get a property value (i.e. control.border or control.style.backgroundColor). string s = myControl.GetValue<string>("style.backgroundColor") (Inherited from HtmlControl.)
 | Height | The height of the image.
 | ID | Control's ID if set. (Inherited from HtmlControl.)
 | InvokeEvent(ScriptEventType) | Invokes an event on this control (Inherited from HtmlControl.)
 | IsLoaded() | Gets whether the image loaded or not.
 | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
 | IsVisible() | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
 | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
 | MemberwiseClone() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MouseClick() | Uses the Desktop.Mouse object to move the mouse to this control and click it. (Inherited from HtmlControl.)
 | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to this control and click it. (Inherited from HtmlControl.)
 | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to this control and click it. (Inherited from HtmlControl.)
 | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to this control and click it. (Inherited from HtmlControl.)
 | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to this control and click it. (Inherited from HtmlControl.)
 | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over the control (Inherited from HtmlControl.)
 | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over the control (Inherited from HtmlControl.)
 | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over the control (Inherited from HtmlControl.)
 | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
 | Parent<(Of TContainerControl>)() | Return the parent HtmlContainerControl of desired type that this control is contained in. If control is not found, will return null. (Inherited from HtmlControl.)
 | Refresh() | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
 | ScrollLeft | Gets/Sets the scrollLeft value of the html control. (Inherited from HtmlControl.)
 | ScrollTop | Gets/Sets the scrollTop value of the html control (Inherited from HtmlControl.)
 | ScrollToVisible(ScrollToVisibleType) | Scroll control to Visible Position on the page (Inherited from HtmlControl.)
 | SetValue<(Of T>)(String, T) | Set a property value. (i.e. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
 | Src | A string that contains the path to an image file to display.
 | Styles | Styles collection set on this control and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
 | TagName | The tag name of this element (Inherited from HtmlControl.)
 | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
 | ToString() | Returns a String that represents the current Object. (Inherited from Object.)
 | ValidateControl() | Validate a control using a its Locator. (Inherited from HtmlControl.)
 | ValidateTag(String) | Validate a tag name (Inherited from HtmlControl.)
 | Wait | Gets the HTML Wait object. (Inherited from HtmlControl.)
 | Width | The width of the image.
Inheritance Hierarchy
Object
 | Control
 |  | HtmlControl
 |  |  | HtmlImage


Align property

HtmlImage.Align property
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlImage > Align
A string that specifies the alignment of the image relative to other Web page elements.
Syntax
C#
public string Align { get; }


Alt property

HtmlImage.Alt property
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlImage > Alt
A string that contains the alternative caption for the browser to use when the image is unavailable.
Syntax
C#
public string Alt { get; }


AssignElement(e) method

HtmlImage.AssignElement(e) method
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlImage > AssignElement(Element)
Assign element and initialize this control.
Syntax
C#
public override void AssignElement (
    Element e
)
Parameters
e (Element)
The base element.


Border property

HtmlImage.Border property
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlImage > Border
The width (in pixels) of a frame for an image.
Syntax
C#
public string Border { get; }


Constructors

HtmlImage constructors
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlImage > HtmlImageNew
Members
Icon | Member | Description
 | HtmlImageNew() | Create a new control.
 | HtmlImageNew(Element) | Create a new control.


HtmlImage() constructor

HtmlImage() constructor
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlImage > HtmlImageNew()
Create a new control.
Syntax
C#
public HtmlImage ()


HtmlImage(element) constructor

HtmlImage(element) constructor
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlImage > HtmlImageNew(Element)
Create a new control.
Syntax
C#
public HtmlImage (
    Element element
)
Parameters
element (Element)
The base element.


Height property

HtmlImage.Height property
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlImage > Height
The height of the image.
Syntax
C#
public string Height { get; }


IsLoaded() method

HtmlImage.IsLoaded() method
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlImage > IsLoaded()
Gets whether the image loaded or not.
Syntax
C#
public bool IsLoaded ()
Return Value
Returns true/false whether the image has actually loaded or not on the page.


Src property

HtmlImage.Src property
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlImage > Src
A string that contains the path to an image file to display.
Syntax
C#
public string Src { get; }


Width property

HtmlImage.Width property
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlImage > Width
The width of the image.
Syntax
C#
public string Width { get; }


HtmlInputButton class

HtmlInputButton class
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlInputButton
Test class for an HtmlInputButton element <input type="button" />
Syntax
C#
public class HtmlInputButton : HtmlInputControl
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | HtmlInputButtonNew() | Create a new control.
 | HtmlInputButtonNew(Element) | Create a new control.
 | AssignElement(Element) | Assign element and initialize this control. (Overrides HtmlInputControl.AssignElement(Element).)
 | AssignFailed(Exception) | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
 | Attributes | All attributes set on this control (Inherited from HtmlControl.)
 | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
 | Capture() | Captures and returns the image of the current Html Control. (Inherited from HtmlControl.)
 | Capture(String) | Captures and saves Html Control Image to the WebAii log location as a bmp file. (Inherited from HtmlControl.)
 | Capture(String, String) | Captures and saves Html Control Image to the specified save path as the specified image name in bmp format. (Inherited from HtmlControl.)
 | Click() | Invoke a click within the loaded page. (Inherited from HtmlControl.)
 | Click(Boolean) | Invoke a click that causes that browser window to close (i.e. this is common for html pop-ups) (Inherited from HtmlControl.)
 | CssClass | Control's CSS class if set. (Inherited from HtmlControl.)
 | Download(Boolean, DownloadOption, String, Int32) | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
 | DragTo(HtmlControl) | Drag this control to the center on the destination control. (Inherited from HtmlControl.)
 | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination control with an offset of where within the destination control to drag to. (Inherited from HtmlControl.)
 | DragTo(Int32, Int32) | Drag this control to a relative X/Y offset. (Inherited from HtmlControl.)
 | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this control by specifying a reference point on the control rectangle to start the drag from and a reference point on the destination control to specify the drop location. (Inherited from HtmlControl.)
 | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this control from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
 | DragTo(OffsetReference, Point, HtmlControl) | Drag this control by specifying a reference point on the control rectangle to start the drag from with an offset and drop on the destination control center. (Inherited from HtmlControl.)
 | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this control by specifying a reference point on the control rectangle to start the drag from and a reference point on the destination control to specify the drop location. (Inherited from HtmlControl.)
 | DragTo(OffsetReference, Point, Int32, Int32) | Drag this control from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
 | DragTo(Point) | Drag this control to an absolute point. (Inherited from HtmlControl.)
 | DragToWindowLocation(OffsetReference, Int32, Int32, Boolean, OffsetReference, Int32, Int32, Boolean) | Drag this control, using the browser window as the drop target (Inherited from HtmlControl.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Events collection set on this control (Inherited from HtmlControl.)
 | Finalize() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindParentContainer<(Of TContainerControl>)() | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
 | GetAttributeAsString(String) | Get an attribute of this element as a string (Inherited from HtmlControl.)
 | GetComputedStyle(String) | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
 | GetComputedStyleValue(String) | Returns computed style value. Computed style represents the final computed value of all CSS properties for the element. (Inherited from HtmlControl.)
 | GetHashCode() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetRectangle() | The absolute screen position of the control. (Inherited from HtmlControl.)
 | GetStyle(String) | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
 | GetStyleValue(String) | Returns any style as if you are accessing the element.style object from javascript. (Inherited from HtmlControl.)
 | GetType() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue<(Of T>)(String) | Get a property value (i.e. control.border or control.style.backgroundColor). string s = myControl.GetValue<string>("style.backgroundColor") (Inherited from HtmlControl.)
 | ID | Control's ID if set. (Inherited from HtmlControl.)
 | InvokeEvent(ScriptEventType) | Invokes an event on this control (Inherited from HtmlControl.)
 | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
 | IsVisible() | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
 | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
 | MemberwiseClone() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MouseClick() | Uses the Desktop.Mouse object to move the mouse to this control and click it. (Inherited from HtmlControl.)
 | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to this control and click it. (Inherited from HtmlControl.)
 | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to this control and click it. (Inherited from HtmlControl.)
 | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to this control and click it. (Inherited from HtmlControl.)
 | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to this control and click it. (Inherited from HtmlControl.)
 | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over the control (Inherited from HtmlControl.)
 | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over the control (Inherited from HtmlControl.)
 | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over the control (Inherited from HtmlControl.)
 | Name | Gets the name attribute for control (Inherited from HtmlInputControl.)
 | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
 | Parent<(Of TContainerControl>)() | Return the parent HtmlContainerControl of desired type that this control is contained in. If control is not found, will return null. (Inherited from HtmlControl.)
 | Refresh() | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
 | ScrollLeft | Gets/Sets the scrollLeft value of the html control. (Inherited from HtmlControl.)
 | ScrollTop | Gets/Sets the scrollTop value of the html control (Inherited from HtmlControl.)
 | ScrollToVisible(ScrollToVisibleType) | Scroll control to Visible Position on the page (Inherited from HtmlControl.)
 | SetValue<(Of T>)(String, T) | Set a property value. (i.e. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
 | Styles | Styles collection set on this control and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
 | TagName | The tag name of this element (Inherited from HtmlControl.)
 | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
 | ToString() | Returns a String that represents the current Object. (Inherited from Object.)
 | Type | Input control type (Inherited from HtmlInputControl.)
 | ValidateControl() | Validate a control using a its Locator. (Inherited from HtmlControl.)
 | ValidateTag(String) | Validate a tag name (Inherited from HtmlControl.)
 | ValidateType(InputElementType) | Validates the type of the input control. (Inherited from HtmlInputControl.)
 | Value | Gets or sets the value attribute for control (Inherited from HtmlInputControl.)
 | Wait | Gets the HTML Wait object. (Inherited from HtmlControl.)
Inheritance Hierarchy
Object
 | Control
 |  | HtmlControl
 |  |  | HtmlInputControl
 |  |  |  | HtmlInputButton


AssignElement(e) method

HtmlInputButton.AssignElement(e) method
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlInputButton > AssignElement(Element)
Assign element and initialize this control.
Syntax
C#
public override void AssignElement (
    Element e
)
Parameters
e (Element)
The base element.


Constructors

HtmlInputButton constructors
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlInputButton > HtmlInputButtonNew
Members
Icon | Member | Description
 | HtmlInputButtonNew() | Create a new control.
 | HtmlInputButtonNew(Element) | Create a new control.


HtmlInputButton() constructor

HtmlInputButton() constructor
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlInputButton > HtmlInputButtonNew()
Create a new control.
Syntax
C#
public HtmlInputButton ()


HtmlInputButton(element) constructor

HtmlInputButton(element) constructor
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlInputButton > HtmlInputButtonNew(Element)
Create a new control.
Syntax
C#
public HtmlInputButton (
    Element element
)
Parameters
element (Element)
The base element.


HtmlInputCheckBox class

HtmlInputCheckBox class
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlInputCheckBox
Test class for an HtmlInputCheckBox element <input type="checkbox" />
Syntax
C#
public class HtmlInputCheckBox : HtmlInputControl
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | HtmlInputCheckBoxNew() | Create a new control.
 | HtmlInputCheckBoxNew(Element) | Create a new control.
 | AssignElement(Element) | Assign element and initialize this control. (Overrides HtmlInputControl.AssignElement(Element).)
 | AssignFailed(Exception) | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
 | Attributes | All attributes set on this control (Inherited from HtmlControl.)
 | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
 | Capture() | Captures and returns the image of the current Html Control. (Inherited from HtmlControl.)
 | Capture(String) | Captures and saves Html Control Image to the WebAii log location as a bmp file. (Inherited from HtmlControl.)
 | Capture(String, String) | Captures and saves Html Control Image to the specified save path as the specified image name in bmp format. (Inherited from HtmlControl.)
 | Check(Boolean, Boolean) | Sets the Checked state to isChecked and optionally invokes the onclick event. Note: Invoking the OnClick in Firefox will toggle the checked state of a checkbox vs IE which doesn't.
 | Checked | Sets or returns whether or not a checkbox should be checked.
 | Click() | Invoke a click within the loaded page. (Inherited from HtmlControl.)
 | Click(Boolean) | Invoke a click that causes that browser window to close (i.e. this is common for html pop-ups) (Inherited from HtmlControl.)
 | CssClass | Control's CSS class if set. (Inherited from HtmlControl.)
 | Download(Boolean, DownloadOption, String, Int32) | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
 | DragTo(HtmlControl) | Drag this control to the center on the destination control. (Inherited from HtmlControl.)
 | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination control with an offset of where within the destination control to drag to. (Inherited from HtmlControl.)
 | DragTo(Int32, Int32) | Drag this control to a relative X/Y offset. (Inherited from HtmlControl.)
 | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this control by specifying a reference point on the control rectangle to start the drag from and a reference point on the destination control to specify the drop location. (Inherited from HtmlControl.)
 | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this control from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
 | DragTo(OffsetReference, Point, HtmlControl) | Drag this control by specifying a reference point on the control rectangle to start the drag from with an offset and drop on the destination control center. (Inherited from HtmlControl.)
 | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this control by specifying a reference point on the control rectangle to start the drag from and a reference point on the destination control to specify the drop location. (Inherited from HtmlControl.)
 | DragTo(OffsetReference, Point, Int32, Int32) | Drag this control from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
 | DragTo(Point) | Drag this control to an absolute point. (Inherited from HtmlControl.)
 | DragToWindowLocation(OffsetReference, Int32, Int32, Boolean, OffsetReference, Int32, Int32, Boolean) | Drag this control, using the browser window as the drop target (Inherited from HtmlControl.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Events collection set on this control (Inherited from HtmlControl.)
 | Finalize() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindParentContainer<(Of TContainerControl>)() | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
 | GetAttributeAsString(String) | Get an attribute of this element as a string (Inherited from HtmlControl.)
 | GetComputedStyle(String) | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
 | GetComputedStyleValue(String) | Returns computed style value. Computed style represents the final computed value of all CSS properties for the element. (Inherited from HtmlControl.)
 | GetHashCode() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetRectangle() | The absolute screen position of the control. (Inherited from HtmlControl.)
 | GetStyle(String) | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
 | GetStyleValue(String) | Returns any style as if you are accessing the element.style object from javascript. (Inherited from HtmlControl.)
 | GetType() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue<(Of T>)(String) | Get a property value (i.e. control.border or control.style.backgroundColor). string s = myControl.GetValue<string>("style.backgroundColor") (Inherited from HtmlControl.)
 | ID | Control's ID if set. (Inherited from HtmlControl.)
 | InvokeEvent(ScriptEventType) | Invokes an event on this control (Inherited from HtmlControl.)
 | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
 | IsVisible() | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
 | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
 | MemberwiseClone() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MouseClick() | Uses the Desktop.Mouse object to move the mouse to this control and click it. (Inherited from HtmlControl.)
 | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to this control and click it. (Inherited from HtmlControl.)
 | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to this control and click it. (Inherited from HtmlControl.)
 | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to this control and click it. (Inherited from HtmlControl.)
 | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to this control and click it. (Inherited from HtmlControl.)
 | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over the control (Inherited from HtmlControl.)
 | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over the control (Inherited from HtmlControl.)
 | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over the control (Inherited from HtmlControl.)
 | Name | Gets the name attribute for control (Inherited from HtmlInputControl.)
 | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
 | Parent<(Of TContainerControl>)() | Return the parent HtmlContainerControl of desired type that this control is contained in. If control is not found, will return null. (Inherited from HtmlControl.)
 | Refresh() | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
 | ScrollLeft | Gets/Sets the scrollLeft value of the html control. (Inherited from HtmlControl.)
 | ScrollTop | Gets/Sets the scrollTop value of the html control (Inherited from HtmlControl.)
 | ScrollToVisible(ScrollToVisibleType) | Scroll control to Visible Position on the page (Inherited from HtmlControl.)
 | SetValue<(Of T>)(String, T) | Set a property value. (i.e. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
 | Styles | Styles collection set on this control and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
 | TagName | The tag name of this element (Inherited from HtmlControl.)
 | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
 | ToString() | Returns a String that represents the current Object. (Inherited from Object.)
 | Type | Input control type (Inherited from HtmlInputControl.)
 | ValidateControl() | Validate a control using a its Locator. (Inherited from HtmlControl.)
 | ValidateTag(String) | Validate a tag name (Inherited from HtmlControl.)
 | ValidateType(InputElementType) | Validates the type of the input control. (Inherited from HtmlInputControl.)
 | Value | Gets or sets the value attribute for control (Inherited from HtmlInputControl.)
 | Wait | Gets the HTML Wait object. (Inherited from HtmlControl.)
Inheritance Hierarchy
Object
 | Control
 |  | HtmlControl
 |  |  | HtmlInputControl
 |  |  |  | HtmlInputCheckBox


AssignElement(e) method

HtmlInputCheckBox.AssignElement(e) method
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlInputCheckBox > AssignElement(Element)
Assign element and initialize this control.
Syntax
C#
public override void AssignElement (
    Element e
)
Parameters
e (Element)
The base element.


Check(isChecked, invokeOnClickChanged) method

HtmlInputCheckBox.Check(isChecked, invokeOnClickChanged) method
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlInputCheckBox > Check(Boolean, Boolean)
Sets the Checked state to isChecked and optionally invokes the onclick event. Note: Invoking the OnClick in Firefox will toggle the checked state of a checkbox vs IE which doesn't.
Syntax
C#
public void Check (
    bool isChecked,
    bool invokeOnClickChanged
)
Parameters
isChecked (Boolean)
The checked state to set.
invokeOnClickChanged (Boolean)
True/False whether to invoke the click event.


Checked property

HtmlInputCheckBox.Checked property
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlInputCheckBox > Checked
Sets or returns whether or not a checkbox should be checked.
Syntax
C#
[DebuggerBrowsableAttribute(DebuggerBrowsableState.Never)]
public bool Checked { get; set; }


Constructors

HtmlInputCheckBox constructors
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlInputCheckBox > HtmlInputCheckBoxNew
Members
Icon | Member | Description
 | HtmlInputCheckBoxNew() | Create a new control.
 | HtmlInputCheckBoxNew(Element) | Create a new control.


HtmlInputCheckBox() constructor

HtmlInputCheckBox() constructor
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlInputCheckBox > HtmlInputCheckBoxNew()
Create a new control.
Syntax
C#
public HtmlInputCheckBox ()


HtmlInputCheckBox(element) constructor

HtmlInputCheckBox(element) constructor
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlInputCheckBox > HtmlInputCheckBoxNew(Element)
Create a new control.
Syntax
C#
public HtmlInputCheckBox (
    Element element
)
Parameters
element (Element)
The base element.


HtmlInputCheckBoxExtensions class

HtmlInputCheckBoxExtensions class
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlInputCheckBoxExtensions
Assert extensions for the HtmlControl class.
Syntax
C#
[ExtensionAttribute]
public static class HtmlInputCheckBoxExtensions
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AssertCheck(HtmlInputCheckBox) | Assert methods for the control content.
Inheritance Hierarchy
Object
HtmlInputCheckBoxExtensions


AssertCheck(control) method

HtmlInputCheckBoxExtensions.AssertCheck(control) method
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlInputCheckBoxExtensions > AssertCheck(HtmlInputCheckBox)
Assert methods for the control content.
Syntax
C#
[ExtensionAttribute]
public static AssertCheck AssertCheck (
    HtmlInputCheckBox control
)
Parameters
control (HtmlInputCheckBox)
Return Value


HtmlInputControl class

HtmlInputControl class
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlInputControl
Base class for all input controls
Syntax
C#
public abstract class HtmlInputControl : HtmlControl
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | HtmlInputControlNew() | Create a new test control.
 | HtmlInputControlNew(Element) | Create a new control.
 | AssignElement(Element) | Assign element and initialize this control. (Overrides HtmlControl.AssignElement(Element).)
 | AssignFailed(Exception) | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
 | Attributes | All attributes set on this control (Inherited from HtmlControl.)
 | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
 | Capture() | Captures and returns the image of the current Html Control. (Inherited from HtmlControl.)
 | Capture(String) | Captures and saves Html Control Image to the WebAii log location as a bmp file. (Inherited from HtmlControl.)
 | Capture(String, String) | Captures and saves Html Control Image to the specified save path as the specified image name in bmp format. (Inherited from HtmlControl.)
 | Click() | Invoke a click within the loaded page. (Inherited from HtmlControl.)
 | Click(Boolean) | Invoke a click that causes that browser window to close (i.e. this is common for html pop-ups) (Inherited from HtmlControl.)
 | CssClass | Control's CSS class if set. (Inherited from HtmlControl.)
 | Download(Boolean, DownloadOption, String, Int32) | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
 | DragTo(HtmlControl) | Drag this control to the center on the destination control. (Inherited from HtmlControl.)
 | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination control with an offset of where within the destination control to drag to. (Inherited from HtmlControl.)
 | DragTo(Int32, Int32) | Drag this control to a relative X/Y offset. (Inherited from HtmlControl.)
 | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this control by specifying a reference point on the control rectangle to start the drag from and a reference point on the destination control to specify the drop location. (Inherited from HtmlControl.)
 | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this control from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
 | DragTo(OffsetReference, Point, HtmlControl) | Drag this control by specifying a reference point on the control rectangle to start the drag from with an offset and drop on the destination control center. (Inherited from HtmlControl.)
 | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this control by specifying a reference point on the control rectangle to start the drag from and a reference point on the destination control to specify the drop location. (Inherited from HtmlControl.)
 | DragTo(OffsetReference, Point, Int32, Int32) | Drag this control from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
 | DragTo(Point) | Drag this control to an absolute point. (Inherited from HtmlControl.)
 | DragToWindowLocation(OffsetReference, Int32, Int32, Boolean, OffsetReference, Int32, Int32, Boolean) | Drag this control, using the browser window as the drop target (Inherited from HtmlControl.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Events collection set on this control (Inherited from HtmlControl.)
 | Finalize() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindParentContainer<(Of TContainerControl>)() | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
 | GetAttributeAsString(String) | Get an attribute of this element as a string (Inherited from HtmlControl.)
 | GetComputedStyle(String) | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
 | GetComputedStyleValue(String) | Returns computed style value. Computed style represents the final computed value of all CSS properties for the element. (Inherited from HtmlControl.)
 | GetHashCode() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetRectangle() | The absolute screen position of the control. (Inherited from HtmlControl.)
 | GetStyle(String) | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
 | GetStyleValue(String) | Returns any style as if you are accessing the element.style object from javascript. (Inherited from HtmlControl.)
 | GetType() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue<(Of T>)(String) | Get a property value (i.e. control.border or control.style.backgroundColor). string s = myControl.GetValue<string>("style.backgroundColor") (Inherited from HtmlControl.)
 | ID | Control's ID if set. (Inherited from HtmlControl.)
 | InvokeEvent(ScriptEventType) | Invokes an event on this control (Inherited from HtmlControl.)
 | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
 | IsVisible() | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
 | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
 | MemberwiseClone() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MouseClick() | Uses the Desktop.Mouse object to move the mouse to this control and click it. (Inherited from HtmlControl.)
 | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to this control and click it. (Inherited from HtmlControl.)
 | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to this control and click it. (Inherited from HtmlControl.)
 | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to this control and click it. (Inherited from HtmlControl.)
 | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to this control and click it. (Inherited from HtmlControl.)
 | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over the control (Inherited from HtmlControl.)
 | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over the control (Inherited from HtmlControl.)
 | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over the control (Inherited from HtmlControl.)
 | Name | Gets the name attribute for control
 | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
 | Parent<(Of TContainerControl>)() | Return the parent HtmlContainerControl of desired type that this control is contained in. If control is not found, will return null. (Inherited from HtmlControl.)
 | Refresh() | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
 | ScrollLeft | Gets/Sets the scrollLeft value of the html control. (Inherited from HtmlControl.)
 | ScrollTop | Gets/Sets the scrollTop value of the html control (Inherited from HtmlControl.)
 | ScrollToVisible(ScrollToVisibleType) | Scroll control to Visible Position on the page (Inherited from HtmlControl.)
 | SetValue<(Of T>)(String, T) | Set a property value. (i.e. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
 | Styles | Styles collection set on this control and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
 | TagName | The tag name of this element (Inherited from HtmlControl.)
 | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
 | ToString() | Returns a String that represents the current Object. (Inherited from Object.)
 | Type | Input control type
 | ValidateControl() | Validate a control using a its Locator. (Inherited from HtmlControl.)
 | ValidateTag(String) | Validate a tag name (Inherited from HtmlControl.)
 | ValidateType(InputElementType) | Validates the type of the input control.
 | Value | Gets or sets the value attribute for control
 | Wait | Gets the HTML Wait object. (Inherited from HtmlControl.)
Inheritance Hierarchy
Object
 | Control
 |  | HtmlControl
 |  |  | HtmlInputControl
 |  |  |  | HtmlInputCheckBox
 |  |  |  | HtmlInputSubmit
 |  |  |  | HtmlInputFile
 |  |  |  | HtmlInputReset
 |  |  |  | HtmlInputImage
 |  |  |  | HtmlInputButton
 |  |  |  | HtmlInputPassword
 |  |  |  | HtmlInputHidden
 |  |  |  | HtmlInputText
 |  |  |  | HtmlInputRadioButton


AssignElement(e) method

HtmlInputControl.AssignElement(e) method
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlInputControl > AssignElement(Element)
Assign element and initialize this control.
Syntax
C#
public override void AssignElement (
    Element e
)
Parameters
e (Element)
The base element.


Constructors

HtmlInputControl constructors
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlInputControl > HtmlInputControlNew
Members
Icon | Member | Description
 | HtmlInputControlNew() | Create a new test control.
 | HtmlInputControlNew(Element) | Create a new control.


HtmlInputControl() constructor

HtmlInputControl() constructor
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlInputControl > HtmlInputControlNew()
Create a new test control.
Syntax
C#
public HtmlInputControl ()


HtmlInputControl(element) constructor

HtmlInputControl(element) constructor
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlInputControl > HtmlInputControlNew(Element)
Create a new control.
Syntax
C#
public HtmlInputControl (
    Element element
)
Parameters
element (Element)
The base element.


Name property

HtmlInputControl.Name property
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlInputControl > Name
Gets the name attribute for control
Syntax
C#
public string Name { get; }


Type property

HtmlInputControl.Type property
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlInputControl > Type
Input control type
Syntax
C#
public InputElementType Type { get; }


ValidateType(inputElementType) method

HtmlInputControl.ValidateType(inputElementType) method
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlInputControl > ValidateType(InputElementType)
Validates the type of the input control.
Syntax
C#
protected void ValidateType (
    InputElementType inputElementType
)
Parameters
inputElementType (InputElementType)
InputElementType Enum


Value property

HtmlInputControl.Value property
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlInputControl > Value
Gets or sets the value attribute for control
Syntax
C#
[DebuggerBrowsableAttribute(DebuggerBrowsableState.Never)]
public string Value { get; set; }


HtmlInputFile class

HtmlInputFile class
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlInputFile
Test class for an HtmlInputFile element <input type="file" />
Syntax
C#
public class HtmlInputFile : HtmlInputControl
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | HtmlInputFileNew() | Create a new control.
 | HtmlInputFileNew(Element) | Create a new control.
 | AssignElement(Element) | Assign element and initialize this control. (Overrides HtmlInputControl.AssignElement(Element).)
 | AssignFailed(Exception) | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
 | Attributes | All attributes set on this control (Inherited from HtmlControl.)
 | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
 | Capture() | Captures and returns the image of the current Html Control. (Inherited from HtmlControl.)
 | Capture(String) | Captures and saves Html Control Image to the WebAii log location as a bmp file. (Inherited from HtmlControl.)
 | Capture(String, String) | Captures and saves Html Control Image to the specified save path as the specified image name in bmp format. (Inherited from HtmlControl.)
 | Click() | Invoke a click within the loaded page. (Inherited from HtmlControl.)
 | Click(Boolean) | Invoke a click that causes that browser window to close (i.e. this is common for html pop-ups) (Inherited from HtmlControl.)
 | CssClass | Control's CSS class if set. (Inherited from HtmlControl.)
 | Download(Boolean, DownloadOption, String, Int32) | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
 | DragTo(HtmlControl) | Drag this control to the center on the destination control. (Inherited from HtmlControl.)
 | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination control with an offset of where within the destination control to drag to. (Inherited from HtmlControl.)
 | DragTo(Int32, Int32) | Drag this control to a relative X/Y offset. (Inherited from HtmlControl.)
 | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this control by specifying a reference point on the control rectangle to start the drag from and a reference point on the destination control to specify the drop location. (Inherited from HtmlControl.)
 | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this control from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
 | DragTo(OffsetReference, Point, HtmlControl) | Drag this control by specifying a reference point on the control rectangle to start the drag from with an offset and drop on the destination control center. (Inherited from HtmlControl.)
 | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this control by specifying a reference point on the control rectangle to start the drag from and a reference point on the destination control to specify the drop location. (Inherited from HtmlControl.)
 | DragTo(OffsetReference, Point, Int32, Int32) | Drag this control from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
 | DragTo(Point) | Drag this control to an absolute point. (Inherited from HtmlControl.)
 | DragToWindowLocation(OffsetReference, Int32, Int32, Boolean, OffsetReference, Int32, Int32, Boolean) | Drag this control, using the browser window as the drop target (Inherited from HtmlControl.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Events collection set on this control (Inherited from HtmlControl.)
 | FilePath | Gets or sets the Path for the control
 | Finalize() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindParentContainer<(Of TContainerControl>)() | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
 | GetAttributeAsString(String) | Get an attribute of this element as a string (Inherited from HtmlControl.)
 | GetComputedStyle(String) | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
 | GetComputedStyleValue(String) | Returns computed style value. Computed style represents the final computed value of all CSS properties for the element. (Inherited from HtmlControl.)
 | GetHashCode() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetRectangle() | The absolute screen position of the control. (Inherited from HtmlControl.)
 | GetStyle(String) | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
 | GetStyleValue(String) | Returns any style as if you are accessing the element.style object from javascript. (Inherited from HtmlControl.)
 | GetType() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue<(Of T>)(String) | Get a property value (i.e. control.border or control.style.backgroundColor). string s = myControl.GetValue<string>("style.backgroundColor") (Inherited from HtmlControl.)
 | ID | Control's ID if set. (Inherited from HtmlControl.)
 | InvokeEvent(ScriptEventType) | Invokes an event on this control (Inherited from HtmlControl.)
 | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
 | IsVisible() | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
 | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
 | MemberwiseClone() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MouseClick() | Uses the Desktop.Mouse object to move the mouse to this control and click it. (Inherited from HtmlControl.)
 | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to this control and click it. (Inherited from HtmlControl.)
 | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to this control and click it. (Inherited from HtmlControl.)
 | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to this control and click it. (Inherited from HtmlControl.)
 | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to this control and click it. (Inherited from HtmlControl.)
 | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over the control (Inherited from HtmlControl.)
 | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over the control (Inherited from HtmlControl.)
 | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over the control (Inherited from HtmlControl.)
 | Name | Gets the name attribute for control (Inherited from HtmlInputControl.)
 | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
 | Parent<(Of TContainerControl>)() | Return the parent HtmlContainerControl of desired type that this control is contained in. If control is not found, will return null. (Inherited from HtmlControl.)
 | Refresh() | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
 | ScrollLeft | Gets/Sets the scrollLeft value of the html control. (Inherited from HtmlControl.)
 | ScrollTop | Gets/Sets the scrollTop value of the html control (Inherited from HtmlControl.)
 | ScrollToVisible(ScrollToVisibleType) | Scroll control to Visible Position on the page (Inherited from HtmlControl.)
 | SetValue<(Of T>)(String, T) | Set a property value. (i.e. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
 | Styles | Styles collection set on this control and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
 | TagName | The tag name of this element (Inherited from HtmlControl.)
 | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
 | ToString() | Returns a String that represents the current Object. (Inherited from Object.)
 | Type | Input control type (Inherited from HtmlInputControl.)
 | Upload(String, Int32) | Upload a file.
 | ValidateControl() | Validate a control using a its Locator. (Inherited from HtmlControl.)
 | ValidateTag(String) | Validate a tag name (Inherited from HtmlControl.)
 | ValidateType(InputElementType) | Validates the type of the input control. (Inherited from HtmlInputControl.)
 | Value | Gets or sets the value attribute for control (Inherited from HtmlInputControl.)
 | Wait | Gets the HTML Wait object. (Inherited from HtmlControl.)
Inheritance Hierarchy
Object
 | Control
 |  | HtmlControl
 |  |  | HtmlInputControl
 |  |  |  | HtmlInputFile


AssignElement(e) method

HtmlInputFile.AssignElement(e) method
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlInputFile > AssignElement(Element)
Assign element and initialize this control.
Syntax
C#
public override void AssignElement (
    Element e
)
Parameters
e (Element)
The base element.


Constructors

HtmlInputFile constructors
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlInputFile > HtmlInputFileNew
Members
Icon | Member | Description
 | HtmlInputFileNew() | Create a new control.
 | HtmlInputFileNew(Element) | Create a new control.


HtmlInputFile() constructor

HtmlInputFile() constructor
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlInputFile > HtmlInputFileNew()
Create a new control.
Syntax
C#
public HtmlInputFile ()


HtmlInputFile(element) constructor

HtmlInputFile(element) constructor
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlInputFile > HtmlInputFileNew(Element)
Create a new control.
Syntax
C#
public HtmlInputFile (
    Element element
)
Parameters
element (Element)
The base element.


FilePath property

HtmlInputFile.FilePath property
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlInputFile > FilePath
Gets or sets the Path for the control
Syntax
C#
public string FilePath { get; set; }


Upload(filePath, uploadTimeout) method

HtmlInputFile.Upload(filePath, uploadTimeout) method
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlInputFile > Upload(String, Int32)
Upload a file.
Syntax
C#
public void Upload (
    string filePath,
    int uploadTimeout
)
Parameters
filePath (String)
The full path to file to upload.
uploadTimeout (Int32)
The timeout to wait until upload is complete.


HtmlInputHidden class

HtmlInputHidden class
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlInputHidden
Test class for an HtmlInputHidden element <input type="hidden" />
Syntax
C#
public class HtmlInputHidden : HtmlInputControl
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | HtmlInputHiddenNew() | Create a new control.
 | HtmlInputHiddenNew(Element) | Create a new control.
 | AssignElement(Element) | Assign element and initialize this control. (Overrides HtmlInputControl.AssignElement(Element).)
 | AssignFailed(Exception) | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
 | Attributes | All attributes set on this control (Inherited from HtmlControl.)
 | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
 | Capture() | Captures and returns the image of the current Html Control. (Inherited from HtmlControl.)
 | Capture(String) | Captures and saves Html Control Image to the WebAii log location as a bmp file. (Inherited from HtmlControl.)
 | Capture(String, String) | Captures and saves Html Control Image to the specified save path as the specified image name in bmp format. (Inherited from HtmlControl.)
 | Click() | Invoke a click within the loaded page. (Inherited from HtmlControl.)
 | Click(Boolean) | Invoke a click that causes that browser window to close (i.e. this is common for html pop-ups) (Inherited from HtmlControl.)
 | CssClass | Control's CSS class if set. (Inherited from HtmlControl.)
 | Download(Boolean, DownloadOption, String, Int32) | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
 | DragTo(HtmlControl) | Drag this control to the center on the destination control. (Inherited from HtmlControl.)
 | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination control with an offset of where within the destination control to drag to. (Inherited from HtmlControl.)
 | DragTo(Int32, Int32) | Drag this control to a relative X/Y offset. (Inherited from HtmlControl.)
 | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this control by specifying a reference point on the control rectangle to start the drag from and a reference point on the destination control to specify the drop location. (Inherited from HtmlControl.)
 | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this control from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
 | DragTo(OffsetReference, Point, HtmlControl) | Drag this control by specifying a reference point on the control rectangle to start the drag from with an offset and drop on the destination control center. (Inherited from HtmlControl.)
 | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this control by specifying a reference point on the control rectangle to start the drag from and a reference point on the destination control to specify the drop location. (Inherited from HtmlControl.)
 | DragTo(OffsetReference, Point, Int32, Int32) | Drag this control from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
 | DragTo(Point) | Drag this control to an absolute point. (Inherited from HtmlControl.)
 | DragToWindowLocation(OffsetReference, Int32, Int32, Boolean, OffsetReference, Int32, Int32, Boolean) | Drag this control, using the browser window as the drop target (Inherited from HtmlControl.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Events collection set on this control (Inherited from HtmlControl.)
 | Finalize() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindParentContainer<(Of TContainerControl>)() | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
 | GetAttributeAsString(String) | Get an attribute of this element as a string (Inherited from HtmlControl.)
 | GetComputedStyle(String) | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
 | GetComputedStyleValue(String) | Returns computed style value. Computed style represents the final computed value of all CSS properties for the element. (Inherited from HtmlControl.)
 | GetHashCode() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetRectangle() | The absolute screen position of the control. (Inherited from HtmlControl.)
 | GetStyle(String) | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
 | GetStyleValue(String) | Returns any style as if you are accessing the element.style object from javascript. (Inherited from HtmlControl.)
 | GetType() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue<(Of T>)(String) | Get a property value (i.e. control.border or control.style.backgroundColor). string s = myControl.GetValue<string>("style.backgroundColor") (Inherited from HtmlControl.)
 | ID | Control's ID if set. (Inherited from HtmlControl.)
 | InvokeEvent(ScriptEventType) | Invokes an event on this control (Inherited from HtmlControl.)
 | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
 | IsVisible() | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
 | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
 | MemberwiseClone() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MouseClick() | Uses the Desktop.Mouse object to move the mouse to this control and click it. (Inherited from HtmlControl.)
 | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to this control and click it. (Inherited from HtmlControl.)
 | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to this control and click it. (Inherited from HtmlControl.)
 | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to this control and click it. (Inherited from HtmlControl.)
 | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to this control and click it. (Inherited from HtmlControl.)
 | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over the control (Inherited from HtmlControl.)
 | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over the control (Inherited from HtmlControl.)
 | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over the control (Inherited from HtmlControl.)
 | Name | Gets the name attribute for control (Inherited from HtmlInputControl.)
 | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
 | Parent<(Of TContainerControl>)() | Return the parent HtmlContainerControl of desired type that this control is contained in. If control is not found, will return null. (Inherited from HtmlControl.)
 | Refresh() | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
 | ScrollLeft | Gets/Sets the scrollLeft value of the html control. (Inherited from HtmlControl.)
 | ScrollTop | Gets/Sets the scrollTop value of the html control (Inherited from HtmlControl.)
 | ScrollToVisible(ScrollToVisibleType) | Scroll control to Visible Position on the page (Inherited from HtmlControl.)
 | SetValue<(Of T>)(String, T) | Set a property value. (i.e. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
 | Styles | Styles collection set on this control and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
 | TagName | The tag name of this element (Inherited from HtmlControl.)
 | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
 | ToString() | Returns a String that represents the current Object. (Inherited from Object.)
 | Type | Input control type (Inherited from HtmlInputControl.)
 | ValidateControl() | Validate a control using a its Locator. (Inherited from HtmlControl.)
 | ValidateTag(String) | Validate a tag name (Inherited from HtmlControl.)
 | ValidateType(InputElementType) | Validates the type of the input control. (Inherited from HtmlInputControl.)
 | Value | Gets or sets the value attribute for control (Inherited from HtmlInputControl.)
 | Wait | Gets the HTML Wait object. (Inherited from HtmlControl.)
Inheritance Hierarchy
Object
 | Control
 |  | HtmlControl
 |  |  | HtmlInputControl
 |  |  |  | HtmlInputHidden


AssignElement(e) method

HtmlInputHidden.AssignElement(e) method
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlInputHidden > AssignElement(Element)
Assign element and initialize this control.
Syntax
C#
public override void AssignElement (
    Element e
)
Parameters
e (Element)
The base element.


Constructors

HtmlInputHidden constructors
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlInputHidden > HtmlInputHiddenNew
Members
Icon | Member | Description
 | HtmlInputHiddenNew() | Create a new control.
 | HtmlInputHiddenNew(Element) | Create a new control.


HtmlInputHidden() constructor

HtmlInputHidden() constructor
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlInputHidden > HtmlInputHiddenNew()
Create a new control.
Syntax
C#
public HtmlInputHidden ()


HtmlInputHidden(element) constructor

HtmlInputHidden(element) constructor
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlInputHidden > HtmlInputHiddenNew(Element)
Create a new control.
Syntax
C#
public HtmlInputHidden (
    Element element
)
Parameters
element (Element)
The base element.


HtmlInputImage class

HtmlInputImage class
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlInputImage
Test class for an HtmlInputImage element <input type="image" />
Syntax
C#
public class HtmlInputImage : HtmlInputControl
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | HtmlInputImageNew() | Create a new control.
 | HtmlInputImageNew(Element) | Create a new control.
 | Align | A string that specifies the alignment of the image relative to other Web page elements.
 | Alt | A string that contains the alternative caption for the browser to use when the image is unavailable.
 | AssignElement(Element) | Assign element and initialize this control. (Overrides HtmlInputControl.AssignElement(Element).)
 | AssignFailed(Exception) | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
 | Attributes | All attributes set on this control (Inherited from HtmlControl.)
 | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
 | Border | The width (in pixels) of a frame for an image.
 | Capture() | Captures and returns the image of the current Html Control. (Inherited from HtmlControl.)
 | Capture(String) | Captures and saves Html Control Image to the WebAii log location as a bmp file. (Inherited from HtmlControl.)
 | Capture(String, String) | Captures and saves Html Control Image to the specified save path as the specified image name in bmp format. (Inherited from HtmlControl.)
 | Click() | Invoke a click within the loaded page. (Inherited from HtmlControl.)
 | Click(Boolean) | Invoke a click that causes that browser window to close (i.e. this is common for html pop-ups) (Inherited from HtmlControl.)
 | CssClass | Control's CSS class if set. (Inherited from HtmlControl.)
 | Download(Boolean, DownloadOption, String, Int32) | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
 | DragTo(HtmlControl) | Drag this control to the center on the destination control. (Inherited from HtmlControl.)
 | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination control with an offset of where within the destination control to drag to. (Inherited from HtmlControl.)
 | DragTo(Int32, Int32) | Drag this control to a relative X/Y offset. (Inherited from HtmlControl.)
 | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this control by specifying a reference point on the control rectangle to start the drag from and a reference point on the destination control to specify the drop location. (Inherited from HtmlControl.)
 | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this control from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
 | DragTo(OffsetReference, Point, HtmlControl) | Drag this control by specifying a reference point on the control rectangle to start the drag from with an offset and drop on the destination control center. (Inherited from HtmlControl.)
 | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this control by specifying a reference point on the control rectangle to start the drag from and a reference point on the destination control to specify the drop location. (Inherited from HtmlControl.)
 | DragTo(OffsetReference, Point, Int32, Int32) | Drag this control from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
 | DragTo(Point) | Drag this control to an absolute point. (Inherited from HtmlControl.)
 | DragToWindowLocation(OffsetReference, Int32, Int32, Boolean, OffsetReference, Int32, Int32, Boolean) | Drag this control, using the browser window as the drop target (Inherited from HtmlControl.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Events collection set on this control (Inherited from HtmlControl.)
 | Finalize() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindParentContainer<(Of TContainerControl>)() | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
 | GetAttributeAsString(String) | Get an attribute of this element as a string (Inherited from HtmlControl.)
 | GetComputedStyle(String) | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
 | GetComputedStyleValue(String) | Returns computed style value. Computed style represents the final computed value of all CSS properties for the element. (Inherited from HtmlControl.)
 | GetHashCode() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetRectangle() | The absolute screen position of the control. (Inherited from HtmlControl.)
 | GetStyle(String) | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
 | GetStyleValue(String) | Returns any style as if you are accessing the element.style object from javascript. (Inherited from HtmlControl.)
 | GetType() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue<(Of T>)(String) | Get a property value (i.e. control.border or control.style.backgroundColor). string s = myControl.GetValue<string>("style.backgroundColor") (Inherited from HtmlControl.)
 | Height | The height of the image.
 | ID | Control's ID if set. (Inherited from HtmlControl.)
 | InvokeEvent(ScriptEventType) | Invokes an event on this control (Inherited from HtmlControl.)
 | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
 | IsVisible() | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
 | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
 | MemberwiseClone() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MouseClick() | Uses the Desktop.Mouse object to move the mouse to this control and click it. (Inherited from HtmlControl.)
 | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to this control and click it. (Inherited from HtmlControl.)
 | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to this control and click it. (Inherited from HtmlControl.)
 | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to this control and click it. (Inherited from HtmlControl.)
 | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to this control and click it. (Inherited from HtmlControl.)
 | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over the control (Inherited from HtmlControl.)
 | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over the control (Inherited from HtmlControl.)
 | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over the control (Inherited from HtmlControl.)
 | Name | Gets the name attribute for control (Inherited from HtmlInputControl.)
 | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
 | Parent<(Of TContainerControl>)() | Return the parent HtmlContainerControl of desired type that this control is contained in. If control is not found, will return null. (Inherited from HtmlControl.)
 | Refresh() | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
 | ScrollLeft | Gets/Sets the scrollLeft value of the html control. (Inherited from HtmlControl.)
 | ScrollTop | Gets/Sets the scrollTop value of the html control (Inherited from HtmlControl.)
 | ScrollToVisible(ScrollToVisibleType) | Scroll control to Visible Position on the page (Inherited from HtmlControl.)
 | SetValue<(Of T>)(String, T) | Set a property value. (i.e. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
 | Src | A string that contains the path to an image file to display.
 | Styles | Styles collection set on this control and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
 | TagName | The tag name of this element (Inherited from HtmlControl.)
 | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
 | ToString() | Returns a String that represents the current Object. (Inherited from Object.)
 | Type | Input control type (Inherited from HtmlInputControl.)
 | ValidateControl() | Validate a control using a its Locator. (Inherited from HtmlControl.)
 | ValidateTag(String) | Validate a tag name (Inherited from HtmlControl.)
 | ValidateType(InputElementType) | Validates the type of the input control. (Inherited from HtmlInputControl.)
 | Value | Gets or sets the value attribute for control (Inherited from HtmlInputControl.)
 | Wait | Gets the HTML Wait object. (Inherited from HtmlControl.)
 | Width | The width of the image.
Inheritance Hierarchy
Object
 | Control
 |  | HtmlControl
 |  |  | HtmlInputControl
 |  |  |  | HtmlInputImage


Align property

HtmlInputImage.Align property
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlInputImage > Align
A string that specifies the alignment of the image relative to other Web page elements.
Syntax
C#
public string Align { get; }


Alt property

HtmlInputImage.Alt property
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlInputImage > Alt
A string that contains the alternative caption for the browser to use when the image is unavailable.
Syntax
C#
public string Alt { get; }


AssignElement(e) method

HtmlInputImage.AssignElement(e) method
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlInputImage > AssignElement(Element)
Assign element and initialize this control.
Syntax
C#
public override void AssignElement (
    Element e
)
Parameters
e (Element)
The base element.


Border property

HtmlInputImage.Border property
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlInputImage > Border
The width (in pixels) of a frame for an image.
Syntax
C#
public string Border { get; }


Constructors

HtmlInputImage constructors
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlInputImage > HtmlInputImageNew
Members
Icon | Member | Description
 | HtmlInputImageNew() | Create a new control.
 | HtmlInputImageNew(Element) | Create a new control.


HtmlInputImage() constructor

HtmlInputImage() constructor
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlInputImage > HtmlInputImageNew()
Create a new control.
Syntax
C#
public HtmlInputImage ()


HtmlInputImage(element) constructor

HtmlInputImage(element) constructor
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlInputImage > HtmlInputImageNew(Element)
Create a new control.
Syntax
C#
public HtmlInputImage (
    Element element
)
Parameters
element (Element)
The base element.


Height property

HtmlInputImage.Height property
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlInputImage > Height
The height of the image.
Syntax
C#
public string Height { get; }


Src property

HtmlInputImage.Src property
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlInputImage > Src
A string that contains the path to an image file to display.
Syntax
C#
public string Src { get; }


Width property

HtmlInputImage.Width property
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlInputImage > Width
The width of the image.
Syntax
C#
public string Width { get; }


HtmlInputPassword class

HtmlInputPassword class
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlInputPassword
Test class for an HtmlInputPassword element <input type="password" />
Syntax
C#
public class HtmlInputPassword : HtmlInputControl
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | HtmlInputPasswordNew() | Create a new control.
 | HtmlInputPasswordNew(Element) | Create a new control.
 | AssignElement(Element) | Assign element and initialize this control. (Overrides HtmlInputControl.AssignElement(Element).)
 | AssignFailed(Exception) | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
 | Attributes | All attributes set on this control (Inherited from HtmlControl.)
 | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
 | Capture() | Captures and returns the image of the current Html Control. (Inherited from HtmlControl.)
 | Capture(String) | Captures and saves Html Control Image to the WebAii log location as a bmp file. (Inherited from HtmlControl.)
 | Capture(String, String) | Captures and saves Html Control Image to the specified save path as the specified image name in bmp format. (Inherited from HtmlControl.)
 | Click() | Invoke a click within the loaded page. (Inherited from HtmlControl.)
 | Click(Boolean) | Invoke a click that causes that browser window to close (i.e. this is common for html pop-ups) (Inherited from HtmlControl.)
 | CssClass | Control's CSS class if set. (Inherited from HtmlControl.)
 | Disabled | Gets whether or not a text field is disabled
 | Download(Boolean, DownloadOption, String, Int32) | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
 | DragTo(HtmlControl) | Drag this control to the center on the destination control. (Inherited from HtmlControl.)
 | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination control with an offset of where within the destination control to drag to. (Inherited from HtmlControl.)
 | DragTo(Int32, Int32) | Drag this control to a relative X/Y offset. (Inherited from HtmlControl.)
 | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this control by specifying a reference point on the control rectangle to start the drag from and a reference point on the destination control to specify the drop location. (Inherited from HtmlControl.)
 | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this control from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
 | DragTo(OffsetReference, Point, HtmlControl) | Drag this control by specifying a reference point on the control rectangle to start the drag from with an offset and drop on the destination control center. (Inherited from HtmlControl.)
 | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this control by specifying a reference point on the control rectangle to start the drag from and a reference point on the destination control to specify the drop location. (Inherited from HtmlControl.)
 | DragTo(OffsetReference, Point, Int32, Int32) | Drag this control from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
 | DragTo(Point) | Drag this control to an absolute point. (Inherited from HtmlControl.)
 | DragToWindowLocation(OffsetReference, Int32, Int32, Boolean, OffsetReference, Int32, Int32, Boolean) | Drag this control, using the browser window as the drop target (Inherited from HtmlControl.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Events collection set on this control (Inherited from HtmlControl.)
 | Finalize() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindParentContainer<(Of TContainerControl>)() | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
 | GetAttributeAsString(String) | Get an attribute of this element as a string (Inherited from HtmlControl.)
 | GetComputedStyle(String) | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
 | GetComputedStyleValue(String) | Returns computed style value. Computed style represents the final computed value of all CSS properties for the element. (Inherited from HtmlControl.)
 | GetHashCode() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetRectangle() | The absolute screen position of the control. (Inherited from HtmlControl.)
 | GetStyle(String) | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
 | GetStyleValue(String) | Returns any style as if you are accessing the element.style object from javascript. (Inherited from HtmlControl.)
 | GetType() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue<(Of T>)(String) | Get a property value (i.e. control.border or control.style.backgroundColor). string s = myControl.GetValue<string>("style.backgroundColor") (Inherited from HtmlControl.)
 | ID | Control's ID if set. (Inherited from HtmlControl.)
 | InvokeEvent(ScriptEventType) | Invokes an event on this control (Inherited from HtmlControl.)
 | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
 | IsVisible() | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
 | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
 | MemberwiseClone() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MouseClick() | Uses the Desktop.Mouse object to move the mouse to this control and click it. (Inherited from HtmlControl.)
 | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to this control and click it. (Inherited from HtmlControl.)
 | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to this control and click it. (Inherited from HtmlControl.)
 | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to this control and click it. (Inherited from HtmlControl.)
 | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to this control and click it. (Inherited from HtmlControl.)
 | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over the control (Inherited from HtmlControl.)
 | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over the control (Inherited from HtmlControl.)
 | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over the control (Inherited from HtmlControl.)
 | Name | Gets the name attribute for control (Inherited from HtmlInputControl.)
 | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
 | Parent<(Of TContainerControl>)() | Return the parent HtmlContainerControl of desired type that this control is contained in. If control is not found, will return null. (Inherited from HtmlControl.)
 | Refresh() | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
 | ScrollLeft | Gets/Sets the scrollLeft value of the html control. (Inherited from HtmlControl.)
 | ScrollTop | Gets/Sets the scrollTop value of the html control (Inherited from HtmlControl.)
 | ScrollToVisible(ScrollToVisibleType) | Scroll control to Visible Position on the page (Inherited from HtmlControl.)
 | SetValue<(Of T>)(String, T) | Set a property value. (i.e. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
 | Size | Gets the size of a text field (in number of characters).
 | Styles | Styles collection set on this control and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
 | TabIndex | Gets the tab order for a text field.
 | TagName | The tag name of this element (Inherited from HtmlControl.)
 | Text | Gets/Sets the value of the value attribute of a text field
 | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
 | ToString() | Returns a String that represents the current Object. (Inherited from Object.)
 | Type | Input control type (Inherited from HtmlInputControl.)
 | ValidateControl() | Validate a control using a its Locator. (Inherited from HtmlControl.)
 | ValidateTag(String) | Validate a tag name (Inherited from HtmlControl.)
 | ValidateType(InputElementType) | Validates the type of the input control. (Inherited from HtmlInputControl.)
 | Value | Gets or sets the value attribute for control (Inherited from HtmlInputControl.)
 | Wait | Gets the HTML Wait object. (Inherited from HtmlControl.)
Inheritance Hierarchy
Object
 | Control
 |  | HtmlControl
 |  |  | HtmlInputControl
 |  |  |  | HtmlInputPassword


AssignElement(e) method

HtmlInputPassword.AssignElement(e) method
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlInputPassword > AssignElement(Element)
Assign element and initialize this control.
Syntax
C#
public override void AssignElement (
    Element e
)
Parameters
e (Element)
The base element.


Constructors

HtmlInputPassword constructors
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlInputPassword > HtmlInputPasswordNew
Members
Icon | Member | Description
 | HtmlInputPasswordNew() | Create a new control.
 | HtmlInputPasswordNew(Element) | Create a new control.


HtmlInputPassword() constructor

HtmlInputPassword() constructor
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlInputPassword > HtmlInputPasswordNew()
Create a new control.
Syntax
C#
public HtmlInputPassword ()


HtmlInputPassword(element) constructor

HtmlInputPassword(element) constructor
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlInputPassword > HtmlInputPasswordNew(Element)
Create a new control.
Syntax
C#
public HtmlInputPassword (
    Element element
)
Parameters
element (Element)
The base element.


Disabled property

HtmlInputPassword.Disabled property
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlInputPassword > Disabled
Gets whether or not a text field is disabled
Syntax
C#
public bool Disabled { get; }


Size property

HtmlInputPassword.Size property
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlInputPassword > Size
Gets the size of a text field (in number of characters).
Syntax
C#
public int Size { get; }


TabIndex property

HtmlInputPassword.TabIndex property
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlInputPassword > TabIndex
Gets the tab order for a text field.
Syntax
C#
public int TabIndex { get; }


Text property

HtmlInputPassword.Text property
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlInputPassword > Text
Gets/Sets the value of the value attribute of a text field
Syntax
C#
public string Text { get; set; }


HtmlInputRadioButton class

HtmlInputRadioButton class
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlInputRadioButton
Test class for an HtmlInputImage element <input type="radio" />
Syntax
C#
public class HtmlInputRadioButton : HtmlInputControl
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | HtmlInputRadioButtonNew() | Create a new control.
 | HtmlInputRadioButtonNew(Element) | Create a new control.
 | AssignElement(Element) | Assign element and initialize this control. (Overrides HtmlInputControl.AssignElement(Element).)
 | AssignFailed(Exception) | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
 | Attributes | All attributes set on this control (Inherited from HtmlControl.)
 | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
 | Capture() | Captures and returns the image of the current Html Control. (Inherited from HtmlControl.)
 | Capture(String) | Captures and saves Html Control Image to the WebAii log location as a bmp file. (Inherited from HtmlControl.)
 | Capture(String, String) | Captures and saves Html Control Image to the specified save path as the specified image name in bmp format. (Inherited from HtmlControl.)
 | Check(Boolean, Boolean) | Sets the Checked state to isChecked and optionally invokes the onclick event.
 | Checked | Gets/Sets whether or not a checkbox should be checked.
 | Click() | Invoke a click within the loaded page. (Inherited from HtmlControl.)
 | Click(Boolean) | Invoke a click that causes that browser window to close (i.e. this is common for html pop-ups) (Inherited from HtmlControl.)
 | CssClass | Control's CSS class if set. (Inherited from HtmlControl.)
 | Download(Boolean, DownloadOption, String, Int32) | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
 | DragTo(HtmlControl) | Drag this control to the center on the destination control. (Inherited from HtmlControl.)
 | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination control with an offset of where within the destination control to drag to. (Inherited from HtmlControl.)
 | DragTo(Int32, Int32) | Drag this control to a relative X/Y offset. (Inherited from HtmlControl.)
 | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this control by specifying a reference point on the control rectangle to start the drag from and a reference point on the destination control to specify the drop location. (Inherited from HtmlControl.)
 | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this control from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
 | DragTo(OffsetReference, Point, HtmlControl) | Drag this control by specifying a reference point on the control rectangle to start the drag from with an offset and drop on the destination control center. (Inherited from HtmlControl.)
 | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this control by specifying a reference point on the control rectangle to start the drag from and a reference point on the destination control to specify the drop location. (Inherited from HtmlControl.)
 | DragTo(OffsetReference, Point, Int32, Int32) | Drag this control from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
 | DragTo(Point) | Drag this control to an absolute point. (Inherited from HtmlControl.)
 | DragToWindowLocation(OffsetReference, Int32, Int32, Boolean, OffsetReference, Int32, Int32, Boolean) | Drag this control, using the browser window as the drop target (Inherited from HtmlControl.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Events collection set on this control (Inherited from HtmlControl.)
 | Finalize() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindParentContainer<(Of TContainerControl>)() | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
 | GetAttributeAsString(String) | Get an attribute of this element as a string (Inherited from HtmlControl.)
 | GetComputedStyle(String) | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
 | GetComputedStyleValue(String) | Returns computed style value. Computed style represents the final computed value of all CSS properties for the element. (Inherited from HtmlControl.)
 | GetHashCode() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetRectangle() | The absolute screen position of the control. (Inherited from HtmlControl.)
 | GetStyle(String) | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
 | GetStyleValue(String) | Returns any style as if you are accessing the element.style object from javascript. (Inherited from HtmlControl.)
 | GetType() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue<(Of T>)(String) | Get a property value (i.e. control.border or control.style.backgroundColor). string s = myControl.GetValue<string>("style.backgroundColor") (Inherited from HtmlControl.)
 | ID | Control's ID if set. (Inherited from HtmlControl.)
 | InvokeEvent(ScriptEventType) | Invokes an event on this control (Inherited from HtmlControl.)
 | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
 | IsVisible() | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
 | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
 | MemberwiseClone() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MouseClick() | Uses the Desktop.Mouse object to move the mouse to this control and click it. (Inherited from HtmlControl.)
 | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to this control and click it. (Inherited from HtmlControl.)
 | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to this control and click it. (Inherited from HtmlControl.)
 | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to this control and click it. (Inherited from HtmlControl.)
 | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to this control and click it. (Inherited from HtmlControl.)
 | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over the control (Inherited from HtmlControl.)
 | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over the control (Inherited from HtmlControl.)
 | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over the control (Inherited from HtmlControl.)
 | Name | Gets the name attribute for control (Inherited from HtmlInputControl.)
 | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
 | Parent<(Of TContainerControl>)() | Return the parent HtmlContainerControl of desired type that this control is contained in. If control is not found, will return null. (Inherited from HtmlControl.)
 | Refresh() | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
 | ScrollLeft | Gets/Sets the scrollLeft value of the html control. (Inherited from HtmlControl.)
 | ScrollTop | Gets/Sets the scrollTop value of the html control (Inherited from HtmlControl.)
 | ScrollToVisible(ScrollToVisibleType) | Scroll control to Visible Position on the page (Inherited from HtmlControl.)
 | SetValue<(Of T>)(String, T) | Set a property value. (i.e. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
 | Styles | Styles collection set on this control and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
 | TagName | The tag name of this element (Inherited from HtmlControl.)
 | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
 | ToString() | Returns a String that represents the current Object. (Inherited from Object.)
 | Type | Input control type (Inherited from HtmlInputControl.)
 | ValidateControl() | Validate a control using a its Locator. (Inherited from HtmlControl.)
 | ValidateTag(String) | Validate a tag name (Inherited from HtmlControl.)
 | ValidateType(InputElementType) | Validates the type of the input control. (Inherited from HtmlInputControl.)
 | Value | Gets or sets the value attribute for control (Inherited from HtmlInputControl.)
 | Wait | Gets the HTML Wait object. (Inherited from HtmlControl.)
Inheritance Hierarchy
Object
 | Control
 |  | HtmlControl
 |  |  | HtmlInputControl
 |  |  |  | HtmlInputRadioButton


AssignElement(e) method

HtmlInputRadioButton.AssignElement(e) method
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlInputRadioButton > AssignElement(Element)
Assign element and initialize this control.
Syntax
C#
public override void AssignElement (
    Element e
)
Parameters
e (Element)
The base element.


Check(isChecked, invokeOnClickChanged) method

HtmlInputRadioButton.Check(isChecked, invokeOnClickChanged) method
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlInputRadioButton > Check(Boolean, Boolean)
Sets the Checked state to isChecked and optionally invokes the onclick event.
Syntax
C#
public void Check (
    bool isChecked,
    bool invokeOnClickChanged
)
Parameters
isChecked (Boolean)
The checked state to set.
invokeOnClickChanged (Boolean)
True/False whether to invoke the click event.


Checked property

HtmlInputRadioButton.Checked property
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlInputRadioButton > Checked
Gets/Sets whether or not a checkbox should be checked.
Syntax
C#
public bool Checked { get; set; }


Constructors

HtmlInputRadioButton constructors
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlInputRadioButton > HtmlInputRadioButtonNew
Members
Icon | Member | Description
 | HtmlInputRadioButtonNew() | Create a new control.
 | HtmlInputRadioButtonNew(Element) | Create a new control.


HtmlInputRadioButton() constructor

HtmlInputRadioButton() constructor
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlInputRadioButton > HtmlInputRadioButtonNew()
Create a new control.
Syntax
C#
public HtmlInputRadioButton ()


HtmlInputRadioButton(element) constructor

HtmlInputRadioButton(element) constructor
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlInputRadioButton > HtmlInputRadioButtonNew(Element)
Create a new control.
Syntax
C#
public HtmlInputRadioButton (
    Element element
)
Parameters
element (Element)
The base element.


HtmlInputRadioButtonExtensions class

HtmlInputRadioButtonExtensions class
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlInputRadioButtonExtensions
Assert extensions for the HtmlControl class.
Syntax
C#
[ExtensionAttribute]
public static class HtmlInputRadioButtonExtensions
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AssertCheck(HtmlInputRadioButton) | Assert methods for the control content.
Inheritance Hierarchy
Object
HtmlInputRadioButtonExtensions


AssertCheck(control) method

HtmlInputRadioButtonExtensions.AssertCheck(control) method
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlInputRadioButtonExtensions > AssertCheck(HtmlInputRadioButton)
Assert methods for the control content.
Syntax
C#
[ExtensionAttribute]
public static AssertCheck AssertCheck (
    HtmlInputRadioButton control
)
Parameters
control (HtmlInputRadioButton)
Return Value


HtmlInputReset class

HtmlInputReset class
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlInputReset
Test class for an HtmlInputImage element <input type="reset" />
Syntax
C#
public class HtmlInputReset : HtmlInputControl
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | HtmlInputResetNew() | Create a new control.
 | HtmlInputResetNew(Element) | Create a new control.
 | AssignElement(Element) | Assign element and initialize this control. (Overrides HtmlInputControl.AssignElement(Element).)
 | AssignFailed(Exception) | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
 | Attributes | All attributes set on this control (Inherited from HtmlControl.)
 | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
 | Capture() | Captures and returns the image of the current Html Control. (Inherited from HtmlControl.)
 | Capture(String) | Captures and saves Html Control Image to the WebAii log location as a bmp file. (Inherited from HtmlControl.)
 | Capture(String, String) | Captures and saves Html Control Image to the specified save path as the specified image name in bmp format. (Inherited from HtmlControl.)
 | Click() | Invoke a click within the loaded page. (Inherited from HtmlControl.)
 | Click(Boolean) | Invoke a click that causes that browser window to close (i.e. this is common for html pop-ups) (Inherited from HtmlControl.)
 | CssClass | Control's CSS class if set. (Inherited from HtmlControl.)
 | Download(Boolean, DownloadOption, String, Int32) | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
 | DragTo(HtmlControl) | Drag this control to the center on the destination control. (Inherited from HtmlControl.)
 | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination control with an offset of where within the destination control to drag to. (Inherited from HtmlControl.)
 | DragTo(Int32, Int32) | Drag this control to a relative X/Y offset. (Inherited from HtmlControl.)
 | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this control by specifying a reference point on the control rectangle to start the drag from and a reference point on the destination control to specify the drop location. (Inherited from HtmlControl.)
 | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this control from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
 | DragTo(OffsetReference, Point, HtmlControl) | Drag this control by specifying a reference point on the control rectangle to start the drag from with an offset and drop on the destination control center. (Inherited from HtmlControl.)
 | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this control by specifying a reference point on the control rectangle to start the drag from and a reference point on the destination control to specify the drop location. (Inherited from HtmlControl.)
 | DragTo(OffsetReference, Point, Int32, Int32) | Drag this control from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
 | DragTo(Point) | Drag this control to an absolute point. (Inherited from HtmlControl.)
 | DragToWindowLocation(OffsetReference, Int32, Int32, Boolean, OffsetReference, Int32, Int32, Boolean) | Drag this control, using the browser window as the drop target (Inherited from HtmlControl.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Events collection set on this control (Inherited from HtmlControl.)
 | Finalize() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindParentContainer<(Of TContainerControl>)() | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
 | GetAttributeAsString(String) | Get an attribute of this element as a string (Inherited from HtmlControl.)
 | GetComputedStyle(String) | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
 | GetComputedStyleValue(String) | Returns computed style value. Computed style represents the final computed value of all CSS properties for the element. (Inherited from HtmlControl.)
 | GetHashCode() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetRectangle() | The absolute screen position of the control. (Inherited from HtmlControl.)
 | GetStyle(String) | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
 | GetStyleValue(String) | Returns any style as if you are accessing the element.style object from javascript. (Inherited from HtmlControl.)
 | GetType() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue<(Of T>)(String) | Get a property value (i.e. control.border or control.style.backgroundColor). string s = myControl.GetValue<string>("style.backgroundColor") (Inherited from HtmlControl.)
 | ID | Control's ID if set. (Inherited from HtmlControl.)
 | InvokeEvent(ScriptEventType) | Invokes an event on this control (Inherited from HtmlControl.)
 | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
 | IsVisible() | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
 | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
 | MemberwiseClone() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MouseClick() | Uses the Desktop.Mouse object to move the mouse to this control and click it. (Inherited from HtmlControl.)
 | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to this control and click it. (Inherited from HtmlControl.)
 | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to this control and click it. (Inherited from HtmlControl.)
 | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to this control and click it. (Inherited from HtmlControl.)
 | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to this control and click it. (Inherited from HtmlControl.)
 | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over the control (Inherited from HtmlControl.)
 | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over the control (Inherited from HtmlControl.)
 | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over the control (Inherited from HtmlControl.)
 | Name | Gets the name attribute for control (Inherited from HtmlInputControl.)
 | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
 | Parent<(Of TContainerControl>)() | Return the parent HtmlContainerControl of desired type that this control is contained in. If control is not found, will return null. (Inherited from HtmlControl.)
 | Refresh() | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
 | ScrollLeft | Gets/Sets the scrollLeft value of the html control. (Inherited from HtmlControl.)
 | ScrollTop | Gets/Sets the scrollTop value of the html control (Inherited from HtmlControl.)
 | ScrollToVisible(ScrollToVisibleType) | Scroll control to Visible Position on the page (Inherited from HtmlControl.)
 | SetValue<(Of T>)(String, T) | Set a property value. (i.e. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
 | Styles | Styles collection set on this control and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
 | TagName | The tag name of this element (Inherited from HtmlControl.)
 | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
 | ToString() | Returns a String that represents the current Object. (Inherited from Object.)
 | Type | Input control type (Inherited from HtmlInputControl.)
 | ValidateControl() | Validate a control using a its Locator. (Inherited from HtmlControl.)
 | ValidateTag(String) | Validate a tag name (Inherited from HtmlControl.)
 | ValidateType(InputElementType) | Validates the type of the input control. (Inherited from HtmlInputControl.)
 | Value | Gets or sets the value attribute for control (Inherited from HtmlInputControl.)
 | Wait | Gets the HTML Wait object. (Inherited from HtmlControl.)
Inheritance Hierarchy
Object
 | Control
 |  | HtmlControl
 |  |  | HtmlInputControl
 |  |  |  | HtmlInputReset


AssignElement(e) method

HtmlInputReset.AssignElement(e) method
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlInputReset > AssignElement(Element)
Assign element and initialize this control.
Syntax
C#
public override void AssignElement (
    Element e
)
Parameters
e (Element)
The base element.


Constructors

HtmlInputReset constructors
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlInputReset > HtmlInputResetNew
Members
Icon | Member | Description
 | HtmlInputResetNew() | Create a new control.
 | HtmlInputResetNew(Element) | Create a new control.


HtmlInputReset() constructor

HtmlInputReset() constructor
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlInputReset > HtmlInputResetNew()
Create a new control.
Syntax
C#
public HtmlInputReset ()


HtmlInputReset(element) constructor

HtmlInputReset(element) constructor
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlInputReset > HtmlInputResetNew(Element)
Create a new control.
Syntax
C#
public HtmlInputReset (
    Element element
)
Parameters
element (Element)
The base element.


HtmlInputSubmit class

HtmlInputSubmit class
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlInputSubmit
Test class for an HtmlInputImage element <input type="reset" />
Syntax
C#
public class HtmlInputSubmit : HtmlInputControl
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | HtmlInputSubmitNew() | Create a new control.
 | HtmlInputSubmitNew(Element) | Create a new control.
 | AssignElement(Element) | Assign element and initialize this control. (Overrides HtmlInputControl.AssignElement(Element).)
 | AssignFailed(Exception) | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
 | Attributes | All attributes set on this control (Inherited from HtmlControl.)
 | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
 | Capture() | Captures and returns the image of the current Html Control. (Inherited from HtmlControl.)
 | Capture(String) | Captures and saves Html Control Image to the WebAii log location as a bmp file. (Inherited from HtmlControl.)
 | Capture(String, String) | Captures and saves Html Control Image to the specified save path as the specified image name in bmp format. (Inherited from HtmlControl.)
 | Click() | Invoke a click within the loaded page. (Inherited from HtmlControl.)
 | Click(Boolean) | Invoke a click that causes that browser window to close (i.e. this is common for html pop-ups) (Inherited from HtmlControl.)
 | CssClass | Control's CSS class if set. (Inherited from HtmlControl.)
 | Download(Boolean, DownloadOption, String, Int32) | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
 | DragTo(HtmlControl) | Drag this control to the center on the destination control. (Inherited from HtmlControl.)
 | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination control with an offset of where within the destination control to drag to. (Inherited from HtmlControl.)
 | DragTo(Int32, Int32) | Drag this control to a relative X/Y offset. (Inherited from HtmlControl.)
 | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this control by specifying a reference point on the control rectangle to start the drag from and a reference point on the destination control to specify the drop location. (Inherited from HtmlControl.)
 | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this control from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
 | DragTo(OffsetReference, Point, HtmlControl) | Drag this control by specifying a reference point on the control rectangle to start the drag from with an offset and drop on the destination control center. (Inherited from HtmlControl.)
 | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this control by specifying a reference point on the control rectangle to start the drag from and a reference point on the destination control to specify the drop location. (Inherited from HtmlControl.)
 | DragTo(OffsetReference, Point, Int32, Int32) | Drag this control from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
 | DragTo(Point) | Drag this control to an absolute point. (Inherited from HtmlControl.)
 | DragToWindowLocation(OffsetReference, Int32, Int32, Boolean, OffsetReference, Int32, Int32, Boolean) | Drag this control, using the browser window as the drop target (Inherited from HtmlControl.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Events collection set on this control (Inherited from HtmlControl.)
 | Finalize() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindParentContainer<(Of TContainerControl>)() | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
 | GetAttributeAsString(String) | Get an attribute of this element as a string (Inherited from HtmlControl.)
 | GetComputedStyle(String) | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
 | GetComputedStyleValue(String) | Returns computed style value. Computed style represents the final computed value of all CSS properties for the element. (Inherited from HtmlControl.)
 | GetHashCode() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetRectangle() | The absolute screen position of the control. (Inherited from HtmlControl.)
 | GetStyle(String) | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
 | GetStyleValue(String) | Returns any style as if you are accessing the element.style object from javascript. (Inherited from HtmlControl.)
 | GetType() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue<(Of T>)(String) | Get a property value (i.e. control.border or control.style.backgroundColor). string s = myControl.GetValue<string>("style.backgroundColor") (Inherited from HtmlControl.)
 | ID | Control's ID if set. (Inherited from HtmlControl.)
 | InvokeEvent(ScriptEventType) | Invokes an event on this control (Inherited from HtmlControl.)
 | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
 | IsVisible() | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
 | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
 | MemberwiseClone() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MouseClick() | Uses the Desktop.Mouse object to move the mouse to this control and click it. (Inherited from HtmlControl.)
 | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to this control and click it. (Inherited from HtmlControl.)
 | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to this control and click it. (Inherited from HtmlControl.)
 | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to this control and click it. (Inherited from HtmlControl.)
 | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to this control and click it. (Inherited from HtmlControl.)
 | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over the control (Inherited from HtmlControl.)
 | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over the control (Inherited from HtmlControl.)
 | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over the control (Inherited from HtmlControl.)
 | Name | Gets the name attribute for control (Inherited from HtmlInputControl.)
 | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
 | Parent<(Of TContainerControl>)() | Return the parent HtmlContainerControl of desired type that this control is contained in. If control is not found, will return null. (Inherited from HtmlControl.)
 | Refresh() | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
 | ScrollLeft | Gets/Sets the scrollLeft value of the html control. (Inherited from HtmlControl.)
 | ScrollTop | Gets/Sets the scrollTop value of the html control (Inherited from HtmlControl.)
 | ScrollToVisible(ScrollToVisibleType) | Scroll control to Visible Position on the page (Inherited from HtmlControl.)
 | SetValue<(Of T>)(String, T) | Set a property value. (i.e. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
 | Styles | Styles collection set on this control and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
 | TagName | The tag name of this element (Inherited from HtmlControl.)
 | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
 | ToString() | Returns a String that represents the current Object. (Inherited from Object.)
 | Type | Input control type (Inherited from HtmlInputControl.)
 | ValidateControl() | Validate a control using a its Locator. (Inherited from HtmlControl.)
 | ValidateTag(String) | Validate a tag name (Inherited from HtmlControl.)
 | ValidateType(InputElementType) | Validates the type of the input control. (Inherited from HtmlInputControl.)
 | Value | Gets or sets the value attribute for control (Inherited from HtmlInputControl.)
 | Wait | Gets the HTML Wait object. (Inherited from HtmlControl.)
Inheritance Hierarchy
Object
 | Control
 |  | HtmlControl
 |  |  | HtmlInputControl
 |  |  |  | HtmlInputSubmit


AssignElement(e) method

HtmlInputSubmit.AssignElement(e) method
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlInputSubmit > AssignElement(Element)
Assign element and initialize this control.
Syntax
C#
public override void AssignElement (
    Element e
)
Parameters
e (Element)
The base element.


Constructors

HtmlInputSubmit constructors
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlInputSubmit > HtmlInputSubmitNew
Members
Icon | Member | Description
 | HtmlInputSubmitNew() | Create a new control.
 | HtmlInputSubmitNew(Element) | Create a new control.


HtmlInputSubmit() constructor

HtmlInputSubmit() constructor
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlInputSubmit > HtmlInputSubmitNew()
Create a new control.
Syntax
C#
public HtmlInputSubmit ()


HtmlInputSubmit(element) constructor

HtmlInputSubmit(element) constructor
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlInputSubmit > HtmlInputSubmitNew(Element)
Create a new control.
Syntax
C#
public HtmlInputSubmit (
    Element element
)
Parameters
element (Element)
The base element.


HtmlInputText class

HtmlInputText class
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlInputText
Test class for an HtmlInputImage element <input type="text" />
Syntax
C#
public class HtmlInputText : HtmlInputControl
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | HtmlInputTextNew() | Create a new control.
 | HtmlInputTextNew(Element) | Create a new control.
 | AssignElement(Element) | Assign element and initialize this control. (Overrides HtmlInputControl.AssignElement(Element).)
 | AssignFailed(Exception) | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
 | Attributes | All attributes set on this control (Inherited from HtmlControl.)
 | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
 | Capture() | Captures and returns the image of the current Html Control. (Inherited from HtmlControl.)
 | Capture(String) | Captures and saves Html Control Image to the WebAii log location as a bmp file. (Inherited from HtmlControl.)
 | Capture(String, String) | Captures and saves Html Control Image to the specified save path as the specified image name in bmp format. (Inherited from HtmlControl.)
 | Click() | Invoke a click within the loaded page. (Inherited from HtmlControl.)
 | Click(Boolean) | Invoke a click that causes that browser window to close (i.e. this is common for html pop-ups) (Inherited from HtmlControl.)
 | CssClass | Control's CSS class if set. (Inherited from HtmlControl.)
 | Disabled | Gets whether or not a text field is disabled
 | Download(Boolean, DownloadOption, String, Int32) | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
 | DragTo(HtmlControl) | Drag this control to the center on the destination control. (Inherited from HtmlControl.)
 | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination control with an offset of where within the destination control to drag to. (Inherited from HtmlControl.)
 | DragTo(Int32, Int32) | Drag this control to a relative X/Y offset. (Inherited from HtmlControl.)
 | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this control by specifying a reference point on the control rectangle to start the drag from and a reference point on the destination control to specify the drop location. (Inherited from HtmlControl.)
 | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this control from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
 | DragTo(OffsetReference, Point, HtmlControl) | Drag this control by specifying a reference point on the control rectangle to start the drag from with an offset and drop on the destination control center. (Inherited from HtmlControl.)
 | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this control by specifying a reference point on the control rectangle to start the drag from and a reference point on the destination control to specify the drop location. (Inherited from HtmlControl.)
 | DragTo(OffsetReference, Point, Int32, Int32) | Drag this control from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
 | DragTo(Point) | Drag this control to an absolute point. (Inherited from HtmlControl.)
 | DragToWindowLocation(OffsetReference, Int32, Int32, Boolean, OffsetReference, Int32, Int32, Boolean) | Drag this control, using the browser window as the drop target (Inherited from HtmlControl.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Events collection set on this control (Inherited from HtmlControl.)
 | Finalize() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindParentContainer<(Of TContainerControl>)() | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
 | GetAttributeAsString(String) | Get an attribute of this element as a string (Inherited from HtmlControl.)
 | GetComputedStyle(String) | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
 | GetComputedStyleValue(String) | Returns computed style value. Computed style represents the final computed value of all CSS properties for the element. (Inherited from HtmlControl.)
 | GetHashCode() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetRectangle() | The absolute screen position of the control. (Inherited from HtmlControl.)
 | GetStyle(String) | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
 | GetStyleValue(String) | Returns any style as if you are accessing the element.style object from javascript. (Inherited from HtmlControl.)
 | GetType() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue<(Of T>)(String) | Get a property value (i.e. control.border or control.style.backgroundColor). string s = myControl.GetValue<string>("style.backgroundColor") (Inherited from HtmlControl.)
 | ID | Control's ID if set. (Inherited from HtmlControl.)
 | InvokeEvent(ScriptEventType) | Invokes an event on this control (Inherited from HtmlControl.)
 | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
 | IsVisible() | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
 | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
 | MemberwiseClone() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MouseClick() | Uses the Desktop.Mouse object to move the mouse to this control and click it. (Inherited from HtmlControl.)
 | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to this control and click it. (Inherited from HtmlControl.)
 | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to this control and click it. (Inherited from HtmlControl.)
 | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to this control and click it. (Inherited from HtmlControl.)
 | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to this control and click it. (Inherited from HtmlControl.)
 | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over the control (Inherited from HtmlControl.)
 | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over the control (Inherited from HtmlControl.)
 | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over the control (Inherited from HtmlControl.)
 | Name | Gets the name attribute for control (Inherited from HtmlInputControl.)
 | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
 | Parent<(Of TContainerControl>)() | Return the parent HtmlContainerControl of desired type that this control is contained in. If control is not found, will return null. (Inherited from HtmlControl.)
 | Refresh() | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
 | ScrollLeft | Gets/Sets the scrollLeft value of the html control. (Inherited from HtmlControl.)
 | ScrollTop | Gets/Sets the scrollTop value of the html control (Inherited from HtmlControl.)
 | ScrollToVisible(ScrollToVisibleType) | Scroll control to Visible Position on the page (Inherited from HtmlControl.)
 | SetValue<(Of T>)(String, T) | Set a property value. (i.e. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
 | Size | Gets the size of a text field (in number of characters).
 | Styles | Styles collection set on this control and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
 | TabIndex | Gets the tab order for a text field.
 | TagName | The tag name of this element (Inherited from HtmlControl.)
 | Text | Gets/Sets the value of the value attribute of a text field
 | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
 | ToString() | Returns a String that represents the current Object. (Inherited from Object.)
 | Type | Input control type (Inherited from HtmlInputControl.)
 | ValidateControl() | Validate a control using a its Locator. (Inherited from HtmlControl.)
 | ValidateTag(String) | Validate a tag name (Inherited from HtmlControl.)
 | ValidateType(InputElementType) | Validates the type of the input control. (Inherited from HtmlInputControl.)
 | Value | Gets or sets the value attribute for control (Inherited from HtmlInputControl.)
 | Wait | Gets the HTML Wait object. (Inherited from HtmlControl.)
Inheritance Hierarchy
Object
 | Control
 |  | HtmlControl
 |  |  | HtmlInputControl
 |  |  |  | HtmlInputText


AssignElement(e) method

HtmlInputText.AssignElement(e) method
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlInputText > AssignElement(Element)
Assign element and initialize this control.
Syntax
C#
public override void AssignElement (
    Element e
)
Parameters
e (Element)
The base element.


Constructors

HtmlInputText constructors
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlInputText > HtmlInputTextNew
Members
Icon | Member | Description
 | HtmlInputTextNew() | Create a new control.
 | HtmlInputTextNew(Element) | Create a new control.


HtmlInputText() constructor

HtmlInputText() constructor
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlInputText > HtmlInputTextNew()
Create a new control.
Syntax
C#
public HtmlInputText ()


HtmlInputText(element) constructor

HtmlInputText(element) constructor
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlInputText > HtmlInputTextNew(Element)
Create a new control.
Syntax
C#
public HtmlInputText (
    Element element
)
Parameters
element (Element)
The base element.


Disabled property

HtmlInputText.Disabled property
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlInputText > Disabled
Gets whether or not a text field is disabled
Syntax
C#
public bool Disabled { get; }


Size property

HtmlInputText.Size property
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlInputText > Size
Gets the size of a text field (in number of characters).
Syntax
C#
public int Size { get; }


TabIndex property

HtmlInputText.TabIndex property
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlInputText > TabIndex
Gets the tab order for a text field.
Syntax
C#
public int TabIndex { get; }


Text property

HtmlInputText.Text property
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlInputText > Text
Gets/Sets the value of the value attribute of a text field
Syntax
C#
[DebuggerBrowsableAttribute(DebuggerBrowsableState.Never)]
public string Text { get; set; }


HtmlOption class

HtmlOption class
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlOption
Test class for an HtmlOption element <option ... />
Syntax
C#
public class HtmlOption : HtmlControl
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | HtmlOptionNew() | Create a new control.
 | HtmlOptionNew(Element) | Create a new control.
 | AssignElement(Element) | Assign element and initialize this control. (Overrides HtmlControl.AssignElement(Element).)
 | AssignFailed(Exception) | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
 | Attributes | All attributes set on this control (Inherited from HtmlControl.)
 | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
 | Capture() | Captures and returns the image of the current Html Control. (Inherited from HtmlControl.)
 | Capture(String) | Captures and saves Html Control Image to the WebAii log location as a bmp file. (Inherited from HtmlControl.)
 | Capture(String, String) | Captures and saves Html Control Image to the specified save path as the specified image name in bmp format. (Inherited from HtmlControl.)
 | Click() | Invoke a click within the loaded page. (Inherited from HtmlControl.)
 | Click(Boolean) | Invoke a click that causes that browser window to close (i.e. this is common for html pop-ups) (Inherited from HtmlControl.)
 | CssClass | Control's CSS class if set. (Inherited from HtmlControl.)
 | Download(Boolean, DownloadOption, String, Int32) | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
 | DragTo(HtmlControl) | Drag this control to the center on the destination control. (Inherited from HtmlControl.)
 | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination control with an offset of where within the destination control to drag to. (Inherited from HtmlControl.)
 | DragTo(Int32, Int32) | Drag this control to a relative X/Y offset. (Inherited from HtmlControl.)
 | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this control by specifying a reference point on the control rectangle to start the drag from and a reference point on the destination control to specify the drop location. (Inherited from HtmlControl.)
 | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this control from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
 | DragTo(OffsetReference, Point, HtmlControl) | Drag this control by specifying a reference point on the control rectangle to start the drag from with an offset and drop on the destination control center. (Inherited from HtmlControl.)
 | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this control by specifying a reference point on the control rectangle to start the drag from and a reference point on the destination control to specify the drop location. (Inherited from HtmlControl.)
 | DragTo(OffsetReference, Point, Int32, Int32) | Drag this control from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
 | DragTo(Point) | Drag this control to an absolute point. (Inherited from HtmlControl.)
 | DragToWindowLocation(OffsetReference, Int32, Int32, Boolean, OffsetReference, Int32, Int32, Boolean) | Drag this control, using the browser window as the drop target (Inherited from HtmlControl.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Events collection set on this control (Inherited from HtmlControl.)
 | Finalize() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindParentContainer<(Of TContainerControl>)() | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
 | GetAttributeAsString(String) | Get an attribute of this element as a string (Inherited from HtmlControl.)
 | GetComputedStyle(String) | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
 | GetComputedStyleValue(String) | Returns computed style value. Computed style represents the final computed value of all CSS properties for the element. (Inherited from HtmlControl.)
 | GetHashCode() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetRectangle() | The absolute screen position of the control. (Inherited from HtmlControl.)
 | GetStyle(String) | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
 | GetStyleValue(String) | Returns any style as if you are accessing the element.style object from javascript. (Inherited from HtmlControl.)
 | GetType() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue<(Of T>)(String) | Get a property value (i.e. control.border or control.style.backgroundColor). string s = myControl.GetValue<string>("style.backgroundColor") (Inherited from HtmlControl.)
 | ID | Control's ID if set. (Inherited from HtmlControl.)
 | InvokeEvent(ScriptEventType) | Invokes an event on this control (Inherited from HtmlControl.)
 | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
 | IsVisible() | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
 | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
 | MemberwiseClone() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MouseClick() | Uses the Desktop.Mouse object to move the mouse to this control and click it. (Inherited from HtmlControl.)
 | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to this control and click it. (Inherited from HtmlControl.)
 | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to this control and click it. (Inherited from HtmlControl.)
 | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to this control and click it. (Inherited from HtmlControl.)
 | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to this control and click it. (Inherited from HtmlControl.)
 | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over the control (Inherited from HtmlControl.)
 | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over the control (Inherited from HtmlControl.)
 | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over the control (Inherited from HtmlControl.)
 | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
 | Parent<(Of TContainerControl>)() | Return the parent HtmlContainerControl of desired type that this control is contained in. If control is not found, will return null. (Inherited from HtmlControl.)
 | Refresh() | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
 | ScrollLeft | Gets/Sets the scrollLeft value of the html control. (Inherited from HtmlControl.)
 | ScrollTop | Gets/Sets the scrollTop value of the html control (Inherited from HtmlControl.)
 | ScrollToVisible(ScrollToVisibleType) | Scroll control to Visible Position on the page (Inherited from HtmlControl.)
 | Selected | Gets or sets this options selection.
 | SetValue<(Of T>)(String, T) | Set a property value. (i.e. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
 | Styles | Styles collection set on this control and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
 | TagName | The tag name of this element (Inherited from HtmlControl.)
 | Text | Return the Text that is set for this option.
 | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
 | ToString() | Returns a String that represents the current Object. (Inherited from Object.)
 | ValidateControl() | Validate a control using a its Locator. (Inherited from HtmlControl.)
 | ValidateTag(String) | Validate a tag name (Inherited from HtmlControl.)
 | Value | Gets the value that is set for this option.
 | Wait | Gets the HTML Wait object. (Inherited from HtmlControl.)
Inheritance Hierarchy
Object
 | Control
 |  | HtmlControl
 |  |  | HtmlOption


AssignElement(e) method

HtmlOption.AssignElement(e) method
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlOption > AssignElement(Element)
Assign element and initialize this control.
Syntax
C#
public override void AssignElement (
    Element e
)
Parameters
e (Element)
The base element.


Constructors

HtmlOption constructors
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlOption > HtmlOptionNew
Members
Icon | Member | Description
 | HtmlOptionNew() | Create a new control.
 | HtmlOptionNew(Element) | Create a new control.


HtmlOption() constructor

HtmlOption() constructor
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlOption > HtmlOptionNew()
Create a new control.
Syntax
C#
public HtmlOption ()


HtmlOption(element) constructor

HtmlOption(element) constructor
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlOption > HtmlOptionNew(Element)
Create a new control.
Syntax
C#
public HtmlOption (
    Element element
)
Parameters
element (Element)
The base element.


Selected property

HtmlOption.Selected property
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlOption > Selected
Gets or sets this options selection.
Syntax
C#
[DebuggerBrowsableAttribute(DebuggerBrowsableState.Never)]
public bool Selected { get; set; }


Text property

HtmlOption.Text property
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlOption > Text
Return the Text that is set for this option.
Syntax
C#
public string Text { get; }


Value property

HtmlOption.Value property
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlOption > Value
Gets the value that is set for this option.
Syntax
C#
public string Value { get; }


HtmlSelect class

HtmlSelect class
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlSelect
Test class for an HtmlSelect element <select>...</select>
Syntax
C#
[DefaultMemberAttribute("Item")]
public class HtmlSelect : HtmlContainerControl
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | HtmlSelectNew() | Create a new control.
 | HtmlSelectNew(Element) | Create a new control.
 | AssignElement(Element) | Assign element and initialize this control. (Overrides HtmlContainerControl.AssignElement(Element).)
 | AssignFailed(Exception) | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
 | Attributes | All attributes set on this control (Inherited from HtmlControl.)
 | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
 | Capture() | Captures and returns the image of the current Html Control. (Inherited from HtmlControl.)
 | Capture(String) | Captures and saves Html Control Image to the WebAii log location as a bmp file. (Inherited from HtmlControl.)
 | Capture(String, String) | Captures and saves Html Control Image to the specified save path as the specified image name in bmp format. (Inherited from HtmlControl.)
 | Click() | Invoke a click within the loaded page. (Inherited from HtmlControl.)
 | Click(Boolean) | Invoke a click that causes that browser window to close (i.e. this is common for html pop-ups) (Inherited from HtmlControl.)
 | CssClass | Control's CSS class if set. (Inherited from HtmlControl.)
 | Download(Boolean, DownloadOption, String, Int32) | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
 | DragTo(HtmlControl) | Drag this control to the center on the destination control. (Inherited from HtmlControl.)
 | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination control with an offset of where within the destination control to drag to. (Inherited from HtmlControl.)
 | DragTo(Int32, Int32) | Drag this control to a relative X/Y offset. (Inherited from HtmlControl.)
 | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this control by specifying a reference point on the control rectangle to start the drag from and a reference point on the destination control to specify the drop location. (Inherited from HtmlControl.)
 | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this control from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
 | DragTo(OffsetReference, Point, HtmlControl) | Drag this control by specifying a reference point on the control rectangle to start the drag from with an offset and drop on the destination control center. (Inherited from HtmlControl.)
 | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this control by specifying a reference point on the control rectangle to start the drag from and a reference point on the destination control to specify the drop location. (Inherited from HtmlControl.)
 | DragTo(OffsetReference, Point, Int32, Int32) | Drag this control from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
 | DragTo(Point) | Drag this control to an absolute point. (Inherited from HtmlControl.)
 | DragToWindowLocation(OffsetReference, Int32, Int32, Boolean, OffsetReference, Int32, Int32, Boolean) | Drag this control, using the browser window as the drop target (Inherited from HtmlControl.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Events collection set on this control (Inherited from HtmlControl.)
 | Finalize() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Find | Find property (Inherited from HtmlContainerControl.)
 | FindParentContainer<(Of TContainerControl>)() | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
 | GetAttributeAsString(String) | Get an attribute of this element as a string (Inherited from HtmlControl.)
 | GetComputedStyle(String) | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
 | GetComputedStyleValue(String) | Returns computed style value. Computed style represents the final computed value of all CSS properties for the element. (Inherited from HtmlControl.)
 | GetHashCode() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetRectangle() | The absolute screen position of the control. (Inherited from HtmlControl.)
 | GetStyle(String) | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
 | GetStyleValue(String) | Returns any style as if you are accessing the element.style object from javascript. (Inherited from HtmlControl.)
 | GetType() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue<(Of T>)(String) | Get a property value (i.e. control.border or control.style.backgroundColor). string s = myControl.GetValue<string>("style.backgroundColor") (Inherited from HtmlControl.)
 | ID | Control's ID if set. (Inherited from HtmlControl.)
 | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
 | InvokeEvent(ScriptEventType) | Invokes an event on this control (Inherited from HtmlControl.)
 | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
 | IsVisible() | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
 | Item(Int32) | Gets Html Option by its index
 | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
 | MemberwiseClone() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MouseClick() | Uses the Desktop.Mouse object to move the mouse to this control and click it. (Inherited from HtmlControl.)
 | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to this control and click it. (Inherited from HtmlControl.)
 | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to this control and click it. (Inherited from HtmlControl.)
 | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to this control and click it. (Inherited from HtmlControl.)
 | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to this control and click it. (Inherited from HtmlControl.)
 | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over the control (Inherited from HtmlControl.)
 | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over the control (Inherited from HtmlControl.)
 | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over the control (Inherited from HtmlControl.)
 | MultiSelect(HtmlOption[]()) | Multi select a set of options on the select drop down. You can also set the .Selected value on any HtmlOption.
 | MultiSelectByValue(String[]()) | Mutli select a set of options by passing in the values of these options to select
 | MutliSelectByText(String[]()) | Multi select a set of options by passing in the text of these options.
 | Options | Gets the List of Options.
 | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
 | Parent<(Of TContainerControl>)() | Return the parent HtmlContainerControl of desired type that this control is contained in. If control is not found, will return null. (Inherited from HtmlControl.)
 | Refresh() | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
 | ScrollLeft | Gets/Sets the scrollLeft value of the html control. (Inherited from HtmlControl.)
 | ScrollTop | Gets/Sets the scrollTop value of the html control (Inherited from HtmlControl.)
 | ScrollToVisible(ScrollToVisibleType) | Scroll control to Visible Position on the page (Inherited from HtmlControl.)
 | SelectByIndex(Int32) | Select a option by index.
 | SelectByIndex(Int32, Boolean) | Select ption by Index
 | SelectByPartialText(String, Boolean) | Select an option by partial text
 | SelectByPartialValue(String, Boolean) | Select an option by partial value.
 | SelectByText(String) | Select a option by text.
 | SelectByText(String, Boolean) | Select Option by Text
 | SelectByValue(String) | Select Option by Value
 | SelectByValue(String, Boolean) | Select Option by Value
 | SelectedIndex | Gets the selected index.
 | SelectedOption | Gets the HtmlOption that is currently selected.
 | SetValue<(Of T>)(String, T) | Set a property value. (i.e. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
 | Styles | Styles collection set on this control and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
 | TagName | The tag name of this element (Inherited from HtmlControl.)
 | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
 | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
 | ToString() | Returns a String that represents the current Object. (Inherited from Object.)
 | ValidateControl() | Validate a control using a its Locator. (Inherited from HtmlControl.)
 | ValidateTag(String) | Validate a tag name (Inherited from HtmlControl.)
 | Wait | Gets the HTML Wait object. (Inherited from HtmlControl.)
Inheritance Hierarchy
Object
 | Control
 |  | HtmlControl
 |  |  | HtmlContainerControl
 |  |  |  | HtmlSelect


AssignElement(e) method

HtmlSelect.AssignElement(e) method
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlSelect > AssignElement(Element)
Assign element and initialize this control.
Syntax
C#
public override void AssignElement (
    Element e
)
Parameters
e (Element)
The base element.


Constructors

HtmlSelect constructors
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlSelect > HtmlSelectNew
Members
Icon | Member | Description
 | HtmlSelectNew() | Create a new control.
 | HtmlSelectNew(Element) | Create a new control.


HtmlSelect() constructor

HtmlSelect() constructor
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlSelect > HtmlSelectNew()
Create a new control.
Syntax
C#
public HtmlSelect ()


HtmlSelect(element) constructor

HtmlSelect(element) constructor
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlSelect > HtmlSelectNew(Element)
Create a new control.
Syntax
C#
public HtmlSelect (
    Element element
)
Parameters
element (Element)
The base element.


Item[index] property

HtmlSelect.Item[index] property
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlSelect > Item(Int32)
Gets Html Option by its index
Syntax
C#
public HtmlOption this [
    int index
] { get; }
Parameters
index (Int32)
The desired index.
Return Value
The html option.


MultiSelect(options) method

HtmlSelect.MultiSelect(options) method
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlSelect > MultiSelect(HtmlOption[]())
Multi select a set of options on the select drop down. You can also set the .Selected value on any HtmlOption.
Syntax
C#
public void MultiSelect (
    params HtmlOption[] options
)
Parameters
options (HtmlOption []())
The list of options to select. These can be accessed fro the Options[] collection.


MultiSelectByValue(values) method

HtmlSelect.MultiSelectByValue(values) method
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlSelect > MultiSelectByValue(String[]())
Mutli select a set of options by passing in the values of these options to select
Syntax
C#
public void MultiSelectByValue (
    params string[] values
)
Parameters
values (String []())
The arrary of value of options to select.


MutliSelectByText(textStrings) method

HtmlSelect.MutliSelectByText(textStrings) method
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlSelect > MutliSelectByText(String[]())
Multi select a set of options by passing in the text of these options.
Syntax
C#
public void MutliSelectByText (
    params string[] textStrings
)
Parameters
textStrings (String []())
The array of strings option texts to select


Options property

HtmlSelect.Options property
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlSelect > Options
Gets the List of Options.
Syntax
C#
public ReadOnlyCollection<HtmlOption> Options { get; }


SelectByIndex methods

HtmlSelect.SelectByIndex methods
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlSelect > SelectByIndex
Members
Icon | Member | Description
 | SelectByIndex(Int32) | Select a option by index.
 | SelectByIndex(Int32, Boolean) | Select ption by Index


SelectByIndex(index) method

HtmlSelect.SelectByIndex(index) method
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlSelect > SelectByIndex(Int32)
Select a option by index.
Syntax
C#
public void SelectByIndex (
    int index
)
Parameters
index (Int32)
Index to select


SelectByIndex(index, invokeOnChangeEvent) method

HtmlSelect.SelectByIndex(index, invokeOnChangeEvent) method
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlSelect > SelectByIndex(Int32, Boolean)
Select ption by Index
Syntax
C#
public void SelectByIndex (
    int index,
    bool invokeOnChangeEvent
)
Parameters
index (Int32)
Index to select
invokeOnChangeEvent (Boolean)
Whether to invoke the onchange event.


SelectByPartialText(partialText, invokeOnChangeEvent) method

HtmlSelect.SelectByPartialText(partialText, invokeOnChangeEvent) method
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlSelect > SelectByPartialText(String, Boolean)
Select an option by partial text
Syntax
C#
public void SelectByPartialText (
    string partialText,
    bool invokeOnChangeEvent
)
Parameters
partialText (String)
The partial text to look for.
invokeOnChangeEvent (Boolean)
Whether to invoke the onchange event.


SelectByPartialValue(partialValue, invokeOnChangeEvent) method

HtmlSelect.SelectByPartialValue(partialValue, invokeOnChangeEvent) method
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlSelect > SelectByPartialValue(String, Boolean)
Select an option by partial value.
Syntax
C#
public void SelectByPartialValue (
    string partialValue,
    bool invokeOnChangeEvent
)
Parameters
partialValue (String)
The partial text to look for.
invokeOnChangeEvent (Boolean)
Whether to invoke the onchange event.


SelectByText methods

HtmlSelect.SelectByText methods
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlSelect > SelectByText
Members
Icon | Member | Description
 | SelectByText(String) | Select a option by text.
 | SelectByText(String, Boolean) | Select Option by Text


SelectByText(text) method

HtmlSelect.SelectByText(text) method
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlSelect > SelectByText(String)
Select a option by text.
Syntax
C#
public void SelectByText (
    string text
)
Parameters
text (String)
Text of the option to select


SelectByText(text, invokeOnChangeEvent) method

HtmlSelect.SelectByText(text, invokeOnChangeEvent) method
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlSelect > SelectByText(String, Boolean)
Select Option by Text
Syntax
C#
public void SelectByText (
    string text,
    bool invokeOnChangeEvent
)
Parameters
text (String)
Text of the option to select
invokeOnChangeEvent (Boolean)
Whether to invoke the onchange event.


SelectByValue methods

HtmlSelect.SelectByValue methods
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlSelect > SelectByValue
Members
Icon | Member | Description
 | SelectByValue(String) | Select Option by Value
 | SelectByValue(String, Boolean) | Select Option by Value


SelectByValue(value) method

HtmlSelect.SelectByValue(value) method
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlSelect > SelectByValue(String)
Select Option by Value
Syntax
C#
public void SelectByValue (
    string value
)
Parameters
value (String)
Value of option to select


SelectByValue(value, invokeOnChangeEvent) method

HtmlSelect.SelectByValue(value, invokeOnChangeEvent) method
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlSelect > SelectByValue(String, Boolean)
Select Option by Value
Syntax
C#
public void SelectByValue (
    string value,
    bool invokeOnChangeEvent
)
Parameters
value (String)
Value of option to select
invokeOnChangeEvent (Boolean)
Whether to invoke the onchange event.


SelectedIndex property

HtmlSelect.SelectedIndex property
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlSelect > SelectedIndex
Gets the selected index.
Syntax
C#
public int SelectedIndex { get; }


SelectedOption property

HtmlSelect.SelectedOption property
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlSelect > SelectedOption
Gets the HtmlOption that is currently selected.
Syntax
C#
[DebuggerBrowsableAttribute(DebuggerBrowsableState.Never)]
public HtmlOption SelectedOption { get; }


HtmlSelectAssertExtensions class

HtmlSelectAssertExtensions class
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlSelectAssertExtensions
Assert extensions for the HtmlControl class.
Syntax
C#
[ExtensionAttribute]
public static class HtmlSelectAssertExtensions
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AssertSelect(HtmlSelect) | Assert methods for the control content.
Inheritance Hierarchy
Object
HtmlSelectAssertExtensions


AssertSelect(control) method

HtmlSelectAssertExtensions.AssertSelect(control) method
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlSelectAssertExtensions > AssertSelect(HtmlSelect)
Assert methods for the control content.
Syntax
C#
[ExtensionAttribute]
public static AssertSelect AssertSelect (
    HtmlSelect control
)
Parameters
control (HtmlSelect)
Return Value


HtmlSpan class

HtmlSpan class
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlSpan
Test class for an HtmlSpan element <span>...</span>
Syntax
C#
public class HtmlSpan : HtmlContainerControl
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | HtmlSpanNew() | Create a new control.
 | HtmlSpanNew(Element) | Create a new control.
 | AssignElement(Element) | Assign element and initialize this control. (Overrides HtmlContainerControl.AssignElement(Element).)
 | AssignFailed(Exception) | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
 | Attributes | All attributes set on this control (Inherited from HtmlControl.)
 | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
 | Capture() | Captures and returns the image of the current Html Control. (Inherited from HtmlControl.)
 | Capture(String) | Captures and saves Html Control Image to the WebAii log location as a bmp file. (Inherited from HtmlControl.)
 | Capture(String, String) | Captures and saves Html Control Image to the specified save path as the specified image name in bmp format. (Inherited from HtmlControl.)
 | Click() | Invoke a click within the loaded page. (Inherited from HtmlControl.)
 | Click(Boolean) | Invoke a click that causes that browser window to close (i.e. this is common for html pop-ups) (Inherited from HtmlControl.)
 | CssClass | Control's CSS class if set. (Inherited from HtmlControl.)
 | Download(Boolean, DownloadOption, String, Int32) | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
 | DragTo(HtmlControl) | Drag this control to the center on the destination control. (Inherited from HtmlControl.)
 | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination control with an offset of where within the destination control to drag to. (Inherited from HtmlControl.)
 | DragTo(Int32, Int32) | Drag this control to a relative X/Y offset. (Inherited from HtmlControl.)
 | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this control by specifying a reference point on the control rectangle to start the drag from and a reference point on the destination control to specify the drop location. (Inherited from HtmlControl.)
 | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this control from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
 | DragTo(OffsetReference, Point, HtmlControl) | Drag this control by specifying a reference point on the control rectangle to start the drag from with an offset and drop on the destination control center. (Inherited from HtmlControl.)
 | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this control by specifying a reference point on the control rectangle to start the drag from and a reference point on the destination control to specify the drop location. (Inherited from HtmlControl.)
 | DragTo(OffsetReference, Point, Int32, Int32) | Drag this control from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
 | DragTo(Point) | Drag this control to an absolute point. (Inherited from HtmlControl.)
 | DragToWindowLocation(OffsetReference, Int32, Int32, Boolean, OffsetReference, Int32, Int32, Boolean) | Drag this control, using the browser window as the drop target (Inherited from HtmlControl.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Events collection set on this control (Inherited from HtmlControl.)
 | Finalize() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Find | Find property (Inherited from HtmlContainerControl.)
 | FindParentContainer<(Of TContainerControl>)() | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
 | GetAttributeAsString(String) | Get an attribute of this element as a string (Inherited from HtmlControl.)
 | GetComputedStyle(String) | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
 | GetComputedStyleValue(String) | Returns computed style value. Computed style represents the final computed value of all CSS properties for the element. (Inherited from HtmlControl.)
 | GetHashCode() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetRectangle() | The absolute screen position of the control. (Inherited from HtmlControl.)
 | GetStyle(String) | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
 | GetStyleValue(String) | Returns any style as if you are accessing the element.style object from javascript. (Inherited from HtmlControl.)
 | GetType() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue<(Of T>)(String) | Get a property value (i.e. control.border or control.style.backgroundColor). string s = myControl.GetValue<string>("style.backgroundColor") (Inherited from HtmlControl.)
 | ID | Control's ID if set. (Inherited from HtmlControl.)
 | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
 | InvokeEvent(ScriptEventType) | Invokes an event on this control (Inherited from HtmlControl.)
 | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
 | IsVisible() | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
 | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
 | MemberwiseClone() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MouseClick() | Uses the Desktop.Mouse object to move the mouse to this control and click it. (Inherited from HtmlControl.)
 | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to this control and click it. (Inherited from HtmlControl.)
 | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to this control and click it. (Inherited from HtmlControl.)
 | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to this control and click it. (Inherited from HtmlControl.)
 | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to this control and click it. (Inherited from HtmlControl.)
 | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over the control (Inherited from HtmlControl.)
 | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over the control (Inherited from HtmlControl.)
 | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over the control (Inherited from HtmlControl.)
 | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
 | Parent<(Of TContainerControl>)() | Return the parent HtmlContainerControl of desired type that this control is contained in. If control is not found, will return null. (Inherited from HtmlControl.)
 | Refresh() | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
 | ScrollLeft | Gets/Sets the scrollLeft value of the html control. (Inherited from HtmlControl.)
 | ScrollTop | Gets/Sets the scrollTop value of the html control (Inherited from HtmlControl.)
 | ScrollToVisible(ScrollToVisibleType) | Scroll control to Visible Position on the page (Inherited from HtmlControl.)
 | SetValue<(Of T>)(String, T) | Set a property value. (i.e. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
 | Styles | Styles collection set on this control and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
 | TagName | The tag name of this element (Inherited from HtmlControl.)
 | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
 | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
 | ToString() | Returns a String that represents the current Object. (Inherited from Object.)
 | ValidateControl() | Validate a control using a its Locator. (Inherited from HtmlControl.)
 | ValidateTag(String) | Validate a tag name (Inherited from HtmlControl.)
 | Wait | Gets the HTML Wait object. (Inherited from HtmlControl.)
Inheritance Hierarchy
Object
 | Control
 |  | HtmlControl
 |  |  | HtmlContainerControl
 |  |  |  | HtmlSpan


AssignElement(e) method

HtmlSpan.AssignElement(e) method
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlSpan > AssignElement(Element)
Assign element and initialize this control.
Syntax
C#
public override void AssignElement (
    Element e
)
Parameters
e (Element)
The base element.


Constructors

HtmlSpan constructors
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlSpan > HtmlSpanNew
Members
Icon | Member | Description
 | HtmlSpanNew() | Create a new control.
 | HtmlSpanNew(Element) | Create a new control.


HtmlSpan() constructor

HtmlSpan() constructor
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlSpan > HtmlSpanNew()
Create a new control.
Syntax
C#
public HtmlSpan ()


HtmlSpan(e) constructor

HtmlSpan(e) constructor
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlSpan > HtmlSpanNew(Element)
Create a new control.
Syntax
C#
public HtmlSpan (
    Element e
)
Parameters
e (Element)
The base element.


HtmlStyle class

HtmlStyle class
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlStyle
Represents a single HtmlStyle. This object can be used to help probe and do validation against Html styles. Has functionality to convert unit styles to int values and color styles to System.Drawing.Color.
Syntax
C#
public class HtmlStyle
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | HtmlStyleNew(String, String) | Create a new HtmlStyle object.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType() | Gets the Type of the current instance. (Inherited from Object.)
 | IsColor() | Whether the value of this style is a color value or not.
 | IsInt() | Whether the value of this style is an integer value or not.
 | IsSameColor(Color, Color) | Performs a simple color compare that only compares red/green/blue colors. Does not compare known color names or alpha blending.
 | MemberwiseClone() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets the style name.
 | ToColor() | Attempts to parse the style value as a color and return a System.Drawing.Color object that corresponds to the color style value.
 | ToHtmlColor(Color) | Translates a System.Drawing.Color to an Html color string.
 | ToInt() | Strips any style value from units (i.e. px/pt..etc) and returns the integer value.
 | ToString() | Returns a String that represents the current Object. (Inherited from Object.)
 | Value | Gets the style value.
Inheritance Hierarchy
Object
HtmlStyle


HtmlStyle(name, value) constructor

HtmlStyle(name, value) constructor
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlStyle > HtmlStyleNew(String, String)
Create a new HtmlStyle object.
Syntax
C#
public HtmlStyle (
    string name,
    string value
)
Parameters
name (String)
The name of the style.
value (String)
The raw value of this style.


IsColor() method

HtmlStyle.IsColor() method
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlStyle > IsColor()
Whether the value of this style is a color value or not.
Syntax
C#
public bool IsColor ()
Return Value
True if style value is a color


IsInt() method

HtmlStyle.IsInt() method
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlStyle > IsInt()
Whether the value of this style is an integer value or not.
Syntax
C#
public bool IsInt ()
Return Value
True if a value is an integer value.


IsSameColor(colorA, colorB) method

HtmlStyle.IsSameColor(colorA, colorB) method
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlStyle > IsSameColor(Color, Color)
Performs a simple color compare that only compares red/green/blue colors. Does not compare known color names or alpha blending.
Syntax
C#
public static bool IsSameColor (
    Color colorA,
    Color colorB
)
Parameters
colorA (Color)
Color A to compare
colorB (Color)
Color B to compare
Return Value
True/False whether the two colors have identical RGB colors.
Remarks
Use this to compare colors instead of System.Color.Equals() to allow your compares to work across browsers. For example, IE returns colors as named colors (yellow, red ..etc) for computed styles where Mozilla always returns (rgb(x,y,z)). Using the HtmlStyle.ToColor and IsSameColor() can help abstract these differences and allow you to perform the compare across browsers.


Name property

HtmlStyle.Name property
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlStyle > Name
Gets the style name.
Syntax
C#
public string Name { get; }


ToColor() method

HtmlStyle.ToColor() method
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlStyle > ToColor()
Attempts to parse the style value as a color and return a System.Drawing.Color object that corresponds to the color style value.
Syntax
C#
public Color ToColor ()
Return Value
The System.Drawing.Color object or Color.Empty if unable to parse the color.


ToHtmlColor(color) method

HtmlStyle.ToHtmlColor(color) method
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlStyle > ToHtmlColor(Color)
Translates a System.Drawing.Color to an Html color string.
Syntax
C#
public static string ToHtmlColor (
    Color color
)
Parameters
color (Color)
The System.Drawing.Color.
Return Value
The html color string.


ToInt() method

HtmlStyle.ToInt() method
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlStyle > ToInt()
Strips any style value from units (i.e. px/pt..etc) and returns the integer value.
Syntax
C#
public int ToInt ()
Return Value
The integer value. If the unit has no integer value or is empty will return -1.


Value property

HtmlStyle.Value property
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlStyle > Value
Gets the style value.
Syntax
C#
public string Value { get; }


HtmlTable class

HtmlTable class
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlTable
Test class for an HtmlTable element <table>...</table>
Syntax
C#
[DefaultMemberAttribute("Item")]
public class HtmlTable : HtmlContainerControl
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | HtmlTableNew() | Create a new control.
 | HtmlTableNew(Element) | Create a new control.
 | AllRows | Gets all rows as one collection. (Head rows, then body rows and then footer rows)
 | AssignElement(Element) | Assign element and initialize this control. (Overrides HtmlContainerControl.AssignElement(Element).)
 | AssignFailed(Exception) | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
 | Attributes | All attributes set on this control (Inherited from HtmlControl.)
 | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
 | BodyRows | Gets the rows contained in the body of the table if the table is using the tbody tag.
 | Border | Gets the width of the table border.
 | Caption | Gets the caption of a table.
 | Capture() | Captures and returns the image of the current Html Control. (Inherited from HtmlControl.)
 | Capture(String) | Captures and saves Html Control Image to the WebAii log location as a bmp file. (Inherited from HtmlControl.)
 | Capture(String, String) | Captures and saves Html Control Image to the specified save path as the specified image name in bmp format. (Inherited from HtmlControl.)
 | CellPadding | Gets the amount of space between the cell border and cell content
 | CellSpacing | Gets the amount of space between the cells in a table.
 | Click() | Invoke a click within the loaded page. (Inherited from HtmlControl.)
 | Click(Boolean) | Invoke a click that causes that browser window to close (i.e. this is common for html pop-ups) (Inherited from HtmlControl.)
 | ColumnCount | Gets the number of columns in this table
 | CssClass | Control's CSS class if set. (Inherited from HtmlControl.)
 | Download(Boolean, DownloadOption, String, Int32) | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
 | DragTo(HtmlControl) | Drag this control to the center on the destination control. (Inherited from HtmlControl.)
 | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination control with an offset of where within the destination control to drag to. (Inherited from HtmlControl.)
 | DragTo(Int32, Int32) | Drag this control to a relative X/Y offset. (Inherited from HtmlControl.)
 | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this control by specifying a reference point on the control rectangle to start the drag from and a reference point on the destination control to specify the drop location. (Inherited from HtmlControl.)
 | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this control from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
 | DragTo(OffsetReference, Point, HtmlControl) | Drag this control by specifying a reference point on the control rectangle to start the drag from with an offset and drop on the destination control center. (Inherited from HtmlControl.)
 | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this control by specifying a reference point on the control rectangle to start the drag from and a reference point on the destination control to specify the drop location. (Inherited from HtmlControl.)
 | DragTo(OffsetReference, Point, Int32, Int32) | Drag this control from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
 | DragTo(Point) | Drag this control to an absolute point. (Inherited from HtmlControl.)
 | DragToWindowLocation(OffsetReference, Int32, Int32, Boolean, OffsetReference, Int32, Int32, Boolean) | Drag this control, using the browser window as the drop target (Inherited from HtmlControl.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Events collection set on this control (Inherited from HtmlControl.)
 | Finalize() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Find | Find property (Inherited from HtmlContainerControl.)
 | FindParentContainer<(Of TContainerControl>)() | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
 | FootRows | Gets the rows contained in the table footer if the table is using the tfoot tag.
 | GetAttributeAsString(String) | Get an attribute of this element as a string (Inherited from HtmlControl.)
 | GetComputedStyle(String) | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
 | GetComputedStyleValue(String) | Returns computed style value. Computed style represents the final computed value of all CSS properties for the element. (Inherited from HtmlControl.)
 | GetHashCode() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetRectangle() | The absolute screen position of the control. (Inherited from HtmlControl.)
 | GetStyle(String) | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
 | GetStyleValue(String) | Returns any style as if you are accessing the element.style object from javascript. (Inherited from HtmlControl.)
 | GetType() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue<(Of T>)(String) | Get a property value (i.e. control.border or control.style.backgroundColor). string s = myControl.GetValue<string>("style.backgroundColor") (Inherited from HtmlControl.)
 | HeadRows | Gets the rows contained in the table header if the table is using the thead tag.
 | ID | Control's ID if set. (Inherited from HtmlControl.)
 | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
 | InvokeEvent(ScriptEventType) | Invokes an event on this control (Inherited from HtmlControl.)
 | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
 | IsVisible() | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
 | Item(Int32) | Gets requested row by index.
 | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
 | MemberwiseClone() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MouseClick() | Uses the Desktop.Mouse object to move the mouse to this control and click it. (Inherited from HtmlControl.)
 | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to this control and click it. (Inherited from HtmlControl.)
 | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to this control and click it. (Inherited from HtmlControl.)
 | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to this control and click it. (Inherited from HtmlControl.)
 | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to this control and click it. (Inherited from HtmlControl.)
 | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over the control (Inherited from HtmlControl.)
 | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over the control (Inherited from HtmlControl.)
 | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over the control (Inherited from HtmlControl.)
 | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
 | Parent<(Of TContainerControl>)() | Return the parent HtmlContainerControl of desired type that this control is contained in. If control is not found, will return null. (Inherited from HtmlControl.)
 | Refresh() | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
 | Rows | Return List of HtmlTableRows. Only the body rows if TBody is used.
 | ScrollLeft | Gets/Sets the scrollLeft value of the html control. (Inherited from HtmlControl.)
 | ScrollTop | Gets/Sets the scrollTop value of the html control (Inherited from HtmlControl.)
 | ScrollToVisible(ScrollToVisibleType) | Scroll control to Visible Position on the page (Inherited from HtmlControl.)
 | SetValue<(Of T>)(String, T) | Set a property value. (i.e. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
 | Styles | Styles collection set on this control and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
 | TagName | The tag name of this element (Inherited from HtmlControl.)
 | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
 | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
 | ToString() | Returns a String that represents the current Object. (Inherited from Object.)
 | ValidateControl() | Validate a control using a its Locator. (Inherited from HtmlControl.)
 | ValidateTag(String) | Validate a tag name (Inherited from HtmlControl.)
 | Wait | Gets the HTML Wait object. (Inherited from HtmlControl.)
 | Width | Gets the width of a table.
Inheritance Hierarchy
Object
 | Control
 |  | HtmlControl
 |  |  | HtmlContainerControl
 |  |  |  | HtmlTable


AllRows property

HtmlTable.AllRows property
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlTable > AllRows
Gets all rows as one collection. (Head rows, then body rows and then footer rows)
Syntax
C#
public ReadOnlyCollection<HtmlTableRow> AllRows { get; }


AssignElement(e) method

HtmlTable.AssignElement(e) method
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlTable > AssignElement(Element)
Assign element and initialize this control.
Syntax
C#
public override void AssignElement (
    Element e
)
Parameters
e (Element)
The base element.


BodyRows property

HtmlTable.BodyRows property
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlTable > BodyRows
Gets the rows contained in the body of the table if the table is using the tbody tag.
Syntax
C#
public ReadOnlyCollection<HtmlTableRow> BodyRows { get; }


Border property

HtmlTable.Border property
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlTable > Border
Gets the width of the table border.
Syntax
C#
public string Border { get; }


Caption property

HtmlTable.Caption property
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlTable > Caption
Gets the caption of a table.
Syntax
C#
public string Caption { get; }


CellPadding property

HtmlTable.CellPadding property
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlTable > CellPadding
Gets the amount of space between the cell border and cell content
Syntax
C#
public string CellPadding { get; }


CellSpacing property

HtmlTable.CellSpacing property
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlTable > CellSpacing
Gets the amount of space between the cells in a table.
Syntax
C#
public string CellSpacing { get; }


ColumnCount property

HtmlTable.ColumnCount property
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlTable > ColumnCount
Gets the number of columns in this table
Syntax
C#
public int ColumnCount { get; }


Constructors

HtmlTable constructors
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlTable > HtmlTableNew
Members
Icon | Member | Description
 | HtmlTableNew() | Create a new control.
 | HtmlTableNew(Element) | Create a new control.


HtmlTable() constructor

HtmlTable() constructor
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlTable > HtmlTableNew()
Create a new control.
Syntax
C#
public HtmlTable ()


HtmlTable(element) constructor

HtmlTable(element) constructor
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlTable > HtmlTableNew(Element)
Create a new control.
Syntax
C#
public HtmlTable (
    Element element
)
Parameters
element (Element)
The base element.


FootRows property

HtmlTable.FootRows property
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlTable > FootRows
Gets the rows contained in the table footer if the table is using the tfoot tag.
Syntax
C#
public ReadOnlyCollection<HtmlTableRow> FootRows { get; }


HeadRows property

HtmlTable.HeadRows property
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlTable > HeadRows
Gets the rows contained in the table header if the table is using the thead tag.
Syntax
C#
public ReadOnlyCollection<HtmlTableRow> HeadRows { get; }


Item[index] property

HtmlTable.Item[index] property
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlTable > Item(Int32)
Gets requested row by index.
Syntax
C#
public HtmlTableRow this [
    int index
] { get; }
Parameters
index (Int32)
row index
Return Value
The requested row.


Rows property

HtmlTable.Rows property
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlTable > Rows
Return List of HtmlTableRows. Only the body rows if TBody is used.
Syntax
C#
public ReadOnlyCollection<HtmlTableRow> Rows { get; }


Width property

HtmlTable.Width property
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlTable > Width
Gets the width of a table.
Syntax
C#
public string Width { get; }


HtmlTableAssertExtensions class

HtmlTableAssertExtensions class
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlTableAssertExtensions
Assert extensions for the HtmlControl class.
Syntax
C#
[ExtensionAttribute]
public static class HtmlTableAssertExtensions
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AssertTable(HtmlTable) | Assert methods for the control content.
Inheritance Hierarchy
Object
HtmlTableAssertExtensions


AssertTable(control) method

HtmlTableAssertExtensions.AssertTable(control) method
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlTableAssertExtensions > AssertTable(HtmlTable)
Assert methods for the control content.
Syntax
C#
[ExtensionAttribute]
public static AssertTable AssertTable (
    HtmlTable control
)
Parameters
control (HtmlTable)
Return Value


HtmlTableCell class

HtmlTableCell class
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlTableCell
Test class for an HtmlTableCell element <td>...</td>
Syntax
C#
public class HtmlTableCell : HtmlContainerControl
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | HtmlTableCellNew() | Create a new control.
 | HtmlTableCellNew(Element) | Create a new control.
 | Align | Gets the horizontal alignment of data within a table cell.
 | AssignElement(Element) | Assign element and initialize this control. (Overrides HtmlContainerControl.AssignElement(Element).)
 | AssignFailed(Exception) | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
 | Attributes | All attributes set on this control (Inherited from HtmlControl.)
 | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
 | Capture() | Captures and returns the image of the current Html Control. (Inherited from HtmlControl.)
 | Capture(String) | Captures and saves Html Control Image to the WebAii log location as a bmp file. (Inherited from HtmlControl.)
 | Capture(String, String) | Captures and saves Html Control Image to the specified save path as the specified image name in bmp format. (Inherited from HtmlControl.)
 | CellIndex | Gets the position of a cell in the cells collection of a row
 | Click() | Invoke a click within the loaded page. (Inherited from HtmlControl.)
 | Click(Boolean) | Invoke a click that causes that browser window to close (i.e. this is common for html pop-ups) (Inherited from HtmlControl.)
 | ColSpan | Gets the number of columns a table cell should span
 | CssClass | Control's CSS class if set. (Inherited from HtmlControl.)
 | Download(Boolean, DownloadOption, String, Int32) | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
 | DragTo(HtmlControl) | Drag this control to the center on the destination control. (Inherited from HtmlControl.)
 | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination control with an offset of where within the destination control to drag to. (Inherited from HtmlControl.)
 | DragTo(Int32, Int32) | Drag this control to a relative X/Y offset. (Inherited from HtmlControl.)
 | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this control by specifying a reference point on the control rectangle to start the drag from and a reference point on the destination control to specify the drop location. (Inherited from HtmlControl.)
 | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this control from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
 | DragTo(OffsetReference, Point, HtmlControl) | Drag this control by specifying a reference point on the control rectangle to start the drag from with an offset and drop on the destination control center. (Inherited from HtmlControl.)
 | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this control by specifying a reference point on the control rectangle to start the drag from and a reference point on the destination control to specify the drop location. (Inherited from HtmlControl.)
 | DragTo(OffsetReference, Point, Int32, Int32) | Drag this control from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
 | DragTo(Point) | Drag this control to an absolute point. (Inherited from HtmlControl.)
 | DragToWindowLocation(OffsetReference, Int32, Int32, Boolean, OffsetReference, Int32, Int32, Boolean) | Drag this control, using the browser window as the drop target (Inherited from HtmlControl.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Events collection set on this control (Inherited from HtmlControl.)
 | Finalize() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Find | Find property (Inherited from HtmlContainerControl.)
 | FindParentContainer<(Of TContainerControl>)() | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
 | GetAttributeAsString(String) | Get an attribute of this element as a string (Inherited from HtmlControl.)
 | GetComputedStyle(String) | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
 | GetComputedStyleValue(String) | Returns computed style value. Computed style represents the final computed value of all CSS properties for the element. (Inherited from HtmlControl.)
 | GetHashCode() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetRectangle() | The absolute screen position of the control. (Inherited from HtmlControl.)
 | GetStyle(String) | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
 | GetStyleValue(String) | Returns any style as if you are accessing the element.style object from javascript. (Inherited from HtmlControl.)
 | GetType() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue<(Of T>)(String) | Get a property value (i.e. control.border or control.style.backgroundColor). string s = myControl.GetValue<string>("style.backgroundColor") (Inherited from HtmlControl.)
 | Height | Gets the height of a table cell.
 | ID | Control's ID if set. (Inherited from HtmlControl.)
 | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
 | InvokeEvent(ScriptEventType) | Invokes an event on this control (Inherited from HtmlControl.)
 | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
 | IsVisible() | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
 | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
 | MemberwiseClone() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MouseClick() | Uses the Desktop.Mouse object to move the mouse to this control and click it. (Inherited from HtmlControl.)
 | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to this control and click it. (Inherited from HtmlControl.)
 | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to this control and click it. (Inherited from HtmlControl.)
 | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to this control and click it. (Inherited from HtmlControl.)
 | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to this control and click it. (Inherited from HtmlControl.)
 | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over the control (Inherited from HtmlControl.)
 | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over the control (Inherited from HtmlControl.)
 | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over the control (Inherited from HtmlControl.)
 | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
 | Parent<(Of TContainerControl>)() | Return the parent HtmlContainerControl of desired type that this control is contained in. If control is not found, will return null. (Inherited from HtmlControl.)
 | Refresh() | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
 | RowSpan | Gets the number of rows a table cell should span.
 | ScrollLeft | Gets/Sets the scrollLeft value of the html control. (Inherited from HtmlControl.)
 | ScrollTop | Gets/Sets the scrollTop value of the html control (Inherited from HtmlControl.)
 | ScrollToVisible(ScrollToVisibleType) | Scroll control to Visible Position on the page (Inherited from HtmlControl.)
 | SetValue<(Of T>)(String, T) | Set a property value. (i.e. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
 | Styles | Styles collection set on this control and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
 | TagName | The tag name of this element (Inherited from HtmlControl.)
 | Text | Obsolete. Gets the text content of the cell.
 | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
 | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
 | ToString() | Returns a String that represents the current Object. (Inherited from Object.)
 | ValidateControl() | Validate a control using a its Locator. (Inherited from HtmlControl.)
 | ValidateTag(String) | Validate a tag name (Inherited from HtmlControl.)
 | VAlign | Gets the vertical alignment of data within a table cell.
 | Wait | Gets the HTML Wait object. (Inherited from HtmlControl.)
 | Width | Gets the width of a table cell.
Inheritance Hierarchy
Object
 | Control
 |  | HtmlControl
 |  |  | HtmlContainerControl
 |  |  |  | HtmlTableCell


Align property

HtmlTableCell.Align property
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlTableCell > Align
Gets the horizontal alignment of data within a table cell.
Syntax
C#
public string Align { get; }


AssignElement(e) method

HtmlTableCell.AssignElement(e) method
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlTableCell > AssignElement(Element)
Assign element and initialize this control.
Syntax
C#
public override void AssignElement (
    Element e
)
Parameters
e (Element)
The base element.


CellIndex property

HtmlTableCell.CellIndex property
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlTableCell > CellIndex
Gets the position of a cell in the cells collection of a row
Syntax
C#
[DebuggerBrowsableAttribute(DebuggerBrowsableState.Never)]
public int CellIndex { get; }


ColSpan property

HtmlTableCell.ColSpan property
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlTableCell > ColSpan
Gets the number of columns a table cell should span
Syntax
C#
public int ColSpan { get; }


Constructors

HtmlTableCell constructors
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlTableCell > HtmlTableCellNew
Members
Icon | Member | Description
 | HtmlTableCellNew() | Create a new control.
 | HtmlTableCellNew(Element) | Create a new control.


HtmlTableCell() constructor

HtmlTableCell() constructor
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlTableCell > HtmlTableCellNew()
Create a new control.
Syntax
C#
public HtmlTableCell ()


HtmlTableCell(element) constructor

HtmlTableCell(element) constructor
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlTableCell > HtmlTableCellNew(Element)
Create a new control.
Syntax
C#
public HtmlTableCell (
    Element element
)
Parameters
element (Element)
The base element.


Height property

HtmlTableCell.Height property
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlTableCell > Height
Gets the height of a table cell.
Syntax
C#
public string Height { get; }


RowSpan property

HtmlTableCell.RowSpan property
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlTableCell > RowSpan
Gets the number of rows a table cell should span.
Syntax
C#
public int RowSpan { get; }


Text property

HtmlTableCell.Text property
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlTableCell > Text
Gets the text content of the cell.
Syntax
C#
[ObsoleteAttribute("Please use the TextContent property instead")]
public string Text { get; }


VAlign property

HtmlTableCell.VAlign property
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlTableCell > VAlign
Gets the vertical alignment of data within a table cell.
Syntax
C#
public string VAlign { get; }


Width property

HtmlTableCell.Width property
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlTableCell > Width
Gets the width of a table cell.
Syntax
C#
public string Width { get; }


HtmlTableRow class

HtmlTableRow class
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlTableRow
Test class for an HtmlTableRow element <tr>...</tr>
Syntax
C#
[DefaultMemberAttribute("Item")]
public class HtmlTableRow : HtmlContainerControl
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | HtmlTableRowNew() | Create a new control.
 | HtmlTableRowNew(Element) | Create a new control.
 | Align | Gets the horizontal alignment of data within a table row.
 | AssignElement(Element) | Assign element and initialize this control. (Overrides HtmlContainerControl.AssignElement(Element).)
 | AssignFailed(Exception) | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
 | Attributes | All attributes set on this control (Inherited from HtmlControl.)
 | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
 | Capture() | Captures and returns the image of the current Html Control. (Inherited from HtmlControl.)
 | Capture(String) | Captures and saves Html Control Image to the WebAii log location as a bmp file. (Inherited from HtmlControl.)
 | Capture(String, String) | Captures and saves Html Control Image to the specified save path as the specified image name in bmp format. (Inherited from HtmlControl.)
 | Cells | Return list of HtmlTableCells.
 | Click() | Invoke a click within the loaded page. (Inherited from HtmlControl.)
 | Click(Boolean) | Invoke a click that causes that browser window to close (i.e. this is common for html pop-ups) (Inherited from HtmlControl.)
 | CssClass | Control's CSS class if set. (Inherited from HtmlControl.)
 | Download(Boolean, DownloadOption, String, Int32) | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
 | DragTo(HtmlControl) | Drag this control to the center on the destination control. (Inherited from HtmlControl.)
 | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination control with an offset of where within the destination control to drag to. (Inherited from HtmlControl.)
 | DragTo(Int32, Int32) | Drag this control to a relative X/Y offset. (Inherited from HtmlControl.)
 | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this control by specifying a reference point on the control rectangle to start the drag from and a reference point on the destination control to specify the drop location. (Inherited from HtmlControl.)
 | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this control from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
 | DragTo(OffsetReference, Point, HtmlControl) | Drag this control by specifying a reference point on the control rectangle to start the drag from with an offset and drop on the destination control center. (Inherited from HtmlControl.)
 | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this control by specifying a reference point on the control rectangle to start the drag from and a reference point on the destination control to specify the drop location. (Inherited from HtmlControl.)
 | DragTo(OffsetReference, Point, Int32, Int32) | Drag this control from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
 | DragTo(Point) | Drag this control to an absolute point. (Inherited from HtmlControl.)
 | DragToWindowLocation(OffsetReference, Int32, Int32, Boolean, OffsetReference, Int32, Int32, Boolean) | Drag this control, using the browser window as the drop target (Inherited from HtmlControl.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Events collection set on this control (Inherited from HtmlControl.)
 | Finalize() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Find | Find property (Inherited from HtmlContainerControl.)
 | FindParentContainer<(Of TContainerControl>)() | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
 | GetAttributeAsString(String) | Get an attribute of this element as a string (Inherited from HtmlControl.)
 | GetComputedStyle(String) | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
 | GetComputedStyleValue(String) | Returns computed style value. Computed style represents the final computed value of all CSS properties for the element. (Inherited from HtmlControl.)
 | GetHashCode() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetRectangle() | The absolute screen position of the control. (Inherited from HtmlControl.)
 | GetStyle(String) | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
 | GetStyleValue(String) | Returns any style as if you are accessing the element.style object from javascript. (Inherited from HtmlControl.)
 | GetType() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue<(Of T>)(String) | Get a property value (i.e. control.border or control.style.backgroundColor). string s = myControl.GetValue<string>("style.backgroundColor") (Inherited from HtmlControl.)
 | ID | Control's ID if set. (Inherited from HtmlControl.)
 | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
 | InvokeEvent(ScriptEventType) | Invokes an event on this control (Inherited from HtmlControl.)
 | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
 | IsVisible() | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
 | Item(Int32) | Return cell by its index in this row.
 | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
 | MemberwiseClone() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MouseClick() | Uses the Desktop.Mouse object to move the mouse to this control and click it. (Inherited from HtmlControl.)
 | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to this control and click it. (Inherited from HtmlControl.)
 | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to this control and click it. (Inherited from HtmlControl.)
 | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to this control and click it. (Inherited from HtmlControl.)
 | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to this control and click it. (Inherited from HtmlControl.)
 | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over the control (Inherited from HtmlControl.)
 | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over the control (Inherited from HtmlControl.)
 | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over the control (Inherited from HtmlControl.)
 | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
 | Parent<(Of TContainerControl>)() | Return the parent HtmlContainerControl of desired type that this control is contained in. If control is not found, will return null. (Inherited from HtmlControl.)
 | Refresh() | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
 | RowIndex | Gets the position of a row in the table's rows collection.
 | ScrollLeft | Gets/Sets the scrollLeft value of the html control. (Inherited from HtmlControl.)
 | ScrollTop | Gets/Sets the scrollTop value of the html control (Inherited from HtmlControl.)
 | ScrollToVisible(ScrollToVisibleType) | Scroll control to Visible Position on the page (Inherited from HtmlControl.)
 | SetValue<(Of T>)(String, T) | Set a property value. (i.e. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
 | Styles | Styles collection set on this control and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
 | TagName | The tag name of this element (Inherited from HtmlControl.)
 | Text | Obsolete. Gets the text content of this table row.
 | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
 | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
 | ToString() | Returns a String that represents the current Object. (Inherited from Object.)
 | ValidateControl() | Validate a control using a its Locator. (Inherited from HtmlControl.)
 | ValidateTag(String) | Validate a tag name (Inherited from HtmlControl.)
 | Wait | Gets the HTML Wait object. (Inherited from HtmlControl.)
Inheritance Hierarchy
Object
 | Control
 |  | HtmlControl
 |  |  | HtmlContainerControl
 |  |  |  | HtmlTableRow


Align property

HtmlTableRow.Align property
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlTableRow > Align
Gets the horizontal alignment of data within a table row.
Syntax
C#
public string Align { get; }


AssignElement(e) method

HtmlTableRow.AssignElement(e) method
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlTableRow > AssignElement(Element)
Assign element and initialize this control.
Syntax
C#
public override void AssignElement (
    Element e
)
Parameters
e (Element)
The base element.


Cells property

HtmlTableRow.Cells property
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlTableRow > Cells
Return list of HtmlTableCells.
Syntax
C#
public List<HtmlTableCell> Cells { get; }


Constructors

HtmlTableRow constructors
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlTableRow > HtmlTableRowNew
Members
Icon | Member | Description
 | HtmlTableRowNew() | Create a new control.
 | HtmlTableRowNew(Element) | Create a new control.


HtmlTableRow() constructor

HtmlTableRow() constructor
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlTableRow > HtmlTableRowNew()
Create a new control.
Syntax
C#
public HtmlTableRow ()


HtmlTableRow(element) constructor

HtmlTableRow(element) constructor
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlTableRow > HtmlTableRowNew(Element)
Create a new control.
Syntax
C#
public HtmlTableRow (
    Element element
)
Parameters
element (Element)
The base element.


Item[index] property

HtmlTableRow.Item[index] property
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlTableRow > Item(Int32)
Return cell by its index in this row.
Syntax
C#
public HtmlTableCell this [
    int index
] { get; }
Parameters
index (Int32)
The cell index.
Return Value
The cell at desired index.


RowIndex property

HtmlTableRow.RowIndex property
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlTableRow > RowIndex
Gets the position of a row in the table's rows collection.
Syntax
C#
[DebuggerBrowsableAttribute(DebuggerBrowsableState.Never)]
public int RowIndex { get; }


Text property

HtmlTableRow.Text property
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlTableRow > Text
Gets the text content of this table row.
Syntax
C#
[ObsoleteAttribute("Please use the TextContent property instead.")]
public string Text { get; }


HtmlTextArea class

HtmlTextArea class
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlTextArea
Test class for an HtmlAnchor element <textarea>...</textarea>
Syntax
C#
public class HtmlTextArea : HtmlContainerControl
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | HtmlTextAreaNew() | Create a new control.
 | HtmlTextAreaNew(Element) | Create a new control.
 | AssignElement(Element) | Assign element and initialize this control. (Overrides HtmlContainerControl.AssignElement(Element).)
 | AssignFailed(Exception) | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
 | Attributes | All attributes set on this control (Inherited from HtmlControl.)
 | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
 | Capture() | Captures and returns the image of the current Html Control. (Inherited from HtmlControl.)
 | Capture(String) | Captures and saves Html Control Image to the WebAii log location as a bmp file. (Inherited from HtmlControl.)
 | Capture(String, String) | Captures and saves Html Control Image to the specified save path as the specified image name in bmp format. (Inherited from HtmlControl.)
 | Click() | Invoke a click within the loaded page. (Inherited from HtmlControl.)
 | Click(Boolean) | Invoke a click that causes that browser window to close (i.e. this is common for html pop-ups) (Inherited from HtmlControl.)
 | Cols | Gets the number of columns set. If none, returns -1
 | CssClass | Control's CSS class if set. (Inherited from HtmlControl.)
 | Download(Boolean, DownloadOption, String, Int32) | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
 | DragTo(HtmlControl) | Drag this control to the center on the destination control. (Inherited from HtmlControl.)
 | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination control with an offset of where within the destination control to drag to. (Inherited from HtmlControl.)
 | DragTo(Int32, Int32) | Drag this control to a relative X/Y offset. (Inherited from HtmlControl.)
 | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this control by specifying a reference point on the control rectangle to start the drag from and a reference point on the destination control to specify the drop location. (Inherited from HtmlControl.)
 | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this control from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
 | DragTo(OffsetReference, Point, HtmlControl) | Drag this control by specifying a reference point on the control rectangle to start the drag from with an offset and drop on the destination control center. (Inherited from HtmlControl.)
 | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this control by specifying a reference point on the control rectangle to start the drag from and a reference point on the destination control to specify the drop location. (Inherited from HtmlControl.)
 | DragTo(OffsetReference, Point, Int32, Int32) | Drag this control from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
 | DragTo(Point) | Drag this control to an absolute point. (Inherited from HtmlControl.)
 | DragToWindowLocation(OffsetReference, Int32, Int32, Boolean, OffsetReference, Int32, Int32, Boolean) | Drag this control, using the browser window as the drop target (Inherited from HtmlControl.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Events collection set on this control (Inherited from HtmlControl.)
 | Finalize() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Find | Find property (Inherited from HtmlContainerControl.)
 | FindParentContainer<(Of TContainerControl>)() | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
 | GetAttributeAsString(String) | Get an attribute of this element as a string (Inherited from HtmlControl.)
 | GetComputedStyle(String) | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
 | GetComputedStyleValue(String) | Returns computed style value. Computed style represents the final computed value of all CSS properties for the element. (Inherited from HtmlControl.)
 | GetHashCode() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetRectangle() | The absolute screen position of the control. (Inherited from HtmlControl.)
 | GetStyle(String) | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
 | GetStyleValue(String) | Returns any style as if you are accessing the element.style object from javascript. (Inherited from HtmlControl.)
 | GetType() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue<(Of T>)(String) | Get a property value (i.e. control.border or control.style.backgroundColor). string s = myControl.GetValue<string>("style.backgroundColor") (Inherited from HtmlControl.)
 | ID | Control's ID if set. (Inherited from HtmlControl.)
 | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
 | InvokeEvent(ScriptEventType) | Invokes an event on this control (Inherited from HtmlControl.)
 | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
 | IsVisible() | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
 | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
 | MemberwiseClone() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MouseClick() | Uses the Desktop.Mouse object to move the mouse to this control and click it. (Inherited from HtmlControl.)
 | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to this control and click it. (Inherited from HtmlControl.)
 | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to this control and click it. (Inherited from HtmlControl.)
 | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to this control and click it. (Inherited from HtmlControl.)
 | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to this control and click it. (Inherited from HtmlControl.)
 | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over the control (Inherited from HtmlControl.)
 | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over the control (Inherited from HtmlControl.)
 | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over the control (Inherited from HtmlControl.)
 | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
 | Parent<(Of TContainerControl>)() | Return the parent HtmlContainerControl of desired type that this control is contained in. If control is not found, will return null. (Inherited from HtmlControl.)
 | Refresh() | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
 | Rows | Gets the number of rows set. If none, returns -1.
 | ScrollLeft | Gets/Sets the scrollLeft value of the html control. (Inherited from HtmlControl.)
 | ScrollTop | Gets/Sets the scrollTop value of the html control (Inherited from HtmlControl.)
 | ScrollToVisible(ScrollToVisibleType) | Scroll control to Visible Position on the page (Inherited from HtmlControl.)
 | SetValue<(Of T>)(String, T) | Set a property value. (i.e. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
 | Styles | Styles collection set on this control and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
 | TagName | The tag name of this element (Inherited from HtmlControl.)
 | Text | Gets or sets the value of the Text Area
 | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
 | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
 | ToString() | Returns a String that represents the current Object. (Inherited from Object.)
 | ValidateControl() | Validate a control using a its Locator. (Inherited from HtmlControl.)
 | ValidateTag(String) | Validate a tag name (Inherited from HtmlControl.)
 | Wait | Gets the HTML Wait object. (Inherited from HtmlControl.)
Inheritance Hierarchy
Object
 | Control
 |  | HtmlControl
 |  |  | HtmlContainerControl
 |  |  |  | HtmlTextArea


AssignElement(e) method

HtmlTextArea.AssignElement(e) method
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlTextArea > AssignElement(Element)
Assign element and initialize this control.
Syntax
C#
public override void AssignElement (
    Element e
)
Parameters
e (Element)
The base element.


Cols property

HtmlTextArea.Cols property
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlTextArea > Cols
Gets the number of columns set. If none, returns -1
Syntax
C#
public int Cols { get; }


Constructors

HtmlTextArea constructors
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlTextArea > HtmlTextAreaNew
Members
Icon | Member | Description
 | HtmlTextAreaNew() | Create a new control.
 | HtmlTextAreaNew(Element) | Create a new control.


HtmlTextArea() constructor

HtmlTextArea() constructor
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlTextArea > HtmlTextAreaNew()
Create a new control.
Syntax
C#
public HtmlTextArea ()


HtmlTextArea(element) constructor

HtmlTextArea(element) constructor
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlTextArea > HtmlTextAreaNew(Element)
Create a new control.
Syntax
C#
public HtmlTextArea (
    Element element
)
Parameters
element (Element)
The base element.


Rows property

HtmlTextArea.Rows property
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlTextArea > Rows
Gets the number of rows set. If none, returns -1.
Syntax
C#
public int Rows { get; }


Text property

HtmlTextArea.Text property
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlTextArea > Text
Gets or sets the value of the Text Area
Syntax
C#
[DebuggerBrowsableAttribute(DebuggerBrowsableState.Never)]
public string Text { get; set; }


HtmlWait class

HtmlWait class
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlWait
Extends the Wait object for specific HtmlWait scenarios.
Syntax
C#
public class HtmlWait : Wait
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | HtmlWaitNew(HtmlControl, Int32) | Create a new wait class.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | ForAttributes(Int32, String[]()) | Wait for a set of attributes on this element. (Inherited from Wait.)
 | ForAttributes(String[]()) | Wait for a set of attributes on this element. (Timeout = Wait.Timeout) (Inherited from Wait.)
 | ForAttributesNot(Int32, String[]()) | Wait for a set of attributes to no longer be true. (Inherited from Wait.)
 | ForAttributesNot(String[]()) | Wait for a set of attributes to no longer be true. (Timeout = Wait.Timeout) (Inherited from Wait.)
 | ForCondition(ControlWaitForCondition, Boolean, Object, Int32) | Wait for a custom condition on this control.
 | ForCondition(ControlWaitForCondition, Object) | Wait for a custom condition on this control. (Timeout = HtmlWait.Timeout)
 | ForCondition(ControlWaitForCondition, Object, Boolean) | Wait for a custom condition on this control. (Timeout = HtmlWait.Timeout)
 | ForCondition(ElementWaitForCondition, Boolean, Object, Int32) | Wait for a custom condition on this element. (Inherited from Wait.)
 | ForCondition(ElementWaitForCondition, Object) | Wait for a custom condition on this element. (Inherited from Wait.)
 | ForCondition(ElementWaitForCondition, Object, Boolean) | Wait for a custom condition on this element. (Inherited from Wait.)
 | ForContent(FindContentType, String) | Wait for certain content of this element to be true. (Timeout = Wait.Timeout) (Inherited from Wait.)
 | ForContent(FindContentType, String, Int32) | Wait for certain content of this element to be true. (Inherited from Wait.)
 | ForContentNot(FindContentType, String) | Wait for certain content of this element to no longer be true. (Timeout = Wait.Timeout) (Inherited from Wait.)
 | ForContentNot(FindContentType, String, Int32) | Wait for certain content of this element to no longer be true. (Inherited from Wait.)
 | ForExists(Int32) | Wait for this element to exist in the DOM. (Inherited from Wait.)
 | ForExists(Int32, Boolean) | Protected exists. [Control the control refresh] (Overrides Wait.ForExists(Int32, Boolean).)
 | ForExistsNot() | Wait for this element not to exist in the DOM (Inherited from Wait.)
 | ForExistsNot(Int32) | Wait for this element not to exist in the DOM. (Inherited from Wait.)
 | ForStyles(Boolean, String[]()) | Wait for a set of styles on this element. (Timeout = HtmlWait.Timeout)
 | ForStyles(Int32, Boolean, String[]()) | Wait for a set of styles on this element.
 | ForStyles(Int32, String[]()) | Wait for a set of styles on this element.
 | ForStyles(String[]()) | Wait for a set of styles on this element. (Timeout = HtmlWait.Timeout)
 | ForStylesNot(Boolean, String[]()) | Wait for a set of styles to no longer be true.
 | ForStylesNot(Int32, Boolean, String[]()) | Wait for a set of styles to no longer be true.
 | ForStylesNot(Int32, String[]()) | Wait for a set of styles to no longer be true.
 | ForStylesNot(String[]()) | Wait for a set of styles to no longer be true. (Timeout = HtmlWait.Timeout)
 | ForVisible() | Wait for an element to be visible. HtmlControl.IsVisible is true. (Timeout = HtmlWait.Timeout)
 | ForVisible(Int32) | Wait for an element to be visible. HtmlControl.IsVisible is true.
 | ForVisibleNot() | Wait for an element to no longer be visible. HtmlControl.IsVisible is false. (Timeout = HtmlWait.Timeout)
 | ForVisibleNot(Int32) | Wait for an element to no longer be visible. HtmlControl.IsVisible is false.
 | GetHashCode() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Timeout | Gets/Sets the timeout for all Wait.Forxx methods. Default=Settings.ExecuteCommandTimeout (Inherited from Wait.)
 | ToString() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Wait
 |  | HtmlWait


ForCondition methods

HtmlWait.ForCondition methods
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlWait > ForCondition
Members
Icon | Member | Description
 | ForCondition(ControlWaitForCondition, Boolean, Object, Int32) | Wait for a custom condition on this control.
 | ForCondition(ControlWaitForCondition, Object) | Wait for a custom condition on this control. (Timeout = HtmlWait.Timeout)
 | ForCondition(ControlWaitForCondition, Object, Boolean) | Wait for a custom condition on this control. (Timeout = HtmlWait.Timeout)
 | ForCondition(ElementWaitForCondition, Boolean, Object, Int32) | Wait for a custom condition on this element.
 | ForCondition(ElementWaitForCondition, Object) | Wait for a custom condition on this element.
 | ForCondition(ElementWaitForCondition, Object, Boolean) | Wait for a custom condition on this element.


ForCondition(condition, custom) method

HtmlWait.ForCondition(condition, custom) method
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlWait > ForCondition(ControlWaitForCondition, Object)
Wait for a custom condition on this control. (Timeout = HtmlWait.Timeout)
Syntax
C#
public void ForCondition (
    ControlWaitForCondition condition,
    Object custom
)
Parameters
condition (ControlWaitForCondition)
The condition to wait for.
custom (Object)
Any custom data to pass to this condition.


ForCondition(condition, custom, invertCondition) method

HtmlWait.ForCondition(condition, custom, invertCondition) method
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlWait > ForCondition(ControlWaitForCondition, Object, Boolean)
Wait for a custom condition on this control. (Timeout = HtmlWait.Timeout)
Syntax
C#
public void ForCondition (
    ControlWaitForCondition condition,
    Object custom,
    bool invertCondition
)
Parameters
condition (ControlWaitForCondition)
The condition to wait for.
custom (Object)
Any custom data to pass to this condition.
invertCondition (Boolean)
True/False whether to invert the condition or not.


ForCondition(condition, invertCondition, custom, timeout) method

HtmlWait.ForCondition(condition, invertCondition, custom, timeout) method
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlWait > ForCondition(ControlWaitForCondition, Boolean, Object, Int32)
Wait for a custom condition on this control.
Syntax
C#
public void ForCondition (
    ControlWaitForCondition condition,
    bool invertCondition,
    Object custom,
    int timeout
)
Parameters
condition (ControlWaitForCondition)
The condition to wait for.
invertCondition (Boolean)
True/False whether to invert the condition or not.
custom (Object)
Any custom data to pass to this condition.
timeout (Int32)
The timeout to use.


ForExists(timeout, refreshElement) method

HtmlWait.ForExists(timeout, refreshElement) method
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlWait > ForExists(Int32, Boolean)
Protected exists. [Control the control refresh]
Syntax
C#
protected override void ForExists (
    int timeout,
    bool refreshElement
)
Parameters
timeout (Int32)
refreshElement (Boolean)


ForStyles methods

HtmlWait.ForStyles methods
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlWait > ForStyles
Members
Icon | Member | Description
 | ForStyles(Boolean, String[]()) | Wait for a set of styles on this element. (Timeout = HtmlWait.Timeout)
 | ForStyles(Int32, Boolean, String[]()) | Wait for a set of styles on this element.
 | ForStyles(Int32, String[]()) | Wait for a set of styles on this element.
 | ForStyles(String[]()) | Wait for a set of styles on this element. (Timeout = HtmlWait.Timeout)


ForStyles(stylesNameValuePairs) method

HtmlWait.ForStyles(stylesNameValuePairs) method
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlWait > ForStyles(String[]())
Wait for a set of styles on this element. (Timeout = HtmlWait.Timeout)
Syntax
C#
public void ForStyles (
    params string[] stylesNameValuePairs
)
Parameters
stylesNameValuePairs (String []())
The styles name/value pairs
Examples
ForStyles("backgroundColor=red","display=none")


ForStyles(timeout, stylesNameValuePairs) method

HtmlWait.ForStyles(timeout, stylesNameValuePairs) method
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlWait > ForStyles(Int32, String[]())
Wait for a set of styles on this element.
Syntax
C#
public void ForStyles (
    int timeout,
    params string[] stylesNameValuePairs
)
Parameters
timeout (Int32)
The timeout to use.
stylesNameValuePairs (String []())
The styles name/value pairs
Examples
ForStyles("backgroundColor=red","display=none")


ForStyles(timeout, useComputedStyles, stylesNameValuePairs) method

HtmlWait.ForStyles(timeout, useComputedStyles, stylesNameValuePairs) method
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlWait > ForStyles(Int32, Boolean, String[]())
Wait for a set of styles on this element.
Syntax
C#
public void ForStyles (
    int timeout,
    bool useComputedStyles,
    params string[] stylesNameValuePairs
)
Parameters
timeout (Int32)
The timeout to use.
useComputedStyles (Boolean)
True/False whether to use the computed style for this wait.
stylesNameValuePairs (String []())
The styles name/value pairs
Examples
ForStyles("backgroundColor=red","display=none")


ForStyles(useComputedStyles, stylesNameValuePairs) method

HtmlWait.ForStyles(useComputedStyles, stylesNameValuePairs) method
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlWait > ForStyles(Boolean, String[]())
Wait for a set of styles on this element. (Timeout = HtmlWait.Timeout)
Syntax
C#
public void ForStyles (
    bool useComputedStyles,
    params string[] stylesNameValuePairs
)
Parameters
useComputedStyles (Boolean)
True/False whether to use the computed style for this wait.
stylesNameValuePairs (String []())
The styles name/value pairs
Examples
ForStyles("backgroundColor=red","display=none")


ForStylesNot methods

HtmlWait.ForStylesNot methods
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlWait > ForStylesNot
Members
Icon | Member | Description
 | ForStylesNot(Boolean, String[]()) | Wait for a set of styles to no longer be true.
 | ForStylesNot(Int32, Boolean, String[]()) | Wait for a set of styles to no longer be true.
 | ForStylesNot(Int32, String[]()) | Wait for a set of styles to no longer be true.
 | ForStylesNot(String[]()) | Wait for a set of styles to no longer be true. (Timeout = HtmlWait.Timeout)


ForStylesNot(stylesNameValuePairs) method

HtmlWait.ForStylesNot(stylesNameValuePairs) method
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlWait > ForStylesNot(String[]())
Wait for a set of styles to no longer be true. (Timeout = HtmlWait.Timeout)
Syntax
C#
public void ForStylesNot (
    params string[] stylesNameValuePairs
)
Parameters
stylesNameValuePairs (String []())
The styles name/value pairs
Examples
ForStyles("backgroundColor=red","display=none")


ForStylesNot(timeout, stylesNameValuePairs) method

HtmlWait.ForStylesNot(timeout, stylesNameValuePairs) method
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlWait > ForStylesNot(Int32, String[]())
Wait for a set of styles to no longer be true.
Syntax
C#
public void ForStylesNot (
    int timeout,
    params string[] stylesNameValuePairs
)
Parameters
timeout (Int32)
The timeout to use.
stylesNameValuePairs (String []())
The styles name/value pairs
Examples
ForStyles("background-color=red","display=none")


ForStylesNot(timeout, useComputedStyles, stylesNameValuePairs) method

HtmlWait.ForStylesNot(timeout, useComputedStyles, stylesNameValuePairs) method
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlWait > ForStylesNot(Int32, Boolean, String[]())
Wait for a set of styles to no longer be true.
Syntax
C#
public void ForStylesNot (
    int timeout,
    bool useComputedStyles,
    params string[] stylesNameValuePairs
)
Parameters
timeout (Int32)
The timeout to use.
useComputedStyles (Boolean)
True/False whether to use the computed style for this wait.
stylesNameValuePairs (String []())
The styles name/value pairs
Examples
ForStyles("backgroundColor=red","display=none")


ForStylesNot(useComputedStyles, stylesNameValuePairs) method

HtmlWait.ForStylesNot(useComputedStyles, stylesNameValuePairs) method
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlWait > ForStylesNot(Boolean, String[]())
Wait for a set of styles to no longer be true.
Syntax
C#
public void ForStylesNot (
    bool useComputedStyles,
    params string[] stylesNameValuePairs
)
Parameters
useComputedStyles (Boolean)
True/False whether to use the computed style for this wait.
stylesNameValuePairs (String []())
The styles name/value pairs
Examples
ForStyles("backgroundColor=red","display=none")


ForVisible methods

HtmlWait.ForVisible methods
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlWait > ForVisible
Members
Icon | Member | Description
 | ForVisible() | Wait for an element to be visible. HtmlControl.IsVisible is true. (Timeout = HtmlWait.Timeout)
 | ForVisible(Int32) | Wait for an element to be visible. HtmlControl.IsVisible is true.


ForVisible() method

HtmlWait.ForVisible() method
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlWait > ForVisible()
Wait for an element to be visible. HtmlControl.IsVisible is true. (Timeout = HtmlWait.Timeout)
Syntax
C#
public void ForVisible ()


ForVisible(timeout) method

HtmlWait.ForVisible(timeout) method
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlWait > ForVisible(Int32)
Wait for an element to be visible. HtmlControl.IsVisible is true.
Syntax
C#
public void ForVisible (
    int timeout
)
Parameters
timeout (Int32)
The timeout to use.


ForVisibleNot methods

HtmlWait.ForVisibleNot methods
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlWait > ForVisibleNot
Members
Icon | Member | Description
 | ForVisibleNot() | Wait for an element to no longer be visible. HtmlControl.IsVisible is false. (Timeout = HtmlWait.Timeout)
 | ForVisibleNot(Int32) | Wait for an element to no longer be visible. HtmlControl.IsVisible is false.


ForVisibleNot() method

HtmlWait.ForVisibleNot() method
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlWait > ForVisibleNot()
Wait for an element to no longer be visible. HtmlControl.IsVisible is false. (Timeout = HtmlWait.Timeout)
Syntax
C#
public void ForVisibleNot ()


ForVisibleNot(timeout) method

HtmlWait.ForVisibleNot(timeout) method
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlWait > ForVisibleNot(Int32)
Wait for an element to no longer be visible. HtmlControl.IsVisible is false.
Syntax
C#
public void ForVisibleNot (
    int timeout
)
Parameters
timeout (Int32)
The timeout to use


HtmlWait(htmlControl, checkInterval) constructor

HtmlWait(htmlControl, checkInterval) constructor
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlWait > HtmlWaitNew(HtmlControl, Int32)
Create a new wait class.
Syntax
C#
public HtmlWait (
    HtmlControl htmlControl,
    int checkInterval
)
Parameters
htmlControl (HtmlControl)
The html control target
checkInterval (Int32)
Interval to use to check on the wait condition. (msec)


ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts Namespace

ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts Namespace
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts
Syntax
C#
namespace ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts
Types
All Types Classes Structures Interfaces Enumerations Delegates
Icon | Type | Description
public class | AssertAttribute | Provides assert service for control attributes
public class | AssertCheck | Assert the checked state for a CheckBox or RadioButton input
public class | AssertContent | Assert the content of an HtmlControl
public class | AssertSelect | Assert methods for an HtmlSelect control
public class | AssertStyle | Assert common htm styles
public class | AssertTable | Provide HtmlTable specific asserts
public enumeration | HtmlStyleBox | CSS2 box formatting (Padding, margin..etc)
public enumeration | HtmlStyleCategory | Style category
public enumeration | HtmlStyleColorAndBackground | CSS2 common color and background styles. (Color, backgroundColor..etc)
public enumeration | HtmlStyleDisplay | CSS2 common block formatting (Width, height...etc)
public enumeration | HtmlStyleFont | CSS2 common font styles. (Family, size..etc)
public enumeration | HtmlStyleList | CSS2 list styles (ListStyleType ...etc)
public enumeration | HtmlStyleText | CSS2 common text formatting (Wordspacing, letterspacing ...etc.)
public enumeration | HtmlStyleType | Style type (Computed vs Inline)
public enumeration | HtmlVisibility | CSS2 element visibility
public enumeration | NumberCompareType | Numerical compare type (Equals, less than..etc)
public enumeration | NumberRangeCompareType | Numerical range compare type (InRange, outsiderange)
public enumeration | StringCompareType | String compare type (Contains, exact ...etc.)


AssertAttribute class

AssertAttribute class
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts > AssertAttribute
Provides assert service for control attributes
Syntax
C#
public class AssertAttribute : BaseControlAssert<HtmlControl>
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AssertAttributeNew() | Create a new AssertAttribute
 | AssertAttributeNew(HtmlControl) | Create a new AssertAttribute
 | Assert(Boolean, String, String, String) | Perform an assert. (Inherited from BaseControlAssert <(Of HtmlControl >).)
 | Assert(Boolean, String, String, String, Boolean) | Perform an assert. (Inherited from BaseControlAssert <(Of HtmlControl >).)
 | AssertNumber(Int32, Int32, NumberCompareType) | Common assert for a number (Inherited from BaseControlAssert <(Of HtmlControl >).)
 | AssertString(String, String, StringCompareType) | Commnon assert for strings. (Inherited from BaseControlAssert <(Of HtmlControl >).)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Exists(String) | Assert a certain attribute exists
 | ExistsNot(String) | Assert a certain attribute does not exist
 | Finalize() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetAttribute(String) | Get an attribute.
 | GetHashCode() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Target | Gets or sets the assert target (Inherited from BaseControlAssert <(Of HtmlControl >).)
 | ToString() | Returns a String that represents the current Object. (Inherited from Object.)
 | Value(String, StringCompareType, String) | Assert the value of a certain attribute
Inheritance Hierarchy
Object
 | BaseControlAssert <(Of HtmlControl >)
 |  | AssertAttribute


Constructors

AssertAttribute constructors
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts > AssertAttribute > AssertAttributeNew
Members
Icon | Member | Description
 | AssertAttributeNew() | Create a new AssertAttribute
 | AssertAttributeNew(HtmlControl) | Create a new AssertAttribute


AssertAttribute() constructor

AssertAttribute() constructor
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts > AssertAttribute > AssertAttributeNew()
Create a new AssertAttribute
Syntax
C#
public AssertAttribute ()


AssertAttribute(control) constructor

AssertAttribute(control) constructor
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts > AssertAttribute > AssertAttributeNew(HtmlControl)
Create a new AssertAttribute
Syntax
C#
public AssertAttribute (
    HtmlControl control
)
Parameters
control (HtmlControl)
The target control to assert against


Exists(attributeName) method

AssertAttribute.Exists(attributeName) method
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts > AssertAttribute > Exists(String)
Assert a certain attribute exists
Syntax
C#
public bool Exists (
    string attributeName
)
Parameters
attributeName (String)
The attribute name.
Return Value
True/False or will throw an AsserException depending on the settings. (Default throw)


ExistsNot(attributeName) method

AssertAttribute.ExistsNot(attributeName) method
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts > AssertAttribute > ExistsNot(String)
Assert a certain attribute does not exist
Syntax
C#
public bool ExistsNot (
    string attributeName
)
Parameters
attributeName (String)
The attribute name.
Return Value
True/False or will throw an AsserException depending on the settings. (Default throw)


GetAttribute(name) method

AssertAttribute.GetAttribute(name) method
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts > AssertAttribute > GetAttribute(String)
Get an attribute.
Syntax
C#
protected iAttribute GetAttribute (
    string name
)
Parameters
name (String)
The attribute name.
Return Value
The atribute if found, else null or throw an AssertException.


Value(attributeName, compare, expectedValue) method

AssertAttribute.Value(attributeName, compare, expectedValue) method
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts > AssertAttribute > Value(String, StringCompareType, String)
Assert the value of a certain attribute
Syntax
C#
public bool Value (
    string attributeName,
    StringCompareType compare,
    string expectedValue
)
Parameters
attributeName (String)
The attribute name
compare (StringCompareType)
The compare type.
expectedValue (String)
The expected value.
Return Value
True/False or will throw an AsserException depending on the settings. (Default throw)


AssertCheck class

AssertCheck class
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts > AssertCheck
Assert the checked state for a CheckBox or RadioButton input
Syntax
C#
public class AssertCheck : BaseControlAssert<HtmlInputControl>
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AssertCheckNew() | Create an new AssertCheck.
 | AssertCheckNew(HtmlInputControl) | Create a new AssertCheck
 | Assert(Boolean, String, String, String) | Perform an assert. (Inherited from BaseControlAssert <(Of HtmlInputControl >).)
 | Assert(Boolean, String, String, String, Boolean) | Perform an assert. (Inherited from BaseControlAssert <(Of HtmlInputControl >).)
 | AssertNumber(Int32, Int32, NumberCompareType) | Common assert for a number (Inherited from BaseControlAssert <(Of HtmlInputControl >).)
 | AssertString(String, String, StringCompareType) | Commnon assert for strings. (Inherited from BaseControlAssert <(Of HtmlInputControl >).)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType() | Gets the Type of the current instance. (Inherited from Object.)
 | IsFalse() | Assert it is not checked.
 | IsTrue() | Assert it is checked
 | MemberwiseClone() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Target | Gets or sets the assert target (Inherited from BaseControlAssert <(Of HtmlInputControl >).)
 | ToString() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | BaseControlAssert <(Of HtmlInputControl >)
 |  | AssertCheck


Constructors

AssertCheck constructors
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts > AssertCheck > AssertCheckNew
Members
Icon | Member | Description
 | AssertCheckNew() | Create an new AssertCheck.
 | AssertCheckNew(HtmlInputControl) | Create a new AssertCheck


AssertCheck() constructor

AssertCheck() constructor
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts > AssertCheck > AssertCheckNew()
Create an new AssertCheck.
Syntax
C#
public AssertCheck ()


AssertCheck(control) constructor

AssertCheck(control) constructor
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts > AssertCheck > AssertCheckNew(HtmlInputControl)
Create a new AssertCheck
Syntax
C#
public AssertCheck (
    HtmlInputControl control
)
Parameters
control (HtmlInputControl)
The control to perform assert against.


IsFalse() method

AssertCheck.IsFalse() method
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts > AssertCheck > IsFalse()
Assert it is not checked.
Syntax
C#
public bool IsFalse ()
Return Value


IsTrue() method

AssertCheck.IsTrue() method
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts > AssertCheck > IsTrue()
Assert it is checked
Syntax
C#
public bool IsTrue ()
Return Value


AssertContent class

AssertContent class
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts > AssertContent
Assert the content of an HtmlControl
Syntax
C#
public class AssertContent : BaseControlAssert<HtmlControl>
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AssertContentNew() | Create an new AssertContent.
 | AssertContentNew(HtmlControl) | Create a new AssertContent
 | Assert(Boolean, String, String, String) | Perform an assert. (Inherited from BaseControlAssert <(Of HtmlControl >).)
 | Assert(Boolean, String, String, String, Boolean) | Perform an assert. (Inherited from BaseControlAssert <(Of HtmlControl >).)
 | AssertNumber(Int32, Int32, NumberCompareType) | Common assert for a number (Inherited from BaseControlAssert <(Of HtmlControl >).)
 | AssertString(String, String, StringCompareType) | Commnon assert for strings. (Inherited from BaseControlAssert <(Of HtmlControl >).)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType() | Gets the Type of the current instance. (Inherited from Object.)
 | InnerMarkup(StringCompareType, String) | Assert the InnerMarkup of the element.
 | InnerText(StringCompareType, String) | Assert the InnerText of the element.
 | MemberwiseClone() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OuterMarkup(StringCompareType, String) | Assert the OuterMarkup of the element.
 | StartTagContent(StringCompareType, String) | Assert the StartTagContent of the element.
 | Target | Gets or sets the assert target (Inherited from BaseControlAssert <(Of HtmlControl >).)
 | TextContent(StringCompareType, String) | Assert the TextContent of the element.
 | ToString() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | BaseControlAssert <(Of HtmlControl >)
 |  | AssertContent


Constructors

AssertContent constructors
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts > AssertContent > AssertContentNew
Members
Icon | Member | Description
 | AssertContentNew() | Create an new AssertContent.
 | AssertContentNew(HtmlControl) | Create a new AssertContent


AssertContent() constructor

AssertContent() constructor
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts > AssertContent > AssertContentNew()
Create an new AssertContent.
Syntax
C#
public AssertContent ()


AssertContent(control) constructor

AssertContent(control) constructor
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts > AssertContent > AssertContentNew(HtmlControl)
Create a new AssertContent
Syntax
C#
public AssertContent (
    HtmlControl control
)
Parameters
control (HtmlControl)
The control to perform assert against.


InnerMarkup(compareType, expectedValue) method

AssertContent.InnerMarkup(compareType, expectedValue) method
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts > AssertContent > InnerMarkup(StringCompareType, String)
Assert the InnerMarkup of the element.
Syntax
C#
public bool InnerMarkup (
    StringCompareType compareType,
    string expectedValue
)
Parameters
compareType (StringCompareType)
The compare type/
expectedValue (String)
The expected value
Return Value
True/False or will throw an AsserException depending on the settings. (Default throw)


InnerText(compareType, expectedValue) method

AssertContent.InnerText(compareType, expectedValue) method
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts > AssertContent > InnerText(StringCompareType, String)
Assert the InnerText of the element.
Syntax
C#
public bool InnerText (
    StringCompareType compareType,
    string expectedValue
)
Parameters
compareType (StringCompareType)
The compare type
expectedValue (String)
The expected value
Return Value
True/False or will throw an AsserException depending on the settings. (Default throw)


OuterMarkup(compareType, expectedValue) method

AssertContent.OuterMarkup(compareType, expectedValue) method
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts > AssertContent > OuterMarkup(StringCompareType, String)
Assert the OuterMarkup of the element.
Syntax
C#
public bool OuterMarkup (
    StringCompareType compareType,
    string expectedValue
)
Parameters
compareType (StringCompareType)
The compare type/
expectedValue (String)
The expected value
Return Value
True/False or will throw an AsserException depending on the settings. (Default throw)


StartTagContent(compareType, expectedValue) method

AssertContent.StartTagContent(compareType, expectedValue) method
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts > AssertContent > StartTagContent(StringCompareType, String)
Assert the StartTagContent of the element.
Syntax
C#
public bool StartTagContent (
    StringCompareType compareType,
    string expectedValue
)
Parameters
compareType (StringCompareType)
The compare type/
expectedValue (String)
The expected value
Return Value
True/False or will throw an AsserException depending on the settings. (Default throw)


TextContent(compareType, expectedValue) method

AssertContent.TextContent(compareType, expectedValue) method
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts > AssertContent > TextContent(StringCompareType, String)
Assert the TextContent of the element.
Syntax
C#
public bool TextContent (
    StringCompareType compareType,
    string expectedValue
)
Parameters
compareType (StringCompareType)
The compare type/
expectedValue (String)
The expected value
Return Value
True/False or will throw an AsserException depending on the settings. (Default throw)


AssertSelect class

AssertSelect class
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts > AssertSelect
Assert methods for an HtmlSelect control
Syntax
C#
public class AssertSelect : BaseControlAssert<HtmlSelect>
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AssertSelectNew() | Create a new AssertSelect class.
 | AssertSelectNew(HtmlSelect) | Create a new AssertSelect class.
 | Assert(Boolean, String, String, String) | Perform an assert. (Inherited from BaseControlAssert <(Of HtmlSelect >).)
 | Assert(Boolean, String, String, String, Boolean) | Perform an assert. (Inherited from BaseControlAssert <(Of HtmlSelect >).)
 | AssertNumber(Int32, Int32, NumberCompareType) | Common assert for a number (Inherited from BaseControlAssert <(Of HtmlSelect >).)
 | AssertString(String, String, StringCompareType) | Commnon assert for strings. (Inherited from BaseControlAssert <(Of HtmlSelect >).)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType() | Gets the Type of the current instance. (Inherited from Object.)
 | ItemsCountIs(NumberCompareType, Int32) | Assert the items count in the select.
 | MemberwiseClone() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | SelectedIndex(NumberCompareType, Int32) | Assert the selected index
 | SelectedText(StringCompareType, String) | Assert the selected text
 | SelectedValue(StringCompareType, String) | Assert the selected value
 | Target | Gets or sets the assert target (Inherited from BaseControlAssert <(Of HtmlSelect >).)
 | TextExists(String) | Assert a text exists in the select.
 | TextExistsNot(String) | Assert a text does not exist in the select.
 | ToString() | Returns a String that represents the current Object. (Inherited from Object.)
 | ValueExists(String) | Assert a value exists in the select
 | ValueExistsNot(String) | Assert a value does not exist in the select.
Inheritance Hierarchy
Object
 | BaseControlAssert <(Of HtmlSelect >)
 |  | AssertSelect


Constructors

AssertSelect constructors
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts > AssertSelect > AssertSelectNew
Members
Icon | Member | Description
 | AssertSelectNew() | Create a new AssertSelect class.
 | AssertSelectNew(HtmlSelect) | Create a new AssertSelect class.


AssertSelect() constructor

AssertSelect() constructor
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts > AssertSelect > AssertSelectNew()
Create a new AssertSelect class.
Syntax
C#
public AssertSelect ()


AssertSelect(select) constructor

AssertSelect(select) constructor
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts > AssertSelect > AssertSelectNew(HtmlSelect)
Create a new AssertSelect class.
Syntax
C#
public AssertSelect (
    HtmlSelect select
)
Parameters
select (HtmlSelect)
The target HtmlSelect


ItemsCountIs(compareType, expectedValue) method

AssertSelect.ItemsCountIs(compareType, expectedValue) method
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts > AssertSelect > ItemsCountIs(NumberCompareType, Int32)
Assert the items count in the select.
Syntax
C#
public bool ItemsCountIs (
    NumberCompareType compareType,
    int expectedValue
)
Parameters
compareType (NumberCompareType)
The integer compare type.
expectedValue (Int32)
The expected value.
Return Value
True/False or will throw an AsserException depending on the settings. (Default throw)


SelectedIndex(compareType, index) method

AssertSelect.SelectedIndex(compareType, index) method
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts > AssertSelect > SelectedIndex(NumberCompareType, Int32)
Assert the selected index
Syntax
C#
public bool SelectedIndex (
    NumberCompareType compareType,
    int index
)
Parameters
compareType (NumberCompareType)
The compare type.
index (Int32)
The expected index
Return Value
True/False or will throw an AsserException depending on the settings. (Default throw)


SelectedText(compareType, expectedText) method

AssertSelect.SelectedText(compareType, expectedText) method
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts > AssertSelect > SelectedText(StringCompareType, String)
Assert the selected text
Syntax
C#
public bool SelectedText (
    StringCompareType compareType,
    string expectedText
)
Parameters
compareType (StringCompareType)
The compare type.
expectedText (String)
The expected text.
Return Value
True/False or will throw an AsserException depending on the settings. (Default throw)


SelectedValue(compareType, expectedValue) method

AssertSelect.SelectedValue(compareType, expectedValue) method
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts > AssertSelect > SelectedValue(StringCompareType, String)
Assert the selected value
Syntax
C#
public bool SelectedValue (
    StringCompareType compareType,
    string expectedValue
)
Parameters
compareType (StringCompareType)
The compare type.
expectedValue (String)
The expected value.
Return Value
True/False or will throw an AsserException depending on the settings. (Default throw)


TextExists(expectedText) method

AssertSelect.TextExists(expectedText) method
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts > AssertSelect > TextExists(String)
Assert a text exists in the select.
Syntax
C#
public bool TextExists (
    string expectedText
)
Parameters
expectedText (String)
Return Value
True/False or will throw an AsserException depending on the settings. (Default throw)


TextExistsNot(expectedText) method

AssertSelect.TextExistsNot(expectedText) method
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts > AssertSelect > TextExistsNot(String)
Assert a text does not exist in the select.
Syntax
C#
public bool TextExistsNot (
    string expectedText
)
Parameters
expectedText (String)
The expected text to verify it does not exist.
Return Value
True/False or will throw an AsserException depending on the settings. (Default throw)


ValueExists(expectedValue) method

AssertSelect.ValueExists(expectedValue) method
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts > AssertSelect > ValueExists(String)
Assert a value exists in the select
Syntax
C#
public bool ValueExists (
    string expectedValue
)
Parameters
expectedValue (String)
The expected value.
Return Value
True/False or will throw an AsserException depending on the settings. (Default throw)


ValueExistsNot(expectedValue) method

AssertSelect.ValueExistsNot(expectedValue) method
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts > AssertSelect > ValueExistsNot(String)
Assert a value does not exist in the select.
Syntax
C#
public bool ValueExistsNot (
    string expectedValue
)
Parameters
expectedValue (String)
The expected value to verify it does not exist.
Return Value
True/False or will throw an AsserException depending on the settings. (Default throw)


AssertStyle class

AssertStyle class
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts > AssertStyle
Assert common htm styles
Syntax
C#
public class AssertStyle : BaseControlAssert<HtmlControl>
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AssertStyleNew() | Create a new AssertStyle object.
 | AssertStyleNew(HtmlControl) | Create a new AssertStyle object passing it the target control.
 | Assert(Boolean, String, String, String) | Perform an assert. (Inherited from BaseControlAssert <(Of HtmlControl >).)
 | Assert(Boolean, String, String, String, Boolean) | Perform an assert. (Inherited from BaseControlAssert <(Of HtmlControl >).)
 | AssertNumber(Int32, Int32, NumberCompareType) | Common assert for a number (Inherited from BaseControlAssert <(Of HtmlControl >).)
 | AssertString(String, String, StringCompareType) | Commnon assert for strings. (Inherited from BaseControlAssert <(Of HtmlControl >).)
 | Box(HtmlStyleBox, String) | Assert Box styles.
 | Box(HtmlStyleBox, String, HtmlStyleType) | Assert Box styles.
 | ColorAndBackground(HtmlStyleColorAndBackground, String) | Assert Color/Background styles.
 | ColorAndBackground(HtmlStyleColorAndBackground, String, HtmlStyleType) | Assert Color/Background styles.
 | CommonStyleAssert(Object, String, HtmlStyleType) | Assert a style
 | DefaultStyleType | Gets or sets the default style to use.
 | Display(HtmlStyleDisplay, String) | Assert Display styles.
 | Display(HtmlStyleDisplay, String, HtmlStyleType) | Assert Display styles.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Font(HtmlStyleFont, String) | Assert Font styles.
 | Font(HtmlStyleFont, String, HtmlStyleType) | Assert Font styles.
 | GetHashCode() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetStyleLiteral(Object, Boolean) | Given a style enum value, will read its CssStyleAttribute and get its literal string representation.
 | GetStyleValue(HtmlControl, Object, HtmlStyleType, Boolean) | Get a style value given an HtmlControl and an enum style type.
 | GetType() | Gets the Type of the current instance. (Inherited from Object.)
 | List(HtmlStyleList, String) | Assert List styles.
 | List(HtmlStyleList, String, HtmlStyleType) | Assert List styles.
 | MemberwiseClone() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Target | Gets or sets the assert target (Inherited from BaseControlAssert <(Of HtmlControl >).)
 | Text(HtmlStyleText, String) | Assert Text styles.
 | Text(HtmlStyleText, String, HtmlStyleType) | Assert Text styles.
 | ToString() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | BaseControlAssert <(Of HtmlControl >)
 |  | AssertStyle


Box methods

AssertStyle.Box methods
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts > AssertStyle > Box
Members
Icon | Member | Description
 | Box(HtmlStyleBox, String) | Assert Box styles.
 | Box(HtmlStyleBox, String, HtmlStyleType) | Assert Box styles.


Box(styleName, expectedValue) method

AssertStyle.Box(styleName, expectedValue) method
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts > AssertStyle > Box(HtmlStyleBox, String)
Assert Box styles.
Syntax
C#
public bool Box (
    HtmlStyleBox styleName,
    string expectedValue
)
Parameters
styleName (HtmlStyleBox)
The style name.
expectedValue (String)
The expected value.
Return Value
True/False or will throw an AsserException depending on the getting. (Default throw)


Box(styleName, expectedValue, styleType) method

AssertStyle.Box(styleName, expectedValue, styleType) method
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts > AssertStyle > Box(HtmlStyleBox, String, HtmlStyleType)
Assert Box styles.
Syntax
C#
public bool Box (
    HtmlStyleBox styleName,
    string expectedValue,
    HtmlStyleType styleType
)
Parameters
styleName (HtmlStyleBox)
The style name.
expectedValue (String)
The expected value.
styleType (HtmlStyleType)
The style type.
Return Value
True/False or will throw an AsserException depending on the getting. (Default throw)


ColorAndBackground methods

AssertStyle.ColorAndBackground methods
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts > AssertStyle > ColorAndBackground
Members
Icon | Member | Description
 | ColorAndBackground(HtmlStyleColorAndBackground, String) | Assert Color/Background styles.
 | ColorAndBackground(HtmlStyleColorAndBackground, String, HtmlStyleType) | Assert Color/Background styles.


ColorAndBackground(styleName, expectedValue) method

AssertStyle.ColorAndBackground(styleName, expectedValue) method
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts > AssertStyle > ColorAndBackground(HtmlStyleColorAndBackground, String)
Assert Color/Background styles.
Syntax
C#
public bool ColorAndBackground (
    HtmlStyleColorAndBackground styleName,
    string expectedValue
)
Parameters
styleName (HtmlStyleColorAndBackground)
The style name.
expectedValue (String)
The expected value.
Return Value
True/False or will throw an AsserException depending on the getting. (Default throw)


ColorAndBackground(styleName, expectedValue, styleType) method

AssertStyle.ColorAndBackground(styleName, expectedValue, styleType) method
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts > AssertStyle > ColorAndBackground(HtmlStyleColorAndBackground, String, HtmlStyleType)
Assert Color/Background styles.
Syntax
C#
public bool ColorAndBackground (
    HtmlStyleColorAndBackground styleName,
    string expectedValue,
    HtmlStyleType styleType
)
Parameters
styleName (HtmlStyleColorAndBackground)
The style name.
expectedValue (String)
The expected value.
styleType (HtmlStyleType)
The style type.
Return Value
True/False or will throw an AsserException depending on the getting. (Default throw)


CommonStyleAssert(style, expectedValue, styleType) method

AssertStyle.CommonStyleAssert(style, expectedValue, styleType) method
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts > AssertStyle > CommonStyleAssert(Object, String, HtmlStyleType)
Assert a style
Syntax
C#
protected bool CommonStyleAssert (
    Object style,
    string expectedValue,
    HtmlStyleType styleType
)
Parameters
style (Object)
The style object.
expectedValue (String)
Expected value.
styleType (HtmlStyleType)
The style type
Return Value


Constructors

AssertStyle constructors
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts > AssertStyle > AssertStyleNew
Members
Icon | Member | Description
 | AssertStyleNew() | Create a new AssertStyle object.
 | AssertStyleNew(HtmlControl) | Create a new AssertStyle object passing it the target control.


AssertStyle() constructor

AssertStyle() constructor
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts > AssertStyle > AssertStyleNew()
Create a new AssertStyle object.
Syntax
C#
public AssertStyle ()


AssertStyle(control) constructor

AssertStyle(control) constructor
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts > AssertStyle > AssertStyleNew(HtmlControl)
Create a new AssertStyle object passing it the target control.
Syntax
C#
public AssertStyle (
    HtmlControl control
)
Parameters
control (HtmlControl)
The target control


DefaultStyleType property

AssertStyle.DefaultStyleType property
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts > AssertStyle > DefaultStyleType
Gets or sets the default style to use.
Syntax
C#
public HtmlStyleType DefaultStyleType { get; set; }


Display methods

AssertStyle.Display methods
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts > AssertStyle > Display
Members
Icon | Member | Description
 | Display(HtmlStyleDisplay, String) | Assert Display styles.
 | Display(HtmlStyleDisplay, String, HtmlStyleType) | Assert Display styles.


Display(styleName, expectedValue) method

AssertStyle.Display(styleName, expectedValue) method
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts > AssertStyle > Display(HtmlStyleDisplay, String)
Assert Display styles.
Syntax
C#
public bool Display (
    HtmlStyleDisplay styleName,
    string expectedValue
)
Parameters
styleName (HtmlStyleDisplay)
The style name.
expectedValue (String)
The expected value.
Return Value
True/False or will throw an AsserException depending on the getting. (Default throw)


Display(styleName, expectedValue, styleType) method

AssertStyle.Display(styleName, expectedValue, styleType) method
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts > AssertStyle > Display(HtmlStyleDisplay, String, HtmlStyleType)
Assert Display styles.
Syntax
C#
public bool Display (
    HtmlStyleDisplay styleName,
    string expectedValue,
    HtmlStyleType styleType
)
Parameters
styleName (HtmlStyleDisplay)
The font style name.
expectedValue (String)
The expected value.
styleType (HtmlStyleType)
The style type.
Return Value
True/False or will throw an AsserException depending on the getting. (Default throw)


Font methods

AssertStyle.Font methods
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts > AssertStyle > Font
Members
Icon | Member | Description
 | Font(HtmlStyleFont, String) | Assert Font styles.
 | Font(HtmlStyleFont, String, HtmlStyleType) | Assert Font styles.


Font(styleName, expectedValue) method

AssertStyle.Font(styleName, expectedValue) method
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts > AssertStyle > Font(HtmlStyleFont, String)
Assert Font styles.
Syntax
C#
public bool Font (
    HtmlStyleFont styleName,
    string expectedValue
)
Parameters
styleName (HtmlStyleFont)
The font style name.
expectedValue (String)
The expected value.
Return Value
True/False or will throw an AsserException depending on the getting. (Default throw)


Font(styleName, expectedValue, styleType) method

AssertStyle.Font(styleName, expectedValue, styleType) method
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts > AssertStyle > Font(HtmlStyleFont, String, HtmlStyleType)
Assert Font styles.
Syntax
C#
public bool Font (
    HtmlStyleFont styleName,
    string expectedValue,
    HtmlStyleType styleType
)
Parameters
styleName (HtmlStyleFont)
The font style name.
expectedValue (String)
The expected value.
styleType (HtmlStyleType)
The style type.
Return Value
True/False or will throw an AsserException depending on the getting. (Default throw)


GetStyleLiteral(styleEnum, isColor) method

AssertStyle.GetStyleLiteral(styleEnum, isColor) method
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts > AssertStyle > GetStyleLiteral(Object, Boolean)
Given a style enum value, will read its CssStyleAttribute and get its literal string representation.
Syntax
C#
public static string GetStyleLiteral (
    Object styleEnum,
    out bool isColor
)
Parameters
styleEnum (Object)
The actual enum value of the style.
isColor (Boolean)
Whether the style is a color style.
Return Value
The string representation.


GetStyleValue(control, styleEnum, styleType, isColor) method

AssertStyle.GetStyleValue(control, styleEnum, styleType, isColor) method
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts > AssertStyle > GetStyleValue(HtmlControl, Object, HtmlStyleType, Boolean)
Get a style value given an HtmlControl and an enum style type.
Syntax
C#
public static string GetStyleValue (
    HtmlControl control,
    Object styleEnum,
    HtmlStyleType styleType,
    out bool isColor
)
Parameters
control (HtmlControl)
The control
styleEnum (Object)
The enum style
styleType (HtmlStyleType)
The style type.
isColor (Boolean)
Return Value
The actual value.


List methods

AssertStyle.List methods
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts > AssertStyle > List
Members
Icon | Member | Description
 | List(HtmlStyleList, String) | Assert List styles.
 | List(HtmlStyleList, String, HtmlStyleType) | Assert List styles.


List(styleName, expectedValue) method

AssertStyle.List(styleName, expectedValue) method
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts > AssertStyle > List(HtmlStyleList, String)
Assert List styles.
Syntax
C#
public bool List (
    HtmlStyleList styleName,
    string expectedValue
)
Parameters
styleName (HtmlStyleList)
The style name.
expectedValue (String)
The expected value.
Return Value
True/False or will throw an AsserException depending on the getting. (Default throw)


List(styleName, expectedValue, styleType) method

AssertStyle.List(styleName, expectedValue, styleType) method
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts > AssertStyle > List(HtmlStyleList, String, HtmlStyleType)
Assert List styles.
Syntax
C#
public bool List (
    HtmlStyleList styleName,
    string expectedValue,
    HtmlStyleType styleType
)
Parameters
styleName (HtmlStyleList)
The style name.
expectedValue (String)
The expected value.
styleType (HtmlStyleType)
The style type.
Return Value
True/False or will throw an AsserException depending on the getting. (Default throw)


Text methods

AssertStyle.Text methods
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts > AssertStyle > Text
Members
Icon | Member | Description
 | Text(HtmlStyleText, String) | Assert Text styles.
 | Text(HtmlStyleText, String, HtmlStyleType) | Assert Text styles.


Text(styleName, expectedValue) method

AssertStyle.Text(styleName, expectedValue) method
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts > AssertStyle > Text(HtmlStyleText, String)
Assert Text styles.
Syntax
C#
public bool Text (
    HtmlStyleText styleName,
    string expectedValue
)
Parameters
styleName (HtmlStyleText)
The style name.
expectedValue (String)
The expected value.
Return Value
True/False or will throw an AsserException depending on the getting. (Default throw)


Text(styleName, expectedValue, styleType) method

AssertStyle.Text(styleName, expectedValue, styleType) method
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts > AssertStyle > Text(HtmlStyleText, String, HtmlStyleType)
Assert Text styles.
Syntax
C#
public bool Text (
    HtmlStyleText styleName,
    string expectedValue,
    HtmlStyleType styleType
)
Parameters
styleName (HtmlStyleText)
The style name.
expectedValue (String)
The expected value.
styleType (HtmlStyleType)
The style type.
Return Value
True/False or will throw an AsserException depending on the getting. (Default throw)


AssertTable class

AssertTable class
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts > AssertTable
Provide HtmlTable specific asserts
Syntax
C#
public class AssertTable : BaseControlAssert<HtmlTable>
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AssertTableNew() | Create a table assert
 | AssertTableNew(HtmlTable) | Create a table assert
 | Assert(Boolean, String, String, String) | Perform an assert. (Inherited from BaseControlAssert <(Of HtmlTable >).)
 | Assert(Boolean, String, String, String, Boolean) | Perform an assert. (Inherited from BaseControlAssert <(Of HtmlTable >).)
 | AssertNumber(Int32, Int32, NumberCompareType) | Common assert for a number (Inherited from BaseControlAssert <(Of HtmlTable >).)
 | AssertString(String, String, StringCompareType) | Commnon assert for strings. (Inherited from BaseControlAssert <(Of HtmlTable >).)
 | ColumnCount(NumberCompareType, Int32) | Assert the table column count.
 | ColumnRange(NumberRangeCompareType, Int32, Int32) | Assert the column range count.
 | Contains(StringCompareType, String) | Asserts that a certain text appears in the table.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | RowCount(NumberCompareType, Int32) | Assert the table row count.
 | RowRange(NumberRangeCompareType, Int32, Int32) | Assert the row range count.
 | Target | Gets or sets the assert target (Inherited from BaseControlAssert <(Of HtmlTable >).)
 | ToString() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | BaseControlAssert <(Of HtmlTable >)
 |  | AssertTable


ColumnCount(compareType, expected) method

AssertTable.ColumnCount(compareType, expected) method
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts > AssertTable > ColumnCount(NumberCompareType, Int32)
Assert the table column count.
Syntax
C#
public bool ColumnCount (
    NumberCompareType compareType,
    int expected
)
Parameters
compareType (NumberCompareType)
The compare type.
expected (Int32)
The expected value.
Return Value
True/False or will throw an AsserException depending on the settings. (Default throw)


ColumnRange(compareType, lowerEnd, upperEnd) method

AssertTable.ColumnRange(compareType, lowerEnd, upperEnd) method
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts > AssertTable > ColumnRange(NumberRangeCompareType, Int32, Int32)
Assert the column range count.
Syntax
C#
public bool ColumnRange (
    NumberRangeCompareType compareType,
    int lowerEnd,
    int upperEnd
)
Parameters
compareType (NumberRangeCompareType)
In/Out of range
lowerEnd (Int32)
Lower end of range
upperEnd (Int32)
Upper end of range
Return Value
True/False or will throw an AsserException depending on the settings. (Default throw)


Constructors

AssertTable constructors
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts > AssertTable > AssertTableNew
Members
Icon | Member | Description
 | AssertTableNew() | Create a table assert
 | AssertTableNew(HtmlTable) | Create a table assert


AssertTable() constructor

AssertTable() constructor
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts > AssertTable > AssertTableNew()
Create a table assert
Syntax
C#
public AssertTable ()


AssertTable(table) constructor

AssertTable(table) constructor
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts > AssertTable > AssertTableNew(HtmlTable)
Create a table assert
Syntax
C#
public AssertTable (
    HtmlTable table
)
Parameters
table (HtmlTable)
The HtmlTable to set as the target


Contains(compareType, expectedString) method

AssertTable.Contains(compareType, expectedString) method
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts > AssertTable > Contains(StringCompareType, String)
Asserts that a certain text appears in the table.
Syntax
C#
public bool Contains (
    StringCompareType compareType,
    string expectedString
)
Parameters
compareType (StringCompareType)
The compare type.
expectedString (String)
The expected string
Return Value
True/False or will throw an AsserException depending on the settings. (Default throw)


RowCount(compareType, expected) method

AssertTable.RowCount(compareType, expected) method
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts > AssertTable > RowCount(NumberCompareType, Int32)
Assert the table row count.
Syntax
C#
public bool RowCount (
    NumberCompareType compareType,
    int expected
)
Parameters
compareType (NumberCompareType)
The compare type.
expected (Int32)
The expected value.
Return Value
True/False or will throw an AsserException depending on the settings. (Default throw)


RowRange(range, lowerEnd, upperEnd) method

AssertTable.RowRange(range, lowerEnd, upperEnd) method
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts > AssertTable > RowRange(NumberRangeCompareType, Int32, Int32)
Assert the row range count.
Syntax
C#
public bool RowRange (
    NumberRangeCompareType range,
    int lowerEnd,
    int upperEnd
)
Parameters
range (NumberRangeCompareType)
In/Out of range
lowerEnd (Int32)
Lower end of range
upperEnd (Int32)
Upper end of range
Return Value
True/False or will throw an AsserException depending on the settings. (Default throw)


HtmlStyleBox enumeration

HtmlStyleBox enumeration
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts > HtmlStyleBox
CSS2 box formatting (Padding, margin..etc)
Syntax
C#
public enum HtmlStyleBox
Members
Member | Description
MarginTop |
MarginRight |
MarginBottom |
MarginLeft |
Margin |
PaddingTop |
PaddingRight |
PaddingBottom |
PaddingLeft |
Padding |
BorderTopWidth |
BorderRightWidth |
BorderBottomWidth |
BorderLeftWidth |
BorderWidth |
BorderTopColor |
BorderRightColor |
BorderBottomColor |
BorderLeftColor |
BorderColor |
BorderStyle |
BorderTopStyle |
BorderRightStyle |
BorderBottomStyle |
BorderLeftStyle |
BorderTop |
BorderRight |
BorderBottom |
BorderLeft |
Border |
NotSet |


HtmlStyleCategory enumeration

HtmlStyleCategory enumeration
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts > HtmlStyleCategory
Style category
Syntax
C#
public enum HtmlStyleCategory
Members
Member | Description
Font |
ColorAndBackground |
Text |
Display |
Box |
List |
NotSet |


HtmlStyleColorAndBackground enumeration

HtmlStyleColorAndBackground enumeration
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts > HtmlStyleColorAndBackground
CSS2 common color and background styles. (Color, backgroundColor..etc)
Syntax
C#
public enum HtmlStyleColorAndBackground
Members
Member | Description
Color |
BackgroundColor |
BackgroundImage |
BackgroundRepeat |
BackgroundAttachment |
BackgroundPosition |
Background |
NotSet |


HtmlStyleDisplay enumeration

HtmlStyleDisplay enumeration
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts > HtmlStyleDisplay
CSS2 common block formatting (Width, height...etc)
Syntax
C#
public enum HtmlStyleDisplay
Members
Member | Description
Width |
Height |
LineHeight |
VerticalAlign |
MinWidth |
MaxWidth |
MinHeight |
MaxHeight |
Display |
Position |
Top |
Left |
Bottom |
Right |
Float |
zIndex |
NotSet |


HtmlStyleFont enumeration

HtmlStyleFont enumeration
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts > HtmlStyleFont
CSS2 common font styles. (Family, size..etc)
Syntax
C#
public enum HtmlStyleFont
Members
Member | Description
Family |
Style |
Variant |
Weight |
Size |
Stretch |
NotSet |


HtmlStyleList enumeration

HtmlStyleList enumeration
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts > HtmlStyleList
CSS2 list styles (ListStyleType ...etc)
Syntax
C#
public enum HtmlStyleList
Members
Member | Description
ListStyleType |
ListStyleImage |
ListStylePosition |
ListStyle |
NotSet |


HtmlStyleText enumeration

HtmlStyleText enumeration
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts > HtmlStyleText
CSS2 common text formatting (Wordspacing, letterspacing ...etc.)
Syntax
C#
public enum HtmlStyleText
Members
Member | Description
WordSpacing |
LetterSpacing |
WhiteSpace |
TextTransform |
TextAlign |
TextIndent |
TextDecoration |
TextShadow |
NotSet |


HtmlStyleType enumeration

HtmlStyleType enumeration
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts > HtmlStyleType
Style type (Computed vs Inline)
Syntax
C#
public enum HtmlStyleType
Members
Member | Description
Computed |
Inline |


HtmlVisibility enumeration

HtmlVisibility enumeration
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts > HtmlVisibility
CSS2 element visibility
Syntax
C#
public enum HtmlVisibility
Members
Member | Description
Visible |
Hidden |
Collapsed |
NotSet |


NumberCompareType enumeration

NumberCompareType enumeration
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts > NumberCompareType
Numerical compare type (Equals, less than..etc)
Syntax
C#
public enum NumberCompareType
Members
Member | Description
Equals |
LessThan |
GreaterThan |
LessThanOrEqual |
GreaterThanOrEqual |
NotEqual |


NumberRangeCompareType enumeration

NumberRangeCompareType enumeration
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts > NumberRangeCompareType
Numerical range compare type (InRange, outsiderange)
Syntax
C#
public enum NumberRangeCompareType
Members
Member | Description
InRange |
OutsideRange |


StringCompareType enumeration

StringCompareType enumeration
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts > StringCompareType
String compare type (Contains, exact ...etc.)
Syntax
C#
public enum StringCompareType
Members
Member | Description
Exact | Exact comparison
Contains | Contains comparison
NotContain | Does not contain comparison
StartsWith | Starts with comparison
EndsWith | Ends with comparison
RegEx | Regex comparison


ArtOfTest.WebAii.Core Namespace

ArtOfTest.WebAii.Core Namespace
Namespaces > ArtOfTest.WebAii.Core
Syntax
C#
namespace ArtOfTest.WebAii.Core
Types
All Types Classes Structures Interfaces Enumerations Delegates
Icon Type Description
public class Actions
Generic action support for all browser types.
public enumeration AnnotationMode
The different annotation modes
public class Browser
Class represents a browser instance managed by the Manager. This object exposes all the browser specific information and methods to automate the underlying browser that this instance represents.
public enumeration BrowserCacheType
The different common categories of browser caching.
public enumeration BrowserType
The browser type. (i.e. firefox, internet explorer ...etc).
public class Desktop
Class representing the desktop input devices. Mouse and Keyboard.
public class ElementFinder
Provides infrastructure for accessing elements defined by FindParamAttribute on test methods and classes. Replaces the Find.Elements dictionary which has been obsoleted.
public enumeration ElementSyncMethod
The different type of element-dom synchronization supported by the framework and the SyncManager.
public class Find
Class provides quick search routines for finding an element(s) within a document.
public enumeration FindReferenceType
Defines which reference type the Find object is using.
public class FrameInfo
Information regarding a specific frame
public class FramesCollection
Collection of frames (Browser objects)
public enumeration LocalWebServerType
Type of local web servers available for tests.
public class Log
Log support for the framework and test cases.
public enumeration LogType
The types of logging available in WebAii.
public class Manager
This class manages the life spans and instances of all browser objects in the framework. It also manages the communication pipeline between the framework and all browsers.
public enumeration MouseClickType
The different types of mouse events to perform.
public enumeration MouseWheelTurnDirection
The mouse wheel turn directions.
public enumeration OffsetReference
Offset references used to adjust the target point (X,Y) of an action.
public enumeration ScriptEventType
Type of script events that can be invoked on an html element.
public enumeration ScrollToVisibleType
Used to configure what the default scroll to visible behavior is.
public class Settings
Class representing the settings to be used when initializing the framework.
public class SettingsConfigSectionHandler
Settings object config section handler. Use this object to read a Settings config section in a .config file.
Examples
   You can persist the settings for your application/test cases in a config file.

   The following is a sample config file that holds certain settings. Any settings
   not specified in this section, their values will be set to the system defaults:

   <?xml version="1.0" encoding="utf-8" ?>
      <configuration>
          <configSections>
              <section name="WebAii.Settings" type="ArtOfTest.WebAii.Core.SettingsConfigSectionHandler,ArtOfTest.WebAii"/>
          </configSections>

      <WebAii.Settings
          defaultBrowser="InternetExplorer"
          logLocation="D:\Log\"
          executionTimeout="30000"
          clientReadyTimeout="20000"
          localWebServer="None";
          webAppPhysicalPath="c:\Inetpub\wwwroot\MyApplication"
          enableScriptLogging="false"
          queryEventLogErrorsOnExit="false"
          enableUILessRequestViewing="false"
          baseUrl="http://www.testsite.com/"
          executionDelay="0"
          annotateExecution="false"
          annotationMode="All"
          logAnnotations="false"
          simulatedMouseMoveSpeed="0.3f"
          waitCheckInterval="500"
          aspNetDevServerPort="-1"
          createLogFile="true"
          killBrowserProcessOnClose="false"
      />

      </configuration>

   In your code, you can get these settings by using the SettingsConfigSectionHandler like this:

   SettingsConfigSectionHandler settingsSection =
               (SettingsConfigSectionHandler)ConfigurationManager.GetSection("WebAii.Settings");
   Settings mySettings = new Settings(settingsSection);

   You can then use mySettings to pass in to the Manager constructor.

public class TreeBuilder
This class builds the a strongly-typed markup elements tree.


Actions class

Actions class
Namespaces > ArtOfTest.WebAii.Core > Actions
Generic action support for all browser types.
Syntax
C#
public abstract class Actions
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AnnotateElement(Element, String) | Visually annotates an element on the browser surface.
 | AnnotateMessage(String) | Visually annotate a message on the browser surface.
 | Browser | Gets the Browser object associated with this instance of the actions object.
 | Check(Element, Boolean) | Sets the a checkbox or a radio button to a specific checked state.
 | Click(Element) | Perform a click on the target element.
 | DoSelectDropDown(Element, String) | Performs the select drop down action.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetComputedStyle(Element, String) | Get the computed style for this element.
 | GetHashCode() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType() | Gets the Type of the current instance. (Inherited from Object.)
 | InvokeEvent(Element, ScriptEventType) | Invoke an event on the target element.
 | InvokeScript(String) | Invokes a javascript function. This function performs a javascript eval() on the callString and returns and values from that call (if any).
 | MemberwiseClone() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ScrollToVisible(Element) | Ensures that an item is visible in the browser. Scrolls it into view. Uses the ElementTopAtWindowTop.
 | ScrollToVisible(Element, ScrollToVisibleType) | Ensures that an item is visible in the browser. Scrolls it into view.
 | SelectDropDown(Element, Int32) | Selects a drop down item from the drop down list using its index.
 | SelectDropDown(Element, String) | Selects a drop down item from the drop down list using the item's text.
 | SelectDropDown(Element, String, Boolean) | Selects a drop down item from the drop down list using the item's text or the items option value (if useItemValue = true).
 | SetText(Element, String) | Set the text of a textbox or textarea.
 | ToString() | Returns a String that represents the current Object. (Inherited from Object.)
 | ValidateTargetElement(Element) | Validates the target element.
 | WaitCheckInterval | The Settings.WaitCheckInterval value. You can get/set it here too.
 | WaitForElement(FindParam, Int32) | Wait until an element is present in the DOM
 | WaitForElement(FindParam, Int32, Boolean) | Wait until an element is present in the DOM
 | WaitForElement(FindParam, TestRegion, Int32, Boolean) | Wait until an element within a region is present in the DOM.
 | WaitForElement(FindParam[](), Int32) | Wait until an element is present in the DOM
 | WaitForElement(FindParam[](), Int32, Boolean) | Wait until an element is present in the DOM
 | WaitForElement(FindParam[](), TestRegion, Int32, Boolean) | Wait until an element within a region is present in the DOM.
 | WaitForElements(Int32, Boolean, FindParam[]()) | Wait until all elements have been found. No chaining is used.
 | WaitForElements(Int32, FindParam[]()) | Wait until all elements have been found. No chaining is used.
 | WaitForElements(Int32, TestRegion, Boolean, FindParam[]()) | Wait until all elements have been found. No chaining is used.
Inheritance Hierarchy
Object
 | Actions
 |  | AspNetHostActions
 |  | FireFoxActions
 |  | InternetExplorerActions


AnnotateElement(targetElement, message) method

Actions.AnnotateElement(targetElement, message) method
Namespaces > ArtOfTest.WebAii.Core > Actions > AnnotateElement(Element, String)
Visually annotates an element on the browser surface.
Syntax
C#
public virtual void AnnotateElement (
    Element targetElement,
    string message
)
Parameters
targetElement (Element)
The target element to annotate.
message (String)
The message to include.


AnnotateMessage(message) method

Actions.AnnotateMessage(message) method
Namespaces > ArtOfTest.WebAii.Core > Actions > AnnotateMessage(String)
Visually annotate a message on the browser surface.
Syntax
C#
public virtual void AnnotateMessage (
    string message
)
Parameters
message (String)
The message.


Browser property

Actions.Browser property
Namespaces > ArtOfTest.WebAii.Core > Actions > Browser
Gets the Browser object associated with this instance of the actions object.
Syntax
C#
protected Browser Browser { get; }


Check(targetElement, checkedState) method

Actions.Check(targetElement, checkedState) method
Namespaces > ArtOfTest.WebAii.Core > Actions > Check(Element, Boolean)
Sets the a checkbox or a radio button to a specific checked state.
Syntax
C#
public virtual void Check (
    Element targetElement,
    bool checkedState
)
Parameters
targetElement (Element)
The target element.
checkedState (Boolean)
True: to set the target to checked, False to set it to unchecked.


Click(targetElement) method

Actions.Click(targetElement) method
Namespaces > ArtOfTest.WebAii.Core > Actions > Click(Element)
Perform a click on the target element.
Syntax
C#
public virtual void Click (
    Element targetElement
)
Parameters
targetElement (Element)
The target element.


DoSelectDropDown(targetElement, data) method

Actions.DoSelectDropDown(targetElement, data) method
Namespaces > ArtOfTest.WebAii.Core > Actions > DoSelectDropDown(Element, String)
Performs the select drop down action.
Syntax
C#
protected virtual void DoSelectDropDown (
    Element targetElement,
    string data
)
Parameters
targetElement (Element)
The target element.
data (String)
The data to pass to the browser that provides information on how to do the select.


GetComputedStyle(targetElement, style) method

Actions.GetComputedStyle(targetElement, style) method
Namespaces > ArtOfTest.WebAii.Core > Actions > GetComputedStyle(Element, String)
Get the computed style for this element.
Syntax
C#
public abstract string GetComputedStyle (
    Element targetElement,
    string style
)
Parameters
targetElement (Element)
The target element.
style (String)
The style to get.
Return Value
The string value of the style.


InvokeEvent(targetElement, eventType) method

Actions.InvokeEvent(targetElement, eventType) method
Namespaces > ArtOfTest.WebAii.Core > Actions > InvokeEvent(Element, ScriptEventType)
Invoke an event on the target element.
Syntax
C#
public virtual void InvokeEvent (
    Element targetElement,
    ScriptEventType eventType
)
Parameters
targetElement (Element)
The target element.
eventType (ScriptEventType)
Event type.


InvokeScript(script) method

Actions.InvokeScript(script) method
Namespaces > ArtOfTest.WebAii.Core > Actions > InvokeScript(String)
Invokes a javascript function. This function performs a javascript eval() on the callString and returns and values from that call (if any).
Syntax
C#
public virtual string InvokeScript (
    string script
)
Parameters
script (String)
The call/script to invoke.
Examples
string retValue = InvokeScript("myfunctioncall(""hi"",myvar);");


ScrollToVisible methods

Actions.ScrollToVisible methods
Namespaces > ArtOfTest.WebAii.Core > Actions > ScrollToVisible
Members
Icon | Member | Description
 | ScrollToVisible(Element) | Ensures that an item is visible in the browser. Scrolls it into view. Uses the ElementTopAtWindowTop.
 | ScrollToVisible(Element, ScrollToVisibleType) | Ensures that an item is visible in the browser. Scrolls it into view.


ScrollToVisible(targetElement) method

Actions.ScrollToVisible(targetElement) method
Namespaces > ArtOfTest.WebAii.Core > Actions > ScrollToVisible(Element)
Ensures that an item is visible in the browser. Scrolls it into view. Uses the ElementTopAtWindowTop.
Syntax
C#
public virtual void ScrollToVisible (
    Element targetElement
)
Parameters
targetElement (Element)
The target element.


ScrollToVisible(targetElement, scrollType) method

Actions.ScrollToVisible(targetElement, scrollType) method
Namespaces > ArtOfTest.WebAii.Core > Actions > ScrollToVisible(Element, ScrollToVisibleType)
Ensures that an item is visible in the browser. Scrolls it into view.
Syntax
C#
public virtual void ScrollToVisible (
    Element targetElement,
    ScrollToVisibleType scrollType
)
Parameters
targetElement (Element)
The target element.
scrollType (ScrollToVisibleType)
The scrolling into view type.


SelectDropDown methods

Actions.SelectDropDown methods
Namespaces > ArtOfTest.WebAii.Core > Actions > SelectDropDown
Members
Icon | Member | Description
 | SelectDropDown(Element, Int32) | Selects a drop down item from the drop down list using its index.
 | SelectDropDown(Element, String) | Selects a drop down item from the drop down list using the item's text.
 | SelectDropDown(Element, String, Boolean) | Selects a drop down item from the drop down list using the item's text or the items option value (if useItemValue = true).


SelectDropDown(targetElement, itemIndex) method

Actions.SelectDropDown(targetElement, itemIndex) method
Namespaces > ArtOfTest.WebAii.Core > Actions > SelectDropDown(Element, Int32)
Selects a drop down item from the drop down list using its index.
Syntax
C#
public virtual void SelectDropDown (
    Element targetElement,
    int itemIndex
)
Parameters
targetElement (Element)
The target element.
itemIndex (Int32)
The selected item index.


SelectDropDown(targetElement, itemText) method

Actions.SelectDropDown(targetElement, itemText) method
Namespaces > ArtOfTest.WebAii.Core > Actions > SelectDropDown(Element, String)
Selects a drop down item from the drop down list using the item's text.
Syntax
C#
public virtual void SelectDropDown (
    Element targetElement,
    string itemText
)
Parameters
targetElement (Element)
The target element.
itemText (String)
The text of the item to select.
Remarks
This function performs a case-insensitive search for the itemText in the list of the drop down items.


SelectDropDown(targetElement, text, useValue) method

Actions.SelectDropDown(targetElement, text, useValue) method
Namespaces > ArtOfTest.WebAii.Core > Actions > SelectDropDown(Element, String, Boolean)
Selects a drop down item from the drop down list using the item's text or the items option value (if useItemValue = true).
Syntax
C#
public virtual void SelectDropDown (
    Element targetElement,
    string text,
    bool useValue
)
Parameters
targetElement (Element)
The target element.
text (String)
The text of the item to select.
useValue (Boolean)
If true, the text is the value of the item not it's textual representation.
Remarks
This function performs a case-insensitive search for the itemText in the list of the drop down items.


SetText(targetElement, text) method

Actions.SetText(targetElement, text) method
Namespaces > ArtOfTest.WebAii.Core > Actions > SetText(Element, String)
Set the text of a textbox or textarea.
Syntax
C#
public virtual void SetText (
    Element targetElement,
    string text
)
Parameters
targetElement (Element)
The target element.
text (String)
The text to set


ValidateTargetElement(targetElement) method

Actions.ValidateTargetElement(targetElement) method
Namespaces > ArtOfTest.WebAii.Core > Actions > ValidateTargetElement(Element)
Validates the target element.
Syntax
C#
protected virtual void ValidateTargetElement (
    Element targetElement
)
Parameters
targetElement (Element)
The target element to validate.


WaitCheckInterval property

Actions.WaitCheckInterval property
Namespaces > ArtOfTest.WebAii.Core > Actions > WaitCheckInterval
The Settings.WaitCheckInterval value. You can get/set it here too.
Syntax
C#
public int WaitCheckInterval { get; set; }


WaitForElement methods

Actions.WaitForElement methods
Namespaces > ArtOfTest.WebAii.Core > Actions > WaitForElement
Members
Icon | Member | Description
 | WaitForElement(FindParam, TestRegion, Int32, Boolean) | Wait until an element within a region is present in the DOM.
 | WaitForElement(FindParam, Int32) | Wait until an element is present in the DOM
 | WaitForElement(FindParam, Int32, Boolean) | Wait until an element is present in the DOM
 | WaitForElement(FindParam[](), TestRegion, Int32, Boolean) | Wait until an element within a region is present in the DOM.
 | WaitForElement(FindParam[](), Int32) | Wait until an element is present in the DOM
 | WaitForElement(FindParam[](), Int32, Boolean) | Wait until an element is present in the DOM


WaitForElement(chainedParams, region, waitTimeout, invertCondition) method

Actions.WaitForElement(chainedParams, region, waitTimeout, invertCondition) method
Namespaces > ArtOfTest.WebAii.Core > Actions > WaitForElement(FindParam[](), TestRegion, Int32, Boolean)
Wait until an element within a region is present in the DOM.
Syntax
C#
public virtual void WaitForElement (
    FindParam[] chainedParams,
    TestRegion region,
    int waitTimeout,
    bool invertCondition
)
Parameters
chainedParams (FindParam []())
The chained element FindParams.
region (TestRegion)
The test region to use to identify the target element.
waitTimeout (Int32)
The timeout to wait for the element to be present.
invertCondition (Boolean)
True/False whether to invert the condition defined by the FindParam.


WaitForElement(chainedParams, waitTimeout) method

Actions.WaitForElement(chainedParams, waitTimeout) method
Namespaces > ArtOfTest.WebAii.Core > Actions > WaitForElement(FindParam[](), Int32)
Wait until an element is present in the DOM
Syntax
C#
public virtual void WaitForElement (
    FindParam[] chainedParams,
    int waitTimeout
)
Parameters
chainedParams (FindParam []())
The chained element FindParams.
waitTimeout (Int32)
The timeout to wait for the element to be present.


WaitForElement(chainedParams, waitTimeout, invertCondition) method

Actions.WaitForElement(chainedParams, waitTimeout, invertCondition) method
Namespaces > ArtOfTest.WebAii.Core > Actions > WaitForElement(FindParam[](), Int32, Boolean)
Wait until an element is present in the DOM
Syntax
C#
public virtual void WaitForElement (
    FindParam[] chainedParams,
    int waitTimeout,
    bool invertCondition
)
Parameters
chainedParams (FindParam []())
The chained element FindParams.
waitTimeout (Int32)
The timeout to wait for the element to be present.
invertCondition (Boolean)
True/False whether to invert the condition defined by the FindParam.


WaitForElement(param, region, waitTimeout, invertCondition) method

Actions.WaitForElement(param, region, waitTimeout, invertCondition) method
Namespaces > ArtOfTest.WebAii.Core > Actions > WaitForElement(FindParam, TestRegion, Int32, Boolean)
Wait until an element within a region is present in the DOM.
Syntax
C#
public virtual void WaitForElement (
    FindParam param,
    TestRegion region,
    int waitTimeout,
    bool invertCondition
)
Parameters
param (FindParam)
The FindPara of the target in reference to the region.
region (TestRegion)
The test region to use to identify the target element.
waitTimeout (Int32)
The timeout to wait for the element to be present.
invertCondition (Boolean)
True/False whether to invert the condition defined by the FindParam.


WaitForElement(param, waitTimeout) method

Actions.WaitForElement(param, waitTimeout) method
Namespaces > ArtOfTest.WebAii.Core > Actions > WaitForElement(FindParam, Int32)
Wait until an element is present in the DOM
Syntax
C#
public virtual void WaitForElement (
    FindParam param,
    int waitTimeout
)
Parameters
param (FindParam)
The FindParam that specifies how to search for the element.
waitTimeout (Int32)
The timeout to wait for the element to be present.


WaitForElement(param, waitTimeout, invertCondition) method

Actions.WaitForElement(param, waitTimeout, invertCondition) method
Namespaces > ArtOfTest.WebAii.Core > Actions > WaitForElement(FindParam, Int32, Boolean)
Wait until an element is present in the DOM
Syntax
C#
public virtual void WaitForElement (
    FindParam param,
    int waitTimeout,
    bool invertCondition
)
Parameters
param (FindParam)
The FindParam that specifies how to search for the element.
waitTimeout (Int32)
The timeout to wait for the element to be present.
invertCondition (Boolean)
True/False whether to invert the condition defined by the FindParam.


WaitForElements methods

Actions.WaitForElements methods
Namespaces > ArtOfTest.WebAii.Core > Actions > WaitForElements
Members
Icon | Member | Description
 | WaitForElements(Int32, FindParam[]()) | Wait until all elements have been found. No chaining is used.
 | WaitForElements(Int32, TestRegion, Boolean, FindParam[]()) | Wait until all elements have been found. No chaining is used.
 | WaitForElements(Int32, Boolean, FindParam[]()) | Wait until all elements have been found. No chaining is used.


WaitForElements(waitTimeout, invertCondition, paramsList) method

Actions.WaitForElements(waitTimeout, invertCondition, paramsList) method
Namespaces > ArtOfTest.WebAii.Core > Actions > WaitForElements(Int32, Boolean, FindParam[]())
Wait until all elements have been found. No chaining is used.
Syntax
C#
public virtual void WaitForElements (
    int waitTimeout,
    bool invertCondition,
    params FindParam[] paramsList
)
Parameters
waitTimeout (Int32)
The timeout to wait for all to be found in milli-seconds.
invertCondition (Boolean)
True/False whether to invert the condition defined by the FindParam.
paramsList (FindParam []())
The find parameters list of the elements to wait for.


WaitForElements(waitTimeout, paramsList) method

Actions.WaitForElements(waitTimeout, paramsList) method
Namespaces > ArtOfTest.WebAii.Core > Actions > WaitForElements(Int32, FindParam[]())
Wait until all elements have been found. No chaining is used.
Syntax
C#
public virtual void WaitForElements (
    int waitTimeout,
    params FindParam[] paramsList
)
Parameters
waitTimeout (Int32)
The timeout to wait for all to be found in milli-seconds.
paramsList (FindParam []())
The find parameters list of the elements to wait for.


WaitForElements(waitTimeout, region, invertCondition, paramsList) method

Actions.WaitForElements(waitTimeout, region, invertCondition, paramsList) method
Namespaces > ArtOfTest.WebAii.Core > Actions > WaitForElements(Int32, TestRegion, Boolean, FindParam[]())
Wait until all elements have been found. No chaining is used.
Syntax
C#
public virtual void WaitForElements (
    int waitTimeout,
    TestRegion region,
    bool invertCondition,
    params FindParam[] paramsList
)
Parameters
waitTimeout (Int32)
The timeout to wait for all to be found in milli-seconds.
region (TestRegion)
Test region to use a reference.
invertCondition (Boolean)
True/False whether to invert the condition defined by the FindParam.
paramsList (FindParam []())
The find parameters list of the elements to wait for.


AnnotationMode enumeration

AnnotationMode enumeration
Namespaces > ArtOfTest.WebAii.Core > AnnotationMode
The different annotation modes
Syntax
C#
public enum AnnotationMode
Members
Member | Description
All | All annotations (native and custom) will be displayed when annotation is enabled
NativeOnly | Only the native annotations will be displayed when annotation is enabled
CustomOnly | Only the custom annotations will be displayed when annotation is enabled


Browser class

Browser class
Namespaces > ArtOfTest.WebAii.Core > Browser
Class represents a browser instance managed by the Manager. This object exposes all the browser specific information and methods to automate the underlying browser that this instance represents.
Syntax
C#
public class Browser
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Actions | Gets the Actions object that can be used to perform different actions against the loaded document in the browser.
 | AfterCommandExecuted | Event occurs after the command is executed and the response is available.
 | Annotator | Gets the Annotator object associated with this browser.
 | AutoDomRefresh | Gets/Sets whether to automatically refresh the DOM tree after each browser command.
 | AutoWaitUntilReady | Gets/Sets whether to automatically wait until browser is ready after each browser command.
 | BeforeCommandExecuted | Event occurs before a command is pushed to the browser.
 | BrowserType | Gets the browser type (i.e. IE/FireFox ...etc)
 | ClientId | The unique ID for this browser that the manager identifies it with.
 | Close() | Closes a browser window.
 | Close(Int32) | Closes a browser window with a custom wait to close timeout.
 | CommandTimeOut | Gets/Sets the max wait time in milliseconds that the browser will wait for a command to process before it times out.
 | ContainsPoint(Point) | True/False whether a specific point falls within this browser/frame rendering region
 | ContainsRectangle(Rectangle) | True/False whether a specific rectangle falls within this browser/frame rendering region
 | ContainsText(String) | True/False whether the 'text' is contained within the page currently loaded. Not case sensitive.
 | ContentWindow | Gets the container window of the browser that contains the actual content of the page. (Excludes the browser toolbars, buttons ...etc.)
 | Cookies | Gets the cookies manager associated with this browser that allows you to retrieve, delete and add cookies.
 | DomHashCode | Gets the current DOM hash code
 | DomRefreshed | Event occurs after the DomTree is rebuilt (either after a command is executed or when RefreshDom is called)
 | DomTree | Gets the DOM Tree representation of the currently loaded document.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | ExecuteCommand(BrowserCommand) | Executes a command against this browser instance.
 | ExecuteCommand(BrowserCommand, Boolean, Boolean) | Executes a command against this browser instance.
 | Finalize() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Find | Gets the Find objects used to provide a rich set of methods to help identify elements in the Dom tree associated with this browser object.
 | FrameInfo | Gets the frame information if IsFrame = true else will return null. FrameInfo contains frame index and frame name.
 | Frames | List of child frames contained in this instance
 | GetHashCode() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetSelectedText() | Gets the text currently selected by the user in the browser window
 | GetType() | Gets the Type of the current instance. (Inherited from Object.)
 | GoBack() | Simulates a go back browser action.
 | GoForward() | Simulates a go forward browser action.
 | IsConnected | Gets whether the browser is connected to manager of not.
 | IsFrame | Gets whether this instance represents a frame or not.
 | IsIEDialog | Gets whether this instance is an IE dialog (Modal/Modeless)
 | IsReady() | Gets whether the browser is ready or not.
 | IsUILess | Whether this browser is UI less browser. (i.e. a raw http request/response browser)
 | Manager | The manager of this browser object.
 | MemberwiseClone() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NativeInstance | The native instance of this browser object (if available), otherwise null
 | NavigateTo(String) | Navigate the browser to a specific url and then enable the script logging.
 | NavigateTo(Uri) | Navigate the browser to a specific url.
 | PageTitle | Gets the page title if one exists. (text content of the 'title' tags)
 | PrepareFrameForClosing() | Used to disable the AutoRefreshDom and WaitUntilReady of a frame preparing it to be closed on next action and no longer polled by the framework.
 | QueryString | Gets a parsed name/value collection of the query string.
 | Refresh() | Simulates a browser Refresh.
 | RefreshDomTree() | Force a referesh of the DOM tree from the current document.
 | Regions | Gets a dictionary of all identified test regions in the currently loaded document.
 | ScrollBy(Int32, Int32) | Scroll this window by offset x horizontally and y vertically.
 | Stop() | Simulate a stop navigation browser action.
 | ToString() | Returns a String that represents the current Object. (Inherited from Object.)
 | UpdateDomTree(String) | Parse and update the DomTree
 | Url | Gets the current page URL. This property is refreshed when calling RefreshDOMTree().
 | Version | The browser version for this browser type.
 | ViewSourceString | Gets the source of the page currently loaded in the browser. This is the string that the framework used to build the DOM.
 | WaitForUrl(String, Boolean, Int32) | Wait for a specific url to be set. This can be used to wait for browser redirects on certain sites.
 | WaitUntilReady() | Waits for the browser until its ready
 | Window | Gets the Win32 window object representing the actual browser window.
Inheritance Hierarchy
Object
 | Browser
 |  | AspNetHostBrowser


Actions property

Browser.Actions property
Namespaces > ArtOfTest.WebAii.Core > Browser > Actions
Gets the Actions object that can be used to perform different actions against the loaded document in the browser.
Syntax
C#
public Actions Actions { get; }


AfterCommandExecuted event

Browser.AfterCommandExecuted event
Namespaces > ArtOfTest.WebAii.Core > Browser > AfterCommandExecuted
Event occurs after the command is executed and the response is available.
Syntax
C#
public event EventHandler<BrowserCommandEventArgs> AfterCommandExecuted


Annotator property

Browser.Annotator property
Namespaces > ArtOfTest.WebAii.Core > Browser > Annotator
Gets the Annotator object associated with this browser.
Syntax
C#
public Annotator Annotator { get; }


AutoDomRefresh property

Browser.AutoDomRefresh property
Namespaces > ArtOfTest.WebAii.Core > Browser > AutoDomRefresh
Gets/Sets whether to automatically refresh the DOM tree after each browser command.
Syntax
C#
public bool AutoDomRefresh { get; set; }


AutoWaitUntilReady property

Browser.AutoWaitUntilReady property
Namespaces > ArtOfTest.WebAii.Core > Browser > AutoWaitUntilReady
Gets/Sets whether to automatically wait until browser is ready after each browser command.
Syntax
C#
public bool AutoWaitUntilReady { get; set; }


BeforeCommandExecuted event

Browser.BeforeCommandExecuted event
Namespaces > ArtOfTest.WebAii.Core > Browser > BeforeCommandExecuted
Event occurs before a command is pushed to the browser.
Syntax
C#
public event EventHandler<BrowserCommandEventArgs> BeforeCommandExecuted


BrowserType property

Browser.BrowserType property
Namespaces > ArtOfTest.WebAii.Core > Browser > BrowserType
Gets the browser type (i.e. IE/FireFox ...etc)
Syntax
C#
public BrowserType BrowserType { get; }


ClientId property

Browser.ClientId property
Namespaces > ArtOfTest.WebAii.Core > Browser > ClientId
The unique ID for this browser that the manager identifies it with.
Syntax
C#
public string ClientId { get; }


Close methods

Browser.Close methods
Namespaces > ArtOfTest.WebAii.Core > Browser > Close
Members
Icon | Member | Description
 | Close() | Closes a browser window.
 | Close(Int32) | Closes a browser window with a custom wait to close timeout.


Close() method

Browser.Close() method
Namespaces > ArtOfTest.WebAii.Core > Browser > Close()
Closes a browser window.
Syntax
C#
public virtual void Close ()
Remarks
This function will disconnect the browser from the manager first and then close its window. It will also perform a wait until the browser window is no longer visible. The time out for the wait is the same as the ExecuteCommandTimeout.


Close(waitToCloseTimeout) method

Browser.Close(waitToCloseTimeout) method
Namespaces > ArtOfTest.WebAii.Core > Browser > Close(Int32)
Closes a browser window with a custom wait to close timeout.
Syntax
C#
public virtual void Close (
    int waitToCloseTimeout
)
Parameters
waitToCloseTimeout (Int32)
The timeout in milliseconds to wait for the browser to close.
Remarks
This function will disconnect the browser from the manager first and then close its window. It will also perform a wait until the browser window is no longer visible. The time out for the wait is the same as the ExecuteCommandTimeout.


CommandTimeOut property

Browser.CommandTimeOut property
Namespaces > ArtOfTest.WebAii.Core > Browser > CommandTimeOut
Gets/Sets the max wait time in milliseconds that the browser will wait for a command to process before it times out.
Syntax
C#
public int CommandTimeOut { get; set; }


ContainsPoint(point) method

Browser.ContainsPoint(point) method
Namespaces > ArtOfTest.WebAii.Core > Browser > ContainsPoint(Point)
True/False whether a specific point falls within this browser/frame rendering region
Syntax
C#
public virtual bool ContainsPoint (
    Point point
)
Parameters
point (Point)
The point to check.
Return Value
True/False whether the point is within the browser window.


ContainsRectangle(rectangle) method

Browser.ContainsRectangle(rectangle) method
Namespaces > ArtOfTest.WebAii.Core > Browser > ContainsRectangle(Rectangle)
True/False whether a specific rectangle falls within this browser/frame rendering region
Syntax
C#
public virtual bool ContainsRectangle (
    Rectangle rectangle
)
Parameters
rectangle (Rectangle)
The rectangle to check.
Return Value
True/False whether the rectangle is within the browser window.


ContainsText(text) method

Browser.ContainsText(text) method
Namespaces > ArtOfTest.WebAii.Core > Browser > ContainsText(String)
True/False whether the 'text' is contained within the page currently loaded. Not case sensitive.
Syntax
C#
public virtual bool ContainsText (
    string text
)
Parameters
text (String)
The text string.
Return Value
True/False whether the text is contained.


ContentWindow property

Browser.ContentWindow property
Namespaces > ArtOfTest.WebAii.Core > Browser > ContentWindow
Gets the container window of the browser that contains the actual content of the page. (Excludes the browser toolbars, buttons ...etc.)
Syntax
C#
public virtual Window ContentWindow { get; }


Cookies property

Browser.Cookies property
Namespaces > ArtOfTest.WebAii.Core > Browser > Cookies
Gets the cookies manager associated with this browser that allows you to retrieve, delete and add cookies.
Syntax
C#
public CookiesManager Cookies { get; }


DomHashCode property

Browser.DomHashCode property
Namespaces > ArtOfTest.WebAii.Core > Browser > DomHashCode
Gets the current DOM hash code
Syntax
C#
public int DomHashCode { get; }


DomRefreshed event

Browser.DomRefreshed event
Namespaces > ArtOfTest.WebAii.Core > Browser > DomRefreshed
Event occurs after the DomTree is rebuilt (either after a command is executed or when RefreshDom is called)
Syntax
C#
public event EventHandler DomRefreshed


DomTree property

Browser.DomTree property
Namespaces > ArtOfTest.WebAii.Core > Browser > DomTree
Gets the DOM Tree representation of the currently loaded document.
Syntax
C#
public TreeBuilder DomTree { get; }


ExecuteCommand methods

Browser.ExecuteCommand methods
Namespaces > ArtOfTest.WebAii.Core > Browser > ExecuteCommand
Members
Icon | Member | Description
 | ExecuteCommand(BrowserCommand) | Executes a command against this browser instance.
 | ExecuteCommand(BrowserCommand, Boolean, Boolean) | Executes a command against this browser instance.


ExecuteCommand(request) method

Browser.ExecuteCommand(request) method
Namespaces > ArtOfTest.WebAii.Core > Browser > ExecuteCommand(BrowserCommand)
Executes a command against this browser instance.
Syntax
C#
public virtual BrowserCommand ExecuteCommand (
    BrowserCommand request
)
Parameters
request (BrowserCommand)
Remarks
If the request requires a specific response data, then the callers of this function should check the BrowserCommand.Response property for any responses from the browser. This method uses the browser's AutoDOMRefresh and AutoWaitUntilReady values to configure whether the browser should refresh the DOM or wait until the browser is ready after the command is executed.


ExecuteCommand(request, performDomRefresh, waitUntilReady) method

Browser.ExecuteCommand(request, performDomRefresh, waitUntilReady) method
Namespaces > ArtOfTest.WebAii.Core > Browser > ExecuteCommand(BrowserCommand, Boolean, Boolean)
Executes a command against this browser instance.
Syntax
C#
public virtual BrowserCommand ExecuteCommand (
    BrowserCommand request,
    bool performDomRefresh,
    bool waitUntilReady
)
Parameters
request (BrowserCommand)
The command request to perform.
performDomRefresh (Boolean)
True/False whether to reference the DOM after the command.
waitUntilReady (Boolean)
True/False whether to wait for the browser to be ready after the command.
Return Value
A response to the request.
Remarks
If the request requires a specific response data, then the callers of this function should check the BrowserCommand.Response property for any responses from the browser.


Find property

Browser.Find property
Namespaces > ArtOfTest.WebAii.Core > Browser > Find
Gets the Find objects used to provide a rich set of methods to help identify elements in the Dom tree associated with this browser object.
Syntax
C#
public Find Find { get; }


FrameInfo property

Browser.FrameInfo property
Namespaces > ArtOfTest.WebAii.Core > Browser > FrameInfo
Gets the frame information if IsFrame = true else will return null. FrameInfo contains frame index and frame name.
Syntax
C#
public FrameInfo FrameInfo { get; }


Frames property

Browser.Frames property
Namespaces > ArtOfTest.WebAii.Core > Browser > Frames
List of child frames contained in this instance
Syntax
C#
public virtual FramesCollection Frames { get; }


GetSelectedText() method

Browser.GetSelectedText() method
Namespaces > ArtOfTest.WebAii.Core > Browser > GetSelectedText()
Gets the text currently selected by the user in the browser window
Syntax
C#
public virtual string GetSelectedText ()
Return Value
The selected text


GoBack() method

Browser.GoBack() method
Namespaces > ArtOfTest.WebAii.Core > Browser > GoBack()
Simulates a go back browser action.
Syntax
C#
public virtual void GoBack ()


GoForward() method

Browser.GoForward() method
Namespaces > ArtOfTest.WebAii.Core > Browser > GoForward()
Simulates a go forward browser action.
Syntax
C#
public virtual void GoForward ()


IsConnected property

Browser.IsConnected property
Namespaces > ArtOfTest.WebAii.Core > Browser > IsConnected
Gets whether the browser is connected to manager of not.
Syntax
C#
public virtual bool IsConnected { get; }
Remarks
This property performs a two way communication check between the manager and the actual browser.


IsFrame property

Browser.IsFrame property
Namespaces > ArtOfTest.WebAii.Core > Browser > IsFrame
Gets whether this instance represents a frame or not.
Syntax
C#
public bool IsFrame { get; }


IsIEDialog property

Browser.IsIEDialog property
Namespaces > ArtOfTest.WebAii.Core > Browser > IsIEDialog
Gets whether this instance is an IE dialog (Modal/Modeless)
Syntax
C#
public bool IsIEDialog { get; }


IsReady() method

Browser.IsReady() method
Namespaces > ArtOfTest.WebAii.Core > Browser > IsReady()
Gets whether the browser is ready or not.
Syntax
C#
public virtual bool IsReady ()


IsUILess property

Browser.IsUILess property
Namespaces > ArtOfTest.WebAii.Core > Browser > IsUILess
Whether this browser is UI less browser. (i.e. a raw http request/response browser)
Syntax
C#
public bool IsUILess { get; }


Manager property

Browser.Manager property
Namespaces > ArtOfTest.WebAii.Core > Browser > Manager
The manager of this browser object.
Syntax
C#
public Manager Manager { get; }


NativeInstance property

Browser.NativeInstance property
Namespaces > ArtOfTest.WebAii.Core > Browser > NativeInstance
The native instance of this browser object (if available), otherwise null
Syntax
C#
public virtual Object NativeInstance { get; }


NavigateTo methods

Browser.NavigateTo methods
Namespaces > ArtOfTest.WebAii.Core > Browser > NavigateTo
Members
Icon | Member | Description
 | NavigateTo(String) | Navigate the browser to a specific url and then enable the script logging.
 | NavigateTo(Uri) | Navigate the browser to a specific url.


NavigateTo(uri) method

Browser.NavigateTo(uri) method
Namespaces > ArtOfTest.WebAii.Core > Browser > NavigateTo(Uri)
Navigate the browser to a specific url.
Syntax
C#
public virtual void NavigateTo (
    Uri uri
)
Parameters
uri (Uri)
The uri object that describes the Url.


NavigateTo(url) method

Browser.NavigateTo(url) method
Namespaces > ArtOfTest.WebAii.Core > Browser > NavigateTo(String)
Navigate the browser to a specific url and then enable the script logging.
Syntax
C#
public virtual void NavigateTo (
    string url
)
Parameters
url (String)
The url to navigate to.


PageTitle property

Browser.PageTitle property
Namespaces > ArtOfTest.WebAii.Core > Browser > PageTitle
Gets the page title if one exists. (text content of the 'title' tags)
Syntax
C#
public string PageTitle { get; }


PrepareFrameForClosing() method

Browser.PrepareFrameForClosing() method
Namespaces > ArtOfTest.WebAii.Core > Browser > PrepareFrameForClosing()
Used to disable the AutoRefreshDom and WaitUntilReady of a frame preparing it to be closed on next action and no longer polled by the framework.
Syntax
C#
public virtual void PrepareFrameForClosing ()


QueryString property

Browser.QueryString property
Namespaces > ArtOfTest.WebAii.Core > Browser > QueryString
Gets a parsed name/value collection of the query string.
Syntax
C#
public NameValueCollection QueryString { get; }


Refresh() method

Browser.Refresh() method
Namespaces > ArtOfTest.WebAii.Core > Browser > Refresh()
Simulates a browser Refresh.
Syntax
C#
public virtual void Refresh ()


RefreshDomTree() method

Browser.RefreshDomTree() method
Namespaces > ArtOfTest.WebAii.Core > Browser > RefreshDomTree()
Force a referesh of the DOM tree from the current document.
Syntax
C#
public virtual bool RefreshDomTree ()


Regions property

Browser.Regions property
Namespaces > ArtOfTest.WebAii.Core > Browser > Regions
Gets a dictionary of all identified test regions in the currently loaded document.
Syntax
C#
public TestRegionCollection Regions { get; }


ScrollBy(x, y) method

Browser.ScrollBy(x, y) method
Namespaces > ArtOfTest.WebAii.Core > Browser > ScrollBy(Int32, Int32)
Scroll this window by offset x horizontally and y vertically.
Syntax
C#
public virtual void ScrollBy (
    int x,
    int y
)
Parameters
x (Int32)
The x offset.(negative for scroll left)
y (Int32)
The y offset.(negative for scroll up)


Stop() method

Browser.Stop() method
Namespaces > ArtOfTest.WebAii.Core > Browser > Stop()
Simulate a stop navigation browser action.
Syntax
C#
public virtual void Stop ()


UpdateDomTree(domString) method

Browser.UpdateDomTree(domString) method
Namespaces > ArtOfTest.WebAii.Core > Browser > UpdateDomTree(String)
Parse and update the DomTree
Syntax
C#
protected virtual bool UpdateDomTree (
    string domString
)
Parameters
domString (String)


Url property

Browser.Url property
Namespaces > ArtOfTest.WebAii.Core > Browser > Url
Gets the current page URL. This property is refreshed when calling RefreshDOMTree().
Syntax
C#
public virtual string Url { get; }


Version property

Browser.Version property
Namespaces > ArtOfTest.WebAii.Core > Browser > Version
The browser version for this browser type.
Syntax
C#
public string Version { get; }


ViewSourceString property

Browser.ViewSourceString property
Namespaces > ArtOfTest.WebAii.Core > Browser > ViewSourceString
Gets the source of the page currently loaded in the browser. This is the string that the framework used to build the DOM.
Syntax
C#
public string ViewSourceString { get; }


WaitForUrl(url, isPartial, timeout) method

Browser.WaitForUrl(url, isPartial, timeout) method
Namespaces > ArtOfTest.WebAii.Core > Browser > WaitForUrl(String, Boolean, Int32)
Wait for a specific url to be set. This can be used to wait for browser redirects on certain sites.
Syntax
C#
public virtual void WaitForUrl (
    string url,
    bool isPartial,
    int timeout
)
Parameters
url (String)
The url to wait for.
isPartial (Boolean)
True/False whether to use partial comparison.
timeout (Int32)
The timeout in milli-seconds to use.


WaitUntilReady() method

Browser.WaitUntilReady() method
Namespaces > ArtOfTest.WebAii.Core > Browser > WaitUntilReady()
Waits for the browser until its ready
Syntax
C#
public virtual void WaitUntilReady ()
Remarks
This method uses the Manager.Settings.ClientReadyTimeout as the timeout.


Window property

Browser.Window property
Namespaces > ArtOfTest.WebAii.Core > Browser > Window
Gets the Win32 window object representing the actual browser window.
Syntax
C#
public virtual Window Window { get; }


BrowserCacheType enumeration

BrowserCacheType enumeration
Namespaces > ArtOfTest.WebAii.Core > BrowserCacheType
The different common categories of browser caching.
Syntax
C#
public enum BrowserCacheType
Members
Member | Description
Cookies | Cookies
TempFilesCache | Temporary internet files cached locally.
History | Browsing history for user profile.


BrowserType enumeration

BrowserType enumeration
Namespaces > ArtOfTest.WebAii.Core > BrowserType
The browser type. (i.e. firefox, internet explorer ...etc).
Syntax
C#
public enum BrowserType
Members
Member | Description
NotSet | Browser type is not set.
InternetExplorer | Internet explorer browser type.
FireFox | FireFox browser type.
AspNetHost | ASP.NET InProc Host that acts as a browser and request processor.
Designer | Internally used for the UI Designer


Desktop class

Desktop class
Namespaces > ArtOfTest.WebAii.Core > Desktop
Class representing the desktop input devices. Mouse and Keyboard.
Syntax
C#
public class Desktop
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DesktopNew() | Create a new desktop object
 | DisableAutoDomRefresh() | Disables auto dom refresh for Mouse/Keyboard actions
 | EnableAutoDomRefresh(Browser) | Enables the Desktop Mouse/Keyboard objects to perform auto dom refreshes after Click/DragDrop/SendKey actions.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType() | Gets the Type of the current instance. (Inherited from Object.)
 | KeyBoard | Gets the keyboard object that enables simulating real keyboard events.
 | MemberwiseClone() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Mouse | Gets the mouse object that enables simulating real mouse events.
 | ToString() | Returns a String that represents the current Object. (Inherited from Object.)
 | ValidateMouseActionsWithinBrowserContent | Gets/Sets whether to validate all mouse actions to ensure they are within the browser's content window. If this is set to true, any mouse action outside that region will throw an exception.
Inheritance Hierarchy
Object
Desktop


Desktop() constructor

Desktop() constructor
Namespaces > ArtOfTest.WebAii.Core > Desktop > DesktopNew()
Create a new desktop object
Syntax
C#
public Desktop ()


DisableAutoDomRefresh() method

Desktop.DisableAutoDomRefresh() method
Namespaces > ArtOfTest.WebAii.Core > Desktop > DisableAutoDomRefresh()
Disables auto dom refresh for Mouse/Keyboard actions
Syntax
C#
public void DisableAutoDomRefresh ()


EnableAutoDomRefresh(targetBrowser) method

Desktop.EnableAutoDomRefresh(targetBrowser) method
Namespaces > ArtOfTest.WebAii.Core > Desktop > EnableAutoDomRefresh(Browser)
Enables the Desktop Mouse/Keyboard objects to perform auto dom refreshes after Click/DragDrop/SendKey actions.
Syntax
C#
public void EnableAutoDomRefresh (
    Browser targetBrowser
)
Parameters
targetBrowser (Browser)
The target browser to perform refresh on.


KeyBoard property

Desktop.KeyBoard property
Namespaces > ArtOfTest.WebAii.Core > Desktop > KeyBoard
Gets the keyboard object that enables simulating real keyboard events.
Syntax
C#
public KeyBoard KeyBoard { get; }


Mouse property

Desktop.Mouse property
Namespaces > ArtOfTest.WebAii.Core > Desktop > Mouse
Gets the mouse object that enables simulating real mouse events.
Syntax
C#
public Mouse Mouse { get; }


ValidateMouseActionsWithinBrowserContent property

Desktop.ValidateMouseActionsWithinBrowserContent property
Namespaces > ArtOfTest.WebAii.Core > Desktop > ValidateMouseActionsWithinBrowserContent
Gets/Sets whether to validate all mouse actions to ensure they are within the browser's content window. If this is set to true, any mouse action outside that region will throw an exception.
Syntax
C#
public bool ValidateMouseActionsWithinBrowserContent { get; set; }


ElementFinder class

ElementFinder class
Namespaces > ArtOfTest.WebAii.Core > ElementFinder
Provides infrastructure for accessing elements defined by FindParamAttribute on test methods and classes. Replaces the Find.Elements dictionary which has been obsoleted.
Syntax
C#
[DefaultMemberAttribute("Item")]
public class ElementFinder
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType() | Gets the Type of the current instance. (Inherited from Object.)
 | Item(String) | Get an element object defined by a FindParam attribute on the test method or test class.
 | MemberwiseClone() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ReturnElementProxyWhenNotFound | Gets or sets a flag that indicates to the ElementFinder to return an ElementProxy object when the element is not found instead of null or an exception. The Element proxy object is an Element object that is only initialized with the FindParam object it needs to use. You can then call Element.Wait.ForExists() on it to wait for it to be found. You can check whether an Element is a proxy element by checking the Element.IsProxy
 | ToString() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
ElementFinder


Item[elementKey] property

ElementFinder.Item[elementKey] property
Namespaces > ArtOfTest.WebAii.Core > ElementFinder > Item(String)
Get an element object defined by a FindParam attribute on the test method or test class.
Syntax
C#
public Element this [
    string elementKey
] { get; }
Parameters
elementKey (String)
The element key as defined by the FindParam attribute
Return Value
The Element object or null.


ReturnElementProxyWhenNotFound property

ElementFinder.ReturnElementProxyWhenNotFound property
Namespaces > ArtOfTest.WebAii.Core > ElementFinder > ReturnElementProxyWhenNotFound
Gets or sets a flag that indicates to the ElementFinder to return an ElementProxy object when the element is not found instead of null or an exception. The Element proxy object is an Element object that is only initialized with the FindParam object it needs to use. You can then call Element.Wait.ForExists() on it to wait for it to be found. You can check whether an Element is a proxy element by checking the Element.IsProxy
Syntax
C#
public bool ReturnElementProxyWhenNotFound { get; set; }


ElementSyncMethod enumeration

ElementSyncMethod enumeration
Namespaces > ArtOfTest.WebAii.Core > ElementSyncMethod
The different type of element-dom synchronization supported by the framework and the SyncManager.
Syntax
C#
public enum ElementSyncMethod
Members
Member | Description
OnRefresh | The element will synchronize with the latest Dom only when the element.Refresh(true) is explicitly called.
OnNextCommand | Will synchronize when the next command is executed.
Always | This element will always ensure it is in-sync with the latest Dom any time any action is performed on it or information is retrieved from it.


Find class

Find class
Namespaces > ArtOfTest.WebAii.Core > Find
Class provides quick search routines for finding an element(s) within a document.
Syntax
C#
public class Find
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon Member Description
All() Obsolete.
Find all elements set using FindParamAttributes on method/class.
All(Boolean) Obsolete.
Find all elements set using FindParamAttributes.
AllByAttributes<(Of TControl>)(String[]())
Returns a list of elements that have attributes that match the NameValuePairs passed it fully or partially.
AllByAttributes(String[]())
Returns a list of elements that have attributes that match the NameValuePairs passed it fully or partially.
AllByContent<(Of TControl>)(String)
AllByContent(String)
AllByContent<(Of TControl>)(String, FindContentType)
AllByContent(String, FindContentType)
AllByContent(String)
Returns a list of elements that have TextContent that match the specified content The content must start with: 'l:' for exact match strings, 'p:' for partial strings or 'x:' for regular expression matches. If none are provided, the string will be matched using an exact match 'l:'. All searches are case-insensitive.
Examples
To find tags with TextContent of: 'foo bar' Example 1: ByContent("l:foo bar"); Example 2: ByContent("p:foo"); Example 3: ByContent("x:[*foo*]");
The TextContent to match
Remarks
There is a difference between FindContentType.InnerText and FindContentType.TextContent that is worth noting: Example:
Text1
Text2
InnerText for div1 : Text1Text2 {recursive} TextContent of div1 : Text1 {non-recursive} Default for ByContent is TextContent which is the most common usage.
AllByContent(String, FindContentType)
Returns a list of elements that match the specified content. The content must start with: 'l:' for exact match strings, 'p:' for partial strings or 'x:' for regular expression matches. If none are provided, the string will be matched using an exact match 'l:'. All searches are case-insensitive.
Examples
To find tags with TextContent of: 'foo bar' Example 1: ByContent("l:foo bar"); Example 2: ByContent("p:foo"); Example 3: ByContent("x:[*foo*]");
Remarks
There is a difference between FindContentType.InnerText and FindContentType.TextContent that is worth noting: Example:
Text1
Text2
InnerText for div1 : Text1Text2 {recursive} TextContent of div1 : Text1 {non-recursive} Default for ByContent is TextContent which is the most common usage.
AllByCustom<(Of TControl>)(Predicate<(Of TControl>))
Returns all controls that match the predicate and are convertable to TControl.
AllByCustom(Predicate<(Of Element>))
Return all elements that match the predicate
AllByParam<(Of TControl>)(FindParam)
Returns a list of elements that match the specified FindParam. Note that this method does not support FindParam.Type=NodePathIndex.
AllByParam(FindParam)
Returns a list of elements that match the specified FindParam. Note that this method does not support FindParam.Type=NodePathIndex.
AllByTagName<(Of TControl>)(String)
Returns a list of elements with a specific tag name as a control collection.
AllByTagName(String)
Returns a list of elements with a specific tag name.
AllByXPath<(Of TControl>)(String)
Returns a list of elements that match the specified XPath. This function supports the System.Xml XPath syntax.
AllByXPath(String)
Returns a list of elements that match the specified XPath. This function supports the System.Xml XPath syntax.
AllControls<(Of TControl>)()
Gets an IEnmerable for TControl to be used for LINQ queries. This will return only elements that are convertable to TControl
AllElements()
Gets a IEnumerable for all elements to be used for LINQ queries
AssociatedBrowser
Gets the browser object that is associated with this find object. If this property is null, then the Find object is associated with a search region.
BuildBestFitFindParam(Element)
Generates a FindParam[] list to be used to find the specified element. The function uses an algorithm optimized for most reliable search methods and will revert back to using the tagname index as a last resort
ByAttributes<(Of TControl>)(String[]())
Same as ByAttributes(). Returns a control type instead of element.
ByAttributes(String[]())
Returns a an element that has attributes that match the NameValuePairs passed it. All matching is case-insensitive.
ByContent<(Of TControl>)(String)
Same as ByContent(). Returns a control type instead of element.
ByContent<(Of TControl>)(String, FindContentType)
Same as ByContent(). Returns a control type instead of element.
ByContent<(Of TControl>)(String, FindContentType, String[]())
Same as ByContent(). Returns a control type instead of element.
ByContent(String)
Returns an element by searching its TextContent. The content must start with: 'l:' for exact match strings, 'p:' for partial strings or 'x:' for regular expression matches. If none are provided, the string will be matched using an exact match 'l:'. All searches are case-insensitive.
Examples
To find tags with innerText content is: 'foo bar' Example 1: ByContent("l:foo bar"); Example 2: ByContent("p:foo"); Example 3: ByContent("x:[*foo*]");
ByContent(String, FindContentType)
Returns an element by searching its content with the options to pick the content type. (InnerText, InnerMarkup or OuterMarkup) The content must start with: 'l:' for exact match strings, 'p:' for partial strings or 'x:' for regular expression matches. If none are provided, the string will be matched using an exact match 'l:'. All searches are case-insensitive.
Examples
Similar to Find.ByContent(string) with the option to specify the content type: Example 1: ByContent("l:foo bar",FindContentType.InnerText); Example 2: ByContent("p:<foo id="f" />",FindContent.OuterMarkup);
Remarks
There is a difference between FindContentType.InnerText and FindContentType.TextContent that is worth noting: Example:
Text1
Text2
InnerText for div1 : Text1Text2 {recursive} TextContent of div1 : Text1 {non-recursive} Default for ByContent is TextContent which is the most common usage.
ByContent(String, FindContentType, String[]())
Returns an element by searching its content with the options to pick the content type. (InnerText, InnerMarkup or OuterMarkup) in addition to a list of attributes. The content must start with: 'l:' for exact match strings, 'p:' for partial strings or 'x:' for regular expression matches. If none are provided, the string will be matched using an exact match 'l:'. All searches are case-insensitive.
Examples
Similar to Find.ByContent(string) with the option to specify the content type: Example 1: ByContent("l:foo bar",FindContentType.InnerText); Example 2: ByContent("p:<foo id="f" />",FindContent.OuterMarkup);
Remarks
There is a difference between FindContentType.InnerText and FindContentType.TextContent that is worth noting: Example:
Text1
Text2
InnerText for div1 : Text1Text2 {recursive} TextContent of div1 : Text1 {non-recursive} Default for ByContent is TextContent which is the most common usage.
ByCustom<(Of TControl>)(Predicate<(Of TControl>))
Get a control by using custom predicate. This function will try to eliminate any elements that are not convertable to TControl type.
ByCustom(Predicate<(Of Element>))
Return the element that matches the defined predicate
ById<(Of TControl>)(String)
Same as ById(). Returns a control type instead of element.
ById(String)
Returns an element by looking for its 'id' attribute value.
ByName<(Of TControl>)(String)
Same as ByName(). Returns a control type instead of element.
ByName(String)
Returns an element by searching for its 'name' attribute value
ByNodeIndexPath<(Of TControl>)(String)
Same as ByNodexIndexPath(). Returns a control type instead of element.
ByNodeIndexPath(String)
Returns an element by searching for it using a node index path.
Examples
  For example:

  This call: ByNodeIndexPath("0/2/0/1") describes the <target></target> element in the below hierarchy:

  <referenceElement>
   (0)<foo>
          <bar>
          </bar>
          <car>
          </car>
       (2)<bus>
           (0)<driver>
                  <cap>
                  </cap>
               (1)<target>
                  </target>
              </driver>
          </bus>
      </foo>
  </referenceElement>

ByParam<(Of TControl>)(FindParam)
Same as ByParam(). Returns a control type instead of element.
ByParam<(Of TControl>)(FindParam[]())
Same as ByParam(). Returns a control type instead of element.
ByParam(FindParam)
Return an element using a FindParam
ByParam(FindParam[]())
Returns an element using a chained identification.
ByTagIndex<(Of TControl>)(String, Int32)
Same as ByTagIndex(). Returns a control type instead of element.
ByTagIndex(String, Int32)
Returns an element by its tag name occrrence.
ByXPath<(Of TControl>)(String)
Same as ByXPath(). Returns a control type instead of element.
ByXPath(String)
Returns an element using an XPath. This function supports the System.Xml XPath syntax.
Elements Obsolete.
Found elements from FindParam attributes set on the class or method. If the Find.All() method has not been called, then accessing this dictionary will call Find.All() before returning the dictionary items.
Equals(Object)
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Finalize()
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
FindReferenceType
Gets the reference type that this Find object is using. (i.e. browser root, testregion ... etc)
FromCollection(FindParamCollection)
Finds all elements with the FindParams in the passed in collection.
FromFile(String)
Finds all elements with FindParams defined in a file. Found elements can be accessed from Find.Elements
FromXml(String)
Finds all elements with FindParams defined in the serialized xml string. Found elements can be accessed from Find.Elements
GetHashCode()
Serves as a hash function for a particular type.
(Inherited from Object.)
GetType()
Gets the Type of the current instance.
(Inherited from Object.)
IgnoreFindAllControlMismatch
Gets/Sets whether to ignore Find.Allxx<TControl>(...) elements that don't match the TControl specified. (i.e. the TControl type validation fails for that element). If false, the Find.Allxx method will throw an exception.
LastSearchLog
Gets the search log for the last find attempt. This log can help diagnose when find fails to locate an element.
MemberwiseClone()
Creates a shallow copy of the current Object.
(Inherited from Object.)
ReturnedNullOrEmpty
Invoked when one of the find methods returns null or an empty list of elements.
SearchRegion
Gets the search region for this Find object. When this is set to a specific region, all search is done locale to that region. All indexes are calculated starting at zero from this region's element. If this property is null, then the Find object will perform all searches from the document root element.
SearchRootElement
Gets/Sets the root element that all searches will be performed under. This element depended on the reference type. [Browser/TestRegion/Element].
ThrowIfNullOrEmpty
Gets/Sets whether to throw an exception if any of the find methods returns a null element or any of the find all methods return empty list of elements.
ToString()
Returns a String that represents the current Object.
(Inherited from Object.)
Inheritance Hierarchy
Object
 | Find
 |  | HtmlFind


All methods

Find.All methods
Namespaces > ArtOfTest.WebAii.Core > Find > All
Members
Icon | Member | Description
 | All() | Obsolete. Find all elements set using FindParamAttributes on method/class.
 | All(Boolean) | Obsolete. Find all elements set using FindParamAttributes.


All() method

Find.All() method
Namespaces > ArtOfTest.WebAii.Core > Find > All()
Find all elements set using FindParamAttributes on method/class.
Syntax
C#
[ObsoleteAttribute("This method is now obsolete. Please use the Manager.Elements[] which can generically handle frames/regions too")]
public void All ()


All(excludeClassAttributes) method

Find.All(excludeClassAttributes) method
Namespaces > ArtOfTest.WebAii.Core > Find > All(Boolean)
Find all elements set using FindParamAttributes.
Syntax
C#
[ObsoleteAttribute("This method is now obsolete. Please use the Manager.Elements[] which can generically handle frames/regions too")]
public void All (
    bool excludeClassAttributes
)
Parameters
excludeClassAttributes (Boolean)
If true, will exclude FindParamAttributes set on the test class.


AllByAttributes methods

Find.AllByAttributes methods
Namespaces > ArtOfTest.WebAii.Core > Find > AllByAttributes
Members
Icon | Member | Description
 | AllByAttributes<(Of TControl>)(String[]()) | Returns a list of elements that have attributes that match the NameValuePairs passed it fully or partially.
 | AllByAttributes(String[]()) | Returns a list of elements that have attributes that match the NameValuePairs passed it fully or partially.


AllByAttributes(nameValuePairs) method

Find.AllByAttributes(nameValuePairs) method
Namespaces > ArtOfTest.WebAii.Core > Find > AllByAttributes(String[]())
Returns a list of elements that have attributes that match the NameValuePairs passed it fully or partially.
Syntax
C#
public ReadOnlyCollection<Element> AllByAttributes (
    params string[] nameValuePairs
)
Parameters
nameValuePairs (String []())
A list of name value pairs to match. For example: AllByAttributes("bar=foo","class=myclass","src=~foo.gif"). Use =~ for partial values.
Return Value
The list of found elements.


AllByAttributes<TControl>(nameValuePairs) method

Find.AllByAttributes<TControl>(nameValuePairs) method
Namespaces > ArtOfTest.WebAii.Core > Find > AllByAttributes<(Of TControl>)(String[]())
Returns a list of elements that have attributes that match the NameValuePairs passed it fully or partially.
Syntax
C#
public ReadOnlyCollection<TControl> AllByAttributes<TControl> (
    params string[] nameValuePairs
) where TControl : new(), Control
Generic Template Parameters
TControl
Control type to get.
Parameters
nameValuePairs (String []())
A list of name value pairs to match. For example: AllByAttributes("bar=foo","class=myclass","src=~foo.gif"). Use =~ for partial values.
Return Value
The list of found elements.
Remarks
If


AllByContent methods

Find.AllByContent methods
Namespaces > ArtOfTest.WebAii.Core > Find > AllByContent
Members
Icon | Member | Description
 | AllByContent(String) | Returns a list of elements that have TextContent that match the specified content The content must start with: 'l:' for exact match strings, 'p:' for partial strings or 'x:' for regular expression matches. If none are provided, the string will be matched using an exact match 'l:'. All searches are case-insensitive. Examples To find tags with TextContent of: 'foo bar' Example 1: ByContent("l:foo bar"); Example 2: ByContent("p:foo"); Example 3: ByContent("x:[*foo*]"); The TextContent to match Remarks There is a difference between FindContentType.InnerText and FindContentType.TextContent that is worth noting: Example: Text1 Text2 InnerText for div1 : Text1Text2 {recursive} TextContent of div1 : Text1 {non-recursive} Default for ByContent is TextContent which is the most common usage.
 | AllByContent<(Of TControl>)(String) | AllByContent(String)
 | AllByContent(String, FindContentType) | Returns a list of elements that match the specified content. The content must start with: 'l:' for exact match strings, 'p:' for partial strings or 'x:' for regular expression matches. If none are provided, the string will be matched using an exact match 'l:'. All searches are case-insensitive. Examples To find tags with TextContent of: 'foo bar' Example 1: ByContent("l:foo bar"); Example 2: ByContent("p:foo"); Example 3: ByContent("x:[*foo*]"); Remarks There is a difference between FindContentType.InnerText and FindContentType.TextContent that is worth noting: Example: Text1 Text2 InnerText for div1 : Text1Text2 {recursive} TextContent of div1 : Text1 {non-recursive} Default for ByContent is TextContent which is the most common usage.
 | AllByContent<(Of TControl>)(String, FindContentType) | AllByContent(String, FindContentType)


AllByContent(content, contentType) method

Find.AllByContent(content, contentType) method
Namespaces > ArtOfTest.WebAii.Core > Find > AllByContent(String, FindContentType)
Returns a list of elements that match the specified content. The content must start with: 'l:' for exact match strings, 'p:' for partial strings or 'x:' for regular expression matches. If none are provided, the string will be matched using an exact match 'l:'. All searches are case-insensitive.
Examples
To find tags with TextContent of: 'foo bar'
Example 1: ByContent("l:foo bar");
Example 2: ByContent("p:foo");
Example 3: ByContent("x:[*foo*]");
Remarks
There is a difference between FindContentType.InnerText and FindContentType.TextContent that is worth noting: Example:
Text1
Text2
InnerText for div1 : Text1Text2 {recursive} TextContent of div1 : Text1 {non-recursive} Default for ByContent is TextContent which is the most common usage.
Syntax
C#
public ReadOnlyCollection<Element> AllByContent (
    string content,
    FindContentType contentType
)
Parameters
content (String)
The content to match
contentType (FindContentType)
The content type to match.
Return Value
The list of found elements.


AllByContent(textContent) method

Find.AllByContent(textContent) method
Namespaces > ArtOfTest.WebAii.Core > Find > AllByContent(String)
Returns a list of elements that have TextContent that match the specified content The content must start with: 'l:' for exact match strings, 'p:' for partial strings or 'x:' for regular expression matches. If none are provided, the string will be matched using an exact match 'l:'. All searches are case-insensitive.
Examples
To find tags with TextContent of: 'foo bar'
Example 1: ByContent("l:foo bar");
Example 2: ByContent("p:foo");
Example 3: ByContent("x:[*foo*]");
The TextContent to match
Remarks
There is a difference between FindContentType.InnerText and FindContentType.TextContent that is worth noting: Example:
Text1
Text2
InnerText for div1 : Text1Text2 {recursive} TextContent of div1 : Text1 {non-recursive} Default for ByContent is TextContent which is the most common usage.
Syntax
C#
public ReadOnlyCollection<Element> AllByContent (
    string textContent
)
Parameters
textContent (String)
Return Value
The list of found elements.


AllByContent<TControl>(content, contentType) method

Find.AllByContent<TControl>(content, contentType) method
Namespaces > ArtOfTest.WebAii.Core > Find > AllByContent<(Of TControl>)(String, FindContentType)
AllByContent(String, FindContentType)
Syntax
C#
public ReadOnlyCollection<TControl> AllByContent<TControl> (
    string content,
    FindContentType contentType
) where TControl : new(), Control
Generic Template Parameters
TControl
Parameters
content (String)
contentType (FindContentType)


AllByContent<TControl>(textContent) method

Find.AllByContent<TControl>(textContent) method
Namespaces > ArtOfTest.WebAii.Core > Find > AllByContent<(Of TControl>)(String)
AllByContent(String)
Syntax
C#
public ReadOnlyCollection<TControl> AllByContent<TControl> (
    string textContent
) where TControl : new(), Control
Generic Template Parameters
TControl
Parameters
textContent (String)


AllByCustom methods

Find.AllByCustom methods
Namespaces > ArtOfTest.WebAii.Core > Find > AllByCustom
Members
Icon | Member | Description
 | AllByCustom(Predicate<(Of Element>)) | Return all elements that match the predicate
 | AllByCustom<(Of TControl>)(Predicate<(Of TControl>)) | Returns all controls that match the predicate and are convertable to TControl.


AllByCustom(predicate) method

Find.AllByCustom(predicate) method
Namespaces > ArtOfTest.WebAii.Core > Find > AllByCustom(Predicate<(Of Element>))
Return all elements that match the predicate
Syntax
C#
public ReadOnlyCollection<Element> AllByCustom (
    Predicate<Element> predicate
)
Parameters
predicate (Predicate <(Of Element >))
The custom predicate that defines the element search
Return Value
The list of elements that match the predicate, else an empty collection or an exception (depending on ThrowIfNullOrEmpty)


AllByCustom<TControl>(predicate) method

Find.AllByCustom<TControl>(predicate) method
Namespaces > ArtOfTest.WebAii.Core > Find > AllByCustom<(Of TControl>)(Predicate<(Of TControl>))
Returns all controls that match the predicate and are convertable to TControl.
Syntax
C#
public ReadOnlyCollection<TControl> AllByCustom<TControl> (
    Predicate<TControl> predicate
) where TControl : new(), Control
Generic Template Parameters
TControl
Parameters
predicate (Predicate <(Of TControl>))
Return Value


AllByParam methods

Find.AllByParam methods
Namespaces > ArtOfTest.WebAii.Core > Find > AllByParam
Members
Icon | Member | Description
 | AllByParam<(Of TControl>)(FindParam) | Returns a list of elements that match the specified FindParam. Note that this method does not support FindParam.Type=NodePathIndex.
 | AllByParam(FindParam) | Returns a list of elements that match the specified FindParam. Note that this method does not support FindParam.Type=NodePathIndex.


AllByParam(param) method

Find.AllByParam(param) method
Namespaces > ArtOfTest.WebAii.Core > Find > AllByParam(FindParam)
Returns a list of elements that match the specified FindParam. Note that this method does not support FindParam.Type=NodePathIndex.
Syntax
C#
public ReadOnlyCollection<Element> AllByParam (
    FindParam param
)
Parameters
param (FindParam)
The FindParam to match.
Return Value
The list of found elements.


AllByParam<TControl>(param) method

Find.AllByParam<TControl>(param) method
Namespaces > ArtOfTest.WebAii.Core > Find > AllByParam<(Of TControl>)(FindParam)
Returns a list of elements that match the specified FindParam. Note that this method does not support FindParam.Type=NodePathIndex.
Syntax
C#
public ReadOnlyCollection<TControl> AllByParam<TControl> (
    FindParam param
) where TControl : new(), Control
Generic Template Parameters
TControl
Control type to get.
Parameters
param (FindParam)
The FindParam to match.
Return Value
The list of found elements.


AllByTagName methods

Find.AllByTagName methods
Namespaces > ArtOfTest.WebAii.Core > Find > AllByTagName
Members
Icon | Member | Description
 | AllByTagName<(Of TControl>)(String) | Returns a list of elements with a specific tag name as a control collection.
 | AllByTagName(String) | Returns a list of elements with a specific tag name.


AllByTagName(tagName) method

Find.AllByTagName(tagName) method
Namespaces > ArtOfTest.WebAii.Core > Find > AllByTagName(String)
Returns a list of elements with a specific tag name.
Syntax
C#
public ReadOnlyCollection<Element> AllByTagName (
    string tagName
)
Parameters
tagName (String)
The tag name to search for.
Return Value
The list of found elements.


AllByTagName<TControl>(tagName) method

Find.AllByTagName<TControl>(tagName) method
Namespaces > ArtOfTest.WebAii.Core > Find > AllByTagName<(Of TControl>)(String)
Returns a list of elements with a specific tag name as a control collection.
Syntax
C#
public ReadOnlyCollection<TControl> AllByTagName<TControl> (
    string tagName
) where TControl : new(), Control
Generic Template Parameters
TControl
The control type to find.
Parameters
tagName (String)
The tag name.
Return Value
The list of found controls.


AllByXPath methods

Find.AllByXPath methods
Namespaces > ArtOfTest.WebAii.Core > Find > AllByXPath
Members
Icon | Member | Description
 | AllByXPath(String) | Returns a list of elements that match the specified XPath. This function supports the System.Xml XPath syntax.
 | AllByXPath<(Of TControl>)(String) | Returns a list of elements that match the specified XPath. This function supports the System.Xml XPath syntax.


AllByXPath(xpath) method

Find.AllByXPath(xpath) method
Namespaces > ArtOfTest.WebAii.Core > Find > AllByXPath(String)
Returns a list of elements that match the specified XPath. This function supports the System.Xml XPath syntax.
Syntax
C#
public ReadOnlyCollection<Element> AllByXPath (
    string xpath
)
Parameters
xpath (String)
The XPath string. XPath is case-sensitive.
Return Value
The list of found elements.


AllByXPath<TControl>(xpath) method

Find.AllByXPath<TControl>(xpath) method
Namespaces > ArtOfTest.WebAii.Core > Find > AllByXPath<(Of TControl>)(String)
Returns a list of elements that match the specified XPath. This function supports the System.Xml XPath syntax.
Syntax
C#
public ReadOnlyCollection<TControl> AllByXPath<TControl> (
    string xpath
) where TControl : new(), Control
Generic Template Parameters
TControl
Control type to get.
Parameters
xpath (String)
The XPath string. XPath is case-sensitive.
Return Value
The list of found elements.


AllControls<TControl>() method

Find.AllControls<TControl>() method
Namespaces > ArtOfTest.WebAii.Core > Find > AllControls<(Of TControl>)()
Gets an IEnmerable for TControl to be used for LINQ queries. This will return only elements that are convertable to TControl
Syntax
C#
public IEnumerable<TControl> AllControls<TControl> () where TControl : new(), Control
Generic Template Parameters
TControl
The control type
Return Value
IEnumberable


AllElements() method

Find.AllElements() method
Namespaces > ArtOfTest.WebAii.Core > Find > AllElements()
Gets a IEnumerable for all elements to be used for LINQ queries
Syntax
C#
public IEnumerable<Element> AllElements ()
Return Value
IEnumberable


AssociatedBrowser property

Find.AssociatedBrowser property
Namespaces > ArtOfTest.WebAii.Core > Find > AssociatedBrowser
Gets the browser object that is associated with this find object. If this property is null, then the Find object is associated with a search region.
Syntax
C#
public Browser AssociatedBrowser { get; }
Remarks
Either Find.SearchRegion or Find.AssociatedBrowser is null. Both can't be null and both can't be set.


BuildBestFitFindParam(element) method

Find.BuildBestFitFindParam(element) method
Namespaces > ArtOfTest.WebAii.Core > Find > BuildBestFitFindParam(Element)
Generates a FindParam[] list to be used to find the specified element. The function uses an algorithm optimized for most reliable search methods and will revert back to using the tagname index as a last resort
Syntax
C#
public static FindParam[] BuildBestFitFindParam (
    Element element
)
Parameters
element (Element)
The element to generate the FindParam for.
Return Value
The FindParam scheme to use to find the element. Can contain Chained FindParams


ByAttributes methods

Find.ByAttributes methods
Namespaces > ArtOfTest.WebAii.Core > Find > ByAttributes
Members
Icon | Member | Description
 | ByAttributes(String[]()) | Returns a an element that has attributes that match the NameValuePairs passed it. All matching is case-insensitive.
 | ByAttributes<(Of TControl>)(String[]()) | Same as ByAttributes(). Returns a control type instead of element.


ByAttributes(nameValuePairs) method

Find.ByAttributes(nameValuePairs) method
Namespaces > ArtOfTest.WebAii.Core > Find > ByAttributes(String[]())
Returns a an element that has attributes that match the NameValuePairs passed it. All matching is case-insensitive.
Syntax
C#
public Element ByAttributes (
    params string[] nameValuePairs
)
Parameters
nameValuePairs (String []())
A list of name value pairs to match. For example: GetAllElementsByAttributes("bar=foo","class=myclass","src=~foo.gif"). Use =~ for partial values.
Return Value
The found element. The function returns null if no element is found.


ByAttributes<TControl>(nameValuePairs) method

Find.ByAttributes<TControl>(nameValuePairs) method
Namespaces > ArtOfTest.WebAii.Core > Find > ByAttributes<(Of TControl>)(String[]())
Same as ByAttributes(). Returns a control type instead of element.
Syntax
C#
public TControl ByAttributes<TControl> (
    params string[] nameValuePairs
) where TControl : new(), Control
Generic Template Parameters
TControl
Control type to create.
Parameters
nameValuePairs (String []())
A list of name value pairs to match. For example: GetAllElementsByAttributes("bar=foo","class=myclass","src=~foo.gif"). Use =~ for partial values.
Return Value
The control object.


ByContent methods

Find.ByContent methods
Namespaces > ArtOfTest.WebAii.Core > Find > ByContent
Members
Icon | Member | Description
 | ByContent(String) | Returns an element by searching its TextContent. The content must start with: 'l:' for exact match strings, 'p:' for partial strings or 'x:' for regular expression matches. If none are provided, the string will be matched using an exact match 'l:'. All searches are case-insensitive. Examples To find tags with innerText content is: 'foo bar' Example 1: ByContent("l:foo bar"); Example 2: ByContent("p:foo"); Example 3: ByContent("x:[*foo*]");
 | ByContent<(Of TControl>)(String) | Same as ByContent(). Returns a control type instead of element.
 | ByContent<(Of TControl>)(String, FindContentType) | Same as ByContent(). Returns a control type instead of element.
 | ByContent(String, FindContentType) | Returns an element by searching its content with the options to pick the content type. (InnerText, InnerMarkup or OuterMarkup) The content must start with: 'l:' for exact match strings, 'p:' for partial strings or 'x:' for regular expression matches. If none are provided, the string will be matched using an exact match 'l:'. All searches are case-insensitive. Examples Similar to Find.ByContent(string) with the option to specify the content type: Example 1: ByContent("l:foo bar",FindContentType.InnerText); Example 2: ByContent("p:<foo id="f" />",FindContent.OuterMarkup); Remarks There is a difference between FindContentType.InnerText and FindContentType.TextContent that is worth noting: Example: Text1 Text2 InnerText for div1 : Text1Text2 {recursive} TextContent of div1 : Text1 {non-recursive} Default for ByContent is TextContent which is the most common usage.
 | ByContent<(Of TControl>)(String, FindContentType, String[]()) | Same as ByContent(). Returns a control type instead of element.
 | ByContent(String, FindContentType, String[]()) | Returns an element by searching its content with the options to pick the content type. (InnerText, InnerMarkup or OuterMarkup) in addition to a list of attributes. The content must start with: 'l:' for exact match strings, 'p:' for partial strings or 'x:' for regular expression matches. If none are provided, the string will be matched using an exact match 'l:'. All searches are case-insensitive. Examples Similar to Find.ByContent(string) with the option to specify the content type: Example 1: ByContent("l:foo bar",FindContentType.InnerText); Example 2: ByContent("p:<foo id="f" />",FindContent.OuterMarkup); Remarks There is a difference between FindContentType.InnerText and FindContentType.TextContent that is worth noting: Example: Text1 Text2 InnerText for div1 : Text1Text2 {recursive} TextContent of div1 : Text1 {non-recursive} Default for ByContent is TextContent which is the most common usage.


ByContent(content) method

Find.ByContent(content) method
Namespaces > ArtOfTest.WebAii.Core > Find > ByContent(String)
Returns an element by searching its TextContent. The content must start with: 'l:' for exact match strings, 'p:' for partial strings or 'x:' for regular expression matches. If none are provided, the string will be matched using an exact match 'l:'. All searches are case-insensitive.
Examples
To find tags with innerText content is: 'foo bar'
Example 1: ByContent("l:foo bar");
Example 2: ByContent("p:foo");
Example 3: ByContent("x:[*foo*]");
Syntax
C#
public Element ByContent (
    string content
)
Parameters
content (String)
The content to match
Return Value
The found element. The function returns null if no element is found


ByContent(content, contentType) method

Find.ByContent(content, contentType) method
Namespaces > ArtOfTest.WebAii.Core > Find > ByContent(String, FindContentType)
Returns an element by searching its content with the options to pick the content type. (InnerText, InnerMarkup or OuterMarkup) The content must start with: 'l:' for exact match strings, 'p:' for partial strings or 'x:' for regular expression matches. If none are provided, the string will be matched using an exact match 'l:'. All searches are case-insensitive.
Examples
Similar to Find.ByContent(string) with the option to specify the content type: Example 1: ByContent("l:foo bar",FindContentType.InnerText); Example 2: ByContent("p:<foo id="f" />",FindContent.OuterMarkup);
Remarks
There is a difference between FindContentType.InnerText and FindContentType.TextContent that is worth noting: Example:
Text1
Text2
InnerText for div1 : Text1Text2 {recursive} TextContent of div1 : Text1 {non-recursive} Default for ByContent is TextContent which is the most common usage.
Syntax
C#
public Element ByContent (
    string content,
    FindContentType contentType
)
Parameters
content (String)
The content to match.
contentType (FindContentType)
The content type to match.
Return Value
The found element. The function returns null if no element is found


ByContent(content, contentType, nameValuePairs) method

Find.ByContent(content, contentType, nameValuePairs) method
Namespaces > ArtOfTest.WebAii.Core > Find > ByContent(String, FindContentType, String[]())
Returns an element by searching its content with the options to pick the content type. (InnerText, InnerMarkup or OuterMarkup) in addition to a list of attributes. The content must start with: 'l:' for exact match strings, 'p:' for partial strings or 'x:' for regular expression matches. If none are provided, the string will be matched using an exact match 'l:'. All searches are case-insensitive.
Examples
Similar to Find.ByContent(string) with the option to specify the content type: Example 1: ByContent("l:foo bar",FindContentType.InnerText); Example 2: ByContent("p:<foo id="f" />",FindContent.OuterMarkup);
Remarks
There is a difference between FindContentType.InnerText and FindContentType.TextContent that is worth noting: Example:
Text1
Text2
InnerText for div1 : Text1Text2 {recursive} TextContent of div1 : Text1 {non-recursive} Default for ByContent is TextContent which is the most common usage.
Syntax
C#
public Element ByContent (
    string content,
    FindContentType contentType,
    params string[] nameValuePairs
)
Parameters
content (String)
The content to match.
contentType (FindContentType)
The content type to match.
nameValuePairs (String []())
The attribute name/value pairs to apply.
Return Value
The found element. The function returns null if no element is found


ByContent<TControl>(content) method

Find.ByContent<TControl>(content) method
Namespaces > ArtOfTest.WebAii.Core > Find > ByContent<(Of TControl>)(String)
Same as ByContent(). Returns a control type instead of element.
Syntax
C#
public TControl ByContent<TControl> (
    string content
) where TControl : new(), Control
Generic Template Parameters
TControl
The control type to create.
Parameters
content (String)
The content to match
Return Value
The control object.


ByContent<TControl>(content, contentType) method

Find.ByContent<TControl>(content, contentType) method
Namespaces > ArtOfTest.WebAii.Core > Find > ByContent<(Of TControl>)(String, FindContentType)
Same as ByContent(). Returns a control type instead of element.
Syntax
C#
public TControl ByContent<TControl> (
    string content,
    FindContentType contentType
) where TControl : new(), Control
Generic Template Parameters
TControl
The control type to create.
Parameters
content (String)
The content to match.
contentType (FindContentType)
The content type to match.
Return Value
The control object.


ByContent<TControl>(content, contentType, nameValuePairs) method

Find.ByContent<TControl>(content, contentType, nameValuePairs) method
Namespaces > ArtOfTest.WebAii.Core > Find > ByContent<(Of TControl>)(String, FindContentType, String[]())
Same as ByContent(). Returns a control type instead of element.
Syntax
C#
public TControl ByContent<TControl> (
    string content,
    FindContentType contentType,
    params string[] nameValuePairs
) where TControl : new(), Control
Generic Template Parameters
TControl
The control type to create.
Parameters
content (String)
The content to match.
contentType (FindContentType)
The content type to match.
nameValuePairs (String []())
The attribute name/value pairs to apply.
Return Value
The control object.


ByCustom methods

Find.ByCustom methods
Namespaces > ArtOfTest.WebAii.Core > Find > ByCustom
Members
Icon | Member | Description
 | ByCustom(Predicate<(Of Element>)) | Return the element that matches the defined predicate
 | ByCustom<(Of TControl>)(Predicate<(Of TControl>)) | Get a control by using custom predicate. This function will try to eliminate any elements that are not convertable to TControl type.


ByCustom(predicate) method

Find.ByCustom(predicate) method
Namespaces > ArtOfTest.WebAii.Core > Find > ByCustom(Predicate<(Of Element>))
Return the element that matches the defined predicate
Syntax
C#
public Element ByCustom (
    Predicate<Element> predicate
)
Parameters
predicate (Predicate <(Of Element >))
The custom predicate that defines the element search
Return Value
The element, else null.


ByCustom<TControl>(predicate) method

Find.ByCustom<TControl>(predicate) method
Namespaces > ArtOfTest.WebAii.Core > Find > ByCustom<(Of TControl>)(Predicate<(Of TControl>))
Get a control by using custom predicate. This function will try to eliminate any elements that are not convertable to TControl type.
Syntax
C#
public TControl ByCustom<TControl> (
    Predicate<TControl> predicate
) where TControl : new(), Control
Generic Template Parameters
TControl
The control type.
Parameters
predicate (Predicate <(Of TControl>))
The predicate.
Return Value
The first found control.


ById methods

Find.ById methods
Namespaces > ArtOfTest.WebAii.Core > Find > ById
Members
Icon | Member | Description
 | ById(String) | Returns an element by looking for its 'id' attribute value.
 | ById<(Of TControl>)(String) | Same as ById(). Returns a control type instead of element.


ById(id) method

Find.ById(id) method
Namespaces > ArtOfTest.WebAii.Core > Find > ById(String)
Returns an element by looking for its 'id' attribute value.
Syntax
C#
public Element ById (
    string id
)
Parameters
id (String)
The id value for the element to find. All searches are case-insensitive
Return Value
The found element. The function returns null if no element is found.


ById<TControl>(id) method

Find.ById<TControl>(id) method
Namespaces > ArtOfTest.WebAii.Core > Find > ById<(Of TControl>)(String)
Same as ById(). Returns a control type instead of element.
Syntax
C#
public TControl ById<TControl> (
    string id
) where TControl : new(), Control
Generic Template Parameters
TControl
The control type to create.
Parameters
id (String)
The id value for the element to find. All searches are case-insensitive
Return Value
The control object.


ByName methods

Find.ByName methods
Namespaces > ArtOfTest.WebAii.Core > Find > ByName
Members
Icon | Member | Description
 | ByName<(Of TControl>)(String) | Same as ByName(). Returns a control type instead of element.
 | ByName(String) | Returns an element by searching for its 'name' attribute value


ByName(name) method

Find.ByName(name) method
Namespaces > ArtOfTest.WebAii.Core > Find > ByName(String)
Returns an element by searching for its 'name' attribute value
Syntax
C#
public Element ByName (
    string name
)
Parameters
name (String)
The name value for the element to find. All searches as case-insensitive
Return Value
The found element. The function returns null if no element is found.


ByName<TControl>(name) method

Find.ByName<TControl>(name) method
Namespaces > ArtOfTest.WebAii.Core > Find > ByName<(Of TControl>)(String)
Same as ByName(). Returns a control type instead of element.
Syntax
C#
public TControl ByName<TControl> (
    string name
) where TControl : new(), Control
Generic Template Parameters
TControl
The control type to create.
Parameters
name (String)
The name value for the element to find. All searches as case-insensitive
Return Value
The control object.


ByNodeIndexPath methods

Find.ByNodeIndexPath methods
Namespaces > ArtOfTest.WebAii.Core > Find > ByNodeIndexPath
Members
Icon Member Description
ByNodeIndexPath(String)
Returns an element by searching for it using a node index path.
Examples
  For example:

  This call: ByNodeIndexPath("0/2/0/1") describes the <target></target> element in the below hierarchy:

  <referenceElement>
   (0)<foo>
          <bar>
          </bar>
          <car>
          </car>
       (2)<bus>
           (0)<driver>
                  <cap>
                  </cap>
               (1)<target>
                  </target>
              </driver>
          </bus>
      </foo>
  </referenceElement>

ByNodeIndexPath<(Of TControl>)(String)
Same as ByNodexIndexPath(). Returns a control type instead of element.


ByNodeIndexPath(nodeIndexPath) method

Find.ByNodeIndexPath(nodeIndexPath) method
Namespaces > ArtOfTest.WebAii.Core > Find > ByNodeIndexPath(String)
Returns an element by searching for it using a node index path.
Examples
  For example:

  This call: ByNodeIndexPath("0/2/0/1") describes the <target></target> element in the below hierarchy:

  <referenceElement>
   (0)<foo>
          <bar>
          </bar>
          <car>
          </car>
       (2)<bus>
           (0)<driver>
                  <cap>
                  </cap>
               (1)<target>
                  </target>
              </driver>
          </bus>
      </foo>
  </referenceElement>

Syntax
C#
public Element ByNodeIndexPath (
    string nodeIndexPath
)
Parameters
nodeIndexPath (String)
The node index path. This is a forward slash delimited list of tree node indexes that describe a specific path to a target element while ignoring the actual element tags and simply describing the hierarchal relationship to that element.
Return Value
The found element. The function returns null if no element is found.


ByNodeIndexPath<TControl>(nodeIndexPath) method

Find.ByNodeIndexPath<TControl>(nodeIndexPath) method
Namespaces > ArtOfTest.WebAii.Core > Find > ByNodeIndexPath<(Of TControl>)(String)
Same as ByNodexIndexPath(). Returns a control type instead of element.
Syntax
C#
public TControl ByNodeIndexPath<TControl> (
    string nodeIndexPath
) where TControl : new(), Control
Generic Template Parameters
TControl
Control type to create.
Parameters
nodeIndexPath (String)
Return Value


ByParam methods

Find.ByParam methods
Namespaces > ArtOfTest.WebAii.Core > Find > ByParam
Members
Icon | Member | Description
 | ByParam(FindParam) | Return an element using a FindParam
 | ByParam<(Of TControl>)(FindParam) | Same as ByParam(). Returns a control type instead of element.
 | ByParam<(Of TControl>)(FindParam[]()) | Same as ByParam(). Returns a control type instead of element.
 | ByParam(FindParam[]()) | Returns an element using a chained identification.


ByParam(chainedParams) method

Find.ByParam(chainedParams) method
Namespaces > ArtOfTest.WebAii.Core > Find > ByParam(FindParam[]())
Returns an element using a chained identification.
Syntax
C#
public Element ByParam (
    FindParam[] chainedParams
)
Parameters
chainedParams (FindParam []())
An array of FindParams used to identify an element by piping the search result of each FindParam as the reference element for the FindParam that follows.
Return Value
The found element. The function returns null if no element is found.


ByParam(param) method

Find.ByParam(param) method
Namespaces > ArtOfTest.WebAii.Core > Find > ByParam(FindParam)
Return an element using a FindParam
Syntax
C#
public Element ByParam (
    FindParam param
)
Parameters
param (FindParam)
The FindParam that describes how to find the target element.
Return Value
The found element. The function returns null if no element is found.


ByParam<TControl>(chainedParams) method

Find.ByParam<TControl>(chainedParams) method
Namespaces > ArtOfTest.WebAii.Core > Find > ByParam<(Of TControl>)(FindParam[]())
Same as ByParam(). Returns a control type instead of element.
Syntax
C#
public TControl ByParam<TControl> (
    FindParam[] chainedParams
) where TControl : new(), Control
Generic Template Parameters
TControl
Control type to create.
Parameters
chainedParams (FindParam []())
An array of FindParams used to identify an element by piping the search result of each FindParam as the reference element for the FindParam that follows.
Return Value
The control object.


ByParam<TControl>(param) method

Find.ByParam<TControl>(param) method
Namespaces > ArtOfTest.WebAii.Core > Find > ByParam<(Of TControl>)(FindParam)
Same as ByParam(). Returns a control type instead of element.
Syntax
C#
public TControl ByParam<TControl> (
    FindParam param
) where TControl : new(), Control
Generic Template Parameters
TControl
Control type to create.
Parameters
param (FindParam)
The FindParam that describes how to find the target element.
Return Value
The control object.


ByTagIndex methods

Find.ByTagIndex methods
Namespaces > ArtOfTest.WebAii.Core > Find > ByTagIndex
Members
Icon | Member | Description
 | ByTagIndex<(Of TControl>)(String, Int32) | Same as ByTagIndex(). Returns a control type instead of element.
 | ByTagIndex(String, Int32) | Returns an element by its tag name occrrence.


ByTagIndex(tagName, occurrenceIndex) method

Find.ByTagIndex(tagName, occurrenceIndex) method
Namespaces > ArtOfTest.WebAii.Core > Find > ByTagIndex(String, Int32)
Returns an element by its tag name occrrence.
Syntax
C#
public Element ByTagIndex (
    string tagName,
    int occurrenceIndex
)
Parameters
tagName (String)
The tag name to find.
occurrenceIndex (Int32)
The tag name index. This is a zero-base index.
Return Value
The found element. The function returns null if no element is found.


ByTagIndex<TControl>(tagName, occurrenceIndex) method

Find.ByTagIndex<TControl>(tagName, occurrenceIndex) method
Namespaces > ArtOfTest.WebAii.Core > Find > ByTagIndex<(Of TControl>)(String, Int32)
Same as ByTagIndex(). Returns a control type instead of element.
Syntax
C#
public TControl ByTagIndex<TControl> (
    string tagName,
    int occurrenceIndex
) where TControl : new(), Control
Generic Template Parameters
TControl
Control type to create.
Parameters
tagName (String)
The tag name to find.
occurrenceIndex (Int32)
The tag name index. This is a zero-base index.
Return Value
The control object.


ByXPath methods

Find.ByXPath methods
Namespaces > ArtOfTest.WebAii.Core > Find > ByXPath
Members
Icon | Member | Description
 | ByXPath(String) | Returns an element using an XPath. This function supports the System.Xml XPath syntax.
 | ByXPath<(Of TControl>)(String) | Same as ByXPath(). Returns a control type instead of element.


ByXPath(xpath) method

Find.ByXPath(xpath) method
Namespaces > ArtOfTest.WebAii.Core > Find > ByXPath(String)
Returns an element using an XPath. This function supports the System.Xml XPath syntax.
Syntax
C#
public Element ByXPath (
    string xpath
)
Parameters
xpath (String)
The XPath string. XPath is case-sensitive.
Return Value
The found element. The function returns null if no element is found.


ByXPath<TControl>(xpath) method

Find.ByXPath<TControl>(xpath) method
Namespaces > ArtOfTest.WebAii.Core > Find > ByXPath<(Of TControl>)(String)
Same as ByXPath(). Returns a control type instead of element.
Syntax
C#
public TControl ByXPath<TControl> (
    string xpath
) where TControl : new(), Control
Generic Template Parameters
TControl
The control type to create.
Parameters
xpath (String)
The XPath string. XPath is case-sensitive.
Return Value
The control object.


Elements property

Find.Elements property
Namespaces > ArtOfTest.WebAii.Core > Find > Elements
Found elements from FindParam attributes set on the class or method. If the Find.All() method has not been called, then accessing this dictionary will call Find.All() before returning the dictionary items.
Syntax
C#
[ObsoleteAttribute("This method is now obsolete. Please use the Manager.Elements[] which can generically handle frames/regions too")]
public IDictionary<string, Element> Elements { get; }


FindReferenceType property

Find.FindReferenceType property
Namespaces > ArtOfTest.WebAii.Core > Find > FindReferenceType
Gets the reference type that this Find object is using. (i.e. browser root, testregion ... etc)
Syntax
C#
public FindReferenceType FindReferenceType { get; }


FromCollection(collection) method

Find.FromCollection(collection) method
Namespaces > ArtOfTest.WebAii.Core > Find > FromCollection(FindParamCollection)
Finds all elements with the FindParams in the passed in collection.
Syntax
C#
public IDictionary<string, Element> FromCollection (
    FindParamCollection collection
)
Parameters
collection (FindParamCollection)
The collection of all the FindParams
Remarks
If ThrowIfNullOrEmpty is true, this function will throw if an element is not found. If ThrowIfNullOrEmpty is false, this function will not add and element that we not found.


FromFile(fileName) method

Find.FromFile(fileName) method
Namespaces > ArtOfTest.WebAii.Core > Find > FromFile(String)
Finds all elements with FindParams defined in a file. Found elements can be accessed from Find.Elements
Syntax
C#
public IDictionary<string, Element> FromFile (
    string fileName
)
Parameters
fileName (String)
The filename where all the FindParams are defined.


FromXml(xml) method

Find.FromXml(xml) method
Namespaces > ArtOfTest.WebAii.Core > Find > FromXml(String)
Finds all elements with FindParams defined in the serialized xml string. Found elements can be accessed from Find.Elements
Syntax
C#
public IDictionary<string, Element> FromXml (
    string xml
)
Parameters
xml (String)
The xml string that describes the FindParams collection.


IgnoreFindAllControlMismatch property

Find.IgnoreFindAllControlMismatch property
Namespaces > ArtOfTest.WebAii.Core > Find > IgnoreFindAllControlMismatch
Gets/Sets whether to ignore Find.Allxx<TControl>(...) elements that don't match the TControl specified. (i.e. the TControl type validation fails for that element). If false, the Find.Allxx method will throw an exception.
Syntax
C#
public bool IgnoreFindAllControlMismatch { get; set; }


LastSearchLog property

Find.LastSearchLog property
Namespaces > ArtOfTest.WebAii.Core > Find > LastSearchLog
Gets the search log for the last find attempt. This log can help diagnose when find fails to locate an element.
Syntax
C#
public string LastSearchLog { get; }


ReturnedNullOrEmpty event

Find.ReturnedNullOrEmpty event
Namespaces > ArtOfTest.WebAii.Core > Find > ReturnedNullOrEmpty
Invoked when one of the find methods returns null or an empty list of elements.
Syntax
C#
public event EventHandler<ReturnedNullOrEmptyEventArgs> ReturnedNullOrEmpty


SearchRegion property

Find.SearchRegion property
Namespaces > ArtOfTest.WebAii.Core > Find > SearchRegion
Gets the search region for this Find object. When this is set to a specific region, all search is done locale to that region. All indexes are calculated starting at zero from this region's element. If this property is null, then the Find object will perform all searches from the document root element.
Syntax
C#
public TestRegion SearchRegion { get; }


SearchRootElement property

Find.SearchRootElement property
Namespaces > ArtOfTest.WebAii.Core > Find > SearchRootElement
Gets/Sets the root element that all searches will be performed under. This element depended on the reference type. [Browser/TestRegion/Element].
Syntax
C#
public Element SearchRootElement { get; }


ThrowIfNullOrEmpty property

Find.ThrowIfNullOrEmpty property
Namespaces > ArtOfTest.WebAii.Core > Find > ThrowIfNullOrEmpty
Gets/Sets whether to throw an exception if any of the find methods returns a null element or any of the find all methods return empty list of elements.
Syntax
C#
public bool ThrowIfNullOrEmpty { get; set; }


FindReferenceType enumeration

FindReferenceType enumeration
Namespaces > ArtOfTest.WebAii.Core > FindReferenceType
Defines which reference type the Find object is using.
Syntax
C#
public enum FindReferenceType
Members
Member | Description
Document | The reference element is root Dom tree element of the parent browser
TestRegion | The reference element is a TestRegion
Element | The reference element is an generic element.


FrameInfo class

FrameInfo class
Namespaces > ArtOfTest.WebAii.Core > FrameInfo
Information regarding a specific frame
Syntax
C#
[SerializableAttribute]
public class FrameInfo : INotifyPropertyChanged, IXmlSerializable
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | FrameInfoNew() | Create a new FrameInfo object.
 | FrameInfoNew(String, String, Int32) | Create a new FrameInfo object.
 | Equals(Object) | Determines if two FrameInfo objects are equal. (Overrides Object.Equals(Object).)
 | Finalize() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode() | Get hash code of this FrameInfo object. (Overrides Object.GetHashCode().)
 | GetIndexer(String) | Get the set indexer on this FrameInfo
 | GetSchema() |
 | GetType() | Gets the Type of the current instance. (Inherited from Object.)
 | Id | Get frame id.
 | Index | Get frame index.
 | MemberwiseClone() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Get frame name.
 | PropertyChanged | Occurs when a property on the FrameInfo object changes.
 | ReadXml(XmlReader) |
 | Rectangle | Get the rectangle coordinates of this frame.
 | ToString() | String representation of the frame info. (Overrides Object.ToString().)
 | UniqueId | Gets the unique id of the frame for that session. Note: This property is not garanteed to be the same between requests to the same page so it shouldn't be serialized as part of this frame's information.
 | WriteXml(XmlWriter) |
Inheritance Hierarchy
Object
FrameInfo


Constructors

FrameInfo constructors
Namespaces > ArtOfTest.WebAii.Core > FrameInfo > FrameInfoNew
Members
Icon | Member | Description
 | FrameInfoNew() | Create a new FrameInfo object.
 | FrameInfoNew(String, String, Int32) | Create a new FrameInfo object.


FrameInfo() constructor

FrameInfo() constructor
Namespaces > ArtOfTest.WebAii.Core > FrameInfo > FrameInfoNew()
Create a new FrameInfo object.
Syntax
C#
public FrameInfo ()


FrameInfo(id, name, index) constructor

FrameInfo(id, name, index) constructor
Namespaces > ArtOfTest.WebAii.Core > FrameInfo > FrameInfoNew(String, String, Int32)
Create a new FrameInfo object.
Syntax
C#
public FrameInfo (
    string id,
    string name,
    int index
)
Parameters
id (String)
Frame id.
name (String)
Frame name.
index (Int32)
Frame index.


Equals(obj) method

FrameInfo.Equals(obj) method
Namespaces > ArtOfTest.WebAii.Core > FrameInfo > Equals(Object)
Determines if two FrameInfo objects are equal.
Syntax
C#
public override bool Equals (
    Object obj
)
Parameters
obj (Object)
The object to comapre to.
Return Value
True/False whether the two objects are equal.


GetHashCode() method

FrameInfo.GetHashCode() method
Namespaces > ArtOfTest.WebAii.Core > FrameInfo > GetHashCode()
Get hash code of this FrameInfo object.
Syntax
C#
public override int GetHashCode ()
Return Value
The hash code.


GetIndexer(frameFindParamParameter) method

FrameInfo.GetIndexer(frameFindParamParameter) method
Namespaces > ArtOfTest.WebAii.Core > FrameInfo > GetIndexer(String)
Get the set indexer on this FrameInfo
Syntax
C#
public Object GetIndexer (
    out string frameFindParamParameter
)
Parameters
frameFindParamParameter (String)
Return Value


GetSchema() method

FrameInfo.GetSchema() method
Namespaces > ArtOfTest.WebAii.Core > FrameInfo > GetSchema()
Syntax
C#
public XmlSchema GetSchema ()


Id property

FrameInfo.Id property
Namespaces > ArtOfTest.WebAii.Core > FrameInfo > Id
Get frame id.
Syntax
C#
[CategoryAttribute("Frame Identification")]
[DescriptionAttribute("The frame id to find. If this value is empty, WebAii checks the name then the index")]
[NotifyParentPropertyAttribute(true)]
public string Id { get; set; }


Index property

FrameInfo.Index property
Namespaces > ArtOfTest.WebAii.Core > FrameInfo > Index
Get frame index.
Syntax
C#
[CategoryAttribute("Frame Identification")]
[NotifyParentPropertyAttribute(true)]
[DescriptionAttribute("The index of this frame as WebAii sees it in the flat list of frames on the page. This is used as a last option to locate the frame if id or name are not set.")]
public int Index { get; set; }


Name property

FrameInfo.Name property
Namespaces > ArtOfTest.WebAii.Core > FrameInfo > Name
Get frame name.
Syntax
C#
[NotifyParentPropertyAttribute(true)]
[CategoryAttribute("Frame Identification")]
[DescriptionAttribute("The frame name to find. WebAii check the Id property first, it is empty, it will check the name next.")]
public string Name { get; set; }


PropertyChanged event

FrameInfo.PropertyChanged event
Namespaces > ArtOfTest.WebAii.Core > FrameInfo > PropertyChanged
Occurs when a property on the FrameInfo object changes.
Syntax
C#
public event PropertyChangedEventHandler PropertyChanged


ReadXml(reader) method

FrameInfo.ReadXml(reader) method
Namespaces > ArtOfTest.WebAii.Core > FrameInfo > ReadXml(XmlReader)
Syntax
C#
public void ReadXml (
    XmlReader reader
)
Parameters
reader (XmlReader)


Rectangle property

FrameInfo.Rectangle property
Namespaces > ArtOfTest.WebAii.Core > FrameInfo > Rectangle
Get the rectangle coordinates of this frame.
Syntax
C#
[BrowsableAttribute(false)]
public Rectangle Rectangle { get; }


ToString() method

FrameInfo.ToString() method
Namespaces > ArtOfTest.WebAii.Core > FrameInfo > ToString()
String representation of the frame info.
Syntax
C#
public override string ToString ()
Return Value
The string.


UniqueId property

FrameInfo.UniqueId property
Namespaces > ArtOfTest.WebAii.Core > FrameInfo > UniqueId
Gets the unique id of the frame for that session. Note: This property is not garanteed to be the same between requests to the same page so it shouldn't be serialized as part of this frame's information.
Syntax
C#
[BrowsableAttribute(false)]
public string UniqueId { get; }


WriteXml(writer) method

FrameInfo.WriteXml(writer) method
Namespaces > ArtOfTest.WebAii.Core > FrameInfo > WriteXml(XmlWriter)
Syntax
C#
public void WriteXml (
    XmlWriter writer
)
Parameters
writer (XmlWriter)


FramesCollection class

FramesCollection class
Namespaces > ArtOfTest.WebAii.Core > FramesCollection
Collection of frames (Browser objects)
Syntax
C#
[DefaultMemberAttribute("Item")]
public class FramesCollection : Dictionary<string, Browser>, IEnumerable<Browser>, IEnumerable
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | FramesCollectionNew() |
 | Add(String, Browser) | Adds the specified key and value to the dictionary. (Inherited from Dictionary <(Of String, Browser >).)
 | Browser}.Keys | (Inherited from Dictionary <(Of String, Browser >).)
 | Browser}.Values | (Inherited from Dictionary <(Of String, Browser >).)
 | Browser}}.Add(KeyValuePair<(Of String, Browser>)) | (Inherited from Dictionary <(Of String, Browser >).)
 | Browser}}.Contains(KeyValuePair<(Of String, Browser>)) | (Inherited from Dictionary <(Of String, Browser >).)
 | Browser}}.CopyTo(KeyValuePair<(Of String, Browser>)[](), Int32) | (Inherited from Dictionary <(Of String, Browser >).)
 | Browser}}.GetEnumerator() | (Inherited from Dictionary <(Of String, Browser >).)
 | Browser}}.IsReadOnly | (Inherited from Dictionary <(Of String, Browser >).)
 | Browser}}.Remove(KeyValuePair<(Of String, Browser>)) | (Inherited from Dictionary <(Of String, Browser >).)
 | ById(String) | Gets a frame using its id.
 | Clear() | Removes all keys and values from the Dictionary<(Of TKey, TValue>). (Inherited from Dictionary <(Of String, Browser >).)
 | Comparer | Gets the IEqualityComparer<(Of T>) that is used to determine equality of keys for the dictionary. (Inherited from Dictionary <(Of String, Browser >).)
 | ContainsKey(String) | Determines whether the Dictionary<(Of TKey, TValue>) contains the specified key. (Inherited from Dictionary <(Of String, Browser >).)
 | ContainsValue(Browser) | Determines whether the Dictionary<(Of TKey, TValue>) contains a specific value. (Inherited from Dictionary <(Of String, Browser >).)
 | Count | Gets the number of key/value pairs contained in the Dictionary<(Of TKey, TValue>). (Inherited from Dictionary <(Of String, Browser >).)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetEnumerator() | Get the enumerator.
 | GetHashCode() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | Implements the ISerializable interface and returns the data needed to serialize the Dictionary<(Of TKey, TValue>) instance. (Inherited from Dictionary <(Of String, Browser >).)
 | GetType() | Gets the Type of the current instance. (Inherited from Object.)
 | ICollection.CopyTo(Array, Int32) | (Inherited from Dictionary <(Of String, Browser >).)
 | ICollection.IsSynchronized | (Inherited from Dictionary <(Of String, Browser >).)
 | ICollection.SyncRoot | (Inherited from Dictionary <(Of String, Browser >).)
 | IDictionary.Add(Object, Object) | (Inherited from Dictionary <(Of String, Browser >).)
 | IDictionary.Contains(Object) | (Inherited from Dictionary <(Of String, Browser >).)
 | IDictionary.GetEnumerator() | (Inherited from Dictionary <(Of String, Browser >).)
 | IDictionary.IsFixedSize | (Inherited from Dictionary <(Of String, Browser >).)
 | IDictionary.IsReadOnly | (Inherited from Dictionary <(Of String, Browser >).)
 | IDictionary.Item(Object) | (Inherited from Dictionary <(Of String, Browser >).)
 | IDictionary.Keys | (Inherited from Dictionary <(Of String, Browser >).)
 | IDictionary.Remove(Object) | (Inherited from Dictionary <(Of String, Browser >).)
 | IDictionary.Values | (Inherited from Dictionary <(Of String, Browser >).)
 | IEnumerable.GetEnumerator() | (Inherited from Dictionary <(Of String, Browser >).)
 | Item(FrameInfo) | Get the frame based on its FrameInfo.
 | Item(Int32) | Get the frame at a specific index.
 | Item(String) | (Overrides Dictionary<(Of TKey, TValue>).Item(TKey).)
 | Keys | Gets a collection containing the keys in the Dictionary<(Of TKey, TValue>). (Inherited from Dictionary <(Of String, Browser >).)
 | MemberwiseClone() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OnDeserialization(Object) | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from Dictionary <(Of String, Browser >).)
 | RefreshAllDomTrees() | Refresh all dom trees in this frames collection.
 | Remove(String) | Removes the value with the specified key from the Dictionary<(Of TKey, TValue>). (Inherited from Dictionary <(Of String, Browser >).)
 | ToString() | Returns a String that represents the current Object. (Inherited from Object.)
 | TryGetValue(String, Browser) | (Inherited from Dictionary <(Of String, Browser >).)
 | Values | Gets a collection containing the values in the Dictionary<(Of TKey, TValue>). (Inherited from Dictionary <(Of String, Browser >).)
 | WaitAllUntilReady() | Waits until all frames are ready.
Inheritance Hierarchy
Object
 | Dictionary <(Of String, Browser >)
 |  | FramesCollection


ById(frameid) method

FramesCollection.ById(frameid) method
Namespaces > ArtOfTest.WebAii.Core > FramesCollection > ById(String)
Gets a frame using its id.
Syntax
C#
public Browser ById (
    string frameid
)
Parameters
frameid (String)
The frame id to find.
Return Value
The frame Browser object or else null.


FramesCollection() constructor

FramesCollection() constructor
Namespaces > ArtOfTest.WebAii.Core > FramesCollection > FramesCollectionNew()
Syntax
C#
public FramesCollection ()


GetEnumerator() method

FramesCollection.GetEnumerator() method
Namespaces > ArtOfTest.WebAii.Core > FramesCollection > GetEnumerator()
Get the enumerator.
Syntax
C#
public IEnumerator<Browser> GetEnumerator ()
Return Value
This collection's enumerator


Item properties

FramesCollection.Item properties
Namespaces > ArtOfTest.WebAii.Core > FramesCollection > Item
Members
Icon | Member | Description
 | Item(FrameInfo) | Get the frame based on its FrameInfo.
 | Item(Int32) | Get the frame at a specific index.
 | Item(String) | (Overrides Dictionary<(Of TKey, TValue>).Item(TKey).)


Item[frameInfo] property

FramesCollection.Item[frameInfo] property
Namespaces > ArtOfTest.WebAii.Core > FramesCollection > Item(FrameInfo)
Get the frame based on its FrameInfo.
Syntax
C#
public Browser this [
    FrameInfo frameInfo
] { get; }
Parameters
frameInfo (FrameInfo)
The frameinfo.
Return Value
The Frame, else null.


Item[index] property

FramesCollection.Item[index] property
Namespaces > ArtOfTest.WebAii.Core > FramesCollection > Item(Int32)
Get the frame at a specific index.
Syntax
C#
public Browser this [
    int index
] { get; }
Parameters
index (Int32)
The frame index.
Return Value
The frame object.


Item[name] property

FramesCollection.Item[name] property
Namespaces > ArtOfTest.WebAii.Core > FramesCollection > Item(String)
Syntax
C#
public Browser this [
    string name
] { get; }
Parameters
name (String)


RefreshAllDomTrees() method

FramesCollection.RefreshAllDomTrees() method
Namespaces > ArtOfTest.WebAii.Core > FramesCollection > RefreshAllDomTrees()
Refresh all dom trees in this frames collection.
Syntax
C#
public void RefreshAllDomTrees ()


WaitAllUntilReady() method

FramesCollection.WaitAllUntilReady() method
Namespaces > ArtOfTest.WebAii.Core > FramesCollection > WaitAllUntilReady()
Waits until all frames are ready.
Syntax
C#
public void WaitAllUntilReady ()


LocalWebServerType enumeration

LocalWebServerType enumeration
Namespaces > ArtOfTest.WebAii.Core > LocalWebServerType
Type of local web servers available for tests.
Syntax
C#
public enum LocalWebServerType
Members
Member | Description
None | No local web server is set.
AspNetDevelopmentServer | Requests are processed using ASP.NET Development Server. (aka Cassini)


Log class

Log class
Namespaces > ArtOfTest.WebAii.Core > Log
Log support for the framework and test cases.
Syntax
C#
public class Log : IDisposable
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CaptureBrowser(Browser) | Captures a visual snap shot of a specific browser instance and logs it to the log location. This function will also add the path to the image to the log file.
 | CaptureBrowser(Browser, String) | Captures a visual snap shot of a specific browser instance and logs it to the log location. This function will also add the path to the image to the log file.
 | CapturedBitmaps | A list of all captured bitmaps.
 | CaptureDesktop() | Captures the entire desktop to the log location.
 | CaptureDesktop(String) | Captures the entire desktop to the log location.
 | Dispose() | Dispose of this object.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | FileName | Full file name where we are doing the logging to.
 | Finalize() | Destructor (Overrides Object.Finalize().)
 | GetHashCode() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType() | Gets the Type of the current instance. (Inherited from Object.)
 | LogLocation | The log location on disk where were we are currently creating any logs.
 | LogWrite | This event is invoked everytime a WriteLine is invoked. External frameworks can attach to this event to capture logs from this framework to help unify their logging.
 | MemberwiseClone() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Text | Current string of the log. This is an snap shot of what is currently in the log.
 | ToString() | Returns a String that represents the current Object. (Inherited from Object.)
 | WriteLine(LogType, String) | Log information to the event log.
 | WriteLine(String) | Write a line to the log file.
Inheritance Hierarchy
Object
Log


CaptureBrowser methods

Log.CaptureBrowser methods
Namespaces > ArtOfTest.WebAii.Core > Log > CaptureBrowser
Members
Icon | Member | Description
 | CaptureBrowser(Browser) | Captures a visual snap shot of a specific browser instance and logs it to the log location. This function will also add the path to the image to the log file.
 | CaptureBrowser(Browser, String) | Captures a visual snap shot of a specific browser instance and logs it to the log location. This function will also add the path to the image to the log file.


CaptureBrowser(browserToCapture) method

Log.CaptureBrowser(browserToCapture) method
Namespaces > ArtOfTest.WebAii.Core > Log > CaptureBrowser(Browser)
Captures a visual snap shot of a specific browser instance and logs it to the log location. This function will also add the path to the image to the log file.
Syntax
C#
public void CaptureBrowser (
    Browser browserToCapture
)
Parameters
browserToCapture (Browser)
The browser instance to capture.


CaptureBrowser(browserToCapture, fileNamePrefix) method

Log.CaptureBrowser(browserToCapture, fileNamePrefix) method
Namespaces > ArtOfTest.WebAii.Core > Log > CaptureBrowser(Browser, String)
Captures a visual snap shot of a specific browser instance and logs it to the log location. This function will also add the path to the image to the log file.
Syntax
C#
public void CaptureBrowser (
    Browser browserToCapture,
    string fileNamePrefix
)
Parameters
browserToCapture (Browser)
The browser instance to capture.
fileNamePrefix (String)
The file name prefix to use on disk.


CapturedBitmaps property

Log.CapturedBitmaps property
Namespaces > ArtOfTest.WebAii.Core > Log > CapturedBitmaps
A list of all captured bitmaps.
Syntax
C#
public ReadOnlyCollection<Bitmap> CapturedBitmaps { get; }


CaptureDesktop methods

Log.CaptureDesktop methods
Namespaces > ArtOfTest.WebAii.Core > Log > CaptureDesktop
Members
Icon | Member | Description
 | CaptureDesktop() | Captures the entire desktop to the log location.
 | CaptureDesktop(String) | Captures the entire desktop to the log location.


CaptureDesktop() method

Log.CaptureDesktop() method
Namespaces > ArtOfTest.WebAii.Core > Log > CaptureDesktop()
Captures the entire desktop to the log location.
Syntax
C#
public void CaptureDesktop ()


CaptureDesktop(fileNamePrefix) method

Log.CaptureDesktop(fileNamePrefix) method
Namespaces > ArtOfTest.WebAii.Core > Log > CaptureDesktop(String)
Captures the entire desktop to the log location.
Syntax
C#
public void CaptureDesktop (
    string fileNamePrefix
)
Parameters
fileNamePrefix (String)
File name prefix to use.


Dispose() method

Log.Dispose() method
Namespaces > ArtOfTest.WebAii.Core > Log > Dispose()
Dispose of this object.
Syntax
C#
public void Dispose ()


FileName property

Log.FileName property
Namespaces > ArtOfTest.WebAii.Core > Log > FileName
Full file name where we are doing the logging to.
Syntax
C#
public string FileName { get; }


Finalize() method

Log.Finalize() method
Namespaces > ArtOfTest.WebAii.Core > Log > Finalize()
Destructor
Syntax
C#
protected override void Finalize ()


LogLocation property

Log.LogLocation property
Namespaces > ArtOfTest.WebAii.Core > Log > LogLocation
The log location on disk where were we are currently creating any logs.
Syntax
C#
public string LogLocation { get; }


LogWrite event

Log.LogWrite event
Namespaces > ArtOfTest.WebAii.Core > Log > LogWrite
This event is invoked everytime a WriteLine is invoked. External frameworks can attach to this event to capture logs from this framework to help unify their logging.
Syntax
C#
public event EventHandler<LogWriteEventArgs> LogWrite


Text property

Log.Text property
Namespaces > ArtOfTest.WebAii.Core > Log > Text
Current string of the log. This is an snap shot of what is currently in the log.
Syntax
C#
public string Text { get; }


WriteLine methods

Log.WriteLine methods
Namespaces > ArtOfTest.WebAii.Core > Log > WriteLine
Members
Icon | Member | Description
 | WriteLine(LogType, String) | Log information to the event log.
 | WriteLine(String) | Write a line to the log file.


WriteLine(message) method

Log.WriteLine(message) method
Namespaces > ArtOfTest.WebAii.Core > Log > WriteLine(String)
Write a line to the log file.
Syntax
C#
public void WriteLine (
    string message
)
Parameters
message (String)
The message to write.


WriteLine(type, message) method

Log.WriteLine(type, message) method
Namespaces > ArtOfTest.WebAii.Core > Log > WriteLine(LogType, String)
Log information to the event log.
Syntax
C#
public void WriteLine (
    LogType type,
    string message
)
Parameters
type (LogType)
message (String)


LogType enumeration

LogType enumeration
Namespaces > ArtOfTest.WebAii.Core > LogType
The types of logging available in WebAii.
Syntax
C#
public enum LogType
Members
Member | Description
Information | Logs information to the testcase log.
Error | Logs information to the testcase log and fails the test.
Trace | Logs information to the testcase log and the System.Diagnostics.Trace
EventLog | Logs information directly to the Application event log.


Manager class

Manager class
Namespaces > ArtOfTest.WebAii.Core > Manager
This class manages the life spans and instances of all browser objects in the framework. It also manages the communication pipeline between the framework and all browsers.
Syntax
C#
public class Manager : IDisposable
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ManagerNew(Boolean) | Create a new Manager.
 | ManagerNew(Settings) | Create a new Manager.
 | ActiveBrowser | Gets the last browser instance launched.
 | Browsers | Gets the array of browser instances connected to this instance of the Manager.
 | Current | Gets the current active manager object.
 | Desktop | Gets the Desktop object that can be used to invoke desktop input devices like Mouse, Keyboard events.
 | DialogMonitor | Gets the DialogMonitor object that handles popup dialogs
 | DisconnectClient(String) | Disconnects the specific client. If the client is already disconnected, will simply return.
 | Dispose() | Dispose of resources controlled by this object.
 | Elements | Gets the element finder to be used for finding elements defined by the FindParam attributes. This Elements object replaces all the Find.Elements since current FindParamAttributes are not frames and test region aware.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize() | Destructor (Overrides Object.Finalize().)
 | GetHashCode() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType() | Gets the Type of the current instance. (Inherited from Object.)
 | IsClientConnected(String) | Verifies if a specific client is connected or not to this manager.
 | LaunchNewBrowser() | Launch a new browser using default settings. Waits for browser to connect.
 | LaunchNewBrowser(BrowserType) | Launch a new browser of the selected type and wait for it to connect.
 | LaunchNewBrowser(BrowserType, Boolean) | Launch a new browser of the specified BrowserType.
 | LaunchNewBrowser(BrowserType, Boolean, ProcessWindowStyle) | Launch a new browser.
 | LaunchNewBrowser(ProcessWindowStyle) | Launch a new browser using the default setting and the sets the browser window style. Waits for browser to connect.
 | Log | Gets the Log object.
 | MemberwiseClone() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OnBrowserResponseAvailable(BrowserCommandEventArgs) | Invoke the BrowserResponseAvailable event.
 | OnClientConnected(ClientConnectedEventArgs) | On client connected.
 | OnClientDisconnected(ClientDisconnectedEventArgs) | On client disconnected.
 | PostRequestToBrowser(BrowserCommand, String) | Broadcast a command request to all browser instances currently connected to this manager.
 | RemoveBrowser(String) | Remove a browser from collection
 | SetNewBrowserTracking(Boolean) | Enable or disable new browser tracking. Use to track pop-up browser windows. When enabled, new pop-up browser windows will be added to the browsers[] collection.
 | Settings | Gets the settings object that this Manager instance was initialized with.
 | Start() | Initialize the communication pipelines.
 | ToString() | Returns a String that represents the current Object. (Inherited from Object.)
 | Wait | Gets a wait object that can be used to wait on specific actions on elements/controls or custom predicate actions
 | WaitForNewBrowserConnect(String, Boolean, Int32) | Wait for a specific browser instance to connect using a timeout.
Inheritance Hierarchy
Object
Manager


ActiveBrowser property

Manager.ActiveBrowser property
Namespaces > ArtOfTest.WebAii.Core > Manager > ActiveBrowser
Gets the last browser instance launched.
Syntax
C#
public Browser ActiveBrowser { get; }


Browsers property

Manager.Browsers property
Namespaces > ArtOfTest.WebAii.Core > Manager > Browsers
Gets the array of browser instances connected to this instance of the Manager.
Syntax
C#
public ReadOnlyCollection<Browser> Browsers { get; }


Constructors

Manager constructors
Namespaces > ArtOfTest.WebAii.Core > Manager > ManagerNew
Members
Icon | Member | Description
 | ManagerNew(Settings) | Create a new Manager.
 | ManagerNew(Boolean) | Create a new Manager.


Manager(settings) constructor

Manager(settings) constructor
Namespaces > ArtOfTest.WebAii.Core > Manager > ManagerNew(Settings)
Create a new Manager.
Syntax
C#
public Manager (
    Settings settings
)
Parameters
settings (Settings)
The settings object that specifies the settings to initialize the framework with. These settings are propagated through out the framework objects.


Manager(UseConfig) constructor

Manager(UseConfig) constructor
Namespaces > ArtOfTest.WebAii.Core > Manager > ManagerNew(Boolean)
Create a new Manager.
Syntax
C#
public Manager (
    bool UseConfig
)
Parameters
UseConfig (Boolean)
If set to true, the manager will load the setting from the config. Else will use the default settings.


Current property

Manager.Current property
Namespaces > ArtOfTest.WebAii.Core > Manager > Current
Gets the current active manager object.
Syntax
C#
public static Manager Current { get; }


Desktop property

Manager.Desktop property
Namespaces > ArtOfTest.WebAii.Core > Manager > Desktop
Gets the Desktop object that can be used to invoke desktop input devices like Mouse, Keyboard events.
Syntax
C#
public Desktop Desktop { get; }


DialogMonitor property

Manager.DialogMonitor property
Namespaces > ArtOfTest.WebAii.Core > Manager > DialogMonitor
Gets the DialogMonitor object that handles popup dialogs
Syntax
C#
public DialogMonitor DialogMonitor { get; }


DisconnectClient(clientId) method

Manager.DisconnectClient(clientId) method
Namespaces > ArtOfTest.WebAii.Core > Manager > DisconnectClient(String)
Disconnects the specific client. If the client is already disconnected, will simply return.
Syntax
C#
public void DisconnectClient (
    string clientId
)
Parameters
clientId (String)
The clientId of the client to disconnect.


Dispose() method

Manager.Dispose() method
Namespaces > ArtOfTest.WebAii.Core > Manager > Dispose()
Dispose of resources controlled by this object.
Syntax
C#
public void Dispose ()


Elements property

Manager.Elements property
Namespaces > ArtOfTest.WebAii.Core > Manager > Elements
Gets the element finder to be used for finding elements defined by the FindParam attributes. This Elements object replaces all the Find.Elements since current FindParamAttributes are not frames and test region aware.
Syntax
C#
public ElementFinder Elements { get; }


Finalize() method

Manager.Finalize() method
Namespaces > ArtOfTest.WebAii.Core > Manager > Finalize()
Destructor
Syntax
C#
protected override void Finalize ()


IsClientConnected(clientId) method

Manager.IsClientConnected(clientId) method
Namespaces > ArtOfTest.WebAii.Core > Manager > IsClientConnected(String)
Verifies if a specific client is connected or not to this manager.
Syntax
C#
public bool IsClientConnected (
    string clientId
)
Parameters
clientId (String)
The client id to check.
Return Value
True/False whether this client is connected or not.


LaunchNewBrowser methods

Manager.LaunchNewBrowser methods
Namespaces > ArtOfTest.WebAii.Core > Manager > LaunchNewBrowser
Members
Icon | Member | Description
 | LaunchNewBrowser() | Launch a new browser using default settings. Waits for browser to connect.
 | LaunchNewBrowser(BrowserType) | Launch a new browser of the selected type and wait for it to connect.
 | LaunchNewBrowser(BrowserType, Boolean) | Launch a new browser of the specified BrowserType.
 | LaunchNewBrowser(BrowserType, Boolean, ProcessWindowStyle) | Launch a new browser.
 | LaunchNewBrowser(ProcessWindowStyle) | Launch a new browser using the default setting and the sets the browser window style. Waits for browser to connect.


LaunchNewBrowser() method

Manager.LaunchNewBrowser() method
Namespaces > ArtOfTest.WebAii.Core > Manager > LaunchNewBrowser()
Launch a new browser using default settings. Waits for browser to connect.
Syntax
C#
public void LaunchNewBrowser ()


LaunchNewBrowser(browserToLaunch) method

Manager.LaunchNewBrowser(browserToLaunch) method
Namespaces > ArtOfTest.WebAii.Core > Manager > LaunchNewBrowser(BrowserType)
Launch a new browser of the selected type and wait for it to connect.
Syntax
C#
public void LaunchNewBrowser (
    BrowserType browserToLaunch
)
Parameters
browserToLaunch (BrowserType)
The browser type to launch.


LaunchNewBrowser(browserToLaunch, waitForBrowserToConnect) method

Manager.LaunchNewBrowser(browserToLaunch, waitForBrowserToConnect) method
Namespaces > ArtOfTest.WebAii.Core > Manager > LaunchNewBrowser(BrowserType, Boolean)
Launch a new browser of the specified BrowserType.
Syntax
C#
public void LaunchNewBrowser (
    BrowserType browserToLaunch,
    bool waitForBrowserToConnect
)
Parameters
browserToLaunch (BrowserType)
The browser type to launch.
waitForBrowserToConnect (Boolean)
Whether to wait for the browser to connect and be ready.


LaunchNewBrowser(browserToLaunch, waitForBrowserToConnect, windowStyle) method

Manager.LaunchNewBrowser(browserToLaunch, waitForBrowserToConnect, windowStyle) method
Namespaces > ArtOfTest.WebAii.Core > Manager > LaunchNewBrowser(BrowserType, Boolean, ProcessWindowStyle)
Launch a new browser.
Syntax
C#
public void LaunchNewBrowser (
    BrowserType browserToLaunch,
    bool waitForBrowserToConnect,
    ProcessWindowStyle windowStyle
)
Parameters
browserToLaunch (BrowserType)
The browser to launch.
waitForBrowserToConnect (Boolean)
True/False to wait for the browser to connect or not.
windowStyle (ProcessWindowStyle)
The window style to launch the browser in.


LaunchNewBrowser(windowStyle) method

Manager.LaunchNewBrowser(windowStyle) method
Namespaces > ArtOfTest.WebAii.Core > Manager > LaunchNewBrowser(ProcessWindowStyle)
Launch a new browser using the default setting and the sets the browser window style. Waits for browser to connect.
Syntax
C#
public void LaunchNewBrowser (
    ProcessWindowStyle windowStyle
)
Parameters
windowStyle (ProcessWindowStyle)
The window style to launch the browser in.


Log property

Manager.Log property
Namespaces > ArtOfTest.WebAii.Core > Manager > Log
Gets the Log object.
Syntax
C#
public Log Log { get; set; }


OnBrowserResponseAvailable(e) method

Manager.OnBrowserResponseAvailable(e) method
Namespaces > ArtOfTest.WebAii.Core > Manager > OnBrowserResponseAvailable(BrowserCommandEventArgs)
Invoke the BrowserResponseAvailable event.
Syntax
C#
protected virtual void OnBrowserResponseAvailable (
    BrowserCommandEventArgs e
)
Parameters
e (BrowserCommandEventArgs)
Response event arguments.


OnClientConnected(e) method

Manager.OnClientConnected(e) method
Namespaces > ArtOfTest.WebAii.Core > Manager > OnClientConnected(ClientConnectedEventArgs)
On client connected.
Syntax
C#
protected virtual void OnClientConnected (
    ClientConnectedEventArgs e
)
Parameters
e (ClientConnectedEventArgs)
ClientConnectedEventArgs.


OnClientDisconnected(e) method

Manager.OnClientDisconnected(e) method
Namespaces > ArtOfTest.WebAii.Core > Manager > OnClientDisconnected(ClientDisconnectedEventArgs)
On client disconnected.
Syntax
C#
protected virtual void OnClientDisconnected (
    ClientDisconnectedEventArgs e
)
Parameters
e (ClientDisconnectedEventArgs)
ClientDisconnectedEventArgs.


PostRequestToBrowser(request, requestId) method

Manager.PostRequestToBrowser(request, requestId) method
Namespaces > ArtOfTest.WebAii.Core > Manager > PostRequestToBrowser(BrowserCommand, String)
Broadcast a command request to all browser instances currently connected to this manager.
Syntax
C#
public void PostRequestToBrowser (
    BrowserCommand request,
    string requestId
)
Parameters
request (BrowserCommand)
The command request to broadcast.
requestId (String)
The request unique id.


RemoveBrowser(clientId) method

Manager.RemoveBrowser(clientId) method
Namespaces > ArtOfTest.WebAii.Core > Manager > RemoveBrowser(String)
Remove a browser from collection
Syntax
C#
public void RemoveBrowser (
    string clientId
)
Parameters
clientId (String)
The browser client ID.


SetNewBrowserTracking(enable) method

Manager.SetNewBrowserTracking(enable) method
Namespaces > ArtOfTest.WebAii.Core > Manager > SetNewBrowserTracking(Boolean)
Enable or disable new browser tracking. Use to track pop-up browser windows. When enabled, new pop-up browser windows will be added to the browsers[] collection.
Syntax
C#
public void SetNewBrowserTracking (
    bool enable
)
Parameters
enable (Boolean)
True/false whether to enable/disable new browser tracking.


Settings property

Manager.Settings property
Namespaces > ArtOfTest.WebAii.Core > Manager > Settings
Gets the settings object that this Manager instance was initialized with.
Syntax
C#
public Settings Settings { get; }


Start() method

Manager.Start() method
Namespaces > ArtOfTest.WebAii.Core > Manager > Start()
Initialize the communication pipelines.
Syntax
C#
public void Start ()


Wait property

Manager.Wait property
Namespaces > ArtOfTest.WebAii.Core > Manager > Wait
Gets a wait object that can be used to wait on specific actions on elements/controls or custom predicate actions
Syntax
C#
public WaitSync Wait { get; }


WaitForNewBrowserConnect(url, isPartial, timeout) method

Manager.WaitForNewBrowserConnect(url, isPartial, timeout) method
Namespaces > ArtOfTest.WebAii.Core > Manager > WaitForNewBrowserConnect(String, Boolean, Int32)
Wait for a specific browser instance to connect using a timeout.
Syntax
C#
public void WaitForNewBrowserConnect (
    string url,
    bool isPartial,
    int timeout
)
Parameters
url (String)
The url to use to check the browser.
isPartial (Boolean)
Whether to check the url using partial compares.
timeout (Int32)
The timeout for the wait.


MouseClickType enumeration

MouseClickType enumeration
Namespaces > ArtOfTest.WebAii.Core > MouseClickType
The different types of mouse events to perform.
Syntax
C#
public enum MouseClickType
Members
Member | Description
LeftClick | A left mouse button click.
RightClick | A right mouse button click.
MiddleClick | A middle mouse button click.
LeftDoubleClick | A left mouse button double-click.
LeftDown | A single left mouse button down.
LeftUp | A single left mouse button up.
RightDown | A single right mouse button down.
RightUp | A single right mouse button up.
MiddleDown | A single middle mouse button down.
MiddleUp | A single middle mouse button up.
Wheel | A mouse wheel move.


MouseWheelTurnDirection enumeration

MouseWheelTurnDirection enumeration
Namespaces > ArtOfTest.WebAii.Core > MouseWheelTurnDirection
The mouse wheel turn directions.
Syntax
C#
public enum MouseWheelTurnDirection
Members
Member | Description
Backward | Turn backwards.
Forward | Turn forward.


OffsetReference enumeration

OffsetReference enumeration
Namespaces > ArtOfTest.WebAii.Core > OffsetReference
Offset references used to adjust the target point (X,Y) of an action.
Syntax
C#
public enum OffsetReference
Members
Member | Description
TopLeftCorner | The reference is the top left corner of the target.
BottomLeftCorner | The reference is the bottom left corner of the target.
TopRightCorner | The reference is the top right corner of the target.
BottomRightCorner | The reference is the bottom right corner of the target.
TopCenter | The reference is the center point of the top edge of the target.
RightCenter | The reference is the center point of the right edge of the target.
LeftCenter | The reference is the center point of the left edge of the target.
BottomCenter | The reference is the center point of the bottom edge of the target.
AbsoluteCenter | The reference is the absolute center of the target.
Examples
  Given a Rectangle target, the reference points are as follows:

  TopLeft             TopCenter       TopRight
             X***********X***********X
             *                       *
             *                       *
  LeftCenter X           X           X RightCenter
             *     AbsoluteCenter    *
             *                       *
             X***********X***********X
  BottomLeft         BottomCenter      BottomRight


ScriptEventType enumeration

ScriptEventType enumeration
Namespaces > ArtOfTest.WebAii.Core > ScriptEventType
Type of script events that can be invoked on an html element.
Syntax
C#
public enum ScriptEventType
Members
Member | Description
OnLoad | onload event.
OnUnload | onunload event.
OnChange | onchange event.
OnSubmit | onsubmit event.
OnReset | onreset event.
OnSelect | onselect event.
OnBlur | onblur event.
OnFocus | onblur event.
OnKeyDown | onkeydown event.
OnKeyPress | onkeypress event.
OnKeyUp | onkeyup event.
OnClick | onclick event.
OnDblClick | ondblclick event.
OnMouseDown | onmousedown event.
OnMouseMove | onmousemove event.
OnMouseOut | onmouseout event.
OnMouseOver | onmouseover event.
OnMouseUp | onmouseup event.


ScrollToVisibleType enumeration

ScrollToVisibleType enumeration
Namespaces > ArtOfTest.WebAii.Core > ScrollToVisibleType
Used to configure what the default scroll to visible behavior is.
Syntax
C#
public enum ScrollToVisibleType
Members
Member | Description
ElementTopAtWindowTop | Scrolls the element so that top of the element is visible at the top of the window. [Default]
ElementBottomAtWindowBottom | Scrolls the element so that the bottom of the element is visible at the bottom of the window


Settings class

Settings class
Namespaces > ArtOfTest.WebAii.Core > Settings
Class representing the settings to be used when initializing the framework.
Syntax
C#
[SerializableAttribute]
[XmlRootAttribute]
public class Settings
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SettingsNew() | Create a new Settings object.
 | SettingsNew(BrowserType, String) | Create a new Settings object.
 | SettingsNew(BrowserType, String, String) | Create a new Settings object.
 | SettingsNew(Settings) | Create a clone of the passed in settings
 | SettingsNew(SettingsConfigSectionHandler) | Create a new Settings object from a config section.
 | SettingsNew(String) | Create a new Settings object.
 | AnnotateExecution | Gets/Sets whether to highlight/annotate the target elements that action is being executed against. Default is false.
 | AnnotationMode | Gets/Sets the annotation mode when annotation is enabled. Default is All
 | AspNetDevServerPhysicalPath | Gets the physical path
 | AspNetDevServerPort | Gets/Sets the AspNetDevServer (if use) port. If this is not set (-1) a random port will be generated each time the manager is created.
 | BaseUrl | Gets/Sets the base url to use for all NavigateTo commands. When set NavigateTo should use a relative url (i.e. "~/default.aspx"). Default is string.empty.
 | ClientReadyTimeout | Gets/Sets timeout used to wait for a client to be ready after first launch and after executing a command. (msec.). Default is 20000 msec.
 | Clone() | Clone the existing settings
 | CreateLogFile | Gets or sets whether to create a log file on disk. This value is read once at initialization time. Changing this value during test execution has no effect. Default is true
 | Current | The current settings object.
 | DefaultBrowser | Gets/Sets a supported default browser type (IE,FireFox ...etc). Default is InternetExplorer.
 | EnableScriptLogging | Gets/Sets whether to enable script logging or not. Default is false.
 | EnableUILessRequestViewing | Gets/Sets whether to allow debugging of UILess page requests using a UI browser like IE. Default is false.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | ExecuteCommandTimeout | Gets/Sets The time out to wait for a command request to execute. (msec.). Default is 30000 msec.
 | ExecutionDelay | Gets/Sets an execution delay between commands. This can help in observing test execution. Default is zero.
 | Finalize() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType() | Gets the Type of the current instance. (Inherited from Object.)
 | IsStressRecordingMode | Set by the recorder to indicate a stress recorder mode. This property is not persisted and is NOT configurable using the .config file
 | IsUserInteractiveMode | Gets whether the test is running in a user interactive mode or as non-user interactive.
 | KillBrowserProcessOnClose | Gets or sets whether to make sure the browser process is killed when closing the browser. Note: Firefox is a single process browser. If you are using multiple browser instances and this setting is on, it will kill all open instances of Firefox when close on of the instances. Default is false.
 | LocalWebServer | Gets/Sets the local web server to use to server pages. Default is None.
 | LogAnnotations | Gets/Sets whether to log annotations to the log file. Default is false.
 | LogLocation | Gets/Sets the location where to perform all the logging. Default is C:\WebAiiLog\.
 | MemberwiseClone() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | QueryEventLogErrorsOnExit | Gets/Sets whether to query the event log on manager exit for any error logged from automation clients. Any errors will be logged to the test log. Default is false.
 | Reset() | Resets all settings to the default system settings of the infrastructure. Examples The following are the system default settings: DefaultBrowser=InternetExplorer ClientReadyTimeout=30000 ExecutionCommandTimeout=20000 LogLocation='C:\WebAiiLog\' WebAppPhysicalPath="" EnableScriptLogging=false QueryEventLogErrorsOnExit=false LocalWebServer=LocalWebServerType.None EnableUILessRequestViewing=false BaseUrl="" ExecutionDelay=0 AnnotateExecution=false SimulatedMouseMoveSpeed=0.3f waitCheckInterval=500 aspNetDevServer=-1 annotationMode=All logAnnotations=false createLogFile=true killBrowserProcessOnClose=false
 | SimulatedMouseMoveSpeed | Gets/Sets the simulated mouse move speed for Desktop.Mouse.Move()/DragDrop() operations in pixels/msec. [Typically between 0.1f - .5f] Default is 0.3f
 | ToString() | Returns a String that represents the current Object. (Inherited from Object.)
 | Validate() | Validate the settings.
 | WaitCheckInterval | Gets/Sets the interval in msec. to use between checks for all the WaitForxx methods. Default is 500 msec.
 | WebAppPhysicalPath | Gets/Sets the physical path of the application when running under the ASP.NET Development Server. Default is string.empty. Examples C:\Inetpub\wwwroot\myApp\
Inheritance Hierarchy
Object
Settings


AnnotateExecution property

Settings.AnnotateExecution property
Namespaces > ArtOfTest.WebAii.Core > Settings > AnnotateExecution
Gets/Sets whether to highlight/annotate the target elements that action is being executed against. Default is false.
Syntax
C#
[XmlElementAttribute]
public bool AnnotateExecution { get; set; }


AnnotationMode property

Settings.AnnotationMode property
Namespaces > ArtOfTest.WebAii.Core > Settings > AnnotationMode
Gets/Sets the annotation mode when annotation is enabled. Default is All
Syntax
C#
[XmlElementAttribute]
public AnnotationMode AnnotationMode { get; set; }


AspNetDevServerPhysicalPath property

Settings.AspNetDevServerPhysicalPath property
Namespaces > ArtOfTest.WebAii.Core > Settings > AspNetDevServerPhysicalPath
Gets the physical path
Syntax
C#
public string AspNetDevServerPhysicalPath { get; }


AspNetDevServerPort property

Settings.AspNetDevServerPort property
Namespaces > ArtOfTest.WebAii.Core > Settings > AspNetDevServerPort
Gets/Sets the AspNetDevServer (if use) port. If this is not set (-1) a random port will be generated each time the manager is created.
Syntax
C#
[XmlElementAttribute]
public int AspNetDevServerPort { get; set; }


BaseUrl property

Settings.BaseUrl property
Namespaces > ArtOfTest.WebAii.Core > Settings > BaseUrl
Gets/Sets the base url to use for all NavigateTo commands. When set NavigateTo should use a relative url (i.e. "~/default.aspx"). Default is string.empty.
Syntax
C#
[XmlElementAttribute]
public string BaseUrl { get; set; }


ClientReadyTimeout property

Settings.ClientReadyTimeout property
Namespaces > ArtOfTest.WebAii.Core > Settings > ClientReadyTimeout
Gets/Sets timeout used to wait for a client to be ready after first launch and after executing a command. (msec.). Default is 20000 msec.
Syntax
C#
[XmlElementAttribute]
public int ClientReadyTimeout { get; set; }


Clone() method

Settings.Clone() method
Namespaces > ArtOfTest.WebAii.Core > Settings > Clone()
Clone the existing settings
Syntax
C#
public Settings Clone ()
Return Value
The cloned settings


Constructors

Settings constructors
Namespaces > ArtOfTest.WebAii.Core > Settings > SettingsNew
Members
Icon | Member | Description
 | SettingsNew() | Create a new Settings object.
 | SettingsNew(BrowserType, String) | Create a new Settings object.
 | SettingsNew(BrowserType, String, String) | Create a new Settings object.
 | SettingsNew(Settings) | Create a clone of the passed in settings
 | SettingsNew(SettingsConfigSectionHandler) | Create a new Settings object from a config section.
 | SettingsNew(String) | Create a new Settings object.


Settings() constructor

Settings() constructor
Namespaces > ArtOfTest.WebAii.Core > Settings > SettingsNew()
Create a new Settings object.
Syntax
C#
public Settings ()


Settings(baseUrl) constructor

Settings(baseUrl) constructor
Namespaces > ArtOfTest.WebAii.Core > Settings > SettingsNew(String)
Create a new Settings object.
Syntax
C#
public Settings (
    string baseUrl
)
Parameters
baseUrl (String)
The baseUrl to use


Settings(defaultBrowser, logLocation) constructor

Settings(defaultBrowser, logLocation) constructor
Namespaces > ArtOfTest.WebAii.Core > Settings > SettingsNew(BrowserType, String)
Create a new Settings object.
Syntax
C#
public Settings (
    BrowserType defaultBrowser,
    string logLocation
)
Parameters
defaultBrowser (BrowserType)
The default browser to use.
logLocation (String)
The log location where to do the logging.


Settings(defaultBrowser, logLocation, baseUrl) constructor

Settings(defaultBrowser, logLocation, baseUrl) constructor
Namespaces > ArtOfTest.WebAii.Core > Settings > SettingsNew(BrowserType, String, String)
Create a new Settings object.
Syntax
C#
public Settings (
    BrowserType defaultBrowser,
    string logLocation,
    string baseUrl
)
Parameters
defaultBrowser (BrowserType)
The default browser to use.
logLocation (String)
The log location where to do the logging.
baseUrl (String)
The baseUrl to use.


Settings(sectionHandler) constructor

Settings(sectionHandler) constructor
Namespaces > ArtOfTest.WebAii.Core > Settings > SettingsNew(SettingsConfigSectionHandler)
Create a new Settings object from a config section.
Syntax
C#
public Settings (
    SettingsConfigSectionHandler sectionHandler
)
Parameters
sectionHandler (SettingsConfigSectionHandler)
The config section handler that contains the settings.


Settings(settingsToClone) constructor

Settings(settingsToClone) constructor
Namespaces > ArtOfTest.WebAii.Core > Settings > SettingsNew(Settings)
Create a clone of the passed in settings
Syntax
C#
public Settings (
    Settings settingsToClone
)
Parameters
settingsToClone (Settings)


CreateLogFile property

Settings.CreateLogFile property
Namespaces > ArtOfTest.WebAii.Core > Settings > CreateLogFile
Gets or sets whether to create a log file on disk. This value is read once at initialization time. Changing this value during test execution has no effect. Default is true
Syntax
C#
[XmlElementAttribute]
public bool CreateLogFile { get; set; }


Current property

Settings.Current property
Namespaces > ArtOfTest.WebAii.Core > Settings > Current
The current settings object.
Syntax
C#
public static Settings Current { get; }


DefaultBrowser property

Settings.DefaultBrowser property
Namespaces > ArtOfTest.WebAii.Core > Settings > DefaultBrowser
Gets/Sets a supported default browser type (IE,FireFox ...etc). Default is InternetExplorer.
Syntax
C#
[XmlElementAttribute]
public BrowserType DefaultBrowser { get; set; }


EnableScriptLogging property

Settings.EnableScriptLogging property
Namespaces > ArtOfTest.WebAii.Core > Settings > EnableScriptLogging
Gets/Sets whether to enable script logging or not. Default is false.
Syntax
C#
[XmlElementAttribute]
public bool EnableScriptLogging { get; set; }


EnableUILessRequestViewing property

Settings.EnableUILessRequestViewing property
Namespaces > ArtOfTest.WebAii.Core > Settings > EnableUILessRequestViewing
Gets/Sets whether to allow debugging of UILess page requests using a UI browser like IE. Default is false.
Syntax
C#
[XmlElementAttribute]
public bool EnableUILessRequestViewing { get; set; }


ExecuteCommandTimeout property

Settings.ExecuteCommandTimeout property
Namespaces > ArtOfTest.WebAii.Core > Settings > ExecuteCommandTimeout
Gets/Sets The time out to wait for a command request to execute. (msec.). Default is 30000 msec.
Syntax
C#
[XmlElementAttribute]
public int ExecuteCommandTimeout { get; set; }


ExecutionDelay property

Settings.ExecutionDelay property
Namespaces > ArtOfTest.WebAii.Core > Settings > ExecutionDelay
Gets/Sets an execution delay between commands. This can help in observing test execution. Default is zero.
Syntax
C#
[XmlElementAttribute]
public int ExecutionDelay { get; set; }


IsStressRecordingMode property

Settings.IsStressRecordingMode property
Namespaces > ArtOfTest.WebAii.Core > Settings > IsStressRecordingMode
Set by the recorder to indicate a stress recorder mode. This property is not persisted and is NOT configurable using the .config file
Syntax
C#
public bool IsStressRecordingMode { get; set; }


IsUserInteractiveMode property

Settings.IsUserInteractiveMode property
Namespaces > ArtOfTest.WebAii.Core > Settings > IsUserInteractiveMode
Gets whether the test is running in a user interactive mode or as non-user interactive.
Syntax
C#
public bool IsUserInteractiveMode { get; }


KillBrowserProcessOnClose property

Settings.KillBrowserProcessOnClose property
Namespaces > ArtOfTest.WebAii.Core > Settings > KillBrowserProcessOnClose
Gets or sets whether to make sure the browser process is killed when closing the browser. Note: Firefox is a single process browser. If you are using multiple browser instances and this setting is on, it will kill all open instances of Firefox when close on of the instances. Default is false.
Syntax
C#
public bool KillBrowserProcessOnClose { get; set; }


LocalWebServer property

Settings.LocalWebServer property
Namespaces > ArtOfTest.WebAii.Core > Settings > LocalWebServer
Gets/Sets the local web server to use to server pages. Default is None.
Syntax
C#
[XmlElementAttribute]
public LocalWebServerType LocalWebServer { get; set; }


LogAnnotations property

Settings.LogAnnotations property
Namespaces > ArtOfTest.WebAii.Core > Settings > LogAnnotations
Gets/Sets whether to log annotations to the log file. Default is false.
Syntax
C#
[XmlElementAttribute]
public bool LogAnnotations { get; set; }


LogLocation property

Settings.LogLocation property
Namespaces > ArtOfTest.WebAii.Core > Settings > LogLocation
Gets/Sets the location where to perform all the logging. Default is C:\WebAiiLog\.
Syntax
C#
[XmlElementAttribute]
public string LogLocation { get; set; }


QueryEventLogErrorsOnExit property

Settings.QueryEventLogErrorsOnExit property
Namespaces > ArtOfTest.WebAii.Core > Settings > QueryEventLogErrorsOnExit
Gets/Sets whether to query the event log on manager exit for any error logged from automation clients. Any errors will be logged to the test log. Default is false.
Syntax
C#
[XmlElementAttribute]
public bool QueryEventLogErrorsOnExit { get; set; }


Reset() method

Settings.Reset() method
Namespaces > ArtOfTest.WebAii.Core > Settings > Reset()
Resets all settings to the default system settings of the infrastructure.
Examples
The following are the system default settings:

DefaultBrowser=InternetExplorer
ClientReadyTimeout=30000
ExecutionCommandTimeout=20000
LogLocation='C:\WebAiiLog\'
WebAppPhysicalPath=""
EnableScriptLogging=false
QueryEventLogErrorsOnExit=false
LocalWebServer=LocalWebServerType.None
EnableUILessRequestViewing=false
BaseUrl=""
ExecutionDelay=0
AnnotateExecution=false
SimulatedMouseMoveSpeed=0.3f
waitCheckInterval=500
aspNetDevServer=-1
annotationMode=All
logAnnotations=false
createLogFile=true
killBrowserProcessOnClose=false
Syntax
C#
public void Reset ()


SimulatedMouseMoveSpeed property

Settings.SimulatedMouseMoveSpeed property
Namespaces > ArtOfTest.WebAii.Core > Settings > SimulatedMouseMoveSpeed
Gets/Sets the simulated mouse move speed for Desktop.Mouse.Move()/DragDrop() operations in pixels/msec. [Typically between 0.1f - .5f] Default is 0.3f
Syntax
C#
[XmlElementAttribute]
public float SimulatedMouseMoveSpeed { get; set; }


Validate() method

Settings.Validate() method
Namespaces > ArtOfTest.WebAii.Core > Settings > Validate()
Validate the settings.
Syntax
C#
public void Validate ()


WaitCheckInterval property

Settings.WaitCheckInterval property
Namespaces > ArtOfTest.WebAii.Core > Settings > WaitCheckInterval
Gets/Sets the interval in msec. to use between checks for all the WaitForxx methods. Default is 500 msec.
Syntax
C#
[XmlElementAttribute]
public int WaitCheckInterval { get; set; }


WebAppPhysicalPath property

Settings.WebAppPhysicalPath property
Namespaces > ArtOfTest.WebAii.Core > Settings > WebAppPhysicalPath
Gets/Sets the physical path of the application when running under the ASP.NET Development Server. Default is string.empty.
Examples
C:\Inetpub\wwwroot\myApp\
Syntax
C#
[XmlElementAttribute]
public string WebAppPhysicalPath { get; set; }


SettingsConfigSectionHandler class

SettingsConfigSectionHandler class
Namespaces > ArtOfTest.WebAii.Core > SettingsConfigSectionHandler
Settings object config section handler. Use this object to read a Settings config section in a .config file.
Examples
   You can persist the settings for your application/test cases in a config file.

   The following is a sample config file that holds certain settings. Any settings
   not specified in this section, their values will be set to the system defaults:

   <?xml version="1.0" encoding="utf-8" ?>
      <configuration>
          <configSections>
              <section name="WebAii.Settings" type="ArtOfTest.WebAii.Core.SettingsConfigSectionHandler,ArtOfTest.WebAii"/>
          </configSections>

      <WebAii.Settings
          defaultBrowser="InternetExplorer"
          logLocation="D:\Log\"
          executionTimeout="30000"
          clientReadyTimeout="20000"
          localWebServer="None";
          webAppPhysicalPath="c:\Inetpub\wwwroot\MyApplication"
          enableScriptLogging="false"
          queryEventLogErrorsOnExit="false"
          enableUILessRequestViewing="false"
          baseUrl="http://www.testsite.com/"
          executionDelay="0"
          annotateExecution="false"
          annotationMode="All"
          logAnnotations="false"
          simulatedMouseMoveSpeed="0.3f"
          waitCheckInterval="500"
          aspNetDevServerPort="-1"
          createLogFile="true"
          killBrowserProcessOnClose="false"
      />

      </configuration>

   In your code, you can get these settings by using the SettingsConfigSectionHandler like this:

   SettingsConfigSectionHandler settingsSection =
               (SettingsConfigSectionHandler)ConfigurationManager.GetSection("WebAii.Settings");
   Settings mySettings = new Settings(settingsSection);

   You can then use mySettings to pass in to the Manager constructor.

Syntax
C#
public class SettingsConfigSectionHandler : ConfigurationSection
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SettingsConfigSectionHandlerNew() |
 | AnnotateExecution | Whether to enable execution highlight.
 | AnnotationMode | Gets the annotation mode.
 | AspNetDevServerPort | Gets the AspNetDevServer port if set.
 | BaseUrl | The base url to use for all NavigateTo actions in the framework.
 | ClientReadyTimeout | Gets the client ready timeout.
 | CreateLogFile | Gets whether to create a log file on disk.
 | DefaultBrowser | Gets the default browser used by the Manager when none is specified.
 | DeserializeElement(XmlReader, Boolean) | Reads XML from the configuration file. (Inherited from ConfigurationElement.)
 | DeserializeSection(XmlReader) | Reads XML from the configuration file. (Inherited from ConfigurationSection.)
 | ElementInformation | Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object. (Inherited from ConfigurationElement.)
 | ElementProperty | Gets the ConfigurationElementProperty object that represents the ConfigurationElement object itself. (Inherited from ConfigurationElement.)
 | EnableScriptLogging | Gets whether to enable script logging or not.
 | EnableUILessRequestViewing | Whether to enable debugging of the UILess page requests using a UI browser like IE.
 | Equals(Object) | Compares the current ConfigurationElement instance to the specified object. (Inherited from ConfigurationElement.)
 | EvaluationContext | Gets the ContextInformation object for the ConfigurationElement object. (Inherited from ConfigurationElement.)
 | ExecutionDelay | The execution delay set.
 | ExecutionTimeout | Gets the Execution timeout for commands.
 | Finalize() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode() | Gets a unique value representing the current ConfigurationElement instance. (Inherited from ConfigurationElement.)
 | GetRuntimeObject() | Returns a custom object when overridden in a derived class. (Inherited from ConfigurationSection.)
 | GetType() | Gets the Type of the current instance. (Inherited from Object.)
 | Init() | Sets the ConfigurationElement object to its initial state. (Inherited from ConfigurationElement.)
 | InitializeDefault() | Used to initialize a default set of values for the ConfigurationElement object. (Inherited from ConfigurationElement.)
 | IsModified() | Indicates whether this configuration element has been modified since it was last saved or loaded when implemented in a derived class. (Inherited from ConfigurationSection.)
 | IsReadOnly() | Gets a value indicating whether the ConfigurationElement object is read-only. (Inherited from ConfigurationElement.)
 | Item(ConfigurationProperty) | Gets or sets a property or attribute of this configuration element. (Inherited from ConfigurationElement.)
 | Item(String) | Gets or sets a property, attribute, or child element of this configuration element. (Inherited from ConfigurationElement.)
 | KillBrowserProcessOnClose | Gets whether to kill browser processes on exit
 | ListErrors(IList) | Adds the invalid-property errors in this ConfigurationElement object, and in all subelements, to the passed list. (Inherited from ConfigurationElement.)
 | LocalWebServer | Gets which local web server to use to serve test pages.
 | LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from ConfigurationElement.)
 | LockAllElementsExcept | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
 | LockAttributes | Gets the collection of locked attributes (Inherited from ConfigurationElement.)
 | LockElements | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
 | LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from ConfigurationElement.)
 | LogAnnotations | Gets whether to log annotations to log file.
 | LogLocation | Gets the log location where all logging by the framework will take place.
 | MemberwiseClone() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OnDeserializeUnrecognizedAttribute(String, String) | Gets a value indicating whether an unknown attribute is encountered during deserialization. (Inherited from ConfigurationElement.)
 | OnDeserializeUnrecognizedElement(String, XmlReader) | Gets a value indicating whether an unknown element is encountered during deserialization. (Inherited from ConfigurationElement.)
 | OnRequiredPropertyNotFound(String) | Throws an exception when a required property is not found. (Inherited from ConfigurationElement.)
 | PostDeserialize() | Called after deserialization. (Inherited from ConfigurationElement.)
 | PreSerialize(XmlWriter) | Called before serialization. (Inherited from ConfigurationElement.)
 | Properties | Gets the collection of properties. (Inherited from ConfigurationElement.)
 | QueryEventLogErrorsOnExit | If true, will query the event log for any un expected client errors.
 | Reset(ConfigurationElement) | Resets the internal state of the ConfigurationElement object, including the locks and the properties collections. (Inherited from ConfigurationElement.)
 | ResetModified() | (Inherited from ConfigurationSection.)
 | ScriptLoggingPort | Obsolete. Gets the script logging port to use when enableScriptLogging="true".
 | SectionInformation | Gets a SectionInformation object that contains the non-customizable information and functionality of the ConfigurationSection object. (Inherited from ConfigurationSection.)
 | SerializeElement(XmlWriter, Boolean) | Writes the contents of this configuration element to the configuration file when implemented in a derived class. (Inherited from ConfigurationElement.)
 | SerializeSection(ConfigurationElement, String, ConfigurationSaveMode) | Creates an XML string containing an unmerged view of the ConfigurationSection object as a single section to write to a file. (Inherited from ConfigurationSection.)
 | SerializeToXmlElement(XmlWriter, String) | Writes the outer tags of this configuration element to the configuration file when implemented in a derived class. (Inherited from ConfigurationElement.)
 | SetPropertyValue(ConfigurationProperty, Object, Boolean) | Sets a property to the specified value. (Inherited from ConfigurationElement.)
 | SetReadOnly() | Sets the IsReadOnly() property for the ConfigurationElement object and all subelements. (Inherited from ConfigurationElement.)
 | SimulatedMouseMoveSpeed | The simulated mouse move speed
 | ToString() | Returns a String that represents the current Object. (Inherited from Object.)
 | Unmerge(ConfigurationElement, ConfigurationElement, ConfigurationSaveMode) | Modifies the ConfigurationElement object to remove all values that should not be saved. (Inherited from ConfigurationElement.)
 | WaitCheckInterval | The global wait.Forxx interval check.
 | WebAppPhysicalPath | If UseAspNetDevServer is true, then will indicate the physical path to the application we are testing.
Inheritance Hierarchy
Object
 | ConfigurationElement
 |  | ConfigurationSection
 |  |  | SettingsConfigSectionHandler


AnnotateExecution property

SettingsConfigSectionHandler.AnnotateExecution property
Namespaces > ArtOfTest.WebAii.Core > SettingsConfigSectionHandler > AnnotateExecution
Whether to enable execution highlight.
Syntax
C#
[ConfigurationPropertyAttribute("annotateExecution", IsRequired = false, DefaultValue = false)]
public bool AnnotateExecution { get; }


AnnotationMode property

SettingsConfigSectionHandler.AnnotationMode property
Namespaces > ArtOfTest.WebAii.Core > SettingsConfigSectionHandler > AnnotationMode
Gets the annotation mode.
Syntax
C#
[ConfigurationPropertyAttribute("annotationMode", IsRequired = false, DefaultValue = AnnotationMode.All)]
public AnnotationMode AnnotationMode { get; }


AspNetDevServerPort property

SettingsConfigSectionHandler.AspNetDevServerPort property
Namespaces > ArtOfTest.WebAii.Core > SettingsConfigSectionHandler > AspNetDevServerPort
Gets the AspNetDevServer port if set.
Syntax
C#
[ConfigurationPropertyAttribute("aspNetDevServerPort", IsRequired = false, DefaultValue = )]
public int AspNetDevServerPort { get; }


BaseUrl property

SettingsConfigSectionHandler.BaseUrl property
Namespaces > ArtOfTest.WebAii.Core > SettingsConfigSectionHandler > BaseUrl
The base url to use for all NavigateTo actions in the framework.
Syntax
C#
[ConfigurationPropertyAttribute("baseUrl", IsRequired = false, DefaultValue = "")]
public string BaseUrl { get; }


ClientReadyTimeout property

SettingsConfigSectionHandler.ClientReadyTimeout property
Namespaces > ArtOfTest.WebAii.Core > SettingsConfigSectionHandler > ClientReadyTimeout
Gets the client ready timeout.
Syntax
C#
[ConfigurationPropertyAttribute("clientReadyTimeout", IsRequired = false, DefaultValue = )]
public int ClientReadyTimeout { get; }


CreateLogFile property

SettingsConfigSectionHandler.CreateLogFile property
Namespaces > ArtOfTest.WebAii.Core > SettingsConfigSectionHandler > CreateLogFile
Gets whether to create a log file on disk.
Syntax
C#
[ConfigurationPropertyAttribute("createLogFile", IsRequired = false, DefaultValue = true)]
public bool CreateLogFile { get; }


DefaultBrowser property

SettingsConfigSectionHandler.DefaultBrowser property
Namespaces > ArtOfTest.WebAii.Core > SettingsConfigSectionHandler > DefaultBrowser
Gets the default browser used by the Manager when none is specified.
Syntax
C#
[ConfigurationPropertyAttribute("defaultBrowser", IsRequired = false, DefaultValue = BrowserType.InternetExplorer)]
public BrowserType DefaultBrowser { get; }


EnableScriptLogging property

SettingsConfigSectionHandler.EnableScriptLogging property
Namespaces > ArtOfTest.WebAii.Core > SettingsConfigSectionHandler > EnableScriptLogging
Gets whether to enable script logging or not.
Syntax
C#
[ConfigurationPropertyAttribute("enableScriptLogging", IsRequired = false, DefaultValue = false)]
public bool EnableScriptLogging { get; }


EnableUILessRequestViewing property

SettingsConfigSectionHandler.EnableUILessRequestViewing property
Namespaces > ArtOfTest.WebAii.Core > SettingsConfigSectionHandler > EnableUILessRequestViewing
Whether to enable debugging of the UILess page requests using a UI browser like IE.
Syntax
C#
[ConfigurationPropertyAttribute("enableUILessRequestViewing", IsRequired = false, DefaultValue = false)]
public bool EnableUILessRequestViewing { get; }


ExecutionDelay property

SettingsConfigSectionHandler.ExecutionDelay property
Namespaces > ArtOfTest.WebAii.Core > SettingsConfigSectionHandler > ExecutionDelay
The execution delay set.
Syntax
C#
[ConfigurationPropertyAttribute("executionDelay", IsRequired = false, DefaultValue = )]
public int ExecutionDelay { get; }


ExecutionTimeout property

SettingsConfigSectionHandler.ExecutionTimeout property
Namespaces > ArtOfTest.WebAii.Core > SettingsConfigSectionHandler > ExecutionTimeout
Gets the Execution timeout for commands.
Syntax
C#
[ConfigurationPropertyAttribute("executionTimeout", IsRequired = false, DefaultValue = )]
public int ExecutionTimeout { get; }


KillBrowserProcessOnClose property

SettingsConfigSectionHandler.KillBrowserProcessOnClose property
Namespaces > ArtOfTest.WebAii.Core > SettingsConfigSectionHandler > KillBrowserProcessOnClose
Gets whether to kill browser processes on exit
Syntax
C#
[ConfigurationPropertyAttribute("killBrowserProcessOnClose", IsRequired = false, DefaultValue = false)]
public bool KillBrowserProcessOnClose { get; }


LocalWebServer property

SettingsConfigSectionHandler.LocalWebServer property
Namespaces > ArtOfTest.WebAii.Core > SettingsConfigSectionHandler > LocalWebServer
Gets which local web server to use to serve test pages.
Syntax
C#
[ConfigurationPropertyAttribute("localWebServer", IsRequired = false, DefaultValue = LocalWebServerType.None)]
public LocalWebServerType LocalWebServer { get; }


LogAnnotations property

SettingsConfigSectionHandler.LogAnnotations property
Namespaces > ArtOfTest.WebAii.Core > SettingsConfigSectionHandler > LogAnnotations
Gets whether to log annotations to log file.
Syntax
C#
[ConfigurationPropertyAttribute("logAnnotations", IsRequired = false, DefaultValue = false)]
public bool LogAnnotations { get; }


LogLocation property

SettingsConfigSectionHandler.LogLocation property
Namespaces > ArtOfTest.WebAii.Core > SettingsConfigSectionHandler > LogLocation
Gets the log location where all logging by the framework will take place.
Syntax
C#
[ConfigurationPropertyAttribute("logLocation", IsRequired = false, DefaultValue = "C:\WebAiiLog\")]
public string LogLocation { get; }


QueryEventLogErrorsOnExit property

SettingsConfigSectionHandler.QueryEventLogErrorsOnExit property
Namespaces > ArtOfTest.WebAii.Core > SettingsConfigSectionHandler > QueryEventLogErrorsOnExit
If true, will query the event log for any un expected client errors.
Syntax
C#
[ConfigurationPropertyAttribute("queryEventLogErrorsOnExit", IsRequired = false, DefaultValue = false)]
public bool QueryEventLogErrorsOnExit { get; }


ScriptLoggingPort property

SettingsConfigSectionHandler.ScriptLoggingPort property
Namespaces > ArtOfTest.WebAii.Core > SettingsConfigSectionHandler > ScriptLoggingPort
Gets the script logging port to use when enableScriptLogging="true".
Syntax
C#
[ObsoleteAttribute("This property is no longer needed and can be removed from app.config")]
[ConfigurationPropertyAttribute("scriptLoggingPort", IsRequired = false, DefaultValue = )]
public int ScriptLoggingPort { get; }


SettingsConfigSectionHandler() constructor

SettingsConfigSectionHandler() constructor
Namespaces > ArtOfTest.WebAii.Core > SettingsConfigSectionHandler > SettingsConfigSectionHandlerNew()
Syntax
C#
public SettingsConfigSectionHandler ()


SimulatedMouseMoveSpeed property

SettingsConfigSectionHandler.SimulatedMouseMoveSpeed property
Namespaces > ArtOfTest.WebAii.Core > SettingsConfigSectionHandler > SimulatedMouseMoveSpeed
The simulated mouse move speed
Syntax
C#
[ConfigurationPropertyAttribute("simulatedMouseMoveSpeed", IsRequired = false, DefaultValue = )]
public float SimulatedMouseMoveSpeed { get; }


WaitCheckInterval property

SettingsConfigSectionHandler.WaitCheckInterval property
Namespaces > ArtOfTest.WebAii.Core > SettingsConfigSectionHandler > WaitCheckInterval
The global wait.Forxx interval check.
Syntax
C#
[ConfigurationPropertyAttribute("waitCheckInterval", IsRequired = false, DefaultValue = )]
public int WaitCheckInterval { get; }


WebAppPhysicalPath property

SettingsConfigSectionHandler.WebAppPhysicalPath property
Namespaces > ArtOfTest.WebAii.Core > SettingsConfigSectionHandler > WebAppPhysicalPath
If UseAspNetDevServer is true, then will indicate the physical path to the application we are testing.
Syntax
C#
[ConfigurationPropertyAttribute("webAppPhysicalPath", IsRequired = false, DefaultValue = "")]
public string WebAppPhysicalPath { get; }


TreeBuilder class

TreeBuilder class
Namespaces > ArtOfTest.WebAii.Core > TreeBuilder
This class builds the a strongly-typed markup elements tree.
Syntax
C#
public class TreeBuilder
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon Member Description
BuildDomTree(String, Boolean)
Parse and build the Dom. This method will initialize the Root property with the root element of the Dom.
DocType
Gets the DOCTYPE element if present in the document. Otherwise null.
Equals(Object)
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Finalize()
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
GetHashCode()
Serves as a hash function for a particular type.
(Inherited from Object.)
GetType()
Gets the Type of the current instance.
(Inherited from Object.)
MemberwiseClone()
Creates a shallow copy of the current Object.
(Inherited from Object.)
OwnerBrowser
Gets the owner Browser object of this Dom Tree.
Root
Gets the root Element node. You can access the tree using this node.
TestRegions
Gets a dictionary list of all testregions in the current Dom tree. You can access these regions direction from this property.
Examples
To access the 'foo' test region you can simply call:
    TestRegion foo = myBrowser.DomTree.TestRegions["foo"];

ToString()
Returns a String that represents the current Object.
(Inherited from Object.)
Inheritance Hierarchy
Object
TreeBuilder


BuildDomTree(text, trimWhiteSpace) method

TreeBuilder.BuildDomTree(text, trimWhiteSpace) method
Namespaces > ArtOfTest.WebAii.Core > TreeBuilder > BuildDomTree(String, Boolean)
Parse and build the Dom. This method will initialize the Root property with the root element of the Dom.
Syntax
C#
public Element BuildDomTree (
    string text,
    bool trimWhiteSpace
)
Parameters
text (String)
The text to build the tree for
trimWhiteSpace (Boolean)
Whether to trim the white spaces or not in the text between tags.
Return Value
The root document element.


DocType property

TreeBuilder.DocType property
Namespaces > ArtOfTest.WebAii.Core > TreeBuilder > DocType
Gets the DOCTYPE element if present in the document. Otherwise null.
Syntax
C#
public Element DocType { get; }


OwnerBrowser property

TreeBuilder.OwnerBrowser property
Namespaces > ArtOfTest.WebAii.Core > TreeBuilder > OwnerBrowser
Gets the owner Browser object of this Dom Tree.
Syntax
C#
public Browser OwnerBrowser { get; }


Root property

TreeBuilder.Root property
Namespaces > ArtOfTest.WebAii.Core > TreeBuilder > Root
Gets the root Element node. You can access the tree using this node.
Syntax
C#
public Element Root { get; }


TestRegions property

TreeBuilder.TestRegions property
Namespaces > ArtOfTest.WebAii.Core > TreeBuilder > TestRegions
Gets a dictionary list of all testregions in the current Dom tree. You can access these regions direction from this property.
Examples
To access the 'foo' test region you can simply call:
    TestRegion foo = myBrowser.DomTree.TestRegions["foo"];

Syntax
C#
public TestRegionCollection TestRegions { get; }
Remarks
Regardless of the nesting of test regions in the parsed document, the dictionary returned by this property contains a flat list of all regions.


ArtOfTest.WebAii.EventsArgs Namespace

ArtOfTest.WebAii.EventsArgs Namespace
Namespaces > ArtOfTest.WebAii.EventsArgs
Syntax
C#
namespace ArtOfTest.WebAii.EventsArgs
Types
All Types Classes Structures Interfaces Enumerations Delegates
Icon | Type | Description
public class | BrowserCommandEventArgs | BrowserCommandEventArgs.
public class | ClientConnectedEventArgs | ClientConnectedEventArgs
public class | ClientDisconnectedEventArgs | ClientDisconnectedEventArgs
public class | ClientLogMessageEventArgs | ClientLogMessageEventArgs
public class | FindParamCollectionItemAddedEventArgs | FindParamCollection items added event args
public class | LogWriteEventArgs | LogWrite event argument.
public class | ReturnedNullOrEmptyEventArgs | ReturnedNullOrEmpty event argument.
public class | WaitCompleteEventArgs | Wait complete event args.


BrowserCommandEventArgs class

BrowserCommandEventArgs class
Namespaces > ArtOfTest.WebAii.EventsArgs > BrowserCommandEventArgs
BrowserCommandEventArgs.
Syntax
C#
[SerializableAttribute]
public class BrowserCommandEventArgs : EventArgs
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BrowserCommandEventArgsNew(BrowserCommand, String) | Create a new BrowserRequestEventArgs.
 | Command | Gets the request.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType() | Gets the Type of the current instance. (Inherited from Object.)
 | Id | Gets the unique id of this command.
 | MemberwiseClone() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | BrowserCommandEventArgs


BrowserCommandEventArgs(command, requestId) constructor

BrowserCommandEventArgs(command, requestId) constructor
Namespaces > ArtOfTest.WebAii.EventsArgs > BrowserCommandEventArgs > BrowserCommandEventArgsNew(BrowserCommand, String)
Create a new BrowserRequestEventArgs.
Syntax
C#
public BrowserCommandEventArgs (
    BrowserCommand command,
    string requestId
)
Parameters
command (BrowserCommand)
The request.
requestId (String)
The unique request id.


Command property

BrowserCommandEventArgs.Command property
Namespaces > ArtOfTest.WebAii.EventsArgs > BrowserCommandEventArgs > Command
Gets the request.
Syntax
C#
public BrowserCommand Command { get; }


Id property

BrowserCommandEventArgs.Id property
Namespaces > ArtOfTest.WebAii.EventsArgs > BrowserCommandEventArgs > Id
Gets the unique id of this command.
Syntax
C#
public string Id { get; }


ClientConnectedEventArgs class

ClientConnectedEventArgs class
Namespaces > ArtOfTest.WebAii.EventsArgs > ClientConnectedEventArgs
ClientConnectedEventArgs
Syntax
C#
[SerializableAttribute]
public class ClientConnectedEventArgs : EventArgs
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ClientConnectedEventArgsNew(String, BrowserType, String, IntPtr, Int32, Boolean, Boolean, Boolean) | Create a new ClientConnectedEventArgs.
 | BrowserType | Gets the browser type of this client.
 | ClientId | Gets the client unique id.
 | ClientReadyTimeout | Gets the ClientReadyTimeout to be used for this client.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType() | Gets the Type of the current instance. (Inherited from Object.)
 | Hwnd | Get the hwnd of the browser for this client.
 | IsDialog | Whether the client is a dialog
 | IsUILess | Whether this client is UI less.
 | MemberwiseClone() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | SupportsJsLogging | Gets whether the client should support js logging.
 | ToString() | Returns a String that represents the current Object. (Inherited from Object.)
 | Version | Gets the browser version of this client.
Inheritance Hierarchy
Object
 | EventArgs
 |  | ClientConnectedEventArgs


BrowserType property

ClientConnectedEventArgs.BrowserType property
Namespaces > ArtOfTest.WebAii.EventsArgs > ClientConnectedEventArgs > BrowserType
Gets the browser type of this client.
Syntax
C#
public BrowserType BrowserType { get; }


ClientConnectedEventArgs(clientID, type, version, hwnd, clientReadyTimeout, isUILess, isDialog, supportsJsLogging) constructor

ClientConnectedEventArgs(clientID, type, version, hwnd, clientReadyTimeout, isUILess, isDialog, supportsJsLogging) constructor
Namespaces > ArtOfTest.WebAii.EventsArgs > ClientConnectedEventArgs > ClientConnectedEventArgsNew(String, BrowserType, String, IntPtr, Int32, Boolean, Boolean, Boolean)
Create a new ClientConnectedEventArgs.
Syntax
C#
public ClientConnectedEventArgs (
    string clientID,
    BrowserType type,
    string version,
    IntPtr hwnd,
    int clientReadyTimeout,
    bool isUILess,
    bool isDialog,
    bool supportsJsLogging
)
Parameters
clientID (String)
The client id that connected.
type (BrowserType)
The browser type that connected.
version (String)
The browser version that connected.
hwnd (IntPtr)
The browser hwnd that connected.
clientReadyTimeout (Int32)
The clientReadyTimeout to be used for this client.
isUILess (Boolean)
Whether this client is a UILess or not.
isDialog (Boolean)
Whether the client is a dialog. Used for IE's modal/modeless dialogs.
supportsJsLogging (Boolean)
True/False whether to enable logging from script


ClientId property

ClientConnectedEventArgs.ClientId property
Namespaces > ArtOfTest.WebAii.EventsArgs > ClientConnectedEventArgs > ClientId
Gets the client unique id.
Syntax
C#
public string ClientId { get; }


ClientReadyTimeout property

ClientConnectedEventArgs.ClientReadyTimeout property
Namespaces > ArtOfTest.WebAii.EventsArgs > ClientConnectedEventArgs > ClientReadyTimeout
Gets the ClientReadyTimeout to be used for this client.
Syntax
C#
public int ClientReadyTimeout { get; }


Hwnd property

ClientConnectedEventArgs.Hwnd property
Namespaces > ArtOfTest.WebAii.EventsArgs > ClientConnectedEventArgs > Hwnd
Get the hwnd of the browser for this client.
Syntax
C#
public IntPtr Hwnd { get; }


IsDialog property

ClientConnectedEventArgs.IsDialog property
Namespaces > ArtOfTest.WebAii.EventsArgs > ClientConnectedEventArgs > IsDialog
Whether the client is a dialog
Syntax
C#
public bool IsDialog { get; }


IsUILess property

ClientConnectedEventArgs.IsUILess property
Namespaces > ArtOfTest.WebAii.EventsArgs > ClientConnectedEventArgs > IsUILess
Whether this client is UI less.
Syntax
C#
public bool IsUILess { get; }


SupportsJsLogging property

ClientConnectedEventArgs.SupportsJsLogging property
Namespaces > ArtOfTest.WebAii.EventsArgs > ClientConnectedEventArgs > SupportsJsLogging
Gets whether the client should support js logging.
Syntax
C#
public bool SupportsJsLogging { get; }


Version property

ClientConnectedEventArgs.Version property
Namespaces > ArtOfTest.WebAii.EventsArgs > ClientConnectedEventArgs > Version
Gets the browser version of this client.
Syntax
C#
public string Version { get; }


ClientDisconnectedEventArgs class

ClientDisconnectedEventArgs class
Namespaces > ArtOfTest.WebAii.EventsArgs > ClientDisconnectedEventArgs
ClientDisconnectedEventArgs
Syntax
C#
[SerializableAttribute]
public class ClientDisconnectedEventArgs : EventArgs
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ClientDisconnectedEventArgsNew(String) | Create a new ClientDisconnectedEventArgs.
 | ClientId | Gets the client unique id that disconnected.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | ClientDisconnectedEventArgs


ClientDisconnectedEventArgs(clientId) constructor

ClientDisconnectedEventArgs(clientId) constructor
Namespaces > ArtOfTest.WebAii.EventsArgs > ClientDisconnectedEventArgs > ClientDisconnectedEventArgsNew(String)
Create a new ClientDisconnectedEventArgs.
Syntax
C#
public ClientDisconnectedEventArgs (
    string clientId
)
Parameters
clientId (String)
The client unique id that disconnected.


ClientId property

ClientDisconnectedEventArgs.ClientId property
Namespaces > ArtOfTest.WebAii.EventsArgs > ClientDisconnectedEventArgs > ClientId
Gets the client unique id that disconnected.
Syntax
C#
public string ClientId { get; }


ClientLogMessageEventArgs class

ClientLogMessageEventArgs class
Namespaces > ArtOfTest.WebAii.EventsArgs > ClientLogMessageEventArgs
ClientLogMessageEventArgs
Syntax
C#
[SerializableAttribute]
public class ClientLogMessageEventArgs : EventArgs
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ClientLogMessageEventArgsNew(LogType, String) | Create a new ClientLogMessageEventArgs
 | ClientLogMessageEventArgsNew(String) | Create a new ClientLogMessageEventArgs.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType() | Gets the Type of the current instance. (Inherited from Object.)
 | LogType | Gets the log type to use.
 | MemberwiseClone() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Message | Gets message to log.
 | ToString() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | ClientLogMessageEventArgs


Constructors

ClientLogMessageEventArgs constructors
Namespaces > ArtOfTest.WebAii.EventsArgs > ClientLogMessageEventArgs > ClientLogMessageEventArgsNew
Members
Icon | Member | Description
 | ClientLogMessageEventArgsNew(LogType, String) | Create a new ClientLogMessageEventArgs
 | ClientLogMessageEventArgsNew(String) | Create a new ClientLogMessageEventArgs.


ClientLogMessageEventArgs(message) constructor

ClientLogMessageEventArgs(message) constructor
Namespaces > ArtOfTest.WebAii.EventsArgs > ClientLogMessageEventArgs > ClientLogMessageEventArgsNew(String)
Create a new ClientLogMessageEventArgs.
Syntax
C#
public ClientLogMessageEventArgs (
    string message
)
Parameters
message (String)
Message to log.


ClientLogMessageEventArgs(type, message) constructor

ClientLogMessageEventArgs(type, message) constructor
Namespaces > ArtOfTest.WebAii.EventsArgs > ClientLogMessageEventArgs > ClientLogMessageEventArgsNew(LogType, String)
Create a new ClientLogMessageEventArgs
Syntax
C#
public ClientLogMessageEventArgs (
    LogType type,
    string message
)
Parameters
type (LogType)
The type of the log to execute.
message (String)
The message to log.


LogType property

ClientLogMessageEventArgs.LogType property
Namespaces > ArtOfTest.WebAii.EventsArgs > ClientLogMessageEventArgs > LogType
Gets the log type to use.
Syntax
C#
public LogType LogType { get; }


Message property

ClientLogMessageEventArgs.Message property
Namespaces > ArtOfTest.WebAii.EventsArgs > ClientLogMessageEventArgs > Message
Gets message to log.
Syntax
C#
public string Message { get; }


FindParamCollectionItemAddedEventArgs class

FindParamCollectionItemAddedEventArgs class
Namespaces > ArtOfTest.WebAii.EventsArgs > FindParamCollectionItemAddedEventArgs
FindParamCollection items added event args
Syntax
C#
public class FindParamCollectionItemAddedEventArgs : EventArgs
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | FindParamCollectionItemAddedEventArgsNew(String, FindParam) | Create a new event args.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindParam | Gets the FindParam object added.
 | GetHashCode() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType() | Gets the Type of the current instance. (Inherited from Object.)
 | Key | Gets the FindParam key.
 | MemberwiseClone() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | FindParamCollectionItemAddedEventArgs


FindParam property

FindParamCollectionItemAddedEventArgs.FindParam property
Namespaces > ArtOfTest.WebAii.EventsArgs > FindParamCollectionItemAddedEventArgs > FindParam
Gets the FindParam object added.
Syntax
C#
public FindParam FindParam { get; }


FindParamCollectionItemAddedEventArgs(key, param) constructor

FindParamCollectionItemAddedEventArgs(key, param) constructor
Namespaces > ArtOfTest.WebAii.EventsArgs > FindParamCollectionItemAddedEventArgs > FindParamCollectionItemAddedEventArgsNew(String, FindParam)
Create a new event args.
Syntax
C#
public FindParamCollectionItemAddedEventArgs (
    string key,
    FindParam param
)
Parameters
key (String)
The key of the FindParam
param (FindParam)
The FindParam object.


Key property

FindParamCollectionItemAddedEventArgs.Key property
Namespaces > ArtOfTest.WebAii.EventsArgs > FindParamCollectionItemAddedEventArgs > Key
Gets the FindParam key.
Syntax
C#
public string Key { get; }


LogWriteEventArgs class

LogWriteEventArgs class
Namespaces > ArtOfTest.WebAii.EventsArgs > LogWriteEventArgs
LogWrite event argument.
Syntax
C#
public class LogWriteEventArgs : EventArgs
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LogWriteEventArgsNew(String, String) | Create a new LogWriteEventArgs object.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Message | Gets the message being logged.
 | MessageWithoutTimeStamp | Gets the message without the time stampe.
 | ToString() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | LogWriteEventArgs


LogWriteEventArgs(message, messageNoTime) constructor

LogWriteEventArgs(message, messageNoTime) constructor
Namespaces > ArtOfTest.WebAii.EventsArgs > LogWriteEventArgs > LogWriteEventArgsNew(String, String)
Create a new LogWriteEventArgs object.
Syntax
C#
public LogWriteEventArgs (
    string message,
    string messageNoTime
)
Parameters
message (String)
The message to log.
messageNoTime (String)


Message property

LogWriteEventArgs.Message property
Namespaces > ArtOfTest.WebAii.EventsArgs > LogWriteEventArgs > Message
Gets the message being logged.
Syntax
C#
public string Message { get; }


MessageWithoutTimeStamp property

LogWriteEventArgs.MessageWithoutTimeStamp property
Namespaces > ArtOfTest.WebAii.EventsArgs > LogWriteEventArgs > MessageWithoutTimeStamp
Gets the message without the time stampe.
Syntax
C#
public string MessageWithoutTimeStamp { get; }


ReturnedNullOrEmptyEventArgs class

ReturnedNullOrEmptyEventArgs class
Namespaces > ArtOfTest.WebAii.EventsArgs > ReturnedNullOrEmptyEventArgs
ReturnedNullOrEmpty event argument.
Syntax
C#
public class ReturnedNullOrEmptyEventArgs : EventArgs
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ReturnedNullOrEmptyEventArgsNew(FindError) | Create new ReturnedNullOrEmptyEventArgs
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindErrorData | Gets the FindErrorData object that contains information regarding the identification that caused this event.
 | GetHashCode() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | ReturnedNullOrEmptyEventArgs


FindErrorData property

ReturnedNullOrEmptyEventArgs.FindErrorData property
Namespaces > ArtOfTest.WebAii.EventsArgs > ReturnedNullOrEmptyEventArgs > FindErrorData
Gets the FindErrorData object that contains information regarding the identification that caused this event.
Syntax
C#
public FindError FindErrorData { get; }


ReturnedNullOrEmptyEventArgs(findErrorData) constructor

ReturnedNullOrEmptyEventArgs(findErrorData) constructor
Namespaces > ArtOfTest.WebAii.EventsArgs > ReturnedNullOrEmptyEventArgs > ReturnedNullOrEmptyEventArgsNew(FindError)
Create new ReturnedNullOrEmptyEventArgs
Syntax
C#
public ReturnedNullOrEmptyEventArgs (
    FindError findErrorData
)
Parameters
findErrorData (FindError)
The find error data object that contains information on the find error that results in a null or an empty list of elements to be returned.


WaitCompleteEventArgs class

WaitCompleteEventArgs class
Namespaces > ArtOfTest.WebAii.EventsArgs > WaitCompleteEventArgs
Wait complete event args.
Syntax
C#
public class WaitCompleteEventArgs : EventArgs
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | WaitCompleteEventArgsNew(WaitResult) | Create a new WaitCompleteEventArgs.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString() | Returns a String that represents the current Object. (Inherited from Object.)
 | WaitResult | Gets the wait result of this wait operation.
Inheritance Hierarchy
Object
 | EventArgs
 |  | WaitCompleteEventArgs


WaitCompleteEventArgs(waitResult) constructor

WaitCompleteEventArgs(waitResult) constructor
Namespaces > ArtOfTest.WebAii.EventsArgs > WaitCompleteEventArgs > WaitCompleteEventArgsNew(WaitResult)
Create a new WaitCompleteEventArgs.
Syntax
C#
public WaitCompleteEventArgs (
    WaitResult waitResult
)
Parameters
waitResult (WaitResult)
The wait result.


WaitResult property

WaitCompleteEventArgs.WaitResult property
Namespaces > ArtOfTest.WebAii.EventsArgs > WaitCompleteEventArgs > WaitResult
Gets the wait result of this wait operation.
Syntax
C#
public WaitResult WaitResult { get; }


ArtOfTest.WebAii.Exceptions Namespace

ArtOfTest.WebAii.Exceptions Namespace
Namespaces > ArtOfTest.WebAii.Exceptions
Syntax
C#
namespace ArtOfTest.WebAii.Exceptions
Types
All Types Classes Structures Interfaces Enumerations Delegates
Icon | Type | Description
public class | AssertException | AssertException thrown when an assert fails.
public class | ExecuteCommandException | Execute command exception. Occurs when a command fails to execute.
public class | FindException | Find exception. Thrown when Find returns null or an empty list
public class | LogErrorException | This exception indicates that a log error call has been made to hault the execution of the tests by throwing a LogErrorException.
public class | UnsupportedBrowserOperationException | Exception for operations that are not supported by a certain type of browser.
public class | UnsupportedNonInteractiveOperationException | This exception is thrown when an automation test tries to perform a operation that is deemed invalid in non-interactive mode like trying to use the keyboard or click the mouse.


AssertException class

AssertException class
Namespaces > ArtOfTest.WebAii.Exceptions > AssertException
AssertException thrown when an assert fails.
Syntax
C#
[SerializableAttribute]
public class AssertException : Exception
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AssertExceptionNew(SerializationInfo, StreamingContext) | Serialization constructor
 | AssertExceptionNew(String, Exception) | Create a new AssertException
 | AssertExceptionNew(String, String, String) | Create a new AssertException
 | AssertExceptionNew(String, String, String, Exception) | Create a new AssertException
 | ActualValue | Gets the actual value.
 | Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from Exception.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | ExpectedValue | Gets the expected value.
 | Finalize() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetBaseException() | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
 | GetHashCode() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | Deserialize this exception. (Overrides Exception.GetObjectData(SerializationInfo, StreamingContext).)
 | GetType() | Gets the runtime type of the current instance. (Inherited from Exception.)
 | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
 | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
 | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
 | MemberwiseClone() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Message | Gets the assert message (Overrides Exception.Message.)
 | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
 | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
 | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
 | ToString() | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Inheritance Hierarchy
Object
 | Exception
 |  | AssertException


ActualValue property

AssertException.ActualValue property
Namespaces > ArtOfTest.WebAii.Exceptions > AssertException > ActualValue
Gets the actual value.
Syntax
C#
public string ActualValue { get; }


Constructors

AssertException constructors
Namespaces > ArtOfTest.WebAii.Exceptions > AssertException > AssertExceptionNew
Members
Icon | Member | Description
 | AssertExceptionNew(SerializationInfo, StreamingContext) | Serialization constructor
 | AssertExceptionNew(String, Exception) | Create a new AssertException
 | AssertExceptionNew(String, String, String) | Create a new AssertException
 | AssertExceptionNew(String, String, String, Exception) | Create a new AssertException


AssertException(info, context) constructor

AssertException(info, context) constructor
Namespaces > ArtOfTest.WebAii.Exceptions > AssertException > AssertExceptionNew(SerializationInfo, StreamingContext)
Serialization constructor
Syntax
C#
public AssertException (
    SerializationInfo info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
SerializationInfo
context (StreamingContext)
StreamingContext


AssertException(message, expectedValue, actualValue) constructor

AssertException(message, expectedValue, actualValue) constructor
Namespaces > ArtOfTest.WebAii.Exceptions > AssertException > AssertExceptionNew(String, String, String)
Create a new AssertException
Syntax
C#
public AssertException (
    string message,
    string expectedValue,
    string actualValue
)
Parameters
message (String)
Assert message
expectedValue (String)
Expected value.
actualValue (String)
Actual value.


AssertException(message, expectedValue, actualValue, innerException) constructor

AssertException(message, expectedValue, actualValue, innerException) constructor
Namespaces > ArtOfTest.WebAii.Exceptions > AssertException > AssertExceptionNew(String, String, String, Exception)
Create a new AssertException
Syntax
C#
public AssertException (
    string message,
    string expectedValue,
    string actualValue,
    Exception innerException
)
Parameters
message (String)
Assert message
expectedValue (String)
Expected value.
actualValue (String)
Actual value.
innerException (Exception)
Any inner exceptions


AssertException(message, innerException) constructor

AssertException(message, innerException) constructor
Namespaces > ArtOfTest.WebAii.Exceptions > AssertException > AssertExceptionNew(String, Exception)
Create a new AssertException
Syntax
C#
public AssertException (
    string message,
    Exception innerException
)
Parameters
message (String)
Assert message
innerException (Exception)
Any inner exceptions


ExpectedValue property

AssertException.ExpectedValue property
Namespaces > ArtOfTest.WebAii.Exceptions > AssertException > ExpectedValue
Gets the expected value.
Syntax
C#
public string ExpectedValue { get; }


GetObjectData(info, context) method

AssertException.GetObjectData(info, context) method
Namespaces > ArtOfTest.WebAii.Exceptions > AssertException > GetObjectData(SerializationInfo, StreamingContext)
Deserialize this exception.
Syntax
C#
public override void GetObjectData (
    SerializationInfo info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
Serialization info.
context (StreamingContext)
Context.


Message property

AssertException.Message property
Namespaces > ArtOfTest.WebAii.Exceptions > AssertException > Message
Gets the assert message
Syntax
C#
public override string Message { get; }


ExecuteCommandException class

ExecuteCommandException class
Namespaces > ArtOfTest.WebAii.Exceptions > ExecuteCommandException
Execute command exception. Occurs when a command fails to execute.
Syntax
C#
[SerializableAttribute]
public class ExecuteCommandException : Exception
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ExecuteCommandExceptionNew(BrowserCommand, Exception) | Create a new ExecuteCommandException.
 | ExecuteCommandExceptionNew(SerializationInfo, StreamingContext) |
 | Command | Gets the command that caused the exception.
 | Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from Exception.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetBaseException() | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
 | GetHashCode() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | (Overrides Exception.GetObjectData(SerializationInfo, StreamingContext).)
 | GetType() | Gets the runtime type of the current instance. (Inherited from Exception.)
 | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
 | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
 | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
 | MemberwiseClone() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Message | Gets the ExecuteCommandException message. (Overrides Exception.Message.)
 | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
 | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
 | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
 | ToString() | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Inheritance Hierarchy
Object
 | Exception
 |  | ExecuteCommandException


Command property

ExecuteCommandException.Command property
Namespaces > ArtOfTest.WebAii.Exceptions > ExecuteCommandException > Command
Gets the command that caused the exception.
Syntax
C#
public BrowserCommand Command { get; }


Constructors

ExecuteCommandException constructors
Namespaces > ArtOfTest.WebAii.Exceptions > ExecuteCommandException > ExecuteCommandExceptionNew
Members
Icon | Member | Description
 | ExecuteCommandExceptionNew(BrowserCommand, Exception) | Create a new ExecuteCommandException.
 | ExecuteCommandExceptionNew(SerializationInfo, StreamingContext) |


ExecuteCommandException(command, innerException) constructor

ExecuteCommandException(command, innerException) constructor
Namespaces > ArtOfTest.WebAii.Exceptions > ExecuteCommandException > ExecuteCommandExceptionNew(BrowserCommand, Exception)
Create a new ExecuteCommandException.
Syntax
C#
public ExecuteCommandException (
    BrowserCommand command,
    Exception innerException
)
Parameters
command (BrowserCommand)
The command that caused the exception.
innerException (Exception)
The inner exception (if any).


ExecuteCommandException(info, context) constructor

ExecuteCommandException(info, context) constructor
Namespaces > ArtOfTest.WebAii.Exceptions > ExecuteCommandException > ExecuteCommandExceptionNew(SerializationInfo, StreamingContext)
Syntax
C#
public ExecuteCommandException (
    SerializationInfo info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
context (StreamingContext)


GetObjectData(info, context) method

ExecuteCommandException.GetObjectData(info, context) method
Namespaces > ArtOfTest.WebAii.Exceptions > ExecuteCommandException > GetObjectData(SerializationInfo, StreamingContext)
Syntax
C#
public override void GetObjectData (
    SerializationInfo info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
context (StreamingContext)


Message property

ExecuteCommandException.Message property
Namespaces > ArtOfTest.WebAii.Exceptions > ExecuteCommandException > Message
Gets the ExecuteCommandException message.
Syntax
C#
public override string Message { get; }


FindException class

FindException class
Namespaces > ArtOfTest.WebAii.Exceptions > FindException
Find exception. Thrown when Find returns null or an empty list
Syntax
C#
[SerializableAttribute]
public class FindException : Exception
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | FindExceptionNew(FindError, Exception) | Create a new FindException.
 | FindExceptionNew(String) | Create a new generic FindException.
 | FindExceptionNew(String, Exception) | Create a new generic FindException.
 | Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from Exception.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindErrorData | Extended information on the Find error that occurred.
 | GetBaseException() | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
 | GetHashCode() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
 | GetType() | Gets the runtime type of the current instance. (Inherited from Exception.)
 | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
 | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
 | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
 | MemberwiseClone() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Message | The FindException message. (Overrides Exception.Message.)
 | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
 | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
 | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
 | ToString() | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Inheritance Hierarchy
Object
 | Exception
 |  | FindException


Constructors

FindException constructors
Namespaces > ArtOfTest.WebAii.Exceptions > FindException > FindExceptionNew
Members
Icon | Member | Description
 | FindExceptionNew(FindError, Exception) | Create a new FindException.
 | FindExceptionNew(String) | Create a new generic FindException.
 | FindExceptionNew(String, Exception) | Create a new generic FindException.


FindException(findErrorData, innerException) constructor

FindException(findErrorData, innerException) constructor
Namespaces > ArtOfTest.WebAii.Exceptions > FindException > FindExceptionNew(FindError, Exception)
Create a new FindException.
Syntax
C#
public FindException (
    FindError findErrorData,
    Exception innerException
)
Parameters
findErrorData (FindError)
Extended information on the find exception.
innerException (Exception)
The innerException (if any).


FindException(message) constructor

FindException(message) constructor
Namespaces > ArtOfTest.WebAii.Exceptions > FindException > FindExceptionNew(String)
Create a new generic FindException.
Syntax
C#
public FindException (
    string message
)
Parameters
message (String)
The exception message.


FindException(message, innerException) constructor

FindException(message, innerException) constructor
Namespaces > ArtOfTest.WebAii.Exceptions > FindException > FindExceptionNew(String, Exception)
Create a new generic FindException.
Syntax
C#
public FindException (
    string message,
    Exception innerException
)
Parameters
message (String)
The exception message.
innerException (Exception)
Any inner exceptions.


FindErrorData property

FindException.FindErrorData property
Namespaces > ArtOfTest.WebAii.Exceptions > FindException > FindErrorData
Extended information on the Find error that occurred.
Syntax
C#
public FindError FindErrorData { get; }


Message property

FindException.Message property
Namespaces > ArtOfTest.WebAii.Exceptions > FindException > Message
The FindException message.
Syntax
C#
public override string Message { get; }


LogErrorException class

LogErrorException class
Namespaces > ArtOfTest.WebAii.Exceptions > LogErrorException
This exception indicates that a log error call has been made to hault the execution of the tests by throwing a LogErrorException.
Syntax
C#
[SerializableAttribute]
public class LogErrorException : Exception
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LogErrorExceptionNew(SerializationInfo, StreamingContext) | Serialization Contructor.
 | LogErrorExceptionNew(String) | Create this exception
 | Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from Exception.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetBaseException() | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
 | GetHashCode() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | GetObjectData - Serialization (Overrides Exception.GetObjectData(SerializationInfo, StreamingContext).)
 | GetType() | Gets the runtime type of the current instance. (Inherited from Exception.)
 | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
 | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
 | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
 | MemberwiseClone() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Message | Gets a message that describes the current exception. (Inherited from Exception.)
 | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
 | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
 | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
 | ToString() | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Inheritance Hierarchy
Object
 | Exception
 |  | LogErrorException


Constructors

LogErrorException constructors
Namespaces > ArtOfTest.WebAii.Exceptions > LogErrorException > LogErrorExceptionNew
Members
Icon | Member | Description
 | LogErrorExceptionNew(SerializationInfo, StreamingContext) | Serialization Contructor.
 | LogErrorExceptionNew(String) | Create this exception


LogErrorException(info, context) constructor

LogErrorException(info, context) constructor
Namespaces > ArtOfTest.WebAii.Exceptions > LogErrorException > LogErrorExceptionNew(SerializationInfo, StreamingContext)
Serialization Contructor.
Syntax
C#
public LogErrorException (
    SerializationInfo info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
Serialization Info.
context (StreamingContext)
Context Info.


LogErrorException(message) constructor

LogErrorException(message) constructor
Namespaces > ArtOfTest.WebAii.Exceptions > LogErrorException > LogErrorExceptionNew(String)
Create this exception
Syntax
C#
public LogErrorException (
    string message
)
Parameters
message (String)
Exception message.


GetObjectData(info, context) method

LogErrorException.GetObjectData(info, context) method
Namespaces > ArtOfTest.WebAii.Exceptions > LogErrorException > GetObjectData(SerializationInfo, StreamingContext)
GetObjectData - Serialization
Syntax
C#
public override void GetObjectData (
    SerializationInfo info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
Serialization Info.
context (StreamingContext)
Context Info.


UnsupportedBrowserOperationException class

UnsupportedBrowserOperationException class
Namespaces > ArtOfTest.WebAii.Exceptions > UnsupportedBrowserOperationException
Exception for operations that are not supported by a certain type of browser.
Syntax
C#
[SerializableAttribute]
public class UnsupportedBrowserOperationException : Exception
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | UnsupportedBrowserOperationExceptionNew(BrowserType, String) | Create this exception
 | Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from Exception.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetBaseException() | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
 | GetHashCode() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
 | GetType() | Gets the runtime type of the current instance. (Inherited from Exception.)
 | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
 | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
 | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
 | MemberwiseClone() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Message | Gets a message that describes the current exception. (Inherited from Exception.)
 | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
 | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
 | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
 | ToString() | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Inheritance Hierarchy
Object
 | Exception
 |  | UnsupportedBrowserOperationException


UnsupportedBrowserOperationException(browserType, operationName) constructor

UnsupportedBrowserOperationException(browserType, operationName) constructor
Namespaces > ArtOfTest.WebAii.Exceptions > UnsupportedBrowserOperationException > UnsupportedBrowserOperationExceptionNew(BrowserType, String)
Create this exception
Syntax
C#
public UnsupportedBrowserOperationException (
    BrowserType browserType,
    string operationName
)
Parameters
browserType (BrowserType)
The browser type.
operationName (String)
The unsupported operation.


UnsupportedNonInteractiveOperationException class

UnsupportedNonInteractiveOperationException class
Namespaces > ArtOfTest.WebAii.Exceptions > UnsupportedNonInteractiveOperationException
This exception is thrown when an automation test tries to perform a operation that is deemed invalid in non-interactive mode like trying to use the keyboard or click the mouse.
Syntax
C#
[SerializableAttribute]
public class UnsupportedNonInteractiveOperationException : Exception
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | UnsupportedNonInteractiveOperationExceptionNew(String) | Create this exception.
 | UnsupportedNonInteractiveOperationExceptionNew(String, Exception) | Create this exception.
 | Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from Exception.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetBaseException() | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
 | GetHashCode() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
 | GetType() | Gets the runtime type of the current instance. (Inherited from Exception.)
 | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
 | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
 | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
 | MemberwiseClone() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Message | Gets a message that describes the current exception. (Inherited from Exception.)
 | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
 | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
 | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
 | ToString() | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Inheritance Hierarchy
Object
 | Exception
 |  | UnsupportedNonInteractiveOperationException


Constructors

UnsupportedNonInteractiveOperationException constructors
Namespaces > ArtOfTest.WebAii.Exceptions > UnsupportedNonInteractiveOperationException > UnsupportedNonInteractiveOperationExceptionNew
Members
Icon | Member | Description
 | UnsupportedNonInteractiveOperationExceptionNew(String) | Create this exception.
 | UnsupportedNonInteractiveOperationExceptionNew(String, Exception) | Create this exception.


UnsupportedNonInteractiveOperationException(message) constructor

UnsupportedNonInteractiveOperationException(message) constructor
Namespaces > ArtOfTest.WebAii.Exceptions > UnsupportedNonInteractiveOperationException > UnsupportedNonInteractiveOperationExceptionNew(String)
Create this exception.
Syntax
C#
public UnsupportedNonInteractiveOperationException (
    string message
)
Parameters
message (String)
The exception message.


UnsupportedNonInteractiveOperationException(message, innerException) constructor

UnsupportedNonInteractiveOperationException(message, innerException) constructor
Namespaces > ArtOfTest.WebAii.Exceptions > UnsupportedNonInteractiveOperationException > UnsupportedNonInteractiveOperationExceptionNew(String, Exception)
Create this exception.
Syntax
C#
public UnsupportedNonInteractiveOperationException (
    string message,
    Exception innerException
)
Parameters
message (String)
The exception message.
innerException (Exception)
InnerException.


ArtOfTest.WebAii.Exceptions.ErrorData Namespace

ArtOfTest.WebAii.Exceptions.ErrorData Namespace
Namespaces > ArtOfTest.WebAii.Exceptions.ErrorData
Syntax
C#
namespace ArtOfTest.WebAii.Exceptions.ErrorData
Types
All Types Classes Structures Interfaces Enumerations Delegates
Icon | Type | Description
public class | FindError | Class represents a Find error information. This class encapsultes all the information regarding a Find object call that caused an one of the Find methods to return null or an empty list.


FindError class

FindError class
Namespaces > ArtOfTest.WebAii.Exceptions.ErrorData > FindError
Class represents a Find error information. This class encapsultes all the information regarding a Find object call that caused an one of the Find methods to return null or an empty list.
Syntax
C#
[SerializableAttribute]
public class FindError
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ChainedParametersUsed | Gets the chained parameters used for the search. If isChained == null, then this will return null.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType() | Gets the Type of the current instance. (Inherited from Object.)
 | IsChained | Gets whether this is a chained parameter error or not.
 | MemberwiseClone() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ParameterUsed | Gets the FindParam used for the search. If IsChained != null, then this will return null.
 | Reference | Gets the reference element used for the search.
 | SearchLog | Gets the search log returned by the identification routines.
 | ToString() | String representation of a FindError object (Overrides Object.ToString().)
Inheritance Hierarchy
Object
FindError


ChainedParametersUsed property

FindError.ChainedParametersUsed property
Namespaces > ArtOfTest.WebAii.Exceptions.ErrorData > FindError > ChainedParametersUsed
Gets the chained parameters used for the search. If isChained == null, then this will return null.
Syntax
C#
public FindParam[] ChainedParametersUsed { get; }


IsChained property

FindError.IsChained property
Namespaces > ArtOfTest.WebAii.Exceptions.ErrorData > FindError > IsChained
Gets whether this is a chained parameter error or not.
Syntax
C#
public bool IsChained { get; }


ParameterUsed property

FindError.ParameterUsed property
Namespaces > ArtOfTest.WebAii.Exceptions.ErrorData > FindError > ParameterUsed
Gets the FindParam used for the search. If IsChained != null, then this will return null.
Syntax
C#
public FindParam ParameterUsed { get; }


Reference property

FindError.Reference property
Namespaces > ArtOfTest.WebAii.Exceptions.ErrorData > FindError > Reference
Gets the reference element used for the search.
Syntax
C#
public Element Reference { get; }


SearchLog property

FindError.SearchLog property
Namespaces > ArtOfTest.WebAii.Exceptions.ErrorData > FindError > SearchLog
Gets the search log returned by the identification routines.
Syntax
C#
public string SearchLog { get; }


ToString() method

FindError.ToString() method
Namespaces > ArtOfTest.WebAii.Exceptions.ErrorData > FindError > ToString()
String representation of a FindError object
Syntax
C#
public override string ToString ()
Return Value
The string representation.


ArtOfTest.WebAii.Messaging.Process Namespace

ArtOfTest.WebAii.Messaging.Process Namespace
Namespaces > ArtOfTest.WebAii.Messaging.Process
Syntax
C#
namespace ArtOfTest.WebAii.Messaging.Process
Types
All Types Classes Structures Interfaces Enumerations Delegates
Icon | Type | Description
public enumeration | BrowserActionType | Defines the supported sub types of the BrowserCommandType.Action
public class | BrowserCommand | Represents a command that we will pass back and forth between the browser and client to perform actions and return information from the browser.
public enumeration | BrowserCommandType | Type of command category to be requested by the browser
public enumeration | BrowserInformationType | Defines the supported sub types of BrowserCommandType.Information
public class | BrowserRemoteClient | This class represents a client that the browser will create to talk to the automation infrastructure and respond to its requests.
public class | ElementIdMessage | Class represents an identification of an element within a document.
public class | SimplePropertyDescriptor | Describes a simple property to set or get in addition to its value and type


BrowserActionType enumeration

BrowserActionType enumeration
Namespaces > ArtOfTest.WebAii.Messaging.Process > BrowserActionType
Defines the supported sub types of the BrowserCommandType.Action
Syntax
C#
public enum BrowserActionType
Members
Member | Description
NotSet | Type not set.
Click | Invoke a click from within the browser Dom.
SetText | Set the text from within the browser Dom.
SelectDropDown | Select an item in a drop down list from within the browser Dom.
Check | Check (a checkbox/radio buttong) from within the browser Dom.
ScrollToVisible | Scroll the browser until an item is visible.
NavigateTo | Navigate the browser to a specific url.
InvokeEvent | Invoke a script event on an element.
InvokeJsFunction | Invoke a script function.
Refresh | Cause a reload for the loaded document.
GoBack | Causes the browser to go back.
GoForward | Causes the browser to go forward.
LoadString | Load a string into the browser document. Supported only for IE.
GetProperty | Get a property
SetProperty | Set a property
InvokeMethod | Invoke a method
SetCookie | Set a cookie
IEConnectDialog | IE (Only) connect a modal/modeless dialog to manager.
ScrollBy | Control the horizonal/vertical browser/frame scroll bars.
Stop | Stop the browser
ClearHistory | Clear the browser history
ClearFilesCache | Clear the browser file cache


BrowserCommand class

BrowserCommand class
Namespaces > ArtOfTest.WebAii.Messaging.Process > BrowserCommand
Represents a command that we will pass back and forth between the browser and client to perform actions and return information from the browser.
Syntax
C#
[SerializableAttribute]
public class BrowserCommand
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BrowserCommandNew(BrowserCommandType, BrowserInformationType, BrowserActionType, String, ElementIdMessage) | Create a new BrowserCommand object.
 | ActionType | Gets/Sets the type of action the command is requesting.
 | ClientId | Gets/Sets the id of the client that this command originated from.
 | CommandType | Gets/Sets the Command type for this command.
 | Create(Element, BrowserCommandType) | Create an empty command to be used.
 | Data | Gets/Sets any additional data needed to help process the command. (i.e. Text for SetText)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FramesInfo | Gets/Sets the frames information of any sub frames if HasFrames is true.
 | GetHashCode() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType() | Gets the Type of the current instance. (Inherited from Object.)
 | HasFrames | Whether the current document has frames or not. This value is set when the Info.DocumentMarkup command is executed.
 | InError | Gets/Sets the state of error for this command. If InError is true, Response string contains the error message. Otherwise, Response contains the expected response.
 | InformationType | Gets/Sets the type of information the command is requesting.
 | IsDialog | Gets/Sets whether this command is coming from a Modal dialog.
 | MemberwiseClone() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Response | Gets/Sets the response of the command from the browser.
 | Target | Gets/Sets the target element for this command.
 | TargetFrameIndex | The target frame index to execute the command against. Else -1, the command will be executed against the main browser window document.
 | ToString() | String representation of a BrowserCommand. (Overrides Object.ToString().)
Inheritance Hierarchy
Object
BrowserCommand


ActionType property

BrowserCommand.ActionType property
Namespaces > ArtOfTest.WebAii.Messaging.Process > BrowserCommand > ActionType
Gets/Sets the type of action the command is requesting.
Syntax
C#
public BrowserActionType ActionType { get; set; }


BrowserCommand(type, information, action, data, target) constructor

BrowserCommand(type, information, action, data, target) constructor
Namespaces > ArtOfTest.WebAii.Messaging.Process > BrowserCommand > BrowserCommandNew(BrowserCommandType, BrowserInformationType, BrowserActionType, String, ElementIdMessage)
Create a new BrowserCommand object.
Syntax
C#
public BrowserCommand (
    BrowserCommandType type,
    BrowserInformationType information,
    BrowserActionType action,
    string data,
    ElementIdMessage target
)
Parameters
type (BrowserCommandType)
The type of the command (Action or Information).
information (BrowserInformationType)
If Information, the type of information you are asking for.
action (BrowserActionType)
If Action, the type of action you are asking for.
data (String)
Data associated with the Request (mostly).
target (ElementIdMessage)
The target element for this command.


ClientId property

BrowserCommand.ClientId property
Namespaces > ArtOfTest.WebAii.Messaging.Process > BrowserCommand > ClientId
Gets/Sets the id of the client that this command originated from.
Syntax
C#
public string ClientId { get; set; }


CommandType property

BrowserCommand.CommandType property
Namespaces > ArtOfTest.WebAii.Messaging.Process > BrowserCommand > CommandType
Gets/Sets the Command type for this command.
Syntax
C#
public BrowserCommandType CommandType { get; set; }


Create(targetElement, type) method

BrowserCommand.Create(targetElement, type) method
Namespaces > ArtOfTest.WebAii.Messaging.Process > BrowserCommand > Create(Element, BrowserCommandType)
Create an empty command to be used.
Syntax
C#
public static BrowserCommand Create (
    Element targetElement,
    BrowserCommandType type
)
Parameters
targetElement (Element)
The target element for this command.
type (BrowserCommandType)
The type of the command.
Return Value
An initialized BrowserCommand object.


Data property

BrowserCommand.Data property
Namespaces > ArtOfTest.WebAii.Messaging.Process > BrowserCommand > Data
Gets/Sets any additional data needed to help process the command. (i.e. Text for SetText)
Syntax
C#
public string Data { get; set; }


FramesInfo property

BrowserCommand.FramesInfo property
Namespaces > ArtOfTest.WebAii.Messaging.Process > BrowserCommand > FramesInfo
Gets/Sets the frames information of any sub frames if HasFrames is true.
Syntax
C#
public string FramesInfo { get; set; }


HasFrames property

BrowserCommand.HasFrames property
Namespaces > ArtOfTest.WebAii.Messaging.Process > BrowserCommand > HasFrames
Whether the current document has frames or not. This value is set when the Info.DocumentMarkup command is executed.
Syntax
C#
public bool HasFrames { get; set; }


InError property

BrowserCommand.InError property
Namespaces > ArtOfTest.WebAii.Messaging.Process > BrowserCommand > InError
Gets/Sets the state of error for this command. If InError is true, Response string contains the error message. Otherwise, Response contains the expected response.
Syntax
C#
public bool InError { get; set; }


InformationType property

BrowserCommand.InformationType property
Namespaces > ArtOfTest.WebAii.Messaging.Process > BrowserCommand > InformationType
Gets/Sets the type of information the command is requesting.
Syntax
C#
public BrowserInformationType InformationType { get; set; }


IsDialog property

BrowserCommand.IsDialog property
Namespaces > ArtOfTest.WebAii.Messaging.Process > BrowserCommand > IsDialog
Gets/Sets whether this command is coming from a Modal dialog.
Syntax
C#
public bool IsDialog { get; set; }


Response property

BrowserCommand.Response property
Namespaces > ArtOfTest.WebAii.Messaging.Process > BrowserCommand > Response
Gets/Sets the response of the command from the browser.
Syntax
C#
public string Response { get; set; }


Target property

BrowserCommand.Target property
Namespaces > ArtOfTest.WebAii.Messaging.Process > BrowserCommand > Target
Gets/Sets the target element for this command.
Syntax
C#
public ElementIdMessage Target { get; set; }


TargetFrameIndex property

BrowserCommand.TargetFrameIndex property
Namespaces > ArtOfTest.WebAii.Messaging.Process > BrowserCommand > TargetFrameIndex
The target frame index to execute the command against. Else -1, the command will be executed against the main browser window document.
Syntax
C#
public int TargetFrameIndex { get; set; }


ToString() method

BrowserCommand.ToString() method
Namespaces > ArtOfTest.WebAii.Messaging.Process > BrowserCommand > ToString()
String representation of a BrowserCommand.
Syntax
C#
public override string ToString ()
Return Value
The string representation.


BrowserCommandType enumeration

BrowserCommandType enumeration
Namespaces > ArtOfTest.WebAii.Messaging.Process > BrowserCommandType
Type of command category to be requested by the browser
Syntax
C#
public enum BrowserCommandType
Members
Member | Description
NotSet | Command type not set.
Information | Command type is to gather information from the browser but not execution any action.
Action | Command type is to execute an action like clicking a button or setting some text.


BrowserInformationType enumeration

BrowserInformationType enumeration
Namespaces > ArtOfTest.WebAii.Messaging.Process > BrowserInformationType
Defines the supported sub types of BrowserCommandType.Information
Syntax
C#
public enum BrowserInformationType
Members
Member | Description
NotSet | Type not set.
ElementRectangle | Return the rectangle information for a specific element.
DocumentMarkup | Returns the current loaded document markup.
IsReady | Returns whether the browser document is ready or not.
Cookies | Returns the list of cookies
ComputedStyle | Get the computed style
FFCachePath | Firefox cache file path
FFProfilePath | Firefox user profile path


BrowserRemoteClient class

BrowserRemoteClient class
Namespaces > ArtOfTest.WebAii.Messaging.Process > BrowserRemoteClient
This class represents a client that the browser will create to talk to the automation infrastructure and respond to its requests.
Syntax
C#
[SerializableAttribute]
public class BrowserRemoteClient : MarshalByRefObject
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BrowserRemoteClientNew(String) | Create a new BrowserRemoteClient object.
 | browserRemotedObject_BrowserRequest(Object, BrowserCommandEventArgs) | Invoked when the remote object requests for a command
 | browserRemotedObject_ClientConnected(Object, ClientConnectedEventArgs) | Invoked when a client connection is established. This event is invoked as a response to calling Connect().
 | browserRemotedObject_ClientDisconnected(Object, ClientDisconnectedEventArgs) | Invoked when the remote object disconnects a client or when this client calls Disconnect().
 | BrowserRequest | Event that occurs when the client has a request from the automation infrastructure.
 | ClientConnected | Event that occurs when the client is connected.
 | ClientDisconnected | Event that occurs when the client is disconnected.
 | ClientId | Gets this client's unique id.
 | ClientReadyTimeout | Gets the the client ready time out.
 | Connect(BrowserType, String, IntPtr, Boolean, Boolean) | Connect this client to the Manager.
 | CreateObjRef(Type) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
 | Disconnect() | Disconnect this client from Manager.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetLifetimeService() | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
 | GetType() | Gets the Type of the current instance. (Inherited from Object.)
 | InitializeLifetimeService() | Live forever. (Overrides MarshalByRefObject.InitializeLifetimeService().)
 | IsConnected | Gets whether this client is connected or not to the Manager.
 | LogEventError(String, String) | Log an error to the event log.
 | LogMessage(LogType, String) | Log a message to the centralized logging location.
 | LogMessage(String) | Log a message to the centralized logging location.
 | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
 | ProcessResponse(BrowserCommandEventArgs) | Process a response to the Manager.
 | SupportAutomation | Whether this client is launched using a process that supports automation.
 | SupportsJsLogging | Gets whether the client should support js logging.
 | ToString() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | BrowserRemoteClient


BrowserRemoteClient(remoteUrl) constructor

BrowserRemoteClient(remoteUrl) constructor
Namespaces > ArtOfTest.WebAii.Messaging.Process > BrowserRemoteClient > BrowserRemoteClientNew(String)
Create a new BrowserRemoteClient object.
Syntax
C#
public BrowserRemoteClient (
    string remoteUrl
)
Parameters
remoteUrl (String)


browserRemotedObject_BrowserRequest(sender, e) method

BrowserRemoteClient.browserRemotedObject_BrowserRequest(sender, e) method
Namespaces > ArtOfTest.WebAii.Messaging.Process > BrowserRemoteClient > browserRemotedObject_BrowserRequest(Object, BrowserCommandEventArgs)
Invoked when the remote object requests for a command
Syntax
C#
public void browserRemotedObject_BrowserRequest (
    Object sender,
    BrowserCommandEventArgs e
)
Parameters
sender (Object)
sender
e (BrowserCommandEventArgs)
event args


browserRemotedObject_ClientConnected(sender, e) method

BrowserRemoteClient.browserRemotedObject_ClientConnected(sender, e) method
Namespaces > ArtOfTest.WebAii.Messaging.Process > BrowserRemoteClient > browserRemotedObject_ClientConnected(Object, ClientConnectedEventArgs)
Invoked when a client connection is established. This event is invoked as a response to calling Connect().
Syntax
C#
public void browserRemotedObject_ClientConnected (
    Object sender,
    ClientConnectedEventArgs e
)
Parameters
sender (Object)
sender
e (ClientConnectedEventArgs)
event args


browserRemotedObject_ClientDisconnected(sender, e) method

BrowserRemoteClient.browserRemotedObject_ClientDisconnected(sender, e) method
Namespaces > ArtOfTest.WebAii.Messaging.Process > BrowserRemoteClient > browserRemotedObject_ClientDisconnected(Object, ClientDisconnectedEventArgs)
Invoked when the remote object disconnects a client or when this client calls Disconnect().
Syntax
C#
public void browserRemotedObject_ClientDisconnected (
    Object sender,
    ClientDisconnectedEventArgs e
)
Parameters
sender (Object)
sender
e (ClientDisconnectedEventArgs)
event args


BrowserRequest event

BrowserRemoteClient.BrowserRequest event
Namespaces > ArtOfTest.WebAii.Messaging.Process > BrowserRemoteClient > BrowserRequest
Event that occurs when the client has a request from the automation infrastructure.
Syntax
C#
public event EventHandler<BrowserCommandEventArgs> BrowserRequest


ClientConnected event

BrowserRemoteClient.ClientConnected event
Namespaces > ArtOfTest.WebAii.Messaging.Process > BrowserRemoteClient > ClientConnected
Event that occurs when the client is connected.
Syntax
C#
public event EventHandler<ClientConnectedEventArgs> ClientConnected


ClientDisconnected event

BrowserRemoteClient.ClientDisconnected event
Namespaces > ArtOfTest.WebAii.Messaging.Process > BrowserRemoteClient > ClientDisconnected
Event that occurs when the client is disconnected.
Syntax
C#
public event EventHandler<ClientDisconnectedEventArgs> ClientDisconnected


ClientId property

BrowserRemoteClient.ClientId property
Namespaces > ArtOfTest.WebAii.Messaging.Process > BrowserRemoteClient > ClientId
Gets this client's unique id.
Syntax
C#
public string ClientId { get; }


ClientReadyTimeout property

BrowserRemoteClient.ClientReadyTimeout property
Namespaces > ArtOfTest.WebAii.Messaging.Process > BrowserRemoteClient > ClientReadyTimeout
Gets the the client ready time out.
Syntax
C#
public int ClientReadyTimeout { get; }


Connect(type, version, hwnd, isUILess, isDialog) method

BrowserRemoteClient.Connect(type, version, hwnd, isUILess, isDialog) method
Namespaces > ArtOfTest.WebAii.Messaging.Process > BrowserRemoteClient > Connect(BrowserType, String, IntPtr, Boolean, Boolean)
Connect this client to the Manager.
Syntax
C#
public void Connect (
    BrowserType type,
    string version,
    IntPtr hwnd,
    bool isUILess,
    bool isDialog
)
Parameters
type (BrowserType)
The type of the browser being connected.
version (String)
The version of the browser being connected.
hwnd (IntPtr)
The hwnd of the browser window being connected.
isUILess (Boolean)
Whether this client is UI less or not.
isDialog (Boolean)
Whether the browser client is a dialog (Used for IE modal/modeless dialogs).


Disconnect() method

BrowserRemoteClient.Disconnect() method
Namespaces > ArtOfTest.WebAii.Messaging.Process > BrowserRemoteClient > Disconnect()
Disconnect this client from Manager.
Syntax
C#
public void Disconnect ()


InitializeLifetimeService() method

BrowserRemoteClient.InitializeLifetimeService() method
Namespaces > ArtOfTest.WebAii.Messaging.Process > BrowserRemoteClient > InitializeLifetimeService()
Live forever.
Syntax
C#
public override Object InitializeLifetimeService ()
Return Value


IsConnected property

BrowserRemoteClient.IsConnected property
Namespaces > ArtOfTest.WebAii.Messaging.Process > BrowserRemoteClient > IsConnected
Gets whether this client is connected or not to the Manager.
Syntax
C#
public bool IsConnected { get; }


LogEventError(error, clientName) method

BrowserRemoteClient.LogEventError(error, clientName) method
Namespaces > ArtOfTest.WebAii.Messaging.Process > BrowserRemoteClient > LogEventError(String, String)
Log an error to the event log.
Syntax
C#
public static void LogEventError (
    string error,
    string clientName
)
Parameters
error (String)
Error to log.
clientName (String)
The client name that logged this event.


LogMessage methods

BrowserRemoteClient.LogMessage methods
Namespaces > ArtOfTest.WebAii.Messaging.Process > BrowserRemoteClient > LogMessage
Members
Icon | Member | Description
 | LogMessage(LogType, String) | Log a message to the centralized logging location.
 | LogMessage(String) | Log a message to the centralized logging location.


LogMessage(message) method

BrowserRemoteClient.LogMessage(message) method
Namespaces > ArtOfTest.WebAii.Messaging.Process > BrowserRemoteClient > LogMessage(String)
Log a message to the centralized logging location.
Syntax
C#
public void LogMessage (
    string message
)
Parameters
message (String)


LogMessage(type, message) method

BrowserRemoteClient.LogMessage(type, message) method
Namespaces > ArtOfTest.WebAii.Messaging.Process > BrowserRemoteClient > LogMessage(LogType, String)
Log a message to the centralized logging location.
Syntax
C#
public void LogMessage (
    LogType type,
    string message
)
Parameters
type (LogType)
The log type to use.
message (String)
The message


ProcessResponse(e) method

BrowserRemoteClient.ProcessResponse(e) method
Namespaces > ArtOfTest.WebAii.Messaging.Process > BrowserRemoteClient > ProcessResponse(BrowserCommandEventArgs)
Process a response to the Manager.
Syntax
C#
public void ProcessResponse (
    BrowserCommandEventArgs e
)
Parameters
e (BrowserCommandEventArgs)
The response.


SupportAutomation property

BrowserRemoteClient.SupportAutomation property
Namespaces > ArtOfTest.WebAii.Messaging.Process > BrowserRemoteClient > SupportAutomation
Whether this client is launched using a process that supports automation.
Syntax
C#
public static string SupportAutomation { get; }


SupportsJsLogging property

BrowserRemoteClient.SupportsJsLogging property
Namespaces > ArtOfTest.WebAii.Messaging.Process > BrowserRemoteClient > SupportsJsLogging
Gets whether the client should support js logging.
Syntax
C#
public bool SupportsJsLogging { get; }


ElementIdMessage class

ElementIdMessage class
Namespaces > ArtOfTest.WebAii.Messaging.Process > ElementIdMessage
Class represents an identification of an element within a document.
Syntax
C#
[SerializableAttribute]
public class ElementIdMessage
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ElementIdMessageNew(String, Int32) | Create a new ElementIdMessage to identify a specific element
 | Create(Element) | Translate the Element into a ElementIdMessage that the browser can interpret.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OccurrenceIndex | Gets the tag occurrence index of the element we are targeting. Zero based index.
 | TagName | Gets the tag name of the element we are targeting.
 | TargetType | Gets/Sets the target element type (HTML, Silverlight, Flash)
 | ToString() | String representation of an ElementIdMessage (Overrides Object.ToString().)
 | XamlElementName | Gets/Sets the xaml Element name when TargetType=Silverlight
Inheritance Hierarchy
Object
ElementIdMessage


Create(element) method

ElementIdMessage.Create(element) method
Namespaces > ArtOfTest.WebAii.Messaging.Process > ElementIdMessage > Create(Element)
Translate the Element into a ElementIdMessage that the browser can interpret.
Syntax
C#
public static ElementIdMessage Create (
    Element element
)
Parameters
element (Element)
The Element.
Return Value
The ElementIdMessage that represents this element


ElementIdMessage(tagName, occurrenceIndex) constructor

ElementIdMessage(tagName, occurrenceIndex) constructor
Namespaces > ArtOfTest.WebAii.Messaging.Process > ElementIdMessage > ElementIdMessageNew(String, Int32)
Create a new ElementIdMessage to identify a specific element
Syntax
C#
public ElementIdMessage (
    string tagName,
    int occurrenceIndex
)
Parameters
tagName (String)
The tag name.
occurrenceIndex (Int32)
The occurence index of this tag name.


OccurrenceIndex property

ElementIdMessage.OccurrenceIndex property
Namespaces > ArtOfTest.WebAii.Messaging.Process > ElementIdMessage > OccurrenceIndex
Gets the tag occurrence index of the element we are targeting. Zero based index.
Syntax
C#
public int OccurrenceIndex { get; }


TagName property

ElementIdMessage.TagName property
Namespaces > ArtOfTest.WebAii.Messaging.Process > ElementIdMessage > TagName
Gets the tag name of the element we are targeting.
Syntax
C#
public string TagName { get; }


TargetType property

ElementIdMessage.TargetType property
Namespaces > ArtOfTest.WebAii.Messaging.Process > ElementIdMessage > TargetType
Gets/Sets the target element type (HTML, Silverlight, Flash)
Syntax
C#
public ElementGenderType TargetType { get; set; }


ToString() method

ElementIdMessage.ToString() method
Namespaces > ArtOfTest.WebAii.Messaging.Process > ElementIdMessage > ToString()
String representation of an ElementIdMessage
Syntax
C#
public override string ToString ()
Return Value


XamlElementName property

ElementIdMessage.XamlElementName property
Namespaces > ArtOfTest.WebAii.Messaging.Process > ElementIdMessage > XamlElementName
Gets/Sets the xaml Element name when TargetType=Silverlight
Syntax
C#
public string XamlElementName { get; set; }


SimplePropertyDescriptor class

SimplePropertyDescriptor class
Namespaces > ArtOfTest.WebAii.Messaging.Process > SimplePropertyDescriptor
Describes a simple property to set or get in addition to its value and type
Syntax
C#
public class SimplePropertyDescriptor
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SimplePropertyDescriptorNew(String, Object) | Create a new property descriptor
 | SimplePropertyDescriptorNew(String, Type) | Create a new property descriptor
 | ConvertValueType(String, Type) | Converts a value to the desired type.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Get the name of this property
 | PropertyType | Gets property type
 | Serialize() | Serializes this descriptor to a JSON string.
 | ToString() | Returns a String that represents the current Object. (Inherited from Object.)
 | Value | Gets the value of this property
Inheritance Hierarchy
Object
SimplePropertyDescriptor


Constructors

SimplePropertyDescriptor constructors
Namespaces > ArtOfTest.WebAii.Messaging.Process > SimplePropertyDescriptor > SimplePropertyDescriptorNew
Members
Icon | Member | Description
 | SimplePropertyDescriptorNew(String, Object) | Create a new property descriptor
 | SimplePropertyDescriptorNew(String, Type) | Create a new property descriptor


SimplePropertyDescriptor(propertyName, type) constructor

SimplePropertyDescriptor(propertyName, type) constructor
Namespaces > ArtOfTest.WebAii.Messaging.Process > SimplePropertyDescriptor > SimplePropertyDescriptorNew(String, Type)
Create a new property descriptor
Syntax
C#
public SimplePropertyDescriptor (
    string propertyName,
    Type type
)
Parameters
propertyName (String)
The property name.
type (Type)
The property type.


SimplePropertyDescriptor(propertyName, value) constructor

SimplePropertyDescriptor(propertyName, value) constructor
Namespaces > ArtOfTest.WebAii.Messaging.Process > SimplePropertyDescriptor > SimplePropertyDescriptorNew(String, Object)
Create a new property descriptor
Syntax
C#
public SimplePropertyDescriptor (
    string propertyName,
    Object value
)
Parameters
propertyName (String)
The property name.
value (Object)
The property value.


ConvertValueType(value, desiredType) method

SimplePropertyDescriptor.ConvertValueType(value, desiredType) method
Namespaces > ArtOfTest.WebAii.Messaging.Process > SimplePropertyDescriptor > ConvertValueType(String, Type)
Converts a value to the desired type.
Syntax
C#
public static Object ConvertValueType (
    string value,
    Type desiredType
)
Parameters
value (String)
The value.
desiredType (Type)
The desired type.
Return Value
The converted value as the desired type.


Name property

SimplePropertyDescriptor.Name property
Namespaces > ArtOfTest.WebAii.Messaging.Process > SimplePropertyDescriptor > Name
Get the name of this property
Syntax
C#
public string Name { get; }


PropertyType property

SimplePropertyDescriptor.PropertyType property
Namespaces > ArtOfTest.WebAii.Messaging.Process > SimplePropertyDescriptor > PropertyType
Gets property type
Syntax
C#
public Type PropertyType { get; }


Serialize() method

SimplePropertyDescriptor.Serialize() method
Namespaces > ArtOfTest.WebAii.Messaging.Process > SimplePropertyDescriptor > Serialize()
Serializes this descriptor to a JSON string.
Syntax
C#
public string Serialize ()
Return Value
The string representation of this property


Value property

SimplePropertyDescriptor.Value property
Namespaces > ArtOfTest.WebAii.Messaging.Process > SimplePropertyDescriptor > Value
Gets the value of this property
Syntax
C#
public Object Value { get; }


ArtOfTest.WebAii.ObjectModel Namespace

ArtOfTest.WebAii.ObjectModel Namespace
Namespaces > ArtOfTest.WebAii.ObjectModel
Syntax
C#
namespace ArtOfTest.WebAii.ObjectModel
Types
All Types Classes Structures Interfaces Enumerations Delegates
Icon | Type | Description
public enumeration | AttributeType | Type of attributes parsed.
public class | CookiesManager | Class representing all cookie operations on the current browser machine.
public class | Element | Represents an element in the Document Object Model (DOM) tree.
public enumeration | ElementGenderType | The element gender that this element is representing. (i.e. Html or Xaml)
public enumeration | ElementState | Possible element states
public enumeration | ElementType | The element type of an element within the Dom.
public enumeration | FindContentType | Types of identification of type=Content
public class | FindParam | A class that defines how a search for an element should be conducted within a document.
public class | FindParamCollection | Class to manage a collection of FindParam objects.
public enumeration | FindType | Types of identification supported by the framework.
public class | iAttribute | This class represents a markup attribute (foo="bar"). The iAttribute object contains a starting 'i' to distinguish it from System.Attribute.
public enumeration | InputElementType | The types of input for an ElementType=Input.
public enumeration | ParsedElementType | The type set by the parser when an element is parsed.
public enumeration | Quote | Types of quotes parsed.
public class | TestRegion | Class representing a TestRegion Object defined in the document as: <testregion id="foo"> ... </testregion> or <!--testregion id="foo"--> ... <!--/testregion>
public class | TestRegionCollection | A keyed TestRegion collection.


AttributeType enumeration

AttributeType enumeration
Namespaces > ArtOfTest.WebAii.ObjectModel > AttributeType
Type of attributes parsed.
Syntax
C#
public enum AttributeType
Members
Member | Description
Style | A style attribute. For example ( <hr style="backgroundcolor:red;"> )
Event | An event attribute. For example ( <hr onclick="myclick();"> )
Other | All other attributes except style or event.


CookiesManager class

CookiesManager class
Namespaces > ArtOfTest.WebAii.ObjectModel > CookiesManager
Class representing all cookie operations on the current browser machine.
Syntax
C#
public class CookiesManager
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DeleteCookie(Cookie) | Delete a cookie from the machine.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetCookies(String) | Gets all cookies for a specific url
 | GetCookies(Uri) | Gets all cookies for a specific uri
 | GetHashCode() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | SetCookie(Cookie) | Set a new cookie or modify an existing one. This methods will only consider the following cookie properties (Name, Value, Domain, Path and Expires)
 | ToString() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
CookiesManager


DeleteCookie(cookie) method

CookiesManager.DeleteCookie(cookie) method
Namespaces > ArtOfTest.WebAii.ObjectModel > CookiesManager > DeleteCookie(Cookie)
Delete a cookie from the machine.
Syntax
C#
public bool DeleteCookie (
    Cookie cookie
)
Parameters
cookie (Cookie)
The cookie to delete.
Return Value
True/False whether the cookie deletion passed or failed.


GetCookies methods

CookiesManager.GetCookies methods
Namespaces > ArtOfTest.WebAii.ObjectModel > CookiesManager > GetCookies
Members
Icon | Member | Description
 | GetCookies(String) | Gets all cookies for a specific url
 | GetCookies(Uri) | Gets all cookies for a specific uri


GetCookies(uri) method

CookiesManager.GetCookies(uri) method
Namespaces > ArtOfTest.WebAii.ObjectModel > CookiesManager > GetCookies(Uri)
Gets all cookies for a specific uri
Syntax
C#
public CookieCollection GetCookies (
    Uri uri
)
Parameters
uri (Uri)
The url to get the cookies for (i.e. http://www.google.com)
Return Value
The collection of cookies stored on this machine for the associated browser.


GetCookies(url) method

CookiesManager.GetCookies(url) method
Namespaces > ArtOfTest.WebAii.ObjectModel > CookiesManager > GetCookies(String)
Gets all cookies for a specific url
Syntax
C#
public CookieCollection GetCookies (
    string url
)
Parameters
url (String)
The url to get the cookies for (i.e. http://www.google.com)
Return Value
The collection of cookies stored on this machine for the associated browser.


SetCookie(cookie) method

CookiesManager.SetCookie(cookie) method
Namespaces > ArtOfTest.WebAii.ObjectModel > CookiesManager > SetCookie(Cookie)
Set a new cookie or modify an existing one. This methods will only consider the following cookie properties (Name, Value, Domain, Path and Expires)
Syntax
C#
public bool SetCookie (
    Cookie cookie
)
Parameters
cookie (Cookie)
The cookie to set on the machine for current browser.
Return Value
True/False whether the setting passed or failed.


Element class

Element class
Namespaces > ArtOfTest.WebAii.ObjectModel > Element
Represents an element in the Document Object Model (DOM) tree.
Syntax
C#
public class Element
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ElementNew(FindParam, Browser) | Initialize an element proxy. The only property off this element that you can use is Wait.Exist() or Wait.ExistsNot()
 | ElementNew(FindParam, Find, Browser) | Initialize an element proxy. The only property off this element that you can use is Wait.Exist() or Wait.ExistsNot()
 | AbsoluteSiblingTagIndex | Gets the absolute sibling tag index of this element within the parent node. Basically the order of this node among its siblings. Zero-based.
 | AbsoluteTagIndex | Gets the absolute that index of this element. This index is unique within a document.
 | AddChild(Element) | Add a child element to this element.
 | As<(Of TControl>)() | Returns this elements as a strongly-typed control of type TControl.
 | Attributes | Gets the list of attributes contained in this element.
 | ChildNodes | Gets the list of all parsed element of this tag including text literals, comments, malformed tags...etc.
 | Children | Gets the list of child elements that are well formed markup non-text elements.
 | ContainsAttribute(iAttribute, Boolean, StringComparison, Boolean) | Whether a certain attribute is contained in this element
 | ContainsAttribute(String) | True/False whether this element contains a specific attribute name.
 | Content | Gets the raw content of the tag that represents this element. Examples The following tag <foo id="bar" height="px">some text</foo> , has a Content property that is: '<foo id="bar" height="px">' Note: this does not include the innerText or the closing tag.
 | CreateLight(String, Int32) | Create an Element object with a specific tagname and index.
 | CssClassAttributeValue | Gets the value of the attribute ('cssclass') if present on this tag.
 | Data | Gets/Sets any custom data associated with this element.
 | ElementGenderType | This element's gender type. (currently Html or Xaml)
 | ElementType | Gets the element type (div, table ..etc).
 | Equals(Object) | Defines how two Elements should be compared. (Overrides Object.Equals(Object).)
 | Finalize() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindObjectUsed | Gets a reference to the Find object used to find this element
 | FindParamsUsed | Gets the FindParams used to find this element when using the Find object. If chained identification is used this array will contain the list of params, otherwise will contain a single FindParam object. This property is not set when calling the Find.Allxxx methods.
 | FriendlyName() | Constructs a friendly name that represents this element.
 | GetAttribute(String) | Find a specific attribute by name and returns it. (case-insensitive)
 | GetAttribute(String, Boolean) | Finds a specific attribute name in the Element list of attributes and returns its object
 | GetAttributeValueOrEmpty(String) | Gets the value of the attribute or a String.Empty if attribute does not exist.
 | GetHashCode() | Get the hash code for this Element. (Overrides Object.GetHashCode().)
 | GetNextSibling() | Get the next sibling of this node. If this node is the last sibling, will return null.
 | GetPreviousSibling() | Get the previous sibiling of this node. If this node is the first sibling, will return null.
 | GetRectangle() | Gets the element rectangle. (X,Y) and width, height as it appears on browser and screen. Takes into account any scrolling.
 | GetType() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue<(Of T>)(String) | Get a property value on this element.
 | HasIdOrName | Gets whether this element has an id or a name set on it.
 | IdAttributeValue | Gets the value of the attribute ('id') if present on this tag.
 | InnerMarkup | Gets the InnerMarkup of this element. Examples Example: <foo id="1">hello<bar></bar></foo> If foo is this element then InnerMarkup=<bar></bar>
 | InnerText | Gets this element's inner text content including all of its nested children. Examples Example: <foo id="1">one<bar>two</bar></foo> If foo is this element then InnerText=onetwo
 | InputElementType | Gets the Input type (i.e. checkbox, radio...etc) if the ElementType=Input. Otherwise, will return NotSet.
 | IsBeginTag | Gets whether it is a begin tag <foo bar='me'> .
 | IsEndTag | Gets whether this element is an end tag </foo>.
 | IsProxy | Gets whether this element is a proxy element or a fully initialized element.
 | IsSelfClosing | Gets whether the element is self-closing (<foo />).
 | MatchingClosingTag | Gets the element's closing tag if it is a begin tag and not self-closing.
 | MemberwiseClone() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NameAttributeValue | Gets the value of the attribute ('name') if present on this tag
 | OuterMarkup | Gets the OuterMarkup of this element. Examples Example: <foo id="1"><bar></bar></foo> If foo is this element then outerMarkup=<foo id="1"><bar></bar></foo>
 | OwnerBrowser | Returns the owner browser of this element.
 | Parent | Gets the Parent element.
 | ParsingType | Gets the parsing type set by the parser. (Markup, LiteralText, Comment..etc)
 | Refresh() | Using the FindParamsUsed and the TestRegionIdUsed to find this element last, this methods will attempt to re-find this element in the new DOM tree.
 | Refresh(Boolean) | Using the FindParamsUsed and the TestRegionIdUsed to find this element last, this methods will attempt to re-find this element in the new DOM tree.
 | SetValue<(Of T>)(String, T) | Set a property to a value on this element.
 | TagName | Gets the tagName of the the element
 | TagNameIndex | Gets the tagName occurrence of this element. Examples If this element is TagName='foo', then TagNameIndex= 3 indicates that this element represents the third occurence of tagName 'foo' within this document.
 | TextContent | Gets this element's inner text content without recursing through all its nested children for text.
 | ToString() | String representation of an Element. (Overrides Object.ToString().)
 | Wait | Gets the wait object to wait for certain conditions of this element.
Inheritance Hierarchy
Object
Element


AbsoluteSiblingTagIndex property

Element.AbsoluteSiblingTagIndex property
Namespaces > ArtOfTest.WebAii.ObjectModel > Element > AbsoluteSiblingTagIndex
Gets the absolute sibling tag index of this element within the parent node. Basically the order of this node among its siblings. Zero-based.
Syntax
C#
[ReadOnlyAttribute(true)]
public int AbsoluteSiblingTagIndex { get; set; }


AbsoluteTagIndex property

Element.AbsoluteTagIndex property
Namespaces > ArtOfTest.WebAii.ObjectModel > Element > AbsoluteTagIndex
Gets the absolute that index of this element. This index is unique within a document.
Syntax
C#
public int AbsoluteTagIndex { get; }


AddChild(child) method

Element.AddChild(child) method
Namespaces > ArtOfTest.WebAii.ObjectModel > Element > AddChild(Element)
Add a child element to this element.
Syntax
C#
public virtual void AddChild (
    Element child
)
Parameters
child (Element)
The child to add.
Remarks
This method will only add elements of ParsingType=Markup to the Children collection. ChildNodes collection will contain a complete list of elements of all types. (i.e. Comment,TextLiteral ...etc).


As<TControl>() method

Element.As<TControl>() method
Namespaces > ArtOfTest.WebAii.ObjectModel > Element > As<(Of TControl>)()
Returns this elements as a strongly-typed control of type TControl.
Syntax
C#
public TControl As<TControl> () where TControl : new(), Control
Generic Template Parameters
TControl
The control type.
Return Value
The control object.


Attributes property

Element.Attributes property
Namespaces > ArtOfTest.WebAii.ObjectModel > Element > Attributes
Gets the list of attributes contained in this element.
Syntax
C#
public ReadOnlyCollection<iAttribute> Attributes { get; }


ChildNodes property

Element.ChildNodes property
Namespaces > ArtOfTest.WebAii.ObjectModel > Element > ChildNodes
Gets the list of all parsed element of this tag including text literals, comments, malformed tags...etc.
Syntax
C#
public ReadOnlyCollection<Element> ChildNodes { get; }


Children property

Element.Children property
Namespaces > ArtOfTest.WebAii.ObjectModel > Element > Children
Gets the list of child elements that are well formed markup non-text elements.
Syntax
C#
public ReadOnlyCollection<Element> Children { get; }


Constructors

Element constructors
Namespaces > ArtOfTest.WebAii.ObjectModel > Element > ElementNew
Members
Icon | Member | Description
 | ElementNew(FindParam, Browser) | Initialize an element proxy. The only property off this element that you can use is Wait.Exist() or Wait.ExistsNot()
 | ElementNew(FindParam, Find, Browser) | Initialize an element proxy. The only property off this element that you can use is Wait.Exist() or Wait.ExistsNot()


Element(findParam, findObj, ownerBrowser) constructor

Element(findParam, findObj, ownerBrowser) constructor
Namespaces > ArtOfTest.WebAii.ObjectModel > Element > ElementNew(FindParam, Find, Browser)
Initialize an element proxy. The only property off this element that you can use is Wait.Exist() or Wait.ExistsNot()
Syntax
C#
public Element (
    FindParam findParam,
    Find findObj,
    Browser ownerBrowser
)
Parameters
findParam (FindParam)
The FindParam array
findObj (Find)
The Find object to use
ownerBrowser (Browser)
Owner browser


Element(findParam, ownerBrowser) constructor

Element(findParam, ownerBrowser) constructor
Namespaces > ArtOfTest.WebAii.ObjectModel > Element > ElementNew(FindParam, Browser)
Initialize an element proxy. The only property off this element that you can use is Wait.Exist() or Wait.ExistsNot()
Syntax
C#
public Element (
    FindParam findParam,
    Browser ownerBrowser
)
Parameters
findParam (FindParam)
The FindParam array
ownerBrowser (Browser)
Owner browser


ContainsAttribute methods

Element.ContainsAttribute methods
Namespaces > ArtOfTest.WebAii.ObjectModel > Element > ContainsAttribute
Members
Icon | Member | Description
 | ContainsAttribute(iAttribute, Boolean, StringComparison, Boolean) | Whether a certain attribute is contained in this element
 | ContainsAttribute(String) | True/False whether this element contains a specific attribute name.


ContainsAttribute(attributeName) method

Element.ContainsAttribute(attributeName) method
Namespaces > ArtOfTest.WebAii.ObjectModel > Element > ContainsAttribute(String)
True/False whether this element contains a specific attribute name.
Syntax
C#
public bool ContainsAttribute (
    string attributeName
)
Parameters
attributeName (String)
The attribute name to check for.
Return Value
True/False on the attribute existence.


ContainsAttribute(attribute, usePartialAttributeValue, comparison, matchQuotes) method

Element.ContainsAttribute(attribute, usePartialAttributeValue, comparison, matchQuotes) method
Namespaces > ArtOfTest.WebAii.ObjectModel > Element > ContainsAttribute(iAttribute, Boolean, StringComparison, Boolean)
Whether a certain attribute is contained in this element
Syntax
C#
public bool ContainsAttribute (
    iAttribute attribute,
    bool usePartialAttributeValue,
    StringComparison comparison,
    bool matchQuotes
)
Parameters
attribute (iAttribute)
The attribute to compare.
usePartialAttributeValue (Boolean)
Whether to use partinal values of the attribute values.
comparison (StringComparison)
Comparison type.
matchQuotes (Boolean)
Whether to match the quotes or not. This only applied when UsePartialAttributeValue is false.
Return Value
True/False Whether the attribute is contained or not.


Content property

Element.Content property
Namespaces > ArtOfTest.WebAii.ObjectModel > Element > Content
Gets the raw content of the tag that represents this element.
Examples
The following tag <foo id="bar" height="px">some text</foo> , has a Content property that is: '<foo id="bar" height="px">' Note: this does not include the innerText or the closing tag.
Syntax
C#
public string Content { get; }


CreateLight(tagName, tagIndex) method

Element.CreateLight(tagName, tagIndex) method
Namespaces > ArtOfTest.WebAii.ObjectModel > Element > CreateLight(String, Int32)
Create an Element object with a specific tagname and index.
Syntax
C#
public static Element CreateLight (
    string tagName,
    int tagIndex
)
Parameters
tagName (String)
The tagName
tagIndex (Int32)
The tagIndex
Return Value


CssClassAttributeValue property

Element.CssClassAttributeValue property
Namespaces > ArtOfTest.WebAii.ObjectModel > Element > CssClassAttributeValue
Gets the value of the attribute ('cssclass') if present on this tag.
Syntax
C#
public string CssClassAttributeValue { get; }


Data property

Element.Data property
Namespaces > ArtOfTest.WebAii.ObjectModel > Element > Data
Gets/Sets any custom data associated with this element.
Syntax
C#
public Object Data { get; set; }


ElementGenderType property

Element.ElementGenderType property
Namespaces > ArtOfTest.WebAii.ObjectModel > Element > ElementGenderType
This element's gender type. (currently Html or Xaml)
Syntax
C#
public ElementGenderType ElementGenderType { get; }


ElementType property

Element.ElementType property
Namespaces > ArtOfTest.WebAii.ObjectModel > Element > ElementType
Gets the element type (div, table ..etc).
Syntax
C#
public ElementType ElementType { get; }


Equals(obj) method

Element.Equals(obj) method
Namespaces > ArtOfTest.WebAii.ObjectModel > Element > Equals(Object)
Defines how two Elements should be compared.
Syntax
C#
public override bool Equals (
    Object obj
)
Parameters
obj (Object)
The object to compare.
Return Value
True/False whether the two objects are equal.


FindObjectUsed property

Element.FindObjectUsed property
Namespaces > ArtOfTest.WebAii.ObjectModel > Element > FindObjectUsed
Gets a reference to the Find object used to find this element
Syntax
C#
[BrowsableAttribute(false)]
public Find FindObjectUsed { get; }


FindParamsUsed property

Element.FindParamsUsed property
Namespaces > ArtOfTest.WebAii.ObjectModel > Element > FindParamsUsed
Gets the FindParams used to find this element when using the Find object. If chained identification is used this array will contain the list of params, otherwise will contain a single FindParam object. This property is not set when calling the Find.Allxxx methods.
Syntax
C#
[BrowsableAttribute(false)]
public FindParam[] FindParamsUsed { get; }


FriendlyName() method

Element.FriendlyName() method
Namespaces > ArtOfTest.WebAii.ObjectModel > Element > FriendlyName()
Constructs a friendly name that represents this element.
Syntax
C#
public string FriendlyName ()
Return Value
The string representation of this element.


GetAttribute methods

Element.GetAttribute methods
Namespaces > ArtOfTest.WebAii.ObjectModel > Element > GetAttribute
Members
Icon | Member | Description
 | GetAttribute(String) | Find a specific attribute by name and returns it. (case-insensitive)
 | GetAttribute(String, Boolean) | Finds a specific attribute name in the Element list of attributes and returns its object


GetAttribute(name) method

Element.GetAttribute(name) method
Namespaces > ArtOfTest.WebAii.ObjectModel > Element > GetAttribute(String)
Find a specific attribute by name and returns it. (case-insensitive)
Syntax
C#
public iAttribute GetAttribute (
    string name
)
Parameters
name (String)
The name of the attribute to get.
Return Value
The attribute or null if the attribute was not found.


GetAttribute(name, ignoreCase) method

Element.GetAttribute(name, ignoreCase) method
Namespaces > ArtOfTest.WebAii.ObjectModel > Element > GetAttribute(String, Boolean)
Finds a specific attribute name in the Element list of attributes and returns its object
Syntax
C#
public iAttribute GetAttribute (
    string name,
    bool ignoreCase
)
Parameters
name (String)
The name of the attribute to find.
ignoreCase (Boolean)
Ignore case when searching.
Return Value
The attribute object or null if the attribute is not found.


GetAttributeValueOrEmpty(attrName) method

Element.GetAttributeValueOrEmpty(attrName) method
Namespaces > ArtOfTest.WebAii.ObjectModel > Element > GetAttributeValueOrEmpty(String)
Gets the value of the attribute or a String.Empty if attribute does not exist.
Syntax
C#
public string GetAttributeValueOrEmpty (
    string attrName
)
Parameters
attrName (String)
The attribute to get.
Return Value
String.Empty if not found, else the attribute name.


GetHashCode() method

Element.GetHashCode() method
Namespaces > ArtOfTest.WebAii.ObjectModel > Element > GetHashCode()
Get the hash code for this Element.
Syntax
C#
public override int GetHashCode ()
Return Value
The hash code.


GetNextSibling() method

Element.GetNextSibling() method
Namespaces > ArtOfTest.WebAii.ObjectModel > Element > GetNextSibling()
Get the next sibling of this node. If this node is the last sibling, will return null.
Syntax
C#
public Element GetNextSibling ()
Return Value
The next sibiling.


GetPreviousSibling() method

Element.GetPreviousSibling() method
Namespaces > ArtOfTest.WebAii.ObjectModel > Element > GetPreviousSibling()
Get the previous sibiling of this node. If this node is the first sibling, will return null.
Syntax
C#
public Element GetPreviousSibling ()
Return Value
The previous sibling


GetRectangle() method

Element.GetRectangle() method
Namespaces > ArtOfTest.WebAii.ObjectModel > Element > GetRectangle()
Gets the element rectangle. (X,Y) and width, height as it appears on browser and screen. Takes into account any scrolling.
Syntax
C#
public virtual Rectangle GetRectangle ()
Return Value
The rectangle object of this element.


GetValue<T>(propertyName) method

Element.GetValue<T>(propertyName) method
Namespaces > ArtOfTest.WebAii.ObjectModel > Element > GetValue<(Of T>)(String)
Get a property value on this element.
Syntax
C#
public virtual T GetValue<T> (
    string propertyName
)
Generic Template Parameters
T
The type of the property to return.
Parameters
propertyName (String)
The property name.
Return Value
The property value returned as type T.


HasIdOrName property

Element.HasIdOrName property
Namespaces > ArtOfTest.WebAii.ObjectModel > Element > HasIdOrName
Gets whether this element has an id or a name set on it.
Syntax
C#
public bool HasIdOrName { get; }
Return Value


IdAttributeValue property

Element.IdAttributeValue property
Namespaces > ArtOfTest.WebAii.ObjectModel > Element > IdAttributeValue
Gets the value of the attribute ('id') if present on this tag.
Syntax
C#
public string IdAttributeValue { get; }


InnerMarkup property

Element.InnerMarkup property
Namespaces > ArtOfTest.WebAii.ObjectModel > Element > InnerMarkup
Gets the InnerMarkup of this element.
Examples
Example: <foo id="1">hello<bar></bar></foo> If foo is this element then InnerMarkup=<bar></bar>
Syntax
C#
public string InnerMarkup { get; }


InnerText property

Element.InnerText property
Namespaces > ArtOfTest.WebAii.ObjectModel > Element > InnerText
Gets this element's inner text content including all of its nested children.
Examples
Example: <foo id="1">one<bar>two</bar></foo> If foo is this element then InnerText=onetwo
Syntax
C#
public string InnerText { get; }


InputElementType property

Element.InputElementType property
Namespaces > ArtOfTest.WebAii.ObjectModel > Element > InputElementType
Gets the Input type (i.e. checkbox, radio...etc) if the ElementType=Input. Otherwise, will return NotSet.
Syntax
C#
public InputElementType InputElementType { get; }


IsBeginTag property

Element.IsBeginTag property
Namespaces > ArtOfTest.WebAii.ObjectModel > Element > IsBeginTag
Gets whether it is a begin tag <foo bar='me'> .
Syntax
C#
public bool IsBeginTag { get; }


IsEndTag property

Element.IsEndTag property
Namespaces > ArtOfTest.WebAii.ObjectModel > Element > IsEndTag
Gets whether this element is an end tag </foo>.
Syntax
C#
public bool IsEndTag { get; }


IsProxy property

Element.IsProxy property
Namespaces > ArtOfTest.WebAii.ObjectModel > Element > IsProxy
Gets whether this element is a proxy element or a fully initialized element.
Syntax
C#
[BrowsableAttribute(false)]
public bool IsProxy { get; }


IsSelfClosing property

Element.IsSelfClosing property
Namespaces > ArtOfTest.WebAii.ObjectModel > Element > IsSelfClosing
Gets whether the element is self-closing (<foo />).
Syntax
C#
public bool IsSelfClosing { get; }


MatchingClosingTag property

Element.MatchingClosingTag property
Namespaces > ArtOfTest.WebAii.ObjectModel > Element > MatchingClosingTag
Gets the element's closing tag if it is a begin tag and not self-closing.
Syntax
C#
public Element MatchingClosingTag { get; set; }


NameAttributeValue property

Element.NameAttributeValue property
Namespaces > ArtOfTest.WebAii.ObjectModel > Element > NameAttributeValue
Gets the value of the attribute ('name') if present on this tag
Syntax
C#
public string NameAttributeValue { get; }


OuterMarkup property

Element.OuterMarkup property
Namespaces > ArtOfTest.WebAii.ObjectModel > Element > OuterMarkup
Gets the OuterMarkup of this element.
Examples
Example: <foo id="1"><bar></bar></foo> If foo is this element then outerMarkup=<foo id="1"><bar></bar></foo>
Syntax
C#
public string OuterMarkup { get; }


OwnerBrowser property

Element.OwnerBrowser property
Namespaces > ArtOfTest.WebAii.ObjectModel > Element > OwnerBrowser
Returns the owner browser of this element.
Syntax
C#
[BrowsableAttribute(false)]
public Browser OwnerBrowser { get; }


Parent property

Element.Parent property
Namespaces > ArtOfTest.WebAii.ObjectModel > Element > Parent
Gets the Parent element.
Syntax
C#
public Element Parent { get; }


ParsingType property

Element.ParsingType property
Namespaces > ArtOfTest.WebAii.ObjectModel > Element > ParsingType
Gets the parsing type set by the parser. (Markup, LiteralText, Comment..etc)
Syntax
C#
public ParsedElementType ParsingType { get; }


Refresh methods

Element.Refresh methods
Namespaces > ArtOfTest.WebAii.ObjectModel > Element > Refresh
Members
Icon | Member | Description
 | Refresh() | Using the FindParamsUsed and the TestRegionIdUsed to find this element last, this methods will attempt to re-find this element in the new DOM tree.
 | Refresh(Boolean) | Using the FindParamsUsed and the TestRegionIdUsed to find this element last, this methods will attempt to re-find this element in the new DOM tree.


Refresh() method

Element.Refresh() method
Namespaces > ArtOfTest.WebAii.ObjectModel > Element > Refresh()
Using the FindParamsUsed and the TestRegionIdUsed to find this element last, this methods will attempt to re-find this element in the new DOM tree.
Syntax
C#
public virtual void Refresh ()


Refresh(forceDomTreeRefresh) method

Element.Refresh(forceDomTreeRefresh) method
Namespaces > ArtOfTest.WebAii.ObjectModel > Element > Refresh(Boolean)
Using the FindParamsUsed and the TestRegionIdUsed to find this element last, this methods will attempt to re-find this element in the new DOM tree.
Syntax
C#
public virtual void Refresh (
    bool forceDomTreeRefresh
)
Parameters
forceDomTreeRefresh (Boolean)
Force a Browser/Plugin refresh before attempting to refine this element.


SetValue<T>(propertyName, value) method

Element.SetValue<T>(propertyName, value) method
Namespaces > ArtOfTest.WebAii.ObjectModel > Element > SetValue<(Of T>)(String, T)
Set a property to a value on this element.
Syntax
C#
public virtual void SetValue<T> (
    string propertyName,
    T value
)
Generic Template Parameters
T
The type of the value.
Parameters
propertyName (String)
The property name.
value (T)
The value.


TagName property

Element.TagName property
Namespaces > ArtOfTest.WebAii.ObjectModel > Element > TagName
Gets the tagName of the the element
Syntax
C#
public string TagName { get; }


TagNameIndex property

Element.TagNameIndex property
Namespaces > ArtOfTest.WebAii.ObjectModel > Element > TagNameIndex
Gets the tagName occurrence of this element.
Examples
If this element is TagName='foo', then TagNameIndex= 3 indicates that this element represents the third occurence of tagName 'foo' within this document.
Syntax
C#
public int TagNameIndex { get; }


TextContent property

Element.TextContent property
Namespaces > ArtOfTest.WebAii.ObjectModel > Element > TextContent
Gets this element's inner text content without recursing through all its nested children for text.
Syntax
C#
public string TextContent { get; }


ToString() method

Element.ToString() method
Namespaces > ArtOfTest.WebAii.ObjectModel > Element > ToString()
String representation of an Element.
Syntax
C#
public override string ToString ()
Return Value
The string representation.


Wait property

Element.Wait property
Namespaces > ArtOfTest.WebAii.ObjectModel > Element > Wait
Gets the wait object to wait for certain conditions of this element.
Syntax
C#
[BrowsableAttribute(false)]
public Wait Wait { get; }


ElementGenderType enumeration

ElementGenderType enumeration
Namespaces > ArtOfTest.WebAii.ObjectModel > ElementGenderType
The element gender that this element is representing. (i.e. Html or Xaml)
Syntax
C#
public enum ElementGenderType
Members
Member | Description
Html | Html element.
Xaml | Xaml element.


ElementState enumeration

ElementState enumeration
Namespaces > ArtOfTest.WebAii.ObjectModel > ElementState
Possible element states
Syntax
C#
public enum ElementState
Members
Member | Description
NotSet | State not set.
ProxyInitialized | The element was created using a Element(FindParam,Find) constructor instead of being created using the Find.Byxx Properties of this Element are not accessible until .Refresh or Refresh(bool) is called. You can also use the Element.Wait.Exists()/ExistsNot() to wait for this element to exist on the page.
Initialized | The element is fully initialized. Created by Find.Byxxx


ElementType enumeration

ElementType enumeration
Namespaces > ArtOfTest.WebAii.ObjectModel > ElementType
The element type of an element within the Dom.
Syntax
C#
public enum ElementType
Members
Member | Description
CascadingStyleSheet | The element is a css style sheet. For example ( <link type="text/css"> or <style></style> )
Script | The element is a script. For example ( <script></script> )
Table | The element is a table. For example ( <table></table> )
Div | The element is a Div. For example ( <div></div> )
FrameSet | The element is a Frameset. For example ( <frameset></frameset> )
Frame | The element is a Frame. For example ( <frame></frame> )
IFrame | The element is an IFrame. For example ( <iframe></iframe> )
Anchor | The element is an anchor. For example ( <a href="somefile.htm">click me</a> )
Image | The element is an image. For example ( <img></img> )
Map | The element is an imagemap. For example ( <map></map> )
Link | The element is a link. For example ( <link></link> )
TestRegion | The element is a testregion. For example ( <testregion id="foo"></testregion> or <!--testregion id="foo"--><!--/testregion--> )
Select | The element is a select. For example ( <select></select> )
Input | The element is an input. For example ( <input></input> )
TextArea | The element is a textarea. For example ( <textarea></textarea> )
Other | Anything else.


FindContentType enumeration

FindContentType enumeration
Namespaces > ArtOfTest.WebAii.ObjectModel > FindContentType
Types of identification of type=Content
Syntax
C#
public enum FindContentType
Members
Member | Description
InnerText | The inner text of a tag and all its children. (Element.InnerText).
InnerMarkup | The inner markup of a tag. (Element.InnerMarkup).
OuterMarkup | The outer markup of a tag. (Element.OuterMarkup).
TextContent | Text content of the tag only without all its children. (Element.TextContent).
StartTagContent | The raw start tag content. (Element.Content).


FindParam class

FindParam class
Namespaces > ArtOfTest.WebAii.ObjectModel > FindParam
A class that defines how a search for an element should be conducted within a document.
Syntax
C#
[SerializableAttribute]
[XmlRootAttribute]
public class FindParam : INotifyPropertyChanged
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | FindParamNew() | Create a new FindParam
 | FindParamNew(FindType, String, String[]()) | Create a new FindParam by explicitly specifying the FindType.
 | FindParamNew(Int32[]()) | Create a new find parameter of Type=NodeIndexPath
 | FindParamNew(String, Int32) | Create a new find parameter of Type=TagIndex
 | FindParamNew(String, Int32, String[]()) | Create a new find parameter of Type=TagIndex with additional attributes to use to find the element or verify it.
 | FindParamNew(String[]()) | Create a new find parameter using name-value pairs of attributes.
 | Attributes | Gets/Sets the list of Attributes to use for identification.
 | ContentType | Gets/Sets the content type when the identification type is Content. (Default:TextContent)
 | ContentValue | Gets/Sets the content value to find when type is Content. This can be a string to validate against or a regular expression. The content must start with: 'l:' for exact match strings, 'p:' for partial strings or 'x:' for regular expression matches. If none are provided the string will be matched using an exact match 'l:'. All searches are case-insensitive. Examples To find tags with innerText content is: 'foo bar' Example 1: 'l:foo bar' Example 2: 'p:foo' Example 3: 'x:foo\s*bar'
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType() | Gets the Type of the current instance. (Inherited from Object.)
 | LoadFromFile(String) | Load a FindParam from a file.
 | LoadFromXml(String) | Load a FindParam from an xml persisted string.
 | MemberwiseClone() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NodeIndexPath | Gets/Sets Hierarchal path from the reference element when Type=NodeIndexPath.
 | PartialAttributes | Gets/Sets the partial attribute values to use for identification.
 | PropertyChanged | Occurs when a property changes on this FindParam object.
 | Save(String) | Serialized and saves the current FindParam to a file. You can later load that file using FindParam.Load().
 | SearchAttributes |
 | TagIndex | Gets/Sets tagName occurrence index when Type=TagIndex
 | TagName | Gets/Sets the tagName of the element this parameter identifies.
 | ToString() | String representation of the FindParam. (Overrides Object.ToString().)
 | ToXml() | Serialize and return the current FindParam as a string. You can later use that string to create a FindParam using the .Load().
 | Type | Gets/Sets the identification type to use to identify this element. (Default:TagIndex)
 | XPath | Gets/Sets the XPath to use when Type=XPath.
Inheritance Hierarchy
Object
FindParam


Attributes property

FindParam.Attributes property
Namespaces > ArtOfTest.WebAii.ObjectModel > FindParam > Attributes
Gets/Sets the list of Attributes to use for identification.
Syntax
C#
[BrowsableAttribute(false)]
[XmlArrayItemAttribute]
public Collection<iAttribute> Attributes { get; set; }


Constructors

FindParam constructors
Namespaces > ArtOfTest.WebAii.ObjectModel > FindParam > FindParamNew
Members
Icon | Member | Description
 | FindParamNew() | Create a new FindParam
 | FindParamNew(FindType, String, String[]()) | Create a new FindParam by explicitly specifying the FindType.
 | FindParamNew(Int32[]()) | Create a new find parameter of Type=NodeIndexPath
 | FindParamNew(String, Int32) | Create a new find parameter of Type=TagIndex
 | FindParamNew(String, Int32, String[]()) | Create a new find parameter of Type=TagIndex with additional attributes to use to find the element or verify it.
 | FindParamNew(String[]()) | Create a new find parameter using name-value pairs of attributes.


FindParam() constructor

FindParam() constructor
Namespaces > ArtOfTest.WebAii.ObjectModel > FindParam > FindParamNew()
Create a new FindParam
Syntax
C#
public FindParam ()


FindParam(attributesNameValuePairs) constructor

FindParam(attributesNameValuePairs) constructor
Namespaces > ArtOfTest.WebAii.ObjectModel > FindParam > FindParamNew(String[]())
Create a new find parameter using name-value pairs of attributes.
Syntax
C#
public FindParam (
    params string[] attributesNameValuePairs
)
Parameters
attributesNameValuePairs (String []())
The name value pairs. Example ("id=foo","style=~color:red"). Use '=~' to indicate partial values.


FindParam(nodesIndexPath) constructor

FindParam(nodesIndexPath) constructor
Namespaces > ArtOfTest.WebAii.ObjectModel > FindParam > FindParamNew(Int32[]())
Create a new find parameter of Type=NodeIndexPath
Syntax
C#
public FindParam (
    params int[] nodesIndexPath
)
Parameters
nodesIndexPath (Int32 []())
The index path of the desired node


FindParam(tagName, occurrenceIndex) constructor

FindParam(tagName, occurrenceIndex) constructor
Namespaces > ArtOfTest.WebAii.ObjectModel > FindParam > FindParamNew(String, Int32)
Create a new find parameter of Type=TagIndex
Syntax
C#
public FindParam (
    string tagName,
    int occurrenceIndex
)
Parameters
tagName (String)
The TagName to search for
occurrenceIndex (Int32)
The occurrence index of the target tag (zero-based).


FindParam(tagName, occurrenceIndex, attributesNameValuePairs) constructor

FindParam(tagName, occurrenceIndex, attributesNameValuePairs) constructor
Namespaces > ArtOfTest.WebAii.ObjectModel > FindParam > FindParamNew(String, Int32, String[]())
Create a new find parameter of Type=TagIndex with additional attributes to use to find the element or verify it.
Syntax
C#
public FindParam (
    string tagName,
    int occurrenceIndex,
    params string[] attributesNameValuePairs
)
Parameters
tagName (String)
The TagName to search for.
occurrenceIndex (Int32)
The occurrence index of the tag (Zero-Based).
attributesNameValuePairs (String []())
Any additional attributes to check for; both exact or partial


FindParam(type, value, attributesNameValuePairs) constructor

FindParam(type, value, attributesNameValuePairs) constructor
Namespaces > ArtOfTest.WebAii.ObjectModel > FindParam > FindParamNew(FindType, String, String[]())
Create a new FindParam by explicitly specifying the FindType.
Syntax
C#
public FindParam (
    FindType type,
    string value,
    params string[] attributesNameValuePairs
)
Parameters
type (FindType)
The find type.
value (String)
The value signifies the following depending on the type: Type=AttributesOnly:Value=(string.empty|tagName [When tagName is set, will match tagName in addition to attributes]),Type=NodeIndexPath:Value=(index path [i.e. "0/3/2/0"]), Type=XPath:Value=(xpath to use),Type=Content:Value=(content to use [i.e. "p:string"]) - default is FindContentType.TextContent, Type=TagIndex:Value(tagName:tagIndex [i.e. "input:3"])
attributesNameValuePairs (String []())
The attributes list, if any, else string.Empty.


ContentType property

FindParam.ContentType property
Namespaces > ArtOfTest.WebAii.ObjectModel > FindParam > ContentType
Gets/Sets the content type when the identification type is Content. (Default:TextContent)
Syntax
C#
[XmlAttributeAttribute]
[DescriptionAttribute("The content type to use for search when Type=Content")]
public FindContentType ContentType { get; set; }


ContentValue property

FindParam.ContentValue property
Namespaces > ArtOfTest.WebAii.ObjectModel > FindParam > ContentValue
Gets/Sets the content value to find when type is Content. This can be a string to validate against or a regular expression. The content must start with: 'l:' for exact match strings, 'p:' for partial strings or 'x:' for regular expression matches. If none are provided the string will be matched using an exact match 'l:'. All searches are case-insensitive.
Examples
To find tags with innerText content is: 'foo bar' Example 1: 'l:foo bar' Example 2: 'p:foo' Example 3: 'x:foo\s*bar'
Syntax
C#
[XmlAttributeAttribute]
[DescriptionAttribute("The content value to use when Type=Content")]
public string ContentValue { get; set; }


LoadFromFile(fileName) method

FindParam.LoadFromFile(fileName) method
Namespaces > ArtOfTest.WebAii.ObjectModel > FindParam > LoadFromFile(String)
Load a FindParam from a file.
Syntax
C#
public static FindParam LoadFromFile (
    string fileName
)
Parameters
fileName (String)
The file name to load the xml from.
Return Value
The FindParam object.


LoadFromXml(findParamXml) method

FindParam.LoadFromXml(findParamXml) method
Namespaces > ArtOfTest.WebAii.ObjectModel > FindParam > LoadFromXml(String)
Load a FindParam from an xml persisted string.
Syntax
C#
public static FindParam LoadFromXml (
    string findParamXml
)
Parameters
findParamXml (String)
The string.
Return Value
The FindParam object.


NodeIndexPath property

FindParam.NodeIndexPath property
Namespaces > ArtOfTest.WebAii.ObjectModel > FindParam > NodeIndexPath
Gets/Sets Hierarchal path from the reference element when Type=NodeIndexPath.
Syntax
C#
[BrowsableAttribute(false)]
[XmlAttributeAttribute]
public string NodeIndexPath { get; set; }


PartialAttributes property

FindParam.PartialAttributes property
Namespaces > ArtOfTest.WebAii.ObjectModel > FindParam > PartialAttributes
Gets/Sets the partial attribute values to use for identification.
Syntax
C#
[XmlArrayItemAttribute]
[BrowsableAttribute(false)]
public Collection<iAttribute> PartialAttributes { get; set; }


PropertyChanged event

FindParam.PropertyChanged event
Namespaces > ArtOfTest.WebAii.ObjectModel > FindParam > PropertyChanged
Occurs when a property changes on this FindParam object.
Syntax
C#
public event PropertyChangedEventHandler PropertyChanged


Save(fileName) method

FindParam.Save(fileName) method
Namespaces > ArtOfTest.WebAii.ObjectModel > FindParam > Save(String)
Serialized and saves the current FindParam to a file. You can later load that file using FindParam.Load().
Syntax
C#
public void Save (
    string fileName
)
Parameters
fileName (String)
The file name to save to.


SearchAttributes property

FindParam.SearchAttributes property
Namespaces > ArtOfTest.WebAii.ObjectModel > FindParam > SearchAttributes
Syntax
C#
[DescriptionAttribute("List of (partial & exact) attributes to use for identification. To edit attributes, select 'Edit' from the Element's Explorer context menu.")]
[XmlIgnoreAttribute]
public string SearchAttributes { get; }


TagIndex property

FindParam.TagIndex property
Namespaces > ArtOfTest.WebAii.ObjectModel > FindParam > TagIndex
Gets/Sets tagName occurrence index when Type=TagIndex
Syntax
C#
[DescriptionAttribute("The tag index to use when Type=TagIndex")]
[XmlAttributeAttribute]
public int TagIndex { get; set; }


TagName property

FindParam.TagName property
Namespaces > ArtOfTest.WebAii.ObjectModel > FindParam > TagName
Gets/Sets the tagName of the element this parameter identifies.
Syntax
C#
[XmlAttributeAttribute]
[DescriptionAttribute("The TagName to match for all searches")]
public string TagName { get; set; }


ToString() method

FindParam.ToString() method
Namespaces > ArtOfTest.WebAii.ObjectModel > FindParam > ToString()
String representation of the FindParam.
Syntax
C#
public override string ToString ()
Return Value
The string representation.


ToXml() method

FindParam.ToXml() method
Namespaces > ArtOfTest.WebAii.ObjectModel > FindParam > ToXml()
Serialize and return the current FindParam as a string. You can later use that string to create a FindParam using the .Load().
Syntax
C#
public string ToXml ()
Return Value
The serialized Xml that represents this object.


Type property

FindParam.Type property
Namespaces > ArtOfTest.WebAii.ObjectModel > FindParam > Type
Gets/Sets the identification type to use to identify this element. (Default:TagIndex)
Syntax
C#
[XmlAttributeAttribute]
[DescriptionAttribute("The type of search to use (i.e. AttributesOnly, Content, XPath ...etc)")]
public FindType Type { get; set; }


XPath property

FindParam.XPath property
Namespaces > ArtOfTest.WebAii.ObjectModel > FindParam > XPath
Gets/Sets the XPath to use when Type=XPath.
Syntax
C#
[XmlAttributeAttribute]
[DescriptionAttribute("The XPath to use when Type=XPath")]
public string XPath { get; set; }


FindParamCollection class

FindParamCollection class
Namespaces > ArtOfTest.WebAii.ObjectModel > FindParamCollection
Class to manage a collection of FindParam objects.
Syntax
C#
[SerializableAttribute]
[DefaultMemberAttribute("Item")]
[XmlRootAttribute]
public class FindParamCollection : Dictionary<string, FindParam>, IXmlSerializable, ISerializable
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | FindParamCollectionNew() | Create a new FindParam collection that also be serialized.
 | FindParamCollectionNew(SerializationInfo, StreamingContext) | Create new FindParamCollection. Serialization Constructor
 | Add(String, FindParam) | Add a new FindParam item. (Overrides Dictionary <(Of String, FindParam >).Add(String, FindParam).)
 | Clear() | Removes all keys and values from the Dictionary<(Of TKey, TValue>). (Inherited from Dictionary <(Of String, FindParam >).)
 | Comparer | Gets the IEqualityComparer<(Of T>) that is used to determine equality of keys for the dictionary. (Inherited from Dictionary <(Of String, FindParam >).)
 | ContainsKey(String) | Determines whether the Dictionary<(Of TKey, TValue>) contains the specified key. (Inherited from Dictionary <(Of String, FindParam >).)
 | ContainsValue(FindParam) | Determines whether the Dictionary<(Of TKey, TValue>) contains a specific value. (Inherited from Dictionary <(Of String, FindParam >).)
 | Count | Gets the number of key/value pairs contained in the Dictionary<(Of TKey, TValue>). (Inherited from Dictionary <(Of String, FindParam >).)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindParam}.Keys | (Inherited from Dictionary <(Of String, FindParam >).)
 | FindParam}.Values | (Inherited from Dictionary <(Of String, FindParam >).)
 | FindParam}}.Add(KeyValuePair<(Of String, FindParam>)) | (Inherited from Dictionary <(Of String, FindParam >).)
 | FindParam}}.Contains(KeyValuePair<(Of String, FindParam>)) | (Inherited from Dictionary <(Of String, FindParam >).)
 | FindParam}}.CopyTo(KeyValuePair<(Of String, FindParam>)[](), Int32) | (Inherited from Dictionary <(Of String, FindParam >).)
 | FindParam}}.GetEnumerator() | (Inherited from Dictionary <(Of String, FindParam >).)
 | FindParam}}.IsReadOnly | (Inherited from Dictionary <(Of String, FindParam >).)
 | FindParam}}.Remove(KeyValuePair<(Of String, FindParam>)) | (Inherited from Dictionary <(Of String, FindParam >).)
 | GetEnumerator() | Returns an enumerator that iterates through the Dictionary<(Of TKey, TValue>). (Inherited from Dictionary <(Of String, FindParam >).)
 | GetHashCode() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | Implements the ISerializable interface and returns the data needed to serialize the Dictionary<(Of TKey, TValue>) instance. (Inherited from Dictionary <(Of String, FindParam >).)
 | GetSchema() | Return the schema used for serialization. Remarks Currently we are returning null
 | GetType() | Gets the Type of the current instance. (Inherited from Object.)
 | ICollection.CopyTo(Array, Int32) | (Inherited from Dictionary <(Of String, FindParam >).)
 | ICollection.IsSynchronized | (Inherited from Dictionary <(Of String, FindParam >).)
 | ICollection.SyncRoot | (Inherited from Dictionary <(Of String, FindParam >).)
 | IDictionary.Add(Object, Object) | (Inherited from Dictionary <(Of String, FindParam >).)
 | IDictionary.Contains(Object) | (Inherited from Dictionary <(Of String, FindParam >).)
 | IDictionary.GetEnumerator() | (Inherited from Dictionary <(Of String, FindParam >).)
 | IDictionary.IsFixedSize | (Inherited from Dictionary <(Of String, FindParam >).)
 | IDictionary.IsReadOnly | (Inherited from Dictionary <(Of String, FindParam >).)
 | IDictionary.Item(Object) | (Inherited from Dictionary <(Of String, FindParam >).)
 | IDictionary.Keys | (Inherited from Dictionary <(Of String, FindParam >).)
 | IDictionary.Remove(Object) | (Inherited from Dictionary <(Of String, FindParam >).)
 | IDictionary.Values | (Inherited from Dictionary <(Of String, FindParam >).)
 | IEnumerable.GetEnumerator() | (Inherited from Dictionary <(Of String, FindParam >).)
 | ISerializable.System.Runtime.Serialization.ISerializable.GetObjectData(SerializationInfo, StreamingContext) |
 | Item(String) | Access a FindParam using its key. (Overrides Dictionary<(Of TKey, TValue>).Item(TKey).)
 | ItemAdded | Occurs when a new items is added to this collection.
 | Keys | Gets a collection containing the keys in the Dictionary<(Of TKey, TValue>). (Inherited from Dictionary <(Of String, FindParam >).)
 | LoadFromFile(String) | Load a FindParamCollection from a file.
 | LoadFromXml(String) | Load a FindParamCollection from an xml persisted string.
 | MemberwiseClone() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OnDeserialization(Object) | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from Dictionary <(Of String, FindParam >).)
 | OnItemAdded(FindParamCollectionItemAddedEventArgs) | Trigger the ItemAdded event.
 | ReadXml(XmlReader) | Deserialized from the xmlReader and initialize the object
 | Remove(String) | Removes the value with the specified key from the Dictionary<(Of TKey, TValue>). (Inherited from Dictionary <(Of String, FindParam >).)
 | ReturnNullIfNotFound | Gets/Sets whether to throw or return null if a FindParam is not found.
 | Save(String) | Serialized and saves the current collection to a file. You can later load that file using FindParamCollection.Load().
 | ToArray() | Get an array of FindParam objects contained in this collection.
 | ToString() | Returns a String that represents the current Object. (Inherited from Object.)
 | ToXml() | Serialize and return the current FindParamCollection as a string. You can later use that string to create a FindParamCollection using the .Load().
 | TryGetValue(String, FindParam) | (Inherited from Dictionary <(Of String, FindParam >).)
 | Values | Gets a collection containing the values in the Dictionary<(Of TKey, TValue>). (Inherited from Dictionary <(Of String, FindParam >).)
 | WriteXml(XmlWriter) | Serialize this object to the XmlWriter
Inheritance Hierarchy
Object
 | Dictionary <(Of String, FindParam >)
 |  | FindParamCollection


Add(key, param) method

FindParamCollection.Add(key, param) method
Namespaces > ArtOfTest.WebAii.ObjectModel > FindParamCollection > Add(String, FindParam)
Add a new FindParam item.
Syntax
C#
public void Add (
    string key,
    FindParam param
)
Parameters
key (String)
The key.
param (FindParam)
The FindParam object.


Constructors

FindParamCollection constructors
Namespaces > ArtOfTest.WebAii.ObjectModel > FindParamCollection > FindParamCollectionNew
Members
Icon | Member | Description
 | FindParamCollectionNew() | Create a new FindParam collection that also be serialized.
 | FindParamCollectionNew(SerializationInfo, StreamingContext) | Create new FindParamCollection. Serialization Constructor


FindParamCollection() constructor

FindParamCollection() constructor
Namespaces > ArtOfTest.WebAii.ObjectModel > FindParamCollection > FindParamCollectionNew()
Create a new FindParam collection that also be serialized.
Syntax
C#
public FindParamCollection ()


FindParamCollection(info, context) constructor

FindParamCollection(info, context) constructor
Namespaces > ArtOfTest.WebAii.ObjectModel > FindParamCollection > FindParamCollectionNew(SerializationInfo, StreamingContext)
Create new FindParamCollection. Serialization Constructor
Syntax
C#
public FindParamCollection (
    SerializationInfo info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
Serialization info
context (StreamingContext)
Serialization context


GetObjectData(info, context) method

FindParamCollection.GetObjectData(info, context) method
Namespaces > ArtOfTest.WebAii.ObjectModel > FindParamCollection > ISerializable.System.Runtime.Serialization.ISerializable.GetObjectData(SerializationInfo, StreamingContext)
Syntax
C#
private void ISerializable.GetObjectData (
    SerializationInfo info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
context (StreamingContext)


GetSchema() method

FindParamCollection.GetSchema() method
Namespaces > ArtOfTest.WebAii.ObjectModel > FindParamCollection > GetSchema()
Return the schema used for serialization.
Remarks
Currently we are returning null
Syntax
C#
public XmlSchema GetSchema ()
Return Value
The schema


Item[key] property

FindParamCollection.Item[key] property
Namespaces > ArtOfTest.WebAii.ObjectModel > FindParamCollection > Item(String)
Access a FindParam using its key.
Syntax
C#
public FindParam this [
    string key
] { get; }
Parameters
key (String)
The key.
Return Value
The FindParam object.


ItemAdded event

FindParamCollection.ItemAdded event
Namespaces > ArtOfTest.WebAii.ObjectModel > FindParamCollection > ItemAdded
Occurs when a new items is added to this collection.
Syntax
C#
public event EventHandler<FindParamCollectionItemAddedEventArgs> ItemAdded


LoadFromFile(fileName) method

FindParamCollection.LoadFromFile(fileName) method
Namespaces > ArtOfTest.WebAii.ObjectModel > FindParamCollection > LoadFromFile(String)
Load a FindParamCollection from a file.
Syntax
C#
public static FindParamCollection LoadFromFile (
    string fileName
)
Parameters
fileName (String)
The file name to load the xml from.
Return Value
The FindParamCollection object.


LoadFromXml(xml) method

FindParamCollection.LoadFromXml(xml) method
Namespaces > ArtOfTest.WebAii.ObjectModel > FindParamCollection > LoadFromXml(String)
Load a FindParamCollection from an xml persisted string.
Syntax
C#
public static FindParamCollection LoadFromXml (
    string xml
)
Parameters
xml (String)
The string string.
Return Value
The FindParamCollection object.


OnItemAdded(item) method

FindParamCollection.OnItemAdded(item) method
Namespaces > ArtOfTest.WebAii.ObjectModel > FindParamCollection > OnItemAdded(FindParamCollectionItemAddedEventArgs)
Trigger the ItemAdded event.
Syntax
C#
public void OnItemAdded (
    FindParamCollectionItemAddedEventArgs item
)
Parameters
item (FindParamCollectionItemAddedEventArgs)
The event argument.


ReadXml(reader) method

FindParamCollection.ReadXml(reader) method
Namespaces > ArtOfTest.WebAii.ObjectModel > FindParamCollection > ReadXml(XmlReader)
Deserialized from the xmlReader and initialize the object
Syntax
C#
public void ReadXml (
    XmlReader reader
)
Parameters
reader (XmlReader)
The reader.


ReturnNullIfNotFound property

FindParamCollection.ReturnNullIfNotFound property
Namespaces > ArtOfTest.WebAii.ObjectModel > FindParamCollection > ReturnNullIfNotFound
Gets/Sets whether to throw or return null if a FindParam is not found.
Syntax
C#
public bool ReturnNullIfNotFound { get; set; }


Save(fileName) method

FindParamCollection.Save(fileName) method
Namespaces > ArtOfTest.WebAii.ObjectModel > FindParamCollection > Save(String)
Serialized and saves the current collection to a file. You can later load that file using FindParamCollection.Load().
Syntax
C#
public void Save (
    string fileName
)
Parameters
fileName (String)
The file name to save to.


ToArray() method

FindParamCollection.ToArray() method
Namespaces > ArtOfTest.WebAii.ObjectModel > FindParamCollection > ToArray()
Get an array of FindParam objects contained in this collection.
Syntax
C#
public FindParam[] ToArray ()
Return Value
The array.


ToXml() method

FindParamCollection.ToXml() method
Namespaces > ArtOfTest.WebAii.ObjectModel > FindParamCollection > ToXml()
Serialize and return the current FindParamCollection as a string. You can later use that string to create a FindParamCollection using the .Load().
Syntax
C#
public string ToXml ()
Return Value
The serialized Xml that represents this object.


WriteXml(writer) method

FindParamCollection.WriteXml(writer) method
Namespaces > ArtOfTest.WebAii.ObjectModel > FindParamCollection > WriteXml(XmlWriter)
Serialize this object to the XmlWriter
Syntax
C#
public void WriteXml (
    XmlWriter writer
)
Parameters
writer (XmlWriter)
The writer.


FindType enumeration

FindType enumeration
Namespaces > ArtOfTest.WebAii.ObjectModel > FindType
Types of identification supported by the framework.
Syntax
C#
public enum FindType
Members
Member | Description
NodeIndexPath | NodeIndexPath identification.
TagIndex | Tag name occurrence identification.
AttributesOnly | Identification using attributes only.
XPath | Identification using XPath.
Content | Identification using the content of the tag. Content can be (InnerText, InnerMarkup or OuterMarkup)


iAttribute class

iAttribute class
Namespaces > ArtOfTest.WebAii.ObjectModel > iAttribute
This class represents a markup attribute (foo="bar"). The iAttribute object contains a starting 'i' to distinguish it from System.Attribute.
Syntax
C#
[SerializableAttribute]
[XmlRootAttribute]
public class iAttribute : INotifyPropertyChanged
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon Member Description
iAttributeNew()
Create a new attribute.
iAttributeNew(String, String)
Create a new attribute.
AttributeType
Gets the attribute type (i.e. Style/Event/Other).
BeginQuote
Gets/Sets the begin quote type of the attribute.
ContainsPartialAttributeValue(iAttribute, StringComparison)
Determines whether a partial attribute value is contained in this attribute value Also makes sure the attribute name is correct.
EndQuote
Gets/Sets the end quote type of the attribute
Equals(iAttribute, StringComparison, Boolean)
Determines equality between two attributes
Equals(Object)
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Finalize()
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
GetAttributeList(String[]())
Quick shortcut to get a list of attributes. Pass in the name/value pairs as a semi-colon delimited list.
Examples
For example: GetAttributeList("id=foo","checked=true") Note: Any string that don't contain a pair will be ignored. Don't include an type of quotes.
GetHashCode()
Serves as a hash function for a particular type.
(Inherited from Object.)
GetType()
Gets the Type of the current instance.
(Inherited from Object.)
IsSingular
Gets/Sets whether the attribute is singluar.
Examples
  The nowrap attribute is a singluar attribute in  <foo id="myfoo" nowrap /> .

MemberwiseClone()
Creates a shallow copy of the current Object.
(Inherited from Object.)
Name
Gets/Sets the name of this attribute.
PropertyChanged
Occurs when a property changes on this iAttribute object.
RawValue
The raw value of the attribute including any quotes.
Styles
The Styles collection if AttributeType = Style.
Examples
The following element <foo style="height:1px;width:2px;" /> , will contain a NameValueCollection that consists of two items: The first : name=height,value=1px The second : name=width,value=2px
ToString()
A string representation of the attribute.
(Overrides Object.ToString().)
Value
Gets/Sets the value of this attribute.
Remarks
The value will be trimmed from any beginning or ending quotes. If you need the raw value use the RawValue property.
Inheritance Hierarchy
Object
iAttribute


AttributeType property

iAttribute.AttributeType property
Namespaces > ArtOfTest.WebAii.ObjectModel > iAttribute > AttributeType
Gets the attribute type (i.e. Style/Event/Other).
Syntax
C#
[XmlIgnoreAttribute]
public AttributeType AttributeType { get; }


BeginQuote property

iAttribute.BeginQuote property
Namespaces > ArtOfTest.WebAii.ObjectModel > iAttribute > BeginQuote
Gets/Sets the begin quote type of the attribute.
Syntax
C#
[XmlIgnoreAttribute]
[BrowsableAttribute(false)]
public Quote BeginQuote { get; set; }


Constructors

iAttribute constructors
Namespaces > ArtOfTest.WebAii.ObjectModel > iAttribute > iAttributeNew
Members
Icon | Member | Description
 | iAttributeNew() | Create a new attribute.
 | iAttributeNew(String, String) | Create a new attribute.


iAttribute() constructor

iAttribute() constructor
Namespaces > ArtOfTest.WebAii.ObjectModel > iAttribute > iAttributeNew()
Create a new attribute.
Syntax
C#
public iAttribute ()


iAttribute(name, value) constructor

iAttribute(name, value) constructor
Namespaces > ArtOfTest.WebAii.ObjectModel > iAttribute > iAttributeNew(String, String)
Create a new attribute.
Syntax
C#
public iAttribute (
    string name,
    string value
)
Parameters
name (String)
Name of the attribute.
value (String)
Value of the attribute.


ContainsPartialAttributeValue(partialAttributeToCompare, comparison) method

iAttribute.ContainsPartialAttributeValue(partialAttributeToCompare, comparison) method
Namespaces > ArtOfTest.WebAii.ObjectModel > iAttribute > ContainsPartialAttributeValue(iAttribute, StringComparison)
Determines whether a partial attribute value is contained in this attribute value Also makes sure the attribute name is correct.
Syntax
C#
public bool ContainsPartialAttributeValue (
    iAttribute partialAttributeToCompare,
    StringComparison comparison
)
Parameters
partialAttributeToCompare (iAttribute)
The partial attribute to compare.
comparison (StringComparison)
Type of comparison to perform.
Return Value
True/False whether this attribute contains the parital attribute value passed in.


EndQuote property

iAttribute.EndQuote property
Namespaces > ArtOfTest.WebAii.ObjectModel > iAttribute > EndQuote
Gets/Sets the end quote type of the attribute
Syntax
C#
[XmlIgnoreAttribute]
[BrowsableAttribute(false)]
public Quote EndQuote { get; set; }


Equals(obj, comparison, matchQuotes) method

iAttribute.Equals(obj, comparison, matchQuotes) method
Namespaces > ArtOfTest.WebAii.ObjectModel > iAttribute > Equals(iAttribute, StringComparison, Boolean)
Determines equality between two attributes
Syntax
C#
public bool Equals (
    iAttribute obj,
    StringComparison comparison,
    bool matchQuotes
)
Parameters
obj (iAttribute)
The object to compare.
comparison (StringComparison)
The type of comparsion to perform.
matchQuotes (Boolean)
Whether to match the begin/end quotes or just the value.
Return Value
True/False whether they are the same.


GetAttributeList(nameValuePairs) method

iAttribute.GetAttributeList(nameValuePairs) method
Namespaces > ArtOfTest.WebAii.ObjectModel > iAttribute > GetAttributeList(String[]())
Quick shortcut to get a list of attributes. Pass in the name/value pairs as a semi-colon delimited list.
Examples
For example: GetAttributeList("id=foo","checked=true") Note: Any string that don't contain a pair will be ignored. Don't include an type of quotes.
Syntax
C#
public static Collection<iAttribute> GetAttributeList (
    params string[] nameValuePairs
)
Parameters
nameValuePairs (String []())
The name value pairs.
Return Value
The list of attributes.


IsSingular property

iAttribute.IsSingular property
Namespaces > ArtOfTest.WebAii.ObjectModel > iAttribute > IsSingular
Gets/Sets whether the attribute is singluar.
Examples
  The nowrap attribute is a singluar attribute in  <foo id="myfoo" nowrap /> .

Syntax
C#
[NotifyParentPropertyAttribute(true)]
[BrowsableAttribute(false)]
[XmlIgnoreAttribute]
public bool IsSingular { get; set; }


Name property

iAttribute.Name property
Namespaces > ArtOfTest.WebAii.ObjectModel > iAttribute > Name
Gets/Sets the name of this attribute.
Syntax
C#
[NotifyParentPropertyAttribute(true)]
[XmlAttributeAttribute]
[ReadOnlyAttribute(true)]
public string Name { get; set; }


PropertyChanged event

iAttribute.PropertyChanged event
Namespaces > ArtOfTest.WebAii.ObjectModel > iAttribute > PropertyChanged
Occurs when a property changes on this iAttribute object.
Syntax
C#
public event PropertyChangedEventHandler PropertyChanged


RawValue property

iAttribute.RawValue property
Namespaces > ArtOfTest.WebAii.ObjectModel > iAttribute > RawValue
The raw value of the attribute including any quotes.
Syntax
C#
[XmlIgnoreAttribute]
public string RawValue { get; }


Styles property

iAttribute.Styles property
Namespaces > ArtOfTest.WebAii.ObjectModel > iAttribute > Styles
The Styles collection if AttributeType = Style.
Examples
The following element <foo style="height:1px;width:2px;" /> , will contain a NameValueCollection that consists of two items: The first : name=height,value=1px The second : name=width,value=2px
Syntax
C#
[XmlIgnoreAttribute]
[BrowsableAttribute(false)]
public NameValueCollection Styles { get; }


ToString() method

iAttribute.ToString() method
Namespaces > ArtOfTest.WebAii.ObjectModel > iAttribute > ToString()
A string representation of the attribute.
Syntax
C#
public override string ToString ()
Return Value
The string representation.


Value property

iAttribute.Value property
Namespaces > ArtOfTest.WebAii.ObjectModel > iAttribute > Value
Gets/Sets the value of this attribute.
Remarks
The value will be trimmed from any beginning or ending quotes. If you need the raw value use the RawValue property.
Syntax
C#
[XmlAttributeAttribute]
[NotifyParentPropertyAttribute(true)]
[ReadOnlyAttribute(true)]
public string Value { get; set; }


InputElementType enumeration

InputElementType enumeration
Namespaces > ArtOfTest.WebAii.ObjectModel > InputElementType
The types of input for an ElementType=Input.
Syntax
C#
public enum InputElementType
Members
Member | Description
NotSet | Not set.
Button | type="button"
CheckBox | type="checkbox"
File | type="file"
Hidden | type="hidden"
Image | type="image"
Password | type="password"
Radio | type="radio"
Reset | type="reset"
Submit | type="submit"
Text | type="text". This is the default type if no type attribute is set.


ParsedElementType enumeration

ParsedElementType enumeration
Namespaces > ArtOfTest.WebAii.ObjectModel > ParsedElementType
The type set by the parser when an element is parsed.
Syntax
C#
public enum ParsedElementType
Members
Member | Description
TextLiteral | A literal text element.
Markup | Any markup element.
OrphanedClosingTag | An orphaned closing tag with no open tag.
MalFormed | A malformed tag. (example: </foo/> )
Comment | A markup comment tag. (example: <!-- comment --> )
DocType | A DOCTYPE tag.


Quote enumeration

Quote enumeration
Namespaces > ArtOfTest.WebAii.ObjectModel > Quote
Types of quotes parsed.
Syntax
C#
public enum Quote
Members
Member | Description
Single | A single quote. (')
Double | A double quote. (")
None | No quotes.


TestRegion class

TestRegion class
Namespaces > ArtOfTest.WebAii.ObjectModel > TestRegion
Class representing a TestRegion Object defined in the document as: <testregion id="foo"> ... </testregion> or <!--testregion id="foo"--> ... <!--/testregion>
Syntax
C#
public class TestRegion
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AllChildRegions | Gets a list of all sub regions contained in this region regardless of their depth relative to this region.
 | ChildRegions | Gets a list of all direct sub regions of this region.
 | ContainsElement(Element, Boolean) | Checks if a certain element is contained in this region or not.
 | Element | Gets the element object that represents this region in the Dom tree.
 | Equals(Object) | Defined how two TestRegions should be compared. (Overrides Object.Equals(Object).)
 | Finalize() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Find | Gets the Find object associated with this test region. All searchs from this object will be scoped to this region.
 | GetContainerRegion(Element) | This static methods can test whether an element falls within a Test Region. If it does, it will return the region that contains it. If the Element passed in is a test region then the function will return that element's test region. Otherwise will return null.
 | GetHashCode() | Get the hash code for this testregion. (Overrides Object.GetHashCode().)
 | GetType() | Gets the Type of the current instance. (Inherited from Object.)
 | Id | Gets the region id.
 | MemberwiseClone() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Parent | Gets the parent Region that this region is within. Else will return null.
 | Refresh() | Refresh this test region.
 | Refresh(Boolean) | Refresh the test region.
 | ToString() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
TestRegion


AllChildRegions property

TestRegion.AllChildRegions property
Namespaces > ArtOfTest.WebAii.ObjectModel > TestRegion > AllChildRegions
Gets a list of all sub regions contained in this region regardless of their depth relative to this region.
Syntax
C#
public TestRegionCollection AllChildRegions { get; }


ChildRegions property

TestRegion.ChildRegions property
Namespaces > ArtOfTest.WebAii.ObjectModel > TestRegion > ChildRegions
Gets a list of all direct sub regions of this region.
Syntax
C#
public TestRegionCollection ChildRegions { get; }


ContainsElement(element, verifyDirectChildrenOnly) method

TestRegion.ContainsElement(element, verifyDirectChildrenOnly) method
Namespaces > ArtOfTest.WebAii.ObjectModel > TestRegion > ContainsElement(Element, Boolean)
Checks if a certain element is contained in this region or not.
Syntax
C#
public bool ContainsElement (
    Element element,
    bool verifyDirectChildrenOnly
)
Parameters
element (Element)
The element to check.
verifyDirectChildrenOnly (Boolean)
Check only the direct children of this region. If false, this method will check all sub regions too.
Return Value
True/False whether the element is contained or not.


Element property

TestRegion.Element property
Namespaces > ArtOfTest.WebAii.ObjectModel > TestRegion > Element
Gets the element object that represents this region in the Dom tree.
Syntax
C#
public Element Element { get; }


Equals(obj) method

TestRegion.Equals(obj) method
Namespaces > ArtOfTest.WebAii.ObjectModel > TestRegion > Equals(Object)
Defined how two TestRegions should be compared.
Syntax
C#
public override bool Equals (
    Object obj
)
Parameters
obj (Object)
The object to compare.
Return Value
True/False whether the two objects are equal.


Find property

TestRegion.Find property
Namespaces > ArtOfTest.WebAii.ObjectModel > TestRegion > Find
Gets the Find object associated with this test region. All searchs from this object will be scoped to this region.
Syntax
C#
public Find Find { get; }


GetContainerRegion(element) method

TestRegion.GetContainerRegion(element) method
Namespaces > ArtOfTest.WebAii.ObjectModel > TestRegion > GetContainerRegion(Element)
This static methods can test whether an element falls within a Test Region. If it does, it will return the region that contains it. If the Element passed in is a test region then the function will return that element's test region. Otherwise will return null.
Syntax
C#
public static TestRegion GetContainerRegion (
    Element element
)
Parameters
element (Element)
The element to find its container test region.
Return Value
The testregion found or null.


GetHashCode() method

TestRegion.GetHashCode() method
Namespaces > ArtOfTest.WebAii.ObjectModel > TestRegion > GetHashCode()
Get the hash code for this testregion.
Syntax
C#
public override int GetHashCode ()
Return Value
The hash code.


Id property

TestRegion.Id property
Namespaces > ArtOfTest.WebAii.ObjectModel > TestRegion > Id
Gets the region id.
Syntax
C#
public string Id { get; }


Parent property

TestRegion.Parent property
Namespaces > ArtOfTest.WebAii.ObjectModel > TestRegion > Parent
Gets the parent Region that this region is within. Else will return null.
Syntax
C#
public TestRegion Parent { get; }


Refresh methods

TestRegion.Refresh methods
Namespaces > ArtOfTest.WebAii.ObjectModel > TestRegion > Refresh
Members
Icon | Member | Description
 | Refresh() | Refresh this test region.
 | Refresh(Boolean) | Refresh the test region.


Refresh() method

TestRegion.Refresh() method
Namespaces > ArtOfTest.WebAii.ObjectModel > TestRegion > Refresh()
Refresh this test region.
Syntax
C#
public void Refresh ()


Refresh(forceDomTreeRefresh) method

TestRegion.Refresh(forceDomTreeRefresh) method
Namespaces > ArtOfTest.WebAii.ObjectModel > TestRegion > Refresh(Boolean)
Refresh the test region.
Syntax
C#
public void Refresh (
    bool forceDomTreeRefresh
)
Parameters
forceDomTreeRefresh (Boolean)
Whether to update the complete DOM before trying to refresh the region element.


TestRegionCollection class

TestRegionCollection class
Namespaces > ArtOfTest.WebAii.ObjectModel > TestRegionCollection
A keyed TestRegion collection.
Syntax
C#
[DefaultMemberAttribute("Item")]
public class TestRegionCollection : KeyedCollection<string, TestRegion>
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Add(TestRegion) | Adds an object to the end of the Collection<(Of T>). (Inherited from Collection <(Of TestRegion >).)
 | ChangeItemKey(TestRegion, String) | Changes the key associated with the specified element in the lookup dictionary. (Inherited from KeyedCollection <(Of String, TestRegion >).)
 | Clear() | Removes all elements from the Collection<(Of T>). (Inherited from Collection <(Of TestRegion >).)
 | ClearItems() | Removes all elements from the KeyedCollection<(Of TKey, TItem>). (Inherited from KeyedCollection <(Of String, TestRegion >).)
 | Comparer | Gets the generic equality comparer that is used to determine equality of keys in the collection. (Inherited from KeyedCollection <(Of String, TestRegion >).)
 | Contains(String) | Check if a TestRegion is in this collection. (Overrides KeyedCollection <(Of String, TestRegion >).Contains(String).)
 | Contains(TestRegion) | Determines whether an element is in the Collection<(Of T>). (Inherited from Collection <(Of TestRegion >).)
 | CopyTo(TestRegion[](), Int32) | Copies the entire Collection<(Of T>) to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection <(Of TestRegion >).)
 | Count | Gets the number of elements actually contained in the Collection<(Of T>). (Inherited from Collection <(Of TestRegion >).)
 | Dictionary | Gets the lookup dictionary of the KeyedCollection<(Of TKey, TItem>). (Inherited from KeyedCollection <(Of String, TestRegion >).)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetEnumerator() | Returns an enumerator that iterates through the Collection<(Of T>). (Inherited from Collection <(Of TestRegion >).)
 | GetHashCode() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetKeyForItem(TestRegion) | Get the key for an item. (Overrides KeyedCollection <(Of String, TestRegion >).GetKeyForItem(TestRegion).)
 | GetType() | Gets the Type of the current instance. (Inherited from Object.)
 | ICollection{`0}.IsReadOnly | (Inherited from Collection <(Of TestRegion >).)
 | ICollection.CopyTo(Array, Int32) | (Inherited from Collection <(Of TestRegion >).)
 | ICollection.IsSynchronized | (Inherited from Collection <(Of TestRegion >).)
 | ICollection.SyncRoot | (Inherited from Collection <(Of TestRegion >).)
 | IEnumerable.GetEnumerator() | (Inherited from Collection <(Of TestRegion >).)
 | IList.Add(Object) | (Inherited from Collection <(Of TestRegion >).)
 | IList.Contains(Object) | (Inherited from Collection <(Of TestRegion >).)
 | IList.IndexOf(Object) | (Inherited from Collection <(Of TestRegion >).)
 | IList.Insert(Int32, Object) | (Inherited from Collection <(Of TestRegion >).)
 | IList.IsFixedSize | (Inherited from Collection <(Of TestRegion >).)
 | IList.IsReadOnly | (Inherited from Collection <(Of TestRegion >).)
 | IList.Item(Int32) | (Inherited from Collection <(Of TestRegion >).)
 | IList.Remove(Object) | (Inherited from Collection <(Of TestRegion >).)
 | IndexOf(TestRegion) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of T>). (Inherited from Collection <(Of TestRegion >).)
 | Insert(Int32, TestRegion) | Inserts an element into the Collection<(Of T>) at the specified index. (Inherited from Collection <(Of TestRegion >).)
 | InsertItem(Int32, TestRegion) | Inserts an element into the KeyedCollection<(Of TKey, TItem>) at the specified index. (Inherited from KeyedCollection <(Of String, TestRegion >).)
 | Item(Int32) | Gets or sets the element at the specified index. (Inherited from Collection <(Of TestRegion >).)
 | Item(String) | Get a testregion by id. Case-insensitive. (Overrides KeyedCollection<(Of TKey, TItem>).Item(TKey).)
 | Items | Gets a IList<(Of T>) wrapper around the Collection<(Of T>). (Inherited from Collection <(Of TestRegion >).)
 | MemberwiseClone() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Remove(String) | Remove an item from the collection. (Overrides KeyedCollection <(Of String, TestRegion >).Remove(String).)
 | Remove(TestRegion) | Removes the first occurrence of a specific object from the Collection<(Of T>). (Inherited from Collection <(Of TestRegion >).)
 | RemoveAt(Int32) | Removes the element at the specified index of the Collection<(Of T>). (Inherited from Collection <(Of TestRegion >).)
 | RemoveItem(Int32) | Removes the element at the specified index of the KeyedCollection<(Of TKey, TItem>). (Inherited from KeyedCollection <(Of String, TestRegion >).)
 | ReturnNullIfNotFound | Gets/Sets whether to throw or return null if a region is not found.
 | SetItem(Int32, TestRegion) | Replaces the item at the specified index with the specified item. (Inherited from KeyedCollection <(Of String, TestRegion >).)
 | ToString() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Collection <(Of TestRegion >)
 |  | KeyedCollection <(Of String, TestRegion >)
 |  |  | TestRegionCollection


Contains(key) method

TestRegionCollection.Contains(key) method
Namespaces > ArtOfTest.WebAii.ObjectModel > TestRegionCollection > Contains(String)
Check if a TestRegion is in this collection.
Syntax
C#
public bool Contains (
    string key
)
Parameters
key (String)
The key to check
Return Value
True/False whether the items is in the collection.


GetKeyForItem(item) method

TestRegionCollection.GetKeyForItem(item) method
Namespaces > ArtOfTest.WebAii.ObjectModel > TestRegionCollection > GetKeyForItem(TestRegion)
Get the key for an item.
Syntax
C#
protected override string GetKeyForItem (
    TestRegion item
)
Parameters
item (TestRegion)
The item to get the key for.
Return Value
The key.


Item[id] property

TestRegionCollection.Item[id] property
Namespaces > ArtOfTest.WebAii.ObjectModel > TestRegionCollection > Item(String)
Get a testregion by id. Case-insensitive.
Syntax
C#
public TestRegion this [
    string id
] { get; }
Parameters
id (String)
The testregion id.
Return Value
The testregion.


Remove(key) method

TestRegionCollection.Remove(key) method
Namespaces > ArtOfTest.WebAii.ObjectModel > TestRegionCollection > Remove(String)
Remove an item from the collection.
Syntax
C#
public void Remove (
    string key
)
Parameters
key (String)
The key of the TestRegion to remove.


ReturnNullIfNotFound property

TestRegionCollection.ReturnNullIfNotFound property
Namespaces > ArtOfTest.WebAii.ObjectModel > TestRegionCollection > ReturnNullIfNotFound
Gets/Sets whether to throw or return null if a region is not found.
Syntax
C#
public bool ReturnNullIfNotFound { get; set; }
Remarks
Default value is false


ArtOfTest.WebAii.ObjectModel.Plugins Namespace

ArtOfTest.WebAii.ObjectModel.Plugins Namespace
Namespaces > ArtOfTest.WebAii.ObjectModel.Plugins
Syntax
C#
namespace ArtOfTest.WebAii.ObjectModel.Plugins
Types
All Types Classes Structures Interfaces Enumerations Delegates
Icon | Type | Description
public interface | IPlugin | Base interface to be implemented by all plug-in support in WebAii.
public enumeration | PluginType | Supported plugin type objects


IPlugin interface

IPlugin interface
Namespaces > ArtOfTest.WebAii.ObjectModel.Plugins > IPlugin
Base interface to be implemented by all plug-in support in WebAii.
Syntax
C#
public interface IPlugin
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Element | The actual element representing this plugin
 | Find | The Find object associated with this plugin (if applicable)
 | PluginType | The plugin type
 | Refresh() | Refresh this element's settings/objects.
 | Regions | The TestRegions associated with this plugin (if applicable)
 | Version | The plugin version


Element property

IPlugin.Element property
Namespaces > ArtOfTest.WebAii.ObjectModel.Plugins > IPlugin > Element
The actual element representing this plugin
Syntax
C#
Element Element { get; }


Find property

IPlugin.Find property
Namespaces > ArtOfTest.WebAii.ObjectModel.Plugins > IPlugin > Find
The Find object associated with this plugin (if applicable)
Syntax
C#
Find Find { get; }


PluginType property

IPlugin.PluginType property
Namespaces > ArtOfTest.WebAii.ObjectModel.Plugins > IPlugin > PluginType
The plugin type
Syntax
C#
PluginType PluginType { get; }


Refresh() method

IPlugin.Refresh() method
Namespaces > ArtOfTest.WebAii.ObjectModel.Plugins > IPlugin > Refresh()
Refresh this element's settings/objects.
Syntax
C#
void Refresh ()


Regions property

IPlugin.Regions property
Namespaces > ArtOfTest.WebAii.ObjectModel.Plugins > IPlugin > Regions
The TestRegions associated with this plugin (if applicable)
Syntax
C#
TestRegionCollection Regions { get; }


Version property

IPlugin.Version property
Namespaces > ArtOfTest.WebAii.ObjectModel.Plugins > IPlugin > Version
The plugin version
Syntax
C#
string Version { get; }


PluginType enumeration

PluginType enumeration
Namespaces > ArtOfTest.WebAii.ObjectModel.Plugins > PluginType
Supported plugin type objects
Syntax
C#
public enum PluginType
Members
Member | Description
SilverLight | Microsoft Silverlight plug-in
Flash | Adobe Flash plug-in


ArtOfTest.WebAii.Synchronization Namespace

ArtOfTest.WebAii.Synchronization Namespace
Namespaces > ArtOfTest.WebAii.Synchronization
Syntax
C#
namespace ArtOfTest.WebAii.Synchronization
Types
All Types Classes Structures Interfaces Enumerations Delegates
Icon | Type | Description
public delegate | ControlWaitForCondition | Delegate to use to define custom wait conditions on a control.
public delegate | ElementWaitForCondition | Delegate to use to define custom wait conditions on an element.
public class | Wait | Provide wait functionality for an Element object.
public class | WaitAsync | Enables asynchronized waiting on custom conditions
public class | WaitResult | Represents a wait result.
public enumeration | WaitResultType | The different Wait results possible.
public class | WaitSync | Waits Synchronously for a condition.


ControlWaitForCondition delegate

ControlWaitForCondition delegate
Namespaces > ArtOfTest.WebAii.Synchronization > ControlWaitForCondition
Delegate to use to define custom wait conditions on a control.
Syntax
C#
public delegate bool ControlWaitForCondition (
    Control control,
    Object custom
)
Parameters
control (Control)
The control object to use.
custom (Object)
Any custom data to be passed in to the condition delegate
Return Value
True/False whether the condition was met or not.


ElementWaitForCondition delegate

ElementWaitForCondition delegate
Namespaces > ArtOfTest.WebAii.Synchronization > ElementWaitForCondition
Delegate to use to define custom wait conditions on an element.
Syntax
C#
public delegate bool ElementWaitForCondition (
    Element element,
    Object custom
)
Parameters
element (Element)
The element object to use.
custom (Object)
Any custom data to be passed in to the condition delegate
Return Value
True/False whether the condition was met or not.


Wait class

Wait class
Namespaces > ArtOfTest.WebAii.Synchronization > Wait
Provide wait functionality for an Element object.
Syntax
C#
public class Wait
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | ForAttributes(Int32, String[]()) | Wait for a set of attributes on this element.
 | ForAttributes(String[]()) | Wait for a set of attributes on this element. (Timeout = Wait.Timeout)
 | ForAttributesNot(Int32, String[]()) | Wait for a set of attributes to no longer be true.
 | ForAttributesNot(String[]()) | Wait for a set of attributes to no longer be true. (Timeout = Wait.Timeout)
 | ForCondition(ElementWaitForCondition, Boolean, Object, Int32) | Wait for a custom condition on this element.
 | ForCondition(ElementWaitForCondition, Object) | Wait for a custom condition on this element.
 | ForCondition(ElementWaitForCondition, Object, Boolean) | Wait for a custom condition on this element.
 | ForContent(FindContentType, String) | Wait for certain content of this element to be true. (Timeout = Wait.Timeout)
 | ForContent(FindContentType, String, Int32) | Wait for certain content of this element to be true.
 | ForContentNot(FindContentType, String) | Wait for certain content of this element to no longer be true. (Timeout = Wait.Timeout)
 | ForContentNot(FindContentType, String, Int32) | Wait for certain content of this element to no longer be true.
 | ForExists() | Wait for this element to exist in the DOM.
 | ForExists(Int32) | Wait for this element to exist in the DOM.
 | ForExists(Int32, Boolean) | Wait for an element and decide on whether to refresh the element.
 | ForExistsNot() | Wait for this element not to exist in the DOM
 | ForExistsNot(Int32) | Wait for this element not to exist in the DOM.
 | GetHashCode() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Timeout | Gets/Sets the timeout for all Wait.Forxx methods. Default=Settings.ExecuteCommandTimeout
 | ToString() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Wait
 |  | HtmlWait


ForAttributes methods

Wait.ForAttributes methods
Namespaces > ArtOfTest.WebAii.Synchronization > Wait > ForAttributes
Members
Icon | Member | Description
 | ForAttributes(Int32, String[]()) | Wait for a set of attributes on this element.
 | ForAttributes(String[]()) | Wait for a set of attributes on this element. (Timeout = Wait.Timeout)


ForAttributes(attributesNameValuePairs) method

Wait.ForAttributes(attributesNameValuePairs) method
Namespaces > ArtOfTest.WebAii.Synchronization > Wait > ForAttributes(String[]())
Wait for a set of attributes on this element. (Timeout = Wait.Timeout)
Syntax
C#
public void ForAttributes (
    params string[] attributesNameValuePairs
)
Parameters
attributesNameValuePairs (String []())
The attributes name/value pairs
Examples
Wait.ForAttribute("src=~foo.png","foo=bar")


ForAttributes(timeout, attributesNameValuePairs) method

Wait.ForAttributes(timeout, attributesNameValuePairs) method
Namespaces > ArtOfTest.WebAii.Synchronization > Wait > ForAttributes(Int32, String[]())
Wait for a set of attributes on this element.
Syntax
C#
public void ForAttributes (
    int timeout,
    params string[] attributesNameValuePairs
)
Parameters
timeout (Int32)
Wait timeout in milliseconds.
attributesNameValuePairs (String []())
The attribute name/value pairs
Examples
Wait.ForAttribute("src=~foo.png","foo=bar")


ForAttributesNot methods

Wait.ForAttributesNot methods
Namespaces > ArtOfTest.WebAii.Synchronization > Wait > ForAttributesNot
Members
Icon | Member | Description
 | ForAttributesNot(Int32, String[]()) | Wait for a set of attributes to no longer be true.
 | ForAttributesNot(String[]()) | Wait for a set of attributes to no longer be true. (Timeout = Wait.Timeout)


ForAttributesNot(attributeNameValuePairs) method

Wait.ForAttributesNot(attributeNameValuePairs) method
Namespaces > ArtOfTest.WebAii.Synchronization > Wait > ForAttributesNot(String[]())
Wait for a set of attributes to no longer be true. (Timeout = Wait.Timeout)
Syntax
C#
public void ForAttributesNot (
    params string[] attributeNameValuePairs
)
Parameters
attributeNameValuePairs (String []())
The attributes name/value pairs


ForAttributesNot(timeout, attributeNameValuePairs) method

Wait.ForAttributesNot(timeout, attributeNameValuePairs) method
Namespaces > ArtOfTest.WebAii.Synchronization > Wait > ForAttributesNot(Int32, String[]())
Wait for a set of attributes to no longer be true.
Syntax
C#
public void ForAttributesNot (
    int timeout,
    params string[] attributeNameValuePairs
)
Parameters
timeout (Int32)
Wait timeout in milliseconds.
attributeNameValuePairs (String []())
The attributes name/value pairs


ForCondition methods

Wait.ForCondition methods
Namespaces > ArtOfTest.WebAii.Synchronization > Wait > ForCondition
Members
Icon | Member | Description
 | ForCondition(ElementWaitForCondition, Boolean, Object, Int32) | Wait for a custom condition on this element.
 | ForCondition(ElementWaitForCondition, Object) | Wait for a custom condition on this element.
 | ForCondition(ElementWaitForCondition, Object, Boolean) | Wait for a custom condition on this element.


ForCondition(condition, custom) method

Wait.ForCondition(condition, custom) method
Namespaces > ArtOfTest.WebAii.Synchronization > Wait > ForCondition(ElementWaitForCondition, Object)
Wait for a custom condition on this element.
Syntax
C#
public void ForCondition (
    ElementWaitForCondition condition,
    Object custom
)
Parameters
condition (ElementWaitForCondition)
The condition to wait for.
custom (Object)
Any custom data to pass to this condition.


ForCondition(condition, custom, invertCondition) method

Wait.ForCondition(condition, custom, invertCondition) method
Namespaces > ArtOfTest.WebAii.Synchronization > Wait > ForCondition(ElementWaitForCondition, Object, Boolean)
Wait for a custom condition on this element.
Syntax
C#
public void ForCondition (
    ElementWaitForCondition condition,
    Object custom,
    bool invertCondition
)
Parameters
condition (ElementWaitForCondition)
The condition to wait for.
custom (Object)
Any custom data to pass to this condition.
invertCondition (Boolean)
True/False whether to invert the condition or not.


ForCondition(condition, invertCondition, custom, timeout) method

Wait.ForCondition(condition, invertCondition, custom, timeout) method
Namespaces > ArtOfTest.WebAii.Synchronization > Wait > ForCondition(ElementWaitForCondition, Boolean, Object, Int32)
Wait for a custom condition on this element.
Syntax
C#
public void ForCondition (
    ElementWaitForCondition condition,
    bool invertCondition,
    Object custom,
    int timeout
)
Parameters
condition (ElementWaitForCondition)
The condition to wait for.
invertCondition (Boolean)
True/False whether to invert the condition or not.
custom (Object)
Any custom data to pass to this condition.
timeout (Int32)
The timeout to use.


ForContent methods

Wait.ForContent methods
Namespaces > ArtOfTest.WebAii.Synchronization > Wait > ForContent
Members
Icon | Member | Description
 | ForContent(FindContentType, String) | Wait for certain content of this element to be true. (Timeout = Wait.Timeout)
 | ForContent(FindContentType, String, Int32) | Wait for certain content of this element to be true.


ForContent(type, value) method

Wait.ForContent(type, value) method
Namespaces > ArtOfTest.WebAii.Synchronization > Wait > ForContent(FindContentType, String)
Wait for certain content of this element to be true. (Timeout = Wait.Timeout)
Syntax
C#
public void ForContent (
    FindContentType type,
    string value
)
Parameters
type (FindContentType)
The content type to wait for.
value (String)
The content values to wait for. Value can be (p:partialvalue,l:liternal,x:regex)


ForContent(type, value, timeout) method

Wait.ForContent(type, value, timeout) method
Namespaces > ArtOfTest.WebAii.Synchronization > Wait > ForContent(FindContentType, String, Int32)
Wait for certain content of this element to be true.
Syntax
C#
public void ForContent (
    FindContentType type,
    string value,
    int timeout
)
Parameters
type (FindContentType)
The content type to wait for.
value (String)
The content values to wait for. Value can be (p:partialvalue,l:liternal,x:regex)
timeout (Int32)
The time out to wait for.


ForContentNot methods

Wait.ForContentNot methods
Namespaces > ArtOfTest.WebAii.Synchronization > Wait > ForContentNot
Members
Icon | Member | Description
 | ForContentNot(FindContentType, String) | Wait for certain content of this element to no longer be true. (Timeout = Wait.Timeout)
 | ForContentNot(FindContentType, String, Int32) | Wait for certain content of this element to no longer be true.


ForContentNot(type, value) method

Wait.ForContentNot(type, value) method
Namespaces > ArtOfTest.WebAii.Synchronization > Wait > ForContentNot(FindContentType, String)
Wait for certain content of this element to no longer be true. (Timeout = Wait.Timeout)
Syntax
C#
public void ForContentNot (
    FindContentType type,
    string value
)
Parameters
type (FindContentType)
The content type to wait for.
value (String)
The content values to wait for. Value can be (p:partialvalue,l:liternal,x:regex)


ForContentNot(type, value, timeout) method

Wait.ForContentNot(type, value, timeout) method
Namespaces > ArtOfTest.WebAii.Synchronization > Wait > ForContentNot(FindContentType, String, Int32)
Wait for certain content of this element to no longer be true.
Syntax
C#
public void ForContentNot (
    FindContentType type,
    string value,
    int timeout
)
Parameters
type (FindContentType)
The content type to wait for.
value (String)
The content values to wait for. Value can be (p:partialvalue,l:liternal,x:regex)
timeout (Int32)
The time out to wait for.


ForExists methods

Wait.ForExists methods
Namespaces > ArtOfTest.WebAii.Synchronization > Wait > ForExists
Members
Icon | Member | Description
 | ForExists() | Wait for this element to exist in the DOM.
 | ForExists(Int32) | Wait for this element to exist in the DOM.
 | ForExists(Int32, Boolean) | Wait for an element and decide on whether to refresh the element.


ForExists() method

Wait.ForExists() method
Namespaces > ArtOfTest.WebAii.Synchronization > Wait > ForExists()
Wait for this element to exist in the DOM.
Syntax
C#
public void ForExists ()


ForExists(timeout) method

Wait.ForExists(timeout) method
Namespaces > ArtOfTest.WebAii.Synchronization > Wait > ForExists(Int32)
Wait for this element to exist in the DOM.
Syntax
C#
public void ForExists (
    int timeout
)
Parameters
timeout (Int32)
Wait timeout.


ForExists(timeout, refreshElement) method

Wait.ForExists(timeout, refreshElement) method
Namespaces > ArtOfTest.WebAii.Synchronization > Wait > ForExists(Int32, Boolean)
Wait for an element and decide on whether to refresh the element.
Syntax
C#
protected virtual void ForExists (
    int timeout,
    bool refreshElement
)
Parameters
timeout (Int32)
refreshElement (Boolean)


ForExistsNot methods

Wait.ForExistsNot methods
Namespaces > ArtOfTest.WebAii.Synchronization > Wait > ForExistsNot
Members
Icon | Member | Description
 | ForExistsNot() | Wait for this element not to exist in the DOM
 | ForExistsNot(Int32) | Wait for this element not to exist in the DOM.


ForExistsNot() method

Wait.ForExistsNot() method
Namespaces > ArtOfTest.WebAii.Synchronization > Wait > ForExistsNot()
Wait for this element not to exist in the DOM
Syntax
C#
public void ForExistsNot ()


ForExistsNot(timeout) method

Wait.ForExistsNot(timeout) method
Namespaces > ArtOfTest.WebAii.Synchronization > Wait > ForExistsNot(Int32)
Wait for this element not to exist in the DOM.
Syntax
C#
public void ForExistsNot (
    int timeout
)
Parameters
timeout (Int32)
Wait timeout


Timeout property

Wait.Timeout property
Namespaces > ArtOfTest.WebAii.Synchronization > Wait > Timeout
Gets/Sets the timeout for all Wait.Forxx methods. Default=Settings.ExecuteCommandTimeout
Syntax
C#
public int Timeout { get; set; }


WaitAsync class

WaitAsync class
Namespaces > ArtOfTest.WebAii.Synchronization > WaitAsync
Enables asynchronized waiting on custom conditions
Syntax
C#
public class WaitAsync
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | WaitAsyncNew(Int32, Int32) | Create a new WaitAsync object.
 | CheckInterval | Gets or sets the check interval for this wait object.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | For<(Of TControl>)(Func<(Of TControl, Boolean>), TControl, Int32) | Wait for an assert on a control
 | For<(Of TControl>)(Func<(Of TControl, Boolean>), TControl, Int32, Int32) | Wait for an assert on a control
 | For(ControlWaitForCondition, Control) | Wait for a control condition.
 | For(ControlWaitForCondition, Control, Boolean) | Wait for a control condition.
 | For(ControlWaitForCondition, Control, Boolean, Object) | Wait for a control condition.
 | For(ControlWaitForCondition, Control, Boolean, Object, Int32) | Wait for a control condition.
 | For(ControlWaitForCondition, Control, Object) | Wait for a control condition.
 | For(ElementWaitForCondition, Element) | Wait for an element condition.
 | For(ElementWaitForCondition, Element, Boolean) | Wait for an element condition.
 | For(ElementWaitForCondition, Element, Boolean, Object) | Wait for an element condition.
 | For(ElementWaitForCondition, Element, Boolean, Object, Int32) | Wait for an element condition.
 | For(ElementWaitForCondition, Element, Object) | Wait for an element condition.
 | For(Predicate<(Of Object>), Boolean, Object, Int32) | Wait for a simple predicate condition.
 | GetHashCode() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OnWaitComplete(WaitCompleteEventArgs) | Invoke the wait complete event.
 | ToString() | Returns a String that represents the current Object. (Inherited from Object.)
 | WaitCompleted | Triggered when the wait operation is completed
Inheritance Hierarchy
Object
 | WaitAsync
 |  | WaitSync


CheckInterval property

WaitAsync.CheckInterval property
Namespaces > ArtOfTest.WebAii.Synchronization > WaitAsync > CheckInterval
Gets or sets the check interval for this wait object.
Syntax
C#
public int CheckInterval { get; set; }


For methods

WaitAsync.For methods
Namespaces > ArtOfTest.WebAii.Synchronization > WaitAsync > For
Members
Icon | Member | Description
 | For(ControlWaitForCondition, Control) | Wait for a control condition.
 | For(ControlWaitForCondition, Control, Boolean) | Wait for a control condition.
 | For(ControlWaitForCondition, Control, Boolean, Object) | Wait for a control condition.
 | For(ControlWaitForCondition, Control, Boolean, Object, Int32) | Wait for a control condition.
 | For(ControlWaitForCondition, Control, Object) | Wait for a control condition.
 | For(ElementWaitForCondition, Element) | Wait for an element condition.
 | For(ElementWaitForCondition, Element, Boolean) | Wait for an element condition.
 | For(ElementWaitForCondition, Element, Boolean, Object) | Wait for an element condition.
 | For(ElementWaitForCondition, Element, Boolean, Object, Int32) | Wait for an element condition.
 | For(ElementWaitForCondition, Element, Object) | Wait for an element condition.
 | For<(Of TControl>)(Func<(Of TControl, Boolean>), TControl, Int32) | Wait for an assert on a control
 | For<(Of TControl>)(Func<(Of TControl, Boolean>), TControl, Int32, Int32) | Wait for an assert on a control
 | For(Predicate<(Of Object>), Boolean, Object, Int32) | Wait for a simple predicate condition.


For(condition, control) method

WaitAsync.For(condition, control) method
Namespaces > ArtOfTest.WebAii.Synchronization > WaitAsync > For(ControlWaitForCondition, Control)
Wait for a control condition.
Syntax
C#
public void For (
    ControlWaitForCondition condition,
    Control control
)
Parameters
condition (ControlWaitForCondition)
The control wait condition delegate.
control (Control)
The target control


For(condition, control, custom) method

WaitAsync.For(condition, control, custom) method
Namespaces > ArtOfTest.WebAii.Synchronization > WaitAsync > For(ControlWaitForCondition, Control, Object)
Wait for a control condition.
Syntax
C#
public void For (
    ControlWaitForCondition condition,
    Control control,
    Object custom
)
Parameters
condition (ControlWaitForCondition)
The control wait condition delegate.
control (Control)
The target control
custom (Object)
Any custom information you want passed to the condition delegate.


For(condition, control, invertCondition) method

WaitAsync.For(condition, control, invertCondition) method
Namespaces > ArtOfTest.WebAii.Synchronization > WaitAsync > For(ControlWaitForCondition, Control, Boolean)
Wait for a control condition.
Syntax
C#
public void For (
    ControlWaitForCondition condition,
    Control control,
    bool invertCondition
)
Parameters
condition (ControlWaitForCondition)
The control wait condition delegate.
control (Control)
The target control.
invertCondition (Boolean)
Invert the condition.


For(condition, control, invertCondition, custom) method

WaitAsync.For(condition, control, invertCondition, custom) method
Namespaces > ArtOfTest.WebAii.Synchronization > WaitAsync > For(ControlWaitForCondition, Control, Boolean, Object)
Wait for a control condition.
Syntax
C#
public void For (
    ControlWaitForCondition condition,
    Control control,
    bool invertCondition,
    Object custom
)
Parameters
condition (ControlWaitForCondition)
The control wait condition delegate.
control (Control)
The target control
invertCondition (Boolean)
Invert the condition.
custom (Object)
Any custom information you want passed to the condition delegate.


For(condition, control, invertCondition, custom, timeout) method

WaitAsync.For(condition, control, invertCondition, custom, timeout) method
Namespaces > ArtOfTest.WebAii.Synchronization > WaitAsync > For(ControlWaitForCondition, Control, Boolean, Object, Int32)
Wait for a control condition.
Syntax
C#
public virtual void For (
    ControlWaitForCondition condition,
    Control control,
    bool invertCondition,
    Object custom,
    int timeout
)
Parameters
condition (ControlWaitForCondition)
The control wait condition delegate.
control (Control)
The target control
invertCondition (Boolean)
Invert the condition.
custom (Object)
Any custom information you want passed to the condition delegate.
timeout (Int32)
The time out to wait for that condition.


For(condition, element) method

WaitAsync.For(condition, element) method
Namespaces > ArtOfTest.WebAii.Synchronization > WaitAsync > For(ElementWaitForCondition, Element)
Wait for an element condition.
Syntax
C#
public void For (
    ElementWaitForCondition condition,
    Element element
)
Parameters
condition (ElementWaitForCondition)
The element wait condition delegate.
element (Element)
The target element.


For(condition, element, custom) method

WaitAsync.For(condition, element, custom) method
Namespaces > ArtOfTest.WebAii.Synchronization > WaitAsync > For(ElementWaitForCondition, Element, Object)
Wait for an element condition.
Syntax
C#
public void For (
    ElementWaitForCondition condition,
    Element element,
    Object custom
)
Parameters
condition (ElementWaitForCondition)
The element wait condition delegate.
element (Element)
The target element.
custom (Object)
Any custom information you want passed to the condition delegate.


For(condition, element, invertCondition) method

WaitAsync.For(condition, element, invertCondition) method
Namespaces > ArtOfTest.WebAii.Synchronization > WaitAsync > For(ElementWaitForCondition, Element, Boolean)
Wait for an element condition.
Syntax
C#
public void For (
    ElementWaitForCondition condition,
    Element element,
    bool invertCondition
)
Parameters
condition (ElementWaitForCondition)
The element wait condition delegate.
element (Element)
The target element.
invertCondition (Boolean)
Invert the condition. if true, will wait for the condition to return false.


For(condition, element, invertCondition, custom) method

WaitAsync.For(condition, element, invertCondition, custom) method
Namespaces > ArtOfTest.WebAii.Synchronization > WaitAsync > For(ElementWaitForCondition, Element, Boolean, Object)
Wait for an element condition.
Syntax
C#
public void For (
    ElementWaitForCondition condition,
    Element element,
    bool invertCondition,
    Object custom
)
Parameters
condition (ElementWaitForCondition)
The element wait condition delegate.
element (Element)
The target element.
invertCondition (Boolean)
Invert the condition. if true, will wait for the condition to return false.
custom (Object)
Any custom information you want passed to the condition delegate.


For(condition, element, invertCondition, custom, timeout) method

WaitAsync.For(condition, element, invertCondition, custom, timeout) method
Namespaces > ArtOfTest.WebAii.Synchronization > WaitAsync > For(ElementWaitForCondition, Element, Boolean, Object, Int32)
Wait for an element condition.
Syntax
C#
public virtual void For (
    ElementWaitForCondition condition,
    Element element,
    bool invertCondition,
    Object custom,
    int timeout
)
Parameters
condition (ElementWaitForCondition)
The element wait condition delegate.
element (Element)
The target element.
invertCondition (Boolean)
Invert the condition. if true, will wait for the condition to return false.
custom (Object)
Any custom information you want passed to the condition delegate.
timeout (Int32)
The time out to wait for that condition.


For(simplePredicate, invertCondition, custom, timeout) method

WaitAsync.For(simplePredicate, invertCondition, custom, timeout) method
Namespaces > ArtOfTest.WebAii.Synchronization > WaitAsync > For(Predicate<(Of Object>), Boolean, Object, Int32)
Wait for a simple predicate condition.
Syntax
C#
public virtual void For (
    Predicate<Object> simplePredicate,
    bool invertCondition,
    Object custom,
    int timeout
)
Parameters
simplePredicate (Predicate <(Of Object >))
The simple predicate.
invertCondition (Boolean)
Invert the condition if true.
custom (Object)
Any custom object to pass to the predicate
timeout (Int32)
The time out to use.


For<TControl>(assert, control, timeout) method

WaitAsync.For<TControl>(assert, control, timeout) method
Namespaces > ArtOfTest.WebAii.Synchronization > WaitAsync > For<(Of TControl>)(Func<(Of TControl, Boolean>), TControl, Int32)
Wait for an assert on a control
Syntax
C#
public void For<TControl> (
    Func<TControl, bool> assert,
    TControl control,
    int timeout
) where TControl : Control
Generic Template Parameters
TControl
The control type.
Parameters
assert (Func<(Of TControl, Boolean >))
The assert delegate
control (TControl)
The control.
timeout (Int32)
The timeout.


For<TControl>(assert, control, timeout, checkInterval) method

WaitAsync.For<TControl>(assert, control, timeout, checkInterval) method
Namespaces > ArtOfTest.WebAii.Synchronization > WaitAsync > For<(Of TControl>)(Func<(Of TControl, Boolean>), TControl, Int32, Int32)
Wait for an assert on a control
Syntax
C#
public virtual void For<TControl> (
    Func<TControl, bool> assert,
    TControl control,
    int timeout,
    int checkInterval
) where TControl : Control
Generic Template Parameters
TControl
The control type.
Parameters
assert (Func<(Of TControl, Boolean >))
The assert delegate
control (TControl)
The control.
timeout (Int32)
The timeout.
checkInterval (Int32)
Check interval to use.


OnWaitComplete(args) method

WaitAsync.OnWaitComplete(args) method
Namespaces > ArtOfTest.WebAii.Synchronization > WaitAsync > OnWaitComplete(WaitCompleteEventArgs)
Invoke the wait complete event.
Syntax
C#
protected void OnWaitComplete (
    WaitCompleteEventArgs args
)
Parameters
args (WaitCompleteEventArgs)
WaitCompleteEventArgs


WaitAsync(timeout, checkInterval) constructor

WaitAsync(timeout, checkInterval) constructor
Namespaces > ArtOfTest.WebAii.Synchronization > WaitAsync > WaitAsyncNew(Int32, Int32)
Create a new WaitAsync object.
Syntax
C#
public WaitAsync (
    int timeout,
    int checkInterval
)
Parameters
timeout (Int32)
The global timeout to use for this wait async object.
checkInterval (Int32)
The check interval to use for condition checking.


WaitCompleted event

WaitAsync.WaitCompleted event
Namespaces > ArtOfTest.WebAii.Synchronization > WaitAsync > WaitCompleted
Triggered when the wait operation is completed
Syntax
C#
public event EventHandler<WaitCompleteEventArgs> WaitCompleted


WaitResult class

WaitResult class
Namespaces > ArtOfTest.WebAii.Synchronization > WaitResult
Represents a wait result.
Syntax
C#
public class WaitResult
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | WaitResultNew(WaitResultType, String) | Create a new WaitConditionResult object.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Error | Gets the error if the ResultType = ErrorAbort
 | Finalize() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ResultType | Gets the result type of this wait condition.
 | ToString() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
WaitResult


Error property

WaitResult.Error property
Namespaces > ArtOfTest.WebAii.Synchronization > WaitResult > Error
Gets the error if the ResultType = ErrorAbort
Syntax
C#
public string Error { get; }


ResultType property

WaitResult.ResultType property
Namespaces > ArtOfTest.WebAii.Synchronization > WaitResult > ResultType
Gets the result type of this wait condition.
Syntax
C#
public WaitResultType ResultType { get; }


WaitResult(resultType, error) constructor

WaitResult(resultType, error) constructor
Namespaces > ArtOfTest.WebAii.Synchronization > WaitResult > WaitResultNew(WaitResultType, String)
Create a new WaitConditionResult object.
Syntax
C#
public WaitResult (
    WaitResultType resultType,
    string error
)
Parameters
resultType (WaitResultType)
The result type.
error (String)
The error if any.


WaitResultType enumeration

WaitResultType enumeration
Namespaces > ArtOfTest.WebAii.Synchronization > WaitResultType
The different Wait results possible.
Syntax
C#
public enum WaitResultType
Members
Member | Description
NotSet | Result is not set yet.
ConditionMet | The condition that we were waiting for was met.
TimedOut | The condition was not met, timed out.
ErrorAbort | An unexpected error occured. Aborted the wait operation.


WaitSync class

WaitSync class
Namespaces > ArtOfTest.WebAii.Synchronization > WaitSync
Waits Synchronously for a condition.
Syntax
C#
public class WaitSync : WaitAsync
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | WaitSyncNew(Int32, Int32) | Create a new synchronous wait object.
 | CheckInterval | Gets or sets the check interval for this wait object. (Inherited from WaitAsync.)
 | CheckResult(WaitSync) | Check the sync wait result.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | For<(Of TControl>)(Func<(Of TControl, Boolean>), TControl, Int32) | Wait for an assert on a control (Inherited from WaitAsync.)
 | For<(Of TControl>)(Func<(Of TControl, Boolean>), TControl, Int32, Int32) | Wait for a specific assert. (Overrides WaitAsync.For<(Of TControl>)(Func<(Of TControl, Boolean>), TControl, Int32, Int32).)
 | For<(Of TControl>)(Func<(Of TControl, Boolean>), TControl, Int32, Int32) | Wait for an assert on a control (Inherited from WaitAsync.)
 | For(ControlWaitForCondition, Control) | Wait for a control condition. (Inherited from WaitAsync.)
 | For(ControlWaitForCondition, Control, Boolean) | Wait for a control condition. (Inherited from WaitAsync.)
 | For(ControlWaitForCondition, Control, Boolean, Object) | Wait for a control condition. (Inherited from WaitAsync.)
 | For(ControlWaitForCondition, Control, Boolean, Object, Int32) | Wait for a control condition. (Overrides WaitAsync.For(ControlWaitForCondition, Control, Boolean, Object, Int32).)
 | For(ControlWaitForCondition, Control, Object) | Wait for a control condition. (Inherited from WaitAsync.)
 | For(ElementWaitForCondition, Element) | Wait for an element condition. (Inherited from WaitAsync.)
 | For(ElementWaitForCondition, Element, Boolean) | Wait for an element condition. (Inherited from WaitAsync.)
 | For(ElementWaitForCondition, Element, Boolean, Object) | Wait for an element condition. (Inherited from WaitAsync.)
 | For(ElementWaitForCondition, Element, Boolean, Object, Int32) | Wait for an element condition. (Overrides WaitAsync.For(ElementWaitForCondition, Element, Boolean, Object, Int32).)
 | For(ElementWaitForCondition, Element, Object) | Wait for an element condition. (Inherited from WaitAsync.)
 | For(Predicate<(Of Object>), Boolean, Object, Int32) | Wait for a simple predicate. (Overrides WaitAsync.For(Predicate<(Of Object>), Boolean, Object, Int32).)
 | GetHashCode() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OnWaitComplete(WaitCompleteEventArgs) | Invoke the wait complete event. (Inherited from WaitAsync.)
 | SyncWaitResult | Gets the result of the last synchronous wait.
 | ToString() | Returns a String that represents the current Object. (Inherited from Object.)
 | WaitCompleted | Triggered when the wait operation is completed (Inherited from WaitAsync.)
Inheritance Hierarchy
Object
 | WaitAsync
 |  | WaitSync


CheckResult(wait) method

WaitSync.CheckResult(wait) method
Namespaces > ArtOfTest.WebAii.Synchronization > WaitSync > CheckResult(WaitSync)
Check the sync wait result.
Syntax
C#
public static void CheckResult (
    WaitSync wait
)
Parameters
wait (WaitSync)


For methods

WaitSync.For methods
Namespaces > ArtOfTest.WebAii.Synchronization > WaitSync > For
Members
Icon | Member | Description
 | For(ControlWaitForCondition, Control) | Wait for a control condition.
 | For(ControlWaitForCondition, Control, Boolean) | Wait for a control condition.
 | For(ControlWaitForCondition, Control, Boolean, Object) | Wait for a control condition.
 | For(ControlWaitForCondition, Control, Object) | Wait for a control condition.
 | For(ElementWaitForCondition, Element) | Wait for an element condition.
 | For(ElementWaitForCondition, Element, Boolean) | Wait for an element condition.
 | For(ElementWaitForCondition, Element, Boolean, Object) | Wait for an element condition.
 | For(ElementWaitForCondition, Element, Object) | Wait for an element condition.
 | For<(Of TControl>)(Func<(Of TControl, Boolean>), TControl, Int32) | Wait for an assert on a control
 | For<(Of TControl>)(Func<(Of TControl, Boolean>), TControl, Int32, Int32) | Wait for an assert on a control
 | For(ControlWaitForCondition, Control, Boolean, Object, Int32) | Wait for a control condition. (Overrides WaitAsync.For(ControlWaitForCondition, Control, Boolean, Object, Int32).)
 | For(ElementWaitForCondition, Element, Boolean, Object, Int32) | Wait for an element condition. (Overrides WaitAsync.For(ElementWaitForCondition, Element, Boolean, Object, Int32).)
 | For<(Of TControl>)(Func<(Of TControl, Boolean>), TControl, Int32, Int32) | Wait for a specific assert. (Overrides WaitAsync.For<(Of TControl>)(Func<(Of TControl, Boolean>), TControl, Int32, Int32).)
 | For(Predicate<(Of Object>), Boolean, Object, Int32) | Wait for a simple predicate. (Overrides WaitAsync.For(Predicate<(Of Object>), Boolean, Object, Int32).)


For(condition, control, invertCondition, custom, timeout) method

WaitSync.For(condition, control, invertCondition, custom, timeout) method
Namespaces > ArtOfTest.WebAii.Synchronization > WaitSync > For(ControlWaitForCondition, Control, Boolean, Object, Int32)
Wait for a control condition.
Syntax
C#
public override void For (
    ControlWaitForCondition condition,
    Control control,
    bool invertCondition,
    Object custom,
    int timeout
)
Parameters
condition (ControlWaitForCondition)
The control wait condition delegate.
control (Control)
The target control
invertCondition (Boolean)
Invert the condition.
custom (Object)
Any custom information you want passed to the condition delegate.
timeout (Int32)
The time out to wait for that condition.


For(condition, element, invertCondition, custom, timeout) method

WaitSync.For(condition, element, invertCondition, custom, timeout) method
Namespaces > ArtOfTest.WebAii.Synchronization > WaitSync > For(ElementWaitForCondition, Element, Boolean, Object, Int32)
Wait for an element condition.
Syntax
C#
public override void For (
    ElementWaitForCondition condition,
    Element element,
    bool invertCondition,
    Object custom,
    int timeout
)
Parameters
condition (ElementWaitForCondition)
The element wait condition delegate.
element (Element)
The target element.
invertCondition (Boolean)
Invert the condition. if true, will wait for the condition to return false.
custom (Object)
Any custom information you want passed to the condition delegate.
timeout (Int32)
The time out to wait for that condition.


For(simplePredicate, invertCondition, custom, timeout) method

WaitSync.For(simplePredicate, invertCondition, custom, timeout) method
Namespaces > ArtOfTest.WebAii.Synchronization > WaitSync > For(Predicate<(Of Object>), Boolean, Object, Int32)
Wait for a simple predicate.
Syntax
C#
public override void For (
    Predicate<Object> simplePredicate,
    bool invertCondition,
    Object custom,
    int timeout
)
Parameters
simplePredicate (Predicate <(Of Object >))
The simple predicate.
invertCondition (Boolean)
Whether to invert the condition.
custom (Object)
The custom object.
timeout (Int32)
The timeout to use.


For<TControl>(assert, control, timeout, checkInterval) method

WaitSync.For<TControl>(assert, control, timeout, checkInterval) method
Namespaces > ArtOfTest.WebAii.Synchronization > WaitSync > For<(Of TControl>)(Func<(Of TControl, Boolean>), TControl, Int32, Int32)
Wait for a specific assert.
Syntax
C#
public override void For<TControl> (
    Func<TControl, bool> assert,
    TControl control,
    int timeout,
    int checkInterval
) where TControl : Control
Generic Template Parameters
TControl
Parameters
assert (Func<(Of TControl, Boolean >))
The assert to use. Control.AssertXXXX
control (TControl)
The target control
timeout (Int32)
The timeout to use
checkInterval (Int32)
The check interval to use.


SyncWaitResult property

WaitSync.SyncWaitResult property
Namespaces > ArtOfTest.WebAii.Synchronization > WaitSync > SyncWaitResult
Gets the result of the last synchronous wait.
Syntax
C#
public WaitResult SyncWaitResult { get; }


WaitSync(timeout, checkInterval) constructor

WaitSync(timeout, checkInterval) constructor
Namespaces > ArtOfTest.WebAii.Synchronization > WaitSync > WaitSyncNew(Int32, Int32)
Create a new synchronous wait object.
Syntax
C#
public WaitSync (
    int timeout,
    int checkInterval
)
Parameters
timeout (Int32)
The global timeout to use for all waits on this method.
checkInterval (Int32)
The condition wait interval to use.


ArtOfTest.WebAii.TestAttributes Namespace

ArtOfTest.WebAii.TestAttributes Namespace
Namespaces > ArtOfTest.WebAii.TestAttributes
Syntax
C#
namespace ArtOfTest.WebAii.TestAttributes
Types
All Types Classes Structures Interfaces Enumerations Delegates
Icon | Type | Description
public class | DialogAttribute | A dialog attribute that can be set on a test method of a test class.
public class | FindParamAttribute | FindParam attribute used to be set on a test method or test class.


DialogAttribute class

DialogAttribute class
Namespaces > ArtOfTest.WebAii.TestAttributes > DialogAttribute
A dialog attribute that can be set on a test method of a test class.
Syntax
C#
[AttributeUsageAttribute(AttributeTargets.All, AllowMultiple = true, Inherited = true)]
public class DialogAttribute : Attribute
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DialogAttributeNew(DialogButton) | Create an AlertDialog.
 | DialogAttributeNew(IDialog) | Create a custom dialog.
 | DialogAttributeNew(String, DialogButton) | Create a FileUploadDialog
 | DialogAttributeNew(String, String, DialogButton) | Create a LogonDialog.
 | _Attribute.System.Runtime.InteropServices._Attribute.GetIDsOfNames(Guid, IntPtr, UInt32, UInt32, IntPtr) | (Inherited from Attribute.)
 | _Attribute.System.Runtime.InteropServices._Attribute.GetTypeInfo(UInt32, UInt32, IntPtr) | (Inherited from Attribute.)
 | _Attribute.System.Runtime.InteropServices._Attribute.GetTypeInfoCount(UInt32) | (Inherited from Attribute.)
 | _Attribute.System.Runtime.InteropServices._Attribute.Invoke(UInt32, Guid, UInt32, Int16, IntPtr, IntPtr, IntPtr, IntPtr) | (Inherited from Attribute.)
 | Equals(Object) | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
 | Finalize() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode() | Returns the hash code for this instance. (Inherited from Attribute.)
 | GetType() | Gets the Type of the current instance. (Inherited from Object.)
 | IsDefaultAttribute() | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
 | Match(Object) | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
 | MemberwiseClone() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString() | Returns a String that represents the current Object. (Inherited from Object.)
 | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Inheritance Hierarchy
Object
 | Attribute
 |  | DialogAttribute


Constructors

DialogAttribute constructors
Namespaces > ArtOfTest.WebAii.TestAttributes > DialogAttribute > DialogAttributeNew
Members
Icon | Member | Description
 | DialogAttributeNew(DialogButton) | Create an AlertDialog.
 | DialogAttributeNew(IDialog) | Create a custom dialog.
 | DialogAttributeNew(String, DialogButton) | Create a FileUploadDialog
 | DialogAttributeNew(String, String, DialogButton) | Create a LogonDialog.


DialogAttribute(customDialog) constructor

DialogAttribute(customDialog) constructor
Namespaces > ArtOfTest.WebAii.TestAttributes > DialogAttribute > DialogAttributeNew(IDialog)
Create a custom dialog.
Syntax
C#
public DialogAttribute (
    IDialog customDialog
)
Parameters
customDialog (IDialog)
The custom dialog


DialogAttribute(dismissButton) constructor

DialogAttribute(dismissButton) constructor
Namespaces > ArtOfTest.WebAii.TestAttributes > DialogAttribute > DialogAttributeNew(DialogButton)
Create an AlertDialog.
Syntax
C#
public DialogAttribute (
    DialogButton dismissButton
)
Parameters
dismissButton (DialogButton)
The dismiss button to click.


DialogAttribute(filePath, dismissButton) constructor

DialogAttribute(filePath, dismissButton) constructor
Namespaces > ArtOfTest.WebAii.TestAttributes > DialogAttribute > DialogAttributeNew(String, DialogButton)
Create a FileUploadDialog
Syntax
C#
public DialogAttribute (
    string filePath,
    DialogButton dismissButton
)
Parameters
filePath (String)
The filepath to use.
dismissButton (DialogButton)
The dismiss button to click.


DialogAttribute(userName, password, dismissButton) constructor

DialogAttribute(userName, password, dismissButton) constructor
Namespaces > ArtOfTest.WebAii.TestAttributes > DialogAttribute > DialogAttributeNew(String, String, DialogButton)
Create a LogonDialog.
Syntax
C#
public DialogAttribute (
    string userName,
    string password,
    DialogButton dismissButton
)
Parameters
userName (String)
The username to use.
password (String)
The password to use.
dismissButton (DialogButton)
The dismiss button to click.


FindParamAttribute class

FindParamAttribute class
Namespaces > ArtOfTest.WebAii.TestAttributes > FindParamAttribute
FindParam attribute used to be set on a test method or test class.
Syntax
C#
[AttributeUsageAttribute(AttributeTargets.All, AllowMultiple = true, Inherited = true)]
public class FindParamAttribute : Attribute
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | FindParamAttributeNew(String) | Create a new FindParamAttribute.
 | FindParamAttributeNew(String, FindType, String) | Create a new FindParamAttribute.
 | FindParamAttributeNew(String, FindType, String, String[]()) | Create a new FindParamAttribute.
 | _Attribute.System.Runtime.InteropServices._Attribute.GetIDsOfNames(Guid, IntPtr, UInt32, UInt32, IntPtr) | (Inherited from Attribute.)
 | _Attribute.System.Runtime.InteropServices._Attribute.GetTypeInfo(UInt32, UInt32, IntPtr) | (Inherited from Attribute.)
 | _Attribute.System.Runtime.InteropServices._Attribute.GetTypeInfoCount(UInt32) | (Inherited from Attribute.)
 | _Attribute.System.Runtime.InteropServices._Attribute.Invoke(UInt32, Guid, UInt32, Int16, IntPtr, IntPtr, IntPtr, IntPtr) | (Inherited from Attribute.)
 | DefinesFrame | Gets whether the FindParam defines a Frame.
 | DefinesTestRegion | Gets whether the FindParam defines a TestRegion
 | Equals(Object) | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
 | FileName | The file name that contains the collection of FindParams.
 | Finalize() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindParam | The actualy FindParam object corresponding to this attribute.
 | FrameId | Gets or sets the frame id for this findparam.
 | FrameIndex | Gets or sets the frame index
 | FrameName | Gets or sets the frame name for this findparam.
 | GetHashCode() | Returns the hash code for this instance. (Inherited from Attribute.)
 | GetType() | Gets the Type of the current instance. (Inherited from Object.)
 | IsDefaultAttribute() | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
 | Key | The friendly name to identify this FindParam and the element it will identify when using Find.All().
 | Match(Object) | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
 | MemberwiseClone() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | TestRegionId | Gets or sets the TestRegion Id this FindParam belongs to.
 | ToString() | Returns a String that represents the current Object. (Inherited from Object.)
 | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Inheritance Hierarchy
Object
 | Attribute
 |  | FindParamAttribute


Constructors

FindParamAttribute constructors
Namespaces > ArtOfTest.WebAii.TestAttributes > FindParamAttribute > FindParamAttributeNew
Members
Icon | Member | Description
 | FindParamAttributeNew(String) | Create a new FindParamAttribute.
 | FindParamAttributeNew(String, FindType, String) | Create a new FindParamAttribute.
 | FindParamAttributeNew(String, FindType, String, String[]()) | Create a new FindParamAttribute.


FindParamAttribute(fileName) constructor

FindParamAttribute(fileName) constructor
Namespaces > ArtOfTest.WebAii.TestAttributes > FindParamAttribute > FindParamAttributeNew(String)
Create a new FindParamAttribute.
Syntax
C#
public FindParamAttribute (
    string fileName
)
Parameters
fileName (String)
The file name that contains the collection of FindParams.


FindParamAttribute(key, type, value) constructor

FindParamAttribute(key, type, value) constructor
Namespaces > ArtOfTest.WebAii.TestAttributes > FindParamAttribute > FindParamAttributeNew(String, FindType, String)
Create a new FindParamAttribute.
Syntax
C#
public FindParamAttribute (
    string key,
    FindType type,
    string value
)
Parameters
key (String)
The friendly name of this FindParam. You will use that name as the key in the dictionary of found elements using Find.Elements[] collection
type (FindType)
The type of the FindParam.
value (String)
The value of the FindParam


FindParamAttribute(key, type, value, attributes) constructor

FindParamAttribute(key, type, value, attributes) constructor
Namespaces > ArtOfTest.WebAii.TestAttributes > FindParamAttribute > FindParamAttributeNew(String, FindType, String, String[]())
Create a new FindParamAttribute.
Syntax
C#
public FindParamAttribute (
    string key,
    FindType type,
    string value,
    params string[] attributes
)
Parameters
key (String)
The friendly name of this FindParam. You will use that name as the key in the dictionary of found elements using Find.Elements[] collection
type (FindType)
The type of the FindParam.
value (String)
The value of the FindParam
attributes (String []())
The list of attributes to match.
Remarks
value can be set as (string.empty for FindType.AttributesOnly, "tagName:tagIndex" for FindType.TagIndex, "p/l/x:text or expression" for FindType.Content, "xpath" for FindType.XPath, "nodeindexpath" for FindType.NodeIndexPath


DefinesFrame property

FindParamAttribute.DefinesFrame property
Namespaces > ArtOfTest.WebAii.TestAttributes > FindParamAttribute > DefinesFrame
Gets whether the FindParam defines a Frame.
Syntax
C#
public bool DefinesFrame { get; }


DefinesTestRegion property

FindParamAttribute.DefinesTestRegion property
Namespaces > ArtOfTest.WebAii.TestAttributes > FindParamAttribute > DefinesTestRegion
Gets whether the FindParam defines a TestRegion
Syntax
C#
public bool DefinesTestRegion { get; }


FileName property

FindParamAttribute.FileName property
Namespaces > ArtOfTest.WebAii.TestAttributes > FindParamAttribute > FileName
The file name that contains the collection of FindParams.
Syntax
C#
public string FileName { get; }


FindParam property

FindParamAttribute.FindParam property
Namespaces > ArtOfTest.WebAii.TestAttributes > FindParamAttribute > FindParam
The actualy FindParam object corresponding to this attribute.
Syntax
C#
public FindParam FindParam { get; }


FrameId property

FindParamAttribute.FrameId property
Namespaces > ArtOfTest.WebAii.TestAttributes > FindParamAttribute > FrameId
Gets or sets the frame id for this findparam.
Syntax
C#
public string FrameId { get; set; }


FrameIndex property

FindParamAttribute.FrameIndex property
Namespaces > ArtOfTest.WebAii.TestAttributes > FindParamAttribute > FrameIndex
Gets or sets the frame index
Syntax
C#
public int FrameIndex { get; set; }


FrameName property

FindParamAttribute.FrameName property
Namespaces > ArtOfTest.WebAii.TestAttributes > FindParamAttribute > FrameName
Gets or sets the frame name for this findparam.
Syntax
C#
public string FrameName { get; set; }


Key property

FindParamAttribute.Key property
Namespaces > ArtOfTest.WebAii.TestAttributes > FindParamAttribute > Key
The friendly name to identify this FindParam and the element it will identify when using Find.All().
Syntax
C#
public string Key { get; }


TestRegionId property

FindParamAttribute.TestRegionId property
Namespaces > ArtOfTest.WebAii.TestAttributes > FindParamAttribute > TestRegionId
Gets or sets the TestRegion Id this FindParam belongs to.
Syntax
C#
public string TestRegionId { get; set; }


ArtOfTest.WebAii.TestTemplates Namespace

ArtOfTest.WebAii.TestTemplates Namespace
Namespaces > ArtOfTest.WebAii.TestTemplates
Syntax
C#
namespace ArtOfTest.WebAii.TestTemplates
Types
All Types Classes Structures Interfaces Enumerations Delegates
Icon | Type | Description
public class | BaseNUnitTest | This class integrates NUnit testing framework and should only be used with it.
public delegate | BaseNUnitTest.TestContextWriteLine | The NUnit TestContext.Out.WriteLine delegate.
public class | BaseNUnitTestSharedManager | A base unit class that uses a static Manager object. This base class can be used to share browser instances across test methods.
public class | BaseVsUnitTest | This class integrates Microsoft's Visual Studio Team Test unit testing framework and should only be used with it.
public class | BaseVsUnitTestSharedManager | A base unit class that uses a static Manager object. This base class can be used to share browser instances across test methods.
public delegate | TestContextWriteLine | The VS TestContext WriteLine method delegate.


BaseNUnitTest class

BaseNUnitTest class
Namespaces > ArtOfTest.WebAii.TestTemplates > BaseNUnitTest
This class integrates NUnit testing framework and should only be used with it.
Syntax
C#
public abstract class BaseNUnitTest
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BaseNUnitTestNew() |
 | Actions | Gets the actions object associated with the ActiveBrowser.
 | ActiveBrowser | Gets the ActiveBrowser object. (The last browser launched).
 | CleanUp() | Shut down and clean-up.
 | Desktop | Gets the Desktop object from the Manager.
 | Elements | Gets the Elements finder to be used to access elements defined by FindParamAttributes on the test method or class. This accessor replaces the Find.Elements collection.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Find | Gets the Find object associated with the ActiveBrowser.
 | GetHashCode() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetSettings() | This method reads the settings object from the App.Config file and returns a Settings object. Examples The following is a sample config file that holds certain settings. Any settings not specified in this section, their values will be set to the system defaults: <?xml version="1.0" encoding="utf-8" ?> <configuration> <configSections> <section name="WebAii.Settings" type="ArtOfTest.WebAii.Core.SettingsConfigSectionHandler,ArtOfTest.WebAii"/> </configSections> <WebAii.Settings defaultBrowser="InternetExplorer" logLocation="D:\Log\" executionTimeout="60000" clientReadyTimeout="50000" /> </configuration>
 | GetType() | Gets the Type of the current instance. (Inherited from Object.)
 | Initialize() | Initialize this test case object.
 | Initialize(Settings, TestContextWriteLine) | Initialize this test case object.
 | Initialize(String) | Initialize this test case object.
 | Initialize(String, TestContextWriteLine) | Initialize this test case object.
 | Initialize(TestContextWriteLine) | Initialize this test case object.
 | Log | Gets the Log object associated with the Manager.
 | Manager | Gets the Manager object.
 | MemberwiseClone() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | SetTestMethod(Object, String) | Set the TestMethod executing so that WebAii can extract its attributes.
 | ToString() | Returns a String that represents the current Object. (Inherited from Object.)
 | Wait | Gets a wait object that can be used to wait on specific actions or opertions.
Inheritance Hierarchy
Object
BaseNUnitTest


Actions property

BaseNUnitTest.Actions property
Namespaces > ArtOfTest.WebAii.TestTemplates > BaseNUnitTest > Actions
Gets the actions object associated with the ActiveBrowser.
Syntax
C#
public Actions Actions { get; }


ActiveBrowser property

BaseNUnitTest.ActiveBrowser property
Namespaces > ArtOfTest.WebAii.TestTemplates > BaseNUnitTest > ActiveBrowser
Gets the ActiveBrowser object. (The last browser launched).
Syntax
C#
public Browser ActiveBrowser { get; }


BaseNUnitTest() constructor

BaseNUnitTest() constructor
Namespaces > ArtOfTest.WebAii.TestTemplates > BaseNUnitTest > BaseNUnitTestNew()
Syntax
C#
protected BaseNUnitTest ()


CleanUp() method

BaseNUnitTest.CleanUp() method
Namespaces > ArtOfTest.WebAii.TestTemplates > BaseNUnitTest > CleanUp()
Shut down and clean-up.
Syntax
C#
public void CleanUp ()


Desktop property

BaseNUnitTest.Desktop property
Namespaces > ArtOfTest.WebAii.TestTemplates > BaseNUnitTest > Desktop
Gets the Desktop object from the Manager.
Syntax
C#
public Desktop Desktop { get; }


Elements property

BaseNUnitTest.Elements property
Namespaces > ArtOfTest.WebAii.TestTemplates > BaseNUnitTest > Elements
Gets the Elements finder to be used to access elements defined by FindParamAttributes on the test method or class. This accessor replaces the Find.Elements collection.
Syntax
C#
public ElementFinder Elements { get; }


Find property

BaseNUnitTest.Find property
Namespaces > ArtOfTest.WebAii.TestTemplates > BaseNUnitTest > Find
Gets the Find object associated with the ActiveBrowser.
Syntax
C#
public Find Find { get; }


GetSettings() method

BaseNUnitTest.GetSettings() method
Namespaces > ArtOfTest.WebAii.TestTemplates > BaseNUnitTest > GetSettings()
This method reads the settings object from the App.Config file and returns a Settings object.
Examples
The following is a sample config file that holds certain settings. Any settings not specified in this section, their values will be set to the system defaults: <?xml version="1.0" encoding="utf-8" ?> <configuration> <configSections> <section name="WebAii.Settings" type="ArtOfTest.WebAii.Core.SettingsConfigSectionHandler,ArtOfTest.WebAii"/> </configSections> <WebAii.Settings defaultBrowser="InternetExplorer" logLocation="D:\Log\" executionTimeout="60000" clientReadyTimeout="50000" /> </configuration>
Syntax
C#
public static Settings GetSettings ()
Return Value
The settings object read from App.Config.
Remarks
If you call this method and there are not settings present in the App.Config, then the method will create an empty Setting object and reset it to the system default settings. Also note that all Initialize() methods will call this method to attempt to load the settings.


Initialize methods

BaseNUnitTest.Initialize methods
Namespaces > ArtOfTest.WebAii.TestTemplates > BaseNUnitTest > Initialize
Members
Icon | Member | Description
 | Initialize() | Initialize this test case object.
 | Initialize(Settings, TestContextWriteLine) | Initialize this test case object.
 | Initialize(TestContextWriteLine) | Initialize this test case object.
 | Initialize(String) | Initialize this test case object.
 | Initialize(String, TestContextWriteLine) | Initialize this test case object.


Initialize() method

BaseNUnitTest.Initialize() method
Namespaces > ArtOfTest.WebAii.TestTemplates > BaseNUnitTest > Initialize()
Initialize this test case object.
Syntax
C#
public void Initialize ()


Initialize(logLocation) method

BaseNUnitTest.Initialize(logLocation) method
Namespaces > ArtOfTest.WebAii.TestTemplates > BaseNUnitTest > Initialize(String)
Initialize this test case object.
Syntax
C#
public void Initialize (
    string logLocation
)
Parameters
logLocation (String)
The log location where to do the logging.


Initialize(logLocation, nunitWriteLineDelegate) method

BaseNUnitTest.Initialize(logLocation, nunitWriteLineDelegate) method
Namespaces > ArtOfTest.WebAii.TestTemplates > BaseNUnitTest > Initialize(String, TestContextWriteLine)
Initialize this test case object.
Syntax
C#
public void Initialize (
    string logLocation,
    BaseNUnitTest.TestContextWriteLine nunitWriteLineDelegate
)
Parameters
logLocation (String)
The log location where to do the logging.
nunitWriteLineDelegate (TestContextWriteLine)
The NUnit TestContext.Out.WriteLine delegate.


Initialize(nunitWriteLineDelegate) method

BaseNUnitTest.Initialize(nunitWriteLineDelegate) method
Namespaces > ArtOfTest.WebAii.TestTemplates > BaseNUnitTest > Initialize(TestContextWriteLine)
Initialize this test case object.
Syntax
C#
public void Initialize (
    BaseNUnitTest.TestContextWriteLine nunitWriteLineDelegate
)
Parameters
nunitWriteLineDelegate (TestContextWriteLine)
The NUnit TestContext.Out.WriteLine delegate.


Initialize(settings, nunitWriteLineDelegate) method

BaseNUnitTest.Initialize(settings, nunitWriteLineDelegate) method
Namespaces > ArtOfTest.WebAii.TestTemplates > BaseNUnitTest > Initialize(Settings, TestContextWriteLine)
Initialize this test case object.
Syntax
C#
public void Initialize (
    Settings settings,
    BaseNUnitTest.TestContextWriteLine nunitWriteLineDelegate
)
Parameters
settings (Settings)
The settings to use for initialization.
nunitWriteLineDelegate (TestContextWriteLine)
The NUnit TestContext.Out.WriteLine delegate.


Log property

BaseNUnitTest.Log property
Namespaces > ArtOfTest.WebAii.TestTemplates > BaseNUnitTest > Log
Gets the Log object associated with the Manager.
Syntax
C#
public Log Log { get; }


Manager property

BaseNUnitTest.Manager property
Namespaces > ArtOfTest.WebAii.TestTemplates > BaseNUnitTest > Manager
Gets the Manager object.
Syntax
C#
public Manager Manager { get; }


SetTestMethod(testObject, testMethodName) method

BaseNUnitTest.SetTestMethod(testObject, testMethodName) method
Namespaces > ArtOfTest.WebAii.TestTemplates > BaseNUnitTest > SetTestMethod(Object, String)
Set the TestMethod executing so that WebAii can extract its attributes.
Syntax
C#
public void SetTestMethod (
    Object testObject,
    string testMethodName
)
Parameters
testObject (Object)
The test object.
testMethodName (String)
The test Method name executing.


Wait property

BaseNUnitTest.Wait property
Namespaces > ArtOfTest.WebAii.TestTemplates > BaseNUnitTest > Wait
Gets a wait object that can be used to wait on specific actions or opertions.
Syntax
C#
public WaitSync Wait { get; }


BaseNUnitTest.TestContextWriteLine delegate

BaseNUnitTest.TestContextWriteLine delegate
Namespaces > ArtOfTest.WebAii.TestTemplates > BaseNUnitTest > TestContextWriteLine
The NUnit TestContext.Out.WriteLine delegate.
Syntax
C#
public delegate void TestContextWriteLine (
    string Format,
    params Object[] args
)
Parameters
Format (String)
The format string.
args (Object []())
The arguments.
Remarks
Settings this delegate will allow us to unify the logging with NUnit.


BaseNUnitTestSharedManager class

BaseNUnitTestSharedManager class
Namespaces > ArtOfTest.WebAii.TestTemplates > BaseNUnitTestSharedManager
A base unit class that uses a static Manager object. This base class can be used to share browser instances across test methods.
Syntax
C#
public abstract class BaseNUnitTestSharedManager
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BaseNUnitTestSharedManagerNew() |
 | Actions | Gets the actions object associated with the ActiveBrowser.
 | ActiveBrowser | Gets the ActiveBrowser object. (The last browser launched).
 | CleanUp() | Shut down and clean-up.
 | Desktop | Gets the Desktop object from the Manager.
 | Elements | Gets the Elements finder to be used to access elements defined by FindParamAttributes on the test method or class. This accessor replaces the Find.Elements collection.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Find | Gets the Find object associated with the ActiveBrowser.
 | GetHashCode() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetSettings() | This method reads the settings object from the App.Config file and returns a Settings object. Examples The following is a sample config file that holds certain settings. Any settings not specified in this section, their values will be set to the system defaults: <?xml version="1.0" encoding="utf-8" ?> <configuration> <configSections> <section name="WebAii.Settings" type="ArtOfTest.WebAii.Core.SettingsConfigSectionHandler,ArtOfTest.WebAii"/> </configSections> <WebAii.Settings defaultBrowser="InternetExplorer" logLocation="D:\Log\" executionTimeout="60000" clientReadyTimeout="50000" /> </configuration>
 | GetType() | Gets the Type of the current instance. (Inherited from Object.)
 | Initialize() | Initialize this test case object.
 | Initialize(Settings, TestContextWriteLine) | Initialize this test case object.
 | Initialize(String) | Initialize this test case object.
 | Initialize(String, TestContextWriteLine) | Initialize this test case object.
 | Initialize(TestContextWriteLine) | Initialize this test case object.
 | Log | Gets the Log object associated with the Manager.
 | Manager | Gets the Manager object.
 | MemberwiseClone() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | SetTestMethod(Object, String) | Set the TestMethod executing so that WebAii can extract its attributes.
 | ToString() | Returns a String that represents the current Object. (Inherited from Object.)
 | Wait | Gets a wait object that can be used to wait on specific actions or opertions.
Inheritance Hierarchy
Object
BaseNUnitTestSharedManager


Actions property

BaseNUnitTestSharedManager.Actions property
Namespaces > ArtOfTest.WebAii.TestTemplates > BaseNUnitTestSharedManager > Actions
Gets the actions object associated with the ActiveBrowser.
Syntax
C#
public static Actions Actions { get; }


ActiveBrowser property

BaseNUnitTestSharedManager.ActiveBrowser property
Namespaces > ArtOfTest.WebAii.TestTemplates > BaseNUnitTestSharedManager > ActiveBrowser
Gets the ActiveBrowser object. (The last browser launched).
Syntax
C#
public static Browser ActiveBrowser { get; }


BaseNUnitTestSharedManager() constructor

BaseNUnitTestSharedManager() constructor
Namespaces > ArtOfTest.WebAii.TestTemplates > BaseNUnitTestSharedManager > BaseNUnitTestSharedManagerNew()
Syntax
C#
protected BaseNUnitTestSharedManager ()


CleanUp() method

BaseNUnitTestSharedManager.CleanUp() method
Namespaces > ArtOfTest.WebAii.TestTemplates > BaseNUnitTestSharedManager > CleanUp()
Shut down and clean-up.
Syntax
C#
public static void CleanUp ()


Desktop property

BaseNUnitTestSharedManager.Desktop property
Namespaces > ArtOfTest.WebAii.TestTemplates > BaseNUnitTestSharedManager > Desktop
Gets the Desktop object from the Manager.
Syntax
C#
public static Desktop Desktop { get; }


Elements property

BaseNUnitTestSharedManager.Elements property
Namespaces > ArtOfTest.WebAii.TestTemplates > BaseNUnitTestSharedManager > Elements
Gets the Elements finder to be used to access elements defined by FindParamAttributes on the test method or class. This accessor replaces the Find.Elements collection.
Syntax
C#
public static ElementFinder Elements { get; }


Find property

BaseNUnitTestSharedManager.Find property
Namespaces > ArtOfTest.WebAii.TestTemplates > BaseNUnitTestSharedManager > Find
Gets the Find object associated with the ActiveBrowser.
Syntax
C#
public static Find Find { get; }


GetSettings() method

BaseNUnitTestSharedManager.GetSettings() method
Namespaces > ArtOfTest.WebAii.TestTemplates > BaseNUnitTestSharedManager > GetSettings()
This method reads the settings object from the App.Config file and returns a Settings object.
Examples
The following is a sample config file that holds certain settings. Any settings not specified in this section, their values will be set to the system defaults: <?xml version="1.0" encoding="utf-8" ?> <configuration> <configSections> <section name="WebAii.Settings" type="ArtOfTest.WebAii.Core.SettingsConfigSectionHandler,ArtOfTest.WebAii"/> </configSections> <WebAii.Settings defaultBrowser="InternetExplorer" logLocation="D:\Log\" executionTimeout="60000" clientReadyTimeout="50000" /> </configuration>
Syntax
C#
public static Settings GetSettings ()
Return Value
The settings object read from App.Config.
Remarks
If you call this method and there are not settings present in the App.Config, then the method will create an empty Setting object and reset it to the system default settings. Also note that all Initialize() methods will call this method to attempt to load the settings.


Initialize methods

BaseNUnitTestSharedManager.Initialize methods
Namespaces > ArtOfTest.WebAii.TestTemplates > BaseNUnitTestSharedManager > Initialize
Members
Icon | Member | Description
 | Initialize() | Initialize this test case object.
 | Initialize(Settings, TestContextWriteLine) | Initialize this test case object.
 | Initialize(TestContextWriteLine) | Initialize this test case object.
 | Initialize(String) | Initialize this test case object.
 | Initialize(String, TestContextWriteLine) | Initialize this test case object.


Initialize() method

BaseNUnitTestSharedManager.Initialize() method
Namespaces > ArtOfTest.WebAii.TestTemplates > BaseNUnitTestSharedManager > Initialize()
Initialize this test case object.
Syntax
C#
public static void Initialize ()


Initialize(logLocation) method

BaseNUnitTestSharedManager.Initialize(logLocation) method
Namespaces > ArtOfTest.WebAii.TestTemplates > BaseNUnitTestSharedManager > Initialize(String)
Initialize this test case object.
Syntax
C#
public static void Initialize (
    string logLocation
)
Parameters
logLocation (String)
The log location where to do the logging.


Initialize(logLocation, nunitWriteLineDelegate) method

BaseNUnitTestSharedManager.Initialize(logLocation, nunitWriteLineDelegate) method
Namespaces > ArtOfTest.WebAii.TestTemplates > BaseNUnitTestSharedManager > Initialize(String, TestContextWriteLine)
Initialize this test case object.
Syntax
C#
public static void Initialize (
    string logLocation,
    TestContextWriteLine nunitWriteLineDelegate
)
Parameters
logLocation (String)
The log location where to do the logging.
nunitWriteLineDelegate (TestContextWriteLine)
The NUnit TestContext.Out.WriteLine delegate.


Initialize(nunitWriteLineDelegate) method

BaseNUnitTestSharedManager.Initialize(nunitWriteLineDelegate) method
Namespaces > ArtOfTest.WebAii.TestTemplates > BaseNUnitTestSharedManager > Initialize(TestContextWriteLine)
Initialize this test case object.
Syntax
C#
public static void Initialize (
    TestContextWriteLine nunitWriteLineDelegate
)
Parameters
nunitWriteLineDelegate (TestContextWriteLine)
The NUnit TestContext.Out.WriteLine delegate.


Initialize(settings, nunitWriteLineDelegate) method

BaseNUnitTestSharedManager.Initialize(settings, nunitWriteLineDelegate) method
Namespaces > ArtOfTest.WebAii.TestTemplates > BaseNUnitTestSharedManager > Initialize(Settings, TestContextWriteLine)
Initialize this test case object.
Syntax
C#
public static void Initialize (
    Settings settings,
    TestContextWriteLine nunitWriteLineDelegate
)
Parameters
settings (Settings)
The settings to use for initialization.
nunitWriteLineDelegate (TestContextWriteLine)
The NUnit TestContext.Out.WriteLine delegate.


Log property

BaseNUnitTestSharedManager.Log property
Namespaces > ArtOfTest.WebAii.TestTemplates > BaseNUnitTestSharedManager > Log
Gets the Log object associated with the Manager.
Syntax
C#
public static Log Log { get; }


Manager property

BaseNUnitTestSharedManager.Manager property
Namespaces > ArtOfTest.WebAii.TestTemplates > BaseNUnitTestSharedManager > Manager
Gets the Manager object.
Syntax
C#
public static Manager Manager { get; }


SetTestMethod(testObject, testMethodName) method

BaseNUnitTestSharedManager.SetTestMethod(testObject, testMethodName) method
Namespaces > ArtOfTest.WebAii.TestTemplates > BaseNUnitTestSharedManager > SetTestMethod(Object, String)
Set the TestMethod executing so that WebAii can extract its attributes.
Syntax
C#
public static void SetTestMethod (
    Object testObject,
    string testMethodName
)
Parameters
testObject (Object)
The test object.
testMethodName (String)
The test Method name executing.


Wait property

BaseNUnitTestSharedManager.Wait property
Namespaces > ArtOfTest.WebAii.TestTemplates > BaseNUnitTestSharedManager > Wait
Gets a wait object that can be used to wait on specific actions or opertions.
Syntax
C#
public static WaitSync Wait { get; }


BaseVsUnitTest class

BaseVsUnitTest class
Namespaces > ArtOfTest.WebAii.TestTemplates > BaseVsUnitTest
This class integrates Microsoft's Visual Studio Team Test unit testing framework and should only be used with it.
Syntax
C#
public abstract class BaseVsUnitTest
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BaseVsUnitTestNew() |
 | Actions | Gets the actions object associated with the ActiveBrowser.
 | ActiveBrowser | Gets the ActiveBrowser object. (The last browser launched).
 | CleanUp() | Shut down and clean-up.
 | Desktop | Gets the Desktop object from the Manager.
 | Elements | Gets the Elements finder to be used to access elements defined by FindParamAttributes on the test method or class. This accessor replaces the Find.Elements collection.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Find | Gets the Find object associated with the ActiveBrowser.
 | GetHashCode() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetSettings() | This method reads the settings object from the App.Config file and returns a Settings object. Examples The following is a sample config file that holds certain settings. Any settings not specified in this section, their values will be set to the system defaults: <?xml version="1.0" encoding="utf-8" ?> <configuration> <configSections> <section name="WebAii.Settings" type="ArtOfTest.WebAii.Core.SettingsConfigSectionHandler,ArtOfTest.WebAii"/> </configSections> <WebAii.Settings defaultBrowser="InternetExplorer" logLocation="D:\Log\" executionTimeout="60000" clientReadyTimeout="50000" /> </configuration>
 | GetType() | Gets the Type of the current instance. (Inherited from Object.)
 | Initialize() | Initialize this test case object.
 | Initialize(Settings, TestContextWriteLine) | Initialize this test case object.
 | Initialize(String) | Initialize this test case object.
 | Initialize(String, TestContextWriteLine) | Initialize this test case object.
 | Initialize(TestContextWriteLine) | Initialize this test case object.
 | Log | Gets the Log object associated with the Manager.
 | Manager | Gets the Manager object.
 | MemberwiseClone() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | SetTestMethod(Object, String) | Set the TestMethod executing so that WebAii can extract its attributes.
 | ToString() | Returns a String that represents the current Object. (Inherited from Object.)
 | Wait | Gets a wait object that can be used to wait on specific actions or opertions.
Inheritance Hierarchy
Object
BaseVsUnitTest


Actions property

BaseVsUnitTest.Actions property
Namespaces > ArtOfTest.WebAii.TestTemplates > BaseVsUnitTest > Actions
Gets the actions object associated with the ActiveBrowser.
Syntax
C#
public Actions Actions { get; }


ActiveBrowser property

BaseVsUnitTest.ActiveBrowser property
Namespaces > ArtOfTest.WebAii.TestTemplates > BaseVsUnitTest > ActiveBrowser
Gets the ActiveBrowser object. (The last browser launched).
Syntax
C#
public Browser ActiveBrowser { get; }


BaseVsUnitTest() constructor

BaseVsUnitTest() constructor
Namespaces > ArtOfTest.WebAii.TestTemplates > BaseVsUnitTest > BaseVsUnitTestNew()
Syntax
C#
protected BaseVsUnitTest ()


CleanUp() method

BaseVsUnitTest.CleanUp() method
Namespaces > ArtOfTest.WebAii.TestTemplates > BaseVsUnitTest > CleanUp()
Shut down and clean-up.
Syntax
C#
public void CleanUp ()


Desktop property

BaseVsUnitTest.Desktop property
Namespaces > ArtOfTest.WebAii.TestTemplates > BaseVsUnitTest > Desktop
Gets the Desktop object from the Manager.
Syntax
C#
public Desktop Desktop { get; }


Elements property

BaseVsUnitTest.Elements property
Namespaces > ArtOfTest.WebAii.TestTemplates > BaseVsUnitTest > Elements
Gets the Elements finder to be used to access elements defined by FindParamAttributes on the test method or class. This accessor replaces the Find.Elements collection.
Syntax
C#
public ElementFinder Elements { get; }


Find property

BaseVsUnitTest.Find property
Namespaces > ArtOfTest.WebAii.TestTemplates > BaseVsUnitTest > Find
Gets the Find object associated with the ActiveBrowser.
Syntax
C#
public Find Find { get; }


GetSettings() method

BaseVsUnitTest.GetSettings() method
Namespaces > ArtOfTest.WebAii.TestTemplates > BaseVsUnitTest > GetSettings()
This method reads the settings object from the App.Config file and returns a Settings object.
Examples
The following is a sample config file that holds certain settings. Any settings not specified in this section, their values will be set to the system defaults: <?xml version="1.0" encoding="utf-8" ?> <configuration> <configSections> <section name="WebAii.Settings" type="ArtOfTest.WebAii.Core.SettingsConfigSectionHandler,ArtOfTest.WebAii"/> </configSections> <WebAii.Settings defaultBrowser="InternetExplorer" logLocation="D:\Log\" executionTimeout="60000" clientReadyTimeout="50000" /> </configuration>
Syntax
C#
public static Settings GetSettings ()
Return Value
The settings object read from App.Config.
Remarks
If you call this method and there are not settings present in the App.Config, then the method will create an empty Setting object and reset it to the system default settings. Also note that all Initialize() methods will call this method to attempt to load the settings.


Initialize methods

BaseVsUnitTest.Initialize methods
Namespaces > ArtOfTest.WebAii.TestTemplates > BaseVsUnitTest > Initialize
Members
Icon | Member | Description
 | Initialize() | Initialize this test case object.
 | Initialize(Settings, TestContextWriteLine) | Initialize this test case object.
 | Initialize(TestContextWriteLine) | Initialize this test case object.
 | Initialize(String) | Initialize this test case object.
 | Initialize(String, TestContextWriteLine) | Initialize this test case object.


Initialize() method

BaseVsUnitTest.Initialize() method
Namespaces > ArtOfTest.WebAii.TestTemplates > BaseVsUnitTest > Initialize()
Initialize this test case object.
Syntax
C#
public void Initialize ()


Initialize(logLocation) method

BaseVsUnitTest.Initialize(logLocation) method
Namespaces > ArtOfTest.WebAii.TestTemplates > BaseVsUnitTest > Initialize(String)
Initialize this test case object.
Syntax
C#
public void Initialize (
    string logLocation
)
Parameters
logLocation (String)
The log location where to do the logging.


Initialize(logLocation, vsWriteLineDelegate) method

BaseVsUnitTest.Initialize(logLocation, vsWriteLineDelegate) method
Namespaces > ArtOfTest.WebAii.TestTemplates > BaseVsUnitTest > Initialize(String, TestContextWriteLine)
Initialize this test case object.
Syntax
C#
public void Initialize (
    string logLocation,
    TestContextWriteLine vsWriteLineDelegate
)
Parameters
logLocation (String)
The log location where to do the logging.
vsWriteLineDelegate (TestContextWriteLine)
The VS TestContext.WriteLine delegate.


Initialize(settings, vsWriteLineDelegate) method

BaseVsUnitTest.Initialize(settings, vsWriteLineDelegate) method
Namespaces > ArtOfTest.WebAii.TestTemplates > BaseVsUnitTest > Initialize(Settings, TestContextWriteLine)
Initialize this test case object.
Syntax
C#
public void Initialize (
    Settings settings,
    TestContextWriteLine vsWriteLineDelegate
)
Parameters
settings (Settings)
The settings to use for initialization.
vsWriteLineDelegate (TestContextWriteLine)
The VS TestContext.WriteLine delegate.


Initialize(vsWriteLineDelegate) method

BaseVsUnitTest.Initialize(vsWriteLineDelegate) method
Namespaces > ArtOfTest.WebAii.TestTemplates > BaseVsUnitTest > Initialize(TestContextWriteLine)
Initialize this test case object.
Syntax
C#
public void Initialize (
    TestContextWriteLine vsWriteLineDelegate
)
Parameters
vsWriteLineDelegate (TestContextWriteLine)
The VS TestContext.WriteLine delegate.


Log property

BaseVsUnitTest.Log property
Namespaces > ArtOfTest.WebAii.TestTemplates > BaseVsUnitTest > Log
Gets the Log object associated with the Manager.
Syntax
C#
public Log Log { get; }


Manager property

BaseVsUnitTest.Manager property
Namespaces > ArtOfTest.WebAii.TestTemplates > BaseVsUnitTest > Manager
Gets the Manager object.
Syntax
C#
public Manager Manager { get; }


SetTestMethod(testObject, testMethodName) method

BaseVsUnitTest.SetTestMethod(testObject, testMethodName) method
Namespaces > ArtOfTest.WebAii.TestTemplates > BaseVsUnitTest > SetTestMethod(Object, String)
Set the TestMethod executing so that WebAii can extract its attributes.
Syntax
C#
public void SetTestMethod (
    Object testObject,
    string testMethodName
)
Parameters
testObject (Object)
The test object.
testMethodName (String)
The test Method name executing.


Wait property

BaseVsUnitTest.Wait property
Namespaces > ArtOfTest.WebAii.TestTemplates > BaseVsUnitTest > Wait
Gets a wait object that can be used to wait on specific actions or opertions.
Syntax
C#
public WaitSync Wait { get; }


BaseVsUnitTestSharedManager class

BaseVsUnitTestSharedManager class
Namespaces > ArtOfTest.WebAii.TestTemplates > BaseVsUnitTestSharedManager
A base unit class that uses a static Manager object. This base class can be used to share browser instances across test methods.
Syntax
C#
public abstract class BaseVsUnitTestSharedManager
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BaseVsUnitTestSharedManagerNew() |
 | Actions | Gets the actions object associated with the ActiveBrowser.
 | ActiveBrowser | Gets the ActiveBrowser object. (The last browser launched).
 | CleanUp() | Shut down and clean-up.
 | Desktop | Gets the Desktop object from the Manager.
 | Elements | Gets the Elements finder to be used to access elements defined by FindParamAttributes on the test method or class. This accessor replaces the Find.Elements collection.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Find | Gets the Find object associated with the ActiveBrowser.
 | GetHashCode() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetSettings() | This method reads the settings object from the App.Config file and returns a Settings object. Examples The following is a sample config file that holds certain settings. Any settings not specified in this section, their values will be set to the system defaults: <?xml version="1.0" encoding="utf-8" ?> <configuration> <configSections> <section name="WebAii.Settings" type="ArtOfTest.WebAii.Core.SettingsConfigSectionHandler,ArtOfTest.WebAii"/> </configSections> <WebAii.Settings defaultBrowser="InternetExplorer" logLocation="D:\Log\" executionTimeout="60000" clientReadyTimeout="50000" /> </configuration>
 | GetType() | Gets the Type of the current instance. (Inherited from Object.)
 | Initialize() | Initialize this test case object.
 | Initialize(Settings) | Initialize this test case object.
 | Initialize(String) | Initialize this test case object.
 | Log | Gets the Log object associated with the Manager.
 | Manager | Gets the Manager object.
 | MemberwiseClone() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | SetTestMethod(Object, String) | Set the TestMethod executing so that WebAii can extract its attributes.
 | ToString() | Returns a String that represents the current Object. (Inherited from Object.)
 | VsWriteLineDelegate | Gets/Sets the vsWriteLineDelegate
 | Wait | Gets a wait object that can be used to wait on specific actions or opertions.
Inheritance Hierarchy
Object
BaseVsUnitTestSharedManager


Actions property

BaseVsUnitTestSharedManager.Actions property
Namespaces > ArtOfTest.WebAii.TestTemplates > BaseVsUnitTestSharedManager > Actions
Gets the actions object associated with the ActiveBrowser.
Syntax
C#
public static Actions Actions { get; }


ActiveBrowser property

BaseVsUnitTestSharedManager.ActiveBrowser property
Namespaces > ArtOfTest.WebAii.TestTemplates > BaseVsUnitTestSharedManager > ActiveBrowser
Gets the ActiveBrowser object. (The last browser launched).
Syntax
C#
public static Browser ActiveBrowser { get; }


BaseVsUnitTestSharedManager() constructor

BaseVsUnitTestSharedManager() constructor
Namespaces > ArtOfTest.WebAii.TestTemplates > BaseVsUnitTestSharedManager > BaseVsUnitTestSharedManagerNew()
Syntax
C#
protected BaseVsUnitTestSharedManager ()


CleanUp() method

BaseVsUnitTestSharedManager.CleanUp() method
Namespaces > ArtOfTest.WebAii.TestTemplates > BaseVsUnitTestSharedManager > CleanUp()
Shut down and clean-up.
Syntax
C#
public static void CleanUp ()


Desktop property

BaseVsUnitTestSharedManager.Desktop property
Namespaces > ArtOfTest.WebAii.TestTemplates > BaseVsUnitTestSharedManager > Desktop
Gets the Desktop object from the Manager.
Syntax
C#
public static Desktop Desktop { get; }


Elements property

BaseVsUnitTestSharedManager.Elements property
Namespaces > ArtOfTest.WebAii.TestTemplates > BaseVsUnitTestSharedManager > Elements
Gets the Elements finder to be used to access elements defined by FindParamAttributes on the test method or class. This accessor replaces the Find.Elements collection.
Syntax
C#
public static ElementFinder Elements { get; }


Find property

BaseVsUnitTestSharedManager.Find property
Namespaces > ArtOfTest.WebAii.TestTemplates > BaseVsUnitTestSharedManager > Find
Gets the Find object associated with the ActiveBrowser.
Syntax
C#
public static Find Find { get; }


GetSettings() method

BaseVsUnitTestSharedManager.GetSettings() method
Namespaces > ArtOfTest.WebAii.TestTemplates > BaseVsUnitTestSharedManager > GetSettings()
This method reads the settings object from the App.Config file and returns a Settings object.
Examples
The following is a sample config file that holds certain settings. Any settings not specified in this section, their values will be set to the system defaults: <?xml version="1.0" encoding="utf-8" ?> <configuration> <configSections> <section name="WebAii.Settings" type="ArtOfTest.WebAii.Core.SettingsConfigSectionHandler,ArtOfTest.WebAii"/> </configSections> <WebAii.Settings defaultBrowser="InternetExplorer" logLocation="D:\Log\" executionTimeout="60000" clientReadyTimeout="50000" /> </configuration>
Syntax
C#
public static Settings GetSettings ()
Return Value
The settings object read from App.Config.
Remarks
If you call this method and there are not settings present in the App.Config, then the method will create an empty Setting object and reset it to the system default settings. Also note that all Initialize() methods will call this method to attempt to load the settings.


Initialize methods

BaseVsUnitTestSharedManager.Initialize methods
Namespaces > ArtOfTest.WebAii.TestTemplates > BaseVsUnitTestSharedManager > Initialize
Members
Icon | Member | Description
 | Initialize() | Initialize this test case object.
 | Initialize(Settings) | Initialize this test case object.
 | Initialize(String) | Initialize this test case object.


Initialize() method

BaseVsUnitTestSharedManager.Initialize() method
Namespaces > ArtOfTest.WebAii.TestTemplates > BaseVsUnitTestSharedManager > Initialize()
Initialize this test case object.
Syntax
C#
public static void Initialize ()


Initialize(logLocation) method

BaseVsUnitTestSharedManager.Initialize(logLocation) method
Namespaces > ArtOfTest.WebAii.TestTemplates > BaseVsUnitTestSharedManager > Initialize(String)
Initialize this test case object.
Syntax
C#
public static void Initialize (
    string logLocation
)
Parameters
logLocation (String)
The log location where to do the logging.


Initialize(settings) method

BaseVsUnitTestSharedManager.Initialize(settings) method
Namespaces > ArtOfTest.WebAii.TestTemplates > BaseVsUnitTestSharedManager > Initialize(Settings)
Initialize this test case object.
Syntax
C#
public static void Initialize (
    Settings settings
)
Parameters
settings (Settings)
The settings to use for initialization.


Log property

BaseVsUnitTestSharedManager.Log property
Namespaces > ArtOfTest.WebAii.TestTemplates > BaseVsUnitTestSharedManager > Log
Gets the Log object associated with the Manager.
Syntax
C#
public static Log Log { get; }


Manager property

BaseVsUnitTestSharedManager.Manager property
Namespaces > ArtOfTest.WebAii.TestTemplates > BaseVsUnitTestSharedManager > Manager
Gets the Manager object.
Syntax
C#
public static Manager Manager { get; }


SetTestMethod(testObject, testMethodName) method

BaseVsUnitTestSharedManager.SetTestMethod(testObject, testMethodName) method
Namespaces > ArtOfTest.WebAii.TestTemplates > BaseVsUnitTestSharedManager > SetTestMethod(Object, String)
Set the TestMethod executing so that WebAii can extract its attributes.
Syntax
C#
public static void SetTestMethod (
    Object testObject,
    string testMethodName
)
Parameters
testObject (Object)
The test object.
testMethodName (String)
The test Method name executing.


VsWriteLineDelegate property

BaseVsUnitTestSharedManager.VsWriteLineDelegate property
Namespaces > ArtOfTest.WebAii.TestTemplates > BaseVsUnitTestSharedManager > VsWriteLineDelegate
Gets/Sets the vsWriteLineDelegate
Syntax
C#
public static TestContextWriteLine VsWriteLineDelegate { get; set; }


Wait property

BaseVsUnitTestSharedManager.Wait property
Namespaces > ArtOfTest.WebAii.TestTemplates > BaseVsUnitTestSharedManager > Wait
Gets a wait object that can be used to wait on specific actions or opertions.
Syntax
C#
public static WaitSync Wait { get; }


TestContextWriteLine delegate

TestContextWriteLine delegate
Namespaces > ArtOfTest.WebAii.TestTemplates > TestContextWriteLine
The VS TestContext WriteLine method delegate.
Syntax
C#
public delegate void TestContextWriteLine (
    string Format,
    params Object[] args
)
Parameters
Format (String)
The format string.
args (Object []())
The arguments.
Remarks
Settings this delegate will allow us to unify the logging with VisualStudio.


ArtOfTest.WebAii.WebServers.AspNetHost Namespace

ArtOfTest.WebAii.WebServers.AspNetHost Namespace
Namespaces > ArtOfTest.WebAii.WebServers.AspNetHost
Syntax
C#
namespace ArtOfTest.WebAii.WebServers.AspNetHost
Types
All Types Classes Structures Interfaces Enumerations Delegates
Icon | Type | Description
public class | AspNetApplication | Represents an ASP.NET Hosted Application
public class | AspNetForm | Class representing an asp.net form. <form id="foo" runat="server" > </form>
public class | AspNetRequest | Represents an Asp.Net Request
public class | AspNetResponse | Asp.Net Response object.


AspNetApplication class

AspNetApplication class
Namespaces > ArtOfTest.WebAii.WebServers.AspNetHost > AspNetApplication
Represents an ASP.NET Hosted Application
Syntax
C#
public sealed class AspNetApplication : MarshalByRefObject
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AspNetApplicationNew(String, String) | Create a new Asp.Net application.
 | Create(Settings) | Create a new AspNetApplication
 | CreateObjRef(Type) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
 | Current | Return current AspNetApplication object.
 | End() | End the AspNet host application.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetLifetimeService() | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
 | GetType() | Gets the Type of the current instance. (Inherited from Object.)
 | InitializeLifetimeService() | Object will live for ever. (Overrides MarshalByRefObject.InitializeLifetimeService().)
 | IsHostRegistered | The host object hosting this application object.
 | LastRequest | Last request processed by this application
 | LastResponse | Last response processed by this application.
 | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
 | ProcessRequest(AspNetRequest) | Process a Request
 | ProcessRequest(String) | Process a request.
 | ToString() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | AspNetApplication


AspNetApplication(virtualPath, physicalPath) constructor

AspNetApplication(virtualPath, physicalPath) constructor
Namespaces > ArtOfTest.WebAii.WebServers.AspNetHost > AspNetApplication > AspNetApplicationNew(String, String)
Create a new Asp.Net application.
Syntax
C#
public AspNetApplication (
    string virtualPath,
    string physicalPath
)
Parameters
virtualPath (String)
virtual path.
physicalPath (String)
physical path.


Create(settings) method

AspNetApplication.Create(settings) method
Namespaces > ArtOfTest.WebAii.WebServers.AspNetHost > AspNetApplication > Create(Settings)
Create a new AspNetApplication
Syntax
C#
public static AspNetApplication Create (
    Settings settings
)
Parameters
settings (Settings)
Settings to use.
Return Value
The newly created application


Current property

AspNetApplication.Current property
Namespaces > ArtOfTest.WebAii.WebServers.AspNetHost > AspNetApplication > Current
Return current AspNetApplication object.
Syntax
C#
public static AspNetApplication Current { get; }


End() method

AspNetApplication.End() method
Namespaces > ArtOfTest.WebAii.WebServers.AspNetHost > AspNetApplication > End()
End the AspNet host application.
Syntax
C#
public static void End ()


InitializeLifetimeService() method

AspNetApplication.InitializeLifetimeService() method
Namespaces > ArtOfTest.WebAii.WebServers.AspNetHost > AspNetApplication > InitializeLifetimeService()
Object will live for ever.
Syntax
C#
public override Object InitializeLifetimeService ()
Return Value


IsHostRegistered property

AspNetApplication.IsHostRegistered property
Namespaces > ArtOfTest.WebAii.WebServers.AspNetHost > AspNetApplication > IsHostRegistered
The host object hosting this application object.
Syntax
C#
public bool IsHostRegistered { get; }


LastRequest property

AspNetApplication.LastRequest property
Namespaces > ArtOfTest.WebAii.WebServers.AspNetHost > AspNetApplication > LastRequest
Last request processed by this application
Syntax
C#
public AspNetRequest LastRequest { get; }


LastResponse property

AspNetApplication.LastResponse property
Namespaces > ArtOfTest.WebAii.WebServers.AspNetHost > AspNetApplication > LastResponse
Last response processed by this application.
Syntax
C#
public AspNetResponse LastResponse { get; }


ProcessRequest methods

AspNetApplication.ProcessRequest methods
Namespaces > ArtOfTest.WebAii.WebServers.AspNetHost > AspNetApplication > ProcessRequest
Members
Icon | Member | Description
 | ProcessRequest(AspNetRequest) | Process a Request
 | ProcessRequest(String) | Process a request.


ProcessRequest(request) method

AspNetApplication.ProcessRequest(request) method
Namespaces > ArtOfTest.WebAii.WebServers.AspNetHost > AspNetApplication > ProcessRequest(AspNetRequest)
Process a Request
Syntax
C#
public AspNetResponse ProcessRequest (
    AspNetRequest request
)
Parameters
request (AspNetRequest)
The request object.
Return Value
The response object.


ProcessRequest(requestPath) method

AspNetApplication.ProcessRequest(requestPath) method
Namespaces > ArtOfTest.WebAii.WebServers.AspNetHost > AspNetApplication > ProcessRequest(String)
Process a request.
Syntax
C#
public AspNetResponse ProcessRequest (
    string requestPath
)
Parameters
requestPath (String)
The request path.
Return Value
The response object.


AspNetForm class

AspNetForm class
Namespaces > ArtOfTest.WebAii.WebServers.AspNetHost > AspNetForm
Class representing an asp.net form. <form id="foo" runat="server" > </form>
Syntax
C#
public class AspNetForm : NameValueCollection
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Action | Gets/Sets the form action.
 | Add(NameValueCollection) | Copies the entries in the specified NameValueCollection to the current NameValueCollection. (Inherited from NameValueCollection.)
 | Add(String, String) | Adds an entry with the specified name and value to the NameValueCollection. (Inherited from NameValueCollection.)
 | AllKeys | Gets all the keys in the NameValueCollection. (Inherited from NameValueCollection.)
 | BaseAdd(String, Object) | Adds an entry with the specified key and value into the NameObjectCollectionBase instance. (Inherited from NameObjectCollectionBase.)
 | BaseClear() | Removes all entries from the NameObjectCollectionBase instance. (Inherited from NameObjectCollectionBase.)
 | BaseGet(Int32) | Gets the value of the entry at the specified index of the NameObjectCollectionBase instance. (Inherited from NameObjectCollectionBase.)
 | BaseGet(String) | Gets the value of the first entry with the specified key from the NameObjectCollectionBase instance. (Inherited from NameObjectCollectionBase.)
 | BaseGetAllKeys() | Returns a String array that contains all the keys in the NameObjectCollectionBase instance. (Inherited from NameObjectCollectionBase.)
 | BaseGetAllValues() | Returns an Object array that contains all the values in the NameObjectCollectionBase instance. (Inherited from NameObjectCollectionBase.)
 | BaseGetAllValues(Type) | Returns an array of the specified type that contains all the values in the NameObjectCollectionBase instance. (Inherited from NameObjectCollectionBase.)
 | BaseGetKey(Int32) | Gets the key of the entry at the specified index of the NameObjectCollectionBase instance. (Inherited from NameObjectCollectionBase.)
 | BaseHasKeys() | Gets a value indicating whether the NameObjectCollectionBase instance contains entries whose keys are not null. (Inherited from NameObjectCollectionBase.)
 | BaseRemove(String) | Removes the entries with the specified key from the NameObjectCollectionBase instance. (Inherited from NameObjectCollectionBase.)
 | BaseRemoveAt(Int32) | Removes the entry at the specified index of the NameObjectCollectionBase instance. (Inherited from NameObjectCollectionBase.)
 | BaseSet(Int32, Object) | Sets the value of the entry at the specified index of the NameObjectCollectionBase instance. (Inherited from NameObjectCollectionBase.)
 | BaseSet(String, Object) | Sets the value of the first entry with the specified key in the NameObjectCollectionBase instance, if found; otherwise, adds an entry with the specified key and value into the NameObjectCollectionBase instance. (Inherited from NameObjectCollectionBase.)
 | Clear() | Invalidates the cached arrays and removes all entries from the NameValueCollection. (Inherited from NameValueCollection.)
 | CopyTo(Array, Int32) | Copies the entire NameValueCollection to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from NameValueCollection.)
 | Count | Gets the number of key/value pairs contained in the NameObjectCollectionBase instance. (Inherited from NameObjectCollectionBase.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GenerateFormPostRequest() | Craft an AspNetRequest to process given this form's fields.
 | Get(Int32) | Gets the values at the specified index of the NameValueCollection combined into one comma-separated list. (Inherited from NameValueCollection.)
 | Get(String) | Gets the values associated with the specified key from the NameValueCollection combined into one comma-separated list. (Inherited from NameValueCollection.)
 | GetEnumerator() | Returns an enumerator that iterates through the NameObjectCollectionBase. (Inherited from NameObjectCollectionBase.)
 | GetHashCode() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetKey(Int32) | Gets the key at the specified index of the NameValueCollection. (Inherited from NameValueCollection.)
 | GetObjectData(SerializationInfo, StreamingContext) | Implements the ISerializable interface and returns the data needed to serialize the NameObjectCollectionBase instance. (Inherited from NameObjectCollectionBase.)
 | GetType() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValues(Int32) | Gets the values at the specified index of the NameValueCollection. (Inherited from NameValueCollection.)
 | GetValues(String) | Gets the values associated with the specified key from the NameValueCollection. (Inherited from NameValueCollection.)
 | HasKeys() | Gets a value indicating whether the NameValueCollection contains keys that are not null. (Inherited from NameValueCollection.)
 | ICollection.System.Collections.ICollection.CopyTo(Array, Int32) | (Inherited from NameObjectCollectionBase.)
 | ICollection.System.Collections.ICollection.IsSynchronized | (Inherited from NameObjectCollectionBase.)
 | ICollection.System.Collections.ICollection.SyncRoot | (Inherited from NameObjectCollectionBase.)
 | InvalidateCachedArrays() | Resets the cached arrays of the collection to null. (Inherited from NameValueCollection.)
 | IsReadOnly | Gets or sets a value indicating whether the NameObjectCollectionBase instance is read-only. (Inherited from NameObjectCollectionBase.)
 | Item(Int32) | Gets the entry at the specified index of the NameValueCollection. (Inherited from NameValueCollection.)
 | Item(String) | Gets or sets the entry with the specified key in the NameValueCollection. (Inherited from NameValueCollection.)
 | Keys | Gets a KeysCollection instance that contains all the keys in the NameObjectCollectionBase instance. (Inherited from NameObjectCollectionBase.)
 | MemberwiseClone() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Method | Gets/Sets the form method.
 | OnDeserialization(Object) | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from NameObjectCollectionBase.)
 | Remove(String) | Removes the entries with the specified key from the NameObjectCollectionBase instance. (Inherited from NameValueCollection.)
 | Set(String, String) | Sets the value of an entry in the NameValueCollection. (Inherited from NameValueCollection.)
 | ToString() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | NameObjectCollectionBase
 |  | NameValueCollection
 |  |  | AspNetForm


Action property

AspNetForm.Action property
Namespaces > ArtOfTest.WebAii.WebServers.AspNetHost > AspNetForm > Action
Gets/Sets the form action.
Syntax
C#
public string Action { get; set; }


GenerateFormPostRequest() method

AspNetForm.GenerateFormPostRequest() method
Namespaces > ArtOfTest.WebAii.WebServers.AspNetHost > AspNetForm > GenerateFormPostRequest()
Craft an AspNetRequest to process given this form's fields.
Syntax
C#
public AspNetRequest GenerateFormPostRequest ()
Return Value
The AspNetRequest object.


Method property

AspNetForm.Method property
Namespaces > ArtOfTest.WebAii.WebServers.AspNetHost > AspNetForm > Method
Gets/Sets the form method.
Syntax
C#
public string Method { get; set; }


AspNetRequest class

AspNetRequest class
Namespaces > ArtOfTest.WebAii.WebServers.AspNetHost > AspNetRequest
Represents an Asp.Net Request
Syntax
C#
public class AspNetRequest
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AspNetRequestNew(String) | Create a new request
 | AspNetRequestNew(String, String, String, String, List<(Of KeyValuePair<(Of String, String>)>), Byte[]()) | Create a new request
 | Body | Gets the body.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | FilePath | Gets the file path portion only of the request without any query strings.
 | Finalize() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FullRequestUrl | Gets the full request url as passed in to this request object.
 | GetHashCode() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType() | Gets the Type of the current instance. (Inherited from Object.)
 | Headers | Gets the headers.
 | MemberwiseClone() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Method | Gets the request method
 | PathInfo | Gets the Path info.
 | QueryString | Gets the query string.
 | ToString() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
AspNetRequest


Body property

AspNetRequest.Body property
Namespaces > ArtOfTest.WebAii.WebServers.AspNetHost > AspNetRequest > Body
Gets the body.
Syntax
C#
public byte[] Body { get; set; }


Constructors

AspNetRequest constructors
Namespaces > ArtOfTest.WebAii.WebServers.AspNetHost > AspNetRequest > AspNetRequestNew
Members
Icon | Member | Description
 | AspNetRequestNew(String) | Create a new request
 | AspNetRequestNew(String, String, String, String, List<(Of KeyValuePair<(Of String, String>)>), Byte[]()) | Create a new request


AspNetRequest(requestFilePath, requestPathInfo, requestQueryString, requestMethod, requestHeaders, requestBody) constructor

AspNetRequest(requestFilePath, requestPathInfo, requestQueryString, requestMethod, requestHeaders, requestBody) constructor
Namespaces > ArtOfTest.WebAii.WebServers.AspNetHost > AspNetRequest > AspNetRequestNew(String, String, String, String, List<(Of KeyValuePair<(Of String, String>)>), Byte[]())
Create a new request
Syntax
C#
public AspNetRequest (
    string requestFilePath,
    string requestPathInfo,
    string requestQueryString,
    string requestMethod,
    List<KeyValuePair<string, string>> requestHeaders,
    byte[] requestBody
)
Parameters
requestFilePath (String)
Full request url.
requestPathInfo (String)
requestQueryString (String)
requestMethod (String)
requestHeaders (List <(Of KeyValuePair <(Of String, String >)>))
requestBody (Byte []())


AspNetRequest(requestPath) constructor

AspNetRequest(requestPath) constructor
Namespaces > ArtOfTest.WebAii.WebServers.AspNetHost > AspNetRequest > AspNetRequestNew(String)
Create a new request
Syntax
C#
public AspNetRequest (
    string requestPath
)
Parameters
requestPath (String)
The request path.


FilePath property

AspNetRequest.FilePath property
Namespaces > ArtOfTest.WebAii.WebServers.AspNetHost > AspNetRequest > FilePath
Gets the file path portion only of the request without any query strings.
Syntax
C#
public string FilePath { get; set; }


FullRequestUrl property

AspNetRequest.FullRequestUrl property
Namespaces > ArtOfTest.WebAii.WebServers.AspNetHost > AspNetRequest > FullRequestUrl
Gets the full request url as passed in to this request object.
Syntax
C#
public string FullRequestUrl { get; }


Headers property

AspNetRequest.Headers property
Namespaces > ArtOfTest.WebAii.WebServers.AspNetHost > AspNetRequest > Headers
Gets the headers.
Syntax
C#
public List<KeyValuePair<string, string>> Headers { get; }


Method property

AspNetRequest.Method property
Namespaces > ArtOfTest.WebAii.WebServers.AspNetHost > AspNetRequest > Method
Gets the request method
Syntax
C#
public string Method { get; set; }


PathInfo property

AspNetRequest.PathInfo property
Namespaces > ArtOfTest.WebAii.WebServers.AspNetHost > AspNetRequest > PathInfo
Gets the Path info.
Syntax
C#
public string PathInfo { get; set; }


QueryString property

AspNetRequest.QueryString property
Namespaces > ArtOfTest.WebAii.WebServers.AspNetHost > AspNetRequest > QueryString
Gets the query string.
Syntax
C#
public string QueryString { get; set; }


AspNetResponse class

AspNetResponse class
Namespaces > ArtOfTest.WebAii.WebServers.AspNetHost > AspNetResponse
Asp.Net Response object.
Syntax
C#
public class AspNetResponse
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Body | Gets the response body as a byte array.
 | BodyAsString | Gets the response body as a string.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType() | Gets the Type of the current instance. (Inherited from Object.)
 | Headers | Gets the response headers.
 | MemberwiseClone() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Status | Gets the response status.
 | ToEntireResponseString() | Returns the entire response as a string including headers, status and body.
 | ToString() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
AspNetResponse


Body property

AspNetResponse.Body property
Namespaces > ArtOfTest.WebAii.WebServers.AspNetHost > AspNetResponse > Body
Gets the response body as a byte array.
Syntax
C#
public byte[] Body { get; }


BodyAsString property

AspNetResponse.BodyAsString property
Namespaces > ArtOfTest.WebAii.WebServers.AspNetHost > AspNetResponse > BodyAsString
Gets the response body as a string.
Syntax
C#
public string BodyAsString { get; }


Headers property

AspNetResponse.Headers property
Namespaces > ArtOfTest.WebAii.WebServers.AspNetHost > AspNetResponse > Headers
Gets the response headers.
Syntax
C#
public List<KeyValuePair<string, string>> Headers { get; }


Status property

AspNetResponse.Status property
Namespaces > ArtOfTest.WebAii.WebServers.AspNetHost > AspNetResponse > Status
Gets the response status.
Syntax
C#
public int Status { get; }


ToEntireResponseString() method

AspNetResponse.ToEntireResponseString() method
Namespaces > ArtOfTest.WebAii.WebServers.AspNetHost > AspNetResponse > ToEntireResponseString()
Returns the entire response as a string including headers, status and body.
Syntax
C#
public string ToEntireResponseString ()
Return Value
The entire response string.


ArtOfTest.WebAii.Win32 Namespace

ArtOfTest.WebAii.Win32 Namespace
Namespaces > ArtOfTest.WebAii.Win32
Syntax
C#
namespace ArtOfTest.WebAii.Win32
Types
All Types Classes Structures Interfaces Enumerations Delegates
Icon | Type | Description
public class | Annotator | Provides annotation support for a browser.
public class | AnnotatorSettings | Class representing all the annotator settings.
public class | Button | Represents a Win32 button on a window or a dialog.
public class | KeyBoard | Keyboard events class.
public class | Mouse | Mouse events class.
public class | Win32Error | Static class used to retrieve last error strings from Win32 calls.
public class | Window | Class representing a Win32 Window.
public class | WindowCollection | A Window object collection.
public class | WindowManager | Provides basic Win32 window management services like searching ...etc.


Annotator class

Annotator class
Namespaces > ArtOfTest.WebAii.Win32 > Annotator
Provides annotation support for a browser.
Syntax
C#
public class Annotator
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AnnotatorNew(Browser) | Create a new annotator with default settings.
 | AnnotatorNew(Browser, AnnotatorSettings) | Create a new annotator object.
 | Annotate(Point, String) | Annotate a single point.
 | Annotate(Rectangle, String) | Annotate and highlight a specific target rectangle on the browser surface with a message to display underneath.
 | Annotate(String) | Annotate a message to the browser. Will use the AnnotateSettings.InfoMessageLocation to place this message on the browser surface.
 | Annotate(String, Int32, OffsetReference) | Annotate a message to the browser
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Settings | Gets/Sets the annotation settings to use. You can use these settings at any point in execution to change how annotation is done.
 | ToString() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
Annotator


Annotate methods

Annotator.Annotate methods
Namespaces > ArtOfTest.WebAii.Win32 > Annotator > Annotate
Members
Icon | Member | Description
 | Annotate(Point, String) | Annotate a single point.
 | Annotate(Rectangle, String) | Annotate and highlight a specific target rectangle on the browser surface with a message to display underneath.
 | Annotate(String) | Annotate a message to the browser. Will use the AnnotateSettings.InfoMessageLocation to place this message on the browser surface.
 | Annotate(String, Int32, OffsetReference) | Annotate a message to the browser


Annotate(message) method

Annotator.Annotate(message) method
Namespaces > ArtOfTest.WebAii.Win32 > Annotator > Annotate(String)
Annotate a message to the browser. Will use the AnnotateSettings.InfoMessageLocation to place this message on the browser surface.
Syntax
C#
public void Annotate (
    string message
)
Parameters
message (String)
The message.


Annotate(message, displayTime, location) method

Annotator.Annotate(message, displayTime, location) method
Namespaces > ArtOfTest.WebAii.Win32 > Annotator > Annotate(String, Int32, OffsetReference)
Annotate a message to the browser
Syntax
C#
public void Annotate (
    string message,
    int displayTime,
    OffsetReference location
)
Parameters
message (String)
The message.
displayTime (Int32)
The display time (msec).
location (OffsetReference)
The display location


Annotate(point, message) method

Annotator.Annotate(point, message) method
Namespaces > ArtOfTest.WebAii.Win32 > Annotator > Annotate(Point, String)
Annotate a single point.
Syntax
C#
public void Annotate (
    Point point,
    string message
)
Parameters
point (Point)
The point.
message (String)
The message


Annotate(targetArea, message) method

Annotator.Annotate(targetArea, message) method
Namespaces > ArtOfTest.WebAii.Win32 > Annotator > Annotate(Rectangle, String)
Annotate and highlight a specific target rectangle on the browser surface with a message to display underneath.
Syntax
C#
public void Annotate (
    Rectangle targetArea,
    string message
)
Parameters
targetArea (Rectangle)
The target area to highlight.
message (String)
The message.


Constructors

Annotator constructors
Namespaces > ArtOfTest.WebAii.Win32 > Annotator > AnnotatorNew
Members
Icon | Member | Description
 | AnnotatorNew(Browser) | Create a new annotator with default settings.
 | AnnotatorNew(Browser, AnnotatorSettings) | Create a new annotator object.


Annotator(browser) constructor

Annotator(browser) constructor
Namespaces > ArtOfTest.WebAii.Win32 > Annotator > AnnotatorNew(Browser)
Create a new annotator with default settings.
Syntax
C#
public Annotator (
    Browser browser
)
Parameters
browser (Browser)
The target browser to annotate.


Annotator(browser, annotationSettings) constructor

Annotator(browser, annotationSettings) constructor
Namespaces > ArtOfTest.WebAii.Win32 > Annotator > AnnotatorNew(Browser, AnnotatorSettings)
Create a new annotator object.
Syntax
C#
public Annotator (
    Browser browser,
    AnnotatorSettings annotationSettings
)
Parameters
browser (Browser)
The target browser to annotate.
annotationSettings (AnnotatorSettings)
The annotation settings.


Settings property

Annotator.Settings property
Namespaces > ArtOfTest.WebAii.Win32 > Annotator > Settings
Gets/Sets the annotation settings to use. You can use these settings at any point in execution to change how annotation is done.
Syntax
C#
public AnnotatorSettings Settings { get; set; }


AnnotatorSettings class

AnnotatorSettings class
Namespaces > ArtOfTest.WebAii.Win32 > AnnotatorSettings
Class representing all the annotator settings.
Syntax
C#
public class AnnotatorSettings
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AnnotatorSettingsNew() | Create a new Annotator settings object. Use default settings.
 | AnnotatorSettingsNew(Color, Single) | Create a new Annotator settings object.
 | AnnotatorSettingsNew(Color, Single, String, Single, FontStyle, Boolean, Color, Int32, Int32, OffsetReference) | Create a new Annotator settings object.
 | BackColor | Gets/Sets the background color for message annotations. Default Yellow.
 | BackColorAlpha | Gets/Sets the background color alpha blending. Default 240.
 | BorderPadding | Gets/Sets the border padding between the border and highlighted element. Default 4.
 | BorderWidth | Gets/Sets the border width that highlights the element. Default 2.
 | Color | Gets/Sets the color to use to draw the annotations. Default Red.
 | CustomDisplayTime | Gets or sets the hang time for custom annotations.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FontemSize | Gets/Sets the font size to use to draw the messages. Default 10.
 | FontFamilyName | The font family name to use to draw the annotation messages. Default Tahoma.
 | FontStyle | Gets/Sets the font style to use to draw the messages. Default Bold.
 | GetHashCode() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType() | Gets the Type of the current instance. (Inherited from Object.)
 | InfoMessageLocation | Gets/Sets the info message location in reference to the window. Default TopCenter.
 | MemberwiseClone() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ShowAnnotationMessage | Gets/Sets whether to show message annotation in addition to highlighting the target elements.
 | ToString() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
AnnotatorSettings


BackColor property

AnnotatorSettings.BackColor property
Namespaces > ArtOfTest.WebAii.Win32 > AnnotatorSettings > BackColor
Gets/Sets the background color for message annotations. Default Yellow.
Syntax
C#
public Color BackColor { get; set; }


BackColorAlpha property

AnnotatorSettings.BackColorAlpha property
Namespaces > ArtOfTest.WebAii.Win32 > AnnotatorSettings > BackColorAlpha
Gets/Sets the background color alpha blending. Default 240.
Syntax
C#
public int BackColorAlpha { get; set; }


BorderPadding property

AnnotatorSettings.BorderPadding property
Namespaces > ArtOfTest.WebAii.Win32 > AnnotatorSettings > BorderPadding
Gets/Sets the border padding between the border and highlighted element. Default 4.
Syntax
C#
public int BorderPadding { get; set; }


BorderWidth property

AnnotatorSettings.BorderWidth property
Namespaces > ArtOfTest.WebAii.Win32 > AnnotatorSettings > BorderWidth
Gets/Sets the border width that highlights the element. Default 2.
Syntax
C#
public float BorderWidth { get; set; }


Color property

AnnotatorSettings.Color property
Namespaces > ArtOfTest.WebAii.Win32 > AnnotatorSettings > Color
Gets/Sets the color to use to draw the annotations. Default Red.
Syntax
C#
public Color Color { get; set; }


Constructors

AnnotatorSettings constructors
Namespaces > ArtOfTest.WebAii.Win32 > AnnotatorSettings > AnnotatorSettingsNew
Members
Icon | Member | Description
 | AnnotatorSettingsNew() | Create a new Annotator settings object. Use default settings.
 | AnnotatorSettingsNew(Color, Single) | Create a new Annotator settings object.
 | AnnotatorSettingsNew(Color, Single, String, Single, FontStyle, Boolean, Color, Int32, Int32, OffsetReference) | Create a new Annotator settings object.


AnnotatorSettings() constructor

AnnotatorSettings() constructor
Namespaces > ArtOfTest.WebAii.Win32 > AnnotatorSettings > AnnotatorSettingsNew()
Create a new Annotator settings object. Use default settings.
Syntax
C#
public AnnotatorSettings ()


AnnotatorSettings(color, borderWidth) constructor

AnnotatorSettings(color, borderWidth) constructor
Namespaces > ArtOfTest.WebAii.Win32 > AnnotatorSettings > AnnotatorSettingsNew(Color, Single)
Create a new Annotator settings object.
Syntax
C#
public AnnotatorSettings (
    Color color,
    float borderWidth
)
Parameters
color (Color)
The color to use.
borderWidth (Single)
The border width to use.


AnnotatorSettings(color, borderWidth, fontFamilyName, fontemSize, fontStyle, ShowAnnotationMessage, backgroundColor, backgroundAlpha, borderPadding, infoLocation) constructor

AnnotatorSettings(color, borderWidth, fontFamilyName, fontemSize, fontStyle, ShowAnnotationMessage, backgroundColor, backgroundAlpha, borderPadding, infoLocation) constructor
Namespaces > ArtOfTest.WebAii.Win32 > AnnotatorSettings > AnnotatorSettingsNew(Color, Single, String, Single, FontStyle, Boolean, Color, Int32, Int32, OffsetReference)
Create a new Annotator settings object.
Syntax
C#
public AnnotatorSettings (
    Color color,
    float borderWidth,
    string fontFamilyName,
    float fontemSize,
    FontStyle fontStyle,
    bool ShowAnnotationMessage,
    Color backgroundColor,
    int backgroundAlpha,
    int borderPadding,
    OffsetReference infoLocation
)
Parameters
color (Color)
The color to use.
borderWidth (Single)
The border width to use.
fontFamilyName (String)
The font to use to draw messages.
fontemSize (Single)
The font size to use.
fontStyle (FontStyle)
The font style to use.
ShowAnnotationMessage (Boolean)
Whether to show annotation messages or not.
backgroundColor (Color)
The background color of text annotations.
backgroundAlpha (Int32)
The background alpha blending 0-255.
borderPadding (Int32)
The padding between the highlight border and the element.
infoLocation (OffsetReference)
The location where to place text annotations.


CustomDisplayTime property

AnnotatorSettings.CustomDisplayTime property
Namespaces > ArtOfTest.WebAii.Win32 > AnnotatorSettings > CustomDisplayTime
Gets or sets the hang time for custom annotations.
Syntax
C#
public int CustomDisplayTime { get; set; }


FontemSize property

AnnotatorSettings.FontemSize property
Namespaces > ArtOfTest.WebAii.Win32 > AnnotatorSettings > FontemSize
Gets/Sets the font size to use to draw the messages. Default 10.
Syntax
C#
public float FontemSize { get; set; }


FontFamilyName property

AnnotatorSettings.FontFamilyName property
Namespaces > ArtOfTest.WebAii.Win32 > AnnotatorSettings > FontFamilyName
The font family name to use to draw the annotation messages. Default Tahoma.
Syntax
C#
public string FontFamilyName { get; set; }


FontStyle property

AnnotatorSettings.FontStyle property
Namespaces > ArtOfTest.WebAii.Win32 > AnnotatorSettings > FontStyle
Gets/Sets the font style to use to draw the messages. Default Bold.
Syntax
C#
public FontStyle FontStyle { get; set; }


InfoMessageLocation property

AnnotatorSettings.InfoMessageLocation property
Namespaces > ArtOfTest.WebAii.Win32 > AnnotatorSettings > InfoMessageLocation
Gets/Sets the info message location in reference to the window. Default TopCenter.
Syntax
C#
public OffsetReference InfoMessageLocation { get; set; }


ShowAnnotationMessage property

AnnotatorSettings.ShowAnnotationMessage property
Namespaces > ArtOfTest.WebAii.Win32 > AnnotatorSettings > ShowAnnotationMessage
Gets/Sets whether to show message annotation in addition to highlighting the target elements.
Syntax
C#
public bool ShowAnnotationMessage { get; set; }


Button class

Button class
Namespaces > ArtOfTest.WebAii.Win32 > Button
Represents a Win32 button on a window or a dialog.
Syntax
C#
public class Button : Window
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ButtonNew(IntPtr, Int32) | Create a new button using its parent and its button id.
 | ButtonNew(IntPtr, String, Boolean) | Create a new button using a parent window and the button caption. Can use partial caption.
 | ButtonNew(Window, Int32) | Create a new button using the button id
 | ButtonNew(Window, String, Boolean) | Create a new button using a button text and parent window.
 | Caption | Gets the window's caption. (Inherited from Window.)
 | ClassName | Gets the window's class name. (Inherited from Window.)
 | Click() | Click this button
 | Close() | Close the window. (Inherited from Window.)
 | Enabled | Gets whether this window is enabled or not. (Inherited from Window.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetBitmap(Rectangle) | Returns a bitmap of a specified target area within this window. (Inherited from Window.)
 | GetHashCode() | The hash code is the window's hwnd. (Inherited from Window.)
 | GetType() | Gets the Type of the current instance. (Inherited from Object.)
 | Handle | Gets the handle of the window. (Inherited from Window.)
 | Hide() | Hide the window. (Inherited from Window.)
 | IsMaximized | Gets whether the window is maximized. (Inherited from Window.)
 | IsMinimized | Gets whether the window is minimized. (Inherited from Window.)
 | IsVisible | Gets whether the window is visible. (Inherited from Window.)
 | Location | Gets the top left point of the location of the window relative to the screen. (Inherited from Window.)
 | MakeRelative(Rectangle) | Make the absolute rects passed in relative to this window. (Inherited from Window.)
 | Maximize() | Maximize the window (Inherited from Window.)
 | MemberwiseClone() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Minimize() | Minimize the window. (Inherited from Window.)
 | Move(Rectangle, Boolean) | Move this window to a new location (Inherited from Window.)
 | OwnerProcess | The owner process that created this window. (Inherited from Window.)
 | Rectangle | Gets the rectangle of the window. (Inherited from Window.)
 | SetActive() | Set this window to active. (Inherited from Window.)
 | SetFocus() | Restores and Brings the window to the front, assuming it is a visible application window. (Inherited from Window.)
 | Show() | Show this window and make it visible (Inherited from Window.)
 | Size | Gets the size of the window. (Inherited from Window.)
 | ToString() | Returns a String that represents the current Object. (Inherited from Object.)
 | Update() | Update the window. Invalidates all areas and forces a redraw. (Inherited from Window.)
 | WaitForVisibility(Boolean, Int32) | Waits for a certain visibility state for a window (Inherited from Window.)
 | WaitForVisibility(Boolean, Int32, Boolean) | Waits for a certain visibility state for a window (Inherited from Window.)
Inheritance Hierarchy
Object
 | Window
 |  | Button


Click() method

Button.Click() method
Namespaces > ArtOfTest.WebAii.Win32 > Button > Click()
Click this button
Syntax
C#
public void Click ()


Constructors

Button constructors
Namespaces > ArtOfTest.WebAii.Win32 > Button > ButtonNew
Members
Icon | Member | Description
 | ButtonNew(Window, Int32) | Create a new button using the button id
 | ButtonNew(Window, String, Boolean) | Create a new button using a button text and parent window.
 | ButtonNew(IntPtr, Int32) | Create a new button using its parent and its button id.
 | ButtonNew(IntPtr, String, Boolean) | Create a new button using a parent window and the button caption. Can use partial caption.


Button(parentWindow, buttonCaption, isPartial) constructor

Button(parentWindow, buttonCaption, isPartial) constructor
Namespaces > ArtOfTest.WebAii.Win32 > Button > ButtonNew(Window, String, Boolean)
Create a new button using a button text and parent window.
Syntax
C#
public Button (
    Window parentWindow,
    string buttonCaption,
    bool isPartial
)
Parameters
parentWindow (Window)
The parent window object.
buttonCaption (String)
The button caption.
isPartial (Boolean)
True/False whether using a partial caption.


Button(parentWindow, buttonCaption, isPartial) constructor

Button(parentWindow, buttonCaption, isPartial) constructor
Namespaces > ArtOfTest.WebAii.Win32 > Button > ButtonNew(IntPtr, String, Boolean)
Create a new button using a parent window and the button caption. Can use partial caption.
Syntax
C#
public Button (
    IntPtr parentWindow,
    string buttonCaption,
    bool isPartial
)
Parameters
parentWindow (IntPtr)
The parent window that contains the button.
buttonCaption (String)
The button caption.
isPartial (Boolean)
True/False whether the caption is partial.


Button(parentWindow, buttonId) constructor

Button(parentWindow, buttonId) constructor
Namespaces > ArtOfTest.WebAii.Win32 > Button > ButtonNew(IntPtr, Int32)
Create a new button using its parent and its button id.
Syntax
C#
public Button (
    IntPtr parentWindow,
    int buttonId
)
Parameters
parentWindow (IntPtr)
The parent window.
buttonId (Int32)
The button id.


Button(parentWindow, buttonId) constructor

Button(parentWindow, buttonId) constructor
Namespaces > ArtOfTest.WebAii.Win32 > Button > ButtonNew(Window, Int32)
Create a new button using the button id
Syntax
C#
public Button (
    Window parentWindow,
    int buttonId
)
Parameters
parentWindow (Window)
The parent window object.
buttonId (Int32)
The button id.


KeyBoard class

KeyBoard class
Namespaces > ArtOfTest.WebAii.Win32 > KeyBoard
Keyboard events class.
Syntax
C#
public class KeyBoard
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | KeyBoardNew(Desktop) | Create a new keyboard object.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType() | Gets the Type of the current instance. (Inherited from Object.)
 | KeyDown(Keys) | Simulates a key down. (Press-Hold)
 | KeyPress(Keys) | Simulates a keyboard key press (down/up).
 | KeyPress(Keys, Int32) | Simulates a keyboard key press with a hold delay.
 | KeyUp(Keys) | Simulates a key up. (Key-Release)
 | MemberwiseClone() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | SendString(String) | Sends a string to the active application using SendKeys
 | ToString() | Returns a String that represents the current Object. (Inherited from Object.)
 | TypeText(String, Int32) | Types text one character at a time with a specific type speed. This function does not support special keywords (i.e {TAB}, {SPACE}) or special characters like ^,+..etc. to simulate special keys use SendString if you want to send special characters like Ctrl/Shift..etc.
Inheritance Hierarchy
Object
KeyBoard


KeyBoard(desktop) constructor

KeyBoard(desktop) constructor
Namespaces > ArtOfTest.WebAii.Win32 > KeyBoard > KeyBoardNew(Desktop)
Create a new keyboard object.
Syntax
C#
public KeyBoard (
    Desktop desktop
)
Parameters
desktop (Desktop)


KeyDown(code) method

KeyBoard.KeyDown(code) method
Namespaces > ArtOfTest.WebAii.Win32 > KeyBoard > KeyDown(Keys)
Simulates a key down. (Press-Hold)
Syntax
C#
public void KeyDown (
    Keys code
)
Parameters
code (Keys)
The key code


KeyPress methods

KeyBoard.KeyPress methods
Namespaces > ArtOfTest.WebAii.Win32 > KeyBoard > KeyPress
Members
Icon | Member | Description
 | KeyPress(Keys) | Simulates a keyboard key press (down/up).
 | KeyPress(Keys, Int32) | Simulates a keyboard key press with a hold delay.


KeyPress(code) method

KeyBoard.KeyPress(code) method
Namespaces > ArtOfTest.WebAii.Win32 > KeyBoard > KeyPress(Keys)
Simulates a keyboard key press (down/up).
Syntax
C#
public void KeyPress (
    Keys code
)
Parameters
code (Keys)
The key code


KeyPress(code, holdFor) method

KeyBoard.KeyPress(code, holdFor) method
Namespaces > ArtOfTest.WebAii.Win32 > KeyBoard > KeyPress(Keys, Int32)
Simulates a keyboard key press with a hold delay.
Syntax
C#
public void KeyPress (
    Keys code,
    int holdFor
)
Parameters
code (Keys)
The key code
holdFor (Int32)
The length of the key hold in msec.


KeyUp(code) method

KeyBoard.KeyUp(code) method
Namespaces > ArtOfTest.WebAii.Win32 > KeyBoard > KeyUp(Keys)
Simulates a key up. (Key-Release)
Syntax
C#
public void KeyUp (
    Keys code
)
Parameters
code (Keys)
The key code


SendString(text) method

KeyBoard.SendString(text) method
Namespaces > ArtOfTest.WebAii.Win32 > KeyBoard > SendString(String)
Sends a string to the active application using SendKeys
Syntax
C#
public void SendString (
    string text
)
Parameters
text (String)
The string to send


TypeText(text, keyPressTime) method

KeyBoard.TypeText(text, keyPressTime) method
Namespaces > ArtOfTest.WebAii.Win32 > KeyBoard > TypeText(String, Int32)
Types text one character at a time with a specific type speed. This function does not support special keywords (i.e {TAB}, {SPACE}) or special characters like ^,+..etc. to simulate special keys use SendString if you want to send special characters like Ctrl/Shift..etc.
Syntax
C#
public void TypeText (
    string text,
    int keyPressTime
)
Parameters
text (String)
The text to type
keyPressTime (Int32)
The delay time between key presses.


Mouse class

Mouse class
Namespaces > ArtOfTest.WebAii.Win32 > Mouse
Mouse events class.
Syntax
C#
public class Mouse
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CalculateOffset(Rectangle, Point, OffsetReference) | Calculates the offset from the rectangles given a reference.
 | Click(MouseClickType, Int32, Int32) | Simulate a mouse event.
 | Click(MouseClickType, Point) | Simulate a mouse event (Target as a point object)
 | Click(MouseClickType, Rectangle) | Simulate a mouse event (Target a rectangle). Will click absolute center of target rectangle.
 | Click(MouseClickType, Rectangle, Point, OffsetReference) | Simulate a mouse event (Target as a rectangle with offset)
 | DragDrop(Int32, Int32, Int32, Int32) | Simluates a mouse drag and drop.
 | DragDrop(Int32, Int32, Int32, Int32, Int32, Int32) | Simluates a mouse drag and drop.
 | DragDrop(Point, Point) | Simulate a mouse drag and drop.
 | DragDrop(Point, Point, Int32, Int32) | Simulate a mouse drag and drop.
 | DragDrop(Rectangle, Int32, Int32, OffsetReference, Rectangle, Int32, Int32, OffsetReference) | Simulate a mouse drag and drop.
 | DragDrop(Rectangle, Int32, Int32, OffsetReference, Rectangle, Int32, Int32, OffsetReference, Int32, Int32) | Simulate a mouse drag and drop.
 | DragDrop(Rectangle, Point, OffsetReference, Rectangle, Point, OffsetReference) | Simulate a mouse drag and drop.
 | DragDrop(Rectangle, Point, OffsetReference, Rectangle, Point, OffsetReference, Int32, Int32) | Simulate a mouse drag and drop.
 | DragDrop(Rectangle, Rectangle) | Simulate a mouse drag and drop. (Uses center point of each rectangle)
 | DragDrop(Rectangle, Rectangle, Int32, Int32) | Simulate a mouse drag and drop. (Uses center point of each rectangle)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetDistance(Point, Point) | Gets the number of mouse move intervals depending on the current set speed and interval time. Any negative coordinates will be reset to zero automatically.
 | GetHashCode() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetRelativeNumOfMouseMoveIntervals(Int32) | Gets the number of mouse move intervals depending on the current set speed and interval time. DistanceInPixels(pixels) = NumOfIntervals(const) * IntervalTime(msec) * Speed(pixels/msec)
 | GetRelativeNumOfMouseMoveIntervals(Point, Point) | Gets the number of mouse move intervals depending on the current set speed and interval time.
 | GetRelativeNumOfMouseMoveIntervals(Rectangle, Point, OffsetReference, Rectangle, Point, OffsetReference) | Returns the relative number of mouse move intervals given a start/end locations.
 | GetRelativeNumOfMouseMoveIntervals(Rectangle, Rectangle) | Gets the number of mouse move intervals depending on the current set speed and interval time. Uses the absolute centers of passed in rectangles.
 | GetType() | Gets the Type of the current instance. (Inherited from Object.)
 | HoverOver(Int32, Int32) | Simulates a mouse hover over. Simply moves the mouse pointer over the X,Y passed in. Can also be used to move the mouse to a certain location.
 | HoverOver(Point) | HoverOver (Target a point).
 | HoverOver(Rectangle) | Hover over (Target the center of the target rectangle).
 | HoverOver(Rectangle, Point, OffsetReference) | Hover over (Target is a rectangle with an offset).
 | MemberwiseClone() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MouseMoveIntervalTime | Gets/Sets the mouse interval time between mouse move intervals. The default is set at 15msec. Typically you don't need to change this. If you want to configure the speed of the mouse move, use the Settings.SimulatedMouseMoveSpeed.
 | Move(Int32, Int32, Int32, Int32) | Move the mouse from the start to the end location
 | Move(Int32, Int32, Int32, Int32, Int32, Int32) | Move the mouse from the start to the end location
 | Move(Point, Point) | Move the mouse from the start to the end location
 | Move(Point, Point, Int32, Int32) | Move the mouse from the start to the end location
 | Move(Rectangle, Int32, Int32, OffsetReference, Rectangle, Int32, Int32, OffsetReference) | Move the mouse from the start to the end location
 | Move(Rectangle, Int32, Int32, OffsetReference, Rectangle, Int32, Int32, OffsetReference, Int32, Int32) | Move the mouse from the start to the end location
 | Move(Rectangle, Point, OffsetReference, Rectangle, Point, OffsetReference) | Move the mouse from the start to the end location
 | Move(Rectangle, Point, OffsetReference, Rectangle, Point, OffsetReference, Int32, Int32) | Move the mouse from the start to the end location
 | Move(Rectangle, Rectangle) | Move the mouse from the start to the end location
 | Move(Rectangle, Rectangle, Int32, Int32) | Move the mouse from the start to the end location
 | ToString() | Returns a String that represents the current Object. (Inherited from Object.)
 | TurnWheel(Int32, MouseWheelTurnDirection) | Move the mouse wheel by a certain delta
 | ValidateNonNegativePoint(Point) | Validate that the point coordinates i non-negative. if not, will reset to zero.
Inheritance Hierarchy
Object
Mouse


CalculateOffset(rectangle, offset, reference) method

Mouse.CalculateOffset(rectangle, offset, reference) method
Namespaces > ArtOfTest.WebAii.Win32 > Mouse > CalculateOffset(Rectangle, Point, OffsetReference)
Calculates the offset from the rectangles given a reference.
Syntax
C#
public static Point CalculateOffset (
    Rectangle rectangle,
    Point offset,
    OffsetReference reference
)
Parameters
rectangle (Rectangle)
The rectangle.
offset (Point)
The offset.
reference (OffsetReference)
The offset reference type.
Return Value
The adjusted point.


Click methods

Mouse.Click methods
Namespaces > ArtOfTest.WebAii.Win32 > Mouse > Click
Members
Icon | Member | Description
 | Click(MouseClickType, Point) | Simulate a mouse event (Target as a point object)
 | Click(MouseClickType, Rectangle) | Simulate a mouse event (Target a rectangle). Will click absolute center of target rectangle.
 | Click(MouseClickType, Rectangle, Point, OffsetReference) | Simulate a mouse event (Target as a rectangle with offset)
 | Click(MouseClickType, Int32, Int32) | Simulate a mouse event.


Click(clickType, pointToClick) method

Mouse.Click(clickType, pointToClick) method
Namespaces > ArtOfTest.WebAii.Win32 > Mouse > Click(MouseClickType, Point)
Simulate a mouse event (Target as a point object)
Syntax
C#
public void Click (
    MouseClickType clickType,
    Point pointToClick
)
Parameters
clickType (MouseClickType)
The type of the click mouse to simulate.
pointToClick (Point)
The point to click.


Click(clickType, target) method

Mouse.Click(clickType, target) method
Namespaces > ArtOfTest.WebAii.Win32 > Mouse > Click(MouseClickType, Rectangle)
Simulate a mouse event (Target a rectangle). Will click absolute center of target rectangle.
Syntax
C#
public void Click (
    MouseClickType clickType,
    Rectangle target
)
Parameters
clickType (MouseClickType)
The type of the click mouse to simulate.
target (Rectangle)
The target rectangle to click the center for.


Click(clickType, target, offset, reference) method

Mouse.Click(clickType, target, offset, reference) method
Namespaces > ArtOfTest.WebAii.Win32 > Mouse > Click(MouseClickType, Rectangle, Point, OffsetReference)
Simulate a mouse event (Target as a rectangle with offset)
Syntax
C#
public void Click (
    MouseClickType clickType,
    Rectangle target,
    Point offset,
    OffsetReference reference
)
Parameters
clickType (MouseClickType)
The type of the click mouse to simulate.
target (Rectangle)
The target rectangle.
offset (Point)
The offset in X/Y (negatives represents opposite direction).
Remarks
For offset: Positive X : Represents the right direction. Negative X : Represents the left direction. Positive Y : Represents the down direction. Negative Y : Represents the up direction. Keep these in mind when calculating the offset from a reference point.
reference (OffsetReference)
The reference point to offset within the rectangle.


Click(clickType, x, y) method

Mouse.Click(clickType, x, y) method
Namespaces > ArtOfTest.WebAii.Win32 > Mouse > Click(MouseClickType, Int32, Int32)
Simulate a mouse event.
Syntax
C#
public void Click (
    MouseClickType clickType,
    int x,
    int y
)
Parameters
clickType (MouseClickType)
The type of the click mouse to simulate.
x (Int32)
Absolute X coordinate to click on.
y (Int32)
Absolute Y coordinate to click on.


DragDrop methods

Mouse.DragDrop methods
Namespaces > ArtOfTest.WebAii.Win32 > Mouse > DragDrop
Members
Icon | Member | Description
 | DragDrop(Point, Point) | Simulate a mouse drag and drop.
 | DragDrop(Point, Point, Int32, Int32) | Simulate a mouse drag and drop.
 | DragDrop(Rectangle, Point, OffsetReference, Rectangle, Point, OffsetReference) | Simulate a mouse drag and drop.
 | DragDrop(Rectangle, Point, OffsetReference, Rectangle, Point, OffsetReference, Int32, Int32) | Simulate a mouse drag and drop.
 | DragDrop(Rectangle, Rectangle) | Simulate a mouse drag and drop. (Uses center point of each rectangle)
 | DragDrop(Rectangle, Rectangle, Int32, Int32) | Simulate a mouse drag and drop. (Uses center point of each rectangle)
 | DragDrop(Rectangle, Int32, Int32, OffsetReference, Rectangle, Int32, Int32, OffsetReference) | Simulate a mouse drag and drop.
 | DragDrop(Rectangle, Int32, Int32, OffsetReference, Rectangle, Int32, Int32, OffsetReference, Int32, Int32) | Simulate a mouse drag and drop.
 | DragDrop(Int32, Int32, Int32, Int32) | Simluates a mouse drag and drop.
 | DragDrop(Int32, Int32, Int32, Int32, Int32, Int32) | Simluates a mouse drag and drop.


DragDrop(startTarget, endTarget, intervals, intervalDelay) method

Mouse.DragDrop(startTarget, endTarget, intervals, intervalDelay) method
Namespaces > ArtOfTest.WebAii.Win32 > Mouse > DragDrop(Rectangle, Rectangle, Int32, Int32)
Simulate a mouse drag and drop. (Uses center point of each rectangle)
Syntax
C#
public void DragDrop (
    Rectangle startTarget,
    Rectangle endTarget,
    int intervals,
    int intervalDelay
)
Parameters
startTarget (Rectangle)
Start target.
endTarget (Rectangle)
End target.
intervals (Int32)
Number of intervals for this dragdrop operation.
intervalDelay (Int32)
The delay in msec. between each interval.


DragDrop(startTarget, startOffsetX, startOffsetY, startReference, endTarget, endOffsetX, endOffsetY, endReference) method

Mouse.DragDrop(startTarget, startOffsetX, startOffsetY, startReference, endTarget, endOffsetX, endOffsetY, endReference) method
Namespaces > ArtOfTest.WebAii.Win32 > Mouse > DragDrop(Rectangle, Int32, Int32, OffsetReference, Rectangle, Int32, Int32, OffsetReference)
Simulate a mouse drag and drop.
Syntax
C#
public void DragDrop (
    Rectangle startTarget,
    int startOffsetX,
    int startOffsetY,
    OffsetReference startReference,
    Rectangle endTarget,
    int endOffsetX,
    int endOffsetY,
    OffsetReference endReference
)
Parameters
startTarget (Rectangle)
The start rectangle.
startOffsetX (Int32)
The x start offset.
startOffsetY (Int32)
The y start offset.
startReference (OffsetReference)
The start offset reference.
endTarget (Rectangle)
The end rectangle.
endOffsetX (Int32)
The x end offset.
endOffsetY (Int32)
The y end offset.
endReference (OffsetReference)
The end offset reference.


DragDrop(startTarget, startOffsetX, startOffsetY, startReference, endTarget, endOffsetX, endOffsetY, endReference, intervals, intervalDelay) method

Mouse.DragDrop(startTarget, startOffsetX, startOffsetY, startReference, endTarget, endOffsetX, endOffsetY, endReference, intervals, intervalDelay) method
Namespaces > ArtOfTest.WebAii.Win32 > Mouse > DragDrop(Rectangle, Int32, Int32, OffsetReference, Rectangle, Int32, Int32, OffsetReference, Int32, Int32)
Simulate a mouse drag and drop.
Syntax
C#
public void DragDrop (
    Rectangle startTarget,
    int startOffsetX,
    int startOffsetY,
    OffsetReference startReference,
    Rectangle endTarget,
    int endOffsetX,
    int endOffsetY,
    OffsetReference endReference,
    int intervals,
    int intervalDelay
)
Parameters
startTarget (Rectangle)
The start rectangle.
startOffsetX (Int32)
The x start offset.
startOffsetY (Int32)
The y start offset.
startReference (OffsetReference)
The start offset reference.
endTarget (Rectangle)
The end rectangle.
endOffsetX (Int32)
The x end offset.
endOffsetY (Int32)
The y end offset.
endReference (OffsetReference)
The end offset reference.
intervals (Int32)
Number of intervals for this dragdrop operation.
intervalDelay (Int32)
The delay in msec. between each interval.


DragDrop(startTarget, startOffset, startReference, endTarget, endOffset, endReference) method

Mouse.DragDrop(startTarget, startOffset, startReference, endTarget, endOffset, endReference) method
Namespaces > ArtOfTest.WebAii.Win32 > Mouse > DragDrop(Rectangle, Point, OffsetReference, Rectangle, Point, OffsetReference)
Simulate a mouse drag and drop.
Syntax
C#
public void DragDrop (
    Rectangle startTarget,
    Point startOffset,
    OffsetReference startReference,
    Rectangle endTarget,
    Point endOffset,
    OffsetReference endReference
)
Parameters
startTarget (Rectangle)
The start rectangle.
startOffset (Point)
The start offset.
startReference (OffsetReference)
The start offset reference.
endTarget (Rectangle)
The end rectangle.
endOffset (Point)
The end offset.
endReference (OffsetReference)
The end offset reference.


DragDrop(startTarget, startOffset, startReference, endTarget, endOffset, endReference, intervals, intervalDelay) method

Mouse.DragDrop(startTarget, startOffset, startReference, endTarget, endOffset, endReference, intervals, intervalDelay) method
Namespaces > ArtOfTest.WebAii.Win32 > Mouse > DragDrop(Rectangle, Point, OffsetReference, Rectangle, Point, OffsetReference, Int32, Int32)
Simulate a mouse drag and drop.
Syntax
C#
public void DragDrop (
    Rectangle startTarget,
    Point startOffset,
    OffsetReference startReference,
    Rectangle endTarget,
    Point endOffset,
    OffsetReference endReference,
    int intervals,
    int intervalDelay
)
Parameters
startTarget (Rectangle)
The start rectangle.
startOffset (Point)
The start offset.
startReference (OffsetReference)
The start offset reference.
endTarget (Rectangle)
The end rectangle.
endOffset (Point)
The end offset.
endReference (OffsetReference)
The end offset reference.
intervals (Int32)
Number of intervals for this dragdrop operation.
intervalDelay (Int32)
The delay in msec. between each interval.


DragDrop(startX, startY, endX, endY) method

Mouse.DragDrop(startX, startY, endX, endY) method
Namespaces > ArtOfTest.WebAii.Win32 > Mouse > DragDrop(Int32, Int32, Int32, Int32)
Simluates a mouse drag and drop.
Syntax
C#
public void DragDrop (
    int startX,
    int startY,
    int endX,
    int endY
)
Parameters
startX (Int32)
Absolute X coordinate to start the drag.
startY (Int32)
Absolute Y coordinate to start the drag.
endX (Int32)
Absolute X coordinate to do the drop.
endY (Int32)
Absolute Y coordinate to do the drop.


DragDrop(startX, startY, endX, endY, intervals, intervalDelay) method

Mouse.DragDrop(startX, startY, endX, endY, intervals, intervalDelay) method
Namespaces > ArtOfTest.WebAii.Win32 > Mouse > DragDrop(Int32, Int32, Int32, Int32, Int32, Int32)
Simluates a mouse drag and drop.
Syntax
C#
public void DragDrop (
    int startX,
    int startY,
    int endX,
    int endY,
    int intervals,
    int intervalDelay
)
Parameters
startX (Int32)
Absolute X coordinate to start the drag.
startY (Int32)
Absolute Y coordinate to start the drag.
endX (Int32)
Absolute X coordinate to do the drop.
endY (Int32)
Absolute Y coordinate to do the drop.
intervals (Int32)
Number of intervals for this DragDrop operation.
intervalDelay (Int32)
The delay in msec. between each interval.


DragDrop(start, end) method

Mouse.DragDrop(start, end) method
Namespaces > ArtOfTest.WebAii.Win32 > Mouse > DragDrop(Rectangle, Rectangle)
Simulate a mouse drag and drop. (Uses center point of each rectangle)
Syntax
C#
public void DragDrop (
    Rectangle start,
    Rectangle end
)
Parameters
start (Rectangle)
Start target.
end (Rectangle)
End target.


DragDrop(start, end) method

Mouse.DragDrop(start, end) method
Namespaces > ArtOfTest.WebAii.Win32 > Mouse > DragDrop(Point, Point)
Simulate a mouse drag and drop.
Syntax
C#
public void DragDrop (
    Point start,
    Point end
)
Parameters
start (Point)
The start drag point.
end (Point)
The end drop point.


DragDrop(start, end, intervals, intervalDelay) method

Mouse.DragDrop(start, end, intervals, intervalDelay) method
Namespaces > ArtOfTest.WebAii.Win32 > Mouse > DragDrop(Point, Point, Int32, Int32)
Simulate a mouse drag and drop.
Syntax
C#
public void DragDrop (
    Point start,
    Point end,
    int intervals,
    int intervalDelay
)
Parameters
start (Point)
The start drag point.
end (Point)
The end drop point.
intervals (Int32)
Number of intervals for this dragdrop operation.
intervalDelay (Int32)
The delay in msec. between each interval.


GetDistance(start, end) method

Mouse.GetDistance(start, end) method
Namespaces > ArtOfTest.WebAii.Win32 > Mouse > GetDistance(Point, Point)
Gets the number of mouse move intervals depending on the current set speed and interval time. Any negative coordinates will be reset to zero automatically.
Syntax
C#
protected float GetDistance (
    Point start,
    Point end
)
Parameters
start (Point)
The start point.
end (Point)
The end point.
Return Value
The distance.


GetRelativeNumOfMouseMoveIntervals methods

Mouse.GetRelativeNumOfMouseMoveIntervals methods
Namespaces > ArtOfTest.WebAii.Win32 > Mouse > GetRelativeNumOfMouseMoveIntervals
Members
Icon | Member | Description
 | GetRelativeNumOfMouseMoveIntervals(Point, Point) | Gets the number of mouse move intervals depending on the current set speed and interval time.
 | GetRelativeNumOfMouseMoveIntervals(Rectangle, Point, OffsetReference, Rectangle, Point, OffsetReference) | Returns the relative number of mouse move intervals given a start/end locations.
 | GetRelativeNumOfMouseMoveIntervals(Rectangle, Rectangle) | Gets the number of mouse move intervals depending on the current set speed and interval time. Uses the absolute centers of passed in rectangles.
 | GetRelativeNumOfMouseMoveIntervals(Int32) | Gets the number of mouse move intervals depending on the current set speed and interval time. DistanceInPixels(pixels) = NumOfIntervals(const) * IntervalTime(msec) * Speed(pixels/msec)


GetRelativeNumOfMouseMoveIntervals(distanceInPixels) method

Mouse.GetRelativeNumOfMouseMoveIntervals(distanceInPixels) method
Namespaces > ArtOfTest.WebAii.Win32 > Mouse > GetRelativeNumOfMouseMoveIntervals(Int32)
Gets the number of mouse move intervals depending on the current set speed and interval time. DistanceInPixels(pixels) = NumOfIntervals(const) * IntervalTime(msec) * Speed(pixels/msec)
Syntax
C#
protected int GetRelativeNumOfMouseMoveIntervals (
    int distanceInPixels
)
Parameters
distanceInPixels (Int32)
The distance in pixels.
Return Value
The number of intervals.


GetRelativeNumOfMouseMoveIntervals(startTarget, startOffset, startReference, endTarget, endOffset, endReference) method

Mouse.GetRelativeNumOfMouseMoveIntervals(startTarget, startOffset, startReference, endTarget, endOffset, endReference) method
Namespaces > ArtOfTest.WebAii.Win32 > Mouse > GetRelativeNumOfMouseMoveIntervals(Rectangle, Point, OffsetReference, Rectangle, Point, OffsetReference)
Returns the relative number of mouse move intervals given a start/end locations.
Syntax
C#
protected int GetRelativeNumOfMouseMoveIntervals (
    Rectangle startTarget,
    Point startOffset,
    OffsetReference startReference,
    Rectangle endTarget,
    Point endOffset,
    OffsetReference endReference
)
Parameters
startTarget (Rectangle)
Start rectangle.
startOffset (Point)
Start offset.
startReference (OffsetReference)
Start offset reference.
endTarget (Rectangle)
End rectangle.
endOffset (Point)
End offset.
endReference (OffsetReference)
End offset reference.
Return Value
The number of intervals


GetRelativeNumOfMouseMoveIntervals(start, end) method

Mouse.GetRelativeNumOfMouseMoveIntervals(start, end) method
Namespaces > ArtOfTest.WebAii.Win32 > Mouse > GetRelativeNumOfMouseMoveIntervals(Rectangle, Rectangle)
Gets the number of mouse move intervals depending on the current set speed and interval time. Uses the absolute centers of passed in rectangles.
Syntax
C#
protected int GetRelativeNumOfMouseMoveIntervals (
    Rectangle start,
    Rectangle end
)
Parameters
start (Rectangle)
The start location.
end (Rectangle)
The end location.
Return Value
The number of intervals


GetRelativeNumOfMouseMoveIntervals(start, end) method

Mouse.GetRelativeNumOfMouseMoveIntervals(start, end) method
Namespaces > ArtOfTest.WebAii.Win32 > Mouse > GetRelativeNumOfMouseMoveIntervals(Point, Point)
Gets the number of mouse move intervals depending on the current set speed and interval time.
Syntax
C#
protected int GetRelativeNumOfMouseMoveIntervals (
    Point start,
    Point end
)
Parameters
start (Point)
The start point.
end (Point)
The end point.
Return Value
return the number of intervals


HoverOver methods

Mouse.HoverOver methods
Namespaces > ArtOfTest.WebAii.Win32 > Mouse > HoverOver
Members
Icon | Member | Description
 | HoverOver(Point) | HoverOver (Target a point).
 | HoverOver(Rectangle) | Hover over (Target the center of the target rectangle).
 | HoverOver(Rectangle, Point, OffsetReference) | Hover over (Target is a rectangle with an offset).
 | HoverOver(Int32, Int32) | Simulates a mouse hover over. Simply moves the mouse pointer over the X,Y passed in. Can also be used to move the mouse to a certain location.


HoverOver(pointToHoverOver) method

Mouse.HoverOver(pointToHoverOver) method
Namespaces > ArtOfTest.WebAii.Win32 > Mouse > HoverOver(Point)
HoverOver (Target a point).
Syntax
C#
public void HoverOver (
    Point pointToHoverOver
)
Parameters
pointToHoverOver (Point)
Point to hover over.


HoverOver(target) method

Mouse.HoverOver(target) method
Namespaces > ArtOfTest.WebAii.Win32 > Mouse > HoverOver(Rectangle)
Hover over (Target the center of the target rectangle).
Syntax
C#
public void HoverOver (
    Rectangle target
)
Parameters
target (Rectangle)
The target rectangle.


HoverOver(target, offset, reference) method

Mouse.HoverOver(target, offset, reference) method
Namespaces > ArtOfTest.WebAii.Win32 > Mouse > HoverOver(Rectangle, Point, OffsetReference)
Hover over (Target is a rectangle with an offset).
Syntax
C#
public void HoverOver (
    Rectangle target,
    Point offset,
    OffsetReference reference
)
Parameters
target (Rectangle)
The target rectangle.
offset (Point)
The offset in X/Y (negatives represents opposite direction).
reference (OffsetReference)
The reference point to offset within the rectangle.


HoverOver(x, y) method

Mouse.HoverOver(x, y) method
Namespaces > ArtOfTest.WebAii.Win32 > Mouse > HoverOver(Int32, Int32)
Simulates a mouse hover over. Simply moves the mouse pointer over the X,Y passed in. Can also be used to move the mouse to a certain location.
Syntax
C#
public void HoverOver (
    int x,
    int y
)
Parameters
x (Int32)
Absolute X coordinate to click.
y (Int32)
Absolute Y coordinate to click.


MouseMoveIntervalTime property

Mouse.MouseMoveIntervalTime property
Namespaces > ArtOfTest.WebAii.Win32 > Mouse > MouseMoveIntervalTime
Gets/Sets the mouse interval time between mouse move intervals. The default is set at 15msec. Typically you don't need to change this. If you want to configure the speed of the mouse move, use the Settings.SimulatedMouseMoveSpeed.
Syntax
C#
public int MouseMoveIntervalTime { get; set; }


Move methods

Mouse.Move methods
Namespaces > ArtOfTest.WebAii.Win32 > Mouse > Move
Members
Icon | Member | Description
 | Move(Point, Point) | Move the mouse from the start to the end location
 | Move(Point, Point, Int32, Int32) | Move the mouse from the start to the end location
 | Move(Rectangle, Point, OffsetReference, Rectangle, Point, OffsetReference) | Move the mouse from the start to the end location
 | Move(Rectangle, Point, OffsetReference, Rectangle, Point, OffsetReference, Int32, Int32) | Move the mouse from the start to the end location
 | Move(Rectangle, Rectangle) | Move the mouse from the start to the end location
 | Move(Rectangle, Rectangle, Int32, Int32) | Move the mouse from the start to the end location
 | Move(Rectangle, Int32, Int32, OffsetReference, Rectangle, Int32, Int32, OffsetReference) | Move the mouse from the start to the end location
 | Move(Rectangle, Int32, Int32, OffsetReference, Rectangle, Int32, Int32, OffsetReference, Int32, Int32) | Move the mouse from the start to the end location
 | Move(Int32, Int32, Int32, Int32) | Move the mouse from the start to the end location
 | Move(Int32, Int32, Int32, Int32, Int32, Int32) | Move the mouse from the start to the end location


Move(startTarget, startOffsetX, startOffsetY, startReference, endTarget, endOffsetX, endOffsetY, endReference) method

Mouse.Move(startTarget, startOffsetX, startOffsetY, startReference, endTarget, endOffsetX, endOffsetY, endReference) method
Namespaces > ArtOfTest.WebAii.Win32 > Mouse > Move(Rectangle, Int32, Int32, OffsetReference, Rectangle, Int32, Int32, OffsetReference)
Move the mouse from the start to the end location
Syntax
C#
public void Move (
    Rectangle startTarget,
    int startOffsetX,
    int startOffsetY,
    OffsetReference startReference,
    Rectangle endTarget,
    int endOffsetX,
    int endOffsetY,
    OffsetReference endReference
)
Parameters
startTarget (Rectangle)
Move start rectangle.
startOffsetX (Int32)
Move start offset x.
startOffsetY (Int32)
Move start offset y.
startReference (OffsetReference)
Move start offsetReference
endTarget (Rectangle)
Move end rectangle.
endOffsetX (Int32)
Move end offset x.
endOffsetY (Int32)
Move end offset y.
endReference (OffsetReference)
Move end offsetReference.


Move(startTarget, startOffsetX, startOffsetY, startReference, endTarget, endOffsetX, endOffsetY, endReference, intervals, intervalDelay) method

Mouse.Move(startTarget, startOffsetX, startOffsetY, startReference, endTarget, endOffsetX, endOffsetY, endReference, intervals, intervalDelay) method
Namespaces > ArtOfTest.WebAii.Win32 > Mouse > Move(Rectangle, Int32, Int32, OffsetReference, Rectangle, Int32, Int32, OffsetReference, Int32, Int32)
Move the mouse from the start to the end location
Syntax
C#
public void Move (
    Rectangle startTarget,
    int startOffsetX,
    int startOffsetY,
    OffsetReference startReference,
    Rectangle endTarget,
    int endOffsetX,
    int endOffsetY,
    OffsetReference endReference,
    int intervals,
    int intervalDelay
)
Parameters
startTarget (Rectangle)
Move start rectangle.
startOffsetX (Int32)
Move start offset x.
startOffsetY (Int32)
Move start offset y.
startReference (OffsetReference)
Move start offsetReference
endTarget (Rectangle)
Move end rectangle.
endOffsetX (Int32)
Move end offset x.
endOffsetY (Int32)
Move end offset y.
endReference (OffsetReference)
Move end offsetReference.
intervals (Int32)
Number of intervals for this Move operation.
intervalDelay (Int32)
The delay in msec. between each interval.


Move(startTarget, startOffset, startReference, endTarget, endOffset, endReference) method

Mouse.Move(startTarget, startOffset, startReference, endTarget, endOffset, endReference) method
Namespaces > ArtOfTest.WebAii.Win32 > Mouse > Move(Rectangle, Point, OffsetReference, Rectangle, Point, OffsetReference)
Move the mouse from the start to the end location
Syntax
C#
public void Move (
    Rectangle startTarget,
    Point startOffset,
    OffsetReference startReference,
    Rectangle endTarget,
    Point endOffset,
    OffsetReference endReference
)
Parameters
startTarget (Rectangle)
Move start rectangle.
startOffset (Point)
Move start offset.
startReference (OffsetReference)
Move start offsetReference
endTarget (Rectangle)
Move end rectangle.
endOffset (Point)
Move end offset.
endReference (OffsetReference)
Move end offsetReference.


Move(startTarget, startOffset, startReference, endTarget, endOffset, endReference, intervals, intervalDelay) method

Mouse.Move(startTarget, startOffset, startReference, endTarget, endOffset, endReference, intervals, intervalDelay) method
Namespaces > ArtOfTest.WebAii.Win32 > Mouse > Move(Rectangle, Point, OffsetReference, Rectangle, Point, OffsetReference, Int32, Int32)
Move the mouse from the start to the end location
Syntax
C#
public void Move (
    Rectangle startTarget,
    Point startOffset,
    OffsetReference startReference,
    Rectangle endTarget,
    Point endOffset,
    OffsetReference endReference,
    int intervals,
    int intervalDelay
)
Parameters
startTarget (Rectangle)
Move start rectangle.
startOffset (Point)
Move start offset.
startReference (OffsetReference)
Move start offsetReference
endTarget (Rectangle)
Move end rectangle.
endOffset (Point)
Move end offset.
endReference (OffsetReference)
Move end offsetReference.
intervals (Int32)
Number of intervals for this Move operation.
intervalDelay (Int32)
The delay in msec. between each interval.


Move(startX, startY, endX, endY) method

Mouse.Move(startX, startY, endX, endY) method
Namespaces > ArtOfTest.WebAii.Win32 > Mouse > Move(Int32, Int32, Int32, Int32)
Move the mouse from the start to the end location
Syntax
C#
public void Move (
    int startX,
    int startY,
    int endX,
    int endY
)
Parameters
startX (Int32)
Move start X position.
startY (Int32)
Move start Y position.
endX (Int32)
Move end X position.
endY (Int32)
Move end Y position.


Move(startX, startY, endX, endY, intervals, intervalDelay) method

Mouse.Move(startX, startY, endX, endY, intervals, intervalDelay) method
Namespaces > ArtOfTest.WebAii.Win32 > Mouse > Move(Int32, Int32, Int32, Int32, Int32, Int32)
Move the mouse from the start to the end location
Syntax
C#
public void Move (
    int startX,
    int startY,
    int endX,
    int endY,
    int intervals,
    int intervalDelay
)
Parameters
startX (Int32)
Move start X position.
startY (Int32)
Move start Y position.
endX (Int32)
Move end X position.
endY (Int32)
Move end Y position.
intervals (Int32)
Number of intervals for this Move operation.
intervalDelay (Int32)
The delay in msec. between each interval.


Move(start, end) method

Mouse.Move(start, end) method
Namespaces > ArtOfTest.WebAii.Win32 > Mouse > Move(Point, Point)
Move the mouse from the start to the end location
Syntax
C#
public void Move (
    Point start,
    Point end
)
Parameters
start (Point)
start point of the move.
end (Point)
end point of the move


Move(start, end) method

Mouse.Move(start, end) method
Namespaces > ArtOfTest.WebAii.Win32 > Mouse > Move(Rectangle, Rectangle)
Move the mouse from the start to the end location
Syntax
C#
public void Move (
    Rectangle start,
    Rectangle end
)
Parameters
start (Rectangle)
Move start point.
end (Rectangle)
Move end point.


Move(start, end, intervals, intervalDelay) method

Mouse.Move(start, end, intervals, intervalDelay) method
Namespaces > ArtOfTest.WebAii.Win32 > Mouse > Move(Point, Point, Int32, Int32)
Move the mouse from the start to the end location
Syntax
C#
public void Move (
    Point start,
    Point end,
    int intervals,
    int intervalDelay
)
Parameters
start (Point)
start point of the move.
end (Point)
end point of the move
intervals (Int32)
Number of intervals for this Move operation.
intervalDelay (Int32)
The delay in msec. between each interval.


Move(start, end, intervals, intervalDelay) method

Mouse.Move(start, end, intervals, intervalDelay) method
Namespaces > ArtOfTest.WebAii.Win32 > Mouse > Move(Rectangle, Rectangle, Int32, Int32)
Move the mouse from the start to the end location
Syntax
C#
public void Move (
    Rectangle start,
    Rectangle end,
    int intervals,
    int intervalDelay
)
Parameters
start (Rectangle)
Move start point.
end (Rectangle)
Move end point.
intervals (Int32)
Number of intervals for this Move operation.
intervalDelay (Int32)
The delay in msec. between each interval.


TurnWheel(delta, direction) method

Mouse.TurnWheel(delta, direction) method
Namespaces > ArtOfTest.WebAii.Win32 > Mouse > TurnWheel(Int32, MouseWheelTurnDirection)
Move the mouse wheel by a certain delta
Syntax
C#
public void TurnWheel (
    int delta,
    MouseWheelTurnDirection direction
)
Parameters
delta (Int32)
The delta to use.
direction (MouseWheelTurnDirection)
The direction to turn the mouse wheel in.


ValidateNonNegativePoint(point) method

Mouse.ValidateNonNegativePoint(point) method
Namespaces > ArtOfTest.WebAii.Win32 > Mouse > ValidateNonNegativePoint(Point)
Validate that the point coordinates i non-negative. if not, will reset to zero.
Syntax
C#
public void ValidateNonNegativePoint (
    ref Point point
)
Parameters
point (Point)
The point to validate.


Win32Error class

Win32Error class
Namespaces > ArtOfTest.WebAii.Win32 > Win32Error
Static class used to retrieve last error strings from Win32 calls.
Syntax
C#
public static class Win32Error
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LastErrorString | Gets/Sets last error string
 | SetLastWin32Error() | Set the formatted Win32Error string.
Inheritance Hierarchy
Object
Win32Error


LastErrorString property

Win32Error.LastErrorString property
Namespaces > ArtOfTest.WebAii.Win32 > Win32Error > LastErrorString
Gets/Sets last error string
Syntax
C#
public static string LastErrorString { get; set; }


SetLastWin32Error() method

Win32Error.SetLastWin32Error() method
Namespaces > ArtOfTest.WebAii.Win32 > Win32Error > SetLastWin32Error()
Set the formatted Win32Error string.
Syntax
C#
public static void SetLastWin32Error ()


Window class

Window class
Namespaces > ArtOfTest.WebAii.Win32 > Window
Class representing a Win32 Window.
Syntax
C#
public class Window
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | WindowNew(IntPtr) | Constructs a new instance of this class for the specified Window Handle.
 | Caption | Gets the window's caption.
 | ClassName | Gets the window's class name.
 | Close() | Close the window.
 | Enabled | Gets whether this window is enabled or not.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetBitmap() | Capture the entire window bitmap and returns it.
 | GetBitmap(Rectangle) | Returns a bitmap of a specified target area within this window.
 | GetHashCode() | The hash code is the window's hwnd. (Overrides Object.GetHashCode().)
 | GetType() | Gets the Type of the current instance. (Inherited from Object.)
 | Handle | Gets the handle of the window.
 | Hide() | Hide the window.
 | IsMaximized | Gets whether the window is maximized.
 | IsMinimized | Gets whether the window is minimized.
 | IsVisible | Gets whether the window is visible.
 | Location | Gets the top left point of the location of the window relative to the screen.
 | MakeRelative(Rectangle) | Make the absolute rects passed in relative to this window.
 | Maximize() | Maximize the window
 | MemberwiseClone() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Minimize() | Minimize the window.
 | Move(Rectangle, Boolean) | Move this window to a new location
 | OwnerProcess | The owner process that created this window.
 | Rectangle | Gets the rectangle of the window.
 | SetActive() | Set this window to active.
 | SetFocus() | Restores and Brings the window to the front, assuming it is a visible application window.
 | Show() | Show this window and make it visible
 | Size | Gets the size of the window.
 | ToString() | Returns a String that represents the current Object. (Inherited from Object.)
 | Update() | Update the window. Invalidates all areas and forces a redraw.
 | WaitForVisibility(Boolean, Int32) | Waits for a certain visibility state for a window
 | WaitForVisibility(Boolean, Int32, Boolean) | Waits for a certain visibility state for a window
Inheritance Hierarchy
Object
 | Window
 |  | Button


Caption property

Window.Caption property
Namespaces > ArtOfTest.WebAii.Win32 > Window > Caption
Gets the window's caption.
Syntax
C#
public string Caption { get; }


ClassName property

Window.ClassName property
Namespaces > ArtOfTest.WebAii.Win32 > Window > ClassName
Gets the window's class name.
Syntax
C#
public string ClassName { get; }


Close() method

Window.Close() method
Namespaces > ArtOfTest.WebAii.Win32 > Window > Close()
Close the window.
Syntax
C#
public void Close ()


Enabled property

Window.Enabled property
Namespaces > ArtOfTest.WebAii.Win32 > Window > Enabled
Gets whether this window is enabled or not.
Syntax
C#
public bool Enabled { get; }


GetBitmap methods

Window.GetBitmap methods
Namespaces > ArtOfTest.WebAii.Win32 > Window > GetBitmap
Members
Icon | Member | Description
 | GetBitmap() | Capture the entire window bitmap and returns it.
 | GetBitmap(Rectangle) | Returns a bitmap of a specified target area within this window.


GetBitmap() method

Window.GetBitmap() method
Namespaces > ArtOfTest.WebAii.Win32 > Window > GetBitmap()
Capture the entire window bitmap and returns it.
Syntax
C#
public Bitmap GetBitmap ()
Return Value
A bitmap of the window, otherwise will return null


GetBitmap(targetArea) method

Window.GetBitmap(targetArea) method
Namespaces > ArtOfTest.WebAii.Win32 > Window > GetBitmap(Rectangle)
Returns a bitmap of a specified target area within this window.
Syntax
C#
public Bitmap GetBitmap (
    Rectangle targetArea
)
Parameters
targetArea (Rectangle)
The target area to return the bitmap for.
Return Value
The bitmap of that target area as it appears in the window.


GetHashCode() method

Window.GetHashCode() method
Namespaces > ArtOfTest.WebAii.Win32 > Window > GetHashCode()
The hash code is the window's hwnd.
Syntax
C#
public override int GetHashCode ()
Return Value
The Window Handle of this window


Handle property

Window.Handle property
Namespaces > ArtOfTest.WebAii.Win32 > Window > Handle
Gets the handle of the window.
Syntax
C#
public IntPtr Handle { get; }


Hide() method

Window.Hide() method
Namespaces > ArtOfTest.WebAii.Win32 > Window > Hide()
Hide the window.
Syntax
C#
public void Hide ()


IsMaximized property

Window.IsMaximized property
Namespaces > ArtOfTest.WebAii.Win32 > Window > IsMaximized
Gets whether the window is maximized.
Syntax
C#
public bool IsMaximized { get; }


IsMinimized property

Window.IsMinimized property
Namespaces > ArtOfTest.WebAii.Win32 > Window > IsMinimized
Gets whether the window is minimized.
Syntax
C#
public bool IsMinimized { get; }


IsVisible property

Window.IsVisible property
Namespaces > ArtOfTest.WebAii.Win32 > Window > IsVisible
Gets whether the window is visible.
Syntax
C#
public bool IsVisible { get; }


Location property

Window.Location property
Namespaces > ArtOfTest.WebAii.Win32 > Window > Location
Gets the top left point of the location of the window relative to the screen.
Syntax
C#
public Point Location { get; }


MakeRelative(absoluteRects) method

Window.MakeRelative(absoluteRects) method
Namespaces > ArtOfTest.WebAii.Win32 > Window > MakeRelative(Rectangle)
Make the absolute rects passed in relative to this window.
Syntax
C#
public Rectangle MakeRelative (
    Rectangle absoluteRects
)
Parameters
absoluteRects (Rectangle)
The absolute rects
Return Value
The relative coordinates to this window.


Maximize() method

Window.Maximize() method
Namespaces > ArtOfTest.WebAii.Win32 > Window > Maximize()
Maximize the window
Syntax
C#
public void Maximize ()


Minimize() method

Window.Minimize() method
Namespaces > ArtOfTest.WebAii.Win32 > Window > Minimize()
Minimize the window.
Syntax
C#
public void Minimize ()


Move(newLocation, redraw) method

Window.Move(newLocation, redraw) method
Namespaces > ArtOfTest.WebAii.Win32 > Window > Move(Rectangle, Boolean)
Move this window to a new location
Syntax
C#
public void Move (
    Rectangle newLocation,
    bool redraw
)
Parameters
newLocation (Rectangle)
The new location to move the window to.
redraw (Boolean)
True/False whether to redraw the window.


OwnerProcess property

Window.OwnerProcess property
Namespaces > ArtOfTest.WebAii.Win32 > Window > OwnerProcess
The owner process that created this window.
Syntax
C#
public Process OwnerProcess { get; }


Rectangle property

Window.Rectangle property
Namespaces > ArtOfTest.WebAii.Win32 > Window > Rectangle
Gets the rectangle of the window.
Syntax
C#
public Rectangle Rectangle { get; }


SetActive() method

Window.SetActive() method
Namespaces > ArtOfTest.WebAii.Win32 > Window > SetActive()
Set this window to active.
Syntax
C#
public void SetActive ()


SetFocus() method

Window.SetFocus() method
Namespaces > ArtOfTest.WebAii.Win32 > Window > SetFocus()
Restores and Brings the window to the front, assuming it is a visible application window.
Syntax
C#
public void SetFocus ()


Show() method

Window.Show() method
Namespaces > ArtOfTest.WebAii.Win32 > Window > Show()
Show this window and make it visible
Syntax
C#
public void Show ()


Size property

Window.Size property
Namespaces > ArtOfTest.WebAii.Win32 > Window > Size
Gets the size of the window.
Syntax
C#
public Size Size { get; }


Update() method

Window.Update() method
Namespaces > ArtOfTest.WebAii.Win32 > Window > Update()
Update the window. Invalidates all areas and forces a redraw.
Syntax
C#
public void Update ()


WaitForVisibility methods

Window.WaitForVisibility methods
Namespaces > ArtOfTest.WebAii.Win32 > Window > WaitForVisibility
Members
Icon | Member | Description
 | WaitForVisibility(Boolean, Int32) | Waits for a certain visibility state for a window
 | WaitForVisibility(Boolean, Int32, Boolean) | Waits for a certain visibility state for a window


WaitForVisibility(visibilityState, timeout) method

Window.WaitForVisibility(visibilityState, timeout) method
Namespaces > ArtOfTest.WebAii.Win32 > Window > WaitForVisibility(Boolean, Int32)
Waits for a certain visibility state for a window
Syntax
C#
public void WaitForVisibility (
    bool visibilityState,
    int timeout
)
Parameters
visibilityState (Boolean)
The visibility state of the window to wait for. True: wait until window is visible (The window needs to have its handle created before calling this method), False, wait until window is invisible.
timeout (Int32)
The wait timeout in msecs.


WaitForVisibility(visibilityState, timeout, suppressException) method

Window.WaitForVisibility(visibilityState, timeout, suppressException) method
Namespaces > ArtOfTest.WebAii.Win32 > Window > WaitForVisibility(Boolean, Int32, Boolean)
Waits for a certain visibility state for a window
Syntax
C#
public bool WaitForVisibility (
    bool visibilityState,
    int timeout,
    bool suppressException
)
Parameters
visibilityState (Boolean)
The visibility state of the window to wait for. True: wait until window is visible (The window needs to have its handle created before calling this method), False, wait until window is invisible.
timeout (Int32)
The wait timeout in msecs.
suppressException (Boolean)
Whether to throw or return false if the window does not reach the desired visibility state.


Window(hWnd) constructor

Window(hWnd) constructor
Namespaces > ArtOfTest.WebAii.Win32 > Window > WindowNew(IntPtr)
Constructs a new instance of this class for the specified Window Handle.
Syntax
C#
public Window (
    IntPtr hWnd
)
Parameters
hWnd (IntPtr)
The Window Handle


WindowCollection class

WindowCollection class
Namespaces > ArtOfTest.WebAii.Win32 > WindowCollection
A Window object collection.
Syntax
C#
[DefaultMemberAttribute("Item")]
public class WindowCollection : ReadOnlyCollectionBase
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Count | Gets the number of elements contained in the ReadOnlyCollectionBase instance. (Inherited from ReadOnlyCollectionBase.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetEnumerator() | Returns an enumerator that iterates through the ReadOnlyCollectionBase instance. (Inherited from ReadOnlyCollectionBase.)
 | GetHashCode() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType() | Gets the Type of the current instance. (Inherited from Object.)
 | ICollection.System.Collections.ICollection.CopyTo(Array, Int32) | (Inherited from ReadOnlyCollectionBase.)
 | ICollection.System.Collections.ICollection.IsSynchronized | (Inherited from ReadOnlyCollectionBase.)
 | ICollection.System.Collections.ICollection.SyncRoot | (Inherited from ReadOnlyCollectionBase.)
 | InnerList | Gets the list of elements contained in the ReadOnlyCollectionBase instance. (Inherited from ReadOnlyCollectionBase.)
 | Item(Int32) | Gets the Window at the specified index.
 | MemberwiseClone() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | ReadOnlyCollectionBase
 |  | WindowCollection


Item[index] property

WindowCollection.Item[index] property
Namespaces > ArtOfTest.WebAii.Win32 > WindowCollection > Item(Int32)
Gets the Window at the specified index.
Syntax
C#
public Window this [
    int index
] { get; }
Parameters
index (Int32)


WindowManager class

WindowManager class
Namespaces > ArtOfTest.WebAii.Win32 > WindowManager
Provides basic Win32 window management services like searching ...etc.
Syntax
C#
public class WindowManager
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | WindowManagerNew() | Create a new window manager
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindWindowRecursively(IntPtr, String, Boolean, Int32) | Find a window recursively using its caption.
 | FindWindowRecursively(IntPtr, String, Int32) | Find a window recusively under the parent window. Will return the first window that matches the class name.
 | GetHashCode() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType() | Gets the Type of the current instance. (Inherited from Object.)
 | GetWindows() | Populate the Items collection with all top level windows.
 | GetWindows(IntPtr) | Populate the Items collection with all child windows of the parent window passed in.
 | Items | Returns the collection of windows populated by a call to GetWindows()
 | MemberwiseClone() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
WindowManager


FindWindowRecursively methods

WindowManager.FindWindowRecursively methods
Namespaces > ArtOfTest.WebAii.Win32 > WindowManager > FindWindowRecursively
Members
Icon | Member | Description
 | FindWindowRecursively(IntPtr, String, Boolean, Int32) | Find a window recursively using its caption.
 | FindWindowRecursively(IntPtr, String, Int32) | Find a window recusively under the parent window. Will return the first window that matches the class name.


FindWindowRecursively(parentHwnd, caption, partialCaption, delaySearchPeriod) method

WindowManager.FindWindowRecursively(parentHwnd, caption, partialCaption, delaySearchPeriod) method
Namespaces > ArtOfTest.WebAii.Win32 > WindowManager > FindWindowRecursively(IntPtr, String, Boolean, Int32)
Find a window recursively using its caption.
Syntax
C#
public static Window FindWindowRecursively (
    IntPtr parentHwnd,
    string caption,
    bool partialCaption,
    int delaySearchPeriod
)
Parameters
parentHwnd (IntPtr)
The parent window to search under. If Zero, will search all deskop windows.
caption (String)
The caption to find.
partialCaption (Boolean)
Use partial caption matching or exact. (In both cases the matching is case-insensitive).
delaySearchPeriod (Int32)
The number of milli-seconds to delay the start of the search to allow the window we are searching for to be constructed. (if 0, no delay will occur)
Return Value
The found window or null;


FindWindowRecursively(parentHwnd, className, delaySearchPeriod) method

WindowManager.FindWindowRecursively(parentHwnd, className, delaySearchPeriod) method
Namespaces > ArtOfTest.WebAii.Win32 > WindowManager > FindWindowRecursively(IntPtr, String, Int32)
Find a window recusively under the parent window. Will return the first window that matches the class name.
Syntax
C#
public static Window FindWindowRecursively (
    IntPtr parentHwnd,
    string className,
    int delaySearchPeriod
)
Parameters
parentHwnd (IntPtr)
The parent window to search under. If Zero, will search all deskop windows.
className (String)
The class name to search for. (case-insensitive)
delaySearchPeriod (Int32)
The number of milli-seconds to delay the start of the search to allow the window we are searching for to be constructed. (if 0, no delay will occur)
Return Value
The window that matches, otherwise null.


GetWindows methods

WindowManager.GetWindows methods
Namespaces > ArtOfTest.WebAii.Win32 > WindowManager > GetWindows
Members
Icon | Member | Description
 | GetWindows() | Populate the Items collection with all top level windows.
 | GetWindows(IntPtr) | Populate the Items collection with all child windows of the parent window passed in.


GetWindows() method

WindowManager.GetWindows() method
Namespaces > ArtOfTest.WebAii.Win32 > WindowManager > GetWindows()
Populate the Items collection with all top level windows.
Syntax
C#
public void GetWindows ()


GetWindows(parentHwnd) method

WindowManager.GetWindows(parentHwnd) method
Namespaces > ArtOfTest.WebAii.Win32 > WindowManager > GetWindows(IntPtr)
Populate the Items collection with all child windows of the parent window passed in.
Syntax
C#
public void GetWindows (
    IntPtr parentHwnd
)
Parameters
parentHwnd (IntPtr)
The parent window.


Items property

WindowManager.Items property
Namespaces > ArtOfTest.WebAii.Win32 > WindowManager > Items
Returns the collection of windows populated by a call to GetWindows()
Syntax
C#
public WindowCollection Items { get; }


WindowManager() constructor

WindowManager() constructor
Namespaces > ArtOfTest.WebAii.Win32 > WindowManager > WindowManagerNew()
Create a new window manager
Syntax
C#
public WindowManager ()


ArtOfTest.WebAii.Win32.Dialogs Namespace

ArtOfTest.WebAii.Win32.Dialogs Namespace
Namespaces > ArtOfTest.WebAii.Win32.Dialogs
Syntax
C#
namespace ArtOfTest.WebAii.Win32.Dialogs
Types
All Types Classes Structures Interfaces Enumerations Delegates
Icon | Type | Description
public class | AlertDialog | Class to handle javascript alert dialogs.
public class | BaseDialog | A base implementation for a dialog.
public enumeration | DialogButton | Possible buttons for to click for a dialog
public enumeration | DialogCurrentState | Different states the dialog can be set to.
public delegate | DialogHandlerDelegate | A dialog handler that allows for users to do their own handling of a dialog instead of calling Handle().
public class | DialogMonitor | Class implementation for a dialog monitor to handle dialogs during execution.
public class | DownloadDialogsHandler | The download dialogs handler. Wraps all the download dialog sequences for IE/Firefox into a simple API call.
public class | FFOpenDownloadDialog | Firefox OpenDialog.
public class | FileUploadDialog | Class to handle the FileUpload dialog.
public class | GenericDialog | A generic dialog handler that can be used for quick and easy way to write a dialog handler for a simply dialog.
public interface | IDialog | Interface to implement for dialogs to be monitored and handled by the DialogMonitor object.
public class | IEDownloadCompleteDialog | The IE download complete dialog.
public class | IEDownloadDialog | IE's initiali download dialog.
public class | LogonDialog | Class to handle the logon dialog (username/password)
public class | SaveAsDialog | SaveAs Dialog handler.


AlertDialog class

AlertDialog class
Namespaces > ArtOfTest.WebAii.Win32.Dialogs > AlertDialog
Class to handle javascript alert dialogs.
Syntax
C#
public class AlertDialog : BaseDialog
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AlertDialogNew(Browser, DialogButton) | Create a new AlertDialog object to handle the dialog.
 | CurrentState | Gets/Sets the dialog current state. State is handled my DialogMonitor. (Inherited from BaseDialog.)
 | DismissButton | Gets/Sets the dismiss button to use to knock down this dialog. (Inherited from BaseDialog.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetProccessIdForWindow(Window) | Return the process id from a window handle. (Inherited from BaseDialog.)
 | GetType() | Gets the Type of the current instance. (Inherited from Object.)
 | Handle() | Handle this dialog. (Overrides BaseDialog.Handle().)
 | HandleCount | Gets/Sets the number of times this dialog has been handled. (Inherited from BaseDialog.)
 | HandlerDelegate | Gets/Sets the dialog custom handler (Inherited from BaseDialog.)
 | IsDialogActive(WindowCollection) | Whether the dialog is active or not. (Overrides BaseDialog.IsDialogActive(WindowCollection).)
 | IsDialogActiveByTitle(WindowCollection, String) | Get whether the dialog is active based on its title. (Inherited from BaseDialog.)
 | IsDialogActiveByTitle(WindowCollection, String, Boolean) | Get whether the dialog is active base on its title. (Inherited from BaseDialog.)
 | IsDialogActiveByTitleAndTextContent(WindowCollection, String, Boolean, String) | Gets whether a dialog is active or not using the title and caption of an inner window contained in the dialog (Inherited from BaseDialog.)
 | MemberwiseClone() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ParentBrowser | The parent browser object of this dialog (Inherited from BaseDialog.)
 | ParentProcessId | Parent process id of the browser and all the dialogs that this object should handle. (Inherited from BaseDialog.)
 | ResetHandleCount() | Resets the handle count back to zero. (Inherited from BaseDialog.)
 | SetDialogWindow(Window) | Set the dialog window. (Inherited from BaseDialog.)
 | ToString() | Returns a String that represents the current Object. (Inherited from Object.)
 | WaitUntilHandled(Int32) | Waits for the dialog to be handled atleast once. Always performs a reset at the being of the wait. (Inherited from BaseDialog.)
 | WaitUntilHandled(Int32, Int32, Boolean) | Waits for the dialog to be handled handleCount. You can optionally reset the handle count before waiting. (Inherited from BaseDialog.)
 | Window | The dialog Window object. (Inherited from BaseDialog.)
Inheritance Hierarchy
Object
 | BaseDialog
 |  | AlertDialog


AlertDialog(parentBrowser, dismissButton) constructor

AlertDialog(parentBrowser, dismissButton) constructor
Namespaces > ArtOfTest.WebAii.Win32.Dialogs > AlertDialog > AlertDialogNew(Browser, DialogButton)
Create a new AlertDialog object to handle the dialog.
Syntax
C#
public AlertDialog (
    Browser parentBrowser,
    DialogButton dismissButton
)
Parameters
parentBrowser (Browser)
The parent browser.
dismissButton (DialogButton)
The dismiss button to use.


Handle() method

AlertDialog.Handle() method
Namespaces > ArtOfTest.WebAii.Win32.Dialogs > AlertDialog > Handle()
Handle this dialog.
Syntax
C#
public override void Handle ()
Return Value
True/False whether this dialog was handled.


IsDialogActive(dialogs) method

AlertDialog.IsDialogActive(dialogs) method
Namespaces > ArtOfTest.WebAii.Win32.Dialogs > AlertDialog > IsDialogActive(WindowCollection)
Whether the dialog is active or not.
Syntax
C#
public override bool IsDialogActive (
    WindowCollection dialogs
)
Parameters
dialogs (WindowCollection)
The list of dialogs on the desktop.
Return Value
True/False whether the dialog is active or not.


BaseDialog class

BaseDialog class
Namespaces > ArtOfTest.WebAii.Win32.Dialogs > BaseDialog
A base implementation for a dialog.
Syntax
C#
public abstract class BaseDialog : IDialog
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BaseDialogNew(Browser, DialogButton) | Create a new dialog.
 | CurrentState | Gets/Sets the dialog current state. State is handled my DialogMonitor.
 | DismissButton | Gets/Sets the dismiss button to use to knock down this dialog.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetProccessIdForWindow(Window) | Return the process id from a window handle.
 | GetType() | Gets the Type of the current instance. (Inherited from Object.)
 | Handle() | Handle the dialog. If HandlerDelegate is set, use the delegate
 | HandleCount | Gets/Sets the number of times this dialog has been handled.
 | HandlerDelegate | Gets/Sets the dialog custom handler
 | IsDialogActive(WindowCollection) | Detect whether this dialog is active or not.
 | IsDialogActiveByTitle(WindowCollection, String) | Get whether the dialog is active based on its title.
 | IsDialogActiveByTitle(WindowCollection, String, Boolean) | Get whether the dialog is active base on its title.
 | IsDialogActiveByTitleAndTextContent(WindowCollection, String, Boolean, String) | Gets whether a dialog is active or not using the title and caption of an inner window contained in the dialog
 | MemberwiseClone() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ParentBrowser | The parent browser object of this dialog
 | ParentProcessId | Parent process id of the browser and all the dialogs that this object should handle.
 | ResetHandleCount() | Resets the handle count back to zero.
 | SetDialogWindow(Window) | Set the dialog window.
 | ToString() | Returns a String that represents the current Object. (Inherited from Object.)
 | WaitUntilHandled() | Waits for the dialog to be handled atleast once. Always performs a reset at the beginning of the wait. Will use the Settings.ClientReadyTimeout.
 | WaitUntilHandled(Int32) | Waits for the dialog to be handled atleast once. Always performs a reset at the being of the wait.
 | WaitUntilHandled(Int32, Int32, Boolean) | Waits for the dialog to be handled handleCount. You can optionally reset the handle count before waiting.
 | Window | The dialog Window object.
Inheritance Hierarchy
Object
 | BaseDialog
 |  | AlertDialog
 |  | IEDownloadCompleteDialog
 |  | SaveAsDialog
 |  | GenericDialog
 |  | LogonDialog
 |  | FileUploadDialog
 |  | FFOpenDownloadDialog
 |  | IEDownloadDialog


BaseDialog(parentBrowser, dismissButton) constructor

BaseDialog(parentBrowser, dismissButton) constructor
Namespaces > ArtOfTest.WebAii.Win32.Dialogs > BaseDialog > BaseDialogNew(Browser, DialogButton)
Create a new dialog.
Syntax
C#
public BaseDialog (
    Browser parentBrowser,
    DialogButton dismissButton
)
Parameters
parentBrowser (Browser)
The parent browser.
dismissButton (DialogButton)
The button to use to dismiss the dialog.


CurrentState property

BaseDialog.CurrentState property
Namespaces > ArtOfTest.WebAii.Win32.Dialogs > BaseDialog > CurrentState
Gets/Sets the dialog current state. State is handled my DialogMonitor.
Syntax
C#
public DialogCurrentState CurrentState { get; set; }


DismissButton property

BaseDialog.DismissButton property
Namespaces > ArtOfTest.WebAii.Win32.Dialogs > BaseDialog > DismissButton
Gets/Sets the dismiss button to use to knock down this dialog.
Syntax
C#
public DialogButton DismissButton { get; set; }


GetProccessIdForWindow(Window) method

BaseDialog.GetProccessIdForWindow(Window) method
Namespaces > ArtOfTest.WebAii.Win32.Dialogs > BaseDialog > GetProccessIdForWindow(Window)
Return the process id from a window handle.
Syntax
C#
protected int GetProccessIdForWindow (
    Window Window
)
Parameters
Window (Window)
The window to return process id for.
Return Value
The process id, else 0


Handle() method

BaseDialog.Handle() method
Namespaces > ArtOfTest.WebAii.Win32.Dialogs > BaseDialog > Handle()
Handle the dialog. If HandlerDelegate is set, use the delegate
Syntax
C#
public abstract void Handle ()


HandleCount property

BaseDialog.HandleCount property
Namespaces > ArtOfTest.WebAii.Win32.Dialogs > BaseDialog > HandleCount
Gets/Sets the number of times this dialog has been handled.
Syntax
C#
public int HandleCount { get; set; }


HandlerDelegate property

BaseDialog.HandlerDelegate property
Namespaces > ArtOfTest.WebAii.Win32.Dialogs > BaseDialog > HandlerDelegate
Gets/Sets the dialog custom handler
Syntax
C#
public DialogHandlerDelegate HandlerDelegate { get; set; }


IsDialogActive(dialogs) method

BaseDialog.IsDialogActive(dialogs) method
Namespaces > ArtOfTest.WebAii.Win32.Dialogs > BaseDialog > IsDialogActive(WindowCollection)
Detect whether this dialog is active or not.
Syntax
C#
public abstract bool IsDialogActive (
    WindowCollection dialogs
)
Parameters
dialogs (WindowCollection)
The list of all dialogs.
Return Value
True/False whether this dialog is active or not.


IsDialogActiveByTitle methods

BaseDialog.IsDialogActiveByTitle methods
Namespaces > ArtOfTest.WebAii.Win32.Dialogs > BaseDialog > IsDialogActiveByTitle
Members
Icon | Member | Description
 | IsDialogActiveByTitle(WindowCollection, String) | Get whether the dialog is active based on its title.
 | IsDialogActiveByTitle(WindowCollection, String, Boolean) | Get whether the dialog is active base on its title.


IsDialogActiveByTitle(dialogs, title) method

BaseDialog.IsDialogActiveByTitle(dialogs, title) method
Namespaces > ArtOfTest.WebAii.Win32.Dialogs > BaseDialog > IsDialogActiveByTitle(WindowCollection, String)
Get whether the dialog is active based on its title.
Syntax
C#
protected bool IsDialogActiveByTitle (
    WindowCollection dialogs,
    string title
)
Parameters
dialogs (WindowCollection)
The list of dialogs to check.
title (String)
The title to check for.
Return Value
True/False whether the dialog is active or not.


IsDialogActiveByTitle(dialogs, title, partialTitle) method

BaseDialog.IsDialogActiveByTitle(dialogs, title, partialTitle) method
Namespaces > ArtOfTest.WebAii.Win32.Dialogs > BaseDialog > IsDialogActiveByTitle(WindowCollection, String, Boolean)
Get whether the dialog is active base on its title.
Syntax
C#
protected bool IsDialogActiveByTitle (
    WindowCollection dialogs,
    string title,
    bool partialTitle
)
Parameters
dialogs (WindowCollection)
The list of dialogs to check.
title (String)
The title to check for.
partialTitle (Boolean)
True/False whether to do partial match or not.
Return Value
True/False whether the dialog is active or not.


IsDialogActiveByTitleAndTextContent(dialogs, title, partialTitle, childWindowTextContent) method

BaseDialog.IsDialogActiveByTitleAndTextContent(dialogs, title, partialTitle, childWindowTextContent) method
Namespaces > ArtOfTest.WebAii.Win32.Dialogs > BaseDialog > IsDialogActiveByTitleAndTextContent(WindowCollection, String, Boolean, String)
Gets whether a dialog is active or not using the title and caption of an inner window contained in the dialog
Syntax
C#
protected bool IsDialogActiveByTitleAndTextContent (
    WindowCollection dialogs,
    string title,
    bool partialTitle,
    string childWindowTextContent
)
Parameters
dialogs (WindowCollection)
The list of dialogs to check.
title (String)
The title to check for.
partialTitle (Boolean)
True/False whether to do partial match or not.
childWindowTextContent (String)
The partial content of a child window
Return Value
True/False whether the dialog is active or not.


ParentBrowser property

BaseDialog.ParentBrowser property
Namespaces > ArtOfTest.WebAii.Win32.Dialogs > BaseDialog > ParentBrowser
The parent browser object of this dialog
Syntax
C#
protected Browser ParentBrowser { get; }


ParentProcessId property

BaseDialog.ParentProcessId property
Namespaces > ArtOfTest.WebAii.Win32.Dialogs > BaseDialog > ParentProcessId
Parent process id of the browser and all the dialogs that this object should handle.
Syntax
C#
protected int ParentProcessId { get; }


ResetHandleCount() method

BaseDialog.ResetHandleCount() method
Namespaces > ArtOfTest.WebAii.Win32.Dialogs > BaseDialog > ResetHandleCount()
Resets the handle count back to zero.
Syntax
C#
public void ResetHandleCount ()


SetDialogWindow(dialogWindow) method

BaseDialog.SetDialogWindow(dialogWindow) method
Namespaces > ArtOfTest.WebAii.Win32.Dialogs > BaseDialog > SetDialogWindow(Window)
Set the dialog window.
Syntax
C#
protected void SetDialogWindow (
    Window dialogWindow
)
Parameters
dialogWindow (Window)
The dialog window object.


WaitUntilHandled methods

BaseDialog.WaitUntilHandled methods
Namespaces > ArtOfTest.WebAii.Win32.Dialogs > BaseDialog > WaitUntilHandled
Members
Icon | Member | Description
 | WaitUntilHandled() | Waits for the dialog to be handled atleast once. Always performs a reset at the beginning of the wait. Will use the Settings.ClientReadyTimeout.
 | WaitUntilHandled(Int32) | Waits for the dialog to be handled atleast once. Always performs a reset at the being of the wait.
 | WaitUntilHandled(Int32, Int32, Boolean) | Waits for the dialog to be handled handleCount. You can optionally reset the handle count before waiting.


WaitUntilHandled() method

BaseDialog.WaitUntilHandled() method
Namespaces > ArtOfTest.WebAii.Win32.Dialogs > BaseDialog > WaitUntilHandled()
Waits for the dialog to be handled atleast once. Always performs a reset at the beginning of the wait. Will use the Settings.ClientReadyTimeout.
Syntax
C#
public void WaitUntilHandled ()


WaitUntilHandled(handleCount, timeout, resetHandleCount) method

BaseDialog.WaitUntilHandled(handleCount, timeout, resetHandleCount) method
Namespaces > ArtOfTest.WebAii.Win32.Dialogs > BaseDialog > WaitUntilHandled(Int32, Int32, Boolean)
Waits for the dialog to be handled handleCount. You can optionally reset the handle count before waiting.
Syntax
C#
public void WaitUntilHandled (
    int handleCount,
    int timeout,
    bool resetHandleCount
)
Parameters
handleCount (Int32)
The handle count to wait for.
timeout (Int32)
The time out in milli-seconds to wait for count.
resetHandleCount (Boolean)
True/False whether to reset the handle count before starting.


WaitUntilHandled(timeout) method

BaseDialog.WaitUntilHandled(timeout) method
Namespaces > ArtOfTest.WebAii.Win32.Dialogs > BaseDialog > WaitUntilHandled(Int32)
Waits for the dialog to be handled atleast once. Always performs a reset at the being of the wait.
Syntax
C#
public void WaitUntilHandled (
    int timeout
)
Parameters
timeout (Int32)
The timeout to use. (msec.)


Window property

BaseDialog.Window property
Namespaces > ArtOfTest.WebAii.Win32.Dialogs > BaseDialog > Window
The dialog Window object.
Syntax
C#
public Window Window { get; }


DialogButton enumeration

DialogButton enumeration
Namespaces > ArtOfTest.WebAii.Win32.Dialogs > DialogButton
Possible buttons for to click for a dialog
Syntax
C#
public enum DialogButton
Members
Member | Description
OK | OK button.
CANCEL | Cancel button.
OPEN | Open button for the Upload dialog.
YES | Yes button.
NO | No button.
CLOSE | The window close button (X).
RUN | The run button of a File Download dialog (IE)
SAVE | The save button of a File Download dialog (SaveFile for Firefox)
NOTSET | Not using the default dismiss buttons


DialogCurrentState enumeration

DialogCurrentState enumeration
Namespaces > ArtOfTest.WebAii.Win32.Dialogs > DialogCurrentState
Different states the dialog can be set to.
Syntax
C#
public enum DialogCurrentState
Members
Member | Description
NotActive | The dialog is not active
ActivePendingHandling | The dialog was detected active and currently pending handling
Handled | The dialog was handled


DialogHandlerDelegate delegate

DialogHandlerDelegate delegate
Namespaces > ArtOfTest.WebAii.Win32.Dialogs > DialogHandlerDelegate
A dialog handler that allows for users to do their own handling of a dialog instead of calling Handle().
Syntax
C#
public delegate void DialogHandlerDelegate (
    IDialog dialog
)
Parameters
dialog (IDialog)
The dialog being handled.
Return Value
True/False whether the dialog has been handled.


DialogMonitor class

DialogMonitor class
Namespaces > ArtOfTest.WebAii.Win32.Dialogs > DialogMonitor
Class implementation for a dialog monitor to handle dialogs during execution.
Syntax
C#
public class DialogMonitor
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DialogMonitorNew() | Create a new DialogMonitor object and start the monitoring.
 | DialogMonitorNew(Boolean, Int32) | Create a new DialogMonitor object.
 | AddDialog(IDialog) | Add a dialog to be monitored.
 | Dialogs | Gets the collection of dialogs the monitor is monitoring.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetAllDialogs() | Returns a collection of all top level dialogs of the current desktop.
 | GetHashCode() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType() | Gets the Type of the current instance. (Inherited from Object.)
 | IsMonitoring | Gets whether the DialogMonitor object is currently monitoring dialogs or not.
 | MemberwiseClone() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | PollPeriod | Gets/Sets the time in milliseconds to wait between monitoring polls.
 | RemoveDialog(IDialog) | Remove a dialog from the list of dialogs to monitor.
 | Start() | Start dialog monitoring.
 | Stop() | Stop dialog monitoring.
 | ToString() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
DialogMonitor


AddDialog(dialog) method

DialogMonitor.AddDialog(dialog) method
Namespaces > ArtOfTest.WebAii.Win32.Dialogs > DialogMonitor > AddDialog(IDialog)
Add a dialog to be monitored.
Syntax
C#
public void AddDialog (
    IDialog dialog
)
Parameters
dialog (IDialog)
The dialog to add.


Constructors

DialogMonitor constructors
Namespaces > ArtOfTest.WebAii.Win32.Dialogs > DialogMonitor > DialogMonitorNew
Members
Icon | Member | Description
 | DialogMonitorNew() | Create a new DialogMonitor object and start the monitoring.
 | DialogMonitorNew(Boolean, Int32) | Create a new DialogMonitor object.


DialogMonitor() constructor

DialogMonitor() constructor
Namespaces > ArtOfTest.WebAii.Win32.Dialogs > DialogMonitor > DialogMonitorNew()
Create a new DialogMonitor object and start the monitoring.
Syntax
C#
public DialogMonitor ()


DialogMonitor(startMonitoring, pollPeriod) constructor

DialogMonitor(startMonitoring, pollPeriod) constructor
Namespaces > ArtOfTest.WebAii.Win32.Dialogs > DialogMonitor > DialogMonitorNew(Boolean, Int32)
Create a new DialogMonitor object.
Syntax
C#
public DialogMonitor (
    bool startMonitoring,
    int pollPeriod
)
Parameters
startMonitoring (Boolean)
Whether to start monitoring the dialogs. If false, monitoring can start by calling Start().
pollPeriod (Int32)
The time in milliseconds to wait between monitoring polls


Dialogs property

DialogMonitor.Dialogs property
Namespaces > ArtOfTest.WebAii.Win32.Dialogs > DialogMonitor > Dialogs
Gets the collection of dialogs the monitor is monitoring.
Syntax
C#
public ReadOnlyCollection<IDialog> Dialogs { get; }


GetAllDialogs() method

DialogMonitor.GetAllDialogs() method
Namespaces > ArtOfTest.WebAii.Win32.Dialogs > DialogMonitor > GetAllDialogs()
Returns a collection of all top level dialogs of the current desktop.
Syntax
C#
public static WindowCollection GetAllDialogs ()
Return Value
The collectin of dialogs.


IsMonitoring property

DialogMonitor.IsMonitoring property
Namespaces > ArtOfTest.WebAii.Win32.Dialogs > DialogMonitor > IsMonitoring
Gets whether the DialogMonitor object is currently monitoring dialogs or not.
Syntax
C#
public bool IsMonitoring { get; }


PollPeriod property

DialogMonitor.PollPeriod property
Namespaces > ArtOfTest.WebAii.Win32.Dialogs > DialogMonitor > PollPeriod
Gets/Sets the time in milliseconds to wait between monitoring polls.
Syntax
C#
public int PollPeriod { get; set; }


RemoveDialog(dialog) method

DialogMonitor.RemoveDialog(dialog) method
Namespaces > ArtOfTest.WebAii.Win32.Dialogs > DialogMonitor > RemoveDialog(IDialog)
Remove a dialog from the list of dialogs to monitor.
Syntax
C#
public void RemoveDialog (
    IDialog dialog
)
Parameters
dialog (IDialog)
The dialog to remove.


Start() method

DialogMonitor.Start() method
Namespaces > ArtOfTest.WebAii.Win32.Dialogs > DialogMonitor > Start()
Start dialog monitoring.
Syntax
C#
public void Start ()


Stop() method

DialogMonitor.Stop() method
Namespaces > ArtOfTest.WebAii.Win32.Dialogs > DialogMonitor > Stop()
Stop dialog monitoring.
Syntax
C#
public void Stop ()


DownloadDialogsHandler class

DownloadDialogsHandler class
Namespaces > ArtOfTest.WebAii.Win32.Dialogs > DownloadDialogsHandler
The download dialogs handler. Wraps all the download dialog sequences for IE/Firefox into a simple API call.
Syntax
C#
public class DownloadDialogsHandler
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DownloadDialogsHandlerNew(Browser, DialogButton, String, Desktop) | Create the dialog passing it the parent browser and the button to use to dismiss the instance of this dialog.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | SaveLocation | Gets/Sets the save location when doing a SAVE.
 | ToString() | Returns a String that represents the current Object. (Inherited from Object.)
 | WaitUntilHandled() | Wait until all dialogs handled. Uses the Settings.ClientReadyTimeout as the timeout.
 | WaitUntilHandled(Int32) | Wait until all dialogs are handled using the timeout passed in.
Inheritance Hierarchy
Object
DownloadDialogsHandler


DownloadDialogsHandler(parentBrowser, dismissButton, saveLocation, desktopObject) constructor

DownloadDialogsHandler(parentBrowser, dismissButton, saveLocation, desktopObject) constructor
Namespaces > ArtOfTest.WebAii.Win32.Dialogs > DownloadDialogsHandler > DownloadDialogsHandlerNew(Browser, DialogButton, String, Desktop)
Create the dialog passing it the parent browser and the button to use to dismiss the instance of this dialog.
Syntax
C#
public DownloadDialogsHandler (
    Browser parentBrowser,
    DialogButton dismissButton,
    string saveLocation,
    Desktop desktopObject
)
Parameters
parentBrowser (Browser)
The parent browser.
dismissButton (DialogButton)
The button to use to dismiss the dialog. Accepts: SAVE or CANCEL.
saveLocation (String)
The location to save the file if dismiss button is SAVE, else is ignored.
desktopObject (Desktop)
The desktop object.


SaveLocation property

DownloadDialogsHandler.SaveLocation property
Namespaces > ArtOfTest.WebAii.Win32.Dialogs > DownloadDialogsHandler > SaveLocation
Gets/Sets the save location when doing a SAVE.
Syntax
C#
public string SaveLocation { get; set; }


WaitUntilHandled methods

DownloadDialogsHandler.WaitUntilHandled methods
Namespaces > ArtOfTest.WebAii.Win32.Dialogs > DownloadDialogsHandler > WaitUntilHandled
Members
Icon | Member | Description
 | WaitUntilHandled() | Wait until all dialogs handled. Uses the Settings.ClientReadyTimeout as the timeout.
 | WaitUntilHandled(Int32) | Wait until all dialogs are handled using the timeout passed in.


WaitUntilHandled() method

DownloadDialogsHandler.WaitUntilHandled() method
Namespaces > ArtOfTest.WebAii.Win32.Dialogs > DownloadDialogsHandler > WaitUntilHandled()
Wait until all dialogs handled. Uses the Settings.ClientReadyTimeout as the timeout.
Syntax
C#
public void WaitUntilHandled ()


WaitUntilHandled(timeout) method

DownloadDialogsHandler.WaitUntilHandled(timeout) method
Namespaces > ArtOfTest.WebAii.Win32.Dialogs > DownloadDialogsHandler > WaitUntilHandled(Int32)
Wait until all dialogs are handled using the timeout passed in.
Syntax
C#
public void WaitUntilHandled (
    int timeout
)
Parameters
timeout (Int32)


FFOpenDownloadDialog class

FFOpenDownloadDialog class
Namespaces > ArtOfTest.WebAii.Win32.Dialogs > FFOpenDownloadDialog
Firefox OpenDialog.
Syntax
C#
public class FFOpenDownloadDialog : BaseDialog
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | FFOpenDownloadDialogNew(Browser, DialogButton, Desktop) | Create the dialog passing it the parent browser and the button to use to dismiss the instance of this dialog.
 | CurrentState | Gets/Sets the dialog current state. State is handled my DialogMonitor. (Inherited from BaseDialog.)
 | DismissButton | Gets/Sets the dismiss button to use to knock down this dialog. (Inherited from BaseDialog.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetProccessIdForWindow(Window) | Return the process id from a window handle. (Inherited from BaseDialog.)
 | GetType() | Gets the Type of the current instance. (Inherited from Object.)
 | Handle() | Handle this dialog. (Overrides BaseDialog.Handle().)
 | HandleCount | Gets/Sets the number of times this dialog has been handled. (Inherited from BaseDialog.)
 | HandlerDelegate | Gets/Sets the dialog custom handler (Inherited from BaseDialog.)
 | IsDialogActive(WindowCollection) | Whether the dialog is active or not. (Overrides BaseDialog.IsDialogActive(WindowCollection).)
 | IsDialogActiveByTitle(WindowCollection, String) | Get whether the dialog is active based on its title. (Inherited from BaseDialog.)
 | IsDialogActiveByTitle(WindowCollection, String, Boolean) | Get whether the dialog is active base on its title. (Inherited from BaseDialog.)
 | IsDialogActiveByTitleAndTextContent(WindowCollection, String, Boolean, String) | Gets whether a dialog is active or not using the title and caption of an inner window contained in the dialog (Inherited from BaseDialog.)
 | MemberwiseClone() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ParentBrowser | The parent browser object of this dialog (Inherited from BaseDialog.)
 | ParentProcessId | Parent process id of the browser and all the dialogs that this object should handle. (Inherited from BaseDialog.)
 | ResetHandleCount() | Resets the handle count back to zero. (Inherited from BaseDialog.)
 | SetDialogWindow(Window) | Set the dialog window. (Inherited from BaseDialog.)
 | ToString() | Returns a String that represents the current Object. (Inherited from Object.)
 | WaitUntilHandled(Int32) | Waits for the dialog to be handled atleast once. Always performs a reset at the being of the wait. (Inherited from BaseDialog.)
 | WaitUntilHandled(Int32, Int32, Boolean) | Waits for the dialog to be handled handleCount. You can optionally reset the handle count before waiting. (Inherited from BaseDialog.)
 | Window | The dialog Window object. (Inherited from BaseDialog.)
Inheritance Hierarchy
Object
 | BaseDialog
 |  | FFOpenDownloadDialog


FFOpenDownloadDialog(parentBrowser, dismissButton, desktopObject) constructor

FFOpenDownloadDialog(parentBrowser, dismissButton, desktopObject) constructor
Namespaces > ArtOfTest.WebAii.Win32.Dialogs > FFOpenDownloadDialog > FFOpenDownloadDialogNew(Browser, DialogButton, Desktop)
Create the dialog passing it the parent browser and the button to use to dismiss the instance of this dialog.
Syntax
C#
public FFOpenDownloadDialog (
    Browser parentBrowser,
    DialogButton dismissButton,
    Desktop desktopObject
)
Parameters
parentBrowser (Browser)
The parent browser.
dismissButton (DialogButton)
The button to use to dismiss the dialog. Accepts: SAVE, OPEN or CANCEL.
desktopObject (Desktop)
The desktop object to use for mouse events if needed.


Handle() method

FFOpenDownloadDialog.Handle() method
Namespaces > ArtOfTest.WebAii.Win32.Dialogs > FFOpenDownloadDialog > Handle()
Handle this dialog.
Syntax
C#
public override void Handle ()


IsDialogActive(dialogs) method

FFOpenDownloadDialog.IsDialogActive(dialogs) method
Namespaces > ArtOfTest.WebAii.Win32.Dialogs > FFOpenDownloadDialog > IsDialogActive(WindowCollection)
Whether the dialog is active or not.
Syntax
C#
public override bool IsDialogActive (
    WindowCollection dialogs
)
Parameters
dialogs (WindowCollection)
The list of dialogs to check.
Return Value
True/False whether the dialog is active.


FileUploadDialog class

FileUploadDialog class
Namespaces > ArtOfTest.WebAii.Win32.Dialogs > FileUploadDialog
Class to handle the FileUpload dialog.
Syntax
C#
public class FileUploadDialog : BaseDialog
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | FileUploadDialogNew(Browser, String, DialogButton) | Create a new FileUploadDialog.
 | CurrentState | Gets/Sets the dialog current state. State is handled my DialogMonitor. (Inherited from BaseDialog.)
 | DismissButton | Gets/Sets the dismiss button to use to knock down this dialog. (Inherited from BaseDialog.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | FilePath | Gets/Sets the file path to set for this dialog.
 | Finalize() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetProccessIdForWindow(Window) | Return the process id from a window handle. (Inherited from BaseDialog.)
 | GetType() | Gets the Type of the current instance. (Inherited from Object.)
 | Handle() | Handle the dialog. (Overrides BaseDialog.Handle().)
 | HandleCount | Gets/Sets the number of times this dialog has been handled. (Inherited from BaseDialog.)
 | HandlerDelegate | Gets/Sets the dialog custom handler (Inherited from BaseDialog.)
 | IsDialogActive(WindowCollection) | Is dialog active. (Overrides BaseDialog.IsDialogActive(WindowCollection).)
 | IsDialogActiveByTitle(WindowCollection, String) | Get whether the dialog is active based on its title. (Inherited from BaseDialog.)
 | IsDialogActiveByTitle(WindowCollection, String, Boolean) | Get whether the dialog is active base on its title. (Inherited from BaseDialog.)
 | IsDialogActiveByTitleAndTextContent(WindowCollection, String, Boolean, String) | Gets whether a dialog is active or not using the title and caption of an inner window contained in the dialog (Inherited from BaseDialog.)
 | MemberwiseClone() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ParentBrowser | The parent browser object of this dialog (Inherited from BaseDialog.)
 | ParentProcessId | Parent process id of the browser and all the dialogs that this object should handle. (Inherited from BaseDialog.)
 | ResetHandleCount() | Resets the handle count back to zero. (Inherited from BaseDialog.)
 | SetDialogWindow(Window) | Set the dialog window. (Inherited from BaseDialog.)
 | ToString() | Returns a String that represents the current Object. (Inherited from Object.)
 | WaitUntilHandled(Int32) | Waits for the dialog to be handled atleast once. Always performs a reset at the being of the wait. (Inherited from BaseDialog.)
 | WaitUntilHandled(Int32, Int32, Boolean) | Waits for the dialog to be handled handleCount. You can optionally reset the handle count before waiting. (Inherited from BaseDialog.)
 | Window | The dialog Window object. (Inherited from BaseDialog.)
Inheritance Hierarchy
Object
 | BaseDialog
 |  | FileUploadDialog


FilePath property

FileUploadDialog.FilePath property
Namespaces > ArtOfTest.WebAii.Win32.Dialogs > FileUploadDialog > FilePath
Gets/Sets the file path to set for this dialog.
Syntax
C#
public string FilePath { get; set; }


FileUploadDialog(parentBrowser, filePath, dismissButton) constructor

FileUploadDialog(parentBrowser, filePath, dismissButton) constructor
Namespaces > ArtOfTest.WebAii.Win32.Dialogs > FileUploadDialog > FileUploadDialogNew(Browser, String, DialogButton)
Create a new FileUploadDialog.
Syntax
C#
public FileUploadDialog (
    Browser parentBrowser,
    string filePath,
    DialogButton dismissButton
)
Parameters
parentBrowser (Browser)
The parent browser.
filePath (String)
The file path of the file to upload.
dismissButton (DialogButton)
The dismiss button to use to close the dialog.


Handle() method

FileUploadDialog.Handle() method
Namespaces > ArtOfTest.WebAii.Win32.Dialogs > FileUploadDialog > Handle()
Handle the dialog.
Syntax
C#
public override void Handle ()


IsDialogActive(dialogs) method

FileUploadDialog.IsDialogActive(dialogs) method
Namespaces > ArtOfTest.WebAii.Win32.Dialogs > FileUploadDialog > IsDialogActive(WindowCollection)
Is dialog active.
Syntax
C#
public override bool IsDialogActive (
    WindowCollection dialogs
)
Parameters
dialogs (WindowCollection)
The list of dialogs
Return Value
True/False whether the dialog is active or not.


GenericDialog class

GenericDialog class
Namespaces > ArtOfTest.WebAii.Win32.Dialogs > GenericDialog
A generic dialog handler that can be used for quick and easy way to write a dialog handler for a simply dialog.
Syntax
C#
public class GenericDialog : BaseDialog
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GenericDialogNew(Browser, String, Boolean) | Create a new generic dialog.
 | GenericDialogNew(Browser, String, Boolean, Int32) | Create a new generic dialog
 | GenericDialogNew(Browser, String, Boolean, Int32, String) | Create a new generic dialog
 | GenericDialogNew(Browser, String, Boolean, String) | Create a new generic dialog.
 | GenericDialogNew(Browser, String, Boolean, String, String) | Create a new generic dialog.
 | GenericDialogNew(Browser, String, String, Boolean) | Create a new generic dialog.
 | ButtonId | Gets/Sets the button id to click.
 | ButtonText | Gets/Sets the button text to click.
 | ChildTextContext | Gets/Sets the child text of a child window of this dialog.
 | CurrentState | Gets/Sets the dialog current state. State is handled my DialogMonitor. (Inherited from BaseDialog.)
 | DismissButton | Gets/Sets the dismiss button to use to knock down this dialog. (Inherited from BaseDialog.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetProccessIdForWindow(Window) | Return the process id from a window handle. (Inherited from BaseDialog.)
 | GetType() | Gets the Type of the current instance. (Inherited from Object.)
 | Handle() | Handle this generic dialog (Overrides BaseDialog.Handle().)
 | HandleCount | Gets/Sets the number of times this dialog has been handled. (Inherited from BaseDialog.)
 | HandlerDelegate | Gets/Sets the dialog custom handler (Inherited from BaseDialog.)
 | IsDialogActive(WindowCollection) | If dialog is active. (Overrides BaseDialog.IsDialogActive(WindowCollection).)
 | IsDialogActiveByTitle(WindowCollection, String) | Get whether the dialog is active based on its title. (Inherited from BaseDialog.)
 | IsDialogActiveByTitle(WindowCollection, String, Boolean) | Get whether the dialog is active base on its title. (Inherited from BaseDialog.)
 | IsDialogActiveByTitleAndTextContent(WindowCollection, String, Boolean, String) | Gets whether a dialog is active or not using the title and caption of an inner window contained in the dialog (Inherited from BaseDialog.)
 | MemberwiseClone() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ParentBrowser | The parent browser object of this dialog (Inherited from BaseDialog.)
 | ParentProcessId | Parent process id of the browser and all the dialogs that this object should handle. (Inherited from BaseDialog.)
 | PartialTitle | Gets/Sets whether the title is partial title.
 | ResetHandleCount() | Resets the handle count back to zero. (Inherited from BaseDialog.)
 | SetDialogWindow(Window) | Set the dialog window. (Inherited from BaseDialog.)
 | Title | Gets/Sets the title of this dialog.
 | ToString() | Returns a String that represents the current Object. (Inherited from Object.)
 | WaitUntilHandled(Int32) | Waits for the dialog to be handled atleast once. Always performs a reset at the being of the wait. (Inherited from BaseDialog.)
 | WaitUntilHandled(Int32, Int32, Boolean) | Waits for the dialog to be handled handleCount. You can optionally reset the handle count before waiting. (Inherited from BaseDialog.)
 | Window | The dialog Window object. (Inherited from BaseDialog.)
Inheritance Hierarchy
Object
 | BaseDialog
 |  | GenericDialog


ButtonId property

GenericDialog.ButtonId property
Namespaces > ArtOfTest.WebAii.Win32.Dialogs > GenericDialog > ButtonId
Gets/Sets the button id to click.
Syntax
C#
public int ButtonId { get; set; }


ButtonText property

GenericDialog.ButtonText property
Namespaces > ArtOfTest.WebAii.Win32.Dialogs > GenericDialog > ButtonText
Gets/Sets the button text to click.
Syntax
C#
public string ButtonText { get; set; }


ChildTextContext property

GenericDialog.ChildTextContext property
Namespaces > ArtOfTest.WebAii.Win32.Dialogs > GenericDialog > ChildTextContext
Gets/Sets the child text of a child window of this dialog.
Syntax
C#
public string ChildTextContext { get; set; }


Constructors

GenericDialog constructors
Namespaces > ArtOfTest.WebAii.Win32.Dialogs > GenericDialog > GenericDialogNew
Members
Icon | Member | Description
 | GenericDialogNew(Browser, String, Boolean) | Create a new generic dialog.
 | GenericDialogNew(Browser, String, Boolean, Int32) | Create a new generic dialog
 | GenericDialogNew(Browser, String, Boolean, Int32, String) | Create a new generic dialog
 | GenericDialogNew(Browser, String, Boolean, String) | Create a new generic dialog.
 | GenericDialogNew(Browser, String, Boolean, String, String) | Create a new generic dialog.
 | GenericDialogNew(Browser, String, String, Boolean) | Create a new generic dialog.


GenericDialog(parentBrowser, title, buttonText, partialTitle) constructor

GenericDialog(parentBrowser, title, buttonText, partialTitle) constructor
Namespaces > ArtOfTest.WebAii.Win32.Dialogs > GenericDialog > GenericDialogNew(Browser, String, String, Boolean)
Create a new generic dialog.
Syntax
C#
public GenericDialog (
    Browser parentBrowser,
    string title,
    string buttonText,
    bool partialTitle
)
Parameters
parentBrowser (Browser)
The parent browser.
title (String)
The title of the dialog.
buttonText (String)
The button caption to click.
partialTitle (Boolean)
Whether the title provided is partial or complete.


GenericDialog(parentBrowser, title, partialTitle) constructor

GenericDialog(parentBrowser, title, partialTitle) constructor
Namespaces > ArtOfTest.WebAii.Win32.Dialogs > GenericDialog > GenericDialogNew(Browser, String, Boolean)
Create a new generic dialog.
Syntax
C#
public GenericDialog (
    Browser parentBrowser,
    string title,
    bool partialTitle
)
Parameters
parentBrowser (Browser)
The parent browser.
title (String)
The title of the dialog to handle.
partialTitle (Boolean)
Whether the title provided is partial or complete.
Remarks
Will simply close this dialog.


GenericDialog(parentBrowser, title, partialTitle, buttonId) constructor

GenericDialog(parentBrowser, title, partialTitle, buttonId) constructor
Namespaces > ArtOfTest.WebAii.Win32.Dialogs > GenericDialog > GenericDialogNew(Browser, String, Boolean, Int32)
Create a new generic dialog
Syntax
C#
public GenericDialog (
    Browser parentBrowser,
    string title,
    bool partialTitle,
    int buttonId
)
Parameters
parentBrowser (Browser)
The parent browser.
title (String)
The title of the dialog.
partialTitle (Boolean)
Whether the title provided is partial or complete.
buttonId (Int32)
The button id to click on the dialog.


GenericDialog(parentBrowser, title, partialTitle, buttonId, childTextContent) constructor

GenericDialog(parentBrowser, title, partialTitle, buttonId, childTextContent) constructor
Namespaces > ArtOfTest.WebAii.Win32.Dialogs > GenericDialog > GenericDialogNew(Browser, String, Boolean, Int32, String)
Create a new generic dialog
Syntax
C#
public GenericDialog (
    Browser parentBrowser,
    string title,
    bool partialTitle,
    int buttonId,
    string childTextContent
)
Parameters
parentBrowser (Browser)
The parent browser.
title (String)
The title of the dialog.
partialTitle (Boolean)
Whether the title provided is partial or complete.
buttonId (Int32)
The button id to click on the dialog.
childTextContent (String)
A partial text that might be found on that dialog. This can help isolate this dialog from other dialogs that might have similar titles.


GenericDialog(parentBrowser, title, partialTitle, buttonText, childTextContent) constructor

GenericDialog(parentBrowser, title, partialTitle, buttonText, childTextContent) constructor
Namespaces > ArtOfTest.WebAii.Win32.Dialogs > GenericDialog > GenericDialogNew(Browser, String, Boolean, String, String)
Create a new generic dialog.
Syntax
C#
public GenericDialog (
    Browser parentBrowser,
    string title,
    bool partialTitle,
    string buttonText,
    string childTextContent
)
Parameters
parentBrowser (Browser)
The parent browser.
title (String)
The title of the dialog.
partialTitle (Boolean)
Whether the title provided is partial or complete.
buttonText (String)
The button caption to click.
childTextContent (String)
A partial text that might be found on that dialog. This can help isolate this dialog from other dialogs that might have similar titles.


GenericDialog(parentBrowser, title, partialTitle, childTextContent) constructor

GenericDialog(parentBrowser, title, partialTitle, childTextContent) constructor
Namespaces > ArtOfTest.WebAii.Win32.Dialogs > GenericDialog > GenericDialogNew(Browser, String, Boolean, String)
Create a new generic dialog.
Syntax
C#
public GenericDialog (
    Browser parentBrowser,
    string title,
    bool partialTitle,
    string childTextContent
)
Parameters
parentBrowser (Browser)
The parent browser.
title (String)
The title of the dialog to handle.
partialTitle (Boolean)
Whether the title provided is partial or complete.
childTextContent (String)
A partial text that might be found on that dialog. This can help isolate this dialog from other dialogs that might have similar titles.


Handle() method

GenericDialog.Handle() method
Namespaces > ArtOfTest.WebAii.Win32.Dialogs > GenericDialog > Handle()
Handle this generic dialog
Syntax
C#
public override void Handle ()
Return Value


IsDialogActive(dialogs) method

GenericDialog.IsDialogActive(dialogs) method
Namespaces > ArtOfTest.WebAii.Win32.Dialogs > GenericDialog > IsDialogActive(WindowCollection)
If dialog is active.
Syntax
C#
public override bool IsDialogActive (
    WindowCollection dialogs
)
Parameters
dialogs (WindowCollection)
The list of all dialogs
Return Value
True/False if the dialog is active.


PartialTitle property

GenericDialog.PartialTitle property
Namespaces > ArtOfTest.WebAii.Win32.Dialogs > GenericDialog > PartialTitle
Gets/Sets whether the title is partial title.
Syntax
C#
public bool PartialTitle { get; set; }


Title property

GenericDialog.Title property
Namespaces > ArtOfTest.WebAii.Win32.Dialogs > GenericDialog > Title
Gets/Sets the title of this dialog.
Syntax
C#
public string Title { get; set; }


IDialog interface

IDialog interface
Namespaces > ArtOfTest.WebAii.Win32.Dialogs > IDialog
Interface to implement for dialogs to be monitored and handled by the DialogMonitor object.
Syntax
C#
public interface IDialog
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CurrentState | The dialogs current state. This property is Managed by the dialog monitor. Implementors should simply provide a private field to store this value for get/set operations.
 | Handle() | If a HandlerDelegate is set, this function should call the delegate, otherwise handle the dialog itself.
 | HandleCount | Gets/Sets the number of times this dialog has been handled.
 | HandlerDelegate | Gets/Sets a dialog handler delegate that will be used instead of the Handle() function.
 | IsDialogActive(WindowCollection) | Whether the dialog is active or not.
 | Window | The Window object that represents this dialog. IsDialogActive() should set this property if it is returning true.


CurrentState property

IDialog.CurrentState property
Namespaces > ArtOfTest.WebAii.Win32.Dialogs > IDialog > CurrentState
The dialogs current state. This property is Managed by the dialog monitor. Implementors should simply provide a private field to store this value for get/set operations.
Syntax
C#
DialogCurrentState CurrentState { get; set; }


Handle() method

IDialog.Handle() method
Namespaces > ArtOfTest.WebAii.Win32.Dialogs > IDialog > Handle()
If a HandlerDelegate is set, this function should call the delegate, otherwise handle the dialog itself.
Syntax
C#
void Handle ()


HandleCount property

IDialog.HandleCount property
Namespaces > ArtOfTest.WebAii.Win32.Dialogs > IDialog > HandleCount
Gets/Sets the number of times this dialog has been handled.
Syntax
C#
int HandleCount { get; set; }


HandlerDelegate property

IDialog.HandlerDelegate property
Namespaces > ArtOfTest.WebAii.Win32.Dialogs > IDialog > HandlerDelegate
Gets/Sets a dialog handler delegate that will be used instead of the Handle() function.
Syntax
C#
DialogHandlerDelegate HandlerDelegate { get; set; }


IsDialogActive(dialogs) method

IDialog.IsDialogActive(dialogs) method
Namespaces > ArtOfTest.WebAii.Win32.Dialogs > IDialog > IsDialogActive(WindowCollection)
Whether the dialog is active or not.
Syntax
C#
bool IsDialogActive (
    WindowCollection dialogs
)
Parameters
dialogs (WindowCollection)
The list of dialogs present on the desktop.
Return Value
True/False whether the dialog is active/present.


Window property

IDialog.Window property
Namespaces > ArtOfTest.WebAii.Win32.Dialogs > IDialog > Window
The Window object that represents this dialog. IsDialogActive() should set this property if it is returning true.
Syntax
C#
Window Window { get; }


IEDownloadCompleteDialog class

IEDownloadCompleteDialog class
Namespaces > ArtOfTest.WebAii.Win32.Dialogs > IEDownloadCompleteDialog
The IE download complete dialog.
Syntax
C#
public class IEDownloadCompleteDialog : BaseDialog
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | IEDownloadCompleteDialogNew(Browser, DialogButton, Desktop) | Create the dialog passing it the parent browser and the button to use to dismiss the instance of this dialog.
 | CurrentState | Gets/Sets the dialog current state. State is handled my DialogMonitor. (Inherited from BaseDialog.)
 | DismissButton | Gets/Sets the dismiss button to use to knock down this dialog. (Inherited from BaseDialog.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetProccessIdForWindow(Window) | Return the process id from a window handle. (Inherited from BaseDialog.)
 | GetType() | Gets the Type of the current instance. (Inherited from Object.)
 | Handle() | This is called by the DialogMonitor whenever IsDialogActive returns true. (Overrides BaseDialog.Handle().)
 | HandleCount | Gets/Sets the number of times this dialog has been handled. (Inherited from BaseDialog.)
 | HandlerDelegate | Gets/Sets the dialog custom handler (Inherited from BaseDialog.)
 | IsDialogActive(WindowCollection) | Check whether the dialog is present or not. This function is called by the dialogmonitor object (Overrides BaseDialog.IsDialogActive(WindowCollection).)
 | IsDialogActiveByTitle(WindowCollection, String) | Get whether the dialog is active based on its title. (Inherited from BaseDialog.)
 | IsDialogActiveByTitle(WindowCollection, String, Boolean) | Get whether the dialog is active base on its title. (Inherited from BaseDialog.)
 | IsDialogActiveByTitleAndTextContent(WindowCollection, String, Boolean, String) | Gets whether a dialog is active or not using the title and caption of an inner window contained in the dialog (Inherited from BaseDialog.)
 | MemberwiseClone() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ParentBrowser | The parent browser object of this dialog (Inherited from BaseDialog.)
 | ParentProcessId | Parent process id of the browser and all the dialogs that this object should handle. (Inherited from BaseDialog.)
 | ResetHandleCount() | Resets the handle count back to zero. (Inherited from BaseDialog.)
 | SetDialogWindow(Window) | Set the dialog window. (Inherited from BaseDialog.)
 | ToString() | Returns a String that represents the current Object. (Inherited from Object.)
 | WaitUntilHandled(Int32) | Waits for the dialog to be handled atleast once. Always performs a reset at the being of the wait. (Inherited from BaseDialog.)
 | WaitUntilHandled(Int32, Int32, Boolean) | Waits for the dialog to be handled handleCount. You can optionally reset the handle count before waiting. (Inherited from BaseDialog.)
 | Window | The dialog Window object. (Inherited from BaseDialog.)
Inheritance Hierarchy
Object
 | BaseDialog
 |  | IEDownloadCompleteDialog


Handle() method

IEDownloadCompleteDialog.Handle() method
Namespaces > ArtOfTest.WebAii.Win32.Dialogs > IEDownloadCompleteDialog > Handle()
This is called by the DialogMonitor whenever IsDialogActive returns true.
Syntax
C#
public override void Handle ()


IEDownloadCompleteDialog(parentBrowser, dismissButton, desktopObject) constructor

IEDownloadCompleteDialog(parentBrowser, dismissButton, desktopObject) constructor
Namespaces > ArtOfTest.WebAii.Win32.Dialogs > IEDownloadCompleteDialog > IEDownloadCompleteDialogNew(Browser, DialogButton, Desktop)
Create the dialog passing it the parent browser and the button to use to dismiss the instance of this dialog.
Syntax
C#
public IEDownloadCompleteDialog (
    Browser parentBrowser,
    DialogButton dismissButton,
    Desktop desktopObject
)
Parameters
parentBrowser (Browser)
The parent browser.
dismissButton (DialogButton)
The button to use to dismiss the dialog. Accepts: RUN, OPEN or CLOSE.
desktopObject (Desktop)
The desktop object to use to invoke mouse/keyboard events.


IsDialogActive(dialogs) method

IEDownloadCompleteDialog.IsDialogActive(dialogs) method
Namespaces > ArtOfTest.WebAii.Win32.Dialogs > IEDownloadCompleteDialog > IsDialogActive(WindowCollection)
Check whether the dialog is present or not. This function is called by the dialogmonitor object
Syntax
C#
public override bool IsDialogActive (
    WindowCollection dialogs
)
Parameters
dialogs (WindowCollection)
This is a list of dialog passes in the by the DialogMonitor object.
Return Value
True/False whether this dialog is present.


IEDownloadDialog class

IEDownloadDialog class
Namespaces > ArtOfTest.WebAii.Win32.Dialogs > IEDownloadDialog
IE's initiali download dialog.
Syntax
C#
public class IEDownloadDialog : BaseDialog
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | IEDownloadDialogNew(Browser, DialogButton, Desktop) | Create the dialog passing it the parent browser and the button to use to dismiss the instance of this dialog.
 | CurrentState | Gets/Sets the dialog current state. State is handled my DialogMonitor. (Inherited from BaseDialog.)
 | DismissButton | Gets/Sets the dismiss button to use to knock down this dialog. (Inherited from BaseDialog.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetProccessIdForWindow(Window) | Return the process id from a window handle. (Inherited from BaseDialog.)
 | GetType() | Gets the Type of the current instance. (Inherited from Object.)
 | Handle() | This is called by the DialogMonitor whenever IsDialogActive returns true. (Overrides BaseDialog.Handle().)
 | HandleCount | Gets/Sets the number of times this dialog has been handled. (Inherited from BaseDialog.)
 | HandlerDelegate | Gets/Sets the dialog custom handler (Inherited from BaseDialog.)
 | IsDialogActive(WindowCollection) | Check whether the dialog is present or not. This function is called by the dialogmonitor object (Overrides BaseDialog.IsDialogActive(WindowCollection).)
 | IsDialogActiveByTitle(WindowCollection, String) | Get whether the dialog is active based on its title. (Inherited from BaseDialog.)
 | IsDialogActiveByTitle(WindowCollection, String, Boolean) | Get whether the dialog is active base on its title. (Inherited from BaseDialog.)
 | IsDialogActiveByTitleAndTextContent(WindowCollection, String, Boolean, String) | Gets whether a dialog is active or not using the title and caption of an inner window contained in the dialog (Inherited from BaseDialog.)
 | MemberwiseClone() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ParentBrowser | The parent browser object of this dialog (Inherited from BaseDialog.)
 | ParentProcessId | Parent process id of the browser and all the dialogs that this object should handle. (Inherited from BaseDialog.)
 | ResetHandleCount() | Resets the handle count back to zero. (Inherited from BaseDialog.)
 | SetDialogWindow(Window) | Set the dialog window. (Inherited from BaseDialog.)
 | ToString() | Returns a String that represents the current Object. (Inherited from Object.)
 | WaitUntilHandled(Int32) | Waits for the dialog to be handled atleast once. Always performs a reset at the being of the wait. (Inherited from BaseDialog.)
 | WaitUntilHandled(Int32, Int32, Boolean) | Waits for the dialog to be handled handleCount. You can optionally reset the handle count before waiting. (Inherited from BaseDialog.)
 | Window | The dialog Window object. (Inherited from BaseDialog.)
Inheritance Hierarchy
Object
 | BaseDialog
 |  | IEDownloadDialog


Handle() method

IEDownloadDialog.Handle() method
Namespaces > ArtOfTest.WebAii.Win32.Dialogs > IEDownloadDialog > Handle()
This is called by the DialogMonitor whenever IsDialogActive returns true.
Syntax
C#
public override void Handle ()


IEDownloadDialog(parentBrowser, dismissButton, desktop) constructor

IEDownloadDialog(parentBrowser, dismissButton, desktop) constructor
Namespaces > ArtOfTest.WebAii.Win32.Dialogs > IEDownloadDialog > IEDownloadDialogNew(Browser, DialogButton, Desktop)
Create the dialog passing it the parent browser and the button to use to dismiss the instance of this dialog.
Syntax
C#
public IEDownloadDialog (
    Browser parentBrowser,
    DialogButton dismissButton,
    Desktop desktop
)
Parameters
parentBrowser (Browser)
The parent browser.
dismissButton (DialogButton)
The button to use to dismiss the dialog. Accepts: RUN, CANCEL, SAVE or OPEN.
desktop (Desktop)
The desktop object.


IsDialogActive(dialogs) method

IEDownloadDialog.IsDialogActive(dialogs) method
Namespaces > ArtOfTest.WebAii.Win32.Dialogs > IEDownloadDialog > IsDialogActive(WindowCollection)
Check whether the dialog is present or not. This function is called by the dialogmonitor object
Syntax
C#
public override bool IsDialogActive (
    WindowCollection dialogs
)
Parameters
dialogs (WindowCollection)
This is a list of dialog passes in the by the DialogMonitor object.
Return Value
True/False whether this dialog is present.


LogonDialog class

LogonDialog class
Namespaces > ArtOfTest.WebAii.Win32.Dialogs > LogonDialog
Class to handle the logon dialog (username/password)
Syntax
C#
public class LogonDialog : BaseDialog
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LogonDialogNew(Browser, String, String, DialogButton) | Create a new LogonDialog handler.
 | CurrentState | Gets/Sets the dialog current state. State is handled my DialogMonitor. (Inherited from BaseDialog.)
 | DismissButton | Gets/Sets the dismiss button to use to knock down this dialog. (Inherited from BaseDialog.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetProccessIdForWindow(Window) | Return the process id from a window handle. (Inherited from BaseDialog.)
 | GetType() | Gets the Type of the current instance. (Inherited from Object.)
 | Handle() | Handle this dialog. (Overrides BaseDialog.Handle().)
 | HandleCount | Gets/Sets the number of times this dialog has been handled. (Inherited from BaseDialog.)
 | HandlerDelegate | Gets/Sets the dialog custom handler (Inherited from BaseDialog.)
 | IsDialogActive(WindowCollection) | Whether this dialog is active or not. (Overrides BaseDialog.IsDialogActive(WindowCollection).)
 | IsDialogActiveByTitle(WindowCollection, String) | Get whether the dialog is active based on its title. (Inherited from BaseDialog.)
 | IsDialogActiveByTitle(WindowCollection, String, Boolean) | Get whether the dialog is active base on its title. (Inherited from BaseDialog.)
 | IsDialogActiveByTitleAndTextContent(WindowCollection, String, Boolean, String) | Gets whether a dialog is active or not using the title and caption of an inner window contained in the dialog (Inherited from BaseDialog.)
 | MemberwiseClone() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ParentBrowser | The parent browser object of this dialog (Inherited from BaseDialog.)
 | ParentProcessId | Parent process id of the browser and all the dialogs that this object should handle. (Inherited from BaseDialog.)
 | Password | Gets/Sets Password
 | ResetHandleCount() | Resets the handle count back to zero. (Inherited from BaseDialog.)
 | SetDialogWindow(Window) | Set the dialog window. (Inherited from BaseDialog.)
 | ToString() | Returns a String that represents the current Object. (Inherited from Object.)
 | UserName | Gets/Sets UserName
 | WaitUntilHandled(Int32) | Waits for the dialog to be handled atleast once. Always performs a reset at the being of the wait. (Inherited from BaseDialog.)
 | WaitUntilHandled(Int32, Int32, Boolean) | Waits for the dialog to be handled handleCount. You can optionally reset the handle count before waiting. (Inherited from BaseDialog.)
 | Window | The dialog Window object. (Inherited from BaseDialog.)
Inheritance Hierarchy
Object
 | BaseDialog
 |  | LogonDialog


Handle() method

LogonDialog.Handle() method
Namespaces > ArtOfTest.WebAii.Win32.Dialogs > LogonDialog > Handle()
Handle this dialog.
Syntax
C#
public override void Handle ()


IsDialogActive(dialogs) method

LogonDialog.IsDialogActive(dialogs) method
Namespaces > ArtOfTest.WebAii.Win32.Dialogs > LogonDialog > IsDialogActive(WindowCollection)
Whether this dialog is active or not.
Syntax
C#
public override bool IsDialogActive (
    WindowCollection dialogs
)
Parameters
dialogs (WindowCollection)
The list of dialogs to check.
Return Value
True/False whether this dialog is active or not.


LogonDialog(parentBrowser, userName, password, dismissButton) constructor

LogonDialog(parentBrowser, userName, password, dismissButton) constructor
Namespaces > ArtOfTest.WebAii.Win32.Dialogs > LogonDialog > LogonDialogNew(Browser, String, String, DialogButton)
Create a new LogonDialog handler.
Syntax
C#
public LogonDialog (
    Browser parentBrowser,
    string userName,
    string password,
    DialogButton dismissButton
)
Parameters
parentBrowser (Browser)
The parent browser.
userName (String)
The username to set.
password (String)
The password to set.
dismissButton (DialogButton)
The button to use to dismiss this dialog.


Password property

LogonDialog.Password property
Namespaces > ArtOfTest.WebAii.Win32.Dialogs > LogonDialog > Password
Gets/Sets Password
Syntax
C#
public string Password { get; set; }


UserName property

LogonDialog.UserName property
Namespaces > ArtOfTest.WebAii.Win32.Dialogs > LogonDialog > UserName
Gets/Sets UserName
Syntax
C#
public string UserName { get; set; }


SaveAsDialog class

SaveAsDialog class
Namespaces > ArtOfTest.WebAii.Win32.Dialogs > SaveAsDialog
SaveAs Dialog handler.
Syntax
C#
public class SaveAsDialog : BaseDialog
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SaveAsDialogNew(Browser, DialogButton, String, Desktop) | Create the dialog passing it the parent browser and the button to use to dismiss the instance of this dialog.
 | CurrentState | Gets/Sets the dialog current state. State is handled my DialogMonitor. (Inherited from BaseDialog.)
 | DismissButton | Gets/Sets the dismiss button to use to knock down this dialog. (Inherited from BaseDialog.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetProccessIdForWindow(Window) | Return the process id from a window handle. (Inherited from BaseDialog.)
 | GetType() | Gets the Type of the current instance. (Inherited from Object.)
 | Handle() | This is called by the DialogMonitor whenever IsDialogActive returns true. (Overrides BaseDialog.Handle().)
 | HandleCount | Gets/Sets the number of times this dialog has been handled. (Inherited from BaseDialog.)
 | HandlerDelegate | Gets/Sets the dialog custom handler (Inherited from BaseDialog.)
 | IsDialogActive(WindowCollection) | Check whether the dialog is present or not. This function is called by the dialogmonitor object (Overrides BaseDialog.IsDialogActive(WindowCollection).)
 | IsDialogActiveByTitle(WindowCollection, String) | Get whether the dialog is active based on its title. (Inherited from BaseDialog.)
 | IsDialogActiveByTitle(WindowCollection, String, Boolean) | Get whether the dialog is active base on its title. (Inherited from BaseDialog.)
 | IsDialogActiveByTitleAndTextContent(WindowCollection, String, Boolean, String) | Gets whether a dialog is active or not using the title and caption of an inner window contained in the dialog (Inherited from BaseDialog.)
 | MemberwiseClone() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ParentBrowser | The parent browser object of this dialog (Inherited from BaseDialog.)
 | ParentProcessId | Parent process id of the browser and all the dialogs that this object should handle. (Inherited from BaseDialog.)
 | ResetHandleCount() | Resets the handle count back to zero. (Inherited from BaseDialog.)
 | SaveFileName | Gets/Sets the save file name/path to use if you are saving the file. Else set to string.empty.
 | SetDialogWindow(Window) | Set the dialog window. (Inherited from BaseDialog.)
 | ToString() | Returns a String that represents the current Object. (Inherited from Object.)
 | WaitUntilHandled(Int32) | Waits for the dialog to be handled atleast once. Always performs a reset at the being of the wait. (Inherited from BaseDialog.)
 | WaitUntilHandled(Int32, Int32, Boolean) | Waits for the dialog to be handled handleCount. You can optionally reset the handle count before waiting. (Inherited from BaseDialog.)
 | Window | The dialog Window object. (Inherited from BaseDialog.)
Inheritance Hierarchy
Object
 | BaseDialog
 |  | SaveAsDialog


Handle() method

SaveAsDialog.Handle() method
Namespaces > ArtOfTest.WebAii.Win32.Dialogs > SaveAsDialog > Handle()
This is called by the DialogMonitor whenever IsDialogActive returns true.
Syntax
C#
public override void Handle ()


IsDialogActive(dialogs) method

SaveAsDialog.IsDialogActive(dialogs) method
Namespaces > ArtOfTest.WebAii.Win32.Dialogs > SaveAsDialog > IsDialogActive(WindowCollection)
Check whether the dialog is present or not. This function is called by the dialogmonitor object
Syntax
C#
public override bool IsDialogActive (
    WindowCollection dialogs
)
Parameters
dialogs (WindowCollection)
This is a list of dialog passes in the by the DialogMonitor object.
Return Value
True/False whether this dialog is present.


SaveAsDialog(parentBrowser, dismissButton, fileName, desktopObject) constructor

SaveAsDialog(parentBrowser, dismissButton, fileName, desktopObject) constructor
Namespaces > ArtOfTest.WebAii.Win32.Dialogs > SaveAsDialog > SaveAsDialogNew(Browser, DialogButton, String, Desktop)
Create the dialog passing it the parent browser and the button to use to dismiss the instance of this dialog.
Syntax
C#
public SaveAsDialog (
    Browser parentBrowser,
    DialogButton dismissButton,
    string fileName,
    Desktop desktopObject
)
Parameters
parentBrowser (Browser)
The parent browser.
dismissButton (DialogButton)
The button to use to dismiss the dialog. Accepts SAVE or CANCEL.
fileName (String)
The full file path to the save location.
desktopObject (Desktop)
The desktop object.


SaveFileName property

SaveAsDialog.SaveFileName property
Namespaces > ArtOfTest.WebAii.Win32.Dialogs > SaveAsDialog > SaveFileName
Gets/Sets the save file name/path to use if you are saving the file. Else set to string.empty.
Syntax
C#
public string SaveFileName { get; set; }


Namespaces

Namespaces overview
Namespaces
Namespaces
Namespace | Description
ArtOfTest.WebAii.BrowserSpecialized.AspNetHost |
ArtOfTest.WebAii.BrowserSpecialized.Firefox |
ArtOfTest.WebAii.BrowserSpecialized.InternetExplorer |
ArtOfTest.WebAii.Controls |
ArtOfTest.WebAii.Controls.HtmlControls |
ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts |
ArtOfTest.WebAii.Core |
ArtOfTest.WebAii.EventsArgs |
ArtOfTest.WebAii.Exceptions |
ArtOfTest.WebAii.Exceptions.ErrorData |
ArtOfTest.WebAii.Messaging.Process |
ArtOfTest.WebAii.ObjectModel |
ArtOfTest.WebAii.ObjectModel.Plugins |
ArtOfTest.WebAii.Synchronization |
ArtOfTest.WebAii.TestAttributes |
ArtOfTest.WebAii.TestTemplates |
ArtOfTest.WebAii.WebServers.AspNetHost |
ArtOfTest.WebAii.Win32 |
ArtOfTest.WebAii.Win32.Dialogs |


ScrollToVisible methods

AspNetHostActions.ScrollToVisible methods
Namespaces > ArtOfTest.WebAii.BrowserSpecialized.AspNetHost > AspNetHostActions > ScrollToVisible
Members
Icon | Member | Description
 | ScrollToVisible(Element) | Unsupported - Does not apply for this browser. (Overrides Actions.ScrollToVisible(Element).)
 | ScrollToVisible(Element, ScrollToVisibleType) | Ensures that an item is visible in the browser. Scrolls it into view.


ExecuteCommand methods

AspNetHostBrowser.ExecuteCommand methods
Namespaces > ArtOfTest.WebAii.BrowserSpecialized.AspNetHost > AspNetHostBrowser > ExecuteCommand
Members
Icon | Member | Description
 | ExecuteCommand(BrowserCommand, Boolean, Boolean) | Unsupported - All commands are executed in-proc. (Overrides Browser.ExecuteCommand(BrowserCommand, Boolean, Boolean).)
 | ExecuteCommand(BrowserCommand) | Executes a command against this browser instance.


NavigateTo methods

AspNetHostBrowser.NavigateTo methods
Namespaces > ArtOfTest.WebAii.BrowserSpecialized.AspNetHost > AspNetHostBrowser > NavigateTo
Members
Icon | Member | Description
 | NavigateTo(Uri) | Navigate to a certain relative Url. (Overrides Browser.NavigateTo(Uri).)
 | NavigateTo(String) | Navigate the browser to a specific url and then enable the script logging.


ForExists methods

HtmlWait.ForExists methods
Namespaces > ArtOfTest.WebAii.Controls.HtmlControls > HtmlWait > ForExists
Members
Icon | Member | Description
 | ForExists(Int32, Boolean) | Protected exists. [Control the control refresh] (Overrides Wait.ForExists(Int32, Boolean).)
 | ForExists(Int32) | Wait for this element to exist in the DOM.